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A Message from Larry Weinberg

In the 1980’s, my secret ambition was to become an illustrator, 
to draw like the great old masters. But something was lacking 
in my brain that kept me from being able to visualize my 
characters’ complex poses. I knew what I wanted to draw, and 
I knew what was great when I saw it, but starting from a blank 
page just never worked. I dropped into my local art supply 
shop and bought one of those little wooden mannequins that 
I thought would be my friend. He wasn’t very nice to me and 
never did what I asked of him. I quickly became determined to 
put him out of a job and thus set out to build the world a better 
mannequin. At the time, I was programming and animating in 
Hollywood, mostly for Rhythm and Hues Studios. I had built up 
a wealth of 3D math and computer graphics knowledge. Why not 
make a digital mannequin? So, while giving life to flaming match 
characters, Mr. Peanut, and billowing sheets of fabric softener 
during my day job, I began creating Poser at night.

All I wanted was a simple visualization tool, one that would be 
easy to pose with and quick to use for any artist. I wasn’t yet 
thinking about high quality rendering, shadows, animation, 
textures, or anything else. But Poser, like old John Henry, 
had a mind of its own. Poser 1 was released in 1995, and grew 
quickly. I knew Poser could be a useful tool but the response was 
overwhelming and the art it helped create was mind blowing.

Throughout the subsequent version releases, Poser’s community 
kept growing and diversifying, with people beginning to 

incorporate Poser into scientific, medical, architectural, CAD, 
theatrical, and dance-based projects and presentations. Ideas 
kept pouring in as more and more people joined the Poser 
community. Poser also evolved to include a new friendlier 
interface, more rendering powers, new content, and many new 
features.

The following that Poser attracted continues to amaze us all, 
as does the community’s ongoing diversity, creativity, talent, 
and passion. The Poser artists and modelers of the world have 
pushed far beyond anything I thought possible. Poser has been 
used in award winning character animations, as design for 
huge sculptures, for comic books, for medical illustration and 
instruction, for legal reconstruction, and for unleashing the kind 
of astounding images that, well, move us all.

In 2000 Curious Labs took Poser’s reigns. Our team began 
looking at where Poser and human simulation could (and 
should) continue growing. We knew we needed to remain 
committed to making products that would be easy enough 
for every artist to use. We also knew we needed to integrate 
our capabilities with the world of professional 3D graphics 
productions and with the new emerging Web-deployable 
technologies. Poser 4 Pro Pack was born of these needs, allowing 
Poser scenes and characters to be hosted inside high end 
professional packages such as 3D Studio MAX, Lightwave, and 
Cinema 4D. We also added Flash and Viewpoint Experience 
Technology capabilities for real time display via the Web. 
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Today, Poser has obtained huge levels of growth through the 
courageous efforts by many extremely talented and motivated 
professionals. Believe me, Poser is no longer written by me 
coding alone into the night. It’s a powerful graphics product that 
is the culmination of the work of a very talented group that spans 
the globe.

While streamlining our interface, we’ve integrated a large 
database of scanned human heads into a phenomenal 
face-designing environment. We added realistic rendering 
capabilities far beyond where we started, with the ability to 
create networks of complex shading nodes for unlimited textures 
and materials. We also added physical simulation of cloth and 
hair. By combining these new powers with a new suite of human 
models and poses, and a new portal to allow people to find 
content on the internet, Poser should, well, change the world–
again.

Each of us at Smith Micro Software sees what we do as a labor 
of love. Poser could never have gotten this far without each 
and every one of our dedicated staff. And, Poser could certainly 
never have evolved this far without the involvement of the Poser 
community, who has supported our efforts with enthusiasm, 
forum inundations, email blasts, contributions to the product, 
and a stream of unbelievable images.

Thanks to everyone who has touched or been touched by Poser.

Larry Weinberg 
Original Poser Creator
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Chapter 1: Welcome to 
Poser!

Thank you for purchasing Poser®. If you’ve never used Poser 
before, welcome! Are you upgrading from an earlier version of 
Poser? Welcome back!

Poser Pro is the fastest way for professional artists and 
production teams to add pre-rigged and fully textured 3D 
characters to their projects. With 5GB of included content 
libraries and richly varied third party Poser content, Poser Pro 
is the perfect link between professional production tools and 
ready to use 3D character assets, saving development time and 
resources.

Poser Pro includes intuitive posing, animation, and rigging tools 
all designed to make working with 3D character content as easy 
as possible. Poser Pro provides a node-based material system, 
dynamic hair, dynamic cloth, morph creation brushes and facial 
photo matching tools Automatic tools lipsync phonemes with 
imported sound files and create walk and run animation cycles. 
Poser Pro renders video or still images in photo-real or sketch 
styles. Included are an updated set of PoserFusion hosting 
plugins to integrate posed or animated Poser characters and 
scenes into 3ds Max, Maya, and Cinema 4D and LightWave. 
Import/ Export COLLADA content for 3D figure interchange 

between game engines and other 2D and 3D tools such as 
Photoshop, Softimage and SketchUp.

Poser Pro is optimized for 32/64 Bit and multi-core systems, 
better utilizing system memory and multiple threads to 
improve overall performance and reduce rendering times, 
with background rendering so you can continue working on 
other projects. Poser Pro’s OpenGL Support takes advantage of 
graphics card hardware to provide realistic lighting, shadows 
and color. Poser Pro’s Queue Manager lets you distribute and 
manage renderings across a Network Render Queue of cross  
platform systems

In Poser Pro 2014, we’ve included a host of exciting and 
powerful new features. Subdivision Surfaces via the use of 
Pixar’s OpenSubdiv provide the most efficient and popular 
surface polygonal smoothing in the business. With Bullet 
Physics we net Soft Body Dynamics, Rigid Body Dynamics 
and Hair physics with Live Simulation. A new Comic Book 
preview node with Threshold control provides both color and 
black & white cartoon images and animations. Weight Maps on 
Magnets provides more precise control over Poser’s powerful 
deformers. Simplify complicated materials and shaders with 
our new Compound Material Node. Our new Interactive 
Raytrace Preview provides you a raytraced thumbnail of your 
scene, updating with every change of the character, camera or 
lights. To repurpose your existing clothing content to fit any 
character, we’ve created a powerful Fitting Room so your figures 
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will always have something to wear. Speaking of figures, we’ve 
included 7 new cartoon characters, and 2 new humans, Rex and 
Roxie. Our morphing tool now will help better fit clothing, with 
Tighten, Loosen and Sag methods. And now Poser supports 
copying morphs from figure to figure. There are improvements 
in Raytrace rendering performance, OpenGL performance, the 
Grouping Tool, Symmetry, Mirroring, and even Cut and Paste 
operations.

Poser Pro supports HDRI output to produce images with full 
range of shadow, color, contrast and highlight intensities. 
With Gamma Correction, specify gamma values for textures 
and exported images for linear rendering with increased 
luminance accuracy. Poser Pro’s improved Firefly render engine 
supports Indirect Lighting with Irradiance Caching for Global 
Illumination effects and now even supports rendering with 
Ambient Occlusion at the same time. New shader nodes enable 
Subsurface Scattering for luminescent skin tones and Custom 
Scatter for bioluminescent effects. Poser’s physically correct 
light fall-off produces more photo-real final renderings. Normal 
Mapping adds the appearance of complexity and surface detail 
to 3D objects without increasing geometry resolution. Render 
out PSD layers for improved compositing, share final content via 
Facebook.

Poser Pro includes advanced Weight Map Rig support enabling 
vertex by vertex fine painting of joint bends and bulges, to 
generate better performing 3D characters that can be more 
easily posed with natural joints across the body. Hybrid 

Rigging supports both traditional Poser Sphere and Capsule 
zones to be used in combination. Poser Pro also supports both 
traditional grouped body part figures and single skin figures for 
interoperability. Weight Map Support for third party figures 
is delivered within our native poser file format, the PZ3, an 
open, well documented format that has been at the heart of the 
creative Poser community for nearly 20 years.

Poser Pro is designed with Poser Character Creators in mind and 
includes a suite of vertex Weight Map Creation tools including 
Vertex Weight Auto-transfer to permit the creation of new 
weight mapped figures from an existing rig, generation of new 
Weight Maps from existing Poser Zones of Influence, pressure 
sensitive painting of Weight Maps and interactive color display 
of affected vertices. Another advance in Poser is the ability to 
set-up both traditional zones and weight maps to affect body 
parts beyond the parent or child of the selected actor, enabling 
complex figures such as winged figures that need to interact with 
multiple body parts simultaneously. Once you’ve created Weight 
Mapped figures using Poser Pro, they can be fully integrated into 
Poser 9 or 10, or any of the third party host apps supported by 
PoserFusion.

Other basic features include Multi-Select Drag and Drop from 
and within Poser’s Content Library, Expanded Context Menus 
for better workflow, new camera modes to focus on your selected 
area, pressure sensitive tablet support in the Morph Brush and 
Weight Map Painting tools. Improved Content Management 
system with drag and drop, auto conforming, search, metadata 
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support, zone strength display for figure rigging, parameter 
change indicator and the Recent Render palette.

Whether used a standalone character animation system, or as a 
critical tool in your existing production pipeline, Poser Pro is the 
most efficient way for game designers, 3D artists, professional 
illustrators, animators and graphics production teams to add 3D 
character animation content to any project.

What’s New in Poser
Poser includes the following new features:

Figure Design

• Fitting Room: See “Chapter 28: The Fitting Room” on 
page 569

• Subdivision Surfaces: Choose Figure > Skinning Method 
> Poser Unimesh to create a unified mesh. Then select 
the Body actor for the figure to specify the amount of 
subdivision in the Properties palette. See “Working with 
Subdivision Surfaces” on page 769.

• Group Editor Enhancements: Select polygons by painting, 
or by rectangular selection. Add or remove polygons by 

group or material, and mirror them on positive or negative 
X, Y, or Z axes. See “The Group Editor” on page 681.

• New Morph Painting Tools: See “Using the Fitting Tools” 
on page 658.

• Weight Maps for Magnets: See “Using Magnets with 
Weight Maps” on page 621.

Animation

• Bullet Physics Simulations: Choose Window > Bullet 
Physics Controls to open the Physics Simulation Palette. 
You can assign each object in your scene to one of three 
types of objects: Choreographed, Rigid Dynamic, or Soft 
Dynamic. See “Chapter 23: Using Bullet Physics” on page 
493

Dynamic Hair

• Hair Room Improvements: Now offers the choice between 
traditional Poser and enhanced Bullet Physics solvers. See 
“Bullet Physics Solver” on page 543.

• Creating and Importing Hair in GoZ: Allows you to import 
ZBrush FiberMesh as hair objects. See “Importing Hair 
from GoZ” on page 799.
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Materials

• Compound Material Nodes: The new Compound node 
allows you to combine any Poser node type as an external 
input or output, providing a way to reduce clutter in the 
Advanced Material Room. Compound nodes allow you to 
add external inputs and outputs within a separate Material 
Room window. After you are finished with the compound 
node, you can return to the main window in the Advanced 
material room editor. See “Compound Nodes” on page 
381.

• User-assignable names for Material Nodes: Double-click 
a node name to assign a new name to a material node. See 
“Renaming Nodes” on page 320.

Preview Rendering

• Raytrace Preview: See “Real-time Raytrace Preview” on 
page 402.

• Improved bounding box calculation performance.

• Comic Book Preview Mode: Use Poser’s exciting new 
Color and B&W Comic Book Preview for static or animated 
toon imagery. This feature will enable you to create comic 
art with fantastic line control and color, or clean black and 

white outlines with persistent shading even when rotating 
or animating your point of view. See “Comic Book Preview 
Mode” on page 120.

Final Rendering

• Performance improvements for all raytraced effects. The 
new ray accelerator significantly speeds up rendering of 
scenes that are raytrace-heavy.

• Improved toon outlines in Firefly.

• Sketch outlines now connect across body parts.

Usability

• Log Window: Displays an ongoing log of commands 
used in Poser. The log window can be docked or floating, 
and can display useful information for users. Use the Log 
Window context menu to filter the log based on criteria 
such as timestamp, category, application commands, group 
selection, warnings, or debug information. See “Using the 
Log Window” on page 45.

• The ability to spawn props for use as simulation proxies in 
physics, hair, or cloth simulations. See “Creating Simulation 
Proxies” on page 240.
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• Various performance improvements for bending, real-time 
shader updates, and animation playback.

• Earlier and more comprehensive verification of binary 
morph data integrity.

• Parameters Palette: Added an option to display parameter 
channels in calculation order, allowing you to correct 
the initial order of physics simulation parameters. See 
“Parameters Palette Options Menu” on page 198.

Import/Export

• Enabled export options for morph weights and sparse array 
KHR extensions in COLLADA.

• Support for modern media formats such as MP3, H.264/
MP4 via Media Foundation (Windows 7 and 8 only).

Included Documentation
Poser includes the following documentation:

• Poser Reference Manual: This Reference Manual has been 
rewritten and Poser features added. It is included in both 
hard copy and in electronic PDF format on your Poser DVD. 

Selecting Help > Poser Reference Manual from within 
Poser will also launch this manual.

The version of the manual accessible from the 
help menu is optimized for screen viewing. If you 

wish to print it out, your Poser DVD contains a version 
that is optimized for print in the documentation folder.

• Quick Reference Card (QRC): The QRC is a fold-out 
reference that briefly describes key Poser features and 
includes a comprehensive list of Poser keyboard shortcuts.

• PoserPython Methods Manual: This manual contains 
an organized listing of each PoserPython method available 
in Poser. It is included in PDF format on your Poser DVD 
and is also accessible from within Poser by selecting Help > 
PoserPython Manual.

• Quick Start Guide: This Quick Start guide is an on-screen 
step-by-step interactive guide that takes users through the 
necessary steps to quickly create scenes within Poser.

System Requirements
System requirements for Poser installation are as follows:
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Windows

• Windows XP, Vista, 7, or 8 (64-bit OS required for 64-bit 
installation)

• 1.3 GHz Pentium 4 or newer, Athlon 64 or newer (1.65 GHz 
or faster recommended)

• 1 GB system RAM (4 GB or more recommended)

• OpenGL enabled graphics card or chipset recommended 
(recent NVIDIA GeForce and ATI Radeon required for 
advanced real-time preview features)

• 24-bit color display, 1440 x 900 minimum resolution

• 3 GB free hard disk space (6 GB recommended)

• DVD-ROM drive (Physical product only)

• Internet connection required for Content Paradise

• Windows® Internet Explorer® 7 or newer

• Adobe® Flash® Player 11 or newer

• Adobe® AIR® (external library)

• Hosting plug-ins require a valid English language 
installation of their respective host application:

 � Maxon CINEMA 4D R10-14 (64 & 32-bit)

 � Autodesk 3ds Max 2010 - 2014 (64 & 32-bit)

 � Autodesk Maya 2010 - 2014 (64 & 32-bit)

 � Newtek LightWave 3D 9 - 11 (64 & 32-bit)

• ZBrush 4 or later required for GoZ interoperability.

Mac

• Mac OS X 10.6, 10.7, or 10.8

• 1.5 GHz Intel Core processor (Core 2 Duo or faster 
recommended, 64-bit CPU required for 64-bit support)

• 1 GB system RAM (4 GB or more recommended)

• OpenGL enabled graphics card or chipset recommended 
(recent NVIDIA GeForce and ATI Radeon required for 
advanced real-time preview features)

• 24-bit color display, 1440 x 900 minimum resolution

• 3 GB free hard disk space (6 GB recommended)
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• DVD-ROM drive (Physical product only)

• Internet connection required for Content Paradise

• Adobe® Flash® Player 11 or newer

• Adobe® AIR® (external library)

• Hosting plug-ins require a valid English language 
installation of their respective host application:

 � Maxon CINEMA 4D R10-14 (64 & 32-bit)

 � Autodesk Maya 2010 - 2014 (64 & 32-bit)

 � Newtek Light Wave 3D 9 - 11 (64 & 32-bit)

• ZBrush 4 or later required for GoZ interoperability.

Poser Content Online

Poser’s Content room includes a direct link to the online 
Content Paradise (http://www.contentparadise.com), which 
offers hundreds of figures, props, textures and other content 
available for use within Poser. Also, Poser’s Download Manager 
makes the process of downloading content and installing it to 
the appropriate Library categories fully automatic, so accessing 
high quality content has never been simpler! See “Chapter 8: 
The Content Room” on page 173 for more information about 
the Content room, and Content Paradise.

Other Smith Micro Software Products

Check out these products from Smith Micro Software:

• Manga Studio: Manga Studio, the leading manga and 
comic art software, provides all the essential tools you 
need to create professional, ready-to-publish pages from 
start to finish! Manga Studio offers an intuitive interface, 
and delivers the best suite of ready-to-use screen tones, 
content and special manga and comic effects for hobbyists, 
experienced artists and professionals.

• Anime Studio: Anime Studio is your complete animation 
program for creating 2D movies, cartoons, anime and cut 
out animations. Create your own desktop animated shorts 
in the style of SouthParkStudios.com and JibJab.com, or 
use Anime Studio to produce full-length animation for 
film, video or streaming over the web. Anime Studio allows 
digital enthusiasts at home and professionals in the studio 
to bring their imagination to life!

When You Have Questions
As you begin using Poser for your 3D projects, you’ll 
undoubtedly have questions or want to network with other Poser 
artists. You’re not alone! There are many resources available for 
Poser artists. Here are just a few:

http://www.contentparadise.com
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Need Help?

Poser includes the Help menu, which serves to answer most of 
your questions while using the application:

• Poser Help: Selecting Help > Poser Reference Manual 
opens the Poser Reference Manual in PDF format.

• PoserPython Help: Selecting Help > PoserPython Manual 
opens the PoserPython Methods Manual in PDF format.

• About: Windows users can select Help > About Poser 
to display the Poser version and copyright information. 
Macintosh users should look in the Poser Application menu, 
and select About Poser, to see this information. This option 
will be useful if you need to obtain technical support, since 
the Technical Support representative will need to know this 
information.

• The Help > Content Paradise submenu contains links to 
information on content from Content Paradise.

Smith Micro Software Resources

• Online Support: For technical support, customer service, 
downloads, and to visit the Smith Micro Poser community 
and gallery, visit us at http://my.smithmicro.com/support.

• Using Poser: For updates, tutorials, and Poser user stories, 
visit http://poser.smithmicro.com/index.html.

• To Learn More: If you’d like to learn more about Smith 
Micro Software, visit us at http://my.smithmicro.com.

• Contacting Technical Support: If our Web Knowledge 
Base does not resolve your situation, please contact us 
through http://support.smithmicro.com. Please refer to 
“Appendix A: Technical Support” on page 845 to view our 
technical support policy.

• Sales: You may reach our sales department via e-mail at: 
sales@smithmicro.com.

• Other Links: Selecting Help > Smith Micro Web Links or 
Help > Other Web Links within Poser lists other valuable 
online resources.

Third-Party Forums

You may also visit online Poser forums such as:

• Animotions: http://www.animotions.com

• Renderosity: http://www.renderosity.com

• RuntimeDNA: http://www.runtimedna.com

mailto:sales%40smithmicro.com?subject=
http://www.animotions.com
http://www.renderosity.com
http://www.runtimedna.com
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Smith Micro Software does not regulate content 
on third-party forums and their listing and 

order of appearance in this manual is not an 
endorsement.

Other Important Resources

Visit the following sites to learn about some of the applications 
and technology supported by Poser:

• Python resources: The following is a small sample of the 
ever-growing body of online and hardcopy information 
concerning the Python scripting language:

 � The basic Python interpreter (which allows you to write 
your own Python scripts for any desired purpose) as 
well as many in-depth documents and links to other 
online resources is available for free download at 
http://www.python.org.

 � You can find additional online resources on wxPython 
at http://www.wxpython.org.

 � Learning Python, 3rd Edition by Mark Lutz; O’Reilly 
& Associates; ISBN # 0-596-51398-4

 � wxPython in Action by Noel Rappin and Robin Dunn; 
Manning Publications; ISBN # 1-932-39462-1

About Your Reference Manual
Smith Micro Software strives to provide documentation that is 
complete, accurate, informative, and friendly. Your feedback is 
always welcome. Please e-mail your comments to: techsupport@
smithmicro.com.

The Poser Reference Manual is for both Macintosh and 
Windows. By convention, Macintosh commands precede 
Windows commands in the text. The Poser interface for 
Macintosh and Windows platforms is identical, unless otherwise 
specified.

For clarity, this manual uses several notational conventions to 
present information of special importance. Lists of items, points 
to consider, or procedures that do not need to be performed in a 
specific order appear in bullet format:

• Item 1

• Item 2

Procedures that must be followed in a specific order appear in 
numbered steps:

1. Perform this step first

2. Perform this step second

http://www.python.org
http://www.wxpython.org
mailto:techsupport%40smithmicro.com?subject=
mailto:techsupport%40smithmicro.com?subject=
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Specific keyboard keys are depicted in square brackets and 
are capitalized. For example: [ESC]. If more than one key 
should be pressed simultaneously, the notation appears as 
[KEY1]+[KEY2], for example [ALT]+[F4]. When a modifier 
key differs between the Macintosh and Windows platform, the 
Macintosh modifier is listed first followed by a slash and the 
Windows modifier key. For example, [COMMAND]/[CTRL]+[I] 
is equivalent to the Macintosh [COMMAND]+[I] and the 
Windows [CTRL]+[I].

Screen prompts, menu and window names, fields, buttons, 
boxes, etc. appear in bold type. Where you need to access a 
palette, command, or submenu, the syntax is Menu > Submenu. 
For example File > Save As means you should open the File 
pull-down menu and then select Save As to open the Save As 
dialog box.

Program and script code appears in standard Courier font, for 
example:

cd\letters\business\legal [ENTER]

Notes detail tips, tricks, and other important 
information.

Warnings alert you to potentially harmful 
consequences such as data loss.
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Chapter 2: Installing 
Poser

Before opening your DVD holder, please take a moment to read, 
understand, and agree to the Poser End User License Agreement 
(EULA). If you do not agree with the terms of the EULA, please 
return your entire Poser package including the unopened DVD 
holder to Smith Micro Software or your place of purchase. Once 
you have read and accepted the EULA, you may proceed with 
installing Poser on your system.

The Smith Micro online store will accept the 
return of either physical or electronically 

downloaded products purchased directly from Smith 
Micro within 30 days of the date of purchase. Products 
purchased in retail stores must be returned to the place 
of purchase and meet their specific return policy terms. 
Smith Micro reserves the right to change this policy at 
any time.

Poser End User License Agreement 
(EULA)
This End User License Agreement (“EULA”) is between you 
(both the individual installing the Program and any single legal 
entity on behalf of which such individual is acting) (“you” or 
“your”) and Smith Micro Software, Inc., and/or its subsidiaries 
(“Company”).

PLEASE READ THIS EULA CAREFULLY BEFORE USING THE 
SOFTWARE. BY CLICKING THE “I ACCEPT” BUTTON WHEN 
INSTALLING THE PROGRAM, YOU ARE AGREEING TO BE 
BOUND BY THE TERMS OF THIS EULA. IF YOU DO NOT 
AGREE TO THE TERMS OF THIS EULA, CLICK ON THE “I 
DO NOT ACCEPT” BUTTON. IF YOU DO NOT ACCEPT THIS 
EULA, YOU MAY NOT USE OR ACCESS THE SOFTWARE. 
USING OR ACCESSING ANY PART OF THE SOFTWARE 
INDICATES THAT YOU ACCEPT THESE TERMS.

DEFINITIONS

• “Content” means animations, characters, clothing, faces, 
hair, geometries, images, materials, meshes, morphs, 
motion files, props, PoserPython scripts, textures, bump 
maps, transparencies, and similar files and data created 
with the intent of being used within the Program and/or 
third party applications.
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• “Documentation” means any written material in any 
form for installation and use of the Program provided by 
authorized agents or representatives of the Company.

• “Legitimate Uses” means (a) creating morph targets based 
on the Restricted Content, provided that any distribution 
of the morph targets will not include the original mesh 
connectivity information (for example, distribution in 
the form of data utilized with morph moving utilities or 
in a .CR2 file that references the original geometry, but 
no inclusion of the complete mesh); (b) creating texture 
templates derived from the Restricted Content to create 
new maps for either Restricted Content or Other Content; 
(c) creating tutorials, books, or other educational materials 
using images of the Program interface or Content for sale, 
distribution, public display, or public performance, provided 
such materials are intended to educate users as to use of the 
Program; (d) creating original Content for sale, distribution, 
public display, or public performance; (e) creating materials 
(e.g., shader trees) for use with either Restricted Content 
or Other Content; (f) creating characters or props based on 
Restricted Content in Proprietary File Formats, where the 
original (or modified) geometry, texture, or other Restricted 
Content files are not distributed with such characters or 
props; or (g) creating PoserPython scripts.

• “Other Content” means Content that is not Restricted 
Content or Unrestricted Content. Other Content may be 

subject to license terms imposed by the Other Content’s 
original creator.

• “Program” means the Company computer software and 
associated files in Proprietary File Formats delivered via the 
accompanying physical media or electronic media.

• “Proprietary File Formats” means any of Company’s 
proprietary compressed and uncompressed formats and/
or future proprietary file formats, including files with the 
following extensions: CM2, CR2, FC2, HD2, HR2, LT2, 
MC6, MT5, PP2, PZ2, PZ3.

• “Restricted Content” means all Content included with 
or part of the Program that is not Unrestricted Content, 
including without limitation mesh objects (geometry) 
in any format, files in Proprietary File Formats, images, 
materials, texture, transparency maps, Documentation, and 
Company’s proprietary data.

• “Unrestricted Content” means Content included with 
or part of the Program that is specifically identified in the 
Documentation or listed in this EULA as Unrestricted 
Content. The following figure geometries and their 
associated textures are Unrestricted Content: low res male, 
low res female, medium res male, medium res female.
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THIRD-PARTY TECHNOLOGY AND 
CONTENT

Portions of the Program and Other Content contain technology 
and/or other components licensed by the Company from the 
following third parties: Pixels Digital, Inc., Singular Inversions, 
Inc., Size8 Software, Inc., and Automatic Sync Technologies 
LLC, each of whom retain the ownership, copyrights, 
trademarks, and patents to their respective contributions to 
the Program. Open source components include: Open source 
components include: Boost C++ http://www.boost.org, Bullet 
Physics http://bulletphysics.org, Embree http://embree.github.
com, FreeImage http://freeimage.sourceforge.net, FreeType 
http://freetype.sourceforge.net, Geometric Tools http://www.
geometrictools.com, k-d tree point cloud: Henrik Wann Jensen, 
libCurl http://curl.haxx.se/libcurl/, libjpeg http://www.ijg.
org, libtiff http://www.libtiff.org, numpy http://www.numpy.
org, OpenEXR http://www.openexr.com, OpenSSL http://
www.openssl.org, pcre http://www.pcre.org, PIL http://www.
pythonware.com/products/pil, pthreads http://sourceware.
org/pthreads-win32, Python http://www.python.org, pthreads 
http://sourceware.org/pthreads-win32, SFMT http://www.
math.sci.hiroshima-u.ac.jp/~m-mat/MT/SFMT, XMLRPC++ 
http://xmlrpcpp.sourceforge.net, XMP http://www.adobe.
com/products/xmp Other Content that is subject to third-party 
rights included with Program and Documentation is copyrighted 
and owned by the original Content creators.

GENERAL

You agree to use the Program, Documentation and Content only 
for lawful purposes. Any use of the Program, Documentation or 
Content other than as granted in this EULA must be approved by 
the Company’s prior written consent. The Company maintains 
an ongoing EULA enforcement program. Violation of any 
provision in this EULA automatically terminates this EULA. The 
Company reserves all other rights that it may have for violation 
of this EULA.

PROGRAM LICENSE

Subject to the terms and conditions of this EULA and your 
payment of the license fee, the Company grants you a limited, 
personal, nontransferable and nonexclusive license (without 
the right to sublicense): (i) to use a single copy of the Program 
(except as expressly permitted in the Documentation) solely 
for your own internal business operations on a single computer 
as set forth in Section K below for production operation or, 
on a temporary basis, on a backup system if such equipment 
is inoperative, consistent with the limitations specified or 
referenced in this EULA and the Documentation; (ii) to use the 
Documentation provided with the Program in support of your 
authorized use of the Program; and (iii) to copy the Program 
to make one (1) archival copy of the Program for your personal 
archival or backup purposes, and to make a sufficient number of 

http://www.boost.org
http://bulletphysics.org
http://embree.github.com
http://embree.github.com
http://freeimage.sourceforge.net
http://freetype.sourceforge.net
http://www.geometrictools.com
http://www.geometrictools.com
http://curl.haxx.se/libcurl/
http://www.ijg.org
http://www.ijg.org
http://www.libtiff.org
http://www.numpy.org
http://www.numpy.org
http://www.openexr.com
http://www.openssl.org
http://www.openssl.org
http://www.pcre.org
http://www.pythonware.com/products/pil
http://www.pythonware.com/products/pil
http://sourceware.org/pthreads-win32
http://sourceware.org/pthreads-win32
http://www.python.org
http://sourceware.org/pthreads-win32
http://www.math.sci.hiroshima-u.ac.jp/~m-mat/MT/SFMT
http://www.math.sci.hiroshima-u.ac.jp/~m-mat/MT/SFMT
http://xmlrpcpp.sourceforge.net
http://www.adobe.com/products/xmp
http://www.adobe.com/products/xmp
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copies for Legitimate Uses or the intended use described in the 
Documentation, provided that all titles and trademark, copyright 
and restricted rights notices are reproduced on all such copies. 
Any other uses of the Program, including without limitation the 
Program interface, other than those granted in this EULA must 
be approved by the Company’s prior written consent.

You will not use, copy, modify, derive, or transfer the Program or 
Documentation, or any copy, modification, derivation, or merged 
portion thereof, in whole or in part via any means or for any 
purpose whatsoever except as expressly permitted in this EULA 
or the Documentation. You will not relicense, sublicense, rent, 
lease, or lend the Program for third-party training, commercial 
time-sharing or service bureau use. You will not, and will not 
permit any third party to, reverse engineer, decompile, debug, 
disassemble, circumvent the security features of, or interfere 
with the normal functionality and operation of the Program for 
any reason whatsoever without the express prior written consent 
of the Company or except to the extent expressly permitted 
by applicable law. If the Program is an upgrade to a previous 
version of the Program, you must possess and maintain a valid 
license to such previous version in order to use the upgrade.

You expressly acknowledge that the Company has a 
valuable proprietary interest in both the Program and the 
Documentation. All title, ownership, interest and rights in and 
to the patent, copyright, trademark, trade secret and any other 
intellectual property rights in the Program (and any derivative 
works thereof) and the Documentation (and any derivative 

works thereof), not expressly granted to you by this EULA 
remain with the Company. You do not acquire any other rights, 
express or implied, in the Program (and any derivative works 
thereof) and the Documentation (and any derivative works 
thereof) other than those rights expressly granted under this 
EULA. Without limiting the generality of the foregoing, the 
Company retains all title, ownership, interest and rights in and 
to the patent, copyright, trademark, trade secret and any other 
intellectual property rights in the copy of the Program contained 
on your archival media, and all of the terms of this EULA 
apply to such archival copy as if it were the original Company-
produced copy of the Program that was furnished to you when 
you paid the licensing fee.

Except as otherwise expressly permitted in the Documentation, 
you will only use the Program on a single computer, meaning 
that you must treat the Program “like a book.” “Like a book” 
means that the Program may be used by any number of people 
and may be freely moved from one computer to another so long 
as no possibility exists of the Program being used at more than 
one computer simultaneously. More than one person at a time 
cannot read the same copy of a book, and this restriction applies 
to the Program. The Company is pleased to offer site licenses for 
multiple simultaneous users. Please contact the Company at the 
address below for details.

You, your employees, and/or authorized agents must protect 
the Program’s confidentiality and act to enforce your obligations 
under this EULA. You cannot distribute or otherwise make 
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the Program or Documentation available to any third party 
via any means whatsoever, public or private, for any purpose, 
commercial or not, unless explicitly allowed by this EULA.

You assume full responsibility for your selection of the Program 
to achieve your intended results and for the installation, use, and 
results you obtain from the Program. Company has no obligation 
to provide support, maintenance, upgrades, modifications or 
new releases under this EULA

CONTENT LICENSE

Subject to the terms and conditions of this EULA and your 
payment of the license fee, Company grants you a limited, 
personal, nontransferable and nonexclusive license (without the 
right to sublicense):

• a. To reproduce, prepare derivative works based upon, 
distribute, publicly display, and publicly perform the 
Unrestricted Content for any lawful purpose other than 
to create a product which is intended to compete with the 
Program or to create new content which is intended to 
compete with the Restricted Content.

• b. To prepare derivative works based upon the Restricted 
Content solely for Legitimate Uses and lawful uses.

• c. To reproduce, prepare derivative works based upon, 
distribute, publicly display, and publicly perform content 
you create using Restricted Content, provided that such use 
of Restricted Content shall be solely Legitimate Uses and 
lawful uses.

Notwithstanding the foregoing, nothing shall limit the 
Company’s right to independently create, develop, own, market, 
distribute, license, sublicense, import, export, sell, or otherwise 
exploit any content or materials similar to any derivative works 
based upon the Content.

You will use the Other Content in accordance with all applicable 
license terms imposed by the content’s original creator.

You will not use, copy, modify, derive, distribute, transfer or 
sublicense the Restricted Content, the Unrestricted Content, 
or the Other Content or any copy, modification, derivation, or 
portion thereof, in whole or in part via any means or for any 
purpose whatsoever except as expressly permitted in this EULA 
or the Documentation.

You expressly acknowledge that the Company has a valuable 
proprietary interest in the Restricted Content and the 
Unrestricted Content. All title, ownership, interest and rights 
in and to the patent, copyright, trademark, trade secret and any 
other intellectual property rights in the Restricted Content and 
the Unrestricted Content not expressly granted to you by this 
EULA remain with the Company. You do not acquire any other 
rights, express or implied, in the Company-created Restricted 
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Content (and any derivative works thereof) other than those 
rights expressly granted under this EULA.

Except as otherwise expressly permitted in the Documentation 
or unless otherwise provided for herein, you will only use the 
Content on a single computer, meaning that you must treat 
the Content “like a book.” The Company is pleased to offer site 
licenses for multiple simultaneous users. Please contact the 
Company at the address below for details.

TERM

This EULA remains in full force and effect until terminated. You 
may terminate it at any time by returning or destroying both 
the Program and the Documentation, together with all copies, 
modifications, and merged portions of the Product and the 
Documentation in any form. The Company is in no way obliged 
to issue refunds. Company may terminate this EULA at any time 
upon your breach of any of the provisions hereof.

Upon termination, you will immediately cease all use of 
the Program, return or destroy both the Program and the 
Documentation to the Company, together with all copies, 
modifications, and merged portions of the Product and 
the Documentation in any form, and so certify to vendor. 
Termination of this EULA for any reason in no way limits the 
Company’s right to continue enforcing all rights provided by law 
and does not entitle you to a refund of your license fee except 

as provided herein. All provisions of this EULA that protect the 
Company’s proprietary rights continue in full force and effect 
after termination.

LIMITED WARRANTY

The Company provides the Program and the Documentation AS 
IS with no warranty. The Company makes no representations or 
warranties, either express or implied, of any kind with respect 
to the Program and the Documentation. To the fullest extent 
permissible under applicable law, Company expressly disclaims 
all warranties of any kind, either express or implied, with respect 
to the Program or the Documentation, including warranties of 
merchantability, fitness for a particular purpose, satisfactory 
quality, and non-infringement. The Company does not warrant 
that the Program’s functionality will meet your requirements 
or that the Program operation will be uninterrupted or error-
free. No distributor, dealer, or any other entity or person is 
authorized to expand or alter either this warranty or this EULA, 
and the Company will not be bound by any such representation 
in any way. You assume the entire risk of the Program’s and the 
Documentation’s quality and performance. Should the Program 
prove defective, you assume the entire cost of all necessary 
servicing repair or correction.
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LIMITATION OF LIABILITY

In no event will the Company be liable to you for any indirect, 
incidental, consequential, special, or punitive damages, 
including damages for any lost profits, arising out of your use or 
inability to use the Program and the Documentation, even if the 
Company has been advised of the possibility of such damages 
or for any claim by any other party. Some states and countries 
do not allow the limitation or exclusion of liability for certain 
damages, so the above limitation or exclusion may not apply to 
you. In no event will the Company’s liability to you or any other 
person for damages hereunder exceed the amount of the license 
fee paid by you to use the Program regardless of the form of the 
claim. The parties acknowledge that this limitation of liability 
are an essential element of the bargain between the parties, 
without which Company would not have entered into this 
EULA. Company’s pricing reflects this allocation of risk and the 
limitation of liability specified herein.

INDEMNIFICATION

You will indemnify and hold harmless, and at Company’s 
request defend, Company and its affiliates, successors and 
assigns from and against any and all claims, losses, liabilities, 
damages, settlements, expenses and costs (including, without 
limitation, attorneys’ fees and court costs) which arise out of or 
relate to any third party claim or threat thereof that your use 

of the Program, Documentation or Content is unlawful or not 
otherwise permitted by this EULA. Company reserves the right, 
at its own expense, to assume the exclusive defense and control 
of any matter otherwise subject to indemnification hereunder.

EXPORT LAW ASSURANCES

Export of this Program and Documentation is governed by 
the laws and regulations of the United States and import laws 
and regulations of certain other countries. You will comply 
with all such laws and regulations. Export of this Program and 
Documentation to any entity on the Denied Parties List and 
other lists promulgated by various agencies of the United States 
Federal Government is strictly prohibited.

U.S. GOVERNMENT RESTRICTED 
RIGHTS

The Program and Documentation is provided with 
RESTRICTED RIGHTS. Any use, modification, reproduction, 
release, performance, display or disclosure by the U.S. 
Government or any of its agencies shall be governed solely by the 
terms of this EULA and shall be prohibited except to the extent 
expressly permitted by the terms of this EULA. The Software 
and Documentation are deemed to be “commercial computer 
software” and “commercial computer software documentation”, 
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respectively, pursuant to DFAR Section 227.7202 and FAR 
12.212(b), as applicable. Any technical data provided that is not 
covered by the above provisions is deemed to be “technical data-
commercial items” pursuant to DFAR Section 227.7015(a). Any 
use, modification, reproduction, release, performance, display or 
disclosure of such technical data shall be governed by the terms 
of DFAR Section 227.7015(b).

MISCELLANEOUS

This EULA shall be governed by the laws of the State of 
California, without giving effect to any choice of law rules. This 
EULA will not be governed by the United Nations Convention on 
Contracts for the International Sales of Goods, the application 
of which is expressly excluded. Exclusive jurisdiction over and 
venue of any suit arising out of or relating to this EULA will be 
in the state and federal courts of Orange County, California. 
If for any reason a court of competent jurisdiction finds any 
provision, or portion thereof, to be unenforceable, the remainder 
of this License shall continue in full force and effect. The waiver 
by either party of any default or breach of this EULA will not 
constitute a waiver of any other or subsequent default or breach. 
You may not assign, sell, transfer, delegate or otherwise dispose 
of, whether voluntarily or involuntarily, by operation of law or 
otherwise, this EULA or any rights or obligations under this 
EULA without the prior written consent of the Company. Any 
purported assignment, transfer or delegation by you will be null 

and void. This EULA constitutes the entire agreement between 
the parties and supersedes all prior or contemporaneous 
agreements or representations, written or oral, concerning the 
subject matter of this EULA. This EULA may not be modified 
or amended except in a writing signed by a duly authorized 
representative of each party.

CONTACT INFORMATION

If you have questions concerning this EULA or need to contact 
Customer Service, please contact Company at this address:

Smith Micro Software, Inc., 51 Columbia, Aliso Viejo, CA 
92656.

TRADEMARK AND COPYRIGHT NOTICE

Poser, Poser Pro, the Poser logo, and the Smith Micro Logo 
are trademarks and or registered trademarks of Smith 
Micro Software, Inc. Poser copyright © 1991-2013 All Rights 
Reserved. All other product names are trademarks or registered 
trademarks of their respective holders. Licensed product.

This EULA does not grant you the right to use, and you shall not 
use, the copyrighted materials or trademarks of Company or its 
affiliates in any advertising, publicity or promotion, or to express 
or imply any endorsement of such party. Without limiting the 
generality of the foregoing, you may not express or imply any 
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endorsement by the Company or its affiliates of any tutorials, 
books, or other educational materials you create using images of 
the Program interface or Content.

BY CLICKING ON THE “I ACCEPT” BUTTON WHEN 
INSTALLING THE PROGRAM, YOU ACKNOWLEDGE THAT 
(1) YOU HAVE READ AND REVIEWED THIS AGREEMENT 
IN ITS ENTIRETY, (2) YOU AGREE TO BE BOUND BY THIS 
AGREEMENT, (3) THE INDIVIDUAL SO CLICKING HAS 
THE POWER, AUTHORITY AND LEGAL RIGHT TO ENTER 
INTO THIS AGREEMENT ON BEHALF OF YOU AND, (4) BY 
SO CLICKING, THIS AGREEMENT CONSTITUTES BINDING 
AND ENFORCEABLE OBLIGATIONS OF YOU.

CONTACTING CUSTOMER SERVICE 
AND TECHNICAL SUPPORT

For Customer Service questions or problems (returns, warranty), 
please visit http://my.smithmicro.com/support.

For technical support, please refer to “Appendix A: Technical 
Support” on page 845 of your Poser Reference Manual.

Using the Download Manager
The Smith Micro Download Manager allows you to selectively 
download and install the Poser application and content 

installers, as well as updates when they become available. Once 
the downloads start, you can pause and resume the download as 
needed.

Poser Pro owners will need to enter the serial 
number for Queue Manager separately to 

download and install the Queue Manager. This allows 
you to install the Queue Manager on every machine that 
you want to use as a network node.

The download manger is platform-specific. If 
you are using Poser Pro on both Mac and 

Windows platforms, you will need to have both platform 
versions of the download manager to obtain the 
necessary Queue Manager installers.

When you first start the Download Manager you will be asked to 
enter a valid Poser serial number.

Check the Keep Installers checkbox if you want to retain a copy 
of the installers on your hard drive after installation is complete. 
Then increase or decrease the number of installers that you want 
to keep on your system.

http://my.smithmicro.com/support
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If you do not have Keep Installers checked, it 
will not keep the installers. This flag does not 

stick to the installers you have already downloaded. The 
Download Manager checks the status of this option and 
acts appropriately on each startup.

Click OK to proceed to the next screen.

 Enter your Poser serial number to use the Download Manager.

A Data Location button appears in the lower-left corner of 
the Download Manager. This allows you to select a location on 

your system to store the files that you download. To change the 
location from the default, click the Data Location button and 
choose the file and folder you want to use.

If you have previously downloaded files with the 
Download Manager and then change the Data 

Location, the Download Manager will move the files 
that you previously downloaded into the new folder that 
you specify.
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 You can selectively download one or more installers, or download 
all of them.

When the Download Manager starts, it displays a list of 
installers, and their version numbers. You can download as 
follows:

• To add all of the installers to the download queue, click 
the Download All button that appears at the bottom of the 
Download Manager.

• To pause all of the downloads, click the Pause All button.

• To download a specific installer, click the Download button 
that appears to the right of the installer name, for each 
installer that you want to download.

• To pause a specific download that is in progress, click the 
Pause button.

• To resume a paused download, click the Resume button.

• To cancel all downloads, close the Download Manager 
window.

After all downloads are complete, you will need to install the 
Poser application first before the download manager allows you 
to install content installers. Click the Install button for each 
content installer that you want to include.

 The Support Files installer must be installed to 
obtain Face Room support for the figures 

included with Poser. 

Both the Nude Figures content installer and the 
Hair content installer must be installed to use 

Roxie (her eyelashes are in the Hair content installer).
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Installing Poser
Installing Poser is a straightforward process. Before inserting 
your DVD, be sure to save any work in progress and close all 
running applications, including virus-checking utilities and other 
“background” software. Having this “clean” environment will 
help the installation process proceed smoothly and will prevent 
any loss of data in the highly unlikely event of a problem. To 
install Poser, complete the following steps:

Poser Installation (Windows)

1. Click on the Poser installer to start the Installer.

2. The Welcome screen will appear, click Next to continue.

3. The “Poser End User License Agreement (EULA)” on page 
12 appears. Select I accept the agreement and click 
Next.

4. The Information screen appears. Review the Readme file. 
This file contains information that was too recent to be 
included in this manual. Please take a moment to read this 
file, as the changes outlined therein may affect how you 
install and/or use Poser. When you have finished reading 
the Readme file, click Next to proceed with the installation.

5. The Select Destination Location screen appears. Use 
this screen to select the installation path for the Poser 
executable. Select the destination location where you want 
to install Poser Pro. You can use the default location or click 
the Browse button to specify another location, click Next to 
continue.

6. If you have a 64-bit computer and 64-bit Windows 
operating system, Setup will install the 64-bit version of 
Poser Pro by default. You can check the Install 32 bit files 
option to optionally and additionally install the 32-bit 
version of Poser Pro in its own installation folder.
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 Choosing an installation location.

If you are using the 64-bit version of Poser Pro, 
you can also choose to install the 32-bit version 

of Poser Pro for improved backward compatibility with 
add-on scripts and plug-ins that are not 64-bit capable. 
In addition, the 32-bit version of Poser Pro allows you 
the option of either docking the library or running it in a 
separate window, whereas the 64-bit version runs the 
library in a separate window only.

7. The Select Components screen appears. Choose the desired 
installation options from the drop-down menu:

 � Full Installation: Most users choose the Full 
Installation option. This option performs the complete 
installation of Poser Pro including all content and the 
Queue Manager.

 � Compact Installation: This option installs Poser Pro, 
the Network Queue Manager, Application Support 
Files, and Core Content Files. Additional content is 
installed if the applicable options are selected. This 
option is useful if hard drive space is limited.

 � Basic Content (Clothed Figures, Props, Scenery): 
This option installs clothed figures and medical 
references (skeletons and muscles), Props, and Scenery.

 � Custom Installation: Allows you to choose the items 
that you want to install.

 � Queue Manager Only: Installs the Poser Queue 
Manager. Use this option for installing additional 
network rendering nodes.

8. Click Next to continue to the Select Content Location 
screen. Select the location for the Poser Pro content 
Runtime directory. Based on the descriptions below, select 
the location that works best for you and click Next.
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 � Shared Documents Directory: This is the default 
installation option. Files can be shared—useful in multi-
user environment or when UAC is enabled on Windows 
Vista or later.

 � My Documents Directory: The files will only be 
accessible to the user who installed them.

 � Poser Directory: The content library resides next to 
the Poser Pro program files.

 � Other Location: Specify the directory of your choice. 
This option is desirable if you want to install your 
content on a different hard drive or folder name.

9. If you selected Other Location in step 8, the Select 
Custom Content Location screen appears. Use this screen 
to choose the installation folder for your Poser content. By 
default, Window 7 users install the content folder beneath 
the Users > Public > Documents folder on their C: drive; 
however, you can browser to or enter the folder or hard 
drive of your choice. Click Next after you make your choice.

10. The Select Start Menu Folder screen will appear. You 
can use the default location or click the Browse button to 
specify another location. When you are finished, click Next.

11. Select Additional Tasks screen will appear. Options here 
allow you to remove, backup or reuse existing preference 
files that store information such as library runtimes, 

interface layouts, and other preferences. You can also enable 
the check boxes to create desktop icons for Poser and the 
Queue Manager (Poser Pro only). Click Next after you make 
your choices

12. Review your choices in the Ready to Install screen. Finally, 
click Install to install the Poser Pro and Queue Manager 
applications. When they are finished installing, click 
Finished.

Portions of Poser require that Flash Player is 
installed on your system. Verify that Flash 

Player is present before using Poser Pro.

Poser’s Content Library utilizes Microsoft 
Internet Explorer technology. To ensure the 

optimal experience and compatibility for the Content 
Library, the installer will disable “Local Machine 
Lockdown” for the Poser application. This will not affect 
other applications outside of Poser. Details about “Local 
Machine Lockdown” can be found at http://msdn.
microsoft.com/en-us/library/ms537641(VS.85).aspx.

 The installer grants Poser components in 
<AppLocation > \Runtime\ui\Flex\ a Flash 

sandbox setting of ‘localTrusted’.

http://msdn.microsoft.com/en-us/library/ms537641%28VS.85%29.aspx
http://msdn.microsoft.com/en-us/library/ms537641%28VS.85%29.aspx
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Some features of Poser, such as the Library and 
rendering in a separate process, require that you 

allow local network communication to operate. The 
features will not work if a personal firewall prevents 
local network communication.

Poser Installation (Mac)

It is recommended that you install Poser on a 
hard drive that is formatted with HFS+ 

Journaled formatting. Extended Journaled formatting 
can be used as long as you do not make it case-sensitive.

Double-click on the Install icon.

1. The Introduction screen appears. Click Continue.

2. The Readme file appears. This file contains information that 
was too recent to be included in this manual. Please take 
a moment to read this file, as the changes outlined therein 
may affect how you install and/or use Poser. When you have 
finished reading the Readme file, click Continue to proceed 
with the installation.

3. The “Poser End User License Agreement (EULA)” on page 
12 appears. Click Continue. Click Agree to continue the 
installation.

4. The Installation Type screen appears. Check or uncheck the 
content types you want to install (Default Content, Clothed 
and Reference Figures, Clothing, Hair, Nude Figures, 
Props and Scenery, Cartoon and Fantasy Figures, and 
Animals:

5. Click Continue after you choose the content you want to 
install.

6. Setup informs you how much space will be used by the 
installation, including the content you selected. Click 
the Change Install Location button to choose another 
installation location, if desired and click Continue to return 
to the previous screen.

7. Once you have made your selection, click the Install button. 
The Authentication window appears, and you will be 
asked to enter your user account password, or an account 
name and password with Administrator privileges, in 
order to proceed with the installation. After entering the 
information, click OK to continue.

8. When the installation is complete are finished installing, 
click Quit.
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Installing Queue Manager
The Queue Manager can be installed as part of your initial Poser 
Pro installation using the Full Installation (Windows) or Easy 
Install option (Mac). You can install just the Queue Manager on 
remote systems by following the instructions below:

Installing Queue Manager on a Remote 
System (Windows)

1. Click on the Poser Pro installer to start the installation.

2. The Welcome screen will appear, click Next to continue.

3. The “Poser End User License Agreement (EULA)” on page 
12 will appear. Accept the agreement and click Next.

4. Review the Readme text and click Next.

5. Select the destination location where you want to install the 
Queue Manager. You can use the default location or click 
the Browse button to specify another location. Click Next to 
continue.

6. Using the pull-down menu select Queue Manager and click 
Next.

7. Select Additional Tasks screen will appear. Enable the 
check boxes to create desktop icons for both Poser Pro and 
the Queue Manager, click Next.

8. Click Install to install the Queue Manager. When the 
installation is done, click Finished.

Installing Queue Manager on a Remote 
System (Mac)

1. Click on the Poser Pro installer to start the installation.

2. The Welcome screen will appear, click Continue.

3. The “Poser End User License Agreement (EULA)” on 
page 12 will appear. Accept the agreement and click 
Continue.

4. Review the Readme text and click Continue.

5. Select the destination location where you want to install the 
Queue Manager. You can use the default location or click the 
Browse button to specify another location. Click Continue.

6. Using the pull-down menu select Queue Manager and click 
Continue.
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7. Click Install to install the Queue Manager. When the 
installation is done, click Quit.

Licensing

The first time you start the Queue Manager, you will be 
prompted to type in your name and your Queue Manager 
serial number in the Queue Manager Personalize screen. It is 
important to know that you can install the Queue Manager on as 
many systems as you wish. However, the number of systems you 
can use simultaneously will be limited to the number of Queue 
Manager nodes that are included with your Poser Pro purchase. 
You can determine how many nodes are available to you by 
looking at your Queue Manager serial number. The second 
set of numbers between dashes indicates how many systems 
(including the one on which Poser Pro is installed) can operate 
the Queue Manager simultaneously.

Upgrading From an Earlier Version of 
Poser
When upgrading from an earlier Poser version, be sure to 
install Poser in a separate, empty folder, so as not to interfere 
with existing Poser installations. Additionally, if you have large 
amounts of content from your previous versions of Poser, the 
ideal way to add this content to your Poser installation is with 

the Add Runtime feature. (See “Accessing Different Content 
Libraries” on page 131 for more information about the Add 
Runtime feature.) We do not recommend attempting to copy 
over or reinstall your content in other ways, as we cannot 
guarantee that the content will be properly transferred to Poser.

Registering Poser
After installation, you can choose to register your copy of Poser 
via the Web. Registering Poser with Smith Micro Software is 
required in order to receive technical support, free product 
updates and other benefits.

1. If you wish to register your copy of Poser, simply check the 
box on the authentication window that appears upon your 
initial launch of Poser, and Poser will automatically register 
your product for you with Smith Micro Software. If you use 
this method, this is the only action necessary on your part; 
the rest will be taken care of automatically.

2. Alternately, you can open your browser and navigate 
to http://www.smithmicro.com/support/product-
registration.aspx. In the unlikely event you receive an error, 
please wait a while then try again. If you get repeated errors 
or if you do not have an Internet connection (or prefer 
to register via email), you may call or email Smith Micro 
Software to complete your registration.

http://www.smithmicro.com/support/product-registration.aspx
http://www.smithmicro.com/support/product-registration.aspx
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3. Select the version of Poser that you wish to register from the 
drop-down list, and click the Next button to continue.

4. Enter your user information in the form that appears in 
your browser. Fields marked in red are required for you to 
register your copy of Poser. Enter your information, then 
click Register to complete your registration.

5. If one or more fields are missing information, a message 
will display specifying the incomplete fields. You will be 
asked to add the necessary information and resubmit your 
user information. Once your registration is successful, a 
summary screen will appear. Thank you for using Poser by 
Smith Micro Software!

Updating Poser
Smith Micro Software is committed to supporting all of our 
products by releasing Service Releases and other updaters that 
address issues present in earlier versions and/or enhance the 
product’s usability or functionality. Poser will automatically 
check for product updates upon launching, and will notify 
you when an update is available. Please visit http://poser.
smithmicro.com/updates.html to download the latest updates.

If you wish to disable the automatic update notification, you may 
do so by clearing the Check for Updates on Launch checkbox 
in the General Preferences dialog.

If you choose not to receive automatic notifications, please visit 
http://poser.smithmicro.com/updates.html regularly to check 
for product updates.

Alternately, you can click the Check Now button in the General 
Preferences dialog to execute an immediate update check. 
(See “Setting Application Preferences” on page 32 for more 
information about the General Preferences dialog.)

Project Selection
Upon launching Poser, you may want to choose Window > 
Quick Start to view the Quick Start dialog. This dialog allows 
you to select a Project to load into the Project Guide palette 
within Poser. A Project is an interactive guided workflow that 
you can use for guidance or reference as you undertake specific 
tasks within Poser. Click the icon for the Project you wish to 
select, or choose a Project from the pop-up menu for more 
options. Once you have selected a Project, click OK to close the 
dialog and complete your launch of Poser.

http://poser.smithmicro.com/updates.html
http://poser.smithmicro.com/updates.html
http://poser.smithmicro.com/updates.html


Poser Pro 2014
Reference Manual 

30

Chapter 2: Installing Poser

 Quick Start window.

Should you choose to load a different Project once Poser has 
launched, simply select Window > Quick Start to open the 
Quick Start dialog and change the current Project in the Project 
Guide palette.

Project Guide
Use the arrows at the top of the Project Guide palette to 
navigate through a Project. Click on the right arrow to step 
forward through the pages of the Project, or on the left arrow 
to step backwards through the pages. The current page number 
and title will be displayed in the center between the navigation 
arrows. The page content, as well as any associated actions by 

the Poser application, will be specific to the Project you choose 
to load.

 Project Guide.

The projects in the Project Guide are interactive 
workflow guides, which means that you, the 

user, perform the tasks described within them. However, 
some steps may include actions automatically 
undertaken by Poser to assist you in following the 
processes described.

The Project Guide palette functions in the same manner as 
all palettes within Poser; once enabled, it will remain open 
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and accessible. You may choose to interact with the Project 
Guide at your own pace, either stepping through a given Project 
methodically or returning to the Project intermittently within the 
process of your own workflow. As such, the Project Guide is a 
flexible tool designed to meet a variety of work styles and needs. 
Should you decide to close the Project Guide palette, simply 
click on the close icon in the upper right corner of the palette. 
You can then reopen the palette at any time by selecting Window 
> Project Guide from the Poser menu bar.



Poser Pro 2014
Reference Manual 

32

Chapter 3: Setting Up the Poser Workspace

Chapter 3: Setting Up the 
Poser Workspace

This chapter discusses the ways in which you can customize 
Poser to suit your individual needs. Your preference settings will 
be stored on your system in the home directory for your user 
name. This allows different users on the same system to set up 
their own individual preference settings. For specific information 
on the location of the preference files on your system, please see 
“Poser Default File Locations” on page 850.

Setting Application Preferences
Poser’s General Preferences dialog allows you to control 
certain global Poser settings. Open this dialog by selecting Edit 
> General Preferences. The General Preferences dialog 
appears.

Click the OK button when finished to save your preferences 
and close the dialog. The following topics describe the available 
preferences.

Document Preferences

The Document Preferences tab contains settings specific to the 
Document window. The Document Preference options are as 
follows:

 Document Preferences.

• Launch Behavior: The Launch Behavior options allow you 
to specify whether the Document window will open using 
your customized preferred settings, or the default factory 
settings, whenever you launch Poser. If you customize the 
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Document window by resizing and/or moving it, or by 
changing the character that loads when you start Poser, 
selecting the Launch to preferred state radio button after 
you have adjusted the Document window will save these 
changes when you exit and re-launch Poser. If you want 
your Document window to revert to its default (as installed) 
location and size whenever you launch Poser, select the 
Launch to factory state button. Please refer to “Chapter 
5: The Document Window” on page 72 for more 
information about the Document window.

• Set Preferred State: Click this button after you arrange 
your document window the way you like. This will save it as 
the preferred startup state

• Undo/Redo: The Undo/Redo options allow you to specify 
the maximum number of levels for the Undo/Redo cache. 
By default the cache size is set to 100 levels of Undo. You 
can leave this setting at 100 if you have available system 
resources, or you can reduce the level to conserve memory. 
Clicking the Clear cache now... button will clear the Undo/
Redo cache.

• Smoothing Preferences: The Default Crease Angle 
setting allows you to specify the default Crease Angle to 
be used in polygon smoothing calculations. Please refer to 
“Smoothing Geometry” on page 422 for more information 
on the Crease Angle setting.

• Optimizations: The Multithreaded Bending setting is 
off by default. When enabled the feature will attempt to 
parallelize the computations across multiple threads during 
bending, this will produce faster bending by better utilizing 
multi-threads and multi-core CPUs.

Interface Preferences

The Interface Preferences tab contains application-level 
settings for Poser’s general user interface. The Interface 
Preference options are as follows:

 Interface Preferences.
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• Launch Behavior: If you customize the Poser interface by 
adding, removing, rotating, resizing, and/or hiding different 
elements, or by creating your own palette arrangements in 
any of the Poser rooms, selecting the Launch to previous 
state radio button after making your changes will save the 
changes when you exit and re-launch Poser. If you want 
your Poser interface to revert to its default (as installed) 
location and size whenever you launch Poser, select the 
Launch to factory state button.

• Mouse Input: The Tablet Mode option decreases the 
sampling rate for greater accuracy when using a graphics 
tablet as the input device. If your button has a scroll wheel, 
you can check the Scroll to Zoom option to zoom in and out 
of your scene. Uncheck the option to disable this feature.

If you wish to operate Poser with a graphic 
tablet, please make sure to activate Tablet Mode 

in Edit -> General Preferences -> Interface -> Mouse 
Input.

• Object Popup Menu: When you use the Object Popup 
menu to select an actor in your scene, the menu arranges 
them in a series of submenus. The value entered in the 
Hierarchical Threshold field determines the maximum 
number of actors that are allowed to appear in a menu item 
before they appear in a branch beneath the previous level. 

Lower values increase the number of submenus. If you want 
all items to appear in a single level in the hierarchy, enter a 
higher value such as 200.

 Object Popup menu hierarchy.
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• Display, Color Blind Accessible: Check this option to use 
an interface that is designed for those who are color-blind.

• Display Units: Poser allows you to work with real-world 
units, enhancing your ability to make accurate recreations. 
Use the Display units pull-down menu to make your 
selection. The available choices are:

 � Poser native units

 � Inches

 � Feet

 � Millimeters

 � Centimeters

 � Meters

One Poser native unit is the equivalent of 8.6 feet, 
or 262.128 centimeters.

• 3D Mouse: The 3D Mouse options control the behavior of 
a 3D input device such as 3Dconnexion’s SpaceNavigator. 
Checking the Reverse Cameras box changes the direction 
the main and auxiliary cameras rotate when using a 3D 
mouse. Checking the Reverse Dolly Cameras box reverses 
the direction the dolly cameras rotate when using a 3D 

mouse. Checking the Reverse Actors box reverses the 
direction actors move when controlled with a 3D mouse.

When using a 3D Mouse (such as 
SpaceNavigator or similar), by default all 

rotation axes and translations will be transmitted. 
Holding down the Shift key will filter out translations, 
and holding down the CTRL key (Windows) or CMD key 
(Mac) will filter out rotations.

Library Preferences

The Library Preferences tab contains setting that are specific 
to the Poser Library. The Library Preference options are as 
follows:
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 Library Preferences (Poser Pro).

• Double-click Behavior: The Double-click Behavior 
setting specifies the results of double-clicking on a Library 
preset. Select the appropriate radio button to choose 
between adding the new preset to the scene, or replacing 
the selected preset in the scene. Note that the first time 
you double-click on a Library preset, a dialog will come up 
allowing you to specify this setting. Your selected option will 
then be applied to all subsequent double-click instances, 

unless you change the setting in the Library Preferences 
tab.

• File Search: When an object is loaded from the Library, 
Poser searches for all the associated files included with that 
object. The File Search options allow you to configure the 
extent of that search. These options are:

 � None: Selecting None disables file searching; this 
option is useful for content developers in testing the 
accuracy of newly developed content, as it checks only 
the file locations that are specified in the Poser files. 
Referenced files will also be found next to a scene 
document when search policy is set to None.

It is recommended that content developers set 
the File Search to None when testing the 

packaging of content that is intended for distribution. 
Doing so will help determine if geometry files and 
textures appear in the correct locations and paths as 
designated within the library files. Error messages will 
display when content files are not in their expected 
locations.

 � Shallow: Selecting Shallow will reduce the amount of 
time spent searching for missing or mislabeled files, but 
will increase the instances of files not found. This option 
looks in all runtimes for the item, using the relative 
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path and filename provided. For example, if the file 
specified is Runtime/geometries/FolderA/ObjectA.obj 
but the file actually lives in an external runtime folder 
named C:/MySpecialFolder/Runtime/geometries/
FolderA/ObjectA.obj, then the shallow search will find 
it. The Shallow search will also find ObjectA.obj in any 
directories that are already known by Poser.

 � Deep: This is the default File Search setting. We 
recommend that you select Deep file searching, as this 
option initiates the most extensive searches for content 
file components, hence increasing the likelihood that 
missing or mislabeled files will be found. This performs 
a thorough search in all Runtime folders.

If your Runtime folders are extremely large, 
resulting in Deep search results that take too 

long to find missing files, consider changing to a Shallow 
search.

• Pose Sets: By checking the Apply Universal Poses box, 
poses saved to the library will be automatically written as 
universal poses, and library poses applied to figures by 
double-clicking will always be applied as universal poses.

• Launch Behavior: Controls how the library launches.

 � Embedded: By default, the library is embedded and 
works internally with Poser Pro. You can dock and float 
the Library Palette the same as other palettes in the 
interface.

 � External: Check this option if you want to run the 
library as an external application. You will not be able 
to dock and undock the library palette, but will be able 
to position it on a second monitor if desired.

 � Foreground Poser on item load: Check this option 
to bring Poser to the foreground after a library item 
is loaded. With the option unchecked, focus remains 
in the library until you manually switch to the Poser 
application to continue with your scene.

Render Preferences

The Render Preferences tab contains settings that are specific 
to the FireFly render engine. The Render Preference options are 
as follows:
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 Render Preferences.

• Number of Threads: If you have a multi-processor and/
or multi-core hardware system, you can take advantage 
of multi-threaded rendering by setting the Number of 
Threads slider to a value greater than one.

We recommend rendering your scene with as 
many threads as your system possesses CPU 

cores. The default value for hyper-threaded CPUs is 
twice the number of cores that you have (because the OS 
sees twice as many virtual cores as there are physical 
cores). On CPUs that are not hyper-threaded, the OS 
sees only the physical cores. If you are unsatisfied with 
the resulting performance, or if the render fails to 
complete, then reduce the number of threads and/or 
maximum bucket size. However, if you have a single-
processor and single-core system, we recommend that 
you set the number of threads to one, as the increased 
memory demand of running parallel threads may offset 
the performance benefits.

For more information on multi-threaded 
rendering, see “Chapter 19: Using The FireFly 

Render Engine” on page 404.

• Separate Process: Checking the Separate Process box 
enables running FireFly renders in a separate process on the 
CPU, and vice versa. This feature is disabled by default. For 
more information on Rendering in a Separate Process, see 
“Chapter 19: Using The FireFly Render Engine” on page 
404.
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• Cache: The Max Cached Renders setting allows you to 
configure the number of renders that will be cached for 
access via the Render Compare feature in the Document 
window’s Render tab, or the number of thumbnails that are 
displayed in the Recent Renders palette. Please see “Render 
Comparison” on page 101 for more information about the 
Render Compare feature, and “Displaying Recent Renders” 
on page 102 for more information about the Recent 
Renders palette.

• Texture Caching: Cached textures are kept in the temp 
location specified in General Preferences, even between 
sessions.

• Persistent size (MB): The maximum amount of memory 
allocated to cached textures, in between sessions. When 
you re-launch Poser, textures from the previous session are 
still cached on disk (unless you set the size to zero). If you 
re-open the scene you worked on previously (or one of the 
recent scenes, if the cache is large enough) the texture cache 
will be prepared already, allowing for a faster render start.

 � Run in Background Thread: Loads textures into the 
cache while Poser is running, in preparation for the first 
render. Any texture that is not yet in the cache, or not 
yet up to date in the cache, needs to be processed. If 
Run in Background Thread is enabled, this processing 
happens in a separate thread in the background (on 

multi-core CPUs only). Chances are that by the time 
you are done preparing the scene for rendering, all your 
textures are in the cache already, and rendering will 
start immediately.

The render cache for keeping rendered images and displaying 
them on the Render tab of the Document window and in the 
Recent Renders Palette uses the following locations to store 
image data:

Windows:
%AppData%\Poser Pro\10\RenderCache\

Windows XP example:
C:\Documents and Settings\<PoserUser>\Application 

Data\Poser Pro\10\RenderCache\

Windows Vista & 7 example:
C:\Users\<PoserUser>\AppData\Roaming\Poser Pro\10\

RenderCache\

Mac OS X:
~/Library/Application Support/Poser Pro/10/

RenderCache/

Mac OS X example:
/Users/<PoserUser>/Library/Application Support/Poser 

Pro/10/RenderCache/

You can delete the files in those folders to clear the render cache. 
Please note that your cached renders will be lost after doing so. If 
you reinstall Poser Pro and choose to back up your preferences, 
the render cache will be moved into its backup location along 
with all preferences.
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Miscellaneous Preferences

 Miscellaneous Preferences.

• Save Files: Poser offers the following options for file saving:

 � Use File Compression: Poser includes the ability to 
save compressed runtime files and scene files using 
“zlib compression”. This compression will significantly 
reduce the size of your runtime directory and save 
valuable hard drive space. These compressed files will 
act identically to non-compressed runtime files when 

used in Poser Pro. To enable file compression, check 
the “Save Compressed Files” option. Poser will open 
both compressed and non-compressed files, but writes 
compressed files using specific file extensions.

Compressed Poser files can be opened by Poser 
versions running Poser 4 Pro Pack or later. Zlib 

compression is similar to gzip and zip compression 
methods, and can typically be uncompressed by any 
utility (such as WinZip) that handles either of these 
formats.

Please note that all content included withPoser 
Pro is compressed.

For more information on zlib, please refer to 
http://www.info-zip.org/pub/infozip/zlib/. To 

uncompress a file, change the extension on the file you 
wish to access to .gz, then run your decompression 
utility. Alternatively, you can use the included 
PoserPython decompression script by launching Poser 
and opening the Python Scripts window.

http://www.info-zip.org/pub/infozip/zlib/
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All Poser files (scene, figure, pose, expression, 
hair, hand, prop, light, camera, material) can be 

compressed. Compressed Poser files have the extension 
*.**Z (*.PZZ, *.CRZ, *.FCZ, etc.). Poser prop files are 
saved with the extension P2Z to avoid confusion with 
compressed scene files.

If you plan to distribute files for use by artists 
with Poser 4 and earlier, please be sure to save 

them uncompressed. To do so, uncheck the Use File 
Compression option in the Misc Preferences tab.

Poser uses standard Z-lib compression, allowing 
you to use any Z-lib compatible compression/

decompression application to compress/decompress 
files.

Some advanced artists use a text editing 
application to directly edit Poser files. You must 

uncompress compressed files before editing them. To do 
this, you can either load a file into Poser, disable 
compressed file support, and save the results to a new 
filename or use a third-party compression utility to 
uncompress the file. If you use the second method, you 
can recompress the file when you’ve finished making 
edits.

 � Use External Binary Morph Targets: Checking this 
box will enable the use of External Binary Morph 
Targets (EBMTs) when saving new content, or resaving 
legacy Poser files. Saving legacy figures to the Poser 
Library with this option enabled will generate new 
.PMD EBMT files for those figures, thus allowing you 
to take advantage of morph target sharing, reduced 
file sizes, and faster processing speeds for your legacy 
figures.

• Set Python Editor: Clicking the Set Python Editor button 
opens a standard Browse dialog, allowing you to select 
the application you wish to use to edit PoserPython scripts 
(such as Notepad for Windows).

• Software Updates: Checking the Check for Updates on 
Launch box enables the Automatic Update Notification 
feature (see “Updating Poser” on page 29 for more 
information about this feature). Clearing the box disables 
Automatic Update Notification. Clicking the Check Now 
button will execute an immediate update check.

Setting Up Your Workspace
The Poser workspace consists of the entire Poser screen, 
including controls, the Document window, and other room-
specific interface elements. You can customize most of these 
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elements to suit the way you work and store your preferences for 
later use.

Docking and Floating Palettes

Poser’s sleek interface is geared toward streamlining your 
workflow. You can dock, float, and arrange floating palettes in 
each of Poser’s different rooms, to set up a workspace layout that 
meets your needs.

The Window menu contains commands that show or hide 
Poser’s many palettes. If a palette is hidden, simply select the 
desired palette from the Window pull-down menu to display it.

The options in the Window > Room Tools 
submenus are enabled only when the respective 

room is active. For example, the commands in the 
Window > Room Tools > Face submenu will only be 
enabled when you are in the Face Room.

The upper-right corner of each palette contains a Palette 
Docking Control square. Click the square to open the palette 
docking menu, which contains commands that work as 
described below.

 Palette Docking menu options.

Moving, Repositioning, and Resizing Palettes

Various controls allow you to resize docked or floating palettes, 
or reposition them as necessary. For example:
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 Resizing handles for palettes.

• To resize a docked palette, position the cursor over the 
resize handle and drag in either direction indicated by the 
double-arrow resize cursor.

• To resize a floating palette, position your cursor over a side 
or corner, where it turns into a double-arrow resize cursor. 
Then drag to the desired size.

• To reposition a palette, position the cursor in the Title area 
of the palette, where it turns into a hand. Reposition the 
palette to another area on your screen. If the area that you 
drag to is highlighted in blue, the palette will dock into the 
highlighted area of your workspace. If the area that you drag 
to is not highlighted, the palette will float in the new area 
when you release the mouse button.

• Some palettes display scroll bars when they contain more 
information than can be displayed in the allotted space.

• Some palettes (such as the Editing Tools or Display Styles 
palettes) display options that wrap based on the width of the 
palette.

• Some palettes cannot be reduced beyond the minimum size 
required to display all of the palette options and controls. 
For examples, see the Camera Controls or Light Controls 
palettes.
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Enabling or Disabling Docking

To enable or disable palette docking:

• Click the Palette Docking Control square at the top-right 
corner of the palette. Check or uncheck Drag-Docking 
Enabled as appropriate. This selection is checked when 
docking is enabled, and not checked when disabled.

When Drag-Docking is disabled, you can move 
the palette anywhere on the screen over the main 

workspace or to an additional monitor. The palette will 
always float until you enable drag-docking again.

Docking Palettes

To dock a palette, use one of the following methods:

• Drag the palette toward the area in which you want to place 
it. When the area becomes highlighted, release the mouse. 
If you drag the palette into an area that is already populated 
by one or more palettes, the active docking area will split 
horizontally or vertically to provide a location for the 
additional palette.

• Click the control at the top-right corner of floating palette, 
and choose Docked from the menu. The palette will dock 
into the position where it was last docked.

Floating Palettes

To float a palette, use one of the following methods:

• Drag the palette out of the docked location, and toward the 
document window. Release the mouse when there is no 
highlighted dock location for the palette.

• Click the control at the top-right corner of a docked palette, 
and choose Floating from the menu. The palette will float in 
the Poser workspace.

Closing Palettes

To close an open palette, use one of the following methods:

• Click the Close icon in the upper-right corner.

• Click the control at the top-right corner of the palette and 
choose Close from the menu that appears.

• Choose an open palette from the Window pull-down menu 
to close it. Palettes that are currently open are indicated by 
a check mark.

UI Memory Dots

You can save up to nine interface configurations using the 
Memory dots (described in “Memory Dots” on page 56). 
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Each Memory dot retains a separate instance of your selected 
interface settings. This feature is globally applicable, meaning 
that UI dots can be applied regardless of the specific scene or 
resolution. An alternative method for saving UI settings for 
accessibility in any Poser scene is to modify Poser’s general 
preferences as described in “Setting Application Preferences” 
on page 32. However, while preferences set in this manner 
are saved separately for each screen resolution, you can only 
save one UI configuration per resolution using the general 
preferences.

Setting Up the Document Window

Please refer to “Chapter 5: The Document Window” on page 
72 for more information on customizing the Document 
window and using the controls found there.

Using the Log Window
The Log window enables you to view a list of ongoing commands 
as you use them in Poser. You can filter these comments on 
various criteria (timestamp, category, application commands, 
group selections, warnings, and debug information). This 
information can be useful when you are trying to troubleshoot a 
problem with Technical Support.

To display the Log window, choose Window > Log.

The window can be docked or undocked to the 
workspace by using the palette context menu. 

Click the square in the upper-right corner of the palette 
to display the docking options.

If a crash occurs and you can’t get to the log 
window, you can copy the recent history from 

Users\<user>\AppData\Local\Temp\Poser Pro\10\
Poser.log



Poser Pro 2014
Reference Manual 

46

Chapter 3: Setting Up the Poser Workspace

 Log Window.
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Part 2: Building 
Scenes
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Chapter 4: The Pose 
Room

The Pose room is the focal point for much of your Poser 
activity. This is where you add figures and props to your scene 
and perform your desired posing and animation (you’ll use the 
Hair, Cloth, Material, and Face rooms to set up and animate 
these items and can access the Library palette from any room). 
This chapter introduces you to the basic Poser interface. The 
following chapters will describe these interface elements in 
greater detail, and then will move on to discussing the other 
rooms in Poser.

The Pose room appears as follows at 1920 x 1200 resolution.

The number of palettes and options that you see 
in each room depends upon your screen 

resolution. At higher resolutions, the default work 
spaces display more palettes, while at lower resolutions 
you see fewer palettes.

 The Pose Room.

In addition to rooms, much of Poser’s functionality is available 
by using floating palettes and windows within the rooms 
themselves. Most Poser rooms (including the Pose room) allow 
you to customize your Poser workspace by hiding/displaying 
and relocating controls anywhere you like. You can even save 
up to nine different screen configurations for the entire Poser 
workspace.

The numbers on the image above identify the controls available 
in the Pose room:

• Menu bar (1)
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• Light controls (2)

• Camera controls (3)

• Room tabs (4)

• Editing tools (5)

• Document window (6)

• Display controls (7)

• Properties & Parameters palettes (8)

• UI dots (9)

• Animation controls (10)

• Library palette (11)

Please refer to “Setting Up Your Workspace” on page 41 for 
more information about creating and saving custom workspace 
layouts. The following sections provide a brief description of 
the labeled interface elements and references to more detailed 
information.

Menu Bar
The Menu Bar consists of a series of pull-down menus used for 
accessing Poser functionality. Some menus and/or submenus 
duplicate other on-screen interface elements. The Menu Bar 
appears as follows and is available from every Poser room.

 Poser’s Menu Bar.

Light Controls
The Light controls allow you to adjust lighting properties. Use it 
for such purposes as adding and removing lights, and specifying 
light colors and other light properties. The Light controls appear 
as follows.
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 The Light Controls.

Please refer to “Chapter 12: Lighting” on page 261 for more 
information about the Light controls.

Camera Controls
The Camera controls allow you to select and move one or more 
Poser cameras. There are two types of camera controls: View 
and Position.

 The Camera Controls.

The topmost controls are the View controls. Clicking one of 
these controls activates the Face, Left Hand, or Right Hand 
camera, as appropriate. You can also scroll through the list of 
available cameras. The controls beneath the hand controls are 
used to turn camera animation on or off, or to use the Flyaround 
camera. The Position controls appear below these controls and 
are used to move or rotate the currently selected camera. The 
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Camera Plane position controls move the camera along the 
X, Y, and/or Z axis, while the Trackball rotates the currently 
selected camera without changing its location in 3D space. To 
use the Camera controls, simply click and drag your desired 
control. Moving a camera does not change the locations or poses 
of figures, props, and other elements in your scene.

The Frame Selected button changes the camera view to fit 
around the currently selected actor. Pick a body part or actor, 
and then click the Frame Selected control to change the camera 
view to fit around the selected actor.

The Orbit Selected button rotates the camera around the 
currently selected actor. This control is a toggle. When toggled 
on, the camera will be centered on the selected object or body 
part and you can rotate the camera so that it is always in the 
center.

The Orbit Selected mode does not work with 
cameras that are already set to orbit a specific 

body part (such as the Face, Left Hand, and Right Hand 
cameras).

A subset of these Camera controls appears in the upper-right 
corner of the Document window. Please refer to “Chapter 11: 
Cameras” on page 242 for complete information about the 
Camera controls.

Room Tabs
The Room tabs allow you to switch from room to room within 
Poser. To enter a room, simply click its tab.

 Room Tabs.

Editing Tools
The Editing Tools display contains the tools you use most often 
when posing figures/props.

By selecting a body part or prop followed by the desired Editing 
tool, you can pose objects in various ways such as translating 
(moving side to side or back and forth), rotating, twisting, etc. 
You can also perform other functions such as editing Inverse 
Kinematic (IK) chains and working with element/material 
groups. Each Editing tool is a little different, but their basic 
usage is as follows:
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 The Editing Tools.

1. Select your desired body part or prop (referred to as an 
element or actor) in your scene by clicking that actor.

2. Select the desired Editing tool. You can only have one 
Editing tool selected at a time. The currently selected 
Editing tool appears yellow within the Poser interface.

3. Click and drag to perform the selected tool’s function.

You can use the Editing tools in any combination to create a 
virtually infinite number of still or animated poses. Please refer 
to “The Editing Tools” on page 184 for more information on 
the Editing tools. In addition, each tool is discussed in depth 
where appropriate in this manual.

Document Window
The Document window is your viewport into the Poser 
workspace where you view and pose your figure and interact 
directly with your scene. Each view of the Document window is 
displayed through a virtual camera, which means you can view 
each scene from multiple camera angles, either one at a time or 
from up to four angles at once.

You can position cameras to view your scene from any angle 
or distance and can resize the Document window to suit your 
needs. In addition, the Document window has numerous 
controls around its edges that you use to change the appearance 
of scene elements. You can also select objects within your scene 
by clicking them directly within the Document window or by 
using the menus on the bottom of the window. Please refer to 
“Chapter 5: The Document Window” on page 72 for more 
information about the Document window.
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 The Document Window.

Display Controls
The Display controls allow you to select your desired preview 
mode for your entire scene, a figure or prop, and/or specific 
elements of your currently selected figure/prop.

 The Display Controls.

Please refer to “Chapter 6: The Display Controls and Menu” on 
page 105 for more information about the Display controls.

Parameters/Properties Palette
Poser offers an easy-to-use Parameters and Properties palette 
that allows you to access any scene object’s properties and 
parameters in one convenient location.
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 Parameters Palette.

To switch between the Properties and Parameters palettes, 
simply click the desired tab at the top of the palette.

Although both properties and parameters 
appear in the same palette, we will treat them as 

separate entities throughout this manual for clarity.

Parameters Palette
The Parameters palette contains all of an object’s parameters 
transformation settings, (as described in “Parameters Palette” 
on page 197) and morph targets. Each object type has 
specialized parameters, which are described where appropriate 
in this manual. Further, individual objects can have parameters 
unique to that object. For example, different figures have 
different morph targets available.

Properties Palette
The Properties palette contains all of an object’s properties. In 
addition to certain universal properties (which are described 
in “Properties” on page 192, each object type has specialized 
properties, which are described where appropriate in this 
manual.

Library Palette
The Library palette consists of three tabs.
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The Library tab contains all of the various categories of content 
from which you can choose.

• The Search tab allows you to perform keyword searches 
through one or all of your runtimes.

• The Favorites tab gives you quick access to your favorite 
content.

Library Tab

The Library tab contain Poser’s Library content categories. The 
Categories icons allow you to access and search through all 
of the content available to your installation of Poser, including 
content included with Poser and any additional content you may 
have obtained. The Library tab contains categories (Figures, 
Props, etc.) and subcategories (Animals, New Figures, etc.) 
for organizing your Poser content: You can also organize your 
favorite content in the Favorites tab for even quicker access.

Use the Library tab to add or remove elements from your Poser 
scenes. The vast collection of content included with Poser allows 
you start building scenes right away. The Library makes it easy 
to add existing and new content collections so that you can find 
and add any items to your scene. Please refer to “Chapter 7: The 
Poser Library” on page 122 for more information about the 
Library palette and to “Changing the Library Appearance” on 

page 127 for information on how to show and hide the various 
elements in the Library tab.

Poser ships with a wide array of content that 
you can use to create thousands of unique still 

and animated scenes. You can also use the Content 
room to locate and obtain even more free and for-sale 
content from leading 3D marketplaces! Please refer to 
“Chapter 8: The Content Room” on page 173 for more 
information about the Content room.

 Library tab.
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Search Tab

Use the Search tab to perform keyword searches on one or all 
of your Runtime libraries. This powerful new features makes it 
easier to find the content you want to use, even in large content 
collections. You’ll find more information in “Searching the 
Library” on page 167.

Favorites Tab

The Favorites tab on the Library palette provides quick access 
to your favorite Poser content. For more information about 
adding favorites, see “Favorites Tab” on page 171

Memory Dots
Being able to customize your workspace wouldn’t be useful if you 
had no way of saving your preferences. Poser includes Memory 
dots that allow you to save poses, camera locations, and user 
interface (UI) preferences and to switch between saved items 
with a single mouse click.

 Memory Dots.

Clicking the arrow to the left of the description allows you to 
choose between the Poses, Camera, and UI memory dots that 
you have saved.

 Memory Dots options.

Please refer to the following for more information on each type 
of Memory dot.

• Pose Dots: Pose dots are described in further detail in 
“Pose Dots” on page 211.
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• Camera Dots: Camera dots are described in further detail 
in “Camera Dots” on page 259

• UI Dots: UI dots are described in further detail in “Setting 
Up Your Workspace” on page 41.

Using Memory Dots

To use Memory dots:

1. Set up your pose, cameras, and/or interface (UI) the way 
you want them.

2. Use the pull-down menu to select the dot type, as described 
above.

3. Click an empty memory dot. This dot will appear full, as 
shown below.

 Filled, empty, and selected Memory Dots.

To use a dot, simply click it. The stored settings are applied to 
your scene. To clear a memory dot (delete its information and 
make it appear empty again), press and hold [OPT]/[ALT] while 
clicking the memory dot you wish to erase.

Animation Controls
The Animation controls allow you to preview animations and 
set up keyframes. You do this by posing your figure, moving to 
a new frame, and changing the pose. Clicking the Play button 
plays an animation using the keyframes. The Animation 
controls appear as follows:
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 Animation Controls.

Please refer to “Using the Animation Controls” on page 450 
to learn more about the Animation controls, and to “Chapter 
22: Animating with Poser” on page 447 for more information 
about creating and rendering animations using Poser.

Showing and Hiding Windows and 
Palettes
The Window menu allows you to enable and disable (show and 
hide) various Poser windows and palettes. The upper portion of 
the Window menu contains the following commands:

The palette options that are displayed in each 
room vary, depending on your screen resolution 

or upon which room you have displayed.

 The Window menu shows and hides windows and palettes.

• Animation Palette: Selecting Window > Animation Palette 
opens the Animation palette. Please refer to “Using the 
Animation Palette” on page 454 for information about the 
Animation palette and creating Poser animations.

• Graph: Selecting Window > Graph opens the Graph 
palette for the selected element in your scene. Please refer 
to “About the Graph Palette” on page 459 for information 
about using the Graph when making Poser animations.
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• Libraries: Selecting Window > Libraries opens the Library 
palette. Please refer to “Chapter 7: The Poser Library” on 
page 122 for more information about the Library palette.

• Hierarchy Editor: Selecting Window > Hierarchy Editor 
opens the Hierarchy Editor palette. Please refer to “About 
Groups” on page 690 for more information about the 
Hierarchy Editor palette.

• Joint Editor: Selecting Window > Joint Editor opens the 
Joint Editor palette. Please refer to “Chapter 33: Working 
with Joints, Weights, and Skinning” on page 719 for 
more information about the Joint Editor palette.

• Sketch Designer: Selecting Window > Sketch Designer 
opens the Sketch Designer window. Please refer to 
“Chapter 20: The Sketch Designer” on page 440for more 
information about the Sketch Designer renderer.

• Walk Designer: Selecting Window > Walk Designer opens 
the Walk Designer window. Please refer to “Using the Walk 
Designer” on page 474 for more information about the 
Walk Designer window.

• Talk Designer: Choose Window > Talk Designer to open 
the Talk Designer window, described in “Using the Talk 
Designer” on page 482.

• Python Scripts: Selecting Window > Python Scripts 
opens the Python Scripts palette. Please refer to “The 
Python Scripts Palette” on page 842 for more information 
about the Python Scripts palette.

• Room Help: Selecting Window > Room Help opens an 
HTML window with information to assist you in using the 
Poser rooms.

• Quick Start Guide: Choose Window > Quick Start Guide 
to open the Quick Start Guide, described in “Project 
Guide” on page 30.

• Project Guide: Choose Window > Project Guide to open 
the Project Guide, described in “Project Guide” on page 
30.

• Recent Renders: Choose Window > Recent Renders to 
display a palette that contains thumbnails of the images 
that you most recently rendered. For more information, see 
“Displaying Recent Renders” on page 102.

• Physics Palette: Choose Window > Bullet Physics 
Controls to create physics simulations using Bullet Physics. 
See “Chapter 23: Using Bullet Physics” on page 493 for 
more information.

The lower portion of the Window menu contains commands that 
toggle frequently-used palettes on and off.
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 Window menu commands show and hide windows and palettes.

• Camera Controls: Selecting Window > Camera Controls 
toggles the Camera controls display on and off. A check 
mark next to this option indicates that the controls are 
currently displayed, and vice versa. Please refer to “The 
Camera Controls” on page 242 for more information 
about the Camera controls.

• Preview Styles: Selecting Window > Preview Styles 
toggles the Display controls display on and off. A check 
mark next to this option indicates that the controls are 
currently displayed, and vice versa. Please refer to “Chapter 
6: The Display Controls and Menu” on page 105 for more 
information about the Display controls.

• Editing Tools: Selecting Window > Editing Tools toggles 
the Editing tools display on and off. A check mark next 
to this option indicates that the controls are currently 
displayed, and vice versa. Please refer to “The Editing 
Tools” on page 184 for more information about the 
Editing tools.

• Light Controls: Selecting Window > Light Controls 
toggles the Light controls display on and off. A check mark 
next to this option indicates that the controls are currently 
displayed, and vice versa. Please refer to “Chapter 12: 
Lighting” on page 261 for more information about the 
Light controls.

• Memory Dots: Selecting Window > Memory Dots toggles 
the Memory dots display on and off. A check mark next 
to this option indicates that the controls are currently 
displayed, and vice versa. Please refer to “Memory Dots” on 
page 56 for more information about the Memory dots.
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• Parameters Palette: Selecting Window > Parameters 
Palette shows or hides the Parameters/Properties 
palette, which contains tabs for the Parameters palette 
and Properties Palette. A check mark next to this option 
indicates that the Parameters/Properties palette is 
currently displayed, and vice versa. Please refer to 
“Parameters Palette” on page 197 for more information 
about the Parameters palette, and to “Properties” on page 
192 for more information about the Properties palette.

• Animation Controls: Selecting Window > Animation 
Controls toggles the Animation controls display on and 
off. A check mark next to this option indicates that the 
controls are currently displayed, and vice versa. Please refer 
to “Using the Animation Controls” on page 450 for more 
information about the Animation controls.

• Log: Choose Window > Log to open the Log Window. 
See “Using the Log Window” on page 45 for further 
information.

• Raytrace Preview: Choose Window > Raytrace Preview 
to open the real-time Raytrace Preview window, discussed 
in “Real-time Raytrace Preview” on page 402

• Room Tools: The Room Tools submenus display options 
that are enabled when you are using the Material, Face, 

Hair, or Cloth room. The options for each room are disabled 
until you enter the room to which they apply.

 � Material: When you are in the Material room, a menu 
option allows you to show or hide the Material Palette. 
See “Chapter 14: The Material Room” on page 296 
for further information about the Material Palette.

 � Face: When you are in the Face Room, menu options 
allow you to show or hide the Face Preview, Photo 
Lineup, Texture Preview, Face Texture Tool, or Face 
Shaping Tool. These palettes are discussed in “Chapter 
24: Rendering Animations” on page 510.

 � Hair: When you are in the Hair Room, menu options 
allow you to show or hide the Hair Growth Groups, 
Growth Controls, Styling Controls, and Dynamics 
Controls palettes. These palettes are discussed in 
“Chapter 26: The Hair Room” on page 533.

 � Cloth: When you are in the Cloth Room, menu options 
allow you to show or hide the Cloth Simulation, Cloth, 
Cloth Groups, and Dynamics Controls palettes. 
These palettes are discussed in “Chapter 27: The Cloth 
Room” on page 550.

• Document Window Size: Selecting Window > Document 
Window Size opens the Preview Dimensions dialog 
allowing you to resize your Document window when it 
is floating. Please refer to “Chapter 5: The Document 



Poser Pro 2014
Reference Manual 

62

Chapter 4: The Pose Room

Window” on page 72 for information about resizing your 
Document window.

The Document Window is only resizeable when it 
is floating. When docked, the document window 

expands to fit into the space that is not used by docked 
palettes.

• Addons: Displays help and addon applications for and by 
third party PoserPython developers.

Keyboard Shortcuts
Keyboard shortcuts are available for many menu commands 
found in Poser. The following tables summarize the available 
keyboard shortcuts for each menu.

File Menu

Command Windows Mac
File > New CTRL+N CMD+N

File > Open CTRL+O CMD+O

File > Close CTRL+W CMD+W

File > Save CTRL+S CMD+S

File > Save As CTRL+Shift+S CMD+Shift+S

File > Print CTRL+P CMD+P

File > Exit CTRL+Q

Edit Menu

Command Windows Mac
Edit > Undo CTRL+Z CMD+Z

Edit > Redo CTRL+Shift+Z CMD+Shift+Z

Edit > Cut CTRL+X CMD+X

Edit > Copy CTRL+C CMD+C

Edit > Paste CTRL+V CMD+V

Edit > Restore > 
Element

CTRL+E CMD+E

Edit > Restore > 
Figure

CTRL+Shift+F CMD+Shift+F

Edit > Restore > Lights CTRL+Shift+L CMD+Shift+L

Edit > Restore > 
Camera

CTRL+Shift+H CMD+Shift+H

Edit > Restore > All CTRL+A CMD+A

Edit > Memorize > 
Object

CTRL+ALT+E CMD+ALT+E

Edit > Memorize > 
Figure

CTRL+ALT+F CMD+ALT+F
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Edit > Memorize > 
Lights

CTRL+ALT+L CMD+ALT+L

Edit > Memorize > 
Camera

CTRL+ALT+H CMD+ALT+H

Edit > Memorize > All CTRL+ALT+A CMD+ALT+A

Edit > Special 
Characters

CMD+ALT+T

Edit > Preferences* CTRL+N CMD+K

* Preferences command is found in the Poser Pro application 
menu in Mac systems

Figure Menu

Command Windows Mac
Figure > Drop to Floor CTRL+D CMD+D

Figure > Hide Figure CTRL+H CMD+H

Object Menu

Command Windows Mac
Object > Properties CTRL+I CMD+I

Display Menu

Command Windows Mac
Display > Camera 
View > Main Camera

CTRL+M CMD+M

Display > Camera 
View > From Left

CTRL+; (semicolon) CMD+; (semicolon)

Display > Camera 
View > From Right

CTRL+’ (apostrophe) CMD+’ (apostrophe)

Display > Camera 
View > From Top

CTRL+T CMD+T

Display > Camera 
View > From Front

CTRL+F CMD+F

Display > Camera 
View > Face Camera

CTRL+= (equal) CMD+= (equal)

Display > Camera 
View > Posing Camera

CTRL+, (comma) CMD+, (comma)

Display > Camera 
View > Right Hand 
Camera

CTRL+[ (left bracket) CMD+[ (left bracket)

Display > Camera 
View > Left Hand 
Camera

CTRL+] (right bracket) CMD+] (right bracket)

Display > Camera 
View > Dolly Camera

CTRL+/ (forward 
slash)

CMD+/ (forward slash)

Display > Fly Around CTRL+L CMD+L
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Display > Frame 
Selected

CTRL+Shift+= (equal) CMD+Shift+= (equal)

Display > Orbit 
Selected Mode

CTRL+0 (zero) CMD+0 (zero)

Display > Document 
Style > Silhouette

CTRL+1 CMD+1

Display > Document 
Style > Outline

CTRL+2 CMD+2

Display > Document 
Style > Wireframe

CTRL+3 CMD+3

Display > Document 
Style > Hidden Line

CTRL+4 CMD+4

Display > Document 
Style > Lit Wireframe

CTRL+5 CMD+5

Display > Document 
Style > Flat Shaded

CTRL+6 CMD+6

Display > Document 
Style > Cartoon w/
Lines

CTRL+7 CMD+7

Display > Document 
Style > Smooth 
Shaded

CTRL+8 CMD+8

Display > Document 
Style > Texture 
Shaded

CTRL+9 CMD+9

Display > Figure Style 
> Use Document Style

CTRL+ALT+0 (zero) CMD+ALT+0 (zero)

Display > Figure Style 
> Silhouette

CTRL+ALT+1 CMD+ALT+1

Display > Figure Style 
> Outline

CTRL+ALT+2 CMD+ALT+2

Display > Figure Style 
> Wireframe

CTRL+ALT+3 CMD+ALT+3

Display > Figure Style 
> Hidden Line

CTRL+ALT+4 CMD+ALT+4

Display > Figure Style 
> Lit Wireframe

CTRL+ALT+5 CMD+ALT+5

Display > Figure Style 
> Flat Shaded

CTRL+ALT+6 CMD+ALT+6

Display > Figure Style 
> Cartoon w/Lines

CTRL+ALT+7 CMD+ALT+7

Display > Figure Style 
> Smooth Shaded

CTRL+ALT+8 CMD+ALT+8

Display > Figure Style 
> Texture Shaded

CTRL+ALT+9 CMD+ALT+9

Display > Element 
Style > Use Figure 
Style

CTRL+Shift+0 (zero) CMD+Shift+0 (zero)

Display > Element 
Style > Silhouette

CTRL+Shift+1 CMD+Shift+1

Display > Element 
Style > Outline

CTRL+Shift+2 CMD+Shift+2

Display > Element 
Style > Wireframe

CTRL+Shift+3 CMD+Shift+3
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Display > Element 
Style > Hidden Line

CTRL+Shift+4 CMD+Shift+4

Display > Element 
Style > Lit Wireframe

CTRL+Shift+5 CMD+Shift+5

Display > Element 
Style > Flat Shaded

CTRL+Shift+6 CMD+Shift+6

Display > Element 
Style > Cartoon w/
Lines

CTRL+Shift+7 CMD+Shift+7

Display > Element 
Style > Smooth 
Shaded

CTRL+Shift+8 CMD+Shift+8

Display > Element 
Style > Texture 
Shaded

CTRL+Shift+9 CMD+Shift+9

Display > Depth Cued CTRL+Shift+D CMD+Shift+D

Display > Tracking > 
Bounding Boxes Only

CTRL+Shift+A CMD+Shift+A

Display > Tracking > 
Fast Tracking

CTRL+Shift+X CMD+Shift+X

Display > Tracking > 
Full Tracking

CTRL+Shift+C CMD+Shift+C

Display > Show 
Background Picture

CTRL+B CMD+B

Display > Guides > 
Ground Plane

CTRL+G CMD+G

Display > Preview 
Drawing > OpenGL 
Hardware

CTRL+ALT+O CMD+ALT+O

Display > Preview 
Drawing > SreeD 
Software

CTRL+ALT+S CMD+ALT+S

Render Menu

Command Windows Mac
Render > Render CTRL+R CMD+R

Render > Area Render CTRL+ALT+N CMD+ALT+N

Render > Antialias 
Document

CTRL+ALT+R CMD+ALT+R

Render > Render 
Settings

CTRL+Y CMD+Y

Render > Render 
Dimensions

CTRL+Shift+Y CMD+Shift+Y

Render > Materials CTRL+U CMD+U

Animation Menu

Command Windows Mac
Animation > Make 
Movie

CTRL+J CMD+J
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Window Menu

Command Windows Mac
Window > Animation 
Palette

CTRL+Shift+V CMD+Shift+V

Window > Graph CTRL+Shift+G CMD+Shift+G

Window > Libraries CTRL+Shift+B CMD+Shift+B

Window > Hierarchy 
Editor

CTRL+Shift+E CMD+Shift+E

Window > Joint Editor CTRL+Shift+J CMD+Shift+J

Window > Walk 
Designer

CTRL+Shift+W CMD+Shift+W

Window > Talk 
Designer

CTRL+Shift+K CMD+Shift+K

Window > Python 
Scripts

CTRL+Shift+O CMD+Shift+O

Window > Camera 
Controls

CTRL+Shift+R CMD+Shift+R

Window > Preview 
Styles

CTRL+Shift+U CMD+Shift+U

Window > Editing 
Tools

CTRL+Shift+T CMD+Shift+T

Window > Light 
Controls

CTRL+Shift+I CMD+Shift+I

Window > Memory 
Dots

CTRL+Shift+M CMD+Shift+M

Window > Parameter 
Dials

CTRL+Shift+N CMD+Shift+N

Window > Animation 
Controls

CTRL+Shift+P CMD+Shift+P

Other Basic Operations

Creating a New Scene

Selecting File > New creates a new Poser scene. A dialog will 
appear if you have any unsaved changes in your previous scene. 
If this dialog appears:

• Selecting Yes opens a Save Poser Scene dialog box, 
allowing you to save your current Poser scene. After saving 
your current scene, the new scene will be created.

• Selecting No creates a new Poser scene without saving your 
unsaved changes. All unsaved changes will be lost, so use 
this option carefully!

• Selecting Cancel closes the dialog and cancels the new 
scene creation, leaving your current Poser scene open.
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Opening a Scene

Selecting File > Open opens a standard Open dialog box, 
allowing you to access and work on a previously saved Poser 
scene file. You are prompted to save any unsaved changes in 
your current scene, if any (see above).

Opening a Recent File

Selecting File > Recent Files opens a pop-up list that displays a 
list of the ten most recent document files (.PZ3 or .PZZ formats) 
that you opened in Poser.

Closing Your Scene

Selecting File > Close closes your current Poser scene while 
leaving the Poser application running. You are prompted to save 
any unsaved changes in your current scene.

Saving a Scene

Selecting File > Save saves your current Poser scene using your 
previously specified filename and save location. If you have not 
previously saved your scene, Poser will open the standard Save 
As dialog box, allowing you to name and save your current Poser 
scene (see below).

Selecting File > Save As saves your current Poser scene 
allowing you to select a different filename and/or save location. 
This feature is useful for creating different versions of work, 
which allows you to return to any previous stage if you decide 
you don’t like your progress beyond a given save point. For 
example, you could save myscene_1.PZ3, then save new versions 
as myscene_2.PZ3, myscene_3.PZ3, and so forth.

Compressed File Support

Poser allows you to compress saved figures/props/scenes to 
save hard drive room. To enable compression support, select 
Edit > General Preferences, select the Library tab, and check 
the Use File Compression box as described in “Miscellaneous 
Preferences” on page 40.

Reverting Changes

Selecting File > Revert allows you to undo your changes and 
reopen your current scene file in its last-saved state. This is a 
great way to do your recent changes over, however you will lose 
everything you’ve done since the last time you saved your scene. 
This is why we recommend that you save your scene often and, 
if you think you may want to return to an earlier version, to save 
progressive versions of your work using the Save As command. 
Clicking Cancel returns you to Poser, and clicking Revert 
proceeds to load the last saved version of your current scene.
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Run Python Script

Selecting File > Run Python Script opens a standard Open 
dialog, allowing you to browse for your desired PoserPython 
script. Once you locate your script, select it and click OK to 
execute it.

Page Setup

Selecting File > Page Setup opens a standard Print Setup 
dialog box allowing you to set up your printers. Please refer 
to your operating system and/or printer documentation for 
information on setting your print preferences.

Print

Selecting File > Print sends your current scene to your selected 
printer. A standard Print dialog box opens allowing you to select 
your desired printer and general printing properties. Poser 
documents always print using the full page size. Please refer 
to your operating system documentation for information on 
selecting print options.

Exit

Selecting File > Exit closes Poser. You are prompted to save any 
unsaved changes. You can also type [COMMAND]/[CTRL]+[Q] 
to exit Poser.

This menu option is available for Windows only. For Macintosh, 
the Quit command appears on the Poser Application menu.

Undo

Selecting Edit > Undo reverses your most recent change to the 
actual scene. You can also press [COMMAND]/[CTRL]+[Z]. 
Undo applies only to alterations made within the actual scene; it 
is not applicable to changes made to application settings, Library 
content, etc.

Poser supports multiple levels of Undo. Selecting Edit > Undo 
repeatedly allows you to step backwards through your most 
recent document changes, reversing each change individually 
and reverting the scene to its previous state. Some operations 
within Poser will purge the Undo/Redo cache; a warning 
dialog will appear asking you to confirm before the action is 
implemented. Closing the file will purge the Undo/Redo cache.

You can specify the maximum size of the Undo stack. Please 
see “Setting Application Preferences” on page 32 for more 
information.
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You can specify whether or not the Undo feature 
will apply to camera changes. Open the 

Properties palette for the currently selected camera, and 
check the “Remember changes for undo” checkbox in 
order to apply Undo to camera changes. Alternately, if 
you do not wish camera changes to be included in the 
Undo feature, make sure to uncheck this checkbox for 
each camera. This checkbox is active by default.

Redo

Selecting Edit > Redo reiterates the most recently undone 
action, thus reverting the scene to its previous state. You can 
also press [COMMAND]/[CTRL]+Shift+[Z]. To reverse a Redo 
action, simply select Edit > Undo again.

Cut

Selecting Edit > Cut removes the selected element(s) and places 
them in the system Clipboard for later pasting. You can also 
press [COMMAND]/[CTRL]+[X]. You can do this for poses and 
other functions.

Copy

Selecting Edit > Copy copies selected elements to the Clipboard. 
You can use this command to copy the position of one prop to 
another. You can also copy transformation and rotation channel 
information from the selected item and paste that information 
into another item. For example, the following figure shows 
rotation information pasted from the figure’s abdomen to its 
arm.

 Before and after abdomen pose settings are copied to a figure’s 
arm.

To copy and paste a shaped body part:
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1. Manipulate the body part using any tool you desire.

2. Select the body part (source), then select Edit > Copy or 
press [COMMAND]/[CTRL]+[C].

3. Click to select the body part you wish to copy to (target) 
and select Edit > Paste (see following subsection). This 
copies all settings from the source to the target, including 
deformers.

Paste

Selecting Edit > Paste, or pressing [COMMAND]/[CTRL]+[V], 
places the item stored in the Clipboard into your current scene. 
If you are pasting a pose, select the element to apply the copied 
pose to, then make your selection.

Copying and pasting poses from one side to the 
other does not mirror the poses. The same pose is 

applied. To mirror poses, use the Symmetry function.

Copy Picture

Selecting Edit > Copy Picture takes a snapshot of your scene, 
which you can then paste into a graphics application such as 

Adobe Photoshop. Your scene is copied exactly as displayed in 
the Document window.

Copying and pasting images in this manner is 
not the same as rendering. Please refer to part 9 

for information on rendering Poser scenes.

Duplicate

The Duplicate [ObjectName] option creates an exact duplicate 
of the currently selected figure or prop. The duplicate object 
is placed within the Document window, in the same position 
as the original. The duplicate object will appear in either the 
Select Figure or Current Actor menu, depending on whether 
it is a figure or a prop, and can be resized and repositioned 
independently from the original object.

Restore

Need to restore a scene element to its default state? Selecting 
Edit > Restore opens a submenu allowing you to restore scene 
elements, which are completely restored to their Poser default 
states, including but not limited to position, scale, morphs, 
parameters, materials, parent/child relationships, etc.
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The Restore function is literally for cases when 
you wish to go back and start all over again. Use 

it with care!

The Restore submenu appears as follows:

• Element: Selecting Edit > Restore > Element restores the 
current element to its default state. An element could be a 
body part, prop, single camera, or single light.

• Figure: Selecting Edit > Restore > Figure restores the 
current figure to its default state.

• Lights: Selecting Edit > Restore > Lights restores all lights 
in your scene to their Poser default state.

• Camera: Selecting Edit > Restore > Camera restores the 
current camera to its default state.

• All: Selecting Edit > Restore > All restores all scene 
elements to their default states. Use this option with care!

Memorize

While working, you might arrive at a convenient stopping 
point. You know you like what you have so far and do not want 
to revert all the way back to the Poser default state should you 
need to restore one or more scene elements (or even the entire 

scene) at a later time. No problem. Select Edit > Memorize and 
the element(s) you wish to memorize (the list is the same as for 
the Restore submenu, above). Doing this essentially changes 
the default for your selected item(s), which can be undesirable 
in some cases. Redoing this operation saves the new default 
overwriting the old. If you later select Edit > Restore, your 
element(s) will be restored to the last memorized settings.

It is very important when setting up new figures 
to use the Edit > Memorize > Figure command 

to preserve default poses so that Inverse Kinematics 
works properly.

Memorization works on a per-file basis, meaning that 
memorizing defaults in one file does not affect the defaults of 
other Poser files or Library entries.
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Chapter 5: The 
Document Window

The Document window is your portal to the Poser workspace 
where you view and can directly manipulate your scene and 
the elements within it. The Document window consists of two 
tabs: the Preview tab, which is where you do the work to set up 
your Poser scene; and the Render tab, which is where you can 
view the results of your renders. The following topics discuss the 
Document window controls and how to use them.

Preview Tab
Clicking on the Preview tab at the top left of the Document 
window brings up the scene preview window, where you can 
manipulate figures, props, etc. to set up your Poser scene. Refer 
to “Preview Tab” on page 398 for detailed configuration 
parameters for the Preview tab’s preview display window. The 
Preview tab contains the following controls:

 Components of the Document Window.
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Title
The Title appears along the top of the Document window, and 
displays the current Poser scene (such as My Scene.PZ3).

Options Menu
Clicking on the arrow at the right side of the Title bar opens the 
Document window’s Options menu. This menu contains the 
following settings and shortcuts:

 Document Window Options menu.

Render

Selecting Render from the Context menu renders your 
entire Poser scene, using the render settings specified in the 
Render Settings dialog, and the render engine specified in the 
Render Engine Selection menu on the Render tab. For more 
information on Poser’s render settings, see “Part 4: Rendering” 
on page 391. The render results will appear in the Render tab 
of the Document window.

Render in Background

Choose the Render in Background command from the Options 
menu to render your image or animation in the background. 
This option allows you to continue working while your project 
renders.

Background renders are only available for single 
frames (images). The Background Render option 

will not be available for movies. We recommend using 
the Render Queue (see “Network Render Queue” on page 
426) when rendering movies.
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Render in Queue

Choose the Render in Queue command to send the selected 
render process to the Queue Manager. Further information on 
the Queue Manager can be found in “Installing Queue Manager” 
on page 27 and “Render in Queue” on page 393.

Export Image

Selecting Export Image opens a standard Save As dialog that 
will allow you to save the scene as it appears in your scene 
preview window as an image file. This can also be accomplished 
by selecting File > Export > Image..

Upload Main Render To

Choose Upload Main Render To > Facebook to upload the 
currently selected render to your Facebook account. For further 
information on how to perform the upload, see “Uploading to 
Facebook” on page 103.

Reload Textures

Clicking on Reload Textures will reload into memory all 
textures for the current scene preview display. This allows 

you to easily update any changes you may have made in other 
applications to the currently loaded textures.

Reuse Shadow Maps

If you do not make changes to lights or object positions between 
renders, there is no need to recalculate the shadow maps for 
your scene, as they will not have changed. The Reuse Shadow 
Maps option allows you to save the shadow map computations 
from your previous render and reuse them, thereby saving time 
with each subsequent render.

Clear Shadow Maps

Clicking on Clear Shadow Maps will cause Poser to recalculate 
the shadow maps for your scene during the next render. Use this 
option if you have made changes to lights or object positions, as 
such changes will affect the shadows in your scene.

Render Settings

Selecting Render Settings will open the Render Settings dialog. 
See “Chapter 18: The Render Settings Dialog” on page 397 for 
more information on the Render Settings dialog options.
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Render Dimensions

Selecting Render Dimensions brings up the Render 
Dimensions dialog, which contains settings that allow you 
to specify the dimensions of your render tab. See “Render 
Dimensions” on page 75 for more information on the 
Render Dimensions dialog settings.

Preview Dimensions

Selecting Preview Dimensions brings up the Preview Dimensions 
dialog. Here you can specify your desired height and width 
(in pixels) of the scene preview window. Clicking the Match 
Background button forces the Document window to match the 
dimensions of an imported background image or movie. Clicking 
the Match Production Aspect button sets the scene preview 
window size to the currently selected Production Frame aspect. 
This button is only active when the Production Frame feature 
is enabled (see “Production Frame” on page 111). Clearing a 
checkbox disables the specified option.

Collisions

A collision occurs when two objects in your scene partially or 
completely occupy the same 3D space. Selecting the Collisions 
menu item opens a pop-up menu that allows you to set the 
following collision options for your current Poser scene:

• Collisions On: Checking the Collisions on option prevents 
objects in your scene from colliding with/penetrating each 
other.

• Collisions Off: Checking the Collisions off option allows 
objects in your scene to collide with/penetrate each other.

• Show Intersections: Checking the Show intersections 
option displays colliding polygons in red when objects in 
your scene collide with/penetrate each other but does not 
prevent the collision.

Once you have set collision preferences for your scene, you must 
then enable collision detection for each of the objects for which 
you want to use this feature. Do this by selecting your desired 
objects one at a time and checking the Collision Detection 
checkbox in that object’s Properties palette. This feature only 
works between objects that have collision detection enabled. 
If you have one object enabled and one disabled, collision 
detection will not work.

Objects lose their collision detection settings 
when hidden.
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Document Window Size

The Document window is dockable and floatable. When the 
Document window is in its floating state, there are two ways 
that you can resize it:

• Clicking and dragging the bottom right corner of the 
Document window to your desired size.

• Choose Window > Document Window Size, which opens 
the Preview Dimensions dialog. Enter your desired 
scene preview window height and width (in pixels) in the 
appropriate fields and click OK to resize the Document 
window.

• Click the Match Background button to match the 
Document window to the dimensions of an imported 
background image or movie.

• Click the Match Production Aspect button to set the 
scene preview window size to the currently selected 
Production Frame aspect. This button is only active when 
the Production Frame feature is enabled (see “Production 
Frame” on page 111).

Note that the above two options are disabled (as 
shown below) when the Document window is 

docked. To undock the document window, click the Float 
Palette button in the Preview Dimensions dialog.

 Setting Document Window size.

The Document window size is saved in the same manner as 
described in “Single/Multiple-View Panes” on page 92.

OpenGL Hardware Acceleration

Poser offers OpenGL hardware accelerated rendering as well as 
SreeD software rendering options for the scene preview display. 
Simply right-click (Windows) or Apple key-click (Mac) within 
the preview window to select hardware or software rendering for 
processing the scene previews. In most cases, hardware rendered 
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previews will be faster than software rendered previews. 
Additionally, hardware accelerated performance is independent 
of the preview window size, whereas software rendering will 
yield a lower frame rate with larger preview window sizes.

Recent and more powerful graphics cards with OpenGL support 
will provide better results with the display of your Poser scene, 
with better texture previews and faster interaction and updating 
of the scene. Unfortunately, due to the vast variety of graphics 
hardware available, hardware acceleration may not be supported 
on every system. In that case please use the SreeD software 
rendering option. Poser should automatically detect whether or 
not OpenGL hardware rendering is supported for your system, 
and if not, should default to SreeD software rendering.

 Choosing your Preview Rendering option.

Select Figure/Current Actor Menus

The top left of the Preview tab contains the Select Figure (left) 
and Current Actor (right) pull-down menus. The currently 
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selected figure and item appear as labels, and those item’s 
properties and parameter dials are accessible in the Parameters 
& Properties palette. Double-clicking anywhere in the scene 
preview area will open the Parameters & Properties palette in 
the position and state in which it was last used, with the settings 
for the currently selected figure and/or actor displayed.

You can also select figures, props, and other scene objects by 
clicking on them directly in the scene preview area.

 Select Figure (left) and Current Actor (right) menus.

• Select Figure Menu: Use the Select Figure pull-down 
menu to select your desired figure. This can be helpful if you 
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have a number of figures in your scene (particularly if you 
are using conforming clothing, each item of which is a Poser 
figure).

• Current Actor Menu: The Current Actor pull-down menu 
allows you to select scene items as follows:

 � Body: Selecting Current Actor > Body selects the 
entire body and all body parts of the currently selected 
figure.

 � Body Parts: Selecting Current Actor > Body Parts 
opens the list of the currently selected figure’s body 
parts. By using this option, you will select only the 
specified body part on the currently selected figure.

 � Props: Selecting Current Actor > Props opens the 
list of all props in your scene (including hair and cloth 
objects), allowing you to select your desired prop.

 � Cameras: Selecting Current Actor > Cameras opens 
the list of the cameras in your scene. You may select 
any camera from this list. Please refer to “Chapter 11: 
Cameras” on page 242 for information about Poser 
cameras.

 � Lights: Selecting Current Actor > Lights opens the list 
of lights in your scene. You may select any light from 
this list. Please refer to “Chapter 12: Lighting” on page 
261 for information about Poser lights.

Preview Tab Context Menus
Right-clicking (Windows) or Apple key-clicking (Mac) within a 
scene preview tab will open up the Context pop-up menu. The 
options that appear in this menu vary, depending on the type of 
item that you right-click over.

Actors Context Menu

When you right-click over a body part in a poseable figure, the 
context menu appears as shown below.
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 Actor Context Menu.

The Actor context menu provides the following commands:

• The top line in the context menu displays the name of the 
selected item.

• Select: Expand the Select menu to select the part that you 
right-click. A check mark appears beside the name of the 
body part when it is set as the current selection.

• Memorize and Restore: Equivalent to using the Edit > 
Memorize and Edit > Restore commands as they apply to 
the entire figure, or to the selected element. See “Memorize” 
on page 71 and “Restore” on page 70.

• Lock: Equivalent to using the Figure > Lock Figure or 
Object > Lock Object commands. Allows you to lock or 
unlock the transformations of the selected actor or figure. 
The item is locked when a check mark appears beside the 
item. See “Lock Figure” on page 215 and “Lock Object” 
on page 211.

• Hide Actor: Hides the actor that is right-clicked.

• Show All: Equivalent to using the Figure > Show All 
command. “Unhides” any hidden figures or actors.

• Frame Object: Equivalent to using the Frame Selected 
camera control or the View > Frame Selected command. 
See “Frame Selected” on page 111.
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• Element Style: Equivalent to using the Display > Element 
Style command for the selected element. Choose the 
desired display style from the submenu. See “Chapter 6: 
The Display Controls and Menu” on page 105 for more 
information about the display styles available in Poser.

• Duplicate Figure: Equivalent to using the Edit > Duplicate 
command. See “Duplicate” on page 70.

• Change Figure (figurename) Parent to: Equivalent to 
using the Figure > Set Figure Parent command. Allows 
you to select a prop, camera, or light as a figure parent. 
Choose Universe to remove the figure parent. See “Set 
Figure Parent” on page 230.

• Conform Figure (figurename)To: Equivalent to using the 
Figure > Conform To command. Allows you to conform 
the figure to another figure in the scene. Choose None to 
unconform the selected figure. See “Adding Conforming 
Clothing: Manual Conforming” on page 143.

• Use Inverse Kinematics: Equivalent to using the Figure > 
Use Inverse Kinematics command. A check mark appears 
beside the leg or hand when inverse kinematics is on. See 
“Inverse Kinematics (IK)” on page 177.

• Symmetry: Equivalent to using the Figure > Symmetry 
command. Expand the menu and choose the desired 
symmetry. See “Symmetry” on page 216.

• Figure Style: Equivalent to using the Display > Figure 
Style command. Allows you to choose the display style for 
the figure. See “Chapter 6: The Display Controls and Menu” 
on page 105 for more information about the display styles 
available in Poser.

• Camera View: Equivalent to using the Display > Camera 
View command. Select the desired camera view from the 
context menu.

• OpenGL: Equivalent to using the Display > Preview 
Drawing > OpenGL Hardware command. See “OpenGL 
Hardware Acceleration” on page 76.

• SreeD: Equivalent to using the Display > Preview Drawing 
> SreeD Software command. See “OpenGL Hardware 
Acceleration” on page 76.

• Toon Tones: Equivalent to using the Display > Cartoon 
Tones command. Select the desired cartoon display mode 
from the context menu. See “Cartoon Tones” on page 120.

Full Figures Context Menu

To display the context menu for a full figure, right-click the 
Figure circle that appears around a poseable figure. The options 
in the context menu are similar to those in the Actor context 
menu described in the previous section.
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 Full Figure Context Menu.

• The top line in the context menu displays the name of the 
selected item.

• Select: Expand the Select menu to select the part that you 
right-click. A check mark appears beside the name of the 
body part when it is set as the current selection.

• Memorize and Restore: Equivalent to using the Edit > 
Memorize and Edit > Restore commands as they apply to 
the entire figure, or to the selected element. See “Memorize” 
on page 71 and “Restore” on page 70.

• Lock: Equivalent to using the Figure > Lock Figure or 
Object > Lock Object commands. Allows you to lock or 
unlock the transformations of the selected actor or figure. 
The item is locked when a check mark appears beside the 
item. See “Lock Figure” on page 215 and “Lock Object” 
on page 211.

• Hide Actor: Hides the actor that is right-clicked.

• Show All: Equivalent to using the Figure > Show All 
command. “Unhides” any hidden figures or actors.

• Frame Object: Equivalent to using the Frame Selected 
camera control or the View > Frame Selected command. 
See “Frame Selected” on page 111.

• Element Style: Equivalent to using the Display > Element 
Style command for the selected element. Choose the 
desired display style from the submenu. See “Chapter 6: 
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The Display Controls and Menu” on page 105 for more 
information about the display styles available in Poser.

• Duplicate Figure: Equivalent to using the Edit > Duplicate 
command. See “Duplicate” on page 70.

• Change Figure (figurename) Parent to: Equivalent to 
using the Figure > Set Figure Parent command. Allows 
you to select a prop, camera, or light as a figure parent. 
Choose Universe to remove the figure parent. See “Set 
Figure Parent” on page 230.

• Conform Figure (figurename)To: Equivalent to using the 
Figure > Conform To command. Allows you to conform 
the figure to another figure in the scene. Choose None to 
unconform the selected figure. See “Adding Conforming 
Clothing: Manual Conforming” on page 143.

• Use Inverse Kinematics: Equivalent to using the Figure > 
Use Inverse Kinematics command. A check mark appears 
beside the leg or hand when inverse kinematics is on. See 
“Inverse Kinematics (IK)” on page 177.

• Symmetry: Equivalent to using the Figure > Symmetry 
command. Expand the menu and choose the desired 
symmetry. See “Symmetry” on page 216.

• Figure Style: Equivalent to using the Display > Figure 
Style command. Allows you to choose the display style for 

the figure. See “Chapter 6: The Display Controls and Menu” 
on page 105 for more information about the display styles 
available in Poser.

• Camera View: Equivalent to using the Display > Camera 
View command. Select the desired camera view from the 
context menu.

• OpenGL: Equivalent to using the Display > Preview 
Drawing > OpenGL Hardware command. See “OpenGL 
Hardware Acceleration” on page 76.

• SreeD: Equivalent to using the Display > Preview Drawing 
> SreeD Software command. See “OpenGL Hardware 
Acceleration” on page 76.

• Toon Tones: Equivalent to using the Display > Cartoon 
Tones command. Select the desired cartoon display mode 
from the context menu. See “Cartoon Tones” on page 120.
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Props Context Menu

 Props Context Menu.

• The top line in the context menu displays the name of the 
selected item.

• Select: Expand the Select menu to select the prop that you 
right-click. A check mark appears beside the name of the 
prop when it is set as the current selection.

• Memorize Prop and Restore Prop: Equivalent to using 
the Edit > Memorize and Edit > Restore commands as 
they apply to the prop. See “Memorize” on page 71 and 
“Restore” on page 70.

• Lock Object: Equivalent to using the Object > Lock 
Object command. Allows you to lock or unlock the 
transformations of the selected prop. The item is locked 
when a check mark appears beside the item. See “Lock 
Object” on page 211.

• Hide Actor: Hides the actor that is right-clicked.

• Show All: Equivalent to using the Figure > Show All 
command. “Unhides” any hidden figures or actors.

• Frame Object: Equivalent to using the Frame Selected 
camera control or the View > Frame Selected command. 
See “Frame Selected” on page 111.

• Element Style: Equivalent to using the Display > Element 
Style command for the selected element. Choose the 
desired display style from the submenu. See “Chapter 6: 
The Display Controls and Menu” on page 105 for more 
information about the display styles available in Poser.
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• Duplicate: Equivalent to using the Edit > Duplicate 
command. See “Duplicate” on page 70.

• Change (propname) Parent to: Equivalent to using the 
Object > Change Parent command. Allows you to select a 
figure, prop, camera, or light as a parent. Choose Universe 
to remove the figure parent. See “Changing a Parent” on 
page 231.

• Camera View: Equivalent to using the Display > Camera 
View command. Select the desired camera view from the 
context menu.

• OpenGL: Equivalent to using the Display > Preview 
Drawing > OpenGL Hardware command. See “OpenGL 
Hardware Acceleration” on page 76.

• SreeD: Equivalent to using the Display > Preview Drawing 
> SreeD Software command. See “OpenGL Hardware 
Acceleration” on page 76.

• Toon Tones: Equivalent to using the Display > Cartoon 
Tones command. Select the desired cartoon display mode 
from the context menu. See “Cartoon Tones” on page 120.

Lights Context Menu

For information regarding commands that are specific to lights, 
see “Chapter 12: Lighting” on page 261.

 Lights Context Menu.
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• The top line in the context menu displays the name of the 
selected light.

• Select: Expand the Select menu to select the light that you 
right-click. A check mark appears beside the name of the 
light when it is set as the current selection.

• Memorize Lights and Restore Lights: Equivalent to using 
the Edit > Memorize and Edit > Restore commands as 
they apply to the lights. See “Memorize” on page 71 and 
“Restore” on page 70.

• Duplicate: Equivalent to using the Edit > Duplicate 
command. See “Duplicate” on page 70.

• Lock Light: Equivalent to using the Object > Lock Object 
command. Allows you to lock or unlock the transformations 
of the selected light. The item is locked when a check mark 
appears beside the item. See “Lock Object” on page 211.

• Light On: Turns the light on or off. A check mark appears 
beside the command when the light is on.

• Casts Shadows: Turns shadows on or off for the selected 
light. Shadows are on when the option is checked.

• Light Type: Allows you to choose the type of light. A check 
mark appears beside the currently selected light type.

• Include in OpenGL Preview: Allows the effects of the 
current light to display in the preview render in the 
document window. A check mark appears beside the light if 
it is included.

• Point At: Equivalent to using the Object > Point At 
command. See “Point At” on page 212.

• Change (lightname) Parent to: Equivalent to using the 
Object > Change Parent command. Allows you to select a 
figure, prop, camera, or light as a parent. Choose Universe 
to remove the parent. See “Changing a Parent” on page 
231.

• Camera View: Equivalent to using the Display > Camera 
View command. Select the desired camera view from the 
context menu.

• OpenGL: Equivalent to using the Display > Preview 
Drawing > OpenGL Hardware command. See “OpenGL 
Hardware Acceleration” on page 76.

• SreeD: Equivalent to using the Display > Preview Drawing 
> SreeD Software command. See “OpenGL Hardware 
Acceleration” on page 76.

• Toon Tones: Equivalent to using the Display > Cartoon 
Tones command. Select the desired cartoon display mode 
from the context menu. See “Cartoon Tones” on page 120.
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Cameras Context Menu

For information regarding commands that are specific to 
cameras, see “Chapter 11: Cameras” on page 242.

You will need to make the camera visible in the 
Properties panel before you right-click to display 

the camera context menu.

 Cameras Context Menu.

• The top line in the context menu displays the name of the 
selected camera.

• Select: Expand the Select menu to select the light that you 
right-click. A check mark appears beside the name of the 
light when it is set as the current selection.

• Memorize Cameras and Restore Cameras: Equivalent to 
using the Edit > Memorize and Edit > Restore commands 
as they apply to the selected camera. See “Memorize” on 
page 71 and “Restore” on page 70.

• Lock Camera: Equivalent to using the Object > Lock 
Object command. Allows you to lock or unlock the 
transformations of the selected camera. The item is locked 
when a check mark appears beside the item. See “Lock 
Object” on page 211.

• Point At: Equivalent to using the Object > Point At 
command. See “Point At” on page 212.

• Change (lightname) Parent to: Equivalent to using the 
Object > Change Parent command. Allows you to select a 
figure, prop, camera, or light as a parent. Choose Universe 
to remove the parent. See “Changing a Parent” on page 
231.

• Camera View: Equivalent to using the Display > Camera 
View command. Select the desired camera view from the 
context menu.
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• OpenGL: Equivalent to using the Display > Preview 
Drawing > OpenGL Hardware command. See “OpenGL 
Hardware Acceleration” on page 76.

• SreeD: Equivalent to using the Display > Preview Drawing 
> SreeD Software command. See “OpenGL Hardware 
Acceleration” on page 76.

• Toon Tones: Equivalent to using the Display > Cartoon 
Tones command. Select the desired cartoon display mode 
from the context menu. See “Cartoon Tones” on page 120.

Background Context Menu

 Background Context Menu.

• Memorize and Restore: Equivalent to using the Edit > 
Memorize and Edit > Restore commands. See “Memorize” 
on page 71 and “Restore” on page 70.
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• Production Frame: Equivalent to using the Display > 
Production Frame command. See “Production Frame” on 
page 111.

• Document Style: Equivalent to using the Display > 
Document Style command. Allows you to choose the 
display style for the entire document. See “Chapter 6: 
The Display Controls and Menu” on page 105 for more 
information about the display styles available in Poser.

• Deformers: Equivalent to using the Display > Deformers 
command. Allows you to show and hide the deformers in 
the scene. See “Deformers” on page 113.

• Ground Shadows: Equivalent to using the Display > 
Ground Shadows command. Turns the ground shadow on 
and off. See “Ground Shadows” on page 114.

• Figure Circle: Equivalent to using the Display > Figure 
Circle command. Toggles the display of the figure circle 
around the figure. See “Figure Circle” on page 114.

• Bend Body Parts: Equivalent to using the Display > Bend 
Body Parts command. Toggles bending on and off in a 
figure. See “Bend Body Parts” on page 114.

• Antialias Document: Equivalent to using the Render > 
Antialias Document command. Smooths rough edges in 

the rendered image. See “Antialias Document” on page 
394.

• Motion Blur Document: Equivalent to using the Render 
> Motion Blur Document command. Adds a motion blur 
effect to the render. See “Motion Blur Document” on page 
394.

• Camera View: Equivalent to using the Display > Camera 
View command. Select the desired camera view from the 
context menu.

• OpenGL: Equivalent to using the Display > Preview 
Drawing > OpenGL Hardware command. See “OpenGL 
Hardware Acceleration” on page 76.

• SreeD: Equivalent to using the Display > Preview Drawing 
> SreeD Software command. See “OpenGL Hardware 
Acceleration” on page 76.

• Toon Tones: Equivalent to using the Display > Cartoon 
Tones command. Select the desired cartoon display mode 
from the context menu. See “Cartoon Tones” on page 120.

Area Render

The Area Render feature allows you to select a specific region of 
your scene to render, thereby allowing you to more quickly view 
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the results of changes to one part of your scene, without having 
to re-render the entire scene each time. Area Renders appear in 
the Render tab overlaid on the window’s existing image at the 
time the Area Render was taken, so you can view the rendered 
area in the context of your entire scene.

 Area Render icon.

To use the Area Render feature, simply click on the Area Render 
icon at the top of the Preview or Render tab. The symbol will 
turn red, indicating that Area Render has been enabled. Then 
click and drag within the scene preview area to select the portion 
of the scene you wish to render. The results will appear in the 
Render tab of the Document window, using the render settings 
specified in the Render Settings dialog, and the render engine 
specified in the Render Engine Selection menu on the Render 
tab. Poser will save the most recently rendered image in the 
Render tab, allowing you to toggle back and forth between the 
Preview and Render tabs, without losing your rendered image.

Render

The Render icon at the top of the Preview or Render tab 
is a shortcut to the Render command. Clicking this symbol 
will render your entire Poser scene, using the render settings 
specified in the Render Settings dialog, and the render engine 
specified in the Render Engine Selection menu on the Render 
tab. For more information on Poser’s render settings, see “Part 
4: Rendering” on page 391. The render results will appear in 
the Render tab of the Document window.

 Render icon.

Mini Camera Controls

The Mini Camera Controls located at the top right of the 
Preview tab contain a subset of the total available Camera 
controls. From left to right, these are:
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• Frame Selected Object: Allows you to pick a body part 
and then frame that body part in the camera view. To frame 
another object, select another body part and click the icon 
again.

• Orbit Selected Mode: Toggles the Orbit Selected feature 
on and off. When on, the camera will be centered on the 
selected body part while rotating. The arrow turns blue 
when Orbit Selected mode is active.

The Orbit Selected mode does not work with 
cameras that are already set to orbit a specific 

body part (such as the Face, Left Hand, and Right Hand 
cameras).

• Camera Rotation: The Camera Rotation trackball tilts and 
spins the currently selected camera about all three axes.

• Move XZ: Clicking and dragging the Move XZ control 
moves the currently selected camera along the X and/or Z 
axes.

• Move XY: Clicking and dragging the Move XY control 
moves the currently selected camera along the X and/or Y 
axes.

Please refer to “Chapter 11: Cameras” on page 242 for detailed 
information about the Camera controls.

 Mini Camera Controls.

Changing Cameras within a Pane

The camera label in the upper left corner of the scene preview 
tab displays the currently selected camera for that pane. You can 
change the selected camera in each pane of the Preview tab. To 
do this, click on the Current Actor pop-up menu, or right-click 
anywhere within the desired pane to open the context menu, and 
click on the Camera View option.
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 Choosing a camera view from the menu commands.

To change the camera, click your desired option. The view in the 
selected pane will switch to your newly selected camera.

Single/Multiple-View Panes

By default, the Preview tab consists of one pane, meaning that 
you can view your scene using one camera at a time. You can, 
however, add up to four simultaneous viewing panes (cameras) 
to your Document window using eight customizable layouts, 
which helps you visualize your scene in all dimensions.

To select a layout, click the Document window Layout menu 
button in the lower left corner of the Preview tab, and select 
your desired layout from the pop-up menu.

• To toggle between single pane and the most recently 
selected multiple-pane layout, press [D].

• Press [F] to cycle through all of the available multiple-pane 
layouts.



Poser Pro 2014
Reference Manual

93

Chapter 5: The Document Window

 Multiple view panes.

• You can resize panes by clicking and dragging their borders. 
Poser remembers pane sizes and camera selections if you 
switch layouts while working on a given scene, and these 
selections are also saved when you save your Poser scene.

• To use the same layout every time you launch Poser, select 
the Previous State option from the General Preferences 
dialog as described in “Setting Application Preferences” 
on page 32. You can also save up to nine pane/camera 
layouts using the UI Memory dots (see “Memory Dots” on 
page 56).

• Clicking anywhere in a pane makes that pane active. A red 
border appears around the active pane.

Tracking Mode

Tracking mode determines the type of preview Poser uses to 
display an object when you reposition either that object or a 
camera. The Tracking Mode pop-up menu in the lower left 
corner of the Preview tab offers three tracking mode options. 
From top to bottom, these are:

• Box: Displays scene elements (figures and props) as 
bounding boxes all the time, whether still or moving. This 
is the fastest way to preview scenes and is useful for rough 
blocking work.

• Fast: Displays figures and props in the currently selected 
display style while they or the camera are still and as 
bounding boxes when in motion. This combines an accurate 
scene view so you can see before and after images without 
waiting for each frame to fully render. Fast tracking can 
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help save time while blocking out scenes and creating 
animations.

• Full: Displays scene elements in the currently selected 
Document window display style at all times, whether still 
or animated. This mode is suitable for users with high-
performance computers and for performing fine-tuning on 
previously blocked-out scenes.

 Box and Full tracking modes.

Depth Cueing

The Depth Cueing button appears to the right of the Tracking 
Mode menu along the bottom left of the Preview tab.

Depth Cueing adds dimension to scene elements visible in the 
Document window. When Depth Cueing is enabled, elements 
farther away from the camera fade into the distance. This 
provides a quick visual indication of the depth of your scene, 
which can be helpful if you are viewing it using a single pane. To 
toggle depth cueing on and off, click the Depth Cueing button. 
Depth Cueing depends on the total depth of your scene. For 
example, if your scene consists of a single figure, the portions 
of that figure farthest from the camera will appear faded out. 
Adding another element (such as a prop) farther from the 
camera than the figure will cause the prop to appear faded with 
the figure being more visible. This is useful if you wish to control 
the amount of depth cueing in your scene.
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 Depth cueing fades objects that are farther away in the distance.

Depth cueing and shadows do not affect your 
rendered output.

Shadows

Items in your scene can cast shadows on the ground plane, 
which can help you orient them in 3D space. Disabling shadows 
can help speed up scene redraw time.

The Shadows button appears in the lower left corner of the 
Document window. Clicking the Shadows button allows you to 
choose which shadows will be displayed in the preview window 
as you build your scene:

 Shadow display options.

• No Shadows: Turns shadow display off. This can help 
improve performance on systems that have limited 
hardware resources.

• Ground Shadows: Displays shadows on the ground only as 
shown in the following figure.

• Hardware Shadows: Displays more realistic shadows in 
relation to the lights in your scene.

 The Enable Hardware Shading option in the 
Preview tab of the Render Settings dialog must 

be enabled for hardware shadows to display.
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• Ground and Hardware Shadows: Displays both ground 
and hardware shadows (if enabled).

 Displaying ground and hardware shadows.

Colors

You can improve your view of your scene by altering the 
foreground, background, shadow, and ground colors appearing 
within the Document window’s Preview tab. The four dots 
located along the lower-right corner of the Preview tab allow 
you to control the following colors, respectively:

 Interface options for foreground, background, shadow, and ground 
colors.

• Foreground: Clicking the Foreground button opens 
the Poser Color Picker and displays an eyedropper icon. 
Pressing [OPT]/[ALT] while clicking this button opens your 
operating system’s standard Color Picker. Position this 
dropper over the color you wish to select and click it. If you 
use the operating system’s standard Color Picker, you can 
alter the color using numeric values. The Foreground color 
affects the color of the Silhouette, Outline, Wireframe, and 
Hidden Line display modes (see “Chapter 6: The Display 
Controls and Menu” on page 105).
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 The color picker.

• Background: Change the Background color as described 
above. This color affects the Poser workspace background.

The final render will always display whatever is 
attached to the Color channel of the Root 

Background node. However, if you wish the same image 
to appear in the preview render, you must also attach it 
to the BG Picture or BG Movie node. For more 
information about nodes, please refer to “Chapter 16: 
Material Room Nodes” on page 325.

• Shadow: Change the Shadow color as described above. 
This color affects the preview shadow displayed in the 
Preview tab (if enabled).

• Ground: Change this color as described above. This color 
affects the ground plane displayed in the Preview tab (if 
enabled).

Render Tab
Clicking on the Render tab at the top left of the Document 
window displays the main render window, where you can see the 
rendered results of your Poser scene. The Render tab contains 
the following controls:
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 Render Window controls.

Render Dimensions

The main render window size is displayed in the upper left 
corner of the Render tab. Clicking this display brings up the 

Render Dimensions dialog, which contains the following 
settings:

 Render Dimensions options.

• Match Preview Window: Clicking the Match Preview 
Window radio button sets the resulting render to match the 
existing render preview window size.

• Fit in Preview Window: Alternately, clicking the Fit in 
Preview Window radio button will fit the resulting render 
within the render preview window, while maintaining the 
specified aspect ratio.
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• Render to Exact Resolution: Clicking the Render to 
Exact Resolution radio button will generate the render 
results according to the specific resolution specified in the 
following fields.

• Width: Enter the width in pixels for the render window in 
the Width field. Larger measurements take longer to render 
and require more disk space.

• Height: Enter the height in pixels for the render window in 
the Height field. Larger measurements take longer to render 
and require more disk space.

• Resolution: Enter the resolution in dot pixels per inch 
(DPI) in the Resolution field. 72DPI is normal for screen-
resolution images and is suitable for images you intend 
to distribute online. 300DPI is appropriate for most print 
functions, and 1200DPI is used when you need extreme 
detail. Higher resolution images require more disk space 
and take longer to render.

• Constrain Aspect Ratio: Checking the Constrain Aspect 
Ratio checkbox preserves the render window’s aspect 
ratio (width divided by height). For example, if you begin 
with 640x480 and change the 640 to 1280, the height 
will automatically change to 960. Clearing this checkbox 
disables this option.

• Match Document Window: Clicking the Match Document 
Window button sets the Document window’s current size in 
the Width and Height fields.

The production frame is determined by the aspect ratio resulting 
from the output width and height. You can set the production 
frame to be visible in the Document window’s scene preview 
area, by selecting Display > Production Frame from the menu 
bar.

Quick-Scale

The Quick-Scale pop-up menu is along the top left of the 
Render tab. It offers quick access to three different render 
scale options: Full Size, Half Size, and Quarter Size. Note that 
this feature is not intended to replace the Render Dimensions 
menu, but rather is a tool for facilitating quick render previews, 
as the smaller scale render sizes require less time to calculate.
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 Quick Scaling options.

Render Engine Selection

Click on the name of the currently selected render engine, along 
the top of the Render tab, to display the Render Engine popup 
menu. This menu allows you to easily switch between the various 
renderers included with Poser. To modify the render settings for 
each render engine, open the Render Settings dialog by clicking 
on Render > Render Settings... in the menu bar (see “Chapter 
18: The Render Settings Dialog” on page 397 for a description 
of this window).

 Selecting a render engine.

Area Render

Clicking the Area Render icon along the top right of the Render 
tab enables the Area Render feature, which allows you to select 
a specific region of the current image to render, thereby saving 
processing time. Area Render uses the render settings specified 
in the Render Settings dialog, and the render engine specified 
in the Render Engine Selection menu (as described above). 
Area Render is available for the FireFly renderer only. Please 
see “Area Render” on page 89 for a complete description of 
this feature’s functionality.
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Render

To render the current image, click the Render icon along the top 
of the Render tab. The results will display in the main render 
window area, using the render settings specified in the Render 
Settings dialog, and the render engine specified in the Render 
Engine Selection menu (as described above).

New Render Window (Tear Off)

Clicking the Tear Off arrow symbol next to the Render icon 
sends the current Main render image to a new window. You can 
then select a previously rendered image, or generate a new one, 
in the main render window and compare the two images side by 
side.

 New Render Window icon.

Pan

If the image you have rendered is larger than the render window 
size, you can pan the image by clicking and dragging in the main 
render window. The Pan symbol at the top right of the Render 
tab activates this feature. Panning is useful as it allows you to 
shrink the Document window as needed, such as when entering 
the Material room, and still have access to your entire rendered 
image.

Render Comparison
Poser offers convenient render comparison features, allowing 
you to contrast two different rendered images within the main 
render window. Clicking either of the two squares in the lower 
left corner of the Render tab brings up a pop-up menu listing 
the most recent renders by date and time. By default, the most 
recent render is set as the Main render, and is checked in the 
list under the black square. The second most recent render is 
the default Compare render, and is checked in the list under the 
white square. You can, however, select any render from the list 
as your Main and Compare renders. To compare the Main and 
Compare renders, use the Render Wipe slider at the bottom 
of the main render window. Moving the slider to the right 
displays the Main render, while moving it to the left displays the 
Compare render. The default number of recent renders listed is 
ten. You can configure this number in the General Preferences 
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dialog. (See “Setting Application Preferences” on page 32 for 
more information about the General Preferences dialog.)

 Render Comparison controls.

Displaying Recent Renders
You can use the Recent Renders palette to display thumbnails of 
your most recent rendered images. This palette can be docked or 
floating in the same manner as other palettes in your workspace.

To show or hide the Recent Renders palette, choose Window > 
Recent Renders. A check mark appears beside the command 
when the palette is visible.

From the Recent Renders palette, you can perform the following 
functions:

• Click a thumbnail in the Recent Renders palette to display 
the selected render in the Render window. Partially and 
fully completed renders appear in this palette

The number of thumbnails that appear in the 
palette are determined by the Max Cached 

Renders setting in the Render tab of the General 
Preferences dialog. For more information on this setting 
see “Render Preferences” on page 37.

Right-click a thumbnail to display a context menu with the 
following commands.

 � Export Image: Opens the Export As dialog, which 
allows you to save the render in one of the supported 
image formats.
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 � Upload To: Allows you to upload the selected render to 
Facebook, as described later in this chapter.

 � Set Compare Image: Designates the selected image as 
the image to compare with another thumbnail for use 
with the Render Wipe slider.

 � Delete: Deletes the selected render from the render 
cache, and removes the thumbnail from the Recent 
Renders palette.

 Recent Renders options.

Uploading to Facebook
If you have a Facebook account, you can upload your renders 
to your account directly from within Poser. The steps are as 
follows:

1. After you complete your render, do one of the following:

 � Click the arrow at the upper-right corner of the 
Document window to display the Options menu. Then 
choose Upload Main Render To > Facebook.

 Uploading to Facebook from the Document Window options menu.
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 � You can also choose Window > Recent Renders to 
display the Recent Renders palette. Then right-click on 
the thumbnail of the image that you want to upload, 
and choose Upload to > Facebook from the context 
menu.

 Uploading to Facebook from the Recent Renders Palette.

2. In the dialog that appears, you are asked to enter a name for 
the Facebook album that you want to upload to, and to add 
a description of the image. After you enter the information, 
click OK to launch Facebook.

3. A browser window opens and you are asked to log in to your 
Facebook account.

4. If you have not yet set up the Smith Micro Video Uploader, 
you are directed to a page where you check an option to 
allow Smith Micro Software Video Uploader to publish 

content. Click Allow Publishing to save the authorization 
permissions. You will be prompted to close the browser 
window to return to the Smith Micro Software Video 
Uploader.

 Configure Facebook to allow access from Smith Micro Video 
Uploader.

5. Your Facebook account opens, where you should see the 
image posted on your wall.
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Chapter 6: The Display 
Controls and Menu

Poser allows you to select 12 display styles. Selecting a different 
display style can help you better visualize your scene and/or 
add additional artistic interest to your rendered output. You can 
select display styles on the scene, figure/prop, or element (body 
part) level.

 Document Display Style controls.

The Display Controls palette has adjustable 
width and height, and the controls auto-wrap to 

fit the allotted width. If additional height is needed to 
display all the controls, a scrollbar appears on the right 
side of the palette.

Clicking the arrow to the left of the title opens a pull-down menu 
with the following options:

 Display styles can be set for the entire document, for a single figure, 
or for an element.

By default, the display style that you select will be applied to the 
entire document (Document Display Style). You can also apply 
different display styles to the selected figure, or the selected 
element.

• To change the display style for the entire document, choose 
Display > Document Style > (display option), or choose 
Document Style from the Display controls palette and click 
the display style icon you want to use. This affects how all 
scene elements (figures and props) are displayed unless the 
display style of a figure or actor is overridden as described 
below.
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• To change the display style for the selected figure, choose 
Display > Figure Style > (display option), or choose 
Figure Style and click the desired display type from the 
Display controls palette shown above. Selecting the Figure 
Style option accesses the Figure Display controls, which 
causes only the selected figure or prop to display in the 
selected style without affecting the other scene elements. To 
revert the selected actor back to the document style, choose 
Display > Figure Style > Use Document Style, or click 
the Use Document Style option in the Figure Style display 
options palette.

• To change the display style for the selected element (such 
as a prop or selected body part actor on a figure), choose 
Display > Element Style > (display option), or choose 
Element Style and click the desired display type from the 
Display controls palette shown above. Only the selected 
figure or prop will display in the selected style without 
affecting the other scene elements. If the selected element 
is a body part on a figure, you can revert back to the display 
mode set for the entire figure by choosing Display > 
Element Style > Use Figure Style, or by clicking the Use 
Figure Style option in the Element Style display options 
palette.

Whether you use the Display > Document Style, Figure 
Style, or Element Style menu, or the Document Style, Figure 
Style, or Element Style display control palette, there are 

twelve different display styles from which to choose. They are as 
follows:

• Silhouette: displays the figure/element only as a cutout, as 
shown to the right.

 Silhouette Display Style.

• Outline: displays the figure/element only as an outline. 
When either the entire scene or an entire figure is displayed 
in this mode, outlines appear around each actor (body part), 
as shown to the right.
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 Outline Display Style.

• Wireframe: displays the figure/element as a polygonal 
mesh. This mode displays the actual polygons comprising 
the figure/element, including polygons that would normally 
be hidden from view (such as a figure’s back when viewed 
from the front), as shown to the right.

 Wireframe Display Style.

• Hidden Line: displays only the figure/element’s polygons 
that would normally be visible from the current camera. 
For example, if you are viewing a figure from the front, the 
polygons forming the back would not be visible, as shown to 
the right.

 Hidden Line Display Style.

• Lit Wireframe: displays much the same as the Wireframe 
display style, except that the polygons’ colors correspond to 
the color of the surface material, as shown to the right.
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 Lit Wireframe Display Style.

• Flat Shaded: displays figures/elements using the surface 
material colors while displaying the mesh facets, as shown 
to the right.

 Flat Shaded Display Style.

• Flat Lined: same as the Flat Shaded display style, except 
that black mesh lines clearly denote polygon edges, as 
shown to the right.

 Flat Lined Display Style.

• Cartoon: displays the figure/element using a simulated 
hand-drawn style, as shown to the right. See “Cartoon 
Tones” on page 120 for more information about this 
shading style. Poser offers improved Cartoon display effects 
in conjunction with the OpenGL hardware acceleration 
option (see “OpenGL Hardware Acceleration” on page 
76).
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 Cartoon Display Style.

• Cartoon With Line: same as the Cartoon display style, 
except that figures/elements are outlined with black lines, as 
shown to the right. See “Cartoon Tones” on page 120 for 
more information.

 Cartoon with Line Display Style.

• Smooth Shaded: displays figures/elements as smooth 
continuous surfaces with the material colors, as shown to 
the right.

 Smooth Shaded Display Style.

• Smooth Lined: combines the Flat Lined and Smooth 
Shaded by displaying the polygons as a black mesh over a 
smooth surface, as shown to the right.
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 Smooth Lined Display Style.

• Texture Shaded: displays figures/elements using texture 
maps, as shown to the right.

 Texture Shaded Display Style.

You can also change display styles by selecting Display > 
Document Style, Display > Figure Style, and Display > 
Element Style.

By default, Poser renders using the Texture Shaded mode. 
While rendering high-resolution output using the currently 
selected display styles and/or depth cueing, etc. is not directly 
supported, you can achieve excellent results using the rendering 
tips discussed in “Tips & Tricks” on page 403.

The Display Menu Commands
As the name implies, the Display menu controls how items 
appear in your Poser workspace, specifically within the 
Document window.

Camera View

Choose Display > Camera View to select one of the cameras 
available in your scene. See “Chapter 11: Cameras” on page 
242 for more information about the various camera views.

Camera Layout

Choose Display > Camera Layout to select the number of 
different views that you want to display in the document 
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window. See “Single/Multiple-View Panes” on page 92 for 
more information about multiple views.

Fly Around

This command puts the current camera in Flyaround mode. For 
more information, see “Flyaround View” on page 247.

Frame Selected

The Frame Selected command fits the camera view around the 
currently selected actor. For example, you can pick a body part, 
and then choose the Frame Selected command to frame the 
camera view around that body part.

Orbit Selected Mode

The Orbit Selected command rotates the camera around 
the currently selected actor. This command is a toggle. When 
toggled on, the camera will be centered on the selected object or 
body part and you can rotate the camera so that it is always in 
the center.

The Orbit Selected mode does not work with 
cameras that are already set to orbit a specific 

body part (such as the Face, Left Hand, and Right Hand 
cameras).

Show Camera Names

This command shows or hides the display of camera names in 
the document window.

Production Frame

Selecting Display > Production Frame allows you to specify 
whether you wish the production frame to be visible in the 
Document window’s scene preview. The size of the production 
frame is determined by the aspect ratio resulting from the output 
width and height. See “Render Dimensions” on page 75 
and “Keyframe Controls” on page 452 for more information 
about configuring the output dimensions for images and movies, 
respectively.

Document Style

Selecting Display > Document Style allows you to select a 
display style for your entire Poser scene. This is the same as 
using the Display controls discussed earlier.
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Figure Style

Selecting Display > Figure Style allows you to select a display 
style for your currently selected Poser figure. This is the same as 
using the Display controls discussed earlier.

If your currently selected figure does not use the 
same display style as the document, choose 

Display > Figure Style > Use Document Style to 
change to change it to the same display mode that is 
selected for Document Display Style.

Element Style

Selecting Display > Element Style allows you to select a display 
style for your currently selected scene element (for example, 
a body part or a prop). This is the same as using the Display 
controls.

If your currently selected element (body part, 
prop, hair, and so on) does not use the same 

display style as the figure to which it is attached, choose 
Display > Element Style > Use Figure Style to change 
to change it to the same display mode that is selected for 
the figure.

Depth Cued

Selecting Display > Depth Cued toggles depth cueing on and 
off. Depth cueing makes objects fade as they get further from 
the camera. A check mark appears when this feature is active 
and vice versa. Please refer to “Depth Cueing” on page 94 for 
more information about depth cueing.

 Depth Cueing fades objects over distance.
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Tracking

Selecting Display > Tracking allows you to set your desired 
tracking mode. Please refer to “Tracking Mode” on page 93 
for more information about tracking modes.

Deformers

As the name implies, deformers (morph targets, parameters, 
force fields, and magnets) affect the shape of figures and props 
within your scene.

The Alyson and Ryan figures utilize many 
deformers to improve bending and joint 

performance.

Each deformer type is discussed in its own section later in this 
manual. Selecting Display > Deformers allows you to:

• Show all deformers (magnets, waves, and force fields) in 
your scene (Display > Deformers > Show All).

• Hide all deformers in your scene (Display > Deformers > 
Hide All).

• Only show the currently selected deformer. (Display > 
Deformers > Show current selection only).

A check mark appears next to the currently selected deformer 
display mode. You can select hidden deformers using the 
Current Actor pull-down menu. Hiding some or all deformers 
can reduce clutter, particularly in complex scenes.

 Deformers hidden (top) and visible (bottom).
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Ground Shadows

Selecting Display > Ground Shadows displays or hides ground 
shadows, as shown in the following figure. 

Please refer to “Shadows” on page 95 for more information 
about ground shadows.

 Ground shadows (top); Hardware shadows (middle); Both 
(bottom).

Figure Circle

Selecting Display > Figure Circle toggles displaying a white 
circle around your currently selected figure in your scene, which 
turns red depending on cursor location, allowing you to select 
the entire figure. Please refer to “Selecting Body Parts” on page 
181 for more information about the Figure Circle.

Bend Body Parts

Selecting Display > Bend Body Parts toggles bending on and 
off. All body parts are separate elements (actors). As you change 
their positions, Poser attempts to maintain continuity over the 
entire body. The arm should connect smoothly to the shoulder, 
etc. Poser achieves these smooth transitions by bending body 
parts where they join. However, the bends that work well for a 
body part might not work well when applied to figures created 
from props, or figures that have some body parts replaced 
by props (such as replacing a hand with a hook for a pirate 
character). Rendering images with bending disabled can cause 
figures to appear “broken”, as shown above.
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 When the Bend Body Parts option is off, figures split at the group 
seams.

Foreground/Background Color

Selecting Display > Foreground Color or Display > 
Background Color allows you to specify the Document 
window’s foreground and background colors, respectively. You 
can also do this using the Color controls located next to the 
Document window. Please refer to “Colors” on page 96 for 
an explanation of foreground and background colors.

Show Background Picture

If you have a background image in your scene that was placed 
there using either the File menu (see “Importing Background 
Pictures” on page 778) or by pasting the current figure/prop 
into the background (see below), then selecting Display > Show 
Background Picture toggles displaying this image on and off. 
Please refer to “Importing Movies” on page 777 for more 
information on adding a background animation to your Poser 
scene.

Clear Background Picture

Selecting Display > Clear Background Picture deletes the 
currently displayed background image (if any).

Paste Onto Background

You can paste an image of your currently selected figure/
prop into your scene background: This is especially helpful for 
planning animation.
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 You can paste a “snapshot” of your scene onto the background and 
make changes.

To do this, select the prop/figure you wish to paste into the 
background, then Select Display > Paste onto Background. If 
you do this more than once, each succeeding image supersedes 
the previous one. This is also true if you import a separate 
background image/movie.

Show Background Footage

Selecting Display > Show Background Footage displays 
imported animation footage in the workspace background.

Clear Background Footage

Selecting Display > Clear Background Footage removes 
imported animation footage from your scene.

Use Background Shader Node

There are two ways of specifying the background of a scene – 
by loading an image in the BG Picture node, or by attaching a 
shader tree to the Background root node:

If you want to use the BG Picture node as the background of your 
rendered image, choose Render over > Background picture 
in the Render Settings dialog, as described in “FireFly Options 
Settings” on page 417. Please refer to “Importing Background 
Pictures” on page 778 for information on importing 
background pictures.

• If you want to use the shader attached to the Background 
root node as the background of your rendered image, choose 
Render over > Current BG shader as described in “FireFly 
Options Settings” on page 417. Please refer to “Root 
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Background Node” on page 329 for information about 
using background shaders.

Guides

Poser provides several guides to assist you when posing 
figures. Guides are particularly useful for helping you achieve 
a particular perspective more easily. To display a guide, select 
Display > Guides and select the guide you wish to display. A 
check mark appears next to visible guides. To hide a guide, select 
Display > Guides and select the guide you wish to hide. Hidden 
guides have no check marks next to them. The available guides 
are described in the following sections.

Ground Plane

The ground plane provides a basic reference of the camera’s 
position relative to the Poser workspace. It also helps show scene 
elements’ vertical positions relative to one another. You can 
display the ground plane using the same display style as the rest 
of your scene or you can give it its own display styles.

 The ground plane represents the “zero” point of the scene’s height.

Head Lengths

This guide references the figure’s height. Most people are 
roughly seven “heads” tall, meaning that the average head is 
1/7th the height of a person. This guide can be helpful when you 
are performing body shaping operations such as using morph 
targets.
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 Head lengths are represented by several parallel planes.

Hip-Shoulder Relationship

This guide displays the relationship between the figure’s upper 
and lower body. It helps you see the side-to-side, bend, and twist 
in the hip, abdomen, and chest. This is particularly useful when 
editing/viewing your figure using different cameras.

 Hip and shoulder relationship guides.

Horizon Line

This guide references the Poser workspace’s horizon line. You 
can check camera orientation by selecting a camera and checking 
its position relative to the horizon line. The horizon line is also 
useful when creating perspective between two or more figures 
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or other scene elements. For example, if the horizon line crosses 
the front figure’s chest, arrange all the figures so that the horizon 
line crosses their chests as well. This ensures that all figures are 
on the same plane and contributes to a viewer’s sense that all 
figures have their feet on the ground.

 Displaying the horizon line.

Vanishing Lines

Vanishing lines are an artistic technique for achieving realistic 
perspective. You can see this is real life by standing at the corner 
of a long building and sighting along a wall. You will see that the 

roof and the ground appear to converge the farther away you 
look until they eventually meet. This phenomenon is one of the 
things that give objects the appearance of depth in both real and 
virtual life.

 Displaying vanishing lines.

Focus Distance Guide

The focus distance is the distance at which objects appear 
most in focus. This distance is individually configurable for 
each camera. The Focus Distance Guide shows you where the 
focus distance for the selected camera falls within the scene, 
to help you visualize the position of various scene elements in 
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relationship to the focal plane. For more information on the 
focal plane and focus distance, see “Camera Parameters” on 
page 252.

Preview Drawing

Selecting Preview Drawing allows you to specify whether you 
wish to use OpenGL hardware rendering, or SreeD software 
rendering, for your scene preview display. Please see “OpenGL 
Hardware Acceleration” on page 76 for more information 
about hardware versus software rendering.

Cartoon Tones

Selecting Cartoon Tones allows you to choose between the 
following options for your scene preview display: One, Two, 
or Three cartoon shading tones, Three Tones Plus Highlights, 
and Smooth Toned. These shading styles affect the Cartoon 
Display Style specifically, and are only visible when Cartoon 
is selected as the Document Style, Figure Style, or Element 
Style from the Display menu. Note that these styles are for the 
scene preview only, and are not to be confused with final render 
shading styles.

Comic Book Preview Mode

Comic book preview mode displays the items in your preview 
window with a look that is similar to comic book illustration, 
without the need to assign materials that have Toon IDs. The 
previews include persistent shadowing and improved outlining. 
Comic Book styles not only work in Texture Shaded mode, but 
they also work with any other display style (Wireframe, Flat 
shaded, Cartoon, and so on).

The Cartoon Tones command, mentioned previously, includes 
two Comic Book mode toggles: Comic Book is used for black and 
white preview, and Comic Book (Color) for color previews:
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 Comic Book (left) and Comic Book (Color) (right).

There are two ways to enable one of the Comic Book styles:

• Choose Display> Cartoon Tones > Comic Book or 
Display > Cartoon Tones > Comic Book (Color).

• Right-click in the viewport, and choose Toon Tones > 
Comic Book, or Toon Tones > Comic Book (Color).

You can use the Render > Antialias Document 
command to produce a final rendering, or open 

the Render Settings dialog to render an image using 
your current Preview settings.

You can use the Comic Book Threshold slider, located below the 
lower-left corner of the document window.  To adjust the light/
dark contrast of the comic book preview, simply click the Comic 
Book Threshold icon to display the slider.

 Comic Book Threshold slider
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Chapter 7: The Poser 
Library

Poser’s hierarchical Library palette provides access to all of 
the content that ships with Poser such as figures, props, lights, 
cameras, etc. It has three tabs: the Library tab that provides 
access to the Poser content categories, the Search tab which 
allows you to search your content folders for specific files, 
and the Favorites tab where you can gain easy access to your 
frequently used or favorite content items. The Library tab 
contains ten categories, discussed below. Each category is 
further divided into subcategories. You can create and remove 
categories and subcategories, and can add and remove content, 
including your existing content libraries, to/from the Library 
palette. See “Maintaining Your Library Palette” on page 161 
for information on maintaining your Library palette.

Poser can also automatically install content purchased or 
obtained using the Content room as described in “Chapter 8: 
The Content Room” on page 173.

The following figure shows the various controls and options that 
are contained in the library palette. The boxed area in Figure 
1 shows the Library list. Navigate through the Library list as 
follows:

• Use the Up and Down arrow keys to move higher or lower in 
your content tree.

• Use the Right and Left arrow keys to open and close folders.

• Click or select an item in the list to expand the display and 
view a larger preview of the content item.
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 The Library Window.

1. Library Tabs: Allows you to switch between three views in 
the Library Palette: Library, Search, and Favorites.

2. Category Icons: Allows you to select one of the ten library 
categories. From left to right, they are Figures, Poses, 
Faces, Hair, Hands, Props, Lights, Cameras, Materials 
and Scenes.

3. Library Selection: Click the Show Library selector to 
display all runtime folders, or to display the contents of 
a single selected runtime folder in the library contents 
window.

4. Expanded folder: Click the down arrow to collapse the 
contents of the folder. The number that appears in brackets 
at the beginning of the folder name designates the number 
of items that are contained within that folder.

5. Collapsed folder: Click the right arrow to expand the 
contents of the folder. The number that appears in brackets 
at the beginning of the folder name designates the number 
of items that are contained within that folder.

6. Category Selection: Allows you to select a library category 
(listed above in Category Icons) by name.

7. Remove Library: A Remove Library (-) icon appears to 
the right of the Add Library icon when you use the Show 
Library menu to select a Library that you added yourself 
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through the Add Library command. See “Removing 
Libraries” on page 134 for details.

8. Add Library: Click the Add Library (+) icon to open 
the Browse for Folder dialog, which allows you to select 
additional Library folders that you have stored on your 
computer.

Content that is created for Poser is typically 
arranged in a folder named Runtime, with 

subfolders beneath that for geometry, textures, and 
library items. For more information about creating, 
installing and accessing additional library folders, see 
“Accessing Different Content Libraries” on page 131

9. Item List Panel: The currently selected item is highlighted 
in blue. If the Item List Panel is not displayed, the currently 
selected item displays as a larger icon in the Tree view.

10. Extended Details Panel: Displays a thumbnail, filename, 
file size, installation date, and other details about the item 
that is selected in the library.

11. Single check mark: Click the single check mark icon to 
replace the item that is currently selected in your scene 
with the item that is highlighted in the library. Functions 
of the single check mark button vary, depending on the 

Library category that is currently selected. See “Loading and 
Managing Items using the Library Icons” on page 135.

12. Double Check mark: Click the double-check mark icon to 
add the currently selected item to your scene. The double 
check mark does not appear for every Library category and 
the purpose varies depending on the selected category. See 
“Loading and Managing Items using the Library Icons” on 
page 135.

13. Add a Folder (+}: Click this button to create a new folder or 
subfolder beneath the currently selected library folder.

14. Save to Library (+): Click this button to add the item that is 
currently selected in your scene into the library.

15. Delete from Library (-): Click this button to delete the 
library content item that is currently selected. Note that 
this button completely removes the library item from the 
Library, not from your scene.

16. Add to Favorites: Adds the item that is currently 
highlighted in the library to the library’s Favorites tab.

17. Display Options Widget: Click the Display Options widget 
to expand or collapse the display options in the bottom of 
the library palette.
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18. Display Options: Use the Display, Tree, List, and General 
display options to configure how content is displayed in the 
Library palette.

19. Breadcrumb Trail: Displays the library path to the currently 
selected folder or item. Use the Up arrow at the left of the 
breadcrumb trail to navigate up to the previous folder level.

20. Library Menu (not shown): Appears in the 32-bit Library 
only. Click the Docking Control icon (the small square) 
in the upper-right corner to select commands that dock, 
undock, close, or enable/disable dragging. Refer to 
“Docking and Floating Palettes” on page 42 for further 
information.

Displaying the Library Palette
If the Library Palette is not open, select Window > Libraries.

The library consists of several different sections that can be 
shown or hidden. For further information, see “Accessing 
Different Content Libraries” on page 131.

• Additional library preferences appear in the Library tab of 
the General Preferences dialog. See “Library Preferences” 
on page 35 for a discussion of the settings you find in 
this tab.

• There are notable differences between the 32-bit and 64-bit 
versions of the Library:

 � When using the 32-bit version of Poser Pro, you can 
dock or float the library palette. Commands to dock or 
float the library appear in the docking options menu, 
accessible by clicking the Docking Control square in the 
upper-rght corner of the Library window.

 � In the 64-bit version (Poser Pro only), the Library 
Palette is displayed in floating (external) state only. The 
docking options menu is not available in the upper-
right corner of the Library window. However, you will 
notice a library popup widget in the upper-right corner 
of the Poser interface that allows you to bring the 
library window to the foreground when it falls behind 
other windows.

 The Library Popup widget.
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When you use the Poser Library as an external 
application (Poser Pro only), you will see two 

icons in the system tray. The icon with the human figure 
brings Poser to the foreground when it appears behind 
other windows. Similarly, the icon with the scrolled 
document brings the external library application to the 
foreground.

 Poser and Poser Library icons.

 � When the Library Palette is floating, you can position 
and resize it however you like. Drag either side of 
the Library palette across your screen to the desired 
width. You can also move the Library palette to a 
second monitor if desired. For further instructions 
on arranging palettes, refer to “Docking and Floating 
Palettes” on page 42.

The Library Palette allows you to display your content in 
a variety of ways. You can display your content in a Tree 
view, which displays all of the content in your libraries in a 
hierarchical list. The tree view appears as shown below if the 
Item List display is turned off

 Viewing library items in Tree view.

Alternatively, you can undock the Library palette and display 
content thumbnails in multiple rows and columns, which allows 
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a better view of all of the content in a selected folder. When 
Item List is open, a hierarchical tree appears in the left side of 
the library. When you select a folder in the tree, the folders and 
content within the selected folder appear in a multi-column 
display that adjusts to fill the width of your library window as 
shown below.

 Displaying thumbnails in multiple rows and columns.

The following section describes how you can customize the 
appearance of the Library palette to suit your needs.

Changing the Library Appearance

A widget appears at the bottom of the Library palette, just 
beneath the library buttons shown in the previous figure. Click 
this widget to expand the Library palette to view the display 
options described in the sections that follow:

 The Library Display Options widget.
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General Options

 General library options.

• Always On Top: Check this option to keep the Library 
window on top of all other open windows on the screen. 
When unchecked, the Library window will be allowed to 
move behind other windows when they have focus.

• Reopen Folders: When checked, preserves the state of 
current open folders when you close and then reopen the 
library. If you toggle it off, the library reverts to a completely 
clean state when relaunched, with all folders closed.

• Show Path Tool Tip: Enable or disable the tool tip that 
displays the path to a library folder when you hover your 
mouse over a folder name in the library.

• Tool Tip Delay (ms): Drag the slider left or right to adjust 
the amount of time between hovering over a library name 

and displaying its path tool tip. Time delay is adjustable 
from 100 to 1000 ms.

• Show Folder Counts: Check or uncheck this option to 
show or hide the number that represents the number of 
items in a folder. When checked, the number of items 
contained in the folder appears within parentheses.

Display Options

 Display library options.

Check or uncheck the options listed below, to show or hide the 
various areas in the Library Palette as desired. These areas are 
labeled in the following figure.
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 Breadcrumbs, Tree, Item List, and Extended Details in the Library 
palette.

• Tree: Displays a hierarchical view of the contents of your 
library. Check or uncheck this option to show or hide the 
hierarchical tree in the Library Palette. If the Item List Panel 
is turned off, thumbnails appear in the tree.

• Item List Panel: Displays the folders and content 
thumbnails for the folder that is selected in the tree. The 

thumbnail display appears in multiple rows and columns 
that adjust to the width and height of the Library palette. 
Check or uncheck this option to show or hide the item list 
panel.

• Extended Details Panel: Displays information about the 
selected item. Check or uncheck this option to show or hide 
the extended details.

The Extended Details panel will display basic 
information such as the product name, size, the 

date the file was installed and last modified, and the 
path to the file on your computer. Additional metadata 
can also appear about a library item if it has been added 
by the author of the content. Extended details can 
include additional information such as author name, 
copyright information, usage instructions, and more. 
Metadata is stored in a file that ends with an XMP 
extension. For more information, see the article at 
http://blog.smithmicro.com/2010/07/12/poser-3d/
metadata-makes-life-in-poser-easier/.

• Breadcrumbs: Displays the runtime folder path to the 
selected library folder. Check or uncheck this option to show 
or hide the breadcrumbs.

• Ticker: Displays up to the minute news about Poser and 
related content.

http://blog.smithmicro.com/2010/07/12/poser-3d/metadata-makes-life-in-poser-easier/
http://blog.smithmicro.com/2010/07/12/poser-3d/metadata-makes-life-in-poser-easier/
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When breadcrumbs are displayed, you can use 
the Up arrow icon (at the right of the 

Breadcrumb trail) to navigate to the next highest folder 
level in the path. You can also click any folder in the 
breadcrumb trail to move up to the selected level.

Tree Options

Thumbnails and additional product details appear in the Tree if 
you have selected to disable the Item List Panel. The options in 
the Tree Options section control the size of preview and selected 
item thumbnails, details, and other items in the Tree.

 Tree library options.

• Thumbnail Size: Drag the slider left or right to decrease or 
increase the size of the preview thumbnails.

• Selected Thumbnail Size: Drag the slider left or right to 
decrease or increase the size of the thumbnail for selected 
library items.

• Show Item Details: Shows or hides the File Name, Size, 
Installed, and Modified details that appear beside the 
currently selected library item.

• Tree Indentation: Drag the slider left or right to decrease 
or increase the amount of indentation for items and folders 
that appear within and beneath library folders.

• Show Folder Thumbnails: Check or uncheck this option to 
show or hide Folder icons in the library. When unchecked, 
only the name of a folder will appear in the library. When 
checked, a small Folder icon appears beside the folder 
name.

List Options

When the Item List is enabled, thumbnails appear in multiple 
columns that adjust to fit the width of the panel. Settings in 
the List Options section control size of the thumbnail and the 
placement of text around the thumbnail.

 List library options.
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• Thumbnail Size: Drag the slider left or right to decrease or 
increase the size of the content thumbnails.

• Label Height: Adjusts the amount of vertical space between 
the thumbnail rows to allow for labels that have multiple 
lines.

• Horizontal Gap: Adjusts the amount of horizontal space 
between the thumbnails

Details Options

 Details library options.

• Show Image: Check this option to display an image of the 
selected library item in the Extended Details panel. Uncheck 
the option to remove the image display.

• Max Image Size: If you have images displayed in the 
Extended Details panel, drag the slider toward the left to 
reduce the size of the image, or toward the right to increase 
the size.

Accessing Different Content Libraries
Poser contains two Libraries: Runtime (contains the content 
that shipped with your copy of Poser) and Downloads (a default 
folder for added third-party content).

Poser content libraries are arranged in Runtime 
folders, which contain many different types of 

components that are used in Poser. In addition to 
content such as figures, props, hair, and poses, Runtime 
folders can also contain scripts, interface files, plug-ins, 
and other application-critical data. The collection of 
different types of elements in a Runtime folder is known 
as a Library.

You may add as many Libraries as you wish. This feature allows 
you to store Poser content in different folders and/or different 
drives, making content management more powerful than ever. 
Also, should you need to reinstall Poser for any reason, you can 
do so without affecting your custom Libraries. You can access 
each of your Libraries using the Library palette.

Switching Libraries

To filter content between loaded Library Runtimes, click on the 
Show Library menu, which is located along the top of the Library 
tab of the Library palette. Doing so will open the Available 
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Libraries pop-up menu, from which you can display the 
contents of any single Library, or of all your runtime libraries.

 You can add and access external libraries from the Library palette.

Adding Libraries

As mentioned earlier, Poser creates Runtime and Download 
libraries during installation, dependent upon which content 
you elect to install during installation. There is also a great 
deal of third-party content available for Poser, and if you have 

acquired a large collection you may find it necessary to arrange 
your content into multiple library folders. Then you can use the 
following process to make your additional folders appear in the 
Library palette.

Runtime folders have a structure similar to the following. 
Folders and content shown in italics are unique to the content 
and are named by the creator of the content.

Runtime
 Geometries
  (vendor or product folder)
	 	 	 OBJ	files	for	product
 Libraries
  Camera
   (vendor or product folder)
	 	 	 	 Camera	and	thumbnail	files	for	product
  Character
   (vendor or product folder)
	 	 	 	 Character	and	thumbnail	files	for	product
  Face
   (vendor or product folder)
	 	 	 	 Face	and	thumbnail	files	for	product
  Hair
   (vendor or product folder)
	 	 	 	 Hair	and	thumbnail	files	for	product
  Hand
   (vendor or product folder)
	 	 	 	 Hand	and	thumbnail	files	for	product
  Light
   (vendor or product folder)
	 	 	 	 Light	and	thumbnail	files	for	product
  Materials
   (vendor or product folder)
	 	 	 	 Material	and	thumbnail	files	for	product
  Pose
   (vendor or product folder)
	 	 	 	 Pose	and	thumbnail	files	for	product
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  Props
   (vendor or product folder)
	 	 	 	 Prop	and	thumbnail	files	for	product
  Scene
   (vendor or product folder)
	 	 	 	 Scene	and	thumbnail	files	for	product
 Textures
  (vendor or product folder)
	 	 	 texture	image	files	for	product

Poser products do not always contain all of the above-
mentioned folders beneath the Runtime folder. For example, 
if you are installing a piece of clothing, it might add files in the 
Geometries, Props, and Textures folders but not in the others.

As an example of creating a new Library on your hard drive, 
assume the following:

• You have collected dozens or hundreds of items that relate 
to several different figures. You want to arrange them into 
different libraries that make the content easier to find.

• You have an external hard drive D: that has lots of room 
to store content. You decide you want to install all of your 
content there.

• You create a Content folder to store all this content. 
Beneath that Content folder, you create other subfolders 
to store each of the content types you want to organize. 
The folders can be named for a specific figure (Miki 3, 
Terai Yuki, etc) or type of character (Monsters, Animals, 
etc), or even a theme (Anime, Horror, Sci Fi, etc). Arrange 

them in any way you like. The following figure shows some 
examples.

 Adding a Library folder.

• Now you want to install all of the content that relates to one 
figure (such as Smith Micro’s Miki 4 figure). You extract/
install all of your Miki 3 clothing, hair, and other related 
content into the D:\Content\Miki 4 folder. The final path to 
the runtime folder is D:\Content\Miki 4\Runtime.

• To add this example Miki 4 Library to Poser, you would 
proceed as follows:
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1. Open the Library palette if it is not open.

2. Click the Add Library button (+) to open a standard 
Browse for Folder dialog box.

 The Add Library icon.

3. Select the hard drive that stores the Library files you want to 
add (for our example, you would choose D:)

4. Navigate to the folder that stores the Runtime folder and 
its subfolders (for our example, you would choose Content, 
then Miki 4).

5. Click OK to add the new Library

When adding existing Poser libraries to your 
Poser Library palette, you must preserve your 

Runtime folder name and structure (<drive > :\<folder 
> \<subfolder > \Runtime\<folders >. Navigate the 
Browse dialog to your desired Runtime folder. The 
added Library will appear using the name of the folder 
containing the Runtime folder.

Poser allows you to create your own folders to 
store your own poses, material settings and 

other creations, or so that you can organize library 
items to your liking. See “Creating Subfolders” on page 
161.

Removing Libraries

The Remove Library button appears when a library other than 
the Poser default libraries is selected. You cannot delete the 
default Poser library. Deleting libraries only severs the link 
between the Library folders and the Library palette. It does not 
remove any of the folders or content from your hard drive. This 
protects your data from accidental deletion and allows you to 
reuse Libraries at need (such as from removable drives).
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If you want to remove the Library from your 
hard drive completely, you will need to do this 

manually by deleting the folder and contents from your 
hard drive. Exercise extreme caution when deleting 
library folders from your hard drive, as they will be 
irretrievably lost.

To remove a library:

1. Use the Show Library list to select a Library that you 
previously added using the steps outlined in “Changing the 
Library Appearance” on page 127

Note that you will be unable to delete libraries 
that were installed during the Poser installation 

You can only remove libraries that you added yourself.

2. Click the Remove Library button (minus sign) to remove 
the selected Library from the Library palette. The name of 
the library is removed from the Show Library list, and its 
contents no longer appear in the Library.

 The Remove Library icon.

Loading and Managing Items using the 
Library Icons

The Library icons appear as shown in the following figure. 
Certain Library icons are only available for specific categories. 
These icons appear at the bottom of the palette.

From left to right, these icons are:
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 Several icons add content to the scene and to the Library.

• Single check mark: Clicking the single check button serves 
different functions as listed below:

 � Figures Category: Changes the selected figure.

 � Poses Category: Applies the pose to the figure for 
which it was originally designed.

 � Faces: Applies the selected face expression to the 
currently selected figure.

 � Hair: Adds selected hair to the scene.

 � Hands: Applies a hand pose to the currently selected 
figure. You are prompted to specify right hand or left 
hand.

 � Props: Adds the currently selected prop to the scene.

 � Lights: Replaces the existing lights in the scene with 
the currently selected light set.

 � Cameras: Applies the camera settings to the camera.

 � Materials: Applies the single material to the currently 
selected single material in an object; or, applies a 
Material Collection to all materials in the current object.

 � Scenes: Closes the current scene and replaces it with 
the scene you are adding from the library.

• Double check mark: The double check mark button 
appears for the following categories and serves the purposes 
listed below:

 � Figures Category: Creates a new figure in the scene. 
Typically used to add additional human characters, 
clothing, and other poseable figures.

 � Poses Category: Applies the currently selected pose as 
a universal pose.

 � Lights: Adds the lights in the library to those already 
present in the scene.
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 � Scene: Keeps the content that is currently in your 
scene, and adds the additional content from the 
selected library item.

 � Add a Folder: Click the Add a Folder (+) button to 
create a folder beneath the currently selected Library 
folder.

• Add to Library: Clicking the Add to Library (+) button 
adds the selected item to the Library palette.

• Delete from Library: Clicking the Delete from Library (-) 
button removes the selected item from the Library palette.

• Add to Favorites: Click to add the currently highlighted 
library item to your Favorites list.

Placing/Adding Items to the Poser 
Workspace

In addition to using the library icons as discussed in the previous 
section, you can also drag an item from the library and drop 
it into your scene. As you drag an item from the library to the 
scene, a tooltip displays the action that you are performing.

You can also select multiple items into the library and add 
them to your scene at the same time. Click to select the first 
item, and then press the Shift key (Windows or Mac) to select a 
contiguous range of thumbnails between the first and last items 

you selected. You can also CMD-click (Mac) or CTRL-click 
(Windows) to add additional items to the selection. Then drag or 
drop the additional items into your scene.

 Adding clothing to a figure.
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Removing an Item From the Poser 
Workspace

To remove an item from the Poser workspace, first select the 
item to remove by either selecting it in the Document window 
or using the Current Actor pull-down menu (see “Select Figure/
Current Actor Menus” on page 77), then press [DEL].

About Library Palette Categories
Poser’s new library allows you to quickly select categories and 
the items contained within them.

 If you are seeking more information related to 
installed third party Poser content, please look in 

the “ReadMe” Folder located in the Poser Pro installed 
“runtime” folder. This folder is in the content location 
that you selected when installingPoser Pro. There are 
not ReadMe’s for every specific piece of content, but 
there are some that may help get you more familiar 
with how pieces of content were designed to be used 
together, special features of a piece of content or in 
depth details on how to use it. The P.I.C.K Content for 
example has a PDF file in the ReadMe/CP Partners/
MindVision-GDS folder which has in depth details on 
how to use it to its fullest potential

• Click a Category icon to select a Content category. Then 
drill down in the hierarchical list in the Library list to select 
the item you want to add to your scene.

 Category icons help you choose a Library category.

• You can also drill down through the Category menu to 
select an item. First, click the Category icon to select the 
main category for your content. Then click the Category 
button (shown in the following figure) to drill down in the 
menus until you find the item you want to choose. In the 
following figure, the menu drills down from Hair > Poser 
Content > People > Alyson to list all of the available hair 
objects in that folder.
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 Category menus allow you to select a category folder.

The Library palette categories are described in further detail 
below in “About Library Palette Categories” on page 138. 
Please refer to “Loading and Managing Items using the Library 
Icons” on page 135 for information on working with Library 
palette content.

The default categories are broken down by Poser file type: 
Figures, Poses, Faces, Hair, Hand poses, Props, Lights, 
Cameras, Materials and Scene. Please refer to “Poser File 
Types” on page 848 for a brief discussion of Poser file types 

and how they relate to using Poser. When you switch between 
categories, the Library remembers which item was selected the 
last time you used a specific category.

You can navigate through the Content pane as follows:

• When you reach a content folder that contains items, you 
can navigate through the contents in the folder using your 
arrow keys. Click to activate a selection in the Content pane, 
then use the Left and Right arrow keys to collapse or expand 
folders, and the Up and Down arrow keys to navigate 
through the folder contents.

• Press the Refresh button to refresh the contents. This is 
useful after you install content while Poser is running.

• The Library popup menu displays nested menus, but you 
can also click on a folder or category to switch to it, and then 
highlight an item to load it.

The Figures Category

Figures are poseable content items that use an extension 
of CR2 or CRZ. The Figures category houses your poseable 
Poser figures. This category contains many figures to work 
with, including various types of males and females, children, 
skeletons, mannequins, stick figures, and animals. Morph values 
can be saved with figures if you choose the option to do so while 
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saving them. Newer Poser figures feature fully articulated hands 
and feet with movable fingers and toes.

There are two main types of clothing used in 
Poser: conforming clothing (discussed here), and 

dynamic clothing, which are treated as and found in the 
Props library. You’ll find more information about 
dynamic clothing in “Chapter 27: The Cloth Room” on 
page 550.

Poser includes two versions of both M/F human 
skeletons. These skeletons are found in the 

Additional Figures/Skeletons content folder. The 
human skeletons named Ryan and Alyson are designed 
to conform inside the Ryan or Alyson figures to create 
medical illustration effects. These conforming skeletons 
will follow the conformed figures’ poses and positions. A 
semi transparent version of each character’s texture is 
found in the Materials in the Library, so setting up a 
skeleton inside a figure is easy to achieve using these 
pre-configured material collections. The fully articulated 
M/F skeletons are accurate versions of the human 
skeleton with each bone poseable. These are not 
designed to conform inside the human figures, but 
instead work best on their own.

 The Figures category stores poseable figures, such as humans and 
animals.

Some models are available in high- and low- resolution versions. 
Use high-resolution models for realism, and low-resolution 
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models (these have very low polygon counts) when performance 
matters. For example, using low polygon figures instead of high 
polygon figures in the distance of a large scene can conserve on 
your computer resources.

Replacing Figures

If you want to replace a figure or light in your scene with one 
from the Library palette:

1. Select the figure you wish to replace and click the Change 
Figure (single check mark) button.

2. If you are replacing a figure, the Change Figure dialog 
appears with the following options:

 � Keep modified geometries: Check this option if you 
have modified the geometry of the figure with morphs 
and want to pass the modifications on to the figure 
that is replacing it. Props and magnets attached to the 
figure, and other changes such as groups changed or 
added and normals reversed, will be applied to the 
figure after replacement.

 � Keep attached props: Check this option if you have 
attached props to the figure and want to attach them to 
the figure that is replacing it.

 � Keep attached deformers: Check this option if you 
want the new object to use any deformers (magnets or 
wave deformers) that you have added to the object that 
is being replaced.

 � Keep attached figures: When checked, any figures 
that are attached to the original figure will remain 
in the scene and will be attached to the new figure. 
For example, if you have Alyson wearing conforming 
clothing, and then you replace Alyson with Alisha, then 
Alisha will wear the same clothing. When this option 
is not checked, the clothing worn by the original figure 
will be removed from the scene when the replacement 
figure appears.

 � Keep current proportions: To have the new 
figure retain the old figure’s proportions, check the 
Keep current proportions checkbox. Leaving this 
checkbox blank allows the new figure to retain its own 
proportions.



Poser Pro 2014
Reference Manual 

142

Chapter 7: The Poser Library

 Change Figure options.

3. After you make your selections, click OK to add the figure.

Adding Conforming Clothing: Automatic Conforming

The simplest way of clothing figures is with conforming 
clothing. Conforming clothing is poseable, just like a human or 
animal figure. This type of clothing is typically designed for a 
specific figure (for example, clothing designed for Alyson will 
not fit or conform exactly to the G2 figures). However, when 
conforming clothing is “attached” (or conformed) to the figure, 
it automatically bends and poses along with the character that 
wears the clothing.

Options in the Properties dialog allow you to 
choose whether or not you want to include 

morphs and/or scaling when conforming your clothing 
to a figure. For further information, see “Figure 
Properties” on page 193.

Due to fundamental changes to Alyson 2 and 
Ryan 2 figures, conforming clothing created for 

the original Alyson and Ryan figures will not 
automatically conform. For best results, clothing 
originally created for Alyson and Ryan can be converted 
using Wardrobe Wizard (included with this copy of 
Poser) to fit the new Alyson 2 and Ryan 2 figure 
variations. See “Chapter 29: Wardrobe Wizard” on page 
589 for detailed information about using the 
Wardrobe Wizard.

Conforming clothing is rigged like a figure, including the same 
joint parameters. Some conforming clothing includes morphs 
that correspond with the morphs in the figure.

You will find conforming clothing in either the Figure library or 
the Props library.

• When found in the Figures library (as is typical for older 
clothing, or conforming clothing created by third-party 
content creators), conforming clothing will use a CR2 or 
CRZ extension.
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• When found in the Props library (as is common for Poser 7 
and later, and G2 Figure clothing prepared by Smith Micro), 
conforming clothing will use a PP2 or PPZ extension.

You can drag and drop conforming clothing onto a selected 
figure and the clothing will automatically inherit the pose of the 
figure. To automatically conform clothing to your figure, follow 
these steps:

 Conforming clothing automatically “fits” to the character that it is 
designed for.

1. Click to select the figure in your scene that you wish to 
clothe. This makes it the active figure in your scene.

2. Locate a conforming clothing item in the desired Figures or 
Props category. Clothing is often named for the figure that 
it is designed to fit (for example, Alyson Pants).

3. Drag the clothing from the library and drop it onto the 
figure that you selected in Step 1. If your figure is posed, you 
should see the clothing conform to the pose of the figure.

Adding Conforming Clothing: Manual Conforming

You can use the Figure > Conform To command to manually 
conform clothing to any figure in your scene. The process is as 
follows:

1. Select the figure you wish to clothe.

2. Select a conforming clothing item from the desired Figures 
or Props category. Clothing is often named for the figure 
that it is designed to fit (for example, Alyson Pants).

3. If your clothing is in the Figures category, click the Create 
New Figure button at the bottom of the Library palette. If 
the item is in the Props category, click the Apply Library 
Preset button. The clothing appears to the scene in its 
default position and pose. Alternatively, you can drag and 
drop from the Library to the Document window.
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4. When added to the scene, conforming clothing appears 
in the Select Figure menu pull-down menu (described 
in “Select Figure/Current Actor Menus” on page 77) 
. Verify that the clothing item that you want to conform is 
currently selected.

5. Choose Figure > Conform To. The Conform To dialog 
appears, listing all of the figures in your scene.

 The Conform To dialog allows you to select the character that will 
wear the clothing.

Some tight-fitting conforming clothing may not 
completely cover the base figure’s skin, 

particularly when the figure is animated. You might 
notice the base figure poking through areas of the 
conforming clothing. There are two ways to correct this 
problem. The first method is to hide the body part of the 
figure that is poking through by setting the body part as 
invisible (see “Body Part Actor Properties” on page 
195). The second method of correction is to use the 
Morph Brush to raise the clothing over the hole, or lower 
the body part underneath the clothing (see “Creating 
Morphs with the Morphing Tool” on page 642).

6. Select the figure you wish to conform the clothing to in the 
dialog that appears. Click OK when finished. The clothing 
conforms to the figure.

7. Apply a pose to the figure, and the conformed clothing 
should automatically snap to the new position.

If the clothing item that you added does not 
appear in the Select Figure menu, check inside 

the Current Actor > Props menu, because you may 
have added a dynamic clothing item instead. For further 
information on using Dynamic clothing, see “Chapter 
27: The Cloth Room” on page 550.
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You can also use conforming clothing without a 
figure. Conforming clothing is treated like any 

other Poser figure and can be added to the Poser 
workspace and posed/animated just like any other 
Poser figure.

The Poses Category

The Poses Library palette category houses poses (*.PZ2), which 
actually fit into several different categories.

Figure Poses

Poses were originally designed as pre-defined poses (standing, 
sitting, working, and so on) that you could apply to your 
currently selected figure. Pose files store pose information 
for an entire figure, including its hands (see below for more 
information). They contain joint positions for each of the figure’s 
joints (such as Left Elbow bend 45 degrees).

When adding a pose to a figure, facial 
expressions are not applied, even if they are 

included in the Pose file. This preserves any work you 
have done to your face prior to applying the pose. To 
apply facial expressions, choose items from the Face 
category in your library. If the pose contains morph 
settings they will override the values on the figure to 
which they are applied.
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 Use presets in the Pose category to pose your characters.

To add a pose to a figure:

1. Select the figure (not its clothing) to apply the pose to.

2. Open the Poses category and highlight the pose that you 
want to apply to the figure.

3. Choose one of the following options:

 � Click the Apply Original Pose (single check mark) 
button to apply the pose to the selected figure when the 
pose was created specifically for that figure.

 � Click the Apply Universal Pose (double check mark) 
button to apply the pose to the selected figure as a 
Universal pose.

 � Drag and drop the pose from the Library to the figure. 
A tooltip displays the name of the character as your 
mouse hovers over it. Release the mouse when the 
tooltip displays the correct character name.
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 After posing, the clothing also poses with the character.

Some of the Poses included in the Library are 
Universal Poses, meaning they will be 

compatible with any human Poser figure. If you check 
the Apply Universal Poses option in the General 
Preferences dialog > Library tab, you can save any pose 
to your library as a Universal pose.

Poses that are set-up for figures with standard 
rigging may not apply correctly when uses with 

figures provided with Poser 7 and later.

Poses that were created in Poser 6 or earlier 
versions applied specifically to a particular 

figure. For example, a pose you may have created for 
the James figure may not work correctly when applied 
to the Kate figure due to the different joint setups 
between the two figures. However, you can apply a 
legacy pose to the figure for which it was designed, and 
then save it to the Library, which will convert the pose to 
a Universal Pose for use with other figures.

Material (or MAT) Poses

Material collections, discussed in “The Materials Category” 
on page 157, are the preferred method for saving complete 
materials for a figure or prop to the Materials library. Third-
party content creators sometimes use Material Poses (or MAT 
files for short), as an alternative to MC6 material collection files. 
MAT Poses are typically found in the Poses library and are not 
created or tested by Smith Micro Software. If you need help with 
MAT files, please refer to the file creator (if you purchased or 
obtained a MAT file using the Content room, for example) or 
to one of the many online resources, some of which are listed in 
“Third-Party Forums” on page 9.
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Other Pose Types

Though not as common as figure and MAT poses, you will also 
find a mixture of other types of pose files in the Pose Room. Like 
MAT poses, these are generally created by third-party content 
creators. Other uses for Pose files include:

• Many Smith Micro characters (including Ryan and Alyson) 
include Specialty poses that zero a figure, add deformers, 
turn IK off of the legs and arms, and lock or unlock the toes. 
Third-party content may or may not include similar poses.

 Specialty poses perform specific functions that help with posing and 
fitting clothing.
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• MOR poses, which apply character morphs and settings to 
a figure.

• INJ and REM poses, which inject or remove injected 
morphs into or from a figure.

When you are not certain what a pose type is used for, check 
the Readme file (which usually accompanies the third-party 
product), or contact the individual that created the product.

Adding Poses with Animation Layers

If you are adding a Pose set containing Animation Layers to your 
scene, a dialog will appear asking whether or not you wish to 
Add new layers to your scene, or Merge all the layers in the Pose 
set into a single layer, which you can select from a pop-up menu. 
The dialog also provides you with options for how to handle 
duplication of layer names when adding new layers to the scene. 
For more information on Animation Layers, see “Layers Tab” on 
page 469.

 Additional options for poses that have animation layers.

 The Faces Category

The Face Library palette category houses facial expression files 
(*.FC2), which can be applied to your currently selected figure.

Face files contain parameter settings that activate facial morph 
targets (see “Chapter 30: Modifying Figures & Props” on 
page 614 for information about morph targets) to create the 
expression. These files are the same as if you manually adjusted 
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each of the face dials available for your current figure, or if you 
use the Random Face poses in the Library, except that they apply 
preset values at once, saving time.

Poser Face directories contain full facial expressions (Angry, 
Disgust, Fear, and so on). You can also dial these individually, 
by facial region (eyes, lips, cheeks, and so on). To do so, click on 
the head to find the full set of facial morphs. Any combination of 
these head/face morph targets will be stored in the Face category 
when you add a new entry.

Facial expressions are often designed for a particular figure, 
since each figure can have different facial parameters available. 
For example, an expression file created for the Poser 6 Male 
figure (James) may not work on Ryan, because Ryan has far 
more available facial parameters.

Ryan and Alyson’s Face directories contain full 
facial expressions. You can also dial the 

expressions manually in the Morphs section of the 
Parameters palette when you select Ryan or Alyson. To 
dial these individually, by facial region such as eyes, 
lips, or other feature, click the head to find the full set of 
morphs. You can save any combination of these head/
face morph targets when you save a new face to the 
Library’s Face category.

To add a facial expression:

1. Select the figure to apply the expression to.

2. Locate the desired facial expression in the Face library.

3. Double-click the selected facial expression, or click 
the Apply Library Preset button, or drag the selected 
expression from the library to the character. The facial 
expression on your figure changes.
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 Expressions for your characters are found in the Face category.

The Hair Category

The Hair Library palette category houses hair (*.HR2) files, 
which can be applied to your currently selected figure. Hair 
created for one figure may or may not fit or work with other 
figures.

There are three different types of hair used in Poser:

• Conforming hair, which is commonly found in the Figures 
library (usually when created by third-party vendors) or 
in the Hair library (usually when created by Smith Micro). 
This type of hair is added and conformed to your figure 
as instructed in “Adding Conforming Clothing: Manual 
Conforming” on page 143.

• Prop hair, which is a modeled and textured OBJ file found 
in the Hair category, using an HR2 extension.

• Strand-based (or dynamic) hair, which is created in the Hair 
room and typically found in the Hair category, using an HR2 
extension.

Strand-based hair created in the Hair room 
cannot be saved to the Library palette unless it is 

saved with underlying geometry such as a figure or 
skull cap.
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Adding Hair to a Figure

Conforming hair is added to your figure using the same method 
as conforming clothing, discussed in “Adding Conforming 
Clothing: Manual Conforming” on page 143.

To add either strand-based or prop-based hair to a figure:

1. Select the figure to which you wish to add hair.

2. Select your desired hair using the Library palette.

3. Click the Apply Library Preset icon or drag the hair from 
the library to your scene. The hair is added to the figure.

If your figure already has prop-based hair, 
adding new hair replaces the old. You can either 

add or replace selected conforming hair, depending on 
whether you choose the single check mark or double 
check mark (which adds another conforming hair 
figure).

 The Hair library stores many different types of hair for your 
characters.
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While prop-based hair usually orients itself to the angle and 
rotation of the head, you may need to reposition the hair to 
precisely fit the figure’s head (especially if it was created for 
another figure as is the case in this example). To do this, use the 
Current Actor pull-down menu to select the hair, then use the 
hair’s Trans parameter dials as necessary in the Parameters 
palette. To translate conforming hair, you usually use the 
Translate dials in the Head actor of the head.

 You can use the YTrans parameter dial to adjust the height of the 
hair.

The Hands Category

This Library palette category houses hand (*.HD2) files, which 
can be applied to your currently selected figure. Hand files are 
subsets of Pose files that only contain positioning information 
for the hand and its children (fingers). Hand poses contain both 
finger positions and wrist positions.

Not all figures hands are created using the same 
number of joints. Ryan and Alyson contain an 

additional joint at the knuckle and older hand poses 
may not work correctly on their hands. Additionally, 
Hand poses saved using Ryan or Alyson may not apply 
to older content correctly.

If you apply a pose file to a figure then apply a hand, only the 
hand positions will change. If, however, you apply a hand file to 
a figure followed by a pose, the pose application will override the 
positions specified by the hand file.
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 The Hands category stores poses that affect the hands and fingers.

To add a hand pose to a figure:

1. Click the figure to which you want to apply the hand pose.

2. Select the Hands category in the Poser Library, and select 
the hand pose that you want to apply.

3. Click the Apply Library Preset button at the bottom of the 
Library palette, or drag the hand pose from the library to the 
character to which you want to apply the pose. A dialog asks 
if you want to apply the pose to the figure’s right hand or left 
hand. Click either button to apply the pose.

The Props Category

This Library palette category houses props (*.PP2), which are 
loosely defined as static or poseable objects that are not figures. 
Items such as swords, balls, canes, furniture, walls, some types 
of clothing (such as dynamic) and other non-conforming items 
fall into this category. You will also find conforming clothing 
items in the Props library.

For more information about Dynamic Clothing, 
see “Chapter 27: The Cloth Room” on page 

550.
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 The Props library includes many elements for scene building.

Adding Props

To add a prop to your scene:

1. Open the scene to which you want to add the prop.

2. If you want to replace a prop that is already in your scene 
with another prop from the library, select the prop in your 
scene that you want to replace.

3. Choose the Props category from the Library palette.

4. From the Library palette, select the prop you want to add to 
the scene.

5. Click the Apply Library Preset (single check mark) button.

6. By default the prop appears in the center of the scene in 
its default position. You can use the Translate dials in the 
Parameters palette to reposition the prop to the correct spot 
in your workspace.
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 A prop added to a scene.

If you wish to have the prop move with another 
scene item (such as a tennis racket moving in 

concert with the figure’s hand), you need to specify a 
parent for the racket. Please refer to “Changing a 
Parent” on page 231 for directions on setting a parent 
for an object.

The Light Category

This Library palette category houses lights (*.LT2), which 
includes the number, color, position, and other lighting 
attributes. Please refer to “Chapter 12: Lighting” on page 261 
for a description of Poser lights.

 Several lighting presets can be found in the Lights category.
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The Camera Category

This Library palette category houses cameras (*.CM2), which 
includes all Poser cameras, their positions, and other attributes. 
Please refer to “Chapter 11: Cameras” on page 242 for 
information about Poser cameras.

 The Camera category stores different settings to position cameras 
in your scene.

The Materials Category

Poser’s Material library provides an easy way to apply preset 
materials to the items in your scene. You can navigate through 
the items in your library, and then drag and drop compatible 
materials from the Library to the objects in your scene. As you 
drag your material into the scene, a tooltip displays the name 
of the actor in your scene. Release the mouse when the tooltip 
displays the correct actor name.

When saving materials to the library, Poser offers two methods 
for storing material definitions for an entire figure in a single file. 
Both of these methods can save considerable time, since they 
can apply colors and maps to an entire figure simply by loading 
them from the Library palette instead of having to add them one 
by one.

This Library palette category houses materials (*.MT5), which 
include all Poser materials and any associated shader trees 
created or loaded into the Material room. Materials and material 
collections can be dragged from the Library and dropped onto an 
object in your scene.

The Material Collection (MC6/MCZ) file format was designed as 
a fully integrated replacement for MAT pose files. Additionally, 
Poser includes a built-in compatibility feature, which enables 
you to simply change the extension of your MAT files to MC6 
or MCZ, and Poser will recognize them as Material Collections. 
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However, Smith Micro Software does support the MAT files 
included in your Poser installation.

 Use the Materials category to apply different textures and 
materials to the items in your scene.

Adding Materials to the Library Palette

Poser offers the option of saving either single materials, or 
grouped material collections from a single figure, to the Library 
palette.

To save single material to the Library palette:

1. Open the Material Room.

2. In the Library palette, select the desired Category/
Subcategory that will store the new material.

3. Move the mouse into the Preview window, where it turns 
into an Eyedropper tool. Use the eyedropper to “pick up” the 
material that you want to save. The material settings appear 
in the Simple or Advanced view in the Material room.

4. Click the Save to Library icon (+) at the bottom of the 
Library palette.

5. In the New Material Set dialog, select the Single Material 
radio button.

6. Enter a name for the Material and click OK. A square 
showing the single material appears in the currently selected 
Material library category/subcategory.
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Adding Material Collections to the Library Palette

Poser also allows you to save some or all of the materials for a 
single figure together in a Material Collection, in addition to 
saving single materials individually. Simply select the Material 
Collection option in the Add to Library dialog, as described 
below, and choose which materials you would like to include 
in the collection. Like MAT files, Material Collections provide 
the convenience of grouping materials in a single file, and also 
offer the added benefit of seamless integration into your Poser 
workflow. Please refer to “Chapter 14: The Material Room” on 
page 296 for information about the Material room.

To save Material Collection to the Library palette:

1. Open the Material Room and select your desired category/
subcategory.

2. Move the mouse into the Preview window, where it turns 
into an Eyedropper tool. Use the eyedropper to “pick up” 
one of the materials in the object that uses the material 
collection that you want to save. The single material that you 
clicked appears in Simple or Advanced view in the Material 
room.

3. Click the Add to Library icon (+) at the bottom of the 
Library palette.

4. In the New Material Set dialog, select the Material 
Collection radio button, and click the Select Materials 
button to open the Select Materials dialog.

5. Choose which materials you would like to include in your 
collection from the list presented in the Select Materials 
dialog, and click OK. Select All and Select None buttons 
are also provided to add or clear all materials in the 
selection set.

6. Enter a name for the Material Collection and click OK. A 
small thumbnail of the object with your material settings 
appears in the currently selected Material library category/
subcategory.

The Scene Category

The Scene category allows you to load or save complete scenes. 
This is especially useful when you want to work with objects 
that are inter-related to each other, or which use dependent 
parameters to interact with each other. It also allows you to 
load complex scenes or a complete set design -- including lights, 
cameras, and props in the background -- with a single click.
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Adding Scenes from the Library

You can use the Scene category in the library to open a scene, 
or to merge content from an existing scene into your current 
project. Follow these steps:

1. Open the Library and select the Scene category.

2. Create or navigate to the folder that stores the scene you 
want to use.

3. Choose one of the following:

 � Click the Load New Scene (single check mark) button 
to replace the contents of the current scene with the 
scene contents in the library. This is the same as using 
the File > Open command. You will be prompted to 
save any unsaved changes in the existing project before 
its contents are replaced.

 � Click the Import Scene (double check mark) button 
to add the contents of the scene in the Library to 
your current scene. This is the same as choosing the 
File > Import > Poser Document/Prop command. 
Everything from the imported scene will be added; 
however if a light in the existing scene is named the 
same as a light in the imported scene, it will be replaced 
with the light from the imported scene.

Saving Scenes to the Library

Saving the scene into the library allows you to easily find and 
reuse projects that you have previously created, and also makes 
it easier to share complete project settings with others.

To save a scene to the library, proceed as follows:

1. Open the Library and select the Scene category.

2. Create or navigate to the folder that will store the new scene.

3. Click the Add to Library icon (+) at the bottom of the 
Library palette.

4. In the New Set dialog, enter a name for the new scene.

5. Click OK. A small thumbnail of the scene appears in the 
currently selected Scene library category/subcategory.
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 The Scene category allows you to use or save complete scenes into 
the Library.

Maintaining Your Library Palette
You can maintain your Library palette by adding and removing 
items to and from the Library palette, as described below.

Creating Subfolders

You can create new subfolders in the library to store your 
content. Follow these steps:

1. Use the Show Library menu to select <All > libraries, or the 
library to which you want to add the folder.

2. Click the category icon that applies to the subfolder you 
want to create. For example, if you are using the new folder 
to store a Prop, select the Prop category.

3. Highlight the folder beneath which you want the new folder 
to appear.

4. Click the Create New Folder icon located at the bottom of 
the Library palette. You are prompted to enter a name for 
the new folder.

5. Enter a new folder name and choose OK. The folder appears 
in the Library palette.
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 Creating a new Library subfolder.

Adding Items to the Library

The following section provides some notes on saving content in 
general.

Saving an item to the Library palette adds the appropriate 
item to the currently selected category/subfolder. The actual 
file location of your saved item will display along the bottom 
of the Library palette when you select the item by clicking on 
its preview image once it has been added to the Library. In 
addition, when you save content to the Library, a basic set of 
metadata is saved along with the object. This metadata appears 
in the Library’s Extended Details panel when it is displayed. 
For more information about the Extended Details panel and 
metadata, see “Display Options” on page 128.

To add an item to the Library palette:

1. Select your desired category/subcategory.

2. Click the Save to Library icon (+) at the bottom of the 
Library palette.



Poser Pro 2014
Reference Manual

163

Chapter 7: The Poser Library

 Library buttons help you maintain and use your library.

3. Complete the dialog that follows (see following subtopics for 
information on category-specific dialogs).

4. Enter a name for the new Library palette item and click 
OK. You may be prompted to select a subset of actors for 
inclusion in the saved item, depending on the item type 
being saved (poses, expressions, props, lights, cameras or 
material collections). Please refer to the following sub-topic 
for information on selecting actors.

5. Depending on the Library palette category being saved to, 
you may be asked if you wish to save morph channels (such 
as facial expressions, muscle bulges, etc.). Saving morph 

channels will preserve all adjustments you might have made 
to any morph target parameters. You may also be asked 
whether you wish to save Body transformations; this option 
will preserve any modifications to parameters on the “Body” 
actor.

 When saving content, you may be prompted for additional 
information to be saved.
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This option appears when saving poses, but you 
need to take care when saving morph channels 

and body transformations with poses that you will 
distribute to others. If your pose is designed as a regular 
pose that reposes the figure (for example, from standing 
to sitting), in most cases you do not want to include 
body transformations or morphs that will affect the 
settings of the figure that is in another user’s scene. On 
the other hand, if your pose is meant to set morph 
targets for a custom figure, you want to include morph 
channels in the pose set.

6. Poses and Faces can save animated data (such as an 
animated pose like swinging a golf club). To select only the 
current frame, select Single Frame. To save more than 
one frame of animation, select Multiple Frames and enter 
your desired starting and ending frame numbers. If you are 
adding an animated pose that includes animation layers, the 
Select Layers button will be enabled. Clicking this button 
opens the Select Layers dialog, which allows you to specify 
which layer(s) you wish to save with the pose. Click OK 
when you have finished making your selections.

 Poses can be saved as still poses (a single frame), or as animated 
poses (multiple frames).

Your new item will be added to the Library palette and will be 
accessible whenever Poser is running. Poser also automatically 
generates an editable .PNG format preview image based on 
Camera position. You can make a better preview image by 
positioning the camera to focus on the item you’re saving.

To add dynamic cloth to the Library palette, add 
it as you would any other prop. For strand-

based hair objects, you must either save a Poser scene 
file (PZ3) with your hair object in it or grow hair on a 
prop and save that prop to the Library palette.
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Adding Actors to a Library Palette Entry

When you save Poses and Faces to the library, a Select Subset 
button appears in the New Set dialog, allowing you to specify 
which actors to include in the library file. This allows you to 
create poses that affect only a part of the figure (for example, a 
pose that only affects the arms and hands, rather than the entire 
body of a figure).

If you opt to select a subset of actors within your scene for saving 
to the Library palette, the Hierarchy Selection dialog appears, 
allowing you to specify the actors you wish to include in your 
new Library palette entry.

 You can include or exclude specific body parts from saved poses.

The list of actors appears hierarchically, just as it does in the 
Hierarchy Editor window (see “About Groups” on page 690). 
You can expand collapsed hierarchies by clicking the + sign next 
to a collapsed branch, and can collapse expanded branches by 
clicking the - sign next to an expanded branch.
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To include an actor in your new Library palette entry, check the 
box to the left of your desired actor. Clearing an actor’s checkbox 
excludes it from the Library palette entry. Excluding an actor 
that is a parent of one or more actors excludes the children 
actors as well.

Adding Items to the Library Palette (Manual 
Method)

You can also add items to the Library palette by creating folders 
and subfolders in the Poser hierarchy and adding your items 
directly to those folders. Please refer to “Appendix B: Poser File 
Structure” on page 847 for more information about the Poser 
file structure.

This is an advanced feature that should only be 
undertaken by advanced Poser users who are 

familiar with creating custom content. Manually adding 
Library items could result in misplacing files, which 
could cause these Library items to be invisible and/or 
unusable. Smith Micro Software cannot provide 
technical support for people who manually create 
content folders. If you purchased content and are unable 
to get it to appear in the Library or if it has other errors, 
please contact the content creator.

Adding Items to the Library Palette (Poser 
Download Manager)

Poser’s Download Manager can detect and install Poser content 
downloaded using the Content room. Please refer to “Chapter 8: 
The Content Room” on page 173 for more information about 
the Content room.

Deleting Items from the Library Palette

To delete an item from the Library palette, select it by clicking 
its preview image, then click the Delete from Library icon (-) at 
the bottom of the palette (see below for an image of the Library 
icons).
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 The Library icons.

Deletions are permanent! Be sure you really 
want to delete the selected item. If you have not 

saved your content elsewhere (such as archiving the 
source files), the deleted content will be permanently 
lost. You cannot undo content deletions.

Dragging and Dropping Library 
Content
You can use drag and drop to add or work with library content, 
with the same functionality that is found in your standard 
operating system drag and drop. For example, when using the 
external (AIR) library, you can drag and drop items between 
library folders, or drag a CR2 file from the library and drop it 
into an opened text editor to make changes to the file.

Searching the Library
The new Search tab in the library allows you to perform a 
keyword search in your local content libraries. You can perform 
the search in all or selected categories.
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 You can search the library for specific search terms.

To perform a Library search, follow these steps:

1. Switch to the Search tab in the Library.

2. Enter a keyword (such as Ryan) or a series of keywords 
(such as Ryan pants) in the Search For field.

3. From the Look In section, click the Local Library radio 
button.

4. Check or uncheck options as follows:

 � To perform a search throughout all Library categories, 
check the All Categories option.

 � To perform a search in specific categories in your 
Library, uncheck the All Categories option and then 
check or uncheck Figures, Pose, Face, Hair, Hands, 
Props, Light, Camera, or Materials as needed to find 
the content you are looking for.

 When searching, you can include or exclude specific categories.
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5. Click the Search button. Poser performs a search for the 
content that you specified, and search results appear in the 
Content pane.

6. To scroll forward or backward to view previous or later 
searches, you can use the arrow keys to the right and left of 
the Search button.

 You can navigate forward and backward through search results.

Poser stores all search strings in a file named 
SearchState.xml file, which is located in your 

Poser installation folder. Windows Vista users can find 
this file in the Users \ (username) \ AppData \ Roaming 
\ Poser \ 9.0 directory. These search terms are used in 
conjunction with the Prev Search and Next Search 
buttons shown in the previous figure. You can edit this 
file to remove unwanted keywords from the search 
results.

Searching for New Content
The Search tab in the library also allows you to perform 
a keyword search in Content Paradise, Renderosity, and 
RuntimeDNA for new content to add to your libraries. You can 
perform the search in all or selected categories.

A working Internet connection is required for the 
Content Paradise search and preview features to 

function correctly.

To perform a search on Content Paradise, Renderosity, or 
Runtime DNA, follow these steps:

1. Switch to the Search tab in the Library.

2. Enter a keyword (such as pants) or a series of keywords 
(such as Alyson pants) in the Search For field.

3. From the Look In section, click the radio button beside the 
name of the content provider site that you want to search 
(Content Paradise, Renderosity, or Runtime DNA).

4. Use the Category, Seller, Software, or Show Me buttons 
to narrow your search to selected categories, if desired. 
The categories you choose here are specific to the content 
provider site that you choose to search.
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 The Search pane also allows you to find content on Content 
Paradise.

5. Click the Search button. Poser performs a search for the 
content that you specified, and search results appear in the 
Content pane.

 Results from your Content Paradise, Renderosity, or Runtime DNA 
search are displayed in the Search pane.

6. Perform either of the following steps on a search result:
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 � Single-click a thumbnail in the results. Details for the 
selected item appear in the Extended Details area. If 
you want to purchase the item, you can click the Add to 
Cart link in the Extended Details area to add the item to 
the shopping cart on the selected site.

 You can add a selected search result to your shopping cart.

7. Double-click a thumbnail in the results. The product page 
opens in the Content tab within Poser Pro. If you want to 
purchase the item, you can click the Add to Cart button to 
add the item to your shopping cart. Fore more information 

about the Content tab, see “Chapter 8: The Content Room” 
on page 173.

8. You can perform additional content searches or add other 
search results into your cart. After your shopping session 
is complete you can proceed to checkout to purchase your 
selections.

Favorites Tab
The Favorites tab allows you to quickly add your favorite content 
to library folders that you create yourself.

To add an item to the Favorites tab:

1. Highlight the library item that you want to add to favorites.

2. Click the Add to Favorites button at the bottom of the 
Library palette. An Add to Favorites menu appears above 
the selected item.

3. From the menu, select an existing Favorites category, or 
choose <<New Folder > > to create a new Favorites folder. 
When the New Library Name dialog appears, enter a name 
for your new folder and click OK. The new folder appears in 
the Favorites tab and your item appears within it.
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 Add selected search results to your Favorites library folder.
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Chapter 8: The Content 
Room

Welcome to Content Paradise! Poser’s Content room accesses 
Content Paradise, which is your gateway to leading marketplaces 
that provide both free and for-sale Poser content. Need a Poser 
figure, prop, texture, or something else? Content Paradise has 
you covered. And, Poser’s Download Manager can auto-install 
most downloaded content and add it to the Library palette. No 
more manually placing files in folders!

Clicking the Content room tab at the top of the Poser workspace 
opens the Content room.

 The Content Room.

Aside from the Download Manager, the Content room accesses 
the online Content Paradise Web server. Poser for Windows 
seamlessly displays Web pages in the Poser workspace. Poser 
for Macintosh automatically opens a new browser window 
connected to Content Paradise. Content Paradise features and 
interface are subject to change. Because of this, the discussion 
in this reference manual is limited to discussing the Download 
Manager.
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Content Paradise includes comprehensive online help, which 
is accessible from anywhere in the interface by clicking the 
Help links. Please be sure to read all of the applicable Terms 
of Service, including the Privacy Policy. Smith Micro Software 
reserves the right to alter these policies at any time without prior 
notice.

Downloading and Installing Content
After you purchase your content and check out of the 
marketplace(s), you will be able to download it to your computer. 
A progress meter keeps you informed of your download’s status. 
Follow the onscreen instructions to begin the download. Once 
the data transfer is complete, you can begin the installation 
process. Macintosh users can simply unpack the downloaded 
files, and install them according to your needs. Windows users 
can use the auto-install option, as described below.

The Install Options dialog appears for each downloaded file 
once data transfer is complete, with the following options:

• Install Path: When you click Install, the content will install 
to the folder specified in the Install Path field. By default, 
the Poser Downloads Library folder is specified. To change 
the folder to which content is installed, enter your desired 
path in the Install Path field, or click the folder icon to 
browse to your desired location. Please see “Chapter 2: 

Installing Poser” on page 12 for information about 
Libraries and the Library palette.

• Install: Clicking the Install button installs the downloaded 
content to the path specified in the Install Path field.

• Cancel: Clicking the Cancel button cancels the installation 
process. Downloaded content will remain uninstalled in the 
location to which it was originally downloaded.

If the file being installed already exists, a dialog pops up asking if 
you want to overwrite the existing file. Click No to abort, or Yes 
to proceed with overwriting the old file.

A confirmation dialog appears once installation is complete. 
Click OK to acknowledge successful installation of your 
downloaded content.

If Poser cannot recognize the content or cannot install content 
(such as an executable file), the Copy to Folder dialog appears, 
with the following options:

• Copy Path: When you click Copy, the downloaded content 
will be copied to the folder specified in the Copy Path field. 
To change the folder to which content is copied, enter your 
desired path in the Copy Path field, or click the folder icon 
to browse to your desired location.
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• Copy: Clicking the Copy button copies downloaded content 
to the path specified in the Copy Path field. You will then 
need to manually install the content yourself.

• Cancel: Clicking the Cancel button cancels the copy 
process. Downloaded content will remain uninstalled in the 
location to which it was originally downloaded.

In addition to the Content Paradise website, the Content room 
also contains two buttons:

• The Reset Content Paradise button returns you to the 
Content Paradise home page.

• The Install From Zip Archive button opens the Install 
Options dialog, which is described above.
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Chapter 9: Posing 
Figures

This chapter explains how to pose figures and the tools you’ll use 
while doing so. Posing is the process of bending, twisting, and 
pulling a figure into new and fantastic positions. You can even 
create movies by changing poses over time.

General Posing Principles
A pose has two aspects: how the body parts move relative to 
the rest of the body (such as raising or lowering an arm, your 
shoulder, upper arm, forearm, hand, and fingers are moving 
relative to the rest of your body) and the figure’s position relative 
to the Poser workspace (such as walking around a room). Poser’s 
Editing tools (“The Editing Tools” on page 184) allow you 
to move body parts, figures, and props by simply clicking and 
dragging. It doesn’t get any easier!

When posing in Poser, you’re working in all three dimensions. 
Your only limitations are specific motion limits placed on joints 
to keep poses realistic. Enabling limits prevents, for example, a 
figure’s knees from bending backward or the head from twisting 
360 degrees. However, you can disable limits and put your 
figures into any position you can imagine.

Posing and Camera Views

Newer Poser figures (Version 3 and later) allow you to pose faces 
and hands (expressions, gestures, etc.). Poser includes Face and 
Hand Cameras (see “Chapter 11: Cameras” on page 242) that 
zoom into these areas for close-up work.

While posing, you can switch cameras to view your work 
from many different angles and can even select up to four 
simultaneous camera views in the Document window (see 
“Chapter 5: The Document Window” on page 72). It is 
recommended that you select the Posing camera while working, 
thus saving the Main and Auxiliary cameras for your final shots, 
particularly if rendering animations.

The Pose Library

You can add poses you create to the Pose Library, as described 
in “Maintaining Your Library Palette” on page 161, or you can 
apply still or animated poses from the library to your currently 
selected figure as described in “The Poses Category” on page 
145.

Translation

Translation moves multiple body parts by pulling them in a 
chain. To visualize this, imagine a person lying down with their 
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arms out to their sides. If you were to take hold of the hand and 
lift it, at first only the affected arm would move. Keep moving 
higher, you’d lift the shoulders, chest, hips, and eventually the 
whole person off the ground. Poser’s Editing tools work this 
way. Drag any part and connected parts follow. Parts move, 
bend, and twist as you would expect them to.

 When you pull one body part, connected parts follow.

Inverse Kinematics (IK)

Poser’s Inverse Kinematics (IK) features help you achieve 
realistic poses and add natural-looking motion to your 
animations. IK effects are most apparent when using the Editing 
tools.

To demonstrate how IK works, try this:

Create a scene and load the default character (in this case, Andy 
is still configured as the default). Make sure that IK is on (it is 
on by default). Use the Translate tool or the YTran parameter 
dial to translate the hip upward on the Y Axis so that the feet 
move up off the floor. Then move one of the feet to the side with 
the Translate tool. You’ll see an outline appear of where the 
foot once was. That is the IK goal. The foot will move into that 
position wherever possible.
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 With IK enabled, the feet move to the position of their IK goals 
whenever possible.

The purpose of IK is to make it easier to pose or animate the 
arms and legs of a figure. For example, when IK is on, you can 
translate the hip, and the legs bend to accommodate the new 
hip position without changing the positions of the feet. Arms 
behave similarly: Place a figure’s hands against an imaginary 
wall and move the hip forward. The arms bend while the hands 
remain fixed in position. For more information on IK, see 
“Understanding IK” on page 179.

Enabling IK on a pose created with IK disabled 
may alter your pose.

Enabling/Disabling IK

Inverse Kinematics can add realism to your scenes. You can 
toggle Inverse kinematics (IK) on and off for the following limbs:

• Left Leg

• Right Leg

• Left Arm

• Right Arm

To toggle IK on or off for a limb, select Figure > Use Inverse 
Kinematics > limb, where limb is one of the four limbs. A 
checkbox next to a limb indicates that IK is active for that limb, 
and vice versa.



Poser Pro 2014
Reference Manual

179

Chapter 9: Posing Figures

 You can enable or disable IK for the legs and hands.

Understanding IK

Kinematics is the study of motion velocity, rotation, and 
position. In terms of structures such as arms and legs, 
kinematics is used to calculate how actions taken at a structure’s 
root determine the position and rotation of the other end. For 
example, hold your arm straight and rotate your shoulder joint. 
Kinematics calculates the change in position of your arm, hand, 
and fingers. If you know the angle by which you rotated your 
shoulder, you can calculate your arm’s new position.

It follows that Inverse Kinematics studies the same problem 
from the other end: The extremity moves, and IK determines 

how the objects joined to it must respond in order to support the 
new placement. If you raise your hand straight out to the side, 
your hand, arm, and shoulder must move to accommodate your 
hand’s new position. Or if someone was to grab your hand and 
push, your arm would bend while your body remains still.

Poser supports IK for the arms and legs. With IK enabled, you 
can translate the hands and feet and achieve appropriate arm 
and leg positions automatically. IK creates targets to indicate the 
end of the chain. When the hands or feet move, the target is set 
to its new position. Moving any other body part keeps the target 
in its original position relative to the rest of the body. Once the 
target is reached, the end of the chain is fixed and the other 
parts must bend to accommodate the hand or foot position. For 
example, a foot reaches its target and the knee bends.

To work effectively with IK, you need to keep the following 
things in mind:

• Enable (turn on) IK when you are working with the Editing 
tools.

• The Rotate, Translate, and Twist tools may not behave 
as you might expect for some body parts. For example, 
you cannot easily rotate or translate a thigh or shin when 
IK is enabled for that leg because the foot’s position takes 
precedence. This behavior corresponds to real life: When 
you stand, your feet and legs support your body, meaning 
that you cannot arbitrarily move or rotate them. This 
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consideration applies to both the Editing tools and the 
parameter dials.

• You cannot use IK and the Chain Break tool (see “Chain 
Break” on page 189) on the same limb.

Limiting Motion

Selecting Figure > Use Limits toggles parameter limits on and 
off. Please refer to “Editing Parameter Dials” on page 201 for 
information about setting limits for parameter dials. The figures 
included with your copy of Poser have realistic limits applied 
to them, meaning that you can’t, for example, bend a knee 
backward. Limits are disabled when this option is toggled off.

 The Use Limits option keeps body parts within preset range limits.

The Use Limits option keeps body parts from moving beyond 
natural ranges of motion. The figures that come with Poser have 
realistic limits that were set when the figures were rigged. Third-
party content may or may not have realistic joint limits. If you 
have questions about a particular piece of content, please contact 
the content’s creator or the marketplace where you purchased 
the content. “Natural” is a subjective definition. The limits for 
Poser figures are a rough guideline that may or may not look 
right to you. You can customize maximum and minimum limits 
using the methods described in “Editing Parameter Dials” on 
page 201.

Select Figure > Use Limits to toggle limits on and off. A check 
mark next to this option indicates that limits are being enforced, 
and vice versa.

Posing Body Parts

Like their real-world counterparts, Poser figures are made of 
body parts connected by joints. Posing a figure is as simple as 
moving body parts to create a new position or pose. Body parts 
are independent, and each considered an actor in its own right. 
This concept holds true no matter what the figure looks like 
(snake, 2-legged, 8-legged, etc.). There are some special posing 
cases:

• Hands (see “Posing Hands” on page 208)
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• Faces (see “Posing Faces” on page 204)

• Eyes (see “Posing Eyes” on page 207)

• Animals (see “Posing Animals” on page 210)

Posing a Figure

The easiest way to pose a figure is to use the Editing tools as 
described in “The Editing Tools” on page 184. The part will 
move based on the part selected, your currently selected Editing 
tool, your camera angle, and whether or not IK is enabled. You 
can also use the parameter dials on the Parameters palette to 
precisely move parts. Most poses are created using the Editing 
tools to get the rough position followed by the parameter dials 
for fine adjustments.

Selecting Body Parts
Before you begin posing figures, you need to know how to select 
the body part Actor(s) you wish to move in order to create your 
still or animated pose. You can select body parts using the 
Editing tools, the Current Actor pull-down menu, or by clicking 
the desired part in the Document window. Each of a figure’s 
body parts is a poseable element.

 The selected body part is outlined when selected.

If you right-click (Windows) or Apple key-click 
(Mac) within the Document window, a pop-up 

context menu brings up a menu listing all the body parts 
positioned under your mouse cursor. You can select your 
desired body part directly from this list, without having 
to interrupt your workflow or change your camera 
view. This process also makes it easier to select a specific 
actor in areas where many objects overlap.
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Using the Editing Tools

To select a body part using the Editing tools, click your desired 
tool then click the body part you wish to pose. The currently 
selected body part is highlighted in the Document window and 
labeled in the Select Figure and Current Actor menus in the 
top left corner of the Document window.

 Click a body part with an editing tool to select it.

Using the Parameters/Properties Palette

You can also select body parts using the selection menu that 
appears at the top left corner of the Parameters/Properties 
palette. Click the arrow at the top-left corner of the palette to 
display the menu. Here you can select any of the following:

• Any body part for the currently selected figure.

• The Body Actor of the currently selected figure.

• Any props connected to the currently selected figure (such 
as hair, jewelry, articles that are parented to it, and so on).

• Any of the cameras in the scene.

• Any of the lights in the scene.
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 A selection menu appears at the top of the Parameters/Properties 
palette.

Using the Current Actor Pull-down Menu

To select a body part Actor using the pull-down menus:

 Select Figure and Current Actor menus.

 Drill through submenus to select your item.
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1. Select the desired figure using the Select Figure pull-down 
menu.

2. Select your desired body part using the Current Actor Item 
pull-down menu.

This method can be preferable if your scene has several figures 
and/or detailed body parts (such as poseable fingers and toes).

If there are too many actors or scene elements 
displayed in the Current Actor pull-down menu, 

you can increase the Hierarchical Threshold value in the 
Interface tab of the Preferences dialog. See “Interface 
Preferences” on page 33.

The Editing Tools
The Editing tools appear as follows on your Poser workspace:

 The Editing tools.

The tools presented in the above image are 
available within the Pose Room. The availability 

of individual Editing tools will vary in different Poser 
rooms. Additional Editing tools available in different 
rooms will be discussed in the relevant chapters of this 
manual.

As described in “Setting Up Your Workspace” on page 41, 
you can locate the Editing tools wherever you like on your Poser 
screen and can display or hide the title. The tools will auto-wrap 
to fit the allotted width or height of the palette. Tool tips are 
displayed at the top of the palette that reveal the name of the tool 
when you hover your mouse over it.

The Editing tools let you move body parts in many different 
ways. A tool’s effect can vary depending on whether or not 
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Inverse Kinematics (IK) is enabled. Please refer to “Inverse 
Kinematics (IK)” on page 177 for information about IK. 
Editing tools can pose an individual body part or a complete 
figure.

The Color, Grouping, View Magnifier, 
Morphing, and Direct Manipulation tools serve 

other purposes than posing and are discussed later in 
this chapter.

The Editing tools work on an entire figure, or on a body part 
Actor on a figure.

• To pose a body part, select it and drag.

• To pose the entire figure, use one of the following methods:

 � Click and drag on the desired Editing tool and the 
entire figure will move according to the tool that has 
been selected.

 � Select your desired Editing tool, then select the Figure 
Ring surrounding your desired figure and drag. The 
Figure Ring is highlighted when selected, indicating 
that you are working on the entire figure at once.

• To move an entire figure, you can:

 � Click and drag an Editing tool.

 � Select and drag the Figure Ring.

 � Select Body using the Select Actor pull-down menu.

 � Select the figure’s hip and move it (with IK disabled).

When using an Editing tool in the Document window, your 
cursor changes to a visual representation of the selected tool. 
This helps you keep track of how you’re moving the selected 
figure or element.

When using an Editing tool with a figure prop, you don’t need to 
click and drag with the cursor positioned over the affected item; 
you can click and drag anywhere in the Document window. 
Also, be aware that your camera view affects how your figure or 
element appears. Depending on the pose you are creating, you 
may want to switch to a different camera. For example, if you 
are moving an arm in front of a figure, a side view will give you 
a good view of the arm’s position relative to the figure’s front, 
and so on. You can change Camera views as described in “Select 
Figure/Current Actor Menus” on page 77, and can even view 
your Poser scene from multiple cameras at once, as described in 
“Changing Cameras within a Pane” on page 91.

From left to right, the Editing tools are:

Rotate

The Rotate tool bends a body part at its joint. Rotation works 
in three dimensions, allowing you to make a lot of progress very 
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quickly. To rotate a body part, select the body part you wish to 
rotate and drag perpendicular to the part to cause the rotation 
to rotate up and down (relative to your point of view). Dragging 
parallel to the part rotates it in and out, again relative to your 
point of view.

To rotate the entire figure, select it. Dragging the mouse up/
down and left/right functions as a trackball and rotates the 
figure on its own axes based on your camera location. You can 
also adjust an item’s rotation using the parameter dials, as 
discussed in “Parameters Palette” on page 197.

 Rotate tool.

Twist

The Twist tool rotates a figure/part/prop along its longest 
axis (length). You can twist an entire figure by selecting it and 

dragging. Most of the body’s joints don’t allow much twisting. 
For example, your forearm can twist almost 180 degrees while 
your wrist can hardly twist at all. The twist axis of the head, 
neck, and torso is along the spine. For the forearm, the axis lies 
along the arm’s length. Twisting an entire figure rotates it about 
its own axis. If the figure is standing, it spins around. If lying 
down, it rolls over. You can also adjust an item’s twist using the 
parameter dials, as discussed in “Parameters Palette” on page 
197.

 Twist tool.

Translate/Pull

The Translate/Pull tool moves the selected figure/part/prop 
along the camera’s view (vertically... X and Y axes) depending 
how you drag. The translation may occur on the figure’s X, Y, 
and or Z axes depending on the position of the camera relative 
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to the figure. You can translate body parts or figures, and can 
also adjust an item’s translation using the parameter dials, as 
discussed in “Parameters Palette” on page 197.

 Translate/Pull tool.

Translate In/Out

The Translate In/Out tool moves the selected figure/part/prop 
along the Camera’s Z axis (in and out). This translation may take 
place along the figure’s X, Y, and/or Z axes. Dragging down pulls 
the item towards you, and vice versa. Moving an item towards 
you makes that items seem larger, and vice versa. You can 
also adjust an item’s translation using the parameter dials, as 
discussed in “Parameters Palette” on page 197.

 Translate In/Out tool.

Scale

The Scale tool allows you to scale the selected figure/part/prop 
along the camera’s X and Y axes. The item’s affected axes will 
vary depending on the camera’s position relative to that item. 
Dragging in towards the element reduces the scale, and dragging 
away from the element increases the scale. To scale in two 
dimensions, drag laterally. Dragging vertically scales in the third 
dimension. The axes affected depend on your currently selected 
camera position. You can also press and hold Shift while using 
this tool to scale evenly in all three dimensions. Make a mistake? 
No problem. Select Edit > Undo, or press [COMMAND]/
[CTRL]+[Z]. You can animate scale using the parameter dials as 
described in “Parameters Palette” on page 197.
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 Scale tool.

To scale an entire figure, select the desired figure using the 
Select Figure pull-down menu in the Document window or 
by clicking its Figure Ring. A figure’s size is relevant only in 
relation to other figures and props within your scene. To pose a 
single figure, scaling is not necessary: You can simply zoom the 
camera. If you are working with two or more figures and want 
to give one the appearance of being in the distance, it’s best to 
simply move the selected figure to the background using the 
Translate tool (see above). You can also adjust an item’s scale 
using the parameter dials, as discussed in “Parameters Palette” 
on page 197.

Taper

The Taper tool allows you to taper the selected figure/part/prop 
along the Camera’s X and Y axes. The item’s affected axes will 
vary depending on the Camera’s position relative to that item. 
This only affects the end of the selected actor that is most distant 
from the center of the body. Dragging to the right increases the 
amount of taper, and dragging to the left decreases the taper, 
“flaring” the selected actor. You can also adjust an item’s taper 
using the parameter dials, as discussed in “Parameters Palette” 
on page 197.

 Taper tool.
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Chain Break

The Chain Break tool ends the chain of parts affected by the 
Translate tools.

 Chain Break tool.

Using chain breaks on different body parts can create interesting 
effects. For example, to prevent the chest from moving, apply 
a chain break to it. You can then translate the hand freely 
without moving the chest: only the hand, forearm, upper arm, 
and shoulder will move. You must have IK disabled on the 
desired limb(s) in order for this to work. Please refer to “Inverse 
Kinematics (IK)” on page 177 for information about Inverse 
Kinematics.

To add a chain break, select the Chain Break tool and click 
where you want the chain broken. A Chain Break icon appears 
wherever you insert a break. You can insert as many breaks in 

your scene as needed. To remove a chain break, click the desired 
icon.

 Using the Chain Break tool.
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All figures have chain breaks at their hips. You 
cannot remove these breaks.

Color

The Color tool allows you to change a material group’s surface 
(diffuse) color. Please refer to “Root Nodes” on page 325 for 
information about setting colors and other material values.

 Color tool.

Grouping

The Grouping tool opens the Group Editor palette, which is 
discussed in “The Group Editor” on page 681.

View Magnifier

The View Magnifier tool allows you to zoom in and out to and 
from your desired areas of the Document window without 
altering the position of your currently selected camera. This can 
be of great help when working with scenes.

 View Magnifier tool.

To use the View Magnifier tool, select it:

• Click anywhere in the Document window or current view 
pane to zoom in on the selected area. Repeated clicking will 
continue zooming in one step per click.

• To zoom in on a specific region in the Document window, 
click and drag a rectangle around the area you wish to 
magnify. Your view will zoom in on the closest point that 
encompasses your selected region.
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• To zoom out, press [COMMAND]/[CTRL] while clicking in 
the Document window.

Morphing Tool

The Morphing Tool opens the Morph Editor palette. The 
Morphing Tool has two operational modes: Combine and 
Create, which are accessed and controlled via the Morph Editor. 
The Combine mode allows you to sculpt any surface on your 
figure using morph targets. The Create mode allows you to 
manipulate the vertices on your model’s mesh to create new 
morph targets. See “Chapter 30: Modifying Figures & Props” on 
page 614 for more information about morph targets and the 
Morph Editor palette.

 Morphing tool.

Direct Manipulation

The Direct Manipulation tool allows you to directly adjust an 
element’s Translate, Scale, and Rotation parameters: You can 
also use this tool to adjust falloff zones when setting up joint 
parameters for a poseable figure.

 Direct Manipulation tool.

To adjust an element, first select the Direct Manipulation tool, 
then select your desired element:

Clicking and dragging one of the shaded boxes above the 
selected element increase or decreases the element’s X, Y, or 
Z scale. This is the same as adjusting the xScale, yScale, and 
zScale parameters, respectively.
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 The Universal Manipulator tool makes posing easier.

You can also click and drag the colored circles to rotate the 
selected element along its axes. Poser calculates the rotation 
by using object coordinates for optimum control. Dragging the 
red circle rotates about the element’s X axis. The green circle 
rotates about the element’s Y axis, and the blue circle rotates 
about the element’s Z axis. The cursor changes to indicate which 
transformation will occur. For example, move the cursor over 
the circles, the cursor changes to a rotation icon, and so forth. 
Elements rotate about their origins.

Clicking near the selected element’s origin translates the element 
as if you were using the Translate tool. Clicking away from the 
origin and axes/circles allows you to rotate the element as if you 
were using the Rotate tool.

The Parameters/Properties Palette
Poser offers a combined Properties/Parameters palette that lets 
you quickly switch between a selected element’s properties and 
parameter dials.

For clarity, each tab on this combined palette is referred to 
as a separate palette, either the Properties palette or the 
Parameters palette, as appropriate. To switch between the 
two, click your desired tab. You can also access an object’s 
Properties palette by double-clicking the desired object. Once 
you do this, clicking the Parameters tab opens the same object’s 
Parameters palette. You can also access both palettes by 
selecting Window > Parameter Dials.

Properties
The Properties palette contains the properties available for the 
currently selected scene element. Properties for lights, cameras, 
props, etc. are listed in their respective sections. This section 
describes the properties available to figures and body parts.
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 The Properties palette allows you to set options for a selected item.

Figure Properties

Figures have the following properties:

• Name: The Name field displays the figure or actor name. 
Enter a new name in this field if you desire.

• Visible: Checking the Visible checkbox makes the figure 
visible and vice versa. Invisible objects are not included in 
any render calculations, and do not appear in the rendered 
scene.

You can animate visibility by clicking the 
Animation Toggle (key icon) next to the Visible 

checkbox. When animation is enabled, the icon appears 
green. When disabled, it appears clear.

• Visible in Raytracing: Checking the Visible in Raytracing 
checkbox makes the figure visible in raytraced reflections, 
such as if the figure is in front of a mirror. Clearing this 
checkbox makes the figure not appear in reflections. This 
option is used when raytracing.

• Light Emitter: When checked, allows the object to be 
included in indirect lighting calculations so that light will 
bounce off the object. When unchecked, indirect lighting 
calculations are skipped for the object.
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• Visible in Camera: When checked, the object is visible 
in the camera and render. When unchecked, the object 
does not render. Used in conjunction with Light Emitter, 
described previously, to create light-casting objects.

• Displacement Bounds: The Displacement Bounds 
property determines the figure’s displacement boundary. 
Please refer to “Chapter 19: Using The FireFly Render 
Engine” on page 404 for more information about 
displacement bounds.

• Include Morphs when conforming: When this option is 
checked, the conforming article will automatically adjust 
to fit morphs that are set in the character to which it is 
conformed. Note, however, that the applicable morphs 
must be included in the conforming article in order for this 
to occur. In other words, if the character has a “Big Belly” 
morph that is set, the conforming clothing must also have a 
“Big Belly” morph in order for automatic morph conforming 
to work properly.

• Include scales when conforming: When this option is 
checked, the conforming article will automatically adjust to 
fit any scaling changes that are set in the character to which 
it is conformed. In other words, if you have scaled the thighs 
and shins of your character to 90%, the thighs and shins of 
the conforming clothing will automatically adjust to fit that 
scaling.

The accuracy of auto-scaling when conforming 
is dependent upon proper configuration of 

content. If auto-scaling does not appear to be working 
properly for third party-content, check the 
documentation furnished with the content, or contact 
the content developer.

• Match endpoints when conforming: In legacy content, 
endpoints might not match between conforming clothing 
and the figure to which the clothing conforms. For example, 
factors such as incorrect joint origin settings or extremely 
tight parameter limits can cause clothing to behave 
unexpectedly. When this option is checked, you can force 
the matching of endpoints for conforming figures on an 
as-needed basis.

• Follow origins when conforming: If you are conforming 
a piece of clothing to a character that has animated origins 
(discussed in “Animatable Origins” on page 488) check 
this option to have the conforming item follow the animated 
origins. When enabled, Poser will compute the deltas of the 
current origin to follow the animated origins of the target 
figure.

• Subdivision Levels: Allows you to subdivide the selected 
figure. See “Working with Subdivision Surfaces” on page 
769 for more information.
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Body Part Actor Properties

Body part Actors have the following properties:

 Body actor properties.

• Internal Name: The Internal Name field displays the body 
part’s internal (hidden) name, which Poser uses to track that 
part. You cannot edit a body part’s internal name within 
Poser.

• Name: The Name field displays the body part’s name. Enter 
a new name in this field if you desire.

• Visible: Checking the Visible checkbox makes the body 
part visible and vice versa. Invisible objects are not included 
in any render calculations, and do not appear in the 
rendered scene. See “Figure Properties” on page 193 for 
information on animating the Visible property.

• Visible in Raytracing: Checking the Visible in Raytracing 
checkbox makes the body part visible in raytraced 
reflections, such as if the figure is in front of a mirror. 
Clearing this checkbox makes the figure not appear in 
reflections. This option is used when raytracing.

• Bend: Checking the Bend checkbox enables bending for the 
selected body part and vice versa. Bends are discussed in 
“Bend Body Parts” on page 114. Remember that selecting 
Display > Bend Body Parts bends all body parts and this 
property only affects the currently selected body part.

• Visible in Camera: When checked, the object is visible 
in the camera and render. When unchecked, the object 
does not render. Used in conjunction with Light Emitter, 
described previously, to create light-casting objects.

• Light Emitter: When checked, allows the object to be 
included in indirect lighting calculations so that light will 
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bounce off the object. When unchecked, indirect lighting 
calculations are skipped for the object.

• Casts Shadows: Checking the Casts Shadows checkbox 
forces the selected body part to cast a shadow, which will be 
visible in your scene. Clearing this box means the selected 
body part casts no shadow.

• Collision Detection: Checking the Collision Detection 
checkbox enables collision detection for the currently 
selected body part.

• Apply Collision Setting to Children: Clicking the Apply 
Collision Setting to Children button applies the currently 
selected body part’s collision detection setting to that part’s 
children parts (if any).

• Load Morph Target: Clicking the Load Morph Target 
button displays the Load Morph Target dialog, allowing 
you to load a custom morph target for the selected body 
part (which is then editable using the Morphing Tool as 
described in “Creating Morphs with the Morphing Tool” on 
page 642). Please refer to “Chapter 30: Modifying Figures 
& Props” on page 614 for more information about loading 
morph targets.

• Set Parent: Click the Set Parent button to assign a parent 
to the currently selected prop. In the case of a figure, this 
button is only enabled for the active end point actor of an IK 

chain. If the chain is turned on, it allows you to set a parent 
for that endpoint actor (such as a foot), to a moving object, 
or to another prop or constraint.

• Displacement Bounds: The Displacement Bounds 
property determines the body part’s displacement 
boundary. Please refer to “Chapter 19: Using The FireFly 
Render Engine” on page 404 for more information about 
displacement bounds.

• Shading Rate: The Shading Rate allows you to specify the 
desired shading rate for the currently selected body part. 
Please refer to “Chapter 19: Using The FireFly Render 
Engine” on page 404 for more information about shading 
rates.

• Smooth Polygons: Checking the Smooth Polygons 
checkbox causes Poser to smooth the body part’s polygons 
at render time to eliminate or reduce a “faceted” appearance 
caused by flat polygons. This option can cause sharp corners 
to appear round. If the affected body part has sharp edges 
that you wish to preserve while applying polygon smoothing 
to other angles, you should specify those sharp edges using 
smoothing groups or the crease angle threshold, as polygon 
smoothing will not override these settings. See “Smoothing 
Geometry” on page 422 for more information on 
specifying hard versus smooth edges.
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• Crease Angle: The Crease Angle setting establishes a 
threshold up to which creases between adjoining polygons 
will be smoothed. Polygons with crease angles over this 
threshold will not be smoothed, and will be rendered as 
hard edges. See “Smoothing Geometry” on page 422 for 
more information about using the Crease Angle setting to 
apply smooth shading.

• Display Origin: Checking the Display Origin checkbox 
displays the prop’s origin. Please refer to “The Prop Origin” 
on page 225 for more information about prop origins

• Animatable Origin: When checked, allows you to animate 
the actor’s origin as the actor is translated, rotated, or 
scaled. This allows you to optimally position the joint origin 
if the shape of the actor changes drastically by scaling or 
morphing.

• Subdivision Levels: Allows you to subdivide the selected 
actor. See “Working with Subdivision Surfaces” on page 
769 for more information.

Parameters Palette
The Parameters palette contains all of the parameters for the 
currently selected scene element:

 The Parameters Palette.

The following topics discuss the Parameters palette in detail:

• (1) Current Actor Menu

• (2) Parameters Palette Options Menu
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• (3) Parameter Dial Groups

• (4) Parameter Dials

• (5) Parameter Dial Menu

• (6) Master Parameter Indicator

• (7) Dependent Parameter, showing Natural and Driven 
parameter values

• (8) If a dot appears to the left of a parameter dial name, it 
means that the dial is set to something other than its default 
value.

Current Actor Menu

The Parameters palette’s Current Actor pull-down menu 
(1) functions the same as the Current Actor pull-down at 
the bottom left of the Document window. Please refer to 
“Select Figure/Current Actor Menus” on page 77 for more 
information about the Current Actor menu.

Parameters Palette Options Menu

The Parameters palette options menu (2) contains the following 
options:

 Parameters Palette Options menu.

• Create New Master Parameter: Creates a new parameter 
dial that can be set up to drive one or more dependent 
parameter dials. For further information on dependent 
parameters, see “Using Dependent Parameters” on page 
666.

• Create New Group: Selecting Create New Group creates 
a new subgroup under the currently selected group. The 
Create New Group dialog appears prompting you for a 
name. Enter your desired name in the field. To rename an 
existing group (or if you make a mistake when creating the 
group), double-clicking the group name in the Parameters 
palette opens a field allowing you to specify a new name.
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• Delete Selected Groups: Selecting Delete Selected 
Group deletes the currently selected group. Parameter dials 
in deleted groups are moved to the next highest group or 
subgroup, as appropriate.

• Display in Calculation Order: Reorders parameter 
channels. Allows you to correct the initial order of physics 
simulation parameters in order to accommodate existing 
and new morphs.

If morphs are added after, they will double after 
simulation. You will need to reorder the channels 

to address this issue.

• Memorize: Selecting Memorize memorizes the current 
parameter dial settings as default. Please refer to 
“Memorize” on page 71 for more information on 
memorizing parameter dials.

• Restore: Selecting Restore restores the most recently 
memorized defaults. Please refer to “Restore” on page 70 
for more information about restoring saved defaults.

• Delete Object: Selecting Delete Object deletes the current 
object.

• Show Hidden Parameters: Displays parameters that are 
normally hidden from view, allowing you to view and edit 
their parameters and properties.

Making changes to channels that are normally 
hidden is recommended for advanced users only, 

as improper changes can affect the usability of the 
figure.

Parameter Dial Groups

Poser offers parameter dial grouping (3), which organizes 
parameters into easy to navigate categories.

Different figures may have different parameter 
dial groups.

Parameter dial groups have the following functionality:

• Clicking the + sign next to a collapsed group/subgroup 
expands that group/subgroup.

• Clicking the – sign next to an expanded group/subgroup 
collapses that group/subgroup.

• Double-clicking a group name allows you to rename that 
group.
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• You can drag and drop groups to change their hierarchical 
relationship to each other. For example, a group could 
become a subgroup under another group, and vice versa.

• You can drag and drop parameter dials to different locations 
within the same group or across groups and subgroups to 
organize them as you see fit.

Parameter dial groups and subgroups are saved 
in your Poser scene files.

Parameter Dials

The parameter dials (4) in the Parameters palette let you pose 
a figure and adjust other attributes for figures, props, lights, 
camera, etc. using precise numerical increments. Each body 
part and most other elements in the scene have their own set of 
parameter dials. When an entire figure is selected, the displayed 
parameters affect the entire figure. To use a parameter dial, you 
can either click and drag it to the right to increase the selected 
value or left to decrease it. You can also click the displayed 
numeric value and manually enter your desired value using the 
text box that appears.

To restore a parameter dial’s default (or last memorized) 
setting, press and hold [OPT]/[ALT] while clicking the desired 
parameter dial. To change a parameter dial’s default value, set 

the dial to your desired value and either select Edit > Memorize 
> element, as described in “Memorize” on page 71, or use the 
Parameter Palette menu as described in “Parameters Palette 
Options Menu” on page 198.

Each parameter dial has its own Parameter Dial menu (5), 
which is accessible by clicking the arrow to the right of your 
desired parameter dial. The Parameter Dial menu has the 
following options:

• Reset: Selecting Reset resets the parameter dial to its 
default or last-memorized value.

• Settings: Selecting Settings opens the Edit Parameter Dial 
dialog, described in the following topic.

• Graph: Selecting Graph opens the Graph palette for the 
selected element. Please refer to “Using Graphs” on page 
458 for more information about the Graph palette.

• Recalculate Dynamics: If you have a dynamic object 
selected (strand-based hair or dynamic cloth), selecting the 
Recalculate Dynamics option recalculates the dynamics 
for that object. Please refer to “Step Four: Setting Hair 
Dynamics” on page 542 and to “Step 4: Cloth Dynamics 
Controls” on page 562 for information about strand-based 
hair and cloth dynamics, respectively.
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• Split Morph: When enabled, selecting Split Morph 
splits the currently selected morph into left and right 
sides, allowing you to apply the selected morph target 
asymmetrically. You can use this, for example, to introduce 
irregularities into a figure’s head, enhancing realism because 
no person’s head is perfectly symmetrical.

Master Parameter Indicator

The Master Parameter indicator appears when the designated 
parameter dial is used to drive settings of other parameter dials. 
Click the Parameter Dial menu arrow to open the Dependent 
Parameter editing tool and the list of parameters controlled by 
that dial. For more information about master parameters, see 
“Using Dependent Parameters” on page 666.

Dependent Parameter Dials

When a parameter is configured as a dependent parameter, two 
values will be displayed to the right of the parameter dial. These 
dials are referred to as the natural and driven parameters, and 
are explained in detail in “Using Dependent Parameters” on 
page 666.

Editing Parameter Dials

You can edit parameter dials by double-clicking your selected 
parameter dial to open an Edit Parameter Dial dialog, which 
allows you to set the following limits:

 Each parameter dial has options that you can edit.

• Value: The Value number sets the current parameter dial 
value.

• Min/Max Limit: The Min Limit and Max Limit values define 
the minimum and maximum limits for the parameter, 
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respectively. The numbers can stand for different types of 
values depending on the parameter you are editing. If it is a 
joint parameter, the value will be expressed in degrees above 
or below 0 (neutral). If you are adjusting a scale parameter, 
the number will be a percentage with 100 being normal size.

• Name: You can rename the parameter by entering a new 
name in the Name field.

• Sensitivity: The Sensitivity value modifies the parameter 
dial’s sensitivity to clicking and dragging. A lower number 
decreases the sensitivity and vice versa.

• Graph: Clicking the Graph button opens the Graph palette 
for the selected element. Please refer to “Using Graphs” on 
page 458 for more information about the Graph palette.

• Force Limits: Check this option to keep the selected dial 
within the minimum and maximum limit settings.

Click OK when you have finished making changes.

Universal/Figure Parameters

This topic discusses both universal parameter dials and those 
used for figures. Parameters for cameras, lights, and other 
elements are discussed in their respective sections.

Scale Parameters

Scale parameters are found in the Transform group of the 
Parameters palette. Their functions are as follows:

 Scale Parameters.

• Taper: The Taper parameter dial tapers the selected body 
part/prop. This function is the same as using the Taper tool, 
described in “Taper” on page 188.

• Scale: The Scale parameter dial enlarges or shrinks the 
selected body part/prop in all three axes equally. This is the 
same as using the Scale tool, described in “Scale” on page 
187. Normal scale is 100%.

• XYZScale: The xScale, yScale, and zScale parameter 
dials enlarge or shrink the selected body part/prop along 
the selected axis only. This allows you to squeeze or stretch 
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items. This is the same as using the Scale tool. Normal scale 
is 100%.

Posing Parameters

Posing parameters appear in the Transform group of the 
Parameters palette, and appear in yellow text. The following 
parameters are available for posing: Note that the options you 
see for each joint vary, depending on the rotation order of the 
joint: Each joint will have three options, one each for X, Y, and 
Z rotation.

 Posing Parameters.

• Twist: The Twist parameter dial rotates a body part along 
its own axis. For example, using twist on the head and neck 
turns the head. This is the same as using the Twist tool, 
described in “Twist” on page 186.

• Bend: The Bend parameter dial rotates a body part on its 
major axis. Most body parts bend forward and back, except 
for the shoulder and hands, which bend up and down.

• Side-to-Side: The Side-to-Side parameter dial rotates a 
body part perpendicular to its major axis. The thigh has lots 
of side-to-side motion, while the knee has very little.

• Turn: The Turn parameter dial only appears for the feet 
in some characters, instead of the Twist parameter. This 
parameter turns the feet inward or outward.

• Front-Back: The Front-Back parameter dial is used with 
shoulders and collars to rotate them forward or back, 
perpendicular to their major axis.

Body Parameter Dials

The following parameter dials are available for entire figures. 
Remember to select the correct figure when working with 
multiple figures in a scene:
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 Body Parameters.

• XYZRotate: The xRotate, yRotate, and zRotate 
parameter dials rotate a figure around the X, Y, or Z axis as 
appropriate.

• XYZTran: the xTran, yTran, and zTran parameter dials 
move a figure along the indicated axis.

The XYZTran and other positioning dials reflect 
the currently selected unit of measure, which is 

available in the General Preferences dialog. For 
example, if a dial is set to 12 inches and you change units 
to feet, the dial will now read 1 foot.

Posing Faces
Poser’s human figures and many third-party figures have fully 
articulated faces, meaning you can position facial muscles such 
as mouth, eyebrows, cheeks, and eyes to create different facial 
expressions using the Parameter dials and/or the Morphing 
Tool (described in “Creating Morphs with the Morphing Tool” 
on page 642).

Facial expressions work for Alyson and Ryan 
and their lo-res versions, even though the 

warning dialog will appear when applying face 
expressions to the lo-res figures.
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 Faces can be enhanced with Expression morphs.

Different Poser and third-party figures will have 
different body morphs. Smith Micro Software 

cannot provide support for third-party figures. Please 
contact the vendor where you obtained your third-party 
content for technical support.

Some older Poser figures do not have poseable 
faces.

When you select a head, a series of face-specific parameter 
dials appears in the Parameters palette, each dial controlling 
a different aspect of the face. When using face parameter dials, 
think of it as manipulating facial muscles to achieve the final 
results.

The Face camera uses the selected figure’s face as its center of 
rotation, allowing you to preview your face poses up close.

Face Parameters

Face parameters normally operate in the range of 0 to 1, with 0 
being fully off and 1 being fully on. Negative values (<0) produce 
inverted poses, and poses greater than +/- 1 give exaggerated 
poses. For example, a negative Frown parameter setting 
produces a slight smile. Face parameters are morph targets that 
can be used in concert to create expressions.
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Please refer to “Chapter 30: Modifying Figures & 
Props” on page 614 for information on morph 

targets and how they work inside Poser.

Poser figures contain an array of facial morphs and parameters 
that allow you to create an endless variety of faces and 
expressions. The list of face parameters varies by figure, and 
the all parameters are self-explanatory. To view the available 
face parameters, select the desired figure’s head and open the 
Parameters palette.

In addition to posing faces, you can also modify facial structure 
as well as Ethnicity, Age and Gender parameters via the Face 
Shaping tool in the Face room. See “The Face Shaping Tool” on 
page 527 for more information on the Face Shaping tool.

Alyson and Ryan figures include two levels of 
facial Ethnicity morphs. You will find face 

shaping morphs in the Parameters palette, and 
Ethnicity, Age and Gender controls in the Face room

Faces & Phonemes

A phoneme is a linguistic term for the positions of the tongue, 
lips, and teeth as they make sounds. Producing certain sounds 
requires the mouth and tongue to be in certain positions. 
Stringing phonemes together is what produces speech.

Poser allows you to create the appearance of phonemes (called 
visemes when observed) to accurately simulate speech, a useful 
feature when adding sound to your scenes (such as a speech). 
You simulate speech by using different phonemes and keyframes 
to sync your figure’s mouth movements to an imported sound 
(see “Sound” on page 481). Poser’s Talk Designer can 
automatically generate a lipsync animation for you based upon 
settings that you configure in the Talk Designer palette. For 
more information about the Talk Designer, see “Using the Talk 
Designer” on page 482.
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 Phoneme morphs work with the Talk Designer.

Posing Eyes

To pose eyes, select them using either the Editing tools or the 
Current Actor pop-up menu and position them by clicking and 
dragging, or by using the parameter dials.

Alyson and Ryan also have additional morph dials for the eyes, 
which can vary the shape of the iris and pupil, or which move the 
eyes up, down, right, or left.

 Eye morphs size or position the Eyeball, Iris, Cornea, and Pupil.
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Posing Hands

Many Poser figures have fully articulated hands. When you move 
a finger, the appropriate knuckle(s) bend. You can pose hands 
for both these figures and older Poser figures without articulated 
hand joints by applying hand poses from the Library palette.

The Left Hand and Right Hand cameras use the hand as their 
centers of rotation, making it easier to create precise hand poses.

Use the Editing tools to pose hands as you would any other 
body part. Please refer to “The Editing Tools” on page 184 for 
information on using the Editing tools. You can also apply preset 
hand poses to any Poser figure using the Hands category in the 
Library palette, just as you would any other pose.

When you select the main portion of a hand (labeled Left Hand 
and Right Hand in the Item Select menu) on some Poser 
figures, you may also see a special set of hand parameter dials in 
the Parameters palette. These dials are as follows:

• Grasp: The Grasp parameter dial controls how tightly the 
hand/fist is clenched.

• Thumb: The Thumb parameter dial moves the thumb. 
Higher values move the thumb in towards the hand, and 
vice versa.

• Spread: The Spread parameter dial controls the amount of 
hand spread. Higher values spread the hand out, and vice 
versa.

In addition, Alyson and Ryan include several additional 
controls that provide extremely fine control over hand poses. 
These additional options, coupled with the extra joints in their 
hands, provide fine enough control to pose your hands holding 
chopsticks or other eating utensils: These additional dials are 
found in the Hand Controls section in the Parameters palette 
when you choose the hand actor for the Alyson or Ryan:

• ThumbBend: Bends all sections of the thumb at the same 
time.

• IndexBend: Bends all sections of the index finger at the 
same time.

• MiddleBend: Bends all sections of the middle finger at the 
same time.

• RingBend: Bends all sections of the ring finger at the same 
time.

• PinkyBend: Bends all sections of the pinky at the same 
time.
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Alyson and Ryan also include advanced controls 
in the feet, that bend the toes in a more realistic 

manner. Select the Right Toe or Left Toe actor, and 
expand the Toe Controls section in the Parameters 
Palette to find four dials: BigToeCurl, BigToeSpread, 
ToesCurl, and ToesSpread.

Using the Hand Model

The Figures > Poser Content > Additional Figures subfolder 
includes disembodied hands that use the new joints found 
Alyson and Ryan. These hands include extra joints that allow 
you to create hand poses that bend in a more realistic manner. 
Use the Left Hand or Right Hand in this subfolder to create 
hand poses that are compatible with Alyson and Ryan. Then save 
the poses to the Hand library for future use.

Using Preset Hands

When you’re done posing a hand, you can save it to the Hands 
category in the Library. Hand poses are a subset of a figure pose, 
meaning that figure poses include the hands but hands don’t 
include figures.

 Use Hand poses to pose a character’s hand and fingers.

The Hands library folder includes various 
subcategories. When selecting preset hand poses 

for your figure(s), pay attention to the subcategory from 
which you choose them, as You can only apply specific 
hands to the corresponding figures. For example, you 
can only apply Poser 2 Fig. Hands to Poser 2 figures.

To use a preset hand pose:

1. Click a figure to select it.

2. Open the Library palette, then open the Hands category 
and your desired subcategory.

3. Double-click the pose you want to use. A dialog appears 
asking if you wish to apply the preset to the left or right 
hand. Make your selection and click OK.
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Posing Animals
You can pose animals using the same techniques used to pose 
humans. Animals have their own set of IK settings, bend zones, 
and limits. On the Horse model, for example, moving the hip 
down toward the ground does not make the animal sit, unlike 
a human figure. Editing tools, parameter dials, menus, etc. all 
work the same with animals as they do with humans. Technically 
speaking, animals and human figures are identical, and Poser 
makes no distinction between them.

Animals do not work with the Walk Designer, 
which is primarily designed for two-legged 

(bipedal) figures. However, animals can work with the 
Talk Designer if the animal includes morphs that 
support it.

 Animal figures are poseable as well, but do not work with the Walk 
Designer.

The stock animal figures shipping with Poser use 
the same limb names as humans, that is, front 

legs and paws are labeled Shoulder, Arm, Hand, etc. 
This means that animal figures will not work in the 
Walk Designer, which was created for use with two-
legged figures. To animate an animal walking or 
running, you need to keyframe its strides manually.
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Posing Animal Heads

Several animal models have fully articulated heads. For example, 
you can pose the dog’s mouth and ears. Use the parameter dials 
just as you would for a human figure. The available parameter 
dials for a given animal’s head will vary depending on the 
animal.

Pose Dots
You can save up to nine pose configurations using the Memory 
dots (described in “Memory Dots” on page 56). Each 
Memory dot retains all of your selected figure’s pose. This 
feature is specific to your current scene, meaning that Pose dots 
cannot be transferred to different scenes. To save pose settings 
and have them accessible in any Poser scene, you need to add 
pose sets to the Library palette.

 Pose Dots.

Saving Poses in the Library
All parameters are saved along with body part positions when 
you save a pose to the Library palette. To save a pose to the 
Library palette:

1. Open the Library palette.

2. Select the Pose category and your desired subcategory.

3. Follow the directions in “Adding Items to the Library” on 
page 162.

Other Posing and Figure Aids
The Object menu allows you to manipulate objects within your 
scene.

Lock Object

Selecting Object > Lock Object locks the currently selected 
element (body part, prop, etc.). To lock your desired actor, select 
it, then select Object > Lock Object. The currently selected 
actor will be locked, meaning that it will not move relative to its 
parent. For example, if the elbow is bent 45 degrees relative to 
the upper arm, it will hold that position. Locking actors is a great 
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way to protect your work once you’ve perfected a portion of your 
figure.

To unlock a locked actor, select it and Object > Lock Object. A 
checkbox appears next to this menu item when the selected actor 
is locked, and reselecting this option clears the checkbox and 
unlocks the actor.

Point At

You can aim body parts, cameras, props, lights, etc. at other 
scene elements using the Point At command. This works in 
numerous situations, such as having a figure’s eyes track a 
moving object, keeping a camera focused on the action, etc. This 
is different than parenting in that no hierarchical relationship 
is created. One object simply points at another. By contrast, 
parented objects retain their exact position and orientation 
relative to their parent actors.

To point an actor at another actor:

1. Select the element you want to aim using the Select Item 
pop-up menu.

2. Select Object > Point At to open a dialog box listing the 
actors in the scene.

 Choosing an object to point toward.

Select the object to aim at and click OK. The selected element 
points at the object and a Point At parameter dial appears 
in that element’s Parameters palette. Selecting 1 points the 
element directly at its selected target, and 0 points the element 
away from the target.
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When selecting only a single item from the Object 
Parent hierarchy window, you can simply 

double-click on that item to make your selection and 
close the window.

To disable pointing for an element:

1. Select the element.

2. Select Object > Point At.

3. Select None in the dialog that appears and click OK.

Figure Height

Poser provides several figure heights, which you can adjust by 
selecting Figure > Figure Height and selecting one of the eight 
heights available.

Note that these settings may not work with al figures. You 
will get the best results when using these options with legacy 
figures, such as figures made for Poser 4 and earlier versions. 
Figure heights are intended for figures that have very basic 
construction.

Figure heights are measured in “heads”, meaning the ratio of the 
head height to the overall body height:

• Baby: 4 heads (each head is approximately 6 inches tall)

• Toddler: 5 heads (each head is approximately 6.5 inches 
tall)

• Child: 6 heads (each head is approximately 7 inches tall)

• Juvenile: 7 heads (each head is approximately 7.5 inches 
tall)

• Adolescent: 7.5 heads (each head is approximately 9 inches 
tall)

• Ideal Adult: 8 heads (each head is approximately 9 inches 
tall)

• Fashion Model: 8.5 heads (each head is approximately 9 
inches tall)

• Heroic Model: 9 heads (each head is approximately 9 
inches tall)

You can create interesting effects by applying different height 
settings to different figures.

Genitalia

Some male and female nude models are anatomically correct. 
Selecting Figure > Genitalia toggles displaying genitals on or 
off.
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The Figures library includes a Poser Content > People > Ryan 
> Genitals subfolder that contains props for all four male figures 
(Diego, Marcus, Ryan, and Tomo). There are versions for the 
LowRes versions of these figures as well. Add the proper library 
item to the male figure in your scene, and then choose Figure 
> Conform To conform to the male figure. Basic, Advanced, 
Shiny, and Ultimate material collection files are found in the 
Materials > Poser Content > People > Ryan > (figurename) > 
Genitals subfolders.

Many female figures do not have modeled 
genitalia, relying instead on texture/bump/

transparency maps to create the appearance of 
genitalia. This option only works for figures that have 
modeled genitalia that is set up to take advantage of this 
feature. To remove genitals on a female character that 
does not have modeled genitalia, you will need to modify 
the texture map. The Judy and Jessi models contain 
modeled genitalia, which are controllable via this 
function.

Different figures use different mechanisms for 
dealing with genitalia, so not all figures will be 

affected by the Figure > Genitalia menu option. Some 
newer figures, such as the G2 male figures and Ryan, 
contain genitalia that is set up as a separate conforming 
figure.

Auto Balance

The Auto Balance feature is a valuable tool for helping create 
realistic poses. When enabled, Poser calculates a figure’s 
mathematical “weight” and maintains it. In the following 
example, there is more weight in the figure’s hip or center 
portion than in the torso. As you pose a figure, Auto Balance 
adjusts body parts to maintain the original weight distribution, 
resulting in more natural-looking poses without having to 
use several position adjustments. To further affect the weight 
distribution and compensation calculations, you can reposition 
the Center of Mass Control Object (the outlined ball) at the 
base of the figure. This control object is adjustable along the X 
and Z axes in the ground plane. Moving the Center of Mass 
Control Object also adjusts the Center of Mass Indicator, 
which appears as a shaded sphere in the XZ (ground) plane 
under the figure. This Indicator shows the position above which 
the current center of mass is located, as calculated from the body 
part weights and the position of the Control Object.
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 Using Auto Balancing.

When using Auto Balance, use small subtle motions to achieve 
the best results. Large motions may create drastic results. If 
this occurs, restore the figure as described in “Restore” on 
page 70. You may also want to select Figure > Use Limits 

while working with the Auto Balance feature, to help maintain 
realistic body positioning.

Selecting Figure > Auto Balance toggles Auto Balance on and 
off for the selected figure. When enabled, the Center of Mass 
controls will be visible at the figure’s base. A check mark appears 
next to this option in the menu when it’s enabled. Reselecting 
this option clears the check mark and disables Auto Balance for 
the selected figure.

Lock Figure

Selecting Figure > Lock Figure locks the figure in its current 
position. You cannot pose or move a locked figure. This is a great 
way of protecting your work in complex scenes where you have 
finished posing a figure and don’t want it to move accidentally. 
A check mark appears next to this option when the currently 
selected figure is locked. Reselecting this option removes the 
check mark and unlocks the figure.

Lock Hand Parts

Selecting Figure > Lock Hand Parts locks the selected hand in 
position, protecting it against accidental position changes while 
you pose the rest of your figure. To use this option:

1. Select the hand to lock.
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2. Select Figure > Lock Hand Parts. The hand is now locked. 
This command is not available for all Poser figures.

Please refer to “Posing Hands” on page 208 for information on 
posing hands.

Drop to Floor

You can place a figure in any position, such as in the middle of a 
flying leap. You can leave your figure in the air, or you can lower 
it to the ground depending on your needs. Selecting Figure > 
Drop to Floor brings the lowest part of the selected figure or 
prop into contact with the workspace floor. To display the floor, 
refer to “Ground Plane” on page 117.

Symmetry

The Symmetry command allows you to copy pose characteristics 
from one side of the body to another, which can save you time 
when creating scenes in the Pose room or when building custom 
figures using the Setup room. Pose an arm and/or leg, and 
use this command to instantly apply the same position to the 
other side. You can also swap entire poses from side to side and 
straighten the currently selected figure’s torso.

 Start pose (left); Right to Left (center); Swap Right and Left (right).

Selecting Figure > Symmetry opens the Symmetry menu, 
which contains the following options for your currently selected 
figure:

• Left to Right: Selecting Left to Right applies the position of 
the bones on the left side of the figure to the right side.

• Right to Left: Selecting Right to Left applies the position of 
the bones on the right side of the figure to the left side.

• Swap Right and Left: Selecting Swap Right and Left 
swaps the positions of the bones on the right and left sides 
of the figure.
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• Left Arm to Right Arm: Selecting Left Arm to Right Arm 
positions the right arm bones in the same position as the 
left arm.

• Right Arm to Left Arm: Selecting Right Arm to Left Arm 
positions the left arm bones in the same position as the right 
arm.

• Swap Right and Left Arms: Selecting Swap Right and 
Left Arms swaps the positions of the bones on the right and 
left arms of the figure.

• Left Leg to Right Leg: Selecting Left Leg to Right Leg 
positions the right leg bones in the same position as the left 
leg.

• Right Leg to Left Leg: Selecting Right Leg to Left Leg 
positions the left leg bones in the same position as the right 
leg.

• Swap Right and Left Legs: Selecting Swap Right and Left 
Legs swaps the positions of the bones on the right and left 
legs of the figure.

• Straighten Torso: Selecting Straighten Torso straightens 
the torso area (Hip, Abdomen, Chest).

When you select a Symmetry function, a dialog box appears 
asking if you wish to copy the joint zone setup as well. Click Yes 

to apply the symmetry to the bone structure, or No to avoid 
copying the joint setup.

Symmetry also copies element settings (morph 
targets, deformers, parameters, etc.) from one 

side to the other. For example, if you scale the Left Hand 
to 200% and apply Left to Right symmetry, the other 
hand will scale as well. Do not use this command if you 
want to use asymmetrical settings.

Delete Figure

Selecting Figure > Delete Figure deletes the currently selected 
figure. A confirmation dialog appears. Click OK to proceed with 
the deletion or Cancel to abort. Windows users can also delete a 
figure by selecting it and pressing [DEL].

If your figure is wearing conforming clothing or has other 
attached figures, you can check the Delete attached figures 
option to delete them in addition to the figure that you are 
deleting.

Hide Figure

Selecting Figure > Hide Figure hides the currently selected 
figure if you have more than one figure in your scene. This is 
helpful when you work with complex scenes, especially where 
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a figure is getting in your way. You can also hide a figure by 
selecting the figure to hide by selecting Body using the Select 
Element pull-down menu and clearing the Visible checkbox 
in the Properties palette as described in “Properties” on page 
192.

Collision detection settings do not apply to 
hidden objects.

Show All Figures

Selecting Figure > Show All Figures makes all hidden figures 
in your scene visible. You can also make hidden figures visible 
by selecting them and checking the Visible checkbox in the 
Properties palette. If one or more body parts are set to invisible, 
these will remain invisible when the selected figure is shown.
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Chapter 10: Working with 
Props

Poser lets you add props to your scene. Props are three-
dimensional objects that your figures can interact with or that 
simply add interest to your scene. Props can be accessories to 
add to your figure’s character such as a wig, a moustache, a pair 
of sunglasses, a cigar, or a briefcase. Or, your figure could base 
its pose on a prop, such as leaning on a cane, climbing a ladder, 
or tossing a ball. This chapter covers hair, conforming (figure-
based) clothing, and miscellaneous props not fitting into these 
categories. Poser treats conforming clothing items like figures, 
however we will treat conforming clothing as props in this 
chapter for the sake of discussion.

About Props
You can manipulate props just as you would any other element, 
which is why you see the term body part/prop used throughout 
this manual. You can change a prop’s color, shape, deformation, 
material, and maps (if it has UV coordinates – refer to “About 
Maps & Templates” on page 283). Props can even cast 
shadows.

Poser’s replaceable geometry feature (see “Replacing a Body 
Part with a Prop” on page 228) lets you replace body parts 
with props, making the prop actually part of the figure. You 
can also parent a prop to a body part or another prop or scene 
element, such as a briefcase in a hand. Please refer to “Poser 
File Types” on page 848 for information about hierarchies in 
general, and to “About Groups” on page 690 for information 
on creating hierarchies within Poser. Props also add general 
interest and meaning to your scenes, such as a mushroom for a 
frog to perch on.

 Props add interest to your scene.

You can select props from the Props category in the Library 
palette, the Content room, or import props in a variety of 
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popular 3D formats. You can also create your own props in your 
favorite 3D modeling application (provided that application 
exports to one or more formats supported by Poser’s Import 
function).

Props function like other scene elements, meaning you can use 
the Editing tools and parameter dials and can specify properties 
in the Properties palette. You can also create groups using the 
Group Editor palette (see “The Group Editor” on page 681).

Hair
Poser’s Hair room (see “Chapter 26: The Hair Room” on page 
533) allows you to create real strand-based hair, or to use 
prop-based hair, when designing your figures. We’ll discuss both 
forms of hair in this section.

Strand-Based Hair
Poser’s Hair room adds dynamic strand-based hair to your scene 
elements for ultimate realism. You can create as much or as little 
hair anywhere you like on any object in your scene and can even 
use it to add fur, lichens, grass, and many other effects. Please 
refer to “Chapter 26: The Hair Room” on page 533 for more 
information about strand-based hair and the Hair room.

By default, strand-based hair requires 
significant computing resources, so you should 

be careful not to overload your system. Please see the 
detailed information about the Hair room for more 
information.

Prop-based Hair
Prop-based hair is a special kind of prop that automatically 
attaches itself to a figure’s head. You can choose from a number 
of styles in the Library palette (see “The Hair Category” on page 
151). Once assigned, hair moves with the figure’s head. Some 
newer hair models that come with Poser are morphable, as are 
many third-party hair props. It is common to use Transparency 
Maps to improve the look of prop-based hair.
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 Prop-based hair automatically attaches to a figure’s head, and is 
geometry-based.

To add hair to a figure from the Library palette, please refer 
to “Adding Hair to a Figure” on page 152. Hair includes 
parameter dials in the Parameters palette (see “Prop 
Parameters” on page 227), allowing you to specify its scale and 
position. Some hair also includes morph target parameter dials 
that allow you to, for example, swing a ponytail as a character 
walks. The Library palette also contains a pose-able hair model, 
which contains elements just like a figure. You can edit and pose 
these elements just as you would any Poser figure.

To use the conforming hair model:

1. Add the James figure from the Figures > Poser Content > 
People > James category of the Library palette.

2. Select and add the Messy Hair model from the Hair > 
Poser Content > People > James Hair category in the 
Library palette.

3. Set the head as the parent for the hair as described in 
“Changing a Parent” on page 231.

Clothing
Poser’s Cloth room (see “Chapter 27: The Cloth Room” on 
page 550) adds a whole new dimension to adding realistic 
clothing to your figures and cloth objects to your scenes. You 
can even add realistic motion to clothes that will react as the 
character moves (such as a skirt on a walking woman) and can 
be windblown using wind force fields (described in “Wind Force 
Fields” on page 633). Of course, Poser supports prop-based 
clothing and ships with both dynamic and conforming (figure-
based) clothing.
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Dynamic Clothing

Please refer to “Adding Dynamic Clothing” on page 551 for 
information about adding dynamic cloth to a figure or scene.

Conforming Clothing

In addition to cloth objects, Poser includes libraries of figure-
based clothing that you can use on nude figures, which are 
located in the Figures category of the Library palette and 
includes shirts, pants, shoes, dresses, skirts, etc. Conforming 
clothing attaches to a figure and automatically moves with the 
figure’s poses. See “Adding Conforming Clothing: Automatic 
Conforming” on page 142 and “Adding Conforming Clothing: 
Manual Conforming” on page 143 for more information on 
using automatic and manual conforming methods to attach 
clothing to your figures.

 Clothing before conforming.
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 Clothing after conforming.

Adding & Importing Props
There are several ways to bring props into Poser. Props can be 
added to the document window from the Props library, or you 
can also import props from other 3D applications.

The Props Library

You can add props from the Library palette’s Props category as 
described in “Adding Hair to a Figure” on page 152.

Using 3D Objects as Props

You can import 3D objects created in other 3D applications 
to use as props. Poser’s Import functionality is described in 
“Importing Files” on page 777.

Poser places props in the workspace with your specified origin 
point. If you do not specify an origin point, the prop will appear 
in the center of the workspace. If you import a prop and can’t 
see it, the prop may be too large and/or your currently selected 
camera may be zoomed in too close to see it. Try zooming out 
and/or switching cameras. You will probably have to scale and 
translate props to get them where you want them in your scene, 
using either the Editing tools or the prop’s Parameter dials.

Moving, Resizing, and Deforming 
Props
You can move, resize, and deform props using the Editing tools, 
the Properties palette, and/or the Parameters palette.
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Deleting Props
To delete a prop, select the prop you wish to delete and either 
select Object > Delete Object or press [DEL].

Creating New Props
You can use the Grouping tool to select specific polygons on 
a figure or prop, as discussed in “The Group Editor” on page 
681. This feature allows you to create new props. For example, 
this graphic shows an example of a face mask created to fit the 
figure by selecting polygons in the figure’s face and creating a 
prop, which was then exported to a 3D modeling application for 
finalizing.

 The Group Editor can be helpful in creating a prop (such as a mask) 
from a figure.

To create a prop:

1. Select the prop or body part you want to base the prop on.

2. Select the Grouping tool to open the Group Editor palette.

3. Select polygons for a new group and create and name the 
prop.
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4. The new prop is now listed in the Current Actor pull-down 
menu and can be moved, shaped, and edited like any other 
prop.

You can save your new prop to the Library palette as described 
in “Adding Items to the Library” on page 162.

Creating Prop Parameters
You can use morph targets to create new parameters for your 
props. Please refer to “Chapter 30: Modifying Figures & Props” 
on page 614 for more information about morph targets.

The Prop Origin
A prop’s origin appears in the Document window as 3D 
crosshairs. This is the center of that prop’s rotation and scale. 
When you rotate a prop, it rotates about its origin. It grows or 
shrinks from the origin point when scaled. You can display a 
prop’s origin by selecting the desired prop and checking the 
Display Origin checkbox in the Properties palette.

You can move a prop’s origin using the originXYZ parameter 
dials. Moving the origin alters the prop’s rotation and scale 
points. When adjusting the origin parameters, remember that 
you are making these adjustments based on the prop’s original 
origin location, not its current position.

Prop Properties
Props have the following properties:

 Prop properties.
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• Internal Name: The Internal Name field displays the prop’s 
internal (hidden) name, which Poser uses to track that part. 
You cannot edit a prop’s internal name within Poser.

• Name: The Name field displays the prop name. Enter a new 
name in this field if you desire.

• Visible: Checking the Visible checkbox makes the prop 
visible and vice versa. Invisible props are not included 
in any render calculations, and do not appear in the 
rendered scene. See “Figure Properties” on page 193 for 
information on animating the Visible property.

• Visible in Raytracing: Checking the Visible in Raytracing 
checkbox makes the prop visible in raytraced reflections, 
such as if the figure is in front of a mirror. Clearing this 
checkbox makes the figure not appear in reflections.

• Casts Shadows: Checking the Casts Shadows checkbox 
forces the selected prop to cast a shadow, which will be 
visible in your scene. Clearing this box means the selected 
body part casts no shadow.

• Visible in Camera: When checked, the object is visible 
in the camera and render. When unchecked, the object 
does not render. Used in conjunction with Light Emitter, 
described next, to create light-casting objects.

• Light Emitter: When checked, allows the object to be 
included in indirect lighting calculations so that light will 
bounce off the object. When unchecked, indirect lighting 
calculations are skipped for the object.

• Collision detection: Checking the Collision Detection 
checkbox enables collision detection for the currently 
selected prop. Please refer to “Collisions” on page 75 for 
more information about collision detection.

• Apply Collision Setting to Children: Clicking the Apply 
Collision Setting to Children button applies the currently 
selected prop’s collision detection setting to that part’s 
children parts (if any).

• Load Morph Target: Clicking the Load Morph Target 
button displays the Load Morph Target dialog, allowing 
you to load a custom morph target for the selected prop 
(which is then editable using the Morphing Tool). Please 
refer to “Chapter 30: Modifying Figures & Props” on page 
614 for more information about loading morph targets.

• Set Parent: Clicking the Set Parent button allows you to 
make the prop a child of another element in your scene. 
Please refer to “Changing a Parent” on page 231 for 
information on setting prop parents.

• Displacement Bounds: The Displacement Bounds 
property determines the prop’s displacement boundary. 
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Please refer to “Chapter 19: Using The FireFly Render 
Engine” on page 404 for more information about 
displacement bounds.

• Shading Rate: The Shading Rate allows you to specify 
the desired shading rate for the currently selected prop. 
Lowering the shading rate improves your render quality but 
consumes computer resources. Please refer to “Chapter 19: 
Using The FireFly Render Engine” on page 404 for more 
information about shading rates.

• Smooth Polygons: Checking the Smooth Polygons 
checkbox causes Poser to smooth the prop’s polygons at 
render time to eliminate or reduce a “faceted” appearance 
caused by flat polygons. This option can cause sharp corners 
to appear round. If the affected prop has sharp angles, you 
should experiment with disabling this option for optimum 
results.

• Crease Angle: The Crease Angle setting establishes a 
threshold up to which creases between adjoining polygons 
will be smoothed. Polygons with crease angles over this 
threshold will not be smoothed, and will be rendered as 
hard edges. See “Smoothing Geometry” on page 422 for 
more information about using the Crease Angle setting to 
apply smooth shading.

• Display Origin: Checking the Display Origin checkbox 
displays the prop’s origin. Please refer to “The Prop Origin” 
on page 225 for more information about prop origins.

• Animatable Origin: When checked, allows you to animate 
the prop origin as its actor is translated, rotated, or scaled. 
This allows you to optimally position the prop origin if its 
shape changes drastically by scaling or morphing.

You can animate the prop origin. When used in 
combination with dependent parameters, this 

can result in more realistic joint bends. See “Animatable 
Origins” on page 488.

• Subdivision Levels: Allows you to subdivide the selected 
prop. See “Working with Subdivision Surfaces” on page 
769 for more information.

Prop Parameters
Props have the following parameters:

• Scale: The Scale parameter dial increases or decreases the 
size of the prop in all axes.

• XYZScale: The xScale, yScale, and zScale parameter dials 
increase or decrease the size of the prop in the selected axis.
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• XYZRotate: The xRotate, yRotate, and zRotate parameter 
dials rotate the prop around the selected axis.

• XYZTran: The xTran, yTran, and zTran parameter dials 
move the prop along the selected axis.

 Prop parameters.

Replacing a Body Part with a Prop
Poser lets you replace a body part with a prop, such as a hook 
on a pirate’s hand or a mask for a man’s head. This example 
was created by importing a model of a mask, then replacing the 
figure’s head with that mask.

You should replace body parts with props before 
posing figures to make positioning and aligning 

easier.
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 A mask prop replaces the figure’s head.

To replace a body part with a prop:

1. Add or import the desired prop.

2. Position and deform the prop as desired using the Editing 
tools, deformers, and/or parameter dials. Be sure that the 
prop’s position overlaps the body a little (in most cases) to 
avoid a “break” where the body meets the prop. You might 

also want to make the body part being replaced invisible 
using the Properties palette as described in “Properties” on 
page 192.

3. Select Object > Replace Body Part with Prop to open the 
Replace Part dialog.

4. Choose the prop to swap using the Prop pull-down menu 
and click OK. The prop assumes the name of the body part 
being replaced.

If the replaced body part doesn’t look right, try disabling 
bending by selecting the replaced body part and clearing the 
Bend checkbox in the Properties palette. You can also use the 
Joint Editor palette to make adjustments. This is an advanced 
feature and should be used with care. Please refer to “Chapter 
33: Working with Joints, Weights, and Skinning” on page 719 
for information on using the Joint Editor palette. The prop 
retains its material groups (see the “Chapter 13: The Basics of 
Materials” on page 281), meaning you can apply shaders to it 
as you can with any other material groups in your scene.

Props turned into body parts retain their current 
positions relative to the figure that they had 

prior to being converted. Be sure to place props in their 
desired locations before turning them into body parts.
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Changing Figures with Replaced Geometry

If you try to change a figure that has a prop for a body part using 
the Change function in the Library palette, a warning will 
appear asking if you want to keep the replaced geometry on the 
new figure replacing the old.

• To keep the props that have replaced body parts, check 
the Keep modified geometries button. To keep the props 
attached to their parents on the new figure, check the Keeps 
props attached to figure checkbox. Click OK when ready.

• To undo a geometry change and restore a figure’s default 
geometry, simply reload the original figure from the Library 
palette.

Set Figure Parent
You can attach props to body parts, body parts to each other, 
figures to props, figures to figures, cameras to body parts- the 
list goes on and on. Setting a parent creates a hierarchical 
relationship, as described in “Poser File Types” on page 848. 
You can parent entire figures to various other scene elements. To 
set a parent for a figure:

1. Select the figure you wish to parent (make the child of 
another object).

2. Select Figure > Set Figure Parent to open the Object 
Parent dialog.

3. Select the desired parent object and click OK. To parent 
props, camera, etc., select Object > Change Parent as 
described in “Changing a Parent” on page 231.

 Choosing a parent for an object.
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Changing a Parent
You can attach props to body parts, body parts to each other, 
figures to props, figures to figures, cameras to body parts, etc. 
Setting a parent creates a hierarchical relationship, as described 
in “Poser File Types” on page 848. You can even control 
whether parented props bend along with their parent body part. 
Some items like sunglasses, etc. should not bend. However, 
other items such as elbow pads on a roller blader should bend 
with the parent. You should change parent props before posing 
your figures, since it may be harder to align props with figures 
once the figures have been posed (such as a sword in a warrior’s 
hand).

Here’s an example of a ball parented to a figure’s right hand.

 A ball follows a figure’s hand when it is parented to the hand.

You could also parent a chair to a figure’s hip and make the chair 
inherit the figure’s bend.

When selecting only a single item from the Object 
Parent hierarchy window, you can simply 

double-click on that item to make your selection and 
close the window.

While IK is set “on” for a figure, you can use the 
Change Parent command on a body part actor 

to parent it to something else (such as another figure 
body part or prop).

Your parenting choices are virtually unlimited. For example, 
how about parenting a camera to a figure’s head? This could 
create some interesting effects.

To set a parent for an element:

1. Select the object you wish to parent (make the child of 
another object).

2. If necessary, use the Editing tools, deformers, and/or 
parameter dials to position and shape the object. Ensure 
the correct positioning using either a detailed preview style 
(such as Lit Wireframe), zooming in close, or a test render. 
You can also enable Collision Detection to prevent the 
selected object from penetrating its parent object, or vice 
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versa. Please refer to “Collisions” on page 75 for more 
information about the Collision Detection feature.

3. Select Object > Change Parent (or click the Set Parent 
button in the Properties palette) to open the Object Parent 
dialog.

 You choose the parent object in the Object Parent dialog.

4. Select the desired parent object (the object to which the 
currently selected object will be attached).

5. If you want the prop to bend like its parent, check the 
Inherit bends of parent checkbox.

6. Click OK.

When selecting only a single item from the Object 
Parent hierarchy window, you can simply 

double-click on that item to make your selection and 
close the window.

In the preceding examples, we parented the ball to the figure’s 
right hand and the chair to the figure’s hip. To set parents for an 
entire figure, select Figure > Set Figure Parent as described in 
“Set Figure Parent” on page 230.

Grouping Objects
A grouping object is a container that can act as a parent to two or 
more objects. A grouping object allows you to perform the same 
action to more than one object at a time. For example, when 
several objects are assigned to the same grouping object as a 
parent, you will be able to move or rotate the grouping object to 
do the same to all of its children; or you could turn off visibility 
for all of the children of the grouping object.

To demonstrate how grouping works:

1. Create a new project.
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2. Add a few primitives (a box, a ball, and a bowl are shown 
here).

3. Also add a Square Groundplane HR from the Props > 
Primitives category.

4. With the Square Groundplane selected go into the 
Material Room and click the Add Reflection Wacro. The 
ground plane will turn into a reflective surface.

5. Change the colors of the props to add more variety to the 
scene.

  Four primitive objects in a scene.

Now, you can create the grouping. Choose Object > Create 
Grouping. A container named Grouping n (where n represents 
a numerical value automatically assigned by Poser) appears in 
the scene. It will appear at the zero position in the scene (on the 
floor, at the origin point of the scene). It appears as a cube in 
wireframe display mode, and will not be rendered in your scene.
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  A grouping object at the origin point of the scene.

There are several ways that you can attach children to the 
Grouping object:

• Select an object in your scene that you want to attach to the 
Grouping object. Choose Object > Change Parent, and use 
the Change Parent dialog to select the Grouping Object in 
the hierarchy.

• Right-click in the Document window on the object you 
want to attach. A context menu appears, and included is a 
Change Parent to command. Expand the menu and select 

Groupings > Grouping n (with n being the number of the 
grouping you want to attach).

• Open the Hierarchy Editor, and select the item you want 
to attach to the grouping object. Drag and drop it on the 
grouping object so that it becomes its child.

Use any of the above methods to attach the box and the ball. 
Leave the bowl and ground plane as they are (do not assign the 
Grouping object to them as the parent). Notice now, that when 
you move the grouping around, the box and ball will move, but 
the bowl and ground plane stay put.
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 Parent with the Object > Change Parent command (top) or with 
the Document window context menu (bottom).

  The Box and Ball move with the Grouping object. The bowl and 
ground (not attached) stay put.

A Grouping object allows you to do more than translate or rotate 
objects together.

For example, you can toggle the Visibility of a grouping object to 
show or hide all of its children at once.
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When a Grouping object is invisible, the 
Hierarchy Window will display the visibility icon 

slightly differently for its children. A blue outline will 
appear around the visibility icons for children of a 
grouping object, indicating that they have inherited the 
Invisible setting from the grouping object.

You can also toggle the Visible in Raytracing property of a 
Grouping object. Let’s say that you have several objects on a 
reflective surface. If Visible in Raytracing is turned on for the 
grouping object, reflections will be calculated and rendered for 
the child object. If Visible in Raytracing is turned off for the 
object, reflections will not be calculated. This can help speed up 
rendering, but there may also be times when you intentionally 
want some objects to be reflected and others not.

  Grouping object Visibility off (top); Visible in Raytracing off 
(bottom).
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Using Grouping Objects with Figures

When you create a grouping that includes a body part on a 
figure, the order that you select items can affect how the figure 
relates to the grouping object:

• If you start by adding a figure to your scene (such as Andy, 
or Alyson or Ryan), and then use the Object > Create 
Grouping command, the grouping object will appear in 
the scene. Next, you select one of the body parts on the 
character (such as the right forearm) and right-click to 
choose Change Figure (figure name) parent to from the 
context menu that appears. The grouping object becomes a 
parent of the entire figure, and not just the selected body 
part.

• If you create your group first (for example, you assign a 
grouping object as a parent to a table, chair, and dishes on 
the table) and then you assign the figure’s hand as a parent 
to the grouping object, you can still have some freedom over 
the hand.

Using Constraint Channels
Constraint channels allow you to animate one object based 
on the position of another object. To explain, visualize a scene 
where a football is being tossed to a football player, and then 

he catches it and runs with it. If you create this type of scene 
in Poser, you can use a constraint channel to help with this 
animation. The figure’s hand can be a target for the football. You 
animate the pass of the football, and when the football gets close 
to the catcher you can set the value of the Constraint object to 1 
so that the ball moves with the figure’s hand.

You can delete the Constraint channel and the 
Constraint object will still appear in the scene 

and act as a grouping object, as described in “Grouping 
Objects” on page 232.

Here is a simple example to illustrate how this works. Create 
a simple scene that has three primitive props, such as a box, a 
bowl, and a ball (or similar).

With one of the props selected (the box in this example), choose 
Object > Add Constraint. The Add Constraint dialog appears 
and prompts you to select a constraint target. You can then 
select the ball as the target.
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  Choose a Constraint target from the Add Constraint dialog.

After you click OK, you will see that the box moves to the same 
position held by the ball, so that they are now in the same space. 
A Constraint dial appears in the Parameters Palette, and is set to 
1. When you move this dial back toward the 0 value, you will see 
the box move back toward its original position.

  The box moves to the same space as the ball when the Constraint 
dial is set to 1.

A wireframe box appears at the origin of the ball (the target), 
but may be hidden within the target object. This wireframe 
box is a container that will not render in your scene, but it 
assists in animation. The Hierarchy Editor will show this box 
as Constraint Grouping n (where n is a numerical value 
automatically assigned in Poser) and it will appear as a child to 
the ball.

Now, to see how a constraint channel works, move the 
Constraint parameter dial back toward 1, so that the box moves 
closer to the ball. Then move the ball (not the Constraint object) 
with the editing tools. You will notice that the box follows the 
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ball. The amount of movement between the two objects is 
determined by the value set by the Constraint parameter dial..

  When an object has two constraint targets, set each to a value 
between 0 and 1 for both to have effect.

You can add more than one constraint object. For example, you 
can select the box and assign the bowl as a second constrain 
target. An additional Constraint dial appears in the Parameters 
window (and also in the Hierarchy window). When an object has 
two Constraint targets, it works as follows:

• If both Constraint 1 and Constraint 2 for the box are set to 1, 
the box will be positioned according to Constraint 2.

• If Constraint 1 is set to 0, and Constraint 2 is set to 1, the box 
will be positioned according to Constraint 2.

• If Constraint 1 is set to 1, and Constraint 2 is set to 0, the box 
will be positioned according to Constraint 1.

• If both Constraint 1 and Constraint 2 are set to values other 
than 0 or 1, the box will be positioned in relation to both.
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  When an object has two constraint targets, set each to a value 
between 0 and 1 for both to have effect.

Creating Simulation Proxies
The Object > Spawn Prop from Convex Hull command allows 
you to quickly create lower-resolution objects that you can use 

as a simulation proxy. They can be used for anything, such as 
physics, hair, or cloth simulations. They help reduce resources 
when you are trying to calculate simulations and collisions 
against high resolution geometry. Simulation proxies are also 
useful when you are trying to visualize where collisions against 
an object will occur, and for proofing dynamics.

To create a simulation proxy, follow these steps:

1. Click the object in your scene for which you want to create a 
low-resolution proxy. This can be a prop in your scene, or an 
actor on a poseable character (such as a character’s head).

2. Choose Object > Spawn Prop from Convex Hull. A prop, 
named hull, appears in your scene.

The first simulation proxy that you create will be 
named hull. The second, and subsequent proxies 

will be named hull n, where n is a sequential number 
(such as 1, 2, and so on).

3. Switch to the Properties Palette, if desired, to assign a more 
descriptive name for the proxy in the Name field.
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  Examples of hull proxy objects.

Deleting Objects
Selecting Object > Delete Object deletes the currently selected 
prop. A confirmation dialog appears. Click OK to delete the prop, 
Cancel to abort.
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Chapter 11: Cameras
This section describes how Poser’s cameras work. As indicated 
previously, cameras aim at the Poser workspace from different 
vantage points. Switching cameras allows you to view your scene 
from up to four of these vantage points at once.

Camera View
Selecting Display > Camera View allows you to select one of the 
cameras available in your scene.

Show Camera Names
Selecting Display > Show Camera Names displays the name 
of the currently selected camera in the top left corner of the 
Document window’s scene preview area. Clicking this option 
again disables this feature.

The Camera Controls
The Camera controls allow you to quickly select and position 
cameras. Used in conjunction with the available Document 
window layouts, they allow you to quickly navigate your scene 

and/or set up final shots for still or animated output. Remember 
that every view you see of your scene inside the Document 
window is done using one or more cameras. You can move 
cameras in any direction, however positioning them can be a 
time-consuming process. Having multiple cameras allows you to 
use preset camera positions to quickly navigate your scene, while 
the ability to position cameras allows you to create custom still 
or moving shots for use either while working on your scene or 
during rendering.

The Camera controls appear as follows in the Poser workspace.

 Camera Controls.
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In addition, the Mini Camera controls appear on the top of the 
Document window, allowing you to navigate your scene without 
having to have the full Camera controls visible (such as when 
you are using the Material room).

 Mini Camera Controls.

The Animation On/Off control allows you to enable or disable 
automatic keyframe generation when you move or change 
rotation of a camera. The Flyaround camera view provides an 
animated view of your scene as a camera rotates around it while 
pointed at the center origin.

The Mini Camera controls consist of (from left to right) the 
Frame Selected and Orbit Selected buttons, and the Trackball, 
Move XY, and Move XZ controls. These function identically 
to their counterparts in the main Camera controls and are 
therefore detailed in this chapter.

The available 3D cameras are: Main, Auxiliary, Posing, Face, 
Left Hand, Right Hand, and Dolly. The available orthographic 
(2D) cameras are: Left, Right, Top, Bottom, Front, and Back. 
When you render stills or animations, the rendering takes place 
using the currently selected camera. Please refer to “Part 4: 

Rendering” on page 391 for more information on rendering. 
Each camera is discussed above.

The Main, Auxiliary, and Posing 
Cameras
The Main, Auxiliary, and Posing cameras are revolving 
cameras, which means they rotate about the center of the Poser 
workspace. By default, figures and props are placed at the center 
of the workspace. Moving figures/props does not alter these 
camera’s positions. The Auxiliary camera provides a secondary 
camera for your use, such as when you are deciding which shot 
to render and want to explore possibilities without affecting your 
previous camera positioning/animation work

The Posing camera is similar to the Main and Auxiliary 
Cameras except that it rotates about the currently selected 
figure, not the workspace. If you select another figure, the 
Posing camera moves to that figure/prop.
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 Main, Auxiliary, and Posing cameras as displayed in the Camera 
Controls.

The Face Camera
The Face camera provides a close-up of the currently selected 
figure’s face, allowing you to precisely adjust facial expressions 
and see your results in detail. This camera rotates around the 
currently selected figure’s face and moves if you select another 
figure. This camera also works with animal figures. To switch to 
the Face camera, select your desired figure and click the Face 
Camera control.

 The Face camera displayed in the Camera Controls.

For the Face camera to work properly, be sure 
your figures’ heads are all named “Head”. This is 

not an issue for figures that were included with Poser 
but could be an issue for third-party content and custom 
figures you create yourself.

Left and Right Hand Cameras
Like the Face camera, you can zoom in on the left or right 
hand of the currently selected figure to fine-tune gestures and 
other hand positions. Hand cameras also focus on the currently 
selected figure. If the figure is an animal, the Hand cameras will 
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focus on the feet/paws/claws as appropriate. To switch to a hand 
camera, click the Left hand or Right Hand icon as appropriate.

 Left and Right Hand cameras as shown in the Camera Controls.

For the hand cameras to work properly, be sure 
your figures’ hands are all named “Left Hand” 

and “Right Hand”. This is not an issue for figures that 
were included with Poser but could be an issue for third-
party content and custom figures you create yourself.

The Dolly Camera
The Dolly camera rotates about its own center independently 
of scene contents, meaning it can move around and between 
elements in the scene. If you want to emulate a motion picture 
camera, the Dolly camera is your best choice.

Orthographic Cameras
The Left, Right, Top, Bottom, Front, and Back cameras are 
orthographic cameras, meaning that they product orthographic 
projections. Orthographic projections makes objects appear flat 
(2D), without the perspective of 3D views. Orthographic cameras 
cannot be rotated, since they are permanently aligned to the 
X, Y, and Z axes in the Poser workspace. Because of this, they 
make excellent references for viewing your scene. Please refer to 
“About 3D Space” on page 857 for a general discussion about 
3D views.

 Orthographic cameras as shown in the Camera controls.
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Shadow Light Cameras
Shadow light cameras are very useful for aiming lights and 
creating their shadows. Each light in your scene has one 
Shadow Light camera. Each shadow camera shares both XYZ 
location and aim direction with its assigned light. Poser uses 
these cameras to calculate shadows cast by the objects in each 
light’s path. Positioning these cameras and/or adjusting their 
parameters/properties can affect how shadows appear in your 
rendered scenes. You can select these cameras using the Select 
Actor pull-down menu. Shadow cameras have a reduced set of 
properties/parameters (see “Camera Properties & Parameters” 
on page 251 for more information).

If you see poor depth map shadows in a portrait 
shot, or if you see warping or flickering shadows 

in animation, you can tweak the shadow cams to adjust 
the field of view to the parts of the scene that really 
matter.

 Shadow Light cameras displayed in the Select Actor drop down 
menu.

Changing Cameras
To change a camera, use any of the following methods:
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• Right-click the camera label in any Document window 
pane and choose one of the options in the Camera View 
submenu.

• Click the Face, Left Hand, or Right Hand icon in the 
Camera controls (see “The Camera Controls” on page 
242).

• Click the Select Camera control in the Camera controls 
(see “Select Camera Control” on page 247).

• Select Display > Camera View using the Menu Bar, then 
selecting your desired camera in the Cameras pull-down 
menu.

Select Camera Control
Clicking and dragging the cursor over the Select Camera 
control cycles through the available camera views and changes 
the Document window or currently active view pane to the 
newly selected camera.

 The Select Camera control.

Just above the main Select Camera control are three shortcut 
buttons for specific cameras. You can replace an existing camera 
shortcut with your currently selected camera by pressing [OPT]/
[ALT] while clicking one of the Select Camera shortcut buttons. 
A shortcut for your currently selected camera will replace the 
previously existing camera shortcut.

Flyaround View
The Flyaround view places the currently selected camera on 
a virtual track above and away from the center of the Poser 
workspace and orbits around your scene, displaying all elements 
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within view. This is an excellent way to quickly see how your 
scene looks in 3D space. Once activated, this view remains 
active until toggled off. To toggle Flyaround on and off, click 
the control or make the selection using the Cameras pull-down 
menu.

 The Flyaround Camera control.

Positioning Cameras
In addition to selecting cameras, the Camera controls allow you 
to position your currently selected camera using one or more of 
the following controls. If you have more than one camera active 

(multiple Document window view panes), these controls will 
only affect the currently selected camera.

Camera Plane Controls

The Camera Plane controls constrain camera motion to specific 
3D planes (axes), helping you move the camera with precision:

• Move YZ: The Move YZ control constrains camera motions 
to the up/down (Y) and front/back (Z) axes.

• Move XY: The Move XY control constrains camera motions 
to the side/side (X) and up/down (Y) axes.

• Move XZ: The Move XZ control constrains camera motions 
to the side/side (X) and front/back (Z) axes.
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 Camera Plane controls.

Rotation Trackball

The Rotation trackball tilts and spins the currently selected 
camera about all three axes. The Main, Auxiliary, Posing, and 
Dolly cameras rotate about the center of the Poser workspace. 
The Posing camera rotates around the currently selected figure. 
The Face and Hand cameras rotate about the respective actors 
(body parts) of the selected figure. You can also use the Rotation 
trackball by pressing [OPT]/[ALT] and dragging the cursor 
around the workspace using the Document window.

 The Rotation Trackball.

Scale Control

The Scale Camera control works like a zoom lens. Click the 
control and drag right to zoom towards the camera’s aim point 
(workspace, figure, or actor, depending on the camera). Clicking 
and dragging left zooms out, and vice versa.

Focal Length Control

The Focal Length control increases or decreases the selected 
camera’s focal length. Clicking the control and dragging right 
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increases the focal length, while clicking and dragging to the left 
reduces the focal length. You can also adjust the camera’s Focal 
Length parameter in the Parameters palette.

Roll Control

The Roll Camera control banks the camera to the left or right, 
tilting your view of the Poser workspace. Click the control and 
drag left or right to tilt the camera in the indicated direction.

 Scale, Roll, and Focal Length camera controls.

Frame and Orbit Selected Control

Use the Frame Selected control to fit the camera view around 
the selected actor. When the Orbit Selected button is enabled, 
the camera will orbit around the selected object. When the Orbit 
Selected button is disabled, the camera will orbit normally.

 Frame Selected and Orbit Selected camera controls.
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Creating Cameras
You can create new revolving or dolly cameras using the Object 
> Create Camera menu option.

You can specify the type of camera you wish to create by 
selecting either Revolving or Dolly from the Create Camera 
sub-menu. A revolving camera rotates about the center of the 
Poser workspace, regardless of the position of objects within the 
scene. A dolly camera rotates about its own center, and can move 
around and between elements in the scene.

Camera Properties & Parameters
When you select a camera, its properties and parameters will 
appear in the Properties and Parameters palettes, respectively. 
To access a camera’s properties and parameters in the 
appropriate palette when you do not currently have a camera 
selected, you can:

• Click your desired camera object if it is visible in the 
Document window.

• Use the Current Actor pull-down menu.

Camera Properties

Cameras have the following properties, available in the 
Properties palette.

 Camera Properties.

• Name: The Name field displays the camera name. Enter a 
new name in this field if you desire.

• Visible: Checking the Visible checkbox makes the camera 
visible in the Document window, and vice versa. Invisible 
objects are not included in any render calculations, and do 
not appear in the rendered scene. See “Figure Properties” 
on page 193 or information on animating the Visible 
property. When cameras are visible, you can right-click to 
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display a context menu as described in “Cameras Context 
Menu” on page 87.

• Animating: Check the Animating box to have the selected 
camera’s movements recorded as keyframes in your 
animation, or clear it to disable this feature. With this 
feature disabled, you can still move the camera but its 
movements will not be recorded as keyframes in your 
animation. Camera animation allows camera movements 
to appear as part of rendered movies, allowing for such 
techniques as follow shots, flyaround views, etc. Please 
refer to “Chapter 22: Animating with Poser” on page 447 
for more information on creating animations. To enable/
disable camera animation, open the Properties palette.

• When a camera is animated, your view of your scene 
changes over time, which can add realism and interest to 
your animation. Watch a movie and notice how often the 
camera moves. You can animate Poser cameras just like 
any other 3D object using keyframes and tween frames. 
Different cameras will animate differently, since they have 
differing centers of motion.

You can only use one camera per animation; you 
cannot switch cameras in mid animation. To do 

this, create separate clips then edit them together using 
video editing software.

• Remember changes for Undo: Checking the Remember 
changes for Undo checkbox specifies that any camera 
changes will be included in the Undo/Redo cache. 
Unchecking this checkbox means that the Undo feature will 
not apply to camera changes.

Camera Parameters

Like all parameter dials, clicking and dragging a dial to the 
right increases its value, and clicking and dragging to the left 
decreases its value. You can also click your desired parameter’s 
numeric value to open a text field allowing you to directly type 
your desired value.
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 Camera Parameters.

Other Parameters

The Other Parameters section contains a variety of parameters 
to control the behavior of the selected camera. These parameters 
are as follows:

• Focal: The Focal parameter dial sets the camera’s focal 
length. Smaller numbers give wider angles and will add 
more stretching and distortion as they decrease. Larger 
numbers give results like telephoto lenses, and result in less 
distorted but flatter images.

• Perspective: The Perspective parameter shifts the current 
camera’s perspective without changing the camera’s 
location. This can give the illusion that the camera is farther 
or nearer to objects in your scene. The Perspective setting is 
hidden, because it is interconnected with the Focal setting. 
If you adjust the Perspective dial, you will see a change in 
the Focal setting.

• Depth of Field: Widening the lens aperture of the camera 
allows you to achieve a Depth of Field effect. The farther 
away items are from the focal plane, the more blurred they 
will appear. Depth of Field can be individually configured 
for each camera.

 � Focus Distance: The focus distance dial controls the 
cross hair so that you can position the focus. Place the 
cross hair at the distance at which objects appear most 
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in focus. In Poser, focal distance for each camera is 
determined by a control object located within the scene. 
You can animate the control object like any other figure 
in Poser, by using keyframes to specify its change in 
position; Poser will interpolate the movement between 
keyframes for you. (For more information about 
animating using keyframes, please refer to “Chapter 
22: Animating with Poser” on page 447.) Enter your 
desired value in the camera’s Focus Distance field.

 The Focus Distance control, with Alyson as the point of focus, and 
its render.
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 The Focus Distance control, with the car as the point of focus, and 
its render.

 � F-Stop: The F-Stop number represents a lens aperture 
size. The larger the number, the smaller the aperture 
opening. Each number is multiplied by a factor of 
approximately 1.4 as the scale rises, giving standard 

values of 1.0, 1.4, 2, 2.8, 4, 5.6, 8, 11, 16, 22, 32, etc. 
Each change either doubles or halves the amount of 
light transmitted by the lens to the film plane. Basically, 
f-stop is calculated from the focal length of the camera 
lens divided by the diameter of the bundle of light rays 
entering the lens and passing through the aperture 
in the iris diaphragm. On a physical camera, this 
represents the lens focal length (see next bullet) divided 
by the f-stop value to determine the actual aperture 
size. The F-Stop setting affects the depth of field in 
Poser, just as it would in a real camera lens. Smaller 
F-stops increase depth of field and narrow the point of 
focus. Focus on the subject, and then enter the desired 
value in the F-Stop field.

The following images illustrate the Depth of Field effect.

 Without depth of field (left); With depth of field (right).
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Poser allows you to enable or disable Depth of 
Field for individual renders. In order for depth of 

field to render, you must enable the Depth of Field 
option in the Render Settings dialog. Please refer to 
“Chapter 19: Using The FireFly Render Engine” on page 
404 for details on how to do this using the FireFly 
Renderer.

If the results of your Depth of Field settings are 
too grainy in the blurred areas, try raising the 

number of Pixel Samples. Doing so will result in a 
smoother effect, but increased render times.

• Shutter Open: The Shutter Open value represents the 
shutter opening time in fractions of a frame, where 0.0 is 
the beginning of the frame and 1.0 is the end of the frame. 
Unlike a real camera shutter, this one opens and closes 
instantly with zero elapsed time. Regular camera shutters, 
while extremely fast, require a small time interval to travel 
between the closed and open positions.

• Shutter Close: The Shutter Close value represents the 
shutter closing time in fractions of a frame, where 0.0 is 
the beginning of the frame and 1.0 is the end of the frame. 
Unlike a real camera shutter, this one opens and closes 
instantly with zero elapsed time. Regular camera shutters, 
while extremely fast, require a small time interval to travel 

between the closed and open positions. For example, setting 
a beginning time of 0.0 and an ending time of 0.5 means the 
shutter would be open for the first half of a frame.

The Shutter Open and Shutter Close settings only 
result in a visible effect when 3D Motion Blur is 

activated in the Render Settings dialog. As the amount 
of time between Shutter Open and Shutter Close 
increases, the motion blur effect increases.

• Hither: The Hither parameter controls the distance of the 
clipping plane. Objects (or portions thereof) closer to the 
camera than the hither distance will not appear in your view 
pane.

• Yon: The Yon parameter sets the farther range of the 
clipping plane. Objects (or portions thereof) farther from 
the camera than the yon distance will not appear in your 
view plane. The Yon parameter is only applicable with 
OpenGL hardware rendering.

Transform Parameters

When a camera is selected, you can use the parameter dials 
on the Parameters palette to precisely adjust that camera’s 
position. The Dolly, Posing, Face, and Hand cameras have 
the standard 3D Pitch, Yaw, and Roll parameters, while the 
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Main and Auxiliary cameras have xOrbit, yOrbit, and zOrbit 
parameters. These parameters are measured in degrees.

XYZ Dolly

The Dolly parameter dials move the selected camera along the 
desired axis without altering its orientation, just like a movie 
camera on a dolly cart, as shown below.

• DollyX: The DollyX parameter moves the camera laterally. 
Increasing this value moves the camera to the right.

• DollyY: The DollyY parameter moves the camera vertically. 
Increasing this value moves the camera up.

• DollyZ: the DollyZ parameter moves the camera in and out. 
Increasing this value moves the camera in and out.

XYZ Scale

As mentioned above, camera scale functions like a zoom lens. 
The Scale control zooms the camera equally in all three axes. 
Using the parameter dials, however, you can scale in any amount 
using any combination of axes to create distorted effects. While 
this might give the same appearance as distorting the figures/
props in your scene, scaling cameras only affects the selected 
camera; items in your scene are not affected. Decreasing scale 
values zooms in along the selected axis, and vice versa.

• xScale: The xScale parameter changes the camera’s 
horizontal scale.

• yScale: The yScale parameter changes the camera’s 
vertical scale.

• zScale: The zScale parameter changes the camera’s depth 
scale.

• Scale: The Scale parameter dial changes the selected 
camera’s scale equally along all three axes and functions in 
the same manner as the Scale camera control. If you have 
already selected unequal scales using the individual axis 
controls, the Scale dial/control preserves your previously 
selected ratios.

XYZ Orbit

The Orbit parameters orbit the selected camera around the 
indicated Poser workspace axis. It helps to think of the selected 
axis as the center of a wheel with the camera being at the edge. 
The camera maintains its distance from the axis and remains 
pointing in the same direction relative to its starting point. 
Setting positive degrees of rotation in the Orbit parameter 
dials orbits the selected camera in a counterclockwise direction 
around the selected axis, and vice versa.

• xOrbit: The xOrbit parameter orbits the selected camera 
using the Poser workspace’s X axis as the center of rotation.
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• yOrbit: The yOrbit parameter orbits the selected camera 
using the Poser workspace’s Y axis as the center of rotation.

• zOrbit: The zOrbit parameter orbits the selected camera 
using the Poser workspace’s Z axis as the center of rotation.

Pitch, Roll, Yaw

These parameters rotate the Dolly, Posing, Face, and Hand 
cameras about their own axes. To illustrate this, let’s use the 
example of a small plane with its X, Y, and Z axes labeled.

 Pitch (Up or Down); Roll (Tilt); Yaw (Turn).

• Pitch: The Pitch parameter rotates the selected camera 
about its own X axis (up/down). A positive number pitches 
the camera up (the scene appears to pitch down), and vice 
versa.

• Roll: the Roll parameter rotates the selected camera about 
its own Z axis (tip left/tip right). A positive number rolls the 
camera to the left (the scene appears to rotate to the right), 
and vice versa.

• Yaw: The Yaw parameter rotates the selected camera about 
its own Y axis (rotate left/rotate right). A positive number 
yaws the camera to the left (scene appears to yaw to the 
right), and vice versa.

Pointing & Locking Cameras
As with any other object in your scene, you can use the 
Hierarchy Editor (see “About Groups” on page 690) to keep 
cameras pointed at certain other objects.

Pointing Cameras at Scene Objects

To point your camera at another scene object:

1. Select your desired camera using the Current Actor pop-up.

2. Select Object > Point At to open the Choose Actor dialog.
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3. Choose your desired scene object in the list of actors (the 
camera can point at anything) and click OK.

The camera will point at the selected object and a Point At 
parameter dial will appear in the Parameters palette for that 
camera. Setting this parameter to 1 locks the camera on target, 
and 0 completely disables pointing. Intermediate values 
cause the camera to lag behind the object it’s pointing at. This 
parameter allows you to create interesting effects when creating 
animations.

Disabling Camera Pointing

To disable camera pointing:

1. Select your desired camera using the Current Actor pop-up.

2. Select Object > Point At to open the Choose Actor dialog.

3. Choose None in the list of actors (the camera can point at 
anything) and click OK.

Locking Cameras

Once you have positioned a camera to your liking, you can lock 
it to prevent it from being moved. To lock a camera, select it as 
described above, then select Object > Lock Object. Selecting 
this option again toggles locking off.

Memorizing and Restoring Cameras

You can use the Edit > Memorize > Camera command to 
memorize the settings of the current camera. If you later want 
to return to that camera, choose the Edit > Restore > Camera 
command to restore the settings back to the camera that you 
memorized.

Camera Dots
You can save up to nine camera configurations using the 
Memory dots (described in “Memory Dots” on page 56). 
Each Memory dot retains the settings for all cameras in your 
scene. All Memory dots are saved with the application, so your 
saved camera configurations will be accessible in any Poser 
document loaded. You can also save camera settings to the 
Library palette as described below, which would allow you to use 
your Memory dots for other settings.

Saving Camera Sets
The Cameras category in the Library palette allows you to save 
camera positions and access them using a few mouse clicks. 
Camera positions are saved relative to the Poser workspace, 
not figures or other scene items. Saving camera sets saves 
all cameras; you cannot save one camera. As with any other 
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Library palette category, you can add subcategories to the 
Cameras categories. Please refer to “Chapter 2: Installing 
Poser” on page 12 for a description of the Library palette, 
and to “Maintaining Your Library Palette” on page 161 for 
information on adding items to it.
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Chapter 12: Lighting
Lights add color to your scene, reveal cues in forms, enhance 
muscle contours, set moods, cast shadows, etc. Good lighting is a 
key element of getting your scene to look right when you render 
it. Lights work in renderings and in the Lit Wireframe and 
Flat Shaded preview modes (refer to “Chapter 6: The Display 
Controls and Menu” on page 105 for information about 
display styles). You can use as many lights as you need in your 
scene, with the only limitation being your system’s resources. 
Poser improves the OpenGL preview of lights in your scenes. It 
automatically selects the eight brightest lights to display in the 
real-time OpenGL preview. You can also manually select which 
eight lights to preview in the Light Properties palette (see “Light 
Properties” on page 270).

Lights can also help you create effects. For example, you could 
add a reflection map to an element in your scene, causing it to 
direct light back at the source. Please refer to “Using the Group 
Editor” on page 681 or an explanation of material groups and 
to “Part 3: Materials” on page 280 for information on creating 
material shaders for your scene elements.

The Light controls appear as follows.

 Light Controls.

Each light has customizable characteristics, such as rotation and 
revolution positions, color, and intensity (brightness). You can 
turn lights on or off, adjust how the brightness diminishes as you 
reach the edge of a light’s range (the falloff), and specify whether 
or not a light casts a shadow. You can also animate lights to 
create effects such as lightning or flickering streetlights. As with 
any other Poser object, you can parent lights to scene elements 
to have the light move as the source element moves. By default, 
Poser scenes include three infinite lights.



Poser Pro 2014
Reference Manual 

262

Chapter 12: Lighting

When you add, remove, move, or adjust lights, the Document 
window, Light controls, and the selected light’s parameter dials 
automatically adjust to show the light’s new position/properties, 
allowing you to preview your changes in real time.

When you right-click on one of the lights in your 
scene, a context menu provides several different 

commands that allow you to perform several different 
functions. The commands shown in the light context 
menu are described in “Lights Context Menu” on page 
85.

Light Types
Poser allows you to create four types of lights: infinite, point, 
spot and image based.

Infinite Lights

Infinite lights are comparable to the sun or moon shining on the 
Earth. Rays from infinite lights are parallel as they enter your 
Poser workspace. If you have multiple figures and/or props in 
your scene, infinite lights shine on each item equally. You cannot 
place any scene element beyond an infinite light’s range, and no 
figure/prop can be lit differently than another.

 Infinite Lights shine parallel, and equally on all items in your scene.

Point Lights

Point lights are similar to a light bulb, in that they emit light 
from a single source point outward in 360 degrees. These lights 
are ideal for times when you want an omnidirectional light 
source that can interact with objects and cast shadows in ways 
that an infinite light cannot. For performance reasons depth 
mapped shadows are not supported for point lights; point light 
shadows must be calculated using raytracing.
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Spotlights

Spotlights cast light in a specific direction, throwing light along 
a cone-shaped path to create a classic stage spot effect. These 
lights are useful for illuminating specific objects or for creating 
lighting effects. Spotlights can increase rendering times.

Diffuse Image Based Lights (IBL)

Diffuse Image Based Lighting (Diffuse IBL) takes a light probe, 
which is ideally a 360 degree light distribution map captured 
in a single map, and illuminates the scene using that map. In 
Poser, only the diffuse component of the light is defined by the 
light probe. As this technique is based on complete light data 
for a given space, the lighting results are very realistic. In order 
to get realistic shadows when using an image based light, we 
recommend using Ambient Occlusion (see “Light Properties” 
on page 270). You must activate raytracing in the Render 
Settings dialog in order to render Ambient Occlusion effects.

To attach a light probe to the image based light, press the 
Advanced Material Properties button on the Properties 
palette (see “Light Properties” on page 270). Once in the 
Material room, you have the option of attaching simply a light 
probe image map, or a shader tree of any complexity, to the color 
channel of your Diffuse IBL.

Poser has the ability to apply the full 
functionality of its procedural shading system to 

an image map used as an image based light. See “Part 3: 
Materials” on page 280 for more information about 
the image node manipulations available using the 
shading system in the Material room.

Selecting Lights
You can select lights as follows:

• Clicking one of the Lights in the Light Position indicator.

• Using the Current Actor pop-up menu.

Creating Lights
To create a light, click the Create Light icon in the Light 
controls, or click on Create Light in the Light Options pop-
up menu. Your new light will appear in the Light Position 
indicator.
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 The Create Light icon.

By default, Poser creates spotlights. To create a different type of 
light, select Object > Create Light, and select the type of light 
you wish to create from the pop-up menu that appears.

To change a light to another light type, select the new light and 
click the Light Properties icon (see below for information about 
light properties). You can also right-click the Create Light icon 
(in the box above) to access the light type menu.

 Creating a light with the Object menu commands.

If you select the Diffuse IBL light type on the Properties tab, you 
will then need to go to the Material room, select that light as the 
current actor, and apply an image map to use as the light probe. 
In the Simple tab, you can simply select an image map via the 
Texture Manager. In the Advanced tab, you would attach an 
image node or a complete shader tree to the color channel.
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Adjusting Light Intensity
You can set a light’s intensity using the Brightness control like 
a dimmer switch. Click and drag the brightness indicator to the 
left to dim the selected light, or to the right to brighten it.

You can also set the light’s intensity using the parameter dials in 
the Parameters palette.

 Slide the Light Intensity slider to adjust the brightness of a light.

For image based lighting, you must adjust the light intensity in 
the Advanced tab of the Material room. Take care when making 
these adjustments, so that your results will approximate the 

realism of the lighting conditions in the image map you have 
selected.

You can set a light’s intensity to a negative value, 
thereby creating a “non-light” that will actually 

darken the affected area(s) of your scene. You can use 
this feature to create interesting effects.

Light Color
Light colors contribute to your scene’s overall appearance and 
mood. Unlike paints, light colors multiply instead of mixing 
and adding to one another. For example, a red figure with blue 
lighting would appear black, not purple. If you don’t want a light 
to affect the color of items in your scene, set that light’s color to 
white or gray. Because of this relationship between scene items 
and lights, you might want to set your scene items’ colors before 
setting lighting colors. Note that with image based lighting, you 
should generally use a white color, so as not to interfere with the 
light colors already contained within the image map.

To change a light’s color, click the Color icon in the Light 
controls to open a standard Color Picker dialog. Make your 
selection, and your selected light will change to its new color.

Two icons appear in the upper-right corner of the Light Color 
picker. The first icon opens the Material Editor, where you can 
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add advanced material properties to the light. The other icon 
opens your standard system color picker.

You can also set a light’s color using the parameter dials in the 
Parameters palette. For image based lighting, you can use the 
Advanced tab of the Material room to plug any image node into 
the color channel of that light. Doing so will allow you to see the 
effects of the image based light on any surface in the Material 
room, which will give you an exact idea of how those surfaces 
will be shaded in the final render.

 Changing the color of a light.

Delete Light
Select the light you wish to delete and click the Delete Light 
icon in the Light controls, or click on Delete Light in the Light 
Options pop-up menu.

Aiming Lights
Spotlights and infinite lights are directional light sources, 
and therefore can be aimed with relation to your scene. You 
should finish posing your figures and positioning your props 
before aiming your lights. Doing this in reverse will cause your 
scene elements’ appearances to change as you move them. For 
example, rotating a figure 180 degrees causes illumination 
falling on its front to fall on its back. You may need to re-aim 
your lights to continue working. Some traditional artists place a 
bright light above and to the left of a figure. Using a strong single 
light source lets you see shading on distant and oblique surfaces, 
contributing to the scene’s depth and curvature. You may want 
to read books on lighting, including using lights in photographic 
studios, to give you ideas on using lights to enhance your Poser 
scenes.

If you import a background image or movie, you should set your 
lights to mimic the lighting in the background. For example, if 
your background image shows a strong light coming from the 
figure’s right, don’t light the figure from the left. This will help 
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preserve consistency between your scene and the background 
and help integrate both elements together. Ideally, when 
working with backgrounds, you should have the background 
look like part of your scene. If your scene is a room using an 
image of a brightly lit background visible through the windows, 
you should have most of your lighting streaming in through the 
windows to blend the room and its contents with the outside 
world and lend realism to your scene.

You can aim lights using any of the following methods:

• Using the Light Position control (see below).

• Moving a light’s indicator in the Document window (see 
below).

• Using the Editing tools (Rotate and Twist for infinite lights, 
and Rotate, Twist, Translate/Pull and Translate In/Out 
for spotlights. Please refer to “The Editing Tools” on page 
184 for information on using the Editing tools).

• Using the selected light’s parameter dials in the Parameters 
palette.

• Using the Object > Point At (“Point At” on page 212) or 
Object > Set Parent (“Changing a Parent” on page 231) 
menus.

• Using the desired light’s Shadow camera, as described in 
“Shadow Light Cameras” on page 246.

As discussed above, infinite lights always shine into the scene. 
Aiming an infinite light sets the location from which the light 
shines (such as setting the sun’s position in the sky). When 
aiming spotlights, you’re setting both the angle at which the light 
shines and the light’s position in 3D space.

Using the Light Position Control

The globe in the center of the Light Position indicator 
represents your Poser scene in 3D space, and the light dots 
represent the positions of each of the lights within your scene. 
These dots can be moved in two ways with respect to the globe: 
Rotation and Revolution. Rotation keeps the light in the same 
physical position relative to the scene, but adjusts its direction 
around its own local axis. Revolution moves the light around the 
globe to a new position relative to the scene, while keeping the 
light pointed at its parent, as shown in the figures below. You 
can select which positioning method you wish to use by clicking 
either Rotate or Revolve in the Light Options pop-up menu. 
The check mark indicates which option is currently selected. 
Then click and drag your selected light dot(s) to change their 
position and/or direction. Revolving these dots to different 
positions around the globe adjusts the lighting angle, as shown 
below.
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 Adjusting light positions.

Clicking anywhere in the Light Position control 
selects the nearest light.

Using Light Indicators
When you select a light, Poser displays a light indicator 
describing your selected light’s position in the Document 
window. In some cases, viewing the indicator from a different 
angle can help you visualize your light’s position. You can 
switch Camera views and/or zoom to view light indicators from 
different angles. Additionally, you can adjust a light’s position 
by clicking and dragging the light indicator in the actual scene. 

The Light controls will reflect any changes you make to the light 
indicator’s position. Note that image based lights have no light 
indicators, as they surround your entire scene.

Infinite Light Indicators

An infinite light’s indicator appears as a ring surrounding the 
currently selected figure/prop. This ring serves as the equatorial 
line of an invisible globe with the light shining down on your 
scene from the point on the equator indicated by the arrows, as 
shown here.

 Infinite Light Indicators.

Then viewed from oblique angles, the circle appears as an ellipse, 
helping show if the light is in front of or behind the figure. The 
light is not actually on the edge of the indicator. The indicator 
simply represents a larger globe encompassing the entire Poser 
workspace. You can click and drag a light indicator to reposition 
the selected light.
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Point Light Indicators

A point light’s indicator appears as a small outlined circle, 
depicting the light’s position in 3D space (remember, you can 
position point and spotlights in 3D space, unlike infinite lights), 
as shown here.

 Point Light Indicators.

As point lights emit light equally in all directions, there is no 
direction indicator as with a spotlight.

Spotlight Indicators

A spotlight’s indicator appears as the outline of a spotlight in 
your Poser workspace depicting both the light’s position in 3D 
space and the direction the light is pointing, as shown in this 
image.

 Spotlight Indicators.

Clicking and dragging a spotlight’s indicator moves the light 
around the scene.

You may want to use orthographic views (Left, 
Right, Top, Bottom, Front, or Back) to move 

Spotlight indicators, since doing so constrains the 
spotlight’s motion to two dimensions (YZ if using the 
Left or Right views, XZ if using the Top or Bottom views, 
and XY if using the Front or Back views). Using 
perspective views can move your spotlight in oblique 
directions, causing unexpected lighting effects.
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Light Properties
Light properties help you fine-tune your lighting effects. To 
access a light’s properties, select the light and either click the 
Light Properties icon in the Light controls or select Object 
> Properties. You can also access light properties in the 
Properties palette.

 Light Properties.

Depending on the light type that you select, you can control 
some or all of the following light properties:

• Include in OpenGL Preview: By default, Poser displays 
the eight brightest lights. Users can optionally choose which 
eight to display. By providing real time previews of eight 
user-selectable lights, posing and lighting is faster and 
yields better results. Use this option to select each light you 
want to illuminate the scene preview. Mip Map support has 
been enabled for enhanced performance when previewing 
large textures. Together, these real-time preview engine 
enhancements let the user view larger textures and offer 
more complete scene previewing when setting up lights 
If your scene has more than eight lights, you can check or 
uncheck this option to include or exclude the current light 
from the preview display.

• Visible: Checking the Visible checkbox makes the light 
visible in the Document window, and vice versa. Invisible 
objects are not included in any render calculations, and do 
not appear in the rendered scene. See “Figure Properties” 
on page 193 for information on animating the Visible 
property.

• Animating: Checking the Animating checkbox allows you to 
animate the light just as you would any other Poser object. 
Animated lights can also have different settings in various 
keyframes. For example, you could create a red spotlight on 
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your figure’s left side that orbits overhead and turns blue. 
When you rendered this animation, you would see your 
figure’s color changing and shadows moving with the light. 
You cannot animate lights that are turned off (see above).

• On/Off: Checking the On box turns the light on, just like 
flicking its switch. Clearing the checkbox turns the light off. 
As a shortcut, you can also press OPT/ALT while clicking a 
light in the Light controls to toggle the selected light on or 
off.

• Spot/Infinite/Point/Diffuse Image (IBL): Check the 
appropriate radio button (Spot, Infinite, Point or Diffuse 
Image (IBL)) to make your selection. Spot, infinite, point 
and image based lights are discussed above.

• Shadows: Checking the Shadows checkbox enables you to 
choose one of the following two options:

 � Raytrace Shadows: Selecting Raytrace Shadows 
enables raytracing of shadows. Traditionally, raytracing 
results in clear, hard-edged shadows. However, Poser 
offers a method for softening the shadow edges, thus 
adding more realism to your raytraced shadows. You 
can control this effect using the Shadow Blur Radius 
dial (see below).

 � Depth Map Shadows: Selecting Depth Map Shadows 
enables depth-based shadow mapping. If you are using 

displacement maps, we recommend you select this 
option rather than raytracing, for greater accuracy. 
Enabling this option activates both the following dials:

 � Shadow Blur Radius: All shadows have a blurry 
region around their edges. The Shadow Blur Radius 
parameter specifies the radius of this blurry region. By 
default, this dial is set to a low value. Raising the blur 
radius increases the soft shadow edge effect.

 � Shadow Samples: The Shadow Samples parameter 
controls the smoothness of shadows. The default value 
is equivalent to earlier Poser versions that used a fixed 
quality. Lower shadow sample settings render faster 
but may produce grainier shadows with a random 
dither. Higher shadow samples reduce the graininess 
that can sometimes be seen in soft raytraced shadows. 
As a general rule, the larger your Shadow Blur Radius 
setting is, the more you will need to increase the 
Shadow Samples to get a smooth result.

 � Shadow Min Bias: The Shadow Min Bias parameter 
specifies how far to shift samples towards the light 
source to prevent self-shadowing of objects.

• Preview Shadow Map Size: Sets the amount of detail 
in the shadows that are displayed by the preview render. 
Default is 512. Higher values will make the shadow preview 
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more detailed and accurate but will increase usage of system 
resources.

• Ambient Occlusion: Checking the Ambient Occlusion 
checkbox enables Ambient Occlusion for the selected 
light. Ambient occlusion adds realism to your scene by 
approximating the way light and shadows act in real life. It 
helps bring out details in creases and corners. This option 
provides the advantage of calculating Ambient Occlusion 
effects on all surfaces within the scene, without having 
to attach an Ambient Occlusion node to every material. 
Enabling this option activates the following controls:

 � Strength: The Ambient Occlusion Strength dial 
specifies the degree to which Ambient Occlusion effects 
will darken the occluded surfaces within the scene.

 � Scene AO Options: The Scene Ambient Occlusion 
Options button provides access to the global set of 
Ambient Occlusion parameters. These parameters are 
described in the Ambient Occlusion node section under 
“Raytrace Nodes” on page 357.

 Scene Ambient Occlusion options.

• Atmosphere Strength: The Atmosphere Strength dial 
and field allow you to specify the strength of atmospheric 
(volumetric) effects. This attribute is used in conjunction 
with the Root Atmosphere node, which is described in 
“Root Atmosphere Node” on page 331.

 Atmosphere Strength control.

• Set Parent: Clicking the Set Parent button allows you to 
make the light a child of another element in your scene.
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• Color: Clicking the Color button opens the Poser Color 
Picker, allowing you to set the light’s color.

• Advanced Material Properties: Clicking the Advanced 
Material Properties button will automatically take you 
to the Material room, with the current light active in the 
Shader window’s Advanced tab. Please refer to “Advanced 
Shader View” on page 308 for more information about the 
Advanced tab of the Shader window, and to “Root Light 
Node” on page 330 for more information about the root 
Light node attributes.

• Attenuation: (Enabled for Spot lights or Point lights only): 
This setting controls how bright or dark a spot light or point 
light gets based on the distance away from the light source. 
Options for spot and point lights are:

 � Constant: Behaves the same as Poser 7 and earlier 
lights. This setting is predictable and controllable. The 
Start Distance and End Distance parameters are very 
useful for setting how close or far the light reaches.

 Constant Attenuation.

 Constant Attenuation with Tone Mapping.
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 � Inverse Linear: Use this option for lights that are 
more physically correct. Objects that are close to the 
light source are infinitely brighter (not exponentially, 
but linearly). In other words, of Object B is twice the 
distance from the light as Object A, then Object B 
receives half as much light as Object A. This option 
allows some artistic freedom without being as touchy as 
Inverse Square (described next).

 Inverse Linear Attenuation.

 Inverse Linear Attenuation with Tone Mapping.

 Inverse Linear Attenuation with Tone Mapping, Adjusted.
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 � Inverse Square: This option provides physically 
correct lighting that is more dramatic, and harsher than 
Inverse Linear. The light brightens exponentially as you 
get closer to the light source. If Object B is twice the 
distance from the light as Object A, it receives 1/4 the 
amount of light.

 Inverse Square Attenuation.

 Inverse Square Attenuation with Tone Mapping.

 Inverse Linear Attenuation with Tone Mapping, Adjusted.
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• Evaluate in Light: When checked, includes Ambient 
Occlusion in render calculations relating to light and 
shadows.

Light Parameters
Be sure to select the light you wish to work with before using 
the parameter dials to avoid accidentally changing settings for 
the wrong light. Once you’ve adjusted a light the way you want 
it, you can use the Lock Object command (see “Lock Object” 
on page 211) to prevent accidental changes. Lights have the 
following parameters, available in the Parameters palette:

 Light Parameters.
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Angle Start/End (Spotlight Only)

The Angle Start and Angle End values allow you to specify how 
a spotlight’s light “falls off” as you approach the edge of the cone 
of light projected by the spotlight. The Angle Start parameter 
specifies the amount of light (in percent) present at the start of 
the cone of light projected by the spotlight, and the Angle End 
parameter specifies the percentage of intensity present at the 
cone’s end.

Distance Start/End (Spotlight Only)

As you know, light fades with distance from its source. The 
Distance Start and Distance End parameters specify the 
distance from the light source (in grid units) where the 
spotlight’s intensity begins to drop (fall off), and the distance 
in grid units when the spotlight is no longer casting light, 
respectively.

Shadow

Poser lights can cast shadows, if you enable this option using the 
selected light’s Cast Shadow property in the Properties palette 
as described above. Shadows add depth, realism, and dramatic 
effects to your still or animated scenes. To change the cast of a 
light’s shadow, move the light.

Spotlights cast shadows based on the spotlight’s angular range, 
meaning that tighter spotlights produce cleaner shadows. By 
contrast, infinite lights adjust the view to fill the screen with 
all objects that cast shadows. Because of this, if you render a 
close-up of a scene with many figures and/or props (especially 
widely spaced items), the shadow map will not contain much 
information.

Each light has a shadow camera, available using 
the Current Actor pull-down menu. Advanced 

users can aim these cameras as desired. Each light’s 
shadow map contains shadow information for the scene 
as viewed through that light’s shadow camera.

The shadow-related parameter dials are:

• Shadow: Use the Shadow parameter dial to specify the 
selected light’s shadow strength. A setting of 0 disables cast 
shadows for the selected light, while a setting of 100% casts 
a dark shadow. You can animate shadow strength over time.

• Map Size: The Map Size parameter dial sets the size of 
the selected light’s shadow map in pixels (shadow maps 
are square). Poser uses image maps to apply shadows to 
objects in the scene, and applies these shadows during 
rendering. Larger map sizes increase the accuracy and detail 
of shadow maps, but at a cost in memory and render time. 
For example, each 1024x1024 map requires about 4MB of 
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space, while a 2048x2048 map requires 16MB. You cannot 
animate the shadow map’s size.

XYZ Rotation

Adjusting these dials adjusts the direction in which the light is 
pointing. For example, think of the sun’s path across the sky 
throughout the day and how it appears farther north or south 
with the changing of seasons. When the xRotate and yRotate 
dials are set to 0 degrees, the light aims at the Poser workspace 
from the front. ZRotate is only significant when the xRotate and 
yRotate settings are not 0,0 or 180, 180. In all cases, the figure 
is in the default position.

• xRotate: The xRotate parameter rotates the selected light 
about the X axis.

• yRotate: The yRotate parameter rotates the selected light 
about the Y axis.

• zRotate: The zRotate parameter rotates the selected light 
about the Z axis.

Scale

The Scale parameter dial allows you to scale a light’s indicator. 
This does not affect the light itself.

Red, Green, Blue

The Red, Green, and Blue dials specify the amount of each of 
the three primary colors to add to a light’s final color. A value 
of 1 means that the selected color is fully added, and 0 means 
that color is not included at all. Using these three primary 
colors to create a final color is called RGB lighting (Red, Green, 
Blue). Each of the three colors can have 256 values ranging 
from 0 to 255. This gives us 256 red, 256 green, and 256 blue 
shades to work with, or 256^3 (16,777,216) total possible colors. 
Parameter dial values correspond to RGB values as follows:

• Parameter dial 0 = RGB color value 0 for the selected color.

• Parameter dial 1 = RGB color value 255 for the selected 
color.

Intensity

You can control your light’s intensity using the Brightness 
control or the Intensity parameter dial. A setting of 0% means 
the light is fully off, and a setting of 100% means the light is 
completely on (at full brightness/intensity).
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XYZ Translation (Spotlight Only)

The Translation dials allow you to specify a spotlight’s 
precise location in 3D space by specifying grid coordinates. As 
previously described, spotlights emit light from their location 
in 3D space, meaning that objects “behind” the light are not 
illuminated.

Saving & Loading Light Sets
You can save light sets to the Library, allowing you to reuse them 
in later scenes. Light sets have the file extension *.LT2 and are 
saved to the Lights Library. Please refer to “Maintaining Your 
Library Palette” on page 161 for information about adding 
items to the Library palette.

Memorizing and Restoring Lights
You can use the Edit > Memorize > Lights command to 
memorize the settings of the lights in your scene. If you later 
want to return to those light settings, choose the Edit > Restore 
> Lights command to restore the settings back to those that you 
memorized. If you delete lights after you memorize light settings, 
the deleted light(s) will not be restored.

Animating Lights
Lights can be animated like other Poser objects using keyframes 
and tween frames. Please see “Chapter 22: Animating with 
Poser” on page 447 for information about animating within 
Poser.
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Part 3: Materials
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Chapter 13: The Basics 
of Materials

Each figure/prop has its own unique material list containing 
individual materials within that list. You can see this for yourself 
by creating a Poser scene with two or more figures/props and 
opening the Material room.

 Two figures in a scene.
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This sample scene has two figures (Alyson Casual and Ryan 
Casual). The Material room therefore displays the following 
selections:

 Materials found in Alyson and Ryan Casual.

As you can see, the two figures in this image each have different 
materials lists. Each object in a Poser scene has its own list 
of materials, which is different for each object. These lists of 
materials behave like a multi/sub-object material list/table.

Why Multi/Sub-object Materials?
The purpose of having more than one material per figure (multi/
sub-object materials) is to provide each polygon with a different 
or shared material property with other polygons. This gives you 
control over material properties down to the polygon level.

A side benefit is that multi/sub-object materials also allow 
great flexibility. For example, if you have a scene with multiple 
figures, each figure can have its own skin and clothing colors. 
Selecting one figure or prop displays only the materials assigned 
to just that figure/prop, which organizes your materials and 
prevents possible confusion. Also, if you save a figure or prop to 
the Library palette, its materials will be saved as well, thereby 
preserving your work.

Color
Color is easy. By applying a color to an object or material group, 
you are essentially dumping a bucket full of paint on that 
object or group. Color goes a long way toward establishing the 
final look of your object but it doesn’t tell the whole story. For 
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example, painting an apple red is obvious, but the simple red 
color does not contain the other colors and shades, nor does it 
portray the apple’s small imperfections and other features. Thus, 
a material that simply uses color ends up looking plastic.

About Maps & Templates
Look at your own skin. Notice the differing colors, hairs, veins, 
moles, and other features. Look at any object. Is it smooth or 
rough? Opaque or transparent? If transparent, does it have the 
same transparency all over or in portions? Is it matte or glossy? 
Is it reflective? What sort of texture or pattern does it have? 
Now look at the objects around you. They all have different 
material properties. How can you capture these properties 
in your 3D objects? One answer is mapping. Each object in 
your Poser scene can have its own maps, which are used for 
specifying various attributes. Maps provide an efficient way to 
add advanced effects to your objects. For example, if you had 
to model every wrinkle, mole, eyelash, hair, or other feature, 
your object’s polygon count (number of polygons) would quickly 
become prohibitive. In fact, most of the 3D figures and other 
objects you see in feature films have relatively low polygon 
counts and make extensive use of mapping.

As you know, most maps are two-dimensional representations 
of 3D surfaces. Each point on the Earth’s surface that lies within 
the map’s area of coverage corresponds to a point on the map. 

Depending on the area being mapped and the mapping method 
used, the map may or may not resemble the actual surfaces it 
represents. This effect is called distortion and is most easily 
seen on world maps created using the Mercator projection. We 
could spend a lot of time on this, but the important things to 
remember are that:

• Maps are 2D representations of 3D surfaces.

• Each coordinate (location) on the 3D surface corresponds to 
a location on the map.

• The map may or may not resemble the 3D surface.

Here is a sample map template for a Poser figure:
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 A texture template.

The grid-like lines on the map correspond to the polygons on the 
figure mesh object itself. Blank areas do not correspond to any 
part of the figure and are ignored. Thus, you can “color outside 

the lines” without ill effect, since only color falling within the 
lines actually appears on the figure.

Maps used for figures normally use the UV coordinate system 
where the upper left corner corresponds to 0,0 and the bottom 
right corner to 1,1. Thus, the exact center of the map would be at 
0.5,0.5. For any given object, you start with the blank template 
shown above and modify it depending on the type of map you 
are creating.

Alyson 2 and Ryan 2 use the same templates and 
texture maps as Alyson and Ryan.

Texture Map
All map types (bump, transparency, etc.) are 2D representations 
of 3D objects, and texture maps are no exception. Texture maps 
are the primary way of making 3D objects look real. Texture 
maps make skin on your Poser figure look real, add realistic 
grain to wood, etc. The following example shows a texture map 
for one of the Poser figures:
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 A texture map.

You can use shader elements such as color to get an effect 
without using texture maps, but you won’t be able to precisely 
place features where you want them (such as painted fingernails 
on the ends of the fingers).

Bump Maps
A bump map is used to simulate roughness on a surface. Bump 
maps are grayscale images where dark gray/black signifies lower 
areas and bright white/light gray areas signify higher areas. 
They work by shifting the object’s normals to give the illusion of 
depth. On a human figure, a bump map allows you to simulate 
wrinkles and other imperfections/textures.
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 A bump map.

Transparency Maps
A transparency map is like a bump map in that it is a grayscale 
image. Transparency maps regulate the amount of opacity 
in a given location. The darker the color is, the greater the 
transparency, and vice versa. Here’s a sample transparency map 
for eyelashes.
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 A transparency map.

Look at the bump map, above. The lighter colored areas around 
the eyelashes indicate that they should have height, that is, they 
should stand out from the figure itself. The texture map (see 
“Texture Map” later in this chapter) specifies the lashes’ color as 

rough smears. The transparency map above allows only those 
portions of the texture map corresponding to the lighter areas 
to show through. The combined effect is eyelashes that stick out 
from the eyes. Where there are no eyelashes, you can see the skin 
beneath them. This is a great example of how combining maps 
can create very realistic effects.

Reflection Map
Reflection maps are also grayscale. As the name implies, they 
are used to differentiate areas of varying reflectivity. The use of 
reflection maps allows you to, for example, create a patterned 
mirror where the patterns have a higher or lower amount of 
reflection.

Displacement Map
Displacement maps are very similar to bump maps but with a 
key difference: Instead of simply shifting normals, displacement 
maps actually move (displace) an object’s geometry. Thus, 
displacements provide more “real” depth than bump maps. 
Displacement occurs at render time, meaning that objects will 
look smooth until rendered.
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Procedural Shaders
Poser’s FireFly rendering engine supports the use of procedural 
shaders (or shaders for short). Shaders consist of a root 
node that can be modified by adding additional nodes that 
modify one or more of the root node’s values. A node’s output 
can modify one or more nodes, and you can use more than one 
node to influence another. You can include all of the maps we’ve 
discussed above when building shaders. You can also create 
realistic materials that don’t require any maps at all, or you can 
have other nodes modifying any maps you decide to use. Thus, 
shaders are a second method of creating materials that may 
or may not integrate maps. Please refer to “Chapter 14: The 
Material Room” on page 296 for information about Poser’s 
Material room.

Creating Character Textures
Creating your own textures for figures and/or props requires a 
solid grasp of the concepts explained in “Appendix C: 3D Basics” 
on page 857 and knowledge of one or more 2D graphics tools 
such as Adobe Photoshop. The process of creating textures is 
very similar if not identical for many 3D applications. While it’s 
impossible to cover the entire process in this manual, we can 
give you enough information to understand the basics and begin 
creating your own maps.

This section covers creating maps. Please refer to 
“Part 3: Materials” on page 280 for 

information about applying maps to shaders.

Creating Texture Templates

If you use the figures and props that came with Poser (or if you 
buy figures from most third-party vendors), they probably come 
with one or more ready-made texture maps and one or more 
blank templates. If you need to create a new texture template, 
you’ll need to follow a process that is roughly similar to the 
following:

1. Create your mesh object in your preferred 3D modeling 
application.

2. Export the mesh in a format supported by Poser (see 
“Importing 3D Objects” on page 779 for a list of 
supported formats).

3. If your 3D modeling application supports exporting your 
mesh object with UV mapping data, be sure to do this, 
as this will probably create your template for you. Please 
refer to your 3D modeling application documentation for 
information.

4. If your exported object does not have UV information, you’ll 
need to use an application such as UV Mapper (http://

http://www.uvmapper.com
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www.uvmapper.com) to create the UV information and 
a blank template that can be used for any sort of map 
(texture, bump, transparency, reflection, displacement, 
etc.). If you use a third-party application to create texture 
templates, please refer to that application’s documentation 
for information on using that application. Also, should you 
require technical support, please contact the application’s 
creator or vendor. Smith Micro cannot provide support for 
third-party applications.

Creating and Using Texture Maps

This subsection contains a brief tutorial on creating texture 
maps.

If you’ve seen some computer-animated movies lately, you were 
probably astounded by the realism of the characters; this high 
level of believability was achieved using high-quality 3D models 
and image maps. The fact is, image maps can make or break a 
model’s believability. What may surprise you is that Poser can 
generate equally realistic results for you. We are going to give 
you some pointers on how you can do this yourself using Poser 
and a 2D graphics application such as Adobe Photoshop. The 
primary topic for this tutorial is texture maps, however the 
same principles apply to all types of image maps. Please refer to 
“About Maps & Templates” on page 283 for information about 
the various types of image maps.

Poser supports texture resolutions up to 8192 x 
8192 pixels. For optimum performance in 3D 

software and gaming engines, try to create your texture 
maps at standard resolutions that are a power of 2. 
Standard sizes are 512, 1024, 2048, 4096, and 8192.

Poser’s Material room can create complete 
materials without needing any image maps. To 

obtain precise results, however (such as a tattoo in a 
specific location), you will need to include image maps 
in your shaders for texture, bump, transparency, etc. 
Image maps are added to nodes using the Material 
room. Also, the Face room can create custom head 
textures for the Poser figures from images or even from 
scratch!

A texture map looks like a skinned 3D model spread out onto 
a flat surface. Imagine peeling an orange and flattening the 
peelings on a table- that’s a texture map. When creating a 
texture, remember that it will ultimately be wrapped around 
your object and that you’ll need to pay special attention to the 
edges, which will be seams when the texture is rendered.

http://www.uvmapper.com
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 A texture map is painted over a template.

Texture makers use a UV map (template) to place the texture’s 
major pieces. A UV map provides grid-like lines that correspond 
to the object’s geometry, provides a coloring book approach 
to making textures, and only requires a good graphics editing 

software package such as Adobe Photoshop. Like a coloring 
book, items not placed properly within the grid lines render 
askew, and anything bleeding over the edge of the grid does 
not appear at all when rendered. This is one time where you 
definitely want to stay between the lines! The texture maps for 
the figures and props that are included with Poser are located on 
the content CD. Because realistic human textures are the hardest 
to achieve, we decided to describe creating one for this section. 
The same principles apply to any texture you are creating, be it a 
brick wall, animal fur, a plant- any figure or prop for which you 
want to use texture mapping.

The brief explanation that follows is courtesy of Ms. Syyd Raven, 
who created the textures used by several default Poser figures:

“Save often and under different filenames to preserve 
each step of your work.

Maps of 1500-3000 pixels provide an ideal realism/
performance balance. Some third-party textures can 
be 4000 pixels or more, however these can slow Poser 
down because they require additional computing 
resources.”

The figure used for these renders requires two maps, one for 
his head, and one for his body. Different Poser figures may use 
one or two texture maps, depending on the figure. The following 
sections address each map separately, and the same principles 
apply to figures that only use one map.
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As discussed above, creating maps is an 
advanced process that can require one or more 

third-party tools. Smith Micro cannot provide support 
or additional information on creating texture maps 
beyond the technical aspects that directly involve Poser. 
The material presented in this section is for 
informational purposes only.

The Head Map

• Photos used for the basis of your texture should roughly 
match the final texture map size.

• Work on one side at a time.

• Set the photograph’s opacity to approximately 50% so you 
can use the underlying template to align it; scale, rotate, and 
clone individual facial features to perfectly fit the map.

• With your image editor running, launch Poser and apply the 
head texture to the figure:

 � Set the figure’s material color to white and highlights to 
black in the material editor.

 � Render the model with white lighting, no shadow, and 
antialiasing enabled to test texture alignment.

 � Test various morph targets on the face to verify that the 
texture remains in alignment.
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 �  If the texture does not align properly on the template, it 
will also not align properly on the model.

• Make changes in your image editing software and test 
render in Poser as many times as you need.

• Once you are satisfied with your map, mirror the completed 
side by copying and pasting into a new layer and flipping the 
new section.

• After mirroring the texture, you may notice a line down 
the center. Remove this line by cloning an area with a 
matching color, cutting and pasting small photo pieces 
from the original source image, using the blend tool, or any 
combination of these methods.

• Change and add various details (lines, moles, etc.). No face 
is perfectly symmetrical!

• Continue expanding the skin to a bit beyond the template 
edge.

• While testing, rotate the head to see the ear and side of the 
neck; you will need to pay close attention to these areas to 
ensure that there are no seams.

• Cut out and place individual teeth, giving the front six 
(top) and eight (bottom) the most detail. Realistic teeth are 
somewhat gray/yellow, not white.
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• Photograph a tongue and apply it directly to the map. 
Pay attention to the deep grooved center line; this adds 
credibility to the texture when the model’s mouth is open.

• The inner mouth looks reminiscent of a rib cage 
surrounding lungs.

• Lachrymal glands (tear ducts) have wetness and roundness.

• Take close-up photos of eyes.

• Have the model hold their eyes wide open to show the 
whites and roundness of the iris.

• Make the veins thin and not overly red to avoid bloodshot-
looking eyes.

• The Body Map

The body’s fine details (hair, moles, etc.) require larger maps to 
avoid blurring and pixilation. Many third-party body maps are 
double the size of the corresponding head map.

 A body texture map.

• It’s difficult to use complete photos for textures since they 
will not align correctly. Size and rotate working images or 
photos using separate layers.
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• Lay out the entire body first, without worrying about 
matching edges to get major portions in place, then finesse 
the edges with ever-increasing detail.

• Male maps require more detail than females because of 
body hair.

• Photograph small areas, treating arms as 4-sided objects; 
concentrate on elbow creases.

• Male necks can include beards or stubble, which can be 
problematic due to different resolutions between the head 
and body textures.

• Nipples can be tricky due to low resolution and may require 
fine-tuning, especially on female maps due to breast 
morphs.

• Hands are also important; get close-ups of both sides.

• Take care to include hand veins on the final texture as well 
as creases that match the model’s geometry.

• Use the same map for the left and right hand, then add 
asymmetrical features. Repeat this for the feet.

• Cut individual fingernails and toenails from your 
photographs and fit them into the template.

• Make sure you test all your work-in-progress in Poser.

• When the body is complete, correct the head and body color 
to make them the same shade/hue. Writing down your color 
values can be a big help.

Creating and Using Bump, 
Reflection, and Transparency Maps
To be fully realistic, many textures also need transparency 
and bump maps. For example, the eyelash area template 
needs to be white where you want the object or eyelash visible. 
Consequently, you will start with a black background and draw 
in white where you want the eyelashes to appear when rendered. 
A graphics tablet works well for this, since eyelashes require a 
natural curved line that tapers to a point, which can be hard to 
achieve with a mouse. If you don’t own a graphics tablet, you 
can begin with a very large map and reduce it to the proper size 
later. The larger map will make it easier to draw the lines with 
accuracy.

Bump maps add further realism to skin pores, scars, or moles. 
For photorealistic skin, it’s imperative to deal with major 
landmarks (moles, birthmarks, etc.) using a bump map. The 
quickest way to create bump maps is to copy the finished texture, 
desaturate it (that is, remove all the color leaving only the 
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black and white components), and invert it. Then convert it to 
grayscale. This reduces the file’s size and memory requirements.

Poser allows you to adjust the bump maps’ height, so it’s a good 
idea to design them with very high contrast (or the most bump). 
Most graphics packages have automatic contrast controls; this 
is a great way to quickly get the widest range of bump for your 
maps. If needed, you can decrease the bump height within Poser 
before render time.

White areas of the bump map are high, and black areas are 
low. In order for your texture to make a plausible map, you will 
have to invert it before you can use it. If you forget to do this, it 
may take you a while to figure out why your test renders look a 
bit odd. A good example of this would be whiskers pushing in 
instead of outward.

Bump maps simply disturb an object’s normals. 
If you apply a bump map to a sphere, the surface 

will seem rough while the edges remain smooth. Poser’s 
Material room contains a displacement channel, 
allowing you to use bump maps to actually alter the 
geometry. For example, applying a displacement map to 
a sphere would make the edges appear rough.

Once you’ve adjusted the contrast and desaturated your texture, 
you can start modifying it to suit your particular needs. Go 
ahead, give it a shot: You might be pleasantly surprised with 
your results!

Putting It All Together
The following image demonstrates the results you can achieve by 
combining the various types of maps.

 A completely textured figure.
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Chapter 14: The Material 
Room

Poser’s Material room is a very powerful tool for creating and 
editing procedural shaders for the content in your scene. The 
Material room is designed from the ground up to provide the 
ultimate in power, flexibility, and ease of use by artists and 
animators. You don’t need to be a programmer! The Material 
room gives you ultimate control over the appearance of your 
Poser scenes.

The Material room allows you to describe the material properties 
of your objects’ surfaces by giving you full control over every 
aspect of shading a surface, from the surface color to complex 
lighting interactions.

In this chapter we will explore the Material room’s basic building 
blocks. For a more detailed look at working with shaders 
and nodes in the Material room, please refer to “Chapter 15: 
Working with Nodes” on page 315 and “Chapter 16: Material 
Room Nodes” on page 325.

Access the Material room by clicking the Material room tab at 
the top of the Poser workspace. The Material room appears as 
follows.

 The Material Room.

The number of palettes and options that you see 
in each room depends upon your screen 

resolution. At higher resolutions, the default work 
spaces display more palettes, while at lower resolutions 
you see fewer palettes:

The Material room offers two options for working with surface 
materials: the Simple and Advanced view tabs. By default, 
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the Simple view of the Material Room is displayed when you 
first start up Poser. This allows new users to get familiar with 
editing Materials before diving into the Advanced settings of the 
Material Room. The Simple tab is actually a less complex front-
end for the Advanced tab, and allows users to apply and modify 
materials by means of a few basic controls. For more advanced 
users, the Advanced tab offers a powerful tool for defining 
material properties using shaders and nodes.

Poser’s Material room contains the following items at 1280 x 
960 resolution. Less items will appear at lower resolutions, and 
more options will appear at higher resolutions.

• Eyedropper Tool (1): The Eyedropper tool appears with 
the Editing tools. Enabling it and clicking an object in 
your scene opens that object’s shader tree for editing in the 
Shader window.

• Document Window (2): Please refer to “Chapter 5: The 
Document Window” on page 72 for information about 
the Document window.

• Light Controls (3): Please refer to “Chapter 12: Lighting” 
on page 261 for information about the Light controls.

• Object List (4): The Object List functions similarly to the 
Current Actor menu and has the following options: Props 
(includes strand-based hair and dynamic cloth), Lights, 
Figures, and Background.

• Current Material List (5): The Current Materials list 
displays all of the material groups in the currently selected 
figure/prop. Poser organizes materials by figure/prop, 
thereby avoiding confusion when assigning materials and 
allowing you to, for example, assign different eye or skin 
colors to each figure. This method of handling materials is 
referred to as multi/sub-object materials and is discussed 
in more detail in “Chapter 13: The Basics of Materials” on 
page 281.

• Material Room Help (6): The (?) icon at the top right of the 
Shader window opens the Material room Help document. 
This HTML document contains information about using 
nodes and shaders to define surface material attributes.

• Options pop-up menu (7): The Options pop-up menu is 
available from the Advanced tab of the Shader window, 
allows you to add, cut, copy, paste, select, and deselect 
nodes. For convenience, this can be also accessed by right-
clicking within the Advanced tab.

• Shader Window (8): The Shader window contains two 
tabs, for Simple or Advanced Material definition techniques. 
The Simple tab allows you to easily modify various 
attributes of your selected material, including Diffuse Color, 
Highlight, Ambient, Reflection, Bump and Transparency. 
The Advanced tab is where you build shaders, which 
consist of a root node and as many connected nodes as 
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you want. Nodes can modify other nodes or the root node. 
Please refer to “Chapter 15: Working with Nodes” on page 
315 and “Chapter 16: Material Room Nodes” on page 
325 for more information about working with shaders and 
nodes.

• Wacro Drawer (9): The Wacro Drawer allows you to select 
from ten predefined shortcuts that cover various material 
setup tasks. For more information about the Wacro Drawer, 
please refer to the description of the Advanced Shader 
View later in this chapter.

• Parameters/Properties Palette (10): Please refer to 
“The Parameters/Properties Palette” on page 192 for 
information about the Parameters/Properties palette.

• Animation Controls (11): Please refer to “Using the 
Animation Controls” on page 450 for information about 
the Animation controls.

• Document Display Styles (12): Allows you to select one 
of several different display styles for the elements in your 
scene. See “Chapter 6: The Display Controls and Menu” on 
page 105 for more information about the various display 
styles.

• Pose, UI and Camera Dots (13): Allows you to store figure 
poses, user interface settings, and camera settings for 

retrieval at any time until you close your Poser document. 
See “Memory Dots” on page 56.

Navigating the Shader Window
The question mark at the top right corner of the Shader window 
opens the Material Room Workflow help page. This document 
provides information on creating and connecting shader nodes, 
frequently used nodes, and advanced material attributes.

Simple Shader View
The Simple tab of the Shader window provides you with easy 
to use controls for adjusting various material attributes. Each of 
these attributes, and how they can be modified, are discussed in 
detail below.
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 Elements of the Simple material view.

For all attributes in the Simple tab, clicking in the Texture 
Preview Slot will bring up the Texture Manager dialog. Here 
you can preview and select a previously used image map from 
the pop-up list, or browse for a new map.

 The Texture Manager.

Note that when accessing the Texture Manager from the Simple 
tab, you have the ability to select both images and movies. In 
the Advanced tab, the image and movie nodes are separate, 
so the Texture Manager enables you to select one or the other 
depending on which node you are using. Click the OK button 
to load the image map. A preview of your selected map should 
appear in the appropriate texture preview slot of the Simple tab.

When you select an image from the Texture Manager, you can 
also select one of two options for Gamma correction:

• Use Gamma value from Render Settings: This is the 
default option. By default, the texture map will use the 
global gamma correction settings as defined in the Render 
Settings dialog.
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• Custom Gamma Value: Choose this option if you want 
to override the global gamma correction settings for this 
texture. Then enter the gamma correction setting in the 
Custom Gamma Value field.

The Map Strength dial adjusts the degree to which that image 
map affects the surface material. Note that the Map Strength 
dial directly controls the texture strength parameter on the 
image map nodes, which can be seen on the Advanced tab. 
For more information about using and creating various types of 
image maps, please refer to “About Maps & Templates” on page 
283.

The image map pop-up list in the Texture Manager provides a 
historical list of path names for previously used image maps and 
movies. This list facilitates quick image selection; it does not 
indicate that these files are currently loaded into memory.

A Caution symbol (exclamation point in a triangle) will appear 
at any point when the surface attributes you are working with 
are too complex to be edited in the Simple tab. For example, this 
would be the case if a procedural shader node were attached to 
the diffuse color input. Whenever the Caution symbol appears, 
it is an indication that you need to use the Advanced tab for 
full access to this attribute’s configuration parameters. Click the 
Caution symbol to switch to the Advanced tab.

 Caution symbols appear when advanced settings are applied.

Diffuse Color

The Diffuse color is the primary surface color of the current 
figure or prop. If there is no texture map applied to the figure, 
the Diffuse color will be the figure’s only color (not considering 
the effect of any colored lights). In a high quality rendering, 
when a texture map is loaded the Diffuse color tints the texture 
map. If you don’t want the texture map to be affected by the 
Diffuse color, leave the Diffuse color set to white (the default 
color).
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 A diffuse color map applied to a material.

To change the Diffuse color, click on the Color Slot at the top of 
the Diffuse component area. This will bring up the Poser Color 
Picker, where you can select your desired color. If you wish to 
access the system Color Picker, simply click on the RGB bar at 
the top right corner of the Poser Color Picker.

 The color picker.

If you choose to have highlights on a textured surface, you 
might want to consider using the same map for Highlights as 
for Diffuse. When you have a texture map applied to the Diffuse 
component, pressing the Apply texture to highlight button will 
also apply the same texture map to the Highlight component. If 
you have a different texture map already loaded for the Highlight 
component, checking this box will override it and apply the 
texture map from the Diffuse component.

Highlights

The Highlight component corresponds to the Specular root 
nodes on the Advanced tab, and controls the object’s highlight. 
Highlights are bright areas appearing where the light is reflected 
directly toward the camera. You can select a highlight color, 
apply a texture map, and adjust the texture map strength, 
as described above. In daylight and under most room lights, 
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highlights are white. To complement the lighting environment 
you’ve set, select a color similar to your main light.

 Highlight settings.

The Highlight Size dial allows you to determine the size and 
intensity of your material’s specular highlights. Smooth surfaces 
have sharper specular highlights, whereas rougher materials 
should have softer highlights. On the dial, higher values result in 
larger, softer highlights for a duller, more matte effect, and lower 
values result in smaller, sharper highlights for a shiny, more 
polished effect.

Ambient

In Poser, you can set the Ambient color for each figure or object 
individually. An object’s Ambient color is the color it emits 
equally in all directions. It simulates an ambient (overall room) 
lighting contribution. Unlike the other color properties, it acts 
without taking into account any light positions or colors. In 
other words, even if all other lights are turned off, the material 
will continue to emit the Ambient color. Thus, using an Ambient 
color on a surface can reduce the effect of shadows on that 
surface.

 Ambient settings.
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The Ambient color mixes with the other lighting properties. Too 
much ambience flattens the detail of an object, because it looks 
the same regardless of how the surface interacts with lights in 
the scene. If you want to turn ambient light down or off, set 
the Ambient color to gray or black. If you want more intense 
ambient light, set the Ambient color to white or a bright color. 
Loading an image map into the Ambient component will cause 
that image to function in the same way as an Ambient color. 
The Ambient color selection, texture map selection, and Map 
Strength control all function as described above.

Reflection

Reflection makes a figure or object direct light back at its source, 
giving it a reflective appearance. Poser offers two methods for 
applying Reflection to your scene. The first is to use a Reflection 
map, which is a 2D texture applied to a virtual sphere that 
surrounds your Poser workspace. The texture is then reflected 
from the workspace and onto your object. This method is best 
for scenes requiring subtle reflections, as it renders much 
quicker than raytracing, but results in somewhat less accurate 
reflection calculations. The other method is to use Raytraced 
Reflection, which is calculated using the raytracing rendering 
technique. This method is ideal for scenes containing objects 
with highly reflective qualities, such as chrome or mirrors, as 
raytracing yields extremely accurate reflections. However, using 
this method will increase your render times.

 Reflection settings.

Reflective Color is a tint that is added only when a Reflection 
map is applied. Use the Reflection Color option to create 
dramatic effects in your renderings. To make a highly reflective 
object appear more vivid, use a variation of the object’s color. 
If the object’s color is particularly bright, you may want to use 
a darker tint of the same color. For an unusual tint, use a color 
that is distinctly different from the object’s color. The Map 
Strength dial adjusts the Texture Strength parameter on the 
Reflection map node on the Advanced tab, and determines to 
what degree the Reflection map will affect the material.
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The Multiply with Lights / Object color checkboxes directly 
control the Reflection Lite Mult and Reflection Kd Mult 
checkboxes on the Advanced tab. For more information about 
these options, see “Root Material (PoserSurface) Node” on page 
325.

Bump

A Bump map is a special image, wrapped around the object, 
that works with the scene lighting to give the appearance of 3D 
texture on an otherwise smooth object. Bump maps can be used 
on individual objects or parts of a figure to emulate any manner 
of textures, from wrinkles and pores in skin, to raised patterns in 
clothing or props, to cracks and bumps in stone.

 Bump settings.

You can load Bump maps using the texture preview slot and 
the Texture Manager, and adjust the Bump map strength with 
the Map Strength dial, as described above. The Amount dial 
specifies the amount of Bump, in units specified in the General 
Preferences dialog. Higher values yield more Bump effect, 
or rougher surfaces, while lower values yield less Bump and 
smoother surfaces. The Amount dial corresponds directly to the 
Bump attribute on the Advanced tab.
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Note that Bump maps simply disturb an object’s normals. Thus, 
if you apply a Bump map to a sphere, the surface will seem rough 
while the edges remain smooth. Poser’s Material room contains 
a Displacement channel, which allows you to use Bump maps to 
actually alter the geometry of the surface. For example, applying 
a Displacement map to a sphere would make the edges appear 
rough, as well as the surface. The Displacement checkbox 
in the Bump attribute enables the Displacement attribute 
on the Advanced tab, replacing the Bump effect with actual 
Displacement. With Displacement enabled, the Amount dial 
specifies the amount of Displacement rather than the amount of 
Bump.

The strength of bump and displacement maps is 
expressed in real world units (whichever unit is 

set under Edit >General Preferences). Please note that 
with the default unit of Feet very small values already 
yield a strong bump or displacement effect.

For more advanced users, adding a Normal Map 
can add yet more realistic surface details.

Transparency

Transparency allows light to pass through a figure or object, 
so you can see through it. The higher a transparency value, 

the more of the surrounding environment is visible through 
the object’s surface. If no light is reflected on an object, 100% 
Transparency and Edge settings make it invisible.

 Transparency settings.

When a Transparency map is applied to an object, its 
texture interferes with the transparency of the object. For 
example, a checkerboard map results in an object that is 
alternately transparent and solid. You can thus use textures as 
Transparency maps.
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The Transparency, Edge, and Falloff dials work together to 
determine how an object’s transparency behaves.

The Transparency dial affects the transparency of the part of 
the object facing the camera, particularly toward the center 
of the object. Higher Transparency values yield greater 
transparency.

The Edge dial affects the transparency of the object’s edges 
specifically. A high Edge value makes the object very transparent 
on its edges. For most renderings, you’ll want to use a 
Transparency value that is higher than the Edge value.

The Falloff dial determines the rate at which the transparency 
becomes more opaque as you approach the edges of an object. 
For a real world example, look at a transparent object such as a 
drinking glass. The edges of the glass are less transparent than 
the rest of the surface. This is where the transparency of the glass 
“falls off”. In Poser, you can vary this falloff behavior. A smaller 
value renders a sharper edge appearance, while a larger value 
renders a more gradual falloff. If the Transparency and Edge 
values are the same, there is no falloff in the rendering.

Normal and Gradient Bump Maps

A normal map is an image, wrapped around the object that 
works with the scene lighting to give the appearance of 3D 
texture on an otherwise smooth object. Normal maps can be 
used on individual objects or parts of a figure to emulate any 

manner of textures, from wrinkles and pores in skin, to raised 
patterns in clothing or props, to cracks and bumps in stone.

Note that normal maps simply replace an object’s normals. Thus, 
if you apply a normal map to a sphere, the surface will seem 
rough while the edges remain smooth. Poser’s Material room 
contains a Displacement channel, which allows you to use 
displacement maps to actually alter the geometry of the surface. 
For example, applying a displacement map to a sphere would 
make the edges appear rough, as well as the surface.

To load a Normal Map, from the Material Room > Material 
Palette, Advanced tab, connect the Image Node containing 
a normal map to the Gradient Bump channel on the Poser 
Surface Node. The channel value controls how much influence 
the normal map has on the surface. Higher values yield more 
effect, or rougher surfaces, while lower values yield less effect 
and smoother surfaces.

You can use Gamma Correction to adjust the 
amount of surface influence from the texture. For 

more information about assigning gamma correction to 
an image source, see “Gamma Correction Per Texture” 
on page 433.

Next, select the type of normal map from the Gradient_Mode 
pull-down menu according to how the normal map was exported 
from the application it was created in. Select from the following 
options.
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• Normal Map (Tangent space): Tangent space normal maps 
have a mostly blue appearance. The normals in a tangent 
space map are always considered “up” even if it is not true 
in world space.

• Normal Map (Object space): Object space normal maps 
are rainbow-colored in appearance. The normals are 
pointing in their actual directions.

• Gradient Bump—Legacy option for Poser gradient bump 
maps.

Poser 4 and previous versions used our 
proprietary gradient (.BUM) file format for 

mapping bumps. Poser Pro now supports .BUM file 
usage as follows: First, in the Material room, create an 
IMAGE MAP node and load your .BUM file into that 
node. Then, connect the image map node with the BUM 
file to the root node’s GRADIENT BUMP attribute.

 Gradient bump maps.

 An object without, and with, a normal map applied.
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Advanced Shader View

The Advanced tab of the Shader window is where you build 
shaders by working with nodes. Please refer to “Chapter 15: 
Working with Nodes” on page 315 and “Chapter 16: Material 
Room Nodes” on page 325 for more information about shader 
nodes and how they function within Poser.

 The Advanced shader view.

The Shader window’s Advanced tab contains the following 
elements:
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• Object menu (1): The Object menu functions similarly 
to the Current Actor menu and has the following options: 
Props (includes strand-based hair and dynamic cloth), 
Lights, Figures, and Background.

• Material menu (2): The Material pull-down menu lists all of 
the materials available for the currently selected actor. Poser 
uses Multi/Sub-object materials, which means you will only 
see the materials assigned to the currently selected figure/
prop in this menu. Please refer to “Chapter 13: The Basics 
of Materials” on page 281 for information about Multi/
Sub-object materials.

• Options Menu (3): Clicking the arrow on the right side of 
the Shader menu opens the Options menu for the Material 
room. You can also open this menu by right-clicking in any 
blank area within the Shader window or by clicking any 
node input (see “Chapter 15: Working with Nodes” on page 
315 and “Chapter 16: Material Room Nodes” on page 
325).

• Title Bar (4): You can reposition the Shader window using 
its title bar.

• Wacro Drawer (5): The Wacro Drawer allows you to select 
from ten predefined shortcuts that cover various material 
setup tasks. See the “Wacros” section below for specific 
information on these shortcuts.

• Root Node (6): The root node for the currently selected 
object or material group appears on the left side of the 
Shader window.

• Nodes (7): Additional nodes also appear in the Shader 
window.

Shaders
A shader is a combination of nodes working together to create 
the final desired color, pattern, and texture -- in short, the look 
for your 3D objects. Every shader consists of a root node with 
a different number of attributes depending on the type of root 
node (Background, Material/Hair, Light or Atmosphere) being 
used. Each of these attributes can have one or more linked nodes 
that dynamically controls that attribute’s value or color. You can 
either create materials from scratch or load a pre-made material. 
Saving a material saves that materials’ shader tree, and loading 
a material also loads its shader tree. Also, if you load a pre-
made material, you can modify it at will to create a whole new 
look. Please refer to “Root Nodes” on page 325 for a detailed 
description of the root nodes.
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 Using nodes to build a shader.

Wacros
Wacros are easy-to-use scripts designed to complete specific 
tasks within the Material room. The Wacro Drawer comes with 
ten predefined Wacros, each of which accomplishes a basic 
material setup task or process--often with the click of a single 
button. You can save time by using Wacros for some of the more 
common tasks you might wish to undertake in the Material 

room. Wacros all act upon the root node for the selected object 
or material. For more information on the various attributes on 
the root nodes, please see “Root Nodes” on page 325.

Poser also supports user defined Wacros, which you can write 
using Python scripting, and then place in the Runtime\Python\
poserScripts\Wacros\UserDefined folder within your Poser 
installation folder. Your Wacros will then appear in the User 
Defined pop-up menu. Please see “Part 8: PoserPython” on 
page 836 for more information about writing Python scripts 
for Poser.

 Material Wacros.
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The following Wacros are included with your Poser installation:

• Add Reflection: Before clicking the Add Reflection Wacro 
button, make sure you have selected a material to which you 
want to add reflective attributes. When you click the Add 
Reflection button, Poser will attach the following nodes:

 � A Reflect raytrace node will be attached to the input 
of the Reflection_Color attribute on the root Material 
node. The Reflect node specifies the reflection color 
when raytracing. See “Raytrace Nodes” on page 357 
for more information on the Reflect node’s attributes.

 � A BG Color node will be attached to the input of the 
Background attribute on the Reflect node.

• Add Refraction: Before clicking the Add Refraction 
Wacro button, select a material to which you want to add 
refraction. Refraction causes light to bend as it passes 
from one transparent medium (material) to another; the 
degree to which this occurs depends on the material’s 
refractive index. Note that refraction only affects 
transparent materials, so the material you select must be 
made transparent for refraction to be visible. Click the Add 
Refraction button. If you have selected a material that is 
opaque, a dialog will appear asking whether you wish to 
make the material transparent and add refraction. Click Yes 
on this dialog to proceed. Poser will then add the following 
nodes:

 � A Refract raytrace node will be attached to the input 
of the Refraction_Color attribute on the root Material 
node. The Refract node specifies the refraction color 
when raytracing. See “Raytrace Nodes” on page 357 
for more information on the Refract node’s attributes.

 � A BG Color node will be attached to the input of the 
Background attribute on the Refract node.

 � Set the Refraction_Value attribute on the root Material 
node to between zero and one, in order to see the 
refraction effect in your rendered image.

Refraction requires raytracing, so be sure to 
have raytracing selected when you render in 

order to see the refraction effect. We also recommend 
setting the number of raytrace bounces to at least two 
(or higher if you have reflective surfaces behind the 
transparent materials).

• Add Skin Subsurface Scattering: Clicking the Add 
Skin Subsurface Scattering Wacro button will apply a 
Subsurface Skin node to the selected material. The node 
will be attached to the Alternate Diffuse input of the root 
material node, and the Alternate Diffuse color will be set to 
white.
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• Set Up Shadow Catcher: Clicking the Set Up Shadow 
Catcher button will enable the ShadowCatchOnly option on 
the Poser Surface node of the selected material. This Wacro 
will turn the selected material into a shadow catcher, 
which means that it will become transparent except for 
areas that are shaded by another object, which will show 
only the shadow. One example of how you might use this 
Wacro is if you created a scene showing a figure on the 
stairs prop, and you wanted to hide the stairs in order to 
composite the figure onto a photograph of actual stairs. For 
more information about the ShadowCatchOnly attribute, 
and shadow catchers, see “Root Material (PoserSurface) 
Node” on page 325.

• Set Up Toon Render: The Set Up Toon Render Wacro 
will configure your material to appear cartoon-like when 
rendered. Clicking the button opens a dialog asking whether 
you want to have specular highlights on your toon surfaces. 
Click either No or Yes on this dialog to proceed. Poser will 
then attach the following nodes:

 � A Toon diffuse node will be attached to the input on the 
Alternate_Diffuse attribute of the root Material node. 
See “Toon” on page 346 for more information about 
the Toon node’s attributes.

 � Two additional links will be created from the output on 
the material’s Image_Map node, to the inputs on the 
LightColor and DarkColor attributes on the Toon node.

 � If you clicked Yes on the initial dialog, a Glossy specular 
node will be attached to the input on the Alternate_
Specular attribute of the root Material node. See 
“Glossy” on page 342 for more information on the 
Glossy node’s attributes.

• Create Atmosphere: In order to view the effects of the 
Create Atmosphere Wacro, you need to have something in 
the background of your scene, such as a background plane 
or additional figures or props. Then, select Atmosphere 
from the Object menu at the top of the Shader window. 
Clicking the Create Atmosphere button opens the Choose 
an Atmosphere dialog. Select the type of atmosphere you 
wish to create, from the following options: Fog, Smoke, 
SmokeyRoom, Depth_Cue. Then click OK. Poser will add 
the appropriate nodes to create the atmosphere you have 
selected. If you wish to know more about any of the specific 
nodes added, see “Chapter 16: Material Room Nodes” on 
page 325. Render your scene to view the atmosphere 
effects.

• Set Up Light Style: The Set Up Light Style Wacro allows 
you to specify the style of light you wish to apply to a 
particular light. First, select the light you wish to configure 
from the Object menu at the top of the Shader window. 
Then click the Set Up Light Style button. The Select a 
light style dialog will appear, asking you to select a light 
style from the following options: diffuse only, specular 
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only, white only. When you have made your selection, click 
OK. You will see a message confirming that the light(s) you 
had selected have been set to the light style you specified. 
Depending on the light style you selected, you will see the 
following effects:

 � If you selected diffuse only, the Diffuse attribute on the 
root Light node will be set to white, and the Specular 
attribute will be set to black.

 � If you selected specular only, the Specular attribute on 
the root Light node will be set to white, and the Diffuse 
attribute will be set to black.

 � If you selected white only, the Color, Diffuse and 
Specular attributes on the root Light node will all be set 
to white.

• Set Up Ambient Occlusion: Clicking the Set Up Ambient 
Occlusion button will create an Ambient_Occlusion 
raytrace node, the output of which is attached to the inputs 
of the Diffuse_Value and Specular_Value attributes on the 
root Material node. See “Ambient Occlusion” on page 358 
for more information on the Ambient_Occlusion node’s 
attributes.

• IBL (Image Based Lighting): The IBL Wacro can only act 
upon lights, so make sure you have selected a light from 
the Object menu at the top of the Shader window, before 

using this Wacro. Clicking the IBL button will open the 
Texture Manager, which asks you to select a texture for the 
Image_Map node.

• Poser allows you to connect shader trees of any level of 
complexity to your Image Based Light; the IBL Wacro, 
however, is set up to use a single light probe image as an 
image map. Light probes are panoramic images that can 
record light levels from a 360 degree perspective, and are 
typically created by taking a high-dynamic range image 
of a mirrored sphere. Once you have selected your light 
probe image in the Texture Manager, click OK. Poser will 
attach an Image_Map node using your light probe to the 
input of the Color attribute on the root Light node. For 
more information on the Image_Map node’s attributes, see 
“Image Map” on page 373. For information about Image 
Based Lighting and light probes, see “Diffuse Image Based 
Lights (IBL)” on page 263.

To maximize your Image Based Lighting effects, 
we recommend using Ambient Occlusion. See 

“Light Properties” on page 270 for information on 
activating Ambient Occlusion for the selected light.

• Remove Detached Nodes: Clicking the Remove 
Detached Nodes button will clear away any nodes on 
the currently selected material group whose outputs are 
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not attached to at least one other node. This Wacro is 
particularly useful for cleaning up complex shader trees, 
where the sheer number of nodes may make it difficult to 
see whether there are any detached nodes present in the 
Shader window.

If you press the Shift key while choosing Remove 
Detached Nodes, detached nodes will be 

removed from all sub-materials in the figure with a 
single click.

Even if one or more nodes are attached to inputs 
on a given node, if that node’s output is not 

attached to another node, it will be removed by the 
Remove Detached Nodes Wacro.
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Chapter 15: Working with 
Nodes

This chapter describes how to perform various operations 
with nodes in the Shader window of the Material room. For a 
description of the Material room itself, please refer to “Chapter 
14: The Material Room” on page 296.

About Nodes
A node is the basic building block used to construct simple or 
complex procedural shaders (also called shaders). All nodes have 
the following elements except where noted:

 Elements of a node.

• Output (1): After accepting and processing any inputs plus 
its own values, the end result is passed to the output for 
connection to another node’s input. Root nodes do not have 
this function.
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• Node Name (2): This is the name of the node. By default, a 
number will appear when you have two or more of the same 
node in your shader, for example Clouds_2, Clouds_3, and 
so forth. You can double-click the name of the node to enter 
a new name if desired.

• Show/Hide Values Button (3): Clicking the Values button 
toggles displaying the node values (6) on and off.

• Show/Hide Preview Button (4): Clicking the Preview 
button toggles displaying the node preview (9) on and off. 
Enabling previews gives you a great idea of how each step in 
your shader tree is contributing to the overall look, however 
this can increase required computing resources.

• Node Values (5): This area shows the values that you can 
specify for the particular node.

• Value Input (6): You can either input values directly in a 
node or connect one or more nodes to an input to modify 
the selected value.

• Animation Toggle (7): Clicking the Animation control 
toggles animation on and off for the selected value.

• Preview (8): This displays a preview of the node’s output.

If you are running OpenGL hardware 
acceleration, you may be able to view the results 

of your procedural shaders in the Document window’s 
Preview tab, to give you a better sense of how your 
rendered scene will appear. For more information 
previewing procedural shaders, please see “Preview 
Tab” on page 398.

The Material Room Options Menu
You can access the Options menu in one of four ways:

• Clicking the Options menu arrow at the top right corner of 
the Shader window.

• Clicking either mouse button on a node’s input. In this case, 
the Options menu will only have the New node option 
available and may (depending on the input) have quick 
access options for appropriate nodes to connect to the 
selected input.

• Clicking either mouse button on a node’s output.

• Right-clicking any blank area in the Shader window.

The Options menu, which varies depending on how it was 
accessed, has the following options:
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 Node options.

• New node: Selecting New node creates a new node. Please 
refer to the following section for more information about 
creating nodes.

• Cut: Selecting Cut places a copy of the selected node(s) into 
the Clipboard and deletes the originals from the Shader 
window along with any existing links between the cut nodes 
and others. This preserves any links that exist between the 
copied nodes.

• Copy: Use the Shift key to select multiple nodes and/or the 
full rote node to copy into the clipboard. Selecting Copy 
places a copy of the selected node(s) into the Clipboard 
without removing the originals from the Shader window 
without altering their relationships with other nodes. This 
preserves any links that exist between the copied nodes but 
does not copy links between the copied nodes and other 
nodes. In conjunction with the Paste command (see below), 
this is a great way to propagate your shader trees (or any 
portions you like) from shader to shader, thereby allowing 
you to save time by leveraging previous work.

• Paste: Selecting Paste places a copy of the node(s) stored 
in the Clipboard into the Shader window.

• Delete: Selecting Delete selected nodes deletes all 
selected node(s). Any links to or from deleted nodes are 
also lost, meaning you will need to reestablish broken 
connections. Please refer to “Linking Nodes” on page 321 
for information on linking/de-linking nodes.

• Apply to all: Selecting Apply to all... applies all selected 
nodes to all materials groups in the current object. This 
overrides existing connections in affected material groups 
but does not delete any nodes.

• Collapse to compound node: Combines the selected 
nodes into a compound node. For more information see 
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“Collapsing Existing Nodes into a Compound Node” on 
page 386.

• Expand compound node: Expands the selected compound 
node back into its individual node components. For more 
information, see “Expanding Compound Nodes” on page 
388.

• Select All: Selecting Select All selects all nodes in your 
shader, including the root node.

• Invert Selection: Selecting Invert Selection selects all 
unselected nodes and deselects all selected nodes. In 
essence, this function reverses your selection.

Material Room Node Connections
The Advanced view of the Material room uses a plug system 
to connect nodes together. Node inputs typically appear on 
the right side of a node’s palette, and the node output typically 
appears in the upper-left corner of the node palette.

 Node inputs and outputs.

You can link nodes to other nodes, thereby controlling one 
node’s input with another node’s output. This interaction 
between nodes is at the heart of the Material room’s 
functionality and provides nearly infinite flexibility. Node 
interaction works by plugging values or colors from one node 
into another. Although only one node’s output can be connected 
to another node’s input at the same time, there is no theoretical 
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limit to how deep these interactions can go. Available memory 
and CPU speed will play a role in setting practical limits.

 Several nodes can be chained together to create realistic materials.

Selecting Nodes

To select a node, simply click any blank area within the desired 
node. To select multiple nodes, press and hold Shift while 
making your selections.

Creating Nodes

Creating additional nodes is the first step to creating your own 
shader tree (remember that all shaders have at least a root 
node).

To create a node, use one of the following methods:

• To create a new node anywhere in the advanced Material 
view, right click in the material view and choose New Node 
> Category > Subcategory > Node. Then connect the new 
node to the locations you desire.

 Creating a new material node.
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• To create an instance of the node that is currently selected 
in the Shader window, open the Options menu in the upper 
right corner of the material room and select New Node > 
Category > Subcategory > Node. Connect the new node 
as desired.

 Node options menu.

• To create a new node that is automatically connected to 
a node input, click the desired node input to display the 
Options menu. Alternatively, you can drag from a node’s 
input to an open area in the view will pop up the new node 

menu. Your new node will appear with its output already 
linked to your current node’s input. If you access the 
Options menu in any other manner (see above), the new 
node will not be linked.

Renaming Nodes

After you create a new node, you can double-click the name field 
to change the name of the node to something more descriptive. 
Press Enter/Return to apply the new name.

 Double-click a node name to rename it (top); After renaming 
(bottom).
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Linking Nodes

After creating a node, you may need to link it to an input on 
another node. This is accomplished in one of three ways:

• Direct Link: Click the output of the node you wish to link 
and drag the cursor over the node or shader input you wish 
to link to. Release the mouse button to complete the link.

 Attaching a new node to the root node.

• Moving Existing Links: To move a link from one node to 
another, click the input you want to unlink and drag the 

cursor off the node. Place the cursor over the input node you 
wish to link and release the mouse button.

 Relinking nodes.

• Clicking and dragging: Click the input you wish to connect 
a new node to and drag. A node connection will appear. 
When you release the mouse button, the Options menu will 
appear, allowing you to create a new node whose output is 
pre-connected to your selected input.
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 Adding a new node to a root node input.

You can link a node to as many other nodes as you wish and each 
node input can be linked to as many input nodes as you wish.

De-Linking Nodes

To break the link between two nodes, click the input you want to 
unlink and select Disconnect in the Options menu.

Expanding/Collapsing Nodes

You can expand and collapse a node’s values and/or preview 
separately, as described in the previous section.

Moving Nodes

You can move and arrange nodes to suit your particular work 
style. A node’s position has no effect on the shader’s function or 
appearance. To move a node or nodes:

1. Select the node(s) you want to move as described above.

2. Hold the mouse button down and drag the node(s) to the 
desired position. Release the mouse button to complete the 
move.

Entering Node Values

To enter a value for a node, click the desired value to open a 
small window with a value field and a parameter dial. Here, 
you can enter a numeric value in the field and/or move the 
parameter dial using the mouse. You can also link one or more 
nodes to the desired value (see below), which will make the 
appropriate adjustments.
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 Manually entering node values.

Some node values are pull-down menus. Use these as you would 
any other pull-down menu.

 Node options can be displayed in a pull-down menu.

Also, clicking a color within a node opens a standard Color 
Picker, which you can use to quickly select your desired color.

 Colors are selected through the Color Picker.

Deleting Nodes

To delete a node, select the node you wish to delete and either 
press [DEL] or select Node > Delete.

Animating Nodes

You can animate node attributes by clicking the Animation 
Toggle (key icon) for the attribute you wish to animate. When 
animation is enabled, the icon appears green. When disabled, it 
appears clear. Clicking the Animation Toggle opens a pull-down 
menu with the following options:
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 Turn the Animation Toggle on (green) to animate a material.

• Animated: Selecting the Animation option toggles 
animation for the current attribute on or off. A check mark 
appears next to this menu item when animation is enabled, 
and vice-versa.

• Info: Each animated attribute has one or more Info options 
depending on the attribute. For example, a numerical node 
will have one Info option for its numeric value, while a 
color node will have three Info options (one each for red, 

green, and blue). Selecting one of these options allows you 
to set the current value, maximum and minimum limits, 
name, and sensitivity. This dialog is exactly the same as the 
Edit Parameter Dial dialog, which is discussed in “Editing 
Parameter Dials” on page 201.

• Graph: For each Info option that appears above, you will 
see a Graph option. Selecting a Graph option opens the 
Graph palette for the selected channel. Please refer to 
“Using Graphs” on page 458 for more information about 
the Graph palette.

Once animation is enabled, you can animate the attribute’s value 
using any combination of the following methods:

• Keyframes: Move to a frame and set a value, then move to a 
different frame and set a new value.

• Graph Palette: Use the Graph palette to animate the node.

• Other nodes: Connect other nodes to control how the 
attribute changes over time.

Please refer to “Chapter 22: Animating with Poser” on page 
447 for more information about animating within Poser.
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Chapter 16: Material 
Room Nodes

Poser includes the following nodes, which, combined and 
linked to root nodes, can create virtually any shader you can 
imagine. Nodes are divided into several groups: Math, Lighting, 
Variables, 3D Textures, and 2D Textures. Each group and its 
shaders is discussed in the following sections:

Root Nodes
As previously mentioned, all shaders include a root node, which 
can be modified using added nodes that modify the root node. 
Thus, the root node is itself a complete shader. The Material 
room has four root nodes: Material, Background, Light, and 
Atmosphere. Let’s examine these nodes further.

Root Node Help

Some node attributes have a question mark (?) icon next to 
them. Clicking this icon opens help for that channel. This help 
is also available by navigating the Material room help window 
(available by clicking on the (?) icon at the top right of the 

Shader window, or by selecting Window > Room Help if the 
help pages are not already displayed in the Material room).

Root Material (PoserSurface) Node

The root Material node and root Hair nodes contain all of the 
attributes required to create a complete shader for almost every 
material group in your scene (figures, props, hair). They both 
have the following attributes:
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 Poser Surface Node.

• Diffuse Color: The Diffuse_Color attribute is the surface 
color that is multiplied through any light striking the object.

• Diffuse Value: The Diffuse_Value attribute defines the 
strength of the diffuse color, where 1=100%.

• Specular Color: The Specular_Color attribute defines the 
color of the object’s highlight.

• Specular Value: The Specular_Value attribute defines the 
strength of the specular color, where 1=100%.

• Highlight Size: The Highlight_Size attribute defines the 
quantity of micro-facets on the object surface. Micro-facets 
are tiny imperfections that are invisible to the human eye, 
yet effect the way light is reflected off the surface. Very 
smooth surfaces (such as glass) have very few imperfections 
and produce a very sharp specular highlight. Surfaces such 
as paper have extremely high numbers of imperfections in 
their surface and thus produce subtler specular highlights.

• Ambient Color: The Ambient_Color attribute defines 
the color that a surface has when it receives no light. This 
can be used to simulate overall ambient light or to create 
self-illuminating surfaces. Note that the ambient color of a 
surface will also bounce off other surfaces when rendering 
with indirect light enabled.
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• Ambient Value: The Ambient_Value attribute defines the 
strength of the ambient color, where 1=100%.

• Transparency: The Transparency attribute defines the 
object’s opacity, where 1=fully transparent.

• Transparency Edge: The Transparency_Edge attribute 
defines the object’s transparency at its edges. For example, a 
glass appears opaque at its edges.

• Transparency Falloff: The Transparency_Falloff attribute 
defines how the transparency changes as it moves towards 
the object edge. Smaller values create a sharper edge and 
vice versa.

• Translucence Color: The Translucence_Color attribute is 
the color of light passing through the object.

• Translucence Value: The Translucence_Value attribute 
defines the strength of the translucent color, where 1=100%.

• Reflection Color: The Reflection_Color attribute allows 
you to specify a reflective color. This is a good input for 
connecting other nodes to control reflections.

• Reflection Value: The Reflection_Value attribute defines 
the strength of the reflective color, where 1=100%.

• Refraction Color: The Refraction_Color attribute defines 
the color of light refracted by the current object.

• Refraction Value: The Refraction_Value attribute defines 
the strength of the refraction color, where 1=100%.

• Bump: The Bump attribute defines the amount of bump 
in the material. See “Bump Maps” on page 285 for 
information about bump.

• Displacement: The Displacement attribute defines the 
amount of displacement in the material. See “Displacement 
Map” on page 287 for information about displacement.

• Alternate Diffuse: The AlternateDiffuse attribute provides 
an alternate input for diffuse lighting. Use this channel 
for strand-based hair and anytime you wish to use custom 
diffuse lighting.

• Alternate Specular: The AlternateSpecular attribute 
provides an alternate input for specular lighting. Use this 
channel for strand-based hair and anytime you wish to use 
custom specular lighting.

• Reflection Lite Mult: Checking the ReflectionLiteMult 
checkbox multiplies the total color through the amount 
of diffuse lighting hitting each point on the surface. This 
automatically darkens reflections in areas not seen by lights. 
On by default.
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• Reflection Kd Mult: Checking the ReflectionKdMult 
checkbox automatically tints the reflection color by the 
surface’s diffuse color value. Off by default.

• Gradient Bump: Previous versions of Poser used a 
proprietary file format for bump maps (*.BUM). If you want 
to use these older file types in Poser, connect an image map 
node to the Gradient_Bump attribute and load your desired 
*.BUM file into that node (see “Image Map” on page 373 
for information on loading images). You cannot use *.BUM 
files with the FireFly renderer. The Gradient Mode option 
also allows you to select one of two types of normal maps.

• Gradient Mode:

 � Gradient Bump: Choose this option to use with a 
grayscale bump map image.

 � Normal Map (Tangent space): Tangent space normal 
maps have a mostly blue appearance. The normals in a 
tangent space map are always considered “up” even if it 
is not true in world space.

 � Normal Map (Object space): Object space normal 
maps are rainbow-colored in appearance. The normals 
are pointing in their actual directions.

For more information about normal maps, see 
“Normal and Gradient Bump Maps” on page 

306.

• ShadowCatchOnly: Checking the ShadowCatchOnly 
checkbox allows transparent surfaces to catch shadows, 
as opposed to letting the shadows appear on the opaque 
surface behind them. In other words, this option will treat 
transparent surfaces as opaque, only in terms of their 
interaction with shadows. A prime use of this feature would 
be if you wish to render only a figure and its shadow; you 
could set up the floor as a transparent surface by using the 
ShadowCatchOnly feature to show your figure’s shadow on 
the transparent floor, and render (without the background). 
The floor will be invisible except for the shadow laying on it, 
so the only things in your rendered scene will be the figure 
and its shadow.

• ToonID: By default, selecting the Toon Outline option 
causes an outline to appear around each separate material 
on the figure or object. Depending on how the figure is 
setup, this may lead to too many outlines. In such a case, 
you can adjust the Toon ID assignment on the root node 
of the material, to reduce the number of outlines drawn. 
Assigning the same ID to multiple materials means that the 
render engine will not draw separating outlines between 
those materials.

• Normals_Forward: Checking the Normals_Forward 
checkbox will flip the surface normal to point towards the 
camera (or towards the ray in case of raytracing). Light 
for indirect lighting (IDL) is also cast in the direction of 



Poser Pro 2014
Reference Manual

329

Chapter 16: Material Room Nodes

the normals. Use this option to avoid shading artifacts on 
double-sided polygons.

• Custom Outputs: Use the Custom_Output_1, Custom_
Output_2 and Custom_Output_3 connectors to define 
material properties that you want to output to Photoshop 
layers. If there is no connection to these inputs in the 
Poser Surface node, the output to a layered PSD file will be 
Diffuse only, Specular only, and Shadow only, respectively 
for Custom Output 1, 2, and 3. For more information, see 
“Rendering Layered PSD Files” on page 434.

You must have a hair object selected in order to 
see its root node.

Root Background Node

The root Background node contains all of the attributes 
required to create a complete shader for your scene’s 
background and has the following attributes:

 Root Background Node.

• Color: The Color attribute allows you to choose the 
background’s base color.

• Diffuse Color: The Diffuse_Color attribute is the surface 
color that is multiplied through any light striking the object.

• Specular Color: The Specular_Color attribute defines the 
color of the object’s highlight.

• Highlight Size: The Highlight_Size attribute defines the 
size of the highlight.

• Bump: The Bump attribute defines the amount of bump in 
the material.
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The final render will always display whatever is 
attached to the Color channel of the Root 

Background node. However, if you wish the same image 
or color to appear in the preview render, you must also 
attach it to the BG Picture or BG Movie node.

Root Light Node

A root Light node appears whenever you have a light selected. 
Each light in your scene has its own root Light node, which has 
the following attributes:

 Root Light Node.

• Color: The Color attribute allows you to choose the light’s 
base color.

• Intensity: The Intensity attribute defines the light’s 
brightness.

• Angle Start: The AngleStart attribute defines the start of 
the light cone (in degrees) for spotlights.

• Angle End: The AngleEnd attribute defines the end of the 
light cone (in degrees) for spotlights.

• Angle Expo: The AngleExpo attribute controls how the 
light fades towards the edge of the light cone (falloff).

• Diffuse: The Diffuse attribute allows you to create lights 
that use only a diffuse component to light the scene.

• Specular: The Specular attribute allows you to create lights 
that use only a specular component to light the scene. You 
can create specular only lights by setting the color in the 
specular channel to black. You can also create a negative 
light source (a light source that darkens or negates certain 
colors in the areas of the scene lit by this light) by setting 
the Specular value to zero (i.e., black) and setting the light’s 
Intensity to -1. Then the Color and Diffuse channels can be 
adjusted to reduce certain aspects of light.
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• Image Resolution: The Image Resolution attribute 
specifies the width and height of the light probe to be 
sampled. You can attach a light probe of any size, and then 
adjust the resolution to suit your needs. Note that higher 
resolutions require more processing time, whereas with 
extremely low resolutions you will lose image quality. 256 is 
a reasonable default resolution for most light probe images.

• IBL Contrast: The IBL Contrast attribute allows you to 
modify the level of contrast in the incoming light probe 
image. The default value of 3 for this attribute is intended 
for use with Low Dynamic Range (LDR) images. For High 
Dynamic Range (HDR) images, the best IBL Contrast 
setting would be 1.

You must have a light selected in order to see its 
root node.

Root Atmosphere Node

The Root Atmosphere node contains all of the attributes 
required to create realistic atmospheric effects such as fog, haze, 
etc. in your scenes.

 Root Atmosphere Node.

• DepthCue_On: Checking the DepthCue_On checkbox 
enables depth cueing, which varies all surface material 
colors from their original lit colors to the specified depth cue 
color (see below). This gives an effect similar to enabling the 
Depth Cueing option in the Document window as described 
in “Depth Cueing” on page 94.

• Volume_On: Checking the Volume_On checkbox enables 
volumetric effects. You can enable depth cueing and/or 
volumetric effects individually.

• DepthCue_Color: The DepthCue_Color attribute specifies 
the color to use when applying the depth cueing.
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• DepthCue_StartDist: The DepthCue_StartDist attribute 
specifies the distance from the current camera at which the 
depth cueing effect begins. This distance is not necessarily 
displayed in Poser distance units.

• DepthCue_EndDist: The DepthCue_EndDist attribute 
specifies the distance from the current camera at which the 
depth cueing effect ends. This distance is not necessarily 
displayed in Poser distance units.

• Volume_Color: The Volume_Color attribute specifies the 
color of the volumetric effect. This color is multiplied with 
the color of the lights in your scene. To use the lights’ colors 
for the volume, set this color to white.

• Volume_Density: The Volume_Density attribute controls 
the strength of the volumetric effect. This effect is multiplied 
by each light’s Atmosphere Strength attribute. If this 
attribute is set to 1.0, the selected light will cast atmospheric 
effects equal to this attribute and so forth. Please refer to 
“Light Properties” on page 270.

• Volume_StepSize: The Volume_StepSize attribute 
specifies the distance between rendering samples taken 
through the volume. Lowering this value increases the 
quality and requires increased render time.

• Volume_Noise: The Volume_Noise attribute adds a 
random factor added to the sample that can help balance 
out the effect of larger step sizes (see previous attribute).

You can connect nodes to the color and density attributes for 
more complex effects.

 Without volumetric rendering (no fog) on left; With volumetric 
rendering (with fog) on right.
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Bright infinite lights can wash out volumetric 
effects unless you use a very low density. 

Volumetric effects are most successfully used with both 
spotlights and carefully controlled density numbers. 
Also, Volumetric lighting effects only appear over a 
rendered object. They do not appear over an empty 
background, even when a background shader is in 
place. You need at least one object in on screen in order 
for volumetric lighting effects to be visible.

Math Nodes
These are the math nodes included with Poser. You will find 
them in the New Node > Math submenu. Unless specified 
otherwise, the list of attributes for each node is listed from top 
to bottom.

Blender

The Blender node blends two colors using a value attribute as an 
alpha mask. It has the following attributes:

 Blender Node.

• Input 1: The Input_1 attribute defines the first blend color. 
Clicking this attribute opens the standard Color Picker.

• Input 2: The Input_2 attribute defines the second blend 
color. Clicking this attribute opens the standard Color 
Picker.
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• Blending: The Blending attribute is used to determine the 
amount of blending. Valid values are from 0 (Input 1 color 
only) to 1 (Input 2 color only).

Fresnel Blend

The Fresnel Blend node has the following attributes:

 Fresnel Blend Node.

• Outer Color: The Outer Color attribute defines the color of 
surfaces facing away from the camera. Clicking it opens the 
standard Color Picker.

• Inner Color: The Inner Color attribute defines the color of 
surfaces facing towards the camera. Clicking it opens the 
standard Color Picker.

• Index of Refraction: The index of refraction of the material. 
Light hitting the surface will be reflected or transmitted 
dependent on the incident angle based on the index of 
refraction.

Edge Blend

The Edge Blend node blends color nodes based on surface and 
camera angles. It has the following attributes:

 Edge Blend Node.

• Inner Color: The Inner Color attribute defines the color of 
surfaces facing towards the camera. Clicking it opens the 
standard Color Picker.

• Outer Color: The Outer Color attribute defines the color of 
surfaces facing away from the camera. Clicking it opens the 
standard Color Picker.

• Attenuation: The Attenuation attribute defines the power 
curve used for transitioning between the inner and outer 
colors.
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Component

The Component node is useful for extracting the red, green, 
or blue components from an input color. It has the following 
attributes:

 Component Node.

• Component: The Component attribute specifies the color 
to extract. 0=red, 1=green, and 2=blue.

• Color: The Color attribute provides an input for another 
node, whose output will be processed according to the 
Component attribute setting.

• Point: The Point attribute provides an input for a point 
node whose output will be processed according to the 
Component attribute setting.

Math Functions

The Math Functions node is useful for mathematically merging 
values, nodes, and other parameters and can be used to create 
patterns. It has the following attributes:

 Math Functions Node.

• Math Argument: This pull-down menu defines the math 
function to be used. Your options are:

 � Add: Selecting Add returns Value 1 plus Value 2.

 � Subtract: Selecting Subtract returns Value 1 minus 
Value 2.

 � Multiply: Selecting Multiply returns Value 1 times 
Value 2.

 � Divide: Selecting Divide returns Value 1 divided by 
Value 2.

 � Sine: Selecting Sin returns the sine of Value 1. Value 2 
is ignored.
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 � Cosine: Selecting Cos returns the cosine of Value 1. 
Value 2 is ignored.

 � Tangent: Selecting Tan returns the tangent of Value 1. 
Value 2 is ignored.

 � Square Root: Selecting Sqrt returns the square root of 
Value 1. Value 2 is ignored.

 � Power: Selecting Pow returns the Value 1 to the Value 
2 power (such as 33).

 � Exponential: Selecting Exp returns e to the exponent 
Value 1, Value 2 is ignored (such as eV1).

 � Logarithm: Selecting Log returns the natural log of 
Value 1, Value 2 is ignored.

 � Modulus: Selecting Mod returns the modulus 
(remainder) of Value 1 divided by Value 2.

 � Absolute: Selecting Abs returns the absolute value of 
Value 1. Value 2 is ignored.

 � Sign: Selecting Sign returns –1 if Value 1 is less than 
zero, and 1 if Value 1 is greater than or equal to zero. 
Value 2 is ignored.

 � Minimum: Selecting Min returns Value 1 if Value 1 is 
less than Value 2, otherwise Value 2 is returned.

 � Maximum: Selecting Max returns Value 1 if Value 1 is 
greater than Value 2, otherwise Value 2 is returned.

 � Clamp: Selecting Clamp returns Value 1 unless 
Value 1 is less than 0 or greater than 1. If Value 1<0, 
0 is returned. If Value 1 > 1, 1 is returned. Value 2 is 
ignored.

 � Ceiling: Selecting Ceil returns Value 1 rounded up to 
the next whole number. Value 2 is ignored.

 � Floor: Selecting Floor returns Value 1 rounded down 
to the last whole number. Value 2 is ignored.

 � Round: Selecting Round returns Value 1 rounded to 
the nearest whole number. Value 2 is ignored.

 � Step: Selecting Step returns 1 if Value 1 is less than 
Value 2, and 0 if Value 1 is greater than or equal to 
Value 2.

 � Smooth Step: Selecting Smoothstep returns Value 1 
bicubically smoothed. Value 2 is ignored.

 � Bias: Selecting Bias adjusts the bias of Value 1 by 
Value 2.

 � Gain: Selecting Gain adjusts the gain of Value 1 by 
Value 2.

• Value 1: The Value_1 value defines the first value in the 
math equation.
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• Value 2: The Value_2 value defines the second value in the 
math equation.

Color Math

The Color Math node performs the selected mathematical 
operation with two colors. It has the following attributes:

 Color Math node.

• Math Argument: Please refer to the previous node 
explanation, above, for a list of math arguments available in 
this pull-down menu.

• Value 1: The Value_1 attribute defines the first color value 
in the math equation.

• Value 2: The Value_2 attribute defines the second color 
value in the math equation.

User Defined

The User Defined node allows you to define a custom color. The 
Color Mode (bottom) attribute is a pull-down menu allowing 
you to specify your desired color model. You can choose RGB, 
HSV, or HSL modes and enter the appropriate attributes in the 
three fields above, as follows:

 User Defined node.

• Red: This attribute allows you to specify the first value: Red 
(RGB) or Hue (HSV or HSL).

• Green: This attribute allows you to specify the second value: 
Green (RGB) or Saturation (HSV or HSL).

• Blue: This attribute allows you to specify the third value: 
Blue (RGB) or Value (HSV) or Lightness (HSL).

• Color Mode: This attribute allows you to specify the color 
mode that applies to the Red, Green, and Blue setting. 
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Choices are RGB (Red, Green, Blue), HSV (Hue, Saturation, 
Value) or HSL (Hue, Saturation, Lightness.

Simple Color

The Simple Color node allows you to access a color picker to 
select a color. Clicking the color (Color attribute) opens the 
Poser Color Picker. To use your operating system’s Color Picker, 
press [OPT]/[ALT] while clicking the color or click the red-green-
blue button in the top right of the Poser Color Picker.

 Simple Color node.

Color Ramp

The Color Ramp node takes four colors and creates a spline 
color map (gradient) with them. You can feed grayscale output 
from other nodes (turbulence, wood, etc.) into this node to 
create interesting still or animated effects using the grayscale 
values as lookups into the color spline, providing a colorized 
version of the original grayscale image. It has the following 
attributes:

 Color Ramp node.

• Color 1 through Color 4: The Color_1 through Color_4 
attributes allow you to input colors for the color spline. 
Clicking them opens the standard Color Picker.

• Input: The Input attribute is the grayscale value to lookup 
into the color spline. This is where you should plug in your 
grayscale images.

HSV

The HSV node allows you to adjust the Hue, Saturation, and/or 
Value of the Color input.
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 HSV Node.

• Color: Allows you to specify the color source that you want 
to adjust.

• Hue: This attribute allows you to adjust the Hue of the Color 
input. A setting of 1 represents no adjustment. Increase or 
decrease the setting to offset the original hue.

• Saturation: This attribute allows you to adjust the 
Saturation of the Color input. A setting of 1 represents no 
adjustment. Increase or decrease the setting to offset the 
original saturation.

• Value: This attribute allows you to adjust the Value of 
the Color input. A setting of 1 represents no adjustment. 
Increase or decrease the setting to offset the original value.

Gamma

The Gamma node allows you to incorporate Gamma settings 
into the currently selected material. The Gamma node provides 
the following settings:

 Gamma Node.

• Color: Allows you to specify a solid color, or to input other 
nodes as a source of color.

• Inverse: Used as a shortcut that applies the specified 
gamma value in reverse. For example, if Gamma value is set 
to 2.2, checking the Inverse option will result in a Gamma 
setting of 1/2.2 (or .4545).

• Use Custom Gamma: Check this option to pass the custom 
gamma settings to the node that is connected to the output.

• Gamma: Sets the desired gamma value.
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Lighting Nodes

These are the light nodes included with the Material room. 
Unless specified otherwise, the list of attributes for each node is 
listed from top to bottom. The Light menu item has several sub-
menus, each containing one or more nodes.

Specular Nodes

Specular nodes provide different models for calculating 
highlights on objects.

Anisotropic

The Anisotropic node allows you to create irregularly shaped 
highlights. It has the following attributes:

 Anisotropic node.

• Specular Color: The Specular_Color is the color of any 
highlight that appears on the object surface. Highlights 
lend the illusion of shininess. For example, a piece of wood 
displays no highlight, while a piece of polished metal has 
one or more distinct highlights. This color is generally the 
same as that of the direct lighting falling on the affected 
surface but does not have to be.

• Specular Value: The Specular_Value is the amount of 
influence the specular color has on the shader. A higher 
value will create larger, more distinct highlights and vice 
versa.
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• U Highlight Size: The U_Highlight_Size attribute is the 
highlight’s size in the U direction.

• V Highlight Size: The V_Highlight_Size attribute is the 
highlight’s size in the V direction.

• Xdir_X: The Xdir_X attribute controls the size of the 
specular reflection relative to the X-axis.

• Xdir Y: The Xdir_Y attribute controls the size of the 
specular reflection relative to the Y-axis.

• Xdir_Z: The Xdir_Z attribute controls the size of the 
specular reflection relative to the Z-axis.

• Normals_Forward: Checking the Normals_Forward 
checkbox will flip the surface normal to point towards the 
camera (or towards the ray in case of raytracing). Use this 
option to avoid shading artifacts on double-sided polygons.

Phong

The Phong node defines a model for calculating highlights. It 
has the following attributes:

 Phong node.

• Specular Color: The Specular_Color is the color of any 
highlight that appears on the object surface. Highlights 
lend the illusion of shininess. For example, a piece of wood 
displays no highlight, while a piece of polished metal has 
one or more distinct highlights. This color is generally the 
same as that of the direct lighting falling on the affected 
surface but does not have to be.

• Specular Value: The Specular_Value is the amount of 
influence the specular color has on the shader. A higher 
value will create larger, more distinct highlights and vice 
versa.

• Size: The Size attribute specifies the size of the highlight.

• Normals_Forward: Checking the Normals_Forward 
checkbox will flip the surface normal to point towards the 
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camera (or towards the ray in case of raytracing). Use this 
option to avoid shading artifacts on double-sided polygons.

Glossy

The Glossy node defines a model for calculating highlights. It 
has the following attributes:

 Glossy node.

• Specular Color: The Specular_Color is the color of any 
highlight that appears on the object surface. Highlights 
lend the illusion of shininess. For example, a piece of wood 
displays no highlight, while a piece of polished metal has 
one or more distinct highlights. This color is generally the 
same as that of the direct lighting falling on the affected 
surface but does not have to be.

• Ks: The Ks attribute defines the strength of the specular 
color, where 1=100%.

• Roughness: The Roughness attribute defines the size of 
highlights.

• Sharpness: The Sharpness attribute defines the sharpness 
of the highlight’s edge.

• Normals_Forward: Checking the Normals_Forward 
checkbox will flip the surface normal to point towards the 
camera (or towards the ray in case of raytracing). Use this 
option to avoid shading artifacts on double-sided polygons.

Blinn

The Blinn node defines a model for calculating highlights. It has 
the following attributes:

 Blinn node.

• Specular Color: The Specular_Color is the color of any 
highlight that appears on the object surface. Highlights 
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lend the illusion of shininess. For example, a piece of wood 
displays no highlight, while a piece of polished metal has 
one or more distinct highlights. This color is generally the 
same as that of the direct lighting falling on the affected 
surface but does not have to be.

• Eccentricity: The Blinn formula models the microfacets 
(microscopic imperfections) of the surface as ellipsoids of 
revolution. The Eccentricity attribute controls the size and 
variation of the imperfections. Use 0 for very shiny surfaces 
and 1 for very diffuse surfaces.

• Specular Roll Off: The SpecularRollOff attribute controls 
the highlight’s sharpness.

• Reflectivity: The Reflectivity attribute controls the amount 
of light reflected back to the eye.

• Normals_Forward: Checking the Normals_Forward 
checkbox will flip the surface normal to point towards the 
camera (or towards the ray in case of raytracing). Use this 
option to avoid shading artifacts on double-sided polygons.

Specular

The Specular node defines a model for calculating highlights. It 
has the same attributes as the Phong node, which is discussed 
below.

 Specular node.

• Specular Color:: The Specular_Color is the color of any 
highlight that appears on the object surface. Highlights 
lend the illusion of shininess. For example, a piece of wood 
displays no highlight, while a piece of polished metal has 
one or more distinct highlights. This color is generally the 
same as that of the direct lighting falling on the affected 
surface but does not have to be.

• Specular Value: The Specular_Value is the amount of 
influence the specular color has on the shader. A higher 
value will create larger, more distinct highlights and vice 
versa.

• Roughness: The Roughness attribute defines the size of 
highlights.

• Normals_Forward: Checking the Normals_Forward 
checkbox will flip the surface normal to point towards the 



Poser Pro 2014
Reference Manual 

344

Chapter 16: Material Room Nodes

camera (or towards the ray in case of raytracing). Use this 
option to avoid shading artifacts on double-sided polygons.

ks Microfacet

The KS-Microfacet node is a node that is a physically-based 
specular node that uses specularity calculations similar to those 
used in the Subsurface Skin and Scatter nodes.

The settings are as follows:

 ks-Microfacet node.

• Roughness: The Roughness attribute defines the size of 
highlights. Lower values create smaller, sharper highlights. 
Higher values create larger, more diffused highlights.

• Ks: The Ks attribute controls the specular light strength, 
where 1=100%.

Diffuse Nodes

Clay

The Clay node applies a clay-like lighting model to the selected 
material. It has the following attributes:

 Clay node.

• Color: The Color attribute specifies the clay color. Clicking 
the color opens a Color Picker.

• Kd: The Kd attribute specifies the strength of the color, 
where 1=100%.

• Roughness: The Roughness attribute defines the size of 
highlights.

Diffuse

The Diffuse node allows you to use the standard diffuse lighting 
model. It has the following attributes:
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 Diffuse node.

• Diffuse_Color: The Diffuse_Color attribute specifies the 
diffuse color.

• Diffuse_Value: The Diffuse_Value attribute defines the 
strength of the diffuse color, where 1=100%.

• Normals_Forward: Checking the Normals_Forward 
checkbox will flip the surface normal to point towards the 
camera (or towards the ray in case of raytracing). Use this 
option to avoid shading artifacts on double-sided polygons.

ProbeLight

The ProbeLight node takes an irradiance environment map, 
which is a 360 degree light distribution contained within a single 
image map, and applies it to your material. It has the following 
attributes, as well as nine coefficients:

 Probe Light node.

• Exposure: The Exposure attribute specifies the brightness, 
or exposure level, of the irradiance map.

• Saturation: The Saturation attribute specifies the degree of 
color saturation within the irradiance map.

• SurfaceColor: The SurfaceColor attribute allows you 
to select a color tint by which the irradiance map will be 
multiplied. For more realistic results, you should multiply 
with white.
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If your intention is to create an image based 
light, you can do so by simply adding a diffuse 

image Based light to your scene in the lighting controls. 
See “Chapter 12: Lighting” on page 261 for more 
information about adding and configuring lights.

Toon

The Toon node gives your material a cartoon-like look. It has the 
following attributes:

 Toon node.

• Light Color: The LightColor attribute specifies the light 
color.

• Dark Color: The DarkColor attribute specifies the dark 
color.

• Ink Color: The InkColor attribute specifies the ink color.

• Spread: The Spread attribute defines the sharpness/
softness of edges between colors.

• Line Width: the LineWidth attribute specifies the width of 
the ink color.

• Normals_Forward: Checking the Normals_Forward 
checkbox will flip the surface normal to point towards the 
camera (or towards the ray in case of raytracing). Use this 
option to avoid shading artifacts on double-sided polygons.

Special Nodes

Skin

The Skin node allows you to create realistic skin. It has the 
following attributes:
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 Skin node.

• Skin Color: The SkinColor attribute selects the skin’s base 
color. Clicking this attribute opens a standard Color Picker.

• Sheen Color: The SheenColor attribute is the color of 
any highlight that appears on the object surface. Highlights 
lend the illusion of shininess. For example, a piece of wood 
displays no highlight, while a piece of polished metal has 
one or more distinct highlights. This color is generally the 
same as that of the direct lighting falling on the affected 
surface but does not have to be.

• Ka: The Ka attribute controls the ambient light strength, 
where 1=100%.

• Kd: The Kd attribute controls the diffuse light strength, 
where 1=100%.

• Ks: The Ks attribute controls the specular light strength, 
where 1=100%.

• Thickness: The Thickness attribute controls the thickness 
of the top, translucent skin layer.

• ETA: The ETA attribute controls the density of the top, 
translucent skin layer.

Subsurface Skin

The Subsurface Skin node offers more realistic skin effects 
than the Skin node. It adds subsurface scattering effects that 
give the skin more luminescence and sheen. This node has the 
following settings:

 Subsurface Skin node.
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• Color: Determines the base color for the material. The 
Subsurface Skin effect is added to this color. By default it 
is set to white. You can choose another color, or attach an 
image map or another node to the input.

• Texture Detail: Represents the ratio of the use of the 
texture for post-scatter versus pre-scatter. The range is from 
0-1.0. A value of 1 will apply 100% of texture at post-scatter, 
yielding more texture details. A value 0 uses none of texture 
at post-scatter, applying all of that texture for pre-scatter 
calculations, and yields very low texture detail. A value of .5 
is a reasonable point to start experimenting.

• Specularity: When set to 1, this setting approximates the 
physical specular behavior of human skin. Increase or 
decrease the setting for your desired effect.

• Highlight Size: Determines the size of the highlight, similar 
to the way that Highlight Size works in the Root node.

• MaxError: This setting is a quality-speed trade-off. When 
set to a low value, you will get higher precision in the 
subsurface scattering, but rendering will be more slow. 
When set to a higher value, you will get better rendering 
speeds, but less precision in the subsurface scattering.

To demonstrate the Subsurface Skin node we start with a 
simple scene: a figure and two directional lights with raytraced 
shadows. The head texture is very simple, just an image map 

plugged into the diffuse color and the specular color. Diffuse 
color is set to white, and specular color is set to black with a 
value of zero.

Render settings for the scene are also standard. However, 
in order to use the Subsurface Skin node, the Subsurface 
Scattering option must be turned on in the Render Settings 
dialog.

 Render settings dialog with Subsurface Scattering turned on.
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Go to the Material room and select the Head material. Right-
click in an empty area in the Advanced material view and choose 
New Node > Lighting > Special > Subsurface Skin.

Plug the output of the image map into the Color input of the new 
node. Then, plug the output of the new node into the Alternate 
Diffuse input of the PoserSurface root node. Finally, set the 
Diffuse Value setting in the root node to 0, so that Poser only 
uses the ALT Diffuse setting.

 Material Settings for the Subsurface Skin node.

When you render the new material, Poser will first render a 
pre-pass to calculate light all over the surface (including the back 
side). During the second pass, it calculates the scattering.

The following figure shows a comparison before and after 
subsurface scattering is added on a character.

Subsurface scattering only works on objects that 
are in direct view of the camera. Objects in 

reflected surfaces will not be calculated with proper 
Subsurface Scattering.

 A figure without subsurface skin (left); with subsurface skin (right).
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Velvet

The Velvet node allows you to create the appearance of realistic 
velvety fabric. It has the following attributes:

 Velvet node.

• Velvet Color: The Velvet_Color attribute selects the color. 
Clicking this attribute opens a standard Color Picker.

• Velvet Sheen: The Velvet_Sheen attribute is the color of 
any highlight that appears on the object surface. Highlights 
lend the illusion of shininess. For example, a piece of wood 
displays no highlight, while a piece of polished metal has 
one or more distinct highlights. This color is generally the 
same as that of the direct lighting falling on the affected 
surface but does not have to be.

• Ka: The Ka attribute controls the ambient light strength, 
where 1=100%.

• Kd: The Kd attribute controls the diffuse light strength, 
where 1=100%.

• Ks: The Ks attribute controls the specular light strength, 
where 1=100%.

• Roughness: The Roughness attribute controls the 
thickness of the velvet.

• Edginess: This attribute controls the horizon scatter of the 
velvet.

• Normals_Forward: Checking the Normals_Forward 
checkbox will flip the surface normal to point towards the 
camera (or towards the ray in case of raytracing). Use this 
option to avoid shading artifacts on double-sided polygons.

Hair

The Hair node allows you to color your characters’ or props’ hair. 
It has the following attributes:
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 Hair node.

• Root Color: The Root_Color attribute selects the color for 
the root of the hair. Clicking this attribute opens a standard 
Color Picker.

• Tip Color: The Tip_Color attribute selects the color for the 
tip of the hair. Clicking this attribute opens a standard Color 
Picker.

• Specular Color:: The Specular_Color attribute selects 
the hair’s highlight color. Clicking this attribute opens a 
standard Color Picker.

• Highlight Size: Allows you to determine the size and 
intensity of the highlights in the hair.

• Root Softness: The Root_Softness attribute controls the 
root’s transparency, which helps hair blend into the scalp.

To create realistic hair shaders, connect this 
node to the root node’s Alternate Diffuse 

attribute.

• Opaque in Shadow: Check this option to create solid 
shadows beneath hair strands. This allows you to create hair 
that looks more full without having to increase the number 
of hairs on the head (thereby requiring less computer 
resources).

Scatter

The Scatter node offers another way to render scattering effects 
in various objects, including skin. A number of presets that use 
real-world material properties are included in this node.

The Scatter node offers the following settings:
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 Scatter node.

• Material: The Material selector includes several presets that 
emulate the scatter effects of real-world materials.

 Material options.

• Use Material Color: Check this option if you want to use 
color from the Material property.

• Texture Detail: Represents the ratio of the use of the 
texture for post-scatter versus pre-scatter. The range is from 
0-1.0. A value of 1 will apply 100% of texture at post-scatter, 
yielding more texture details. A value 0 uses none of texture 
at post-scatter, applying all of that texture for pre-scatter 
calculations, and yields very low texture detail. A value of .5 
is a reasonable point to start experimenting.

• Scale: Each of the Scatter materials are based on physical 
measurements. The Scale setting decreases or increases the 
physical scale to adjust appropriately for your geometry in 
the event that it is smaller or larger than it would be in real 
life.

• MaxError: This setting is a quality-speed trade-off. When 
set to a low value, you will get higher precision in the 
subsurface scattering, but rendering will be more slow. 
When set to a higher value, you will get better rendering 
speeds, but less precision in the subsurface scattering.

• Color: Determines the base color for the material. The 
Scatter effect is added to this color. By default it is set to 
white. You can choose another color or add an image map or 
other node to the input.
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Use the same scene that you started with in “Subsurface Skin” 
on page 347. If you completed that exercise, disconnect the 
Subsurface Skin node from the Alternate Diffuse input of the 
PoserSurface node, and then right-click the Subsurface Skin 
node and choose Delete Node.

Next, right-click in an empty area in the Advanced Material 
view. Choose New Node > Lighting > Special > Scatter. A new 
scatter node is added to the Advanced material view. Plug the 
output into the Alternate Diffuse input of the PoserSurface 
node. Set the Diffuse Value in the PoserSurface node to 0 to 
turn the texture influence off.

You will notice when you render the Scatter node that the object 
takes on the color of the selected material. The color of the 
real-world materials is built in to the preset. In other words, if 
you choose the Apple material there will be a green tone to the 
Scatter effect. If you choose Skin1 or Skin2, the object will have 
natural skin tones, and so on. Examples of Apple and Skin 1 are 
shown in the following figure.

 Apple preset (left); Skin 1 preset (right).

Because colors are built into the Scatter presets, you will need 
to take that into account when you use skin textures that have 
built-in color (as most do.) There is a way that you can work 
around this.

• First, right-click in an empty area of the Advanced Material 
view and add a Color Math node (New Node > Math > 
Color_Math).

• Click the Value 2 color chip in the Color Math node, and 
then use the eyedropper to select the base skin color from 
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the Image Map texture preview. This is the color that will be 
removed after passing through the Color Math node.

 Select the base color for Value 2 from the image texture map.

• Set the Math Argument of the Color Math node to Divide.

• Connect the output from the Image Map node into the 
Value1 connector of the Color Math node. You can display 

the texture preview in the Color Math node to view the 
result. You should see a preview with the base flesh color 
removed, and leaving other areas such as brows, eye 
makeup, and shadows to pass through to the Scatter node.

• Connect the output of the Color Math node into the Color 
input of the Scatter node.

• Connect the output of the Scatter node into the Alternate 
Diffuse input of the PoserSurface node. When completed, 
it should look like the following figure:
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 Final Color Math connections.

Now when you render your head, you will see the scattering 
effects and skin tone from the Scatter node combined with the 
additional detail that was in the texture you used.

 Skin 1 Preset with added color from the Image Map and Color Math 
nodes.
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Custom Scatter

This node exposes subsurface scattering with the raw parameters 
available to the user, as opposed to the measured presets in the 
plain Scatter node.

 Custom Scatter node.

The Custom Scatter node has the following attributes:

• Surface Color: The overall color of the surface. Applied 
post-scattering, so textures applied to this input will remain 
sharp.

• Scatter Color: The color of the light that gets scattered in 
the material.

• Mean Free Path: The mean distance that light travels 
in the surface before it scatters. Larger values result in a 

more translucent effect. Note that regardless of the settings 
in the preferences, this parameter’s units are always in 
millimeters, due to the small size of typical values.

• IOR (Index of Refraction): The index of refraction of 
the material. Light hitting the surface will be reflected or 
transmitted dependent on the incident angle based on the 
index of refraction. Range is 0.0001 – 3.4.

• Pre-Scatter Texture: The incoming light on the surface will 
be modulated by this color before it scatters in the material.

• Pre-Scatter Ambient: The amount of self-illumination of 
the material. This is being applied before scattering, so the 
illumination generated here will be scattered around in the 
material.

• Max Error: Same parameter as in the other two subsurface 
scattering nodes, this one is a speed vs. quality trade-off 
parameter. Lower values equal a more precise calculation at 
the expense of render time, higher values render faster but 
may show artifacts. Range is 0.0 – 1.0.

FastScatter

The FastScatter node offers an easy application of subsurface 
scattering (SSS) effects. The results of the FastScatter 
calculation approximate true Subsurface Scattering.
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 Fast Scatter node.

Subsurface scattering simulates the interaction 
of light with translucent materials, whereby the 

light interacts to some degree with the material below 
the surface level. The FastScatter node is a legacy node 
that was introduced prior to the implementation of true 
Subsurface Scattering. This node should be phased out 
by content developers and replaced with one of the true 
Subsurface Scattering nodes: “Subsurface Skin” on page 
347 or “Scatter” on page 351.

Raytrace Nodes

To use the raytracing nodes, you must have raytracing enabled 
in the Render Settings dialog, as described in “Chapter 18: The 
Render Settings Dialog” on page 397.

Reflect

The Reflect node specifies the reflection color when raytracing. 
It has the following attributes:

 Reflect node.

• Background: The Background attribute selects the 
background color to be used for raytracing. Clicking this 
attribute opens a standard Color Picker.

• Quality: The Quality attribute controls how many rays 
are spawned by hitting a surface. Increasing this value 
increases the realism of reflections but consumes computing 
resources.

• Softness: The Softness attribute controls the randomness 
of the directions of reflected rays.

• RayBias: The RayBias attribute helps to prevent false 
shadows and other artifacts that may occur as a result 
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of using raytracing techniques in conjunction with 
displacement maps. RayBias offsets the starting point of 
the rays above the geometry of the surface, so as to avoid 
the displacement geometry in the raytracing calculation. Be 
aware that if your RayBias setting is too high, your shadows 
will migrate in the scene.

Refract

The Refract node specifies the refraction color when raytracing. 
It has the following attributes:

 Refract node.

• Background: The Background attribute selects the 
background color to be used for raytracing. Clicking this 
attribute opens a standard Color Picker.

• Index of Refraction: The Index of Refraction attribute 
controls how much light bends when passing through the 
object.

• Quality: The Quality attribute controls how many rays 
are spawned by hitting a surface. Increasing this value 
increases the realism of reflections but consumes computing 
resources.

• Softness: The Softness attribute controls how sharp or 
smooth refracted light appears after passing through an 
object.

• RayBias: The RayBias attribute helps to prevent false 
shadows and other artifacts that may occur as a result 
of using raytracing techniques in conjunction with 
displacement maps. RayBias offsets the starting point of 
the rays above the geometry of the surface, so as to avoid 
the displacement geometry in the raytracing calculation. Be 
aware that if your RayBias setting is too high, your shadows 
will migrate in the scene.

Ambient Occlusion

The Ambient Occlusion node uses raytracing to calculate the 
degree to which other objects within a scene mask (or occlude) 
the ambient light of a surface at a given point. Surfaces with 
greater occlusion ratios will be rendered as darker than surfaces 
with little or no occlusion. This node has the following attributes:
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 Ambient Occlusion node.

• Samples: The Samples attribute determines the number 
of rays projected. Too few samples will result in a grainy 
appearance in the darker areas of the scene. Higher sample 
rates yield higher quality darkened areas, but take longer to 
render.

• MaxDist: The MaxDist attribute allows you to control the 
maximum distance that the rays will travel through the 
scene, thus limiting the amount of data collected.

• RayBias: The RayBias attribute helps to prevent false 
shadows and other artifacts that may occur as a result 
of using raytracing techniques in conjunction with 
displacement maps. RayBias offsets the starting point of 
the rays above the geometry of the surface, so as to avoid 
the displacement geometry in the raytracing calculation. Be 

aware that if your RayBias setting is too high, your shadows 
will migrate in the scene.

• Strength: The Strength attribute controls the degree 
to which the Ambient Occlusion node will darken the 
occluded surfaces within the scene.

• Evaluate in IDL: Check this option if you want Poser to 
consider ambient occlusion settings during an indirect 
lighting pass.

•  Without Ambient Occlusion (left); With Ambient 
Occlusion/depth mapped shadows (right).

Gather

The Gather node uses raytracing to collect color and light 
information from the surfaces within a specific area, which when 
combined with an infinite light source adds a realistic “outdoor” 
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lighting effect. This effect also adds some color bleeding to the 
rendered scene. The Gather sampling area, or cone, is defined by 
the following attributes:

 Gather node.

• Samples: The Samples attribute determines the number 
of Gather rays projected. Higher sample rates yield more 
realistic results, but take longer to render.

• MaxDist: The MaxDist attribute allows you to control the 
maximum distance that the Gather rays will travel through 
the scene, thus limiting the amount of data collected.

• RayBias: The RayBias attribute helps to prevent false 
shadows and other artifacts that may occur as a result 
of using raytracing techniques in conjunction with 
displacement maps. RayBias offsets the starting point 
of the Gather rays above the geometry of the surface, so 
as to avoid the displacement geometry in the raytracing 

calculation. Be aware that if your RayBias setting is too 
high, your shadows will migrate in the scene.

• Angle: The Angle attribute sets the angle of the cone in 
which the Gather rays will be projected. A wider angle will 
result in a greater area and hence more data. More data will 
give you more realistic results, but longer render times.

 Without Gather/no color bleeding (left); With Gather/color 
bleeding (right).

Fresnel

The Fresnel node is used for surfaces that are both refractive 
and reflective (also known as dielectrics). Such surfaces tend 
to reflect more when the observer to surface angle is high, and 
refract more when the observer to surface angle is low. Most 
surfaces that are transparent (refractive) are also reflective.
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 Fresnel node.

To use the Fresnel node with a surface node, plug it into the 
surface node’s refraction_color channel. Set the Diffuse 
values low, and Transparency to 0. The Fresnel node has the 
following attributes:

• Background: The Background attribute selects the 
background color to be used for raytracing. Clicking this 
attribute opens a standard Color Picker.

• Index of Refraction: The Index of Refraction attribute 
controls how much light bends when passing through the 
object.

• Quality: The Quality attribute controls how many rays 
are spawned by hitting a surface. Increasing this value 
increases the realism of reflections but consumes computing 
resources.

• Softness: The Softness attribute controls how sharp or 
smooth refracted light appears after passing through an 
object.

Environment Map Nodes

Sphere Map

The Sphere Map node is a lighting node for performing 
spherical reflections. Attach this node to a materials’ reflection 
input (or as a raytrace reflection mode’s color attribute) to create 
spherical reflections. This node has the following attributes:

 Sphere map node.

• Color: The Color attribute specifies the map’s color. 
Clicking the color opens a Color Picker.

• Rotation: The Rotation attribute specifies the maps, 
rotation along the X, Y, and Z values.
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Variable Nodes

These are the value nodes included with Poser. Unless specified 
otherwise, the list of attributes for each node is listed from top 
to bottom.

N

The N node returns the normal at the specified point. It has the 
following attributes:

 N Node.

• X: The X attribute is the normal vector’s X component.

• Y: The Y attribute is the normal vector’s Y component.

• Z: The Z attribute is the normal vector’s Z component.

 Visualizes direction of surface normal.

P

The P node defines a point in space. It has the following 
attributes:

 P Node.
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• X: The X attribute is the point’s X location.

• Y: The Y attribute is the point’s Y location.

• Z: The Z attribute is the point’s Z location.

Frame Number

The Frame Number node returns the current frame number. It 
has no user-definable attributes.

U Texture Coordinate

The U node returns the S coordinate in texture space of the pixel 
currently being rendered. It has no user-definable attributes.

V Texture Coordinate

The V node returns the T coordinate in texture space of the pixel 
currently being rendered. It has no user-definable attributes.

Du

The dU node defines the rate of change of surface parameters 
as pertains to the current pixel’s location in S space. The ‘d’ 
indicates a derivative of the ‘U’ parameter.

Dv

The dV node defines the rate of change of surface parameters 
as pertains to the current pixel’s location in T space. The ‘d’ 
indicates a derivative of the ‘V’ parameter.

dPdv

The dPdv node represents a varying point surface shader 
variable. It is a vector perpendicular to the surface normal in the 
‘V’ direction. Specifically, it indicates the derivative of the surface 
position along ‘V’. It has no user-definable attributes.

dPdu

The dPdu node represents a varying point surface shader 
variable. It is a vector perpendicular to the surface normal in 
the ‘U’ direction. Specifically, it indicates the derivative of the 
surface position along ‘U’. It has no user-definable attributes.

dNdv

The dNdv node represents the derivative of the surface normal 
in the ‘V’ direction. In other words, it defines the rate of change 
of the surface normal along ‘V’.
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dNdu

The dNdu node represents the derivative of the surface normal 
in the ‘U’ direction. In other words, it defines the rate of change 
of the surface normal along ‘U’.

3D Texture Nodes
These are the color nodes included with the Material room. 
Unless specified otherwise, the list of attributes for each node is 
listed from top to bottom.

Fractal Sum

The Fractal Sum node is a fractal function that returns values 
between –1 and 1. It has the following attributes:

 Fractal Sum node.

• X Scale: The scale of the property along the X (horizontal) 
axis

• Y Scale: The scale of the property along the Y (vertical) axis.

• Z Scale: The scale of the property along the Z (depth) axis.

• Octaves: The Octaves attribute defines the number of 
iterations for the fractal function. Higher values produce 
more detailed fractals but may increase render time.

• Bottom: The Bottom attribute controls the bottom color 
level or floor.
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• Bias: The Bias attribute specifies how far to shift samples 
towards the light source to prevent self-shadowing of 
objects.

• Gain: The Gain attribute controls the balance between light 
and dark colors.

fBm

The fBm node is a multi-fractal function. It has the following 
attributes:

 fBm node.

• Signed: Checking the Signed checkbox returns values in 
the range –1 to 1. If unchecked, values less than 0 will be 
returned unsigned, e.g. –25 will be returned as 25.

• Fractal Increment: The Fractal_Increment attribute 
controls noise. Lower values result in a smoother noise 
gradient.

• Frequency Gap: The Frequency_Gap attribute controls 
fractal size. Higher values product larger fractals.

• Octaves: The Octaves attribute defines the number of 
iterations for the fractal function. Higher values produce 
more detailed fractals but may increase render time.

• X Scale: The scale of the property along the X (horizontal) 
axis

• Y Scale: The scale of the property along the Y (vertical) axis.

• Z Scale: The scale of the property along the Z (depth) axis.

• Bottom: The Bottom attribute controls the bottom color 
level or floor.

• Bias: The Bias attribute specifies how far to shift samples 
towards the light source to prevent self-shadowing of 
objects.
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• Gain: The Gain attribute controls the balance between light 
and dark colors.

• Noise_Type: The Noise_Type attribute allows you to 
select between the Original Perlin type and the Improved 
enhanced noise definitions.

Turbulence

The Turbulence node is an unsigned fractal function. It has the 
following attributes:

 Turbulence node.

• X Scale: The scale of the property along the X (horizontal) 
axis

• Y Scale: The scale of the property along the Y (vertical) axis.

• Z Scale: The scale of the property along the Z (depth) axis.

• Octaves: The Octaves attribute defines the number of 
iterations for the fractal function. Higher values produce 
more detailed fractals but may increase render time.

• Bottom: The Bottom attribute controls the bottom color 
level or floor.

• Bias: The Bias attribute specifies how far to shift samples 
towards the light source to prevent self-shadowing of 
objects.

• Gain: The Gain attribute controls the balance between light 
and dark colors.

• Noise_Type: The Noise_Type attribute allows you to 
select between the Original Perlin type and the Improved 
enhanced noise definitions.

Noise

The Noise node adds random “static” or “snow” effects. It has 
the following attributes:
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 Noise node.

• X Index: The x_index attribute defines the position on the 
X axis from which to draw a noise sample.

• Y Index: The y_index attribute defines the position on the Y 
axis from which to draw a noise sample.

• Z Index: The z_index attribute defines the position on the Z 
axis from which to draw a noise sample.

• Min: The Min attribute controls the minimum amount of 
noise.

• Max: The Max attribute controls the maximum amount of 
noise.

Cellular

The Cellular node is used to create mosaic or cubic tiles. It has 
the following attributes:

 Cellular node.

• Color1: The Color1 attribute specifies the cell color.

• Intensity1: The Intensity1 attribute determines the degree 
of dominance between the cells and the cusps.
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• Color2: The Color2 attribute specifies the color of the 
borders between the cells.

• Intensity2: The Intensity2 attribute determines the degree 
of dominance between the cells and the cusps.

• ScaleX: The ScaleX attribute controls the size of the tiles 
along the x axis.

• ScaleY: The ScaleY attribute controls the size of the tiles 
along the y axis.

• ScaleZ: The ScaleZ attribute controls the size of the tiles 
along the z axis.

• RandomColor: Enabling the RandomColor attribute 
specifies that the color of each cell will be randomly 
determined.

• CellMode: The CellMode attribute determines the type and 
shape of the cells. It has the following options:

 � Mode 1: This option creates 3D tiles. You can increase 
the Intensity1 value to make the tiles more prominent.

 � Mode 2: This option emphasizes the cracks between 
the cells. Set the Intensity1 value relatively high to 
maximize this effect.

 � Mode 3: This option creates a spider-web effect. The 
Color1 attribute defines the color of the web strands. 
Set the Intensity1 value relatively high to maximize this 
effect.

 � Mode 4: This option is similar to that of Mode 3, but it 
includes an additional dimension.

 � Mode 5: This option creates a quilt-style cell pattern 
when the RandomColor attribute is enabled.

• Jitter: The Jitter attribute controls the irregularity of the 
cell sizes.

• Turbulence: The Turbulence attribute controls the 
irregularity of the cell boundaries.

• GlobalCoordinates: When the GlobalCoordinates 
attribute is enabled, the object will use the global 
coordinates.

• Noise_Type: The Noise_Type attribute allows you to 
select between the Original Perlin type and the Improved 
enhanced noise definitions.

Clouds

The Clouds node simulates cloud patterns. It has the following 
attributes:
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 Clouds node.

• Sky Color: The Sky_Color attribute defines the areas 
behind the clouds. Clicking it opens the standard Color 
Picker.

• Cloud Color: The Cloud_Color attribute defines the 
clouds. Clicking it opens the standard Color Picker.

• Scale: The Scale attribute defines the size of the clouds.

• Complexity: The Complexity attribute defines the 
complexity of the cloud patterns.

• Bottom: The Bottom attribute controls the bottom color 
level or floor.

• Bias: The Bias attribute specifies how far to shift samples 
towards the light source to prevent self-shadowing of 
objects.

• Gain: The Gain attribute controls the balance between light 
and dark colors.

• Global Coordinates: Use the Global_Coordinates pull-
down menu to select ON or OFF. When on, the texture is 
computes using world space instead of object space and vice 
versa. If this option is on while the object is moving in any 
way, the texture will appear to “slide” through the object 
when rendered.

• Noise_Type: The Noise_Type attribute allows you to 
select between the Original Perlin type and the Improved 
enhanced noise definitions.

Spots

The Spots node consists of a 3D texture composed of random 
spots. It has the following attributes:
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 Spots node.

• Base Color: The Base_Color attribute defines the base 
color. Clicking it opens the standard Color Picker.

• Spot Color: The Spot_Color attribute defines the spot 
color. Clicking it opens the standard Color Picker.

• Spot Size: The Spot_Size attribute defines the size of the 
spots.

• Softness: The Softness attribute determines the transition 
from the spot to the base color.

• Threshold: The Threshold attribute defines the lean 
towards the base or spot color. Values close to 0 favor the 
base color while values closer to 1 favor the spot color.

• Global Coordinates: Use the Global_Coordinates pull-
down menu to select ON or OFF. When on, the texture is 
computes using world space instead of object space and vice 
versa. If this option is on while the object is moving in any 
way, the texture will appear to “slide” through the object 
when rendered.

• Noise_Type: The Noise_Type attribute allows you to 
select between the Original Perlin type and the Improved 
enhanced noise definitions.

Marble

The Marble node is a 3D simulation of marble or other stone 
patterns. It has the following attributes:

 Marble node.



Poser Pro 2014
Reference Manual

371

Chapter 16: Material Room Nodes

• Base Color: The Base_Color attribute defines the base 
color. Clicking it opens the standard Color Picker.

• Veins: The Veins attribute defines the vein color. Clicking it 
opens the standard Color Picker.

• Scale: The Scale attribute defines the size of the veins.

• Turbulence: The Turbulence attribute defines the low-
frequency randomness of the brick pattern.

• Global Coordinates: Use the Global_Coordinates pull-
down menu to select ON or OFF. When on, the texture is 
computes using world space instead of object space and vice 
versa. If this option is on while the object is moving in any 
way, the texture will appear to “slide” through the object 
when rendered.

• Noise_Type: The Noise_Type attribute allows you to 
select between the Original Perlin type and the Improved 
enhanced noise definitions.

Granite

The Granite node is a 3D simulation of speckled granite 
textures. It has the following attributes:

 Granite node.

• Base Color: The Base_Color attribute defines the base 
color. Clicking it opens the standard Color Picker.

• Spot Color: The Spot_Color attribute defines the spot 
color. Clicking it opens the standard Color Picker.

• Scale: The Scale attribute defines the size of the speckles 
(spots).

• Shades: The Shades attribute defines the number of 
shades used for the texture between and including the base 
and spot colors.
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• Balance: The Balance attribute defines the lean towards 
the base or spot color. Values close to 0 favor the spot color 
while values closer to 1 favor the base color.

• Global Coordinates: Use the Global_Coordinates pull-
down menu to select ON or OFF. When on, the texture is 
computes using world space instead of object space and vice 
versa. If this option is on while the object is moving in any 
way, the texture will appear to “slide” through the object 
when rendered.

• Noise_Type: The Noise_Type attribute allows you to 
select between the Original Perlin type and the Improved 
enhanced noise definitions.

Wood

The Wood node provides a 3D texture that simulates wood 
patterns. It has the following attributes:

 Wood node.

• Light Wood: The Light_Wood attribute defines the base 
wood color. Clicking it opens the standard Color Picker.

• Dark Wood: The Dark_Wood attribute defines the wood 
grain color. Clicking it opens the standard Color Picker.

• Scale: The Scale attribute determines the size of the wood 
grain.

• Turbulence: The Turbulence attribute determines the 
amount of randomness of the wood grain.

• Global Coordinates: Use the Global_Coordinates pull-
down menu to select ON or OFF. When on, the texture is 
computes using world space instead of object space and vice 
versa. If this option is on while the object is moving in any 
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way, the texture will appear to “slide” through the object 
when rendered.

• Noise_Type: The Noise_Type attribute allows you to 
select between the Original Perlin type and the Improved 
enhanced noise definitions.

Wave3D

The Wave3D node implements a three-dimensional sin / cos 
trigonometric function, resulting in a three-dimensional wave 
effect.

 Wave 3D node.

2D Texture Nodes
These are the color nodes included with the Material room. 
Unless specified otherwise, the list of attributes for each node is 
listed from top to bottom.

Wave2D

The Wave2D node implements a two-dimensional sin / cos 
trigonometric function, resulting in a two-dimensional wave 
effect.

 Wave 2D node.

Image Map

The Image Map node allows you to specify an image to use as 
a map (texture, reflection, transparency, bump, displacement, 
etc.). You can use any image as a map. However, if you want 
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to use a map designed for the particular figure/prop, you must 
use an image that has been set up to work that way. Please refer 
to “About Maps & Templates” on page 283 for a general 
discussion about maps, and to “Creating Character Textures” on 
page 288 for a brief description on creating maps. This node 
has the following attributes:

Poser supports texture resolutions up to 8192 x 
8192 pixels. Note, however, that high resolution 

textures consume a greater amount of system resources.

 Image map node.

• Image Source: Displays the currently loaded image. 
Clicking the Image Source attribute opens the Texture 
Manager dialog. To load an image map, either select the 
path from the drop-down list or click the Browse button to 
open a standard Open dialog and select the image you wish 
to load. A preview of your selected image should appear 
in the preview window. You can also select to use a global 
gamma value as set in the Render Settings dialog, or enter a 
specific gamma value that is unique to the selected texture. 
Click OK to implement your changes or Cancel to abort.

 Choosing a texture map.

• Auto_Fit: Check this option to automatically fit the texture 
map to the currently selected material without tiling.
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• U Scale: The U_Scale attribute sets the U scale factor to 
apply to the texture map when using UV or VU mapping. 
When using a projection map method (see below), this is 
one of two attributes used to define the world space size of 
the texture map being projected onto the surface.

• V Scale: The V_Scale attribute sets the V scale factor to 
apply to the texture map when using UV or VU mapping. 
When using a projection map method (see below), this is 
one of two attributes used to define the world space size of 
the texture map being projected onto the surface.

• U Offset: The U_Offset attribute defines the U position of 
the first texture tile in UV space. When using a projection 
map method (see below), this is one of two attributes 
used to define the position of the upper left corner of the 
projection “screen” in grid units.

• V Offset: The V_Offset attribute defines the V position of 
the first texture tile in UV space. When using a projection 
map method (see below), this is one of two attributes 
used to define the position of the upper left corner of the 
projection “screen” in grid units.

• Texture Coordinates: The Texture_Coordinates pull-
down menu offers the following choices:

 � UV: The UV option behaves like rubber wallpaper that 
can stretch over the object surface; the image file is 

made to correspond with set positions on the object’s 
surface, making any distortion caused by the stretching 
seem more natural. This is the most versatile mapping 
method.

 � VU: The VU option is identical to UV mapping, except 
that the image map is rotated 90 degrees.

 � XY: The XY option works like a slide projector in that 
the “screen” being projected onto is the XY plane whose 
size and position are determined using the U_Scale, 
V_Scale, U_Offset, and V_Offset parameters. Any 
surface not oriented with the selected viewing plane will 
distort the texture at render time.

 � XZ: Same as above but uses the XZ plane.

 � ZY: Same as above but uses the ZY plane.

• Image Mapped: The Image_Mapped pull-down menu 
offers the following choices:

 � None: The background color will be used for all areas of 
the object not covered by the texture map.

 � Alpha: The background color will be used for all areas 
of the object not covered by the texture map. The 
background color will also be blended with the texture 
map based on the alpha channel of the texture map.
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 � Clamped: The edge pixels of the texture map are 
repeated to cover any area of the object that the texture 
map does not cover.

 � Tile: The texture map will be tiled to ensure total 
coverage. Tiling is controlled using the Mirror U and 
Mirror V attributes, below.

• Background: The Background attribute specifies the 
background color. Clicking this attribute opens a standard 
Color Picker. Global_Coordinates button forces projected 
maps to use global instead of local coordinates.

• Mirror U: Enabling the Mirror_U option can help hide the 
seams between texture cells when tiling textures.

• Mirror V: Enabling the Mirror_V option can help hide the 
seams between texture cells when tiling textures.

• Texture Strength: The Texture_Strength attribute defines 
the strength of the texture map, where 1=100%.

• Filtering: The Filtering attribute allows you to select one 
of three options for texture filtering on the selected image 
map. These options are: None--no texture filtering; Fast--
high-speed texture filtering; Quality--high-quality texture 
filtering; Crisp--provides more aliasing for increased 
crispness.

Brick

The Brick node simulates brick or stone wall patterns. It has the 
following attributes:

 Brick node.

• Brick Color: The Brick_Color attribute defines the brick 
color. Clicking it opens the standard Color Picker.

• Mortar Color: The Mortar_Color attribute defines the 
mortar color. Clicking it opens the standard Color Picker.
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• Brick Width: The Brick_Width attribute determines the 
horizontal scale of the bricks.

• Brick Height: The Brick_Height attribute determines the 
vertical scale of the bricks.

• Mortar Width: The Mortar_Width attribute determines the 
spacing between bricks.

• Turbulence: The Turbulence attribute defines the low 
frequency randomness of the brick pattern.

• Softness: The Softness attribute defines how softly the 
brick blends into the mortar.

• Noise: The Noise attribute defines the high frequency 
randomness of the brick pattern.

• U Offset: The U_Offset attribute defines the U position of 
the first texture tile in UV space. When using a projection 
map method (see below), this is one of two attributes 
used to define the position of the upper left corner of the 
projection “screen” in grid units.

• V Offset: The V_Offset attribute defines the V position of 
the first texture tile in UV space. When using a projection 
map method (see below), this is one of two attributes 
used to define the position of the upper left corner of the 
projection “screen” in grid units.

• Noise_Type: The Noise_Type attribute allows you to 
select between the Original Perlin type and the Improved 
enhanced noise definitions.

Tile

The Tile node is a 2D texture that simulates tile patterns. It has 
the following attributes:

 Tile node.
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• Tile 1: The Tile_1 attribute defines the first tile color. 
Clicking it opens the standard Color Picker.

• Tile Shape 1: The Tile_Shape_1 pull-down menu defines 
the shape of the first tile. Your options are:

 � Rectangle: Selecting Rectangular will make the tiles 
rectangular.

 � Ellipsoid: Selecting Ellipsoid will make the tiles 
elliptical.

• Tile 2: This attribute defines the second tile color. Clicking it 
opens the standard Color Picker.

• Tile Shape 2: The Tile_Shape_2 pull-down menu defines 
the shape of the second tile. This menu has the same options 
as the Tile 1 Shape menu, described above.

• Mortar Color: The Mortar_Color attribute defines the 
mortar color. Clicking it opens the standard Color Picker.

• Tile Width: The Tile_Width attribute defines the tile’s 
width.

• Tile Height: The Tile_Height attribute defines the tile’s 
height in.

• Mortar Thickness: The Mortar_Thickness attribute 
determines the spacing between bricks.

• Turbulence: Defines the low-frequency randomness of the 
brick pattern.

• Softness: The Softness attribute defines how softly the 
brick blends into the mortar.

• Noise: The Noise attribute defines the high-frequency 
randomness of the brick pattern.

• U Offset: The U_Offset attribute defines the U position of 
the first texture tile in UV space. When using a projection 
map method (see below), this is one of two attributes 
used to define the position of the upper left corner of the 
projection “screen” in grid units.

• V Offset: The V_Offset attribute defines the V position of 
the first texture tile in UV space. When using a projection 
map method (see below), this is one of two attributes 
used to define the position of the upper left corner of the 
projection “screen” in grid units.

• Noise_Type: The Noise_Type attribute allows you to 
select between the Original Perlin type and the Improved 
enhanced noise definitions.
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Weave

The Weave node creates woven textile effects. It has the 
following attributes:

 Weave node.

• Color 1: The Color_1 attribute defines the first woven color. 
Clicking this attribute opens the standard Color Picker.

• Color 2: The Color_2 attribute defines the second woven 
color. Clicking this attribute opens the standard Color 
Picker.

• Base Color: The Base_Color attribute defines the 
underlying color behind the woven pattern. Clicking this 
attribute opens the standard Color Picker.

• U Scale: The U_Scale attribute defines the size of the 
weave in the U direction.

• V Scale: The V_Scale attribute defines the size of the weave 
in the V direction.

• Height: The Height attribute defines the height of the 
woven pattern.

• Bias: The Bias attribute adjusts the weave’s bias.

• Gain: The Gain attribute adjusts the weave’s gain.

Movie

The Movie node allows you to add animations to materials. 
Supported formats are AVI, MPG, and WMV. This node has the 
following attributes:
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 Movie node.

• Video Source: The Video_Source attribute specifies the 
path containing the selected animation.

• U_Scale: The U_Scale attribute defines the size of the 
animation in the U direction.

• V_Scale: The V_Scale attribute defines the size of the 
animation in the V direction.

• U Offset: The U_Offset attribute defines the U position of 
the first texture tile in UV space. When using a projection 
map method (see below), this is one of two attributes 
used to define the position of the upper left corner of the 
projection “screen” in grid units.

• V Offset: The V_Offset attribute defines the V position of 
the first texture tile in UV space. When using a projection 
map method (see below), this is one of two attributes 
used to define the position of the upper left corner of the 
projection “screen” in grid units.

• Texture Coordinates: The Texture_Coordinates pull-
down menu offers the following choices:

 � UV: The UV option behaves like rubber wallpaper that 
can stretch over the object surface; the PICT file is 
made to correspond with set positions on the object’s 
surface, making any distortion caused by the stretching 
seem more natural. This is the most versatile mapping 
method.

 � VU: The VU option is identical to UV mapping, except 
that the image map is rotated 90 degrees.

 � XY: The XY option works like a slide projector in that 
the “screen” being projected onto is the XY plane whose 
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size and position are determined using the U_Scale, 
V_Scale, U_Offset, and V_Offset parameters. Any 
surface not oriented with the selected viewing plane will 
distort the texture at render time.

 � XZ: Same as above but uses the XZ plane.

 � ZY: Same as above but uses the ZY plane.

• Image Mapped: The Image_Mapped pull-down menu 
offers the following choices:

 � None: The background color will be used for all areas of 
the object not covered by the texture map.

 � Alpha: The background color will be used for all areas 
of the object not covered by the texture map. The 
background color will also be blended with the texture 
map based on the alpha channel of the texture map.

 � Clamped: The edge pixels of the texture map are 
repeated to cover any area of the object not which the 
texture map does not cover.

 � Tile: The texture map will be tiled to ensure total 
coverage. Tiling is controlled using the Mirror U and 
Mirror V attributes, below.

• Background: The Background attribute specifies the 
background color.

• Global Coordinates: Checking the Global_Coordinates 
button forces projected maps to use global instead of local 
coordinates.

• Mirror U: Enabling the Mirror_U option can help hide the 
seams between texture cells when tiling textures.

• Mirror V: Enabling the Mirror_V option can help hide the 
seams between texture cells when tiling textures.

• Texture Strength: The Texture_Strength attribute defines 
the strength of the animated texture map, where 1=100%.

• Frame Number: The Frame Number attribute functions 
primarily as an input for other nodes (such as math and 
variable nodes), and allows you to retime the animation 
controlled by this node.

• Loop Movie: Checking the Loop Movie checkbox loops the 
animation.

Compound Nodes
The Compound Node allows you to combine any Poser node type 
as an external input or output, providing a way to reduce clutter 
in the Advanced Material Room. You can create modular blocks 
that expose essential settings to the user in the main material 
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room. If the user wants to expose the other settings for editing, 
they can open up the compound node in a separate window.

Creating a Compound Node

A Compound Node is created using the same methods as 
discussed in “Creating Nodes” on page 319. You will notice 
a new node type called Compound in the New Node menu. 
Initially, the new compound node will appear as shown at 
the bottom of the following figure. When you first create the 
compound node, there will be no input or output connections 
exposed. In order to add them, you will need to follow the steps 
that are outlined in “Editing Compound Nodes” on page 383.

 Creating a new Compound node.

You can also select two or more nodes in the 
main Material Room window and collapse them 

into a compound node. See “Collapsing Existing Nodes 
into a Compound Node” on page 386.

In the following figure, we start with a primitive cube that has 
no material settings. Then we create a new Compound node in 
the main material room window. You’ll learn how to edit the 
compound node in the section that follows.
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 Start with a new compound node.

Editing Compound Nodes

After you create a new compound node (or collapse existing 
nodes into a compound node as described in the next section), 

click the first icon in the title bar to open the node in a separate 
editing window in the Material Room.

 Click the Compound node icon to edit the compound node in a 
separate window.

When you enter the Compound Node editor, you’ll see the 
following features:

• Return to Main Window: To return to the main window in 
the Advanced Material Room, click the icon that appears at 
the upper left corner of the Compound Node editor.

• Breadcrumb trail: Compound nodes can be nested 
(in other words, you can have compound nodes within 
compound nodes). If you are editing a nested compound 
node, you’ll be able to follow a breadcrumb trail to move 
forward and backward in the hierarchy.
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• External Outputs: The nodes that you connect here will be 
exposed on the compound node as output plugs that you can 
connect to other nodes in the main window.

• External Inputs: The nodes that you connect here will be 
exposed on the compound as inputs plugs and settings that 
you can connect to other nodes in the main window.

 Compound node editor.

When creating connections to the external inputs and outputs, 
you’ll use the same steps as you would in the main Material 

Room advanced view. In the following figure, a Turbulence node 
has been attached to the External Outputs, and a second external 
output (Noise) is in the process of being added.

 Adding external outputs.
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Next, we’ll connect one input each from the Turbulence and 
Noise nodes into the External Input connector in the compound 
node. What you have now is a very basic compound node that 
has two eternal outputs, and two external inputs.

 Connecting external inputs.

Click the Eye icon in the upper right corner of the External 
Outputs node to expand the preview. When you highlight the 
name of one of the external outputs, the preview will update to 
display the results that will be output through the compound 
node.

 Previewing external outputs.

After you are finished editing, click the icon in the upper-
left corner of the Compound Node view (at the left of the 
breadcrumb trail) to return to the main Advanced Material 
Room view. Your compound node will now display the external 
inputs and outputs that you created in the Compound Node 
editor window.
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 The compound node in the main window.

You can then connect your compound node into other nodes in 
the main material room, just as you do with any other node.

 Connecting the compound node to other material nodes.

Collapsing Existing Nodes into a Compound 
Node

You can select several nodes that already appear in the Advanced 
Material Room window, and then collapse them into a single 
compound node. This helps reduce clutter in the main window, 
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and allows you to later go back and work on one aspect of your 
texture at a time in a separate window.

To collapse two or more nodes into a compound node, follow 
these steps:

1. Select two or more nodes in the Advanced Material View. 
You can select nodes by shift-clicking them, or by drawing a 
rectangular selection around them as shown in the following 
figure.

 Selecting nodes.

2. Right-click over one of the selected nodes and choose 
Collapse to Compound Node.

 Collapsing a Compound node.

Renaming Nodes and Connections

When you return to the main window in the Advanced Material 
room, the compound node is initially assigned a name of 
compound, followed by a numerical value. You can double-click 
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the name to enter a name that is more descriptive, as shown in 
the following figure.

 Renaming a Compound node.

When you are editing nodes in Compound Node view, you can 
also rename the external inputs and outputs that you connect to 
the compound node, so that the user has a better understanding 
of how that input or output will affect the material. 

 Renaming an external output.

The connections in the compound node can also 
be rearranged by dragging the external input 

and output names up or down and arrange them in a 
logical manner . For example, you can place them in 
order from top to bottom to match up with the 
connections that you make to the PoserSurface node, so 
that the connections do not cross over each other.

Expanding Compound Nodes

You can use the Expand Compound Nodes command in the 
node menu to “uncollapse” the compound nodes into their 
individual components. This will place the individual nodes back 
into the main editor in the Advanced Material Room so that they 
are accessible on an individual basis.

To expand a compound node, right-click on the node you want 
to expand, and choose Expand Compound Nodes from the 
context menu.
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 Expanding a Compound node.

Saving Compound Node Fragments to the 
Library

To save a compound node to the library, follow these steps:

1. Click to select the compound node that you want to save.

2. Switch to the Materials category in the library that you want 
to save the selected node into.

3. Navigate to or create the folder that you want to save the 
node into.

4. Click the Add to Library button in the Library window. The 
New Material Set dialog appears.

5. Enter a name for the library item in the Set Name field.

6. Check the Single Material option, and make sure that the 
Selected Nodes Only option is checked.

7. Click OK to save the compound node to the library.

A compound node fragment only saves the 
connections between the nodes that you selected 

when you saved the compound node fragment. If you 
later add that fragment to another material, you will 
need to connect the inputs or outputs from the 
compound node fragments to the appropriate  nodes in 
your current material.
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 Saving a compound node.
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Part 4: Rendering
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Chapter 17: The Render 
Menu

The Render pull-down menu (in the top Poser menu bar) is 
where you render still images of your scene and access Poser’s 
render settings.

Render
Selecting Render > Render renders your current scene using 
the currently selected renderer and that renderer’s current 
settings. Please refer to “Part 4: Rendering” on page 391 for 
more information about the FireFly render engine and adjusting 
render settings.

Area Render
Selecting Render > Area Render enables the Area Render 
feature, which allows you to select a specific region of the current 
image to render, thereby saving processing time. Please see 
“Area Render” on page 89 for a complete description of this 
feature’s functionality.

Render in Background
Render and work at the same time! Using Poser Pro’s 
background rendering capabilities you have the ability to render 
large, complex still frame scenes while you work. With the 
FireFly render engine you can continue to work on your current 
scene while sending another project to render.

To Render in the background, from the Main Menu select 
Render > Render in Background.

Alternatively from the Render Settings dialog, and from the 
FireFly Tab, you can also click on the Send Render To button 
and chose Background on the menu, to render a single image of 
the current state of the scene in the background.

 Rendering in a background process.

Background renders are only available for single 
frames (images). The Background Render option 

will not be available for movies. We recommend using 
the Render Queue (see “Sending Jobs to the Queue 
Manager” on page 427) when rendering movies.
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After the Background Rendering has initialized, the Progress 
Bar on the Document Window will show your Background 
Rendering progress as you continue to work.

 Poser Pro’s Background Rendering capabilities allow graphic 
artists to render and work at the same time.

Clicking on the Preview Tab will allow you to continue to modify 
your current project while it’s rendering.

If you find you need to cancel the Background Rendering in 
progress, just click on the Cancel button in the upper right 
corner of the document window.

 Cancel Render button.

Render in Queue
This command sends rendering jobs to the Queue Manager. For 
more information, see “Sending Jobs to the Queue Manager” on 
page 427 for further information.

Sketch Style Render
Selecting Render > Sketch Style Render renders your scene 
using the current Sketch Designer settings. Please see “Chapter 
20: The Sketch Designer” on page 440 for information on 
working with the Sketch Designer. Once you’ve set your options, 
you can use this menu command for rendering at any time while 
working in your scene.
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Antialias Document
Selecting Render > Antialias Document smooths rough 
edges in your Document window view for preview purposes. 
Antialiasing is a process of oversampling image data to smooth 
object edges and avoid a jagged appearance along them. The 
following images show a test render both without (left) and with 
(right) antialiasing enabled.

 Normal preview (left); Anti-aliased (right).

You can specify whether or not to apply antialiasing during 
renders when specifying render settings. Please refer to “Chapter 

18: The Render Settings Dialog” on page 397 for more 
information about specifying render settings.

Motion Blur Document
As you probably know, fast-moving objects appear blurry. The 
blur is caused by the fact that our eyes cannot “refresh” quickly 
enough to see that the object is no longer in its previous location. 
The 2D Motion Blur feature lets you give your animations the 
illusion of motion, adding a whole new dynamic and level of 
realism to your renderings.

Please see “Chapter 19: Using The FireFly Render Engine” on 
page 404 for information about using the 3D Motion Blur 
feature. You can also blur a single frame for test purposes by 
selecting Render > MotionBlur Document.
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 Using motion blur.

Render Settings
Selecting Render > Render Settings opens the Render 
Settings dialog. Please refer to “Chapter 18: The Render 
Settings Dialog” on page 397 for information about the 
Render Settings dialog.

Render Dimensions
Selecting Render > Render Dimensions brings up the Render 
Dimensions dialog, which contains settings that allow you 
to specify the dimensions of your render tab. See “Render 
Dimensions” on page 75 for more information on the 
Render Dimensions dialog settings.

Materials
Selecting Render > Materials opens the Material room. Please 
refer to “Chapter 14: The Material Room” on page 296 for 
information about the Material room.

Reload Textures
Selecting Render > Reload Textures will reload into memory 
all textures for the current scene preview display. This allows 
you to easily update any changes you may have made in other 
applications to the currently loaded textures.

Reuse Shadow Maps
If you do not make changes to lights or object positions between 
renders, there is no need to recalculate the shadow maps for 
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your scene, as they will not have changed. Selecting Render 
> Reuse Shadow Maps allows you to save the shadow map 
computations from your previous render and reuse them, 
thereby saving time with each subsequent render.

Clear Shadow Maps
Selecting Render > Clear Shadow Maps will cause Poser to 
recalculate the shadow maps for your scene during the next 
render. Use this option if you have made changes to lights or 
object positions, as such changes will affect the shadows in your 
scene.
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Chapter 18: The Render 
Settings Dialog

To open the Render Settings dialog, select Render > Render 
Settings. This window appears as follows.

 The Render Settings dialog.

Note that the Render Settings and Movie Settings dialogs 
appear as tabs within a single dialog, thereby making it easy for 
you to toggle between them.

Render Engines
Poser allows you to render still and animated scenes using three 
separate render engines. You can select which tool you wish 
to use by clicking on the relevant tab in the Render Settings 
dialog. The available Poser renderers are:

• FireFly rendering engine: This rendering engine supports 
the use of procedural shaders, contains many controls that 
let you control exactly how you want your rendered images/
movies to appear, and has the capability of generating truly 
breathtaking results. Please refer to “Chapter 19: Using The 
FireFly Render Engine” on page 404 for information on 
using the FireFly renderer.

• Sketch Renderer: The Sketch Renderer simulates a 
variety of fine art techniques, to render your scene as a 
drawing or painting. This tab also provides access to the 
Sketch Designer, discussed in “Chapter 20: The Sketch 
Designer” on page 440.
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• Preview: If you want to render quality high-resolution 
wireframe or silhouette (or any other display style) views of 
your scene, please choose the Preview rendering engine.

You can also select the Preview tab to configure your scene 
preview window options.

Sketch Tab
The Sketch Tab provides thumbnail previews of ten standard 
Sketch preset styles. Simply click on the appropriate thumbnail 
to select the desired preset, and then click the Render Now 
button to render your image using those preset values. 
Alternately, you can use the Sketch Preset pop-up menu to 
select from a list of standard presets and any custom presets you 
may have saved using the Sketch Designer. To easily access the 
Sketch Designer for fine tuning your sketch settings or creating 
new presets, simply click on the Sketch Designer button. Please 
see “Chapter 20: The Sketch Designer” on page 440 more 
information about using the Sketch Designer render engine, 
please see .

 The Sketch Renderer.

Preview Tab
This tab allows you to customize the Scene Preview display in the 
Document window, using the following settings: The settings in 
this tab apply to the document preview, and the use of Preview 
for actual output.
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The settings are discussed in the following sections.

 The Preview Render tab.

All options on the Render Settings Preview tab 
except for Offscreen Handling are now stored in 

the document. Please set a Preferred Scene on General 
Preferences Document tab if you want your settings to 
persist between sessions.

Display Engine Settings

Select the appropriate radio button to use Poser’s built-in SreeD 
software rendering, or OpenGL hardware rendering, for image 
previews. These settings apply to the document preview, and 
the use of Preview for actual output. Please refer to “OpenGL 
Hardware Acceleration” on page 76 for more information 
about the OpenGL hardware rendering option for Poser.

When using OpenGL for rendering, there are 
two additional options for offscreen handling. 

The default is Scene Window. When rendering a final 
output with the Preview renderer, if you encounter 
blank areas where other windows were overlapping the 
scene window, you should switch to PBuffer.

All options on the Render Settings Preview tab 
except for Offscreen Handling are stored in the 

document. Please set a Preferred Scene on General 
Preferences Document tab if you want your settings to 
persist between sessions.
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Procedural Shader Preview

When using OpenGL hardware rendering, you can choose to see 
the effects of the procedural shaders you are using in your actual 
Scene Preview display, provided your system will support it.

Once you select OpenGL, Poser will automatically check whether 
or not your system will support the calculation of real-time 
procedural shader effects. Poser will then provide a message 
within the Preview tab, stating whether or not your system will 
support this feature. If you are not using OpenGL, Poser will 
provide a message that the status of this feature is undefined for 
your system; simply switch to OpenGL to have Poser confirm the 
support status.

Procedural shader preview is available for 
scenes using up to eight light sources.

• Enable Hardware Shading: You can enable procedural 
shader previews by clicking the checkbox. This feature is 
enabled (checked) by default.

When Hardware Shading is enabled, the 
preview renderer will only display five lights, 

due to complexities of depth map shadows, AO, and 
normal mapping. When Hardware Shading is turned 
off, you can preview up to eight lights.

 � Optimize Simple Materials: Enable shader 
optimization by checking the checkbox. When shader 
optimization is enabled, shaders will not be generated 
for simple materials. Optimization is enabled by 
default.

 � Enable Hardware Shadows: Uncheck this option 
to disable enhanced real-time shadows when using 
hardware shading. The Depth Bias setting is 
dependent on the scene, the light placement, and 
the camera hither and yon settings. You want to find 
the smallest value that works well for your scene and 
hardware. An offset of 4 is generally a good starting 
point for NVidia cards, and an offset of 1 is a good 
starting point for ATI cards.

The crisper your shadows are (that is, the larger 
your shadow map sizes are), and the more your 

light shines on a surface, the lower your hardware 
shadow Depth Bias setting should be.

The performance of the procedural shader preview feature will 
be dependent upon your system’s hardware. Complex scenes 
with a large number of shaders may slow preview performance; 
if you are working with a large number of shaders, you may wish 
to disable this feature.
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The procedural shader preview feature does not 
support bump or displacement maps. 

Additionally, certain nodes are not supported, such as 
some raytracing effects, and some of the Variable nodes.

• Enable Hardware AO: When checked, Ambient Occlusion 
is displayed according to the capabilities in the graphics 
hardware.

• AO Strength: Controls the extent at which the space 
ambient occlusion effect is applied.

Scene Style Options

You can also specify various Style Options for your scene 
preview display, by entering your desired values in the 
appropriate fields. These options include the following:

• Silhouette Outline Width: The Silhouette Outline Width 
option allows you to specify the width of the lines used in 
the Outline display style.

• Wireframe Line Edge: The Wireframe Line Edge option 
allows you to specify the width of the lines used in the 
Wireframe display style.

• Toon Edge Line Width: The Toon Edge Line Width option 
allows you to specify the width of the Toon Outline display 
option, as enabled via the FireFly render settings.

• Remove Backfacing Polys: Polygons facing away from the 
camera will not be rendered when this option is checked.

• Check the Antialias rendered image option to smooth out 
rough “stairstep” edges that might appear in diagonal or 
curved-shaped areas of high contrast.

Click the OK button to apply your settings.

Transparency Display

You can set the Transparency Display to the actual 
transparency, or a specified limit, by clicking the appropriate 
radio button.

Selecting the Actual button will make any fully transparent 
surfaces invisible in your scene preview.

• If you wish to have some indication of where those items 
are in your scene preview, you can specify a limit to the 
transparency by selecting the Limit to button, and entering 
a maximum transparency percentage value. In the final 
render, transparent items are always rendered using the 
actual transparency settings.
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• Objects with multi-layered transparency, such as hair, 
can sometimes appear to have inverted polygons in areas 
where the layers overlap. Check the Enhance multi-layer 
transparency option to improve the display of multi-
layered transparent objects. The preview display runs slower 
when this option is enabled.

Texture Display Resolution

Adjust the Preview Texture Resolution slider to your liking. 
Lower settings provide less detail in your scene preview, but save 
on system resources. Higher settings provide more realism, but 
may result in slower performance while building your scene in 
preview mode.

Movie Settings

You can access the Movie Settings window by toggling 
the Movie Settings tab next to the Render Settings tab. 
Please refer to “Keyframe Controls” on page 452 for more 
information on movie settings.

Real-time Raytrace Preview
Choose Window > Raytrace Preview to enable the real-time 
raytraced viewport, which provides a more accurate preview 
render without having to render your scene.

If the Auto Refresh option is enabled, the Raytrace Preview 
window will update automatically as you make changes in 
your scene, reducing the need for preview renders as you make 
changes. To update the window manually, uncheck the Auto 
Refresh option and click the Refresh button to update the 
preview.

 The Raytrace Preview.
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The Raytrace Preview window functions just like any other 
Poser palette, which can be docked or floated. It appears only 
in the room in which you initially opened it. For example, if you 
turn the Raytrace Preview window on in the Pose Room, but 
then switch to the Material Room, you will not see the Raytrace 
Preview window unless you choose the Window > Raytrace 
Preview command in the Material Room. When you return back 
to the Pose Room, the first Raytrace Preview window will still be 
open there.

The Raytrace Preview rendering levels are in the 
Render Settings “Progressive Mode”, a truncated 

set of parameters that you can use to speed up rendering 
by reducing the number of rays or use of displacement 
maps. Several manual settings will be disabled when 
using progressive mode. Uncheck this option if you need 
more flexibility with manual render settings.

Tips & Tricks
This section contains a few tips and tricks for improving still and 
animated renders:

• Experiment with low render settings and gradually increase 
them until you get the results you want. This will render 
your scene using the optimal balance between quality and 

speed. Small Web animations might need lower quality 
rendering while a piece of fine art might require very high 
settings.

• Still and animated renders use the currently selected 
camera. Be sure to select the proper camera before 
rendering, particularly if camera motion is part of your 
animation.

• By default, Poser renders using the Texture Shaded display 
style.

• Use the draft and production rendering options to save time 
while working and produce highly realistic results.

Use prop-based hair and figure-based clothing instead of strand-
based hair and dynamic cloth where you do not need dynamic 
effects. This will conserve computing resources.



Poser Pro 2014
Reference Manual 

404

Chapter 19: Using The FireFly Render Engine

Chapter 19: Using The 
FireFly Render Engine

This chapter describes the FireFly technology features and 
render settings:

The FireFly renderer includes a wealth of powerful features, all 
of which help to create beautiful, realistic renders in little time. 
Those aspects of FireFly that are configurable are described in 
the following section. The following features enhance FireFly’s 
performance and results:

• High Dynamic Range (HDR) Image Support for IBL: 
Poser supports both High Dynamic Range (HDR) and Low 
Dynamic Range

• HDR images are comparable to analog photo film, with 
regards to the amount of information stored in the image. 
HDR light probes have a significantly higher amount of 
information, but are much harder to produce.

There are a number of different ways to create 
HDR images. Several tutorials appear on the 

Internet for using Photoshop CS2 or later to create 
HDRI images. Some of them appear at http://www.
photoshopgurus.com or http://www.photoshopcafe.
com, for example.

 � You can use LDR images with Image Based Lighting 
(IBL). LDR light probes are relatively easy to create, 
using a mirrored ball to capture the light information 
in a given environment. However, the amount of 
information captured is much less than with an HDR 
image, and therefore the quality of the light probe 
is lower. For more information about Image Based 
Lighting and light probes, see “Diffuse Image Based 
Lights (IBL)” on page 263.

• Occlusion Culling: FireFly ignores invisible scene elements 
while rendering, in order to improve render performance. 
Occlusion culling determines which scene elements have 
visible impacts on the scene, and which may be culled 
(ignored). FireFly runs occlusion culling calculations for 
both the object and shadow render passes, to determine 
whether each scene element (a) is visible within the scene, 
and (b) casts any visible shadows. Occlusion culling cannot 
be used in conjunction with raytracing, as raytracing 
calculations include all scene elements, visible or not.

A scene element’s visibility or invisibility with regards 
to occlusion culling is not the same as the Visibility 
setting the Properties palette for that element. When 
unchecked, the Visibility property setting actually 
hides an object within the scene, so that the object 
is not included in any render calculations regardless 
of its placement within the scene. Occlusion culling 

http://www.photoshopgurus.com
http://www.photoshopgurus.com
http://www.photoshopcafe.com
http://www.photoshopcafe.com
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calculations apply to items that are set to be visible 
within the scene, but are obscured from the camera’s 
perspective by other scene elements.

• Texture Filtering: Texture filtering improves the 
appearance of surfaces rendered using 2D image maps, 
giving you better quality images, and avoiding aliasing and 
other artifacts. Tiled texture loading uses texture filtering 
to reduce the time required for processing. Texture filtering 
can be configured for individual textures on the Image Map 
node in the Material room (see “Image Map” on page 373 
for more information).

 Without Texture Filtering (top); With Texture Filtering (bottom).

• Tiled Texture Loading: Upon your first FireFly render 
Poser generates temporary files on the hard disk from the 
textures within the scene, and then selectively accesses them 
during render time. Poser also creates a cache in memory 
that contains the most recently used texture tiles. Tiled 
texture loading makes use of other features, such as texture 
filtering to reduce processing time. Depending upon your 
system’s resources, you may wish to increase the memory 
cache size to offset the amount of disk access required for 
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tiled texture loading, as this feature may use a lot of hard 
disk space (potentially more than 1 GB). For information 
about increasing the memory cache size, see “Render 
Preferences” on page 37.

• Multi-threaded Rendering: The Multi-threaded Rendering 
feature takes advantage of the increased processing power of 
the multi-processor or multi-core computer systems that are 
now available. Using this feature, you can configure FireFly 
to render any number of separate threads simultaneously, 
which results in reduced render times for most renders. 
The number of threads can be specified in the General 
Preferences dialog (see “Render Preferences” on page 
37 for more information).

We recommend rendering your scene with as 
many threads (CPU cores) as your system 

possesses. This is the default preference after installing 
Poser. If you are unsatisfied with the resulting 
performance, or if the render fails to complete, then 
reduce the number of threads and/or maximum bucket 
size.

• Rendering in a Separate Process: By default, Poser 
runs the application and the FireFly render engine within 
a single process on the CPU. This means that both the 
application and the render engine share the maximum 

memory allotment given to a single process. Rendering in 
a separate process means that the render engine alone has 
access to that same maximum memory allotment, which can 
yield significant performance advantages for highly complex 
scenes, depending upon the memory configuration of your 
specific system. In addition, rendering in a separate process 
provides greater stability due to the compartmentalization 
of tasks, as well as allowing your system to manage memory 
more efficiently. However, rendering in a separate process 
does require more resource overhead for setting up the 
render. Therefore, if you are running primarily area 
renders or simple small renders, we recommend that you 
do not use this feature as the setup overhead will negate 
the performance benefits. However, for large complex 
renders, rendering in a separate process will definitely yield 
significant benefits. You can enable or disable this feature in 
the General Preferences dialog (see “Render Preferences” 
on page 37 for more information).

Firefly Tab: Quality Settings
The FireFly tab offers you a choice between specifying your 
render settings automatically or manually. Check the Auto 
Settings or Manual Settings radio button to display the 
appropriate render setting controls. Note that the Auto and 
Manual settings are stored independently, so making changes 
to one will not affect the state of the other. The Auto settings are 
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useful when you first start using Poser’s FireFly render settings, 
because they allow you to quickly setup and render your scenes.

 Auto Settings.

 Manual Settings.

Auto Settings: Draft vs. Final Quality

The Auto Settings option contains a Render Quality slider, that 
ranges from Draft Quality (faster render times) to Final Quality 
(slower render times). Moving this slider will automatically 
adjust the values of the specific render settings, as shown on the 
graphs below the slider. The values of the render settings (Min 
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shading rate, Pixel samples, Raytrace bounces, and Irradiance 
caching) are depicted using a gradual shaded bar, with lighter 
color representing smaller values and darker representing larger 
values. Render settings such as Cast Shadows and Raytracing 
are either enabled for the render or not, so those settings are 
depicted using a solid color bar indicating the point at which 
they become enabled.

At the Draft Render Quality, the rendering settings will 
provide faster renders at lower quality. Use this option while 
creating your scene to get an idea what it will look like once it’s 
completed. At the Final Render Quality, the render settings yield 
high-quality renders, but with increased render times. Use this 
option for your final output. There are also options below, above, 
and between Draft and Final quality which will increase or 
decrease rendering time depending on your selection.

For a description of the settings that are found in the Auto 
Settings view, refer to “Manual Settings” on page 409.

 Increase or decrease render quality with the Render Quality slider.
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Manual Settings

 Manual settings.

• Acquire From Auto: Clicking the Acquire From Auto 
button applies the current Automatic Quality Settings to the 
individual Manual Quality Settings parameters.

• Cast Shadows: This option is set automatically in Auto 
Settings. Checking the Cast Shadows checkbox causes 
the rendering engine to calculate shadows when rendering. 
Individual settings will override this general setting. For 

example, if a figure in your scene is set to not cast shadows, 
then it will cast no shadows even if Cast Shadows is turned 
on for all other objects in the scene. However, if the Cast 
Shadows checkbox is not enabled, no shadows will be 
rendered regardless of individual object settings. Enabling 
this option adds realism to your renders but can affect 
render time.

• Subsurface Scattering: Enables subsurface scattering in 
the render engine. Materials that use subsurface scattering 
will not render properly if this option is disabled. For 
more information on some materials that use subsurface 
scattering properties, see “Subsurface Skin” on page 347, 
“Scatter” on page 351, and “ks Microfacet” on page 344.

• Raytracing: This option is set automatically in Auto 
Settings. Checking the Raytracing box enables raytracing, 
and vice versa. Enabling raytracing greatly enhances 
renderings, especially for curved surfaces, shadows, 
reflections, and refraction. However, it also greatly increases 
rendering times. Raytracing projects rays from the camera 
through every pixel visible in the render window, also 
called the View pane. Each pixel is then set to the color 
value returned by the ray projected through it, based on 
the ray’s point of intersection with an object in the scene. 
If the ray fails to intersect any objects, the pixel will be set 
to the background color. To determine whether the point 
of intersection is in shadow, a secondary ray is projected 



Poser Pro 2014
Reference Manual 

410

Chapter 19: Using The FireFly Render Engine

from the intersection point towards each light source. If the 
shadow rays intersect an object, the original intersection 
point lies in the shadow of that object. For reflections, 
when the ray intersects a reflective surface, a new ray 
is traced starting from the point of intersection and the 
color returned by that ray is incorporated into the color of 
the original intersection. This process is called recursive 
raytracing because reflected rays can spawn more reflected 
rays as long as they keep intersecting reflective objects. The 
images below show an example of raytracing. You can set 
the number of reflections (bounces) using the Raytrace 
bounces option (see below).

• Raytrace Bounces: This option is set automatically in 
Auto Settings. When raytracing is enabled, the Raytrace 
bounces option specifies how many “bounces” or 
recursions the renderer will use when raytracing. You 
should select the number of raytrace bounces based on the 
number of reflective or refractive surfaces that will interact 
in your scene. Higher numbers can add realism if the scene 
requires complex raytracing calculations. However, as 
higher numbers require longer render times, in a simple 
scenario increasing the number of raytrace bounces will just 
waste computation time.

When using Indirect Lighting with transparent 
surfaces, set the Raytrace Bounces setting to at 

least 2 for proper IDL calculations.

 One raytrace bounce (left); three raytrace bounces (right).

• Irradiance Caching: This option is set automatically in 
Auto Settings. Irradiance Caching is used to accelerate 
Ambient Occlusion, Gather and Indirect Light effects. 
This is done by reusing and interpolating values instead of 
expensively calculating them separately for every shading 
point. This process speeds up calculations by tracing 
less rays. The irradiance caching quality can be adjusted 
using the Irradiance caching slider. A lower setting means 
lower quality: FireFly will use more estimations, resulting 
in shorter processing times but less accuracy. A higher 
setting equals higher quality: FireFly will run more new 
calculations, resulting in longer processing times but 
increased accuracy (see “Indirect Light” on page 413).
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 If the quality of your render is unsatisfactory 
with irradiance caching on, you can disable it to 

calculate indirect lighting with a “brute force” method. 
To disable, uncheck the box that appears to the left of the 
Irradiance Caching slider.

• Indirect Light: Only enabled when Raytracing is enabled. 
See “Indirect Light” on page 413.

When using Indirect Lighting with transparent 
surfaces, set the Raytrace Bounces setting to at 

least 2 for proper IDL calculations.

• Indirect Light Quality: See “Indirect Light” on page 413.

• Pixel Samples: This option is set automatically in Auto 
Settings. Select the XY pixel sample rate by moving the 
Pixel Samples slider. Alternatively, you can click the dots 
at either side of the slider to increment (right) or decrement 
(left) the sample size. Pixel sampling rates determine how 
many pixels are sampled when calculating antialiasing for 
a single pixel. For example, a setting of 3 creates a 3-pixel 
by 3-pixel grid with the pixel being sampled in the center. 
At render time, the renderer would examine the 3x3 area 
when determining the color and other values to assign to the 
pixel currently being rendered. Expanding this number can 

refine your renders but will greatly affect render times. 3x3 
is considered a good default.

• Minimum Shading Rate: This option is set automatically 
in Auto Settings. The Minimum Shading Rate value 
determines the level to which object polygons will be 
subdivided (or diced) into micro-polygons. For example, a 
shading rate of 1 means that polygons will be divided into 
micro-polygons that each occupy approximately one pixel 
of the rendered image, and a value of 4 means that each 
micro-polygon will cover approximately 4 pixels of the 
rendered image. Values less than one (such as 0.2) cause 
each micro-polygon to be less than a pixel in size. Micro-
polygons within a given polygon are as identical in size, 
shape, and area as possible. At render time, the renderer 
will subdivide each polygon, sample each micro-polygon, 
and assign the micro-polygons’ average color to the pixel 
being rendered. Enter your desired sampling rate in the 
Minimum Shading Rate field, or adjust the slider to the 
desired value. Decreasing this value can refine your renders 
but increases render time. You can set this value on a per-
object basis using the desired object’s Properties palette. 
Setting this value in the Render Settings dialog applies it to 
the entire scene, and overrides all per-object settings that 
are lower than this global value. If an object has a higher 
shading rate, Poser will use the object’s shading rate when 
rendering that object.
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 High minimum shading rate (left), loss of detail; Low minimum 
shading rate (right), full detail visible.

• Maximum Bucket Size: The bucket is the area being 
rendered at any one time. Enter your desired value in the 
Maximum Bucket Size field. For example, entering a value 
of 10 creates a rendering bucket that is no greater than 
10-pixels by 10-pixels in size. At render time, the renderer 
will render one such bucket area at once. Increasing the 
bucket size increases the area being rendered at once 
but requires greater system resources. Use caution when 
enlarging the bucket beyond its default size, and monitor 
your system resources. Note that Poser will automatically 
detect when the specified bucket size will consume excessive 
resources, and in such cases will override the specified 
bucket size and subdivide the buckets into smaller sizes. 

Smaller sized buckets require less RAM, but will take longer 
to render.

• Minimum Displacement Bounds: This feature is enabled 
only when Use Displacement Maps is checked in the 
Rendering Options window. The Minimum Displacement 
Bounds value is measured in Poser units (as specified 
in the General Preferences dialog), and determines the 
amount of displacement the render engine anticipates. 
Displacement mapping is a rendering technique that 
adds realistic bumps and indentations to surfaces. This is 
normally preferable to modeling deformations directly, 
since you can alter the displacement map (template used 
for calculating displacement) rather than editing the object. 
Further, adding such detail directly to an object could 
exponentially increase its polygon count and therefore 
greatly affect render time. When setting the Minimum 
Displacement Bounds, keep in mind that it is possible 
for displacement deformations to exceed the render 
bucket boundaries. In other words, even though the actual 
geometry of a given object may be entirely contained within 
the current render bucket, the object still may cross into 
adjacent buckets through the displacement of its surface. 
If a particular displacement exceeds the boundaries of 
the currently rendered bucket at any point, you will see a 
hole or patch crack at the affected location. To avoid this 
problem, the render engine takes into account a volume 
exceeding the actual geometry when determining whether 
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or not an object is contained within a specific bucket. This 
volume is specified by the displacement bounds. Smaller 
bounds result in fewer objects within the current bucket and 
therefore faster rendering, but increase the risk of geometry 
cracks along the bucket boundaries. Larger bounds will 
prevent cracks but will increase render time. The above 
diagram illustrates this concept. In this case, the top of 
the pyramid exceeds the bucket bounds and will therefore 
be cut off, leaving a patch crack. Poser will automatically 
determine the displacement bounds value, by evaluating 
the shader trees defining the materials. If the shader tree is 
particularly complex, Poser might not be able to compute 
an appropriate value. In such a case, you should specify a 
higher value in the Minimum Displacement Bounds field. 
This will become the minimum value Poser is allowed to use 
for the displacement bounds when rendering.

• Progressive Mode: Check this option to get a very fast 
raytraced render. Several manual settings will be disabled 
when using progressive mode. Uncheck this option if you 
need more flexibility with manual render settings.

 The Interactive Preview Window  and 
progressive mode render without any caching 

for AO or IDL. Quality can be improved by using a 
higher number of pixel samples, which comes with 
proportionally higher render times. For more 
information on The Raytrace Preview window, see 
“Real-time Raytrace Preview” on page 402.

 Displacement bounds limit the amount of displacement used in a 
render.

Indirect Light
Poser’s indirect light feature provides increased realism by 
adding light that naturally bounces off of objects to illuminate 
other surrounding objects. To use indirect light, create a scene 
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that contains objects from which light will bounce onto your 
figure(s). For example, you can scale one or more primitive 
cubes to use as walls behind or near your figure. Point a 
directional light at the walls and the figure, and the light will 
bounce off the walls to illuminate the figure near it.

Due to the number of interpolations and 
calculations required for this feature, the 

practical use of indirect light in animation will be 
dependent on the number of elements in your scene and 
the quality settings set in your renderer.

 Indirect lighting bounces light from surrounding objects.

Irradiance caching is used to calculate rays for locations 
where they can easily be determined. In-between locations are 
interpolated. The render engine determines whether to calculate 
or interpolate the rays based on the distance and direction of the 
current location to the locations previously calculated and the 
distance to other nearby objects.

 Bounced light from IDL creates more realistic renders.

Related Settings in the Render Settings dialog include:

• Indirect light: Check this option to add indirect light for 
more realistic lighting
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• Irradiance Caching: Determines the ratio of shading points 
where indirect light will be calculated by raytracing vs. those 
that will be interpolated.

• Low values result in shorter render times, with more 
interpolation.

 � High values achieve more precise results at the expense 
of increased render times.

 � Indirect Light Quality: Indirect Light Quality 
determines the number of rays used to calculate the 
indirect light. Higher values mean higher quality at the 
expense of longer render times.

The renderer will perform one pass as it samples the light rays. 
The pre-pass displays red dots in the places where indirect light 
is calculated explicitly. Following the pre-pass, the final render is 
completed using the indirect light calculated in the pre-pass.

IDL Tips and Tricks

• Scene Considerations: Indirect Light is designed to 
simulate real-world lighting where light bounces from one 
object to another in your scene. It works best when the 
main objects in your scene are surrounded by some type 
of environment such as a box, an environment sphere, or a 
room built with the PICK props which you will find in the 

Props library. Try to use props and materials that simulate a 
real-world scene when you build a scene that uses IDL.

• Watch the Pre-pass: During the IDL pre-pass, you’ll 
see red dots appear in the areas where indirect light is 
calculated. The Irradiance Caching setting controls how 
sparse or dense the calculations are. If the dots are too 
sparse, set the Irradiance Caching slightly higher and render 
again. Conversely, if the dots are too dense you can reduce 
the Irradiance Cache setting.

• Smearing: If you see smearing in your scene, it probably 
means there is not enough detail being picked up in the 
indirect light. Increase the irradiance cache setting to reduce 
the smearing.

• Splotchiness: Splotchiness occurs when there are too 
many samples taken. If you find that the dots are too dense 
during the IDL pre-pass, it may result in splotchiness. Turn 
down the Irradiance Caching setting, and increase the IDL 
Quality setting.

• Watch the number of lights: You won’t need as many 
lights in your scene when using IDL. Start with one or two 
lights, using the first one to light your main subject, and 
a second light at about 15% intensity to offset shadows if 
they are too dark. Also position your lights appropriately as 
they relate to the source of the light (such as sunlight in day 



Poser Pro 2014
Reference Manual 

416

Chapter 19: Using The FireFly Render Engine

scenes, moonlight or artificial light in night scenes, or light 
through windows or from lamps in interior scenes).

• Shadows: For more realistic shadows, use Ray Traced 
shadows. For your main light, start with a Blur Radius of 
around 10, Shadow Samples of around 40, and falloff set 
to constant. Also use a Shadow Min Bias setting that is 
appropriate for your display units setting. For example, if 
your display units are in inches (as set in the Interface tab 
of the General Preferences dialog), set the Shadow Min Bias 
to .1 inch. Adjust these settings as appropriate for your scene

• Normals: Indirect light is always calculated in the direction 
of the normals. You will want to check the Normals Forward 
option (usually checked by default) in the Poser Surface root 
material node. This option is discussed in “Root Material 
(PoserSurface) Node” on page 325.

• Watch for Ambient glow: There are times when you desire 
ambient glow from materials that are designed to be self-
illuminating (LED’s, computer screens, candle light, an 
illuminated ceiling, and so on). There may be other times 
when content uses colors or values in the Ambient channel 
that cast undesirable light when IDL is enabled. This is 
particularly noticeable in skin textures and can leave the 
character looking “flat.”To check for objectionable ambient 
glow, keep IDL enabled but turn all lights off. Then render 
your scene. If you see light being cast from undesired places, 

you’ll need to adjust the ambience of the offending materials 
in the Material room. After you have fixed the objectionable 
materials, turn your lights back on and re-render.

• Animation Considerations: When rendering out an 
animation while using IDL, make sure that multi-threaded 
rendering is not being used (set Number of Threads to 1 in 
the Render tab of the General Preferences dialog). If you 
leave the setting at 2 or higher, your renders will come out 
jittery, as the shadows and lighting will not line up from 
frame to frame.

To create a transparent object with an 
interesting glow, change the Transparency, 

Transparency Edge, and Transparency Falloff settings 
to .8 and mix with higher Ambient values and IDL 
features.
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FireFly Options Settings

 Firefly Options.

• Render Over: These options specify the background to 
be used when rendering images or movies. Check the 
appropriate radio button for the option you wish to select.

 � Background Color: Selecting Background Color 
renders the image/movie over the Document window’s 
background color. Please refer to “Colors” on page 
96 for information about changing Document 
window colors.

 � Black: Selecting Black renders the image/movie over a 
plain black background.

 � Background Picture: Selecting Background Picture 
renders the image/movie over the background image 
in your scene. Please refer to “Importing Background 
Pictures” on page 778 for information on importing 
background pictures.

 � Current Background Shader: Selecting Current BG 
Shader renders the image/movie over the specified 
background shader. Please refer to “Root Background 
Node” on page 329 for information about using 
background shaders.

• Shadow Only: Checking the Shadow Only checkbox will 
cause only the shadows from your scene to be rendered; 
everything else in the scene will be completely white. This 
feature is most useful for production rendering, as it allows 
you to render just the shadows, thereby allowing you to edit 
them independently from the rest of the scene. You can then 
take the shadow only render into an image editing program, 
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and composite it with the unshadowed scene. This setting 
overrides all other render settings.

• Smooth Polygons: Checking the Smooth Polygons 
checkbox enables polygon smoothing, and vice versa. 
When enabled, the FireFly rendering engine uses polygon 
subdivision to smooth hard corners on objects. If your scene 
contains hard edges that you don’t wish to have smoothed, 
you should define those hard edges either by specifying 
smoothing groups or by setting a crease angle threshold 
to determine which polygons are affected. Please see 
“Smoothing Geometry” on page 422 for more information 
about smoothing groups and setting the crease angle 
threshold. This option can be disabled for specific objects as 
needed, in the object’s Properties palette.

 Without Polygon Smoothing (left); With Polygon Smoothing 
(right).

• Remove Backfacing Polys: Check the Remove 
Backfacing Polys option to turn off rendering of all 
polygons that do not face the camera. This option saves 
rendering time, but can effect realism when using 
raytracing. The polygons that are rendered depend upon the 
angle and position of the camera and objects in your scene.

• Use Displacement Maps: Checking the Use Displacement 
Maps checkbox enables (checked) or disables (cleared) 
using displacement maps in your rendered output. Please 
see “About Maps & Templates” on page 283 for a 
description of maps in general, the “Displacement Map” 
on page 287 for a description of displacement maps, 
and “Chapter 14: The Material Room” on page 296 for 
information about the Material room (maps are added to 
nodes that are part of shaders).

 Without Displacement (left); With Displacement (right).
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• Depth of Field: Widening the lens aperture of the camera 
allows you to achieve a Depth of Field effect. The farther 
away items are from the focal plane, the more blurred they 
will appear. The Depth of Field checkbox allows you to 
enable or disable this effect when rendering your scene. 
Please refer to “Camera Parameters” on page 252 for 
information on configuring Depth of Field settings.

• 3D Motion Blur: As you probably know, when you shoot a 
photo of a fast moving object, it appears blurry. The amount 
of blur is directly related to the length of time that the 
camera’s shutter remains open while taking the shot. In a 
similar manner, Poser’s Motion Blur feature lets you give 
your animations the illusion of motion, adding a whole new 
dynamic and level of realism to your renderings. Checking 
the 3D motion blur checkbox enables motion blurring for 
your scene when rendering. When this option is enabled, 
adjusting the shutter open and close times affects the 
amount of blurring. Please refer to “Camera Parameters” on 
page 252 for more information about the Shutter Open 
and Shutter Close parameters.

• Toon Outline: The Toon Outline option uses post-
processing during the rendering process to draw an outline 
around the edges of cartoon images. You can select from 
nine outline brush styles. We recommend applying a Toon 
shader node to your images, and then complementing that 

shading with the Toon Outline option. Check the Toon 
Outline checkbox to enable this feature.

 Toon Outline.

• Post Filter Size: The post filter supersamples pixels, that 
is, samples the colors at various points inside a pixel to 
arrive at the final pixel color. This is done in order to reduce 
or eliminate various forms of aliasing (jagged edges) that 
can occur under different circumstances. The final pixel 
color is a weighted average of the supersample. Increasing 
this value increases the area used for supersampling, but 
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affects rendering time and resources. You can adjust this 
value by moving the Post Filter Size slider or by clicking 
the dots on either slide of the slider to increment (right) or 
decrement (left) the value.

• Post Filter Type: A post filter operates on an image and 
modifies its appearance by applying a specific weighting 
algorithm to the supersamples taken for each pixel. The 
specific algorithm used for determining relative sample 
weights depends upon which filter you select using the Post 
filter type pull-down menu. Your options are as follows:

 � Box: A Box filter gives equal weight to all samples 
within a sampling region with a diameter equal to the 
pixel filter size.  Box filtering example.

 � Gaussian: A Gaussian filter gives a variably 
decreasing amount of weight to all samples within 
a radius equal to half the pixel filter size, with the 
maximum reduction in weight occurring farthest from 
the center of the sampling region.
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 Gaussian filtering example.

 � Sinc: A Sinc filter uses a decreasing sine wave 
calculation to assign weight to samples within a radius 
roughly half the pixel filter size. The sine wave effect is 
similar to ripples radiating from the center point, where 
samples will be given weight according to their relative 
positions with regards to the “crests” and “troughs” of 
the ripples.

 Sinc filtering example.

• Tone Mapping: This feature is useful for scenes with a 
high dynamic range. Tone Mapping provides more control 
for brightness, saturation, and post-render processing to 
produce better images. It helps control overly bright areas in 
an image to produce better, less blown out final renderings 
with deeper contrast, helping to bring the brightest areas 
back into a reproducible range. It helps preserve as much 
information from a high dynamic range source as possible 
in an LDR image or display. Two modes of tone mapping 
are available.

 � Exponential: Works like film. The more you expose 
film, the less sensitive it gets. This is a post rendering 
filter that uses an exponential curve to gently approach 
white. The brighter it gets, the less sensitive gets.

 � HSV (Hue, Saturation, Value) exponential: Treats 
V exponentially, none on H, S. Brightness doesn’t 
desaturate or overbrighten color. It not physically 
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accurate, but may be easier to control in scenes where 
you want to get brights into a normal range without 
going to white. .

• Exposure: Editable when either Exponential or HSV Tone 
Mapping are selected. This setting is the exponent used in 
Exponential calculations.

• HDRI optimized output: Check this option to generate an 
image that is HDRI compatible. For further information, 
see “High Dynamic Range Image (HDRI) Export” on page 
784.

• Gamma Correction: See “Gamma Correction and Linear 
Rendering” on page 432 for more information.

• Auxiliary Render Data: Allows you to choose properties for 
output to individual PSD layers. For further information, 
see “Rendering Layered PSD Files” on page 434.

Once you have finished entering your desired settings, click 
OK to store them. Render settings are saved when you save 
your scene. Clicking Cancel closes the Render Settings dialog 
without storing your changes.

To render your scene as a still image, select Render > Render or 
click the Render Now button in the Render Settings dialog.

To render animations, please refer to “Keyframe Controls” on 
page 452 for more information.

Saving and Loading Presets
Although FireFly settings are not saved with your Poser scene, 
you can save and load FireFly Presets (including both Auto and 
Manual Quality settings, as well as FireFly Options settings). 
Simply click on the appropriate Preset button along the bottom 
of the FireFly tab for the function you wish to perform. The Load 
Preset and Delete Preset buttons will display pop-up menus 
listing the presets that shipped with your copy of Poser, as well 
as any additional presets you may have saved. Note that if you 
make changes to a loaded preset, your changes will not be saved 
unless you use the Save Preset button to record them. The Save 
Preset button will allow you to save the current FireFly render 
settings with a name of your own choosing. The Restore Defaults 
button will restore all FireFly render settings to their default 
locations.

Smoothing Geometry
Poser provides some additional features that make geometry 
look smoother during render time, without having to add 
additional geometry. The smooth shading feature affects an 
object’s shading without changing the geometry of its edges. 
Smooth shading will render creased edges between polygons 
as rounded, continuous surfaces rather than as hard edges. In 
this way, smooth shading allows you to achieve a consistently 
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smooth shading effect, without having to alter the geometry by 
subdividing polygons to minimize the creases.

By default, if there are no smoothing groups specified, smooth 
shading will be applied to all figures and objects within a scene, 
according to the Crease Angle specification in the Properties 
palette for each given current actor. Additionally, you can 
customize smooth shading in one of two ways, as described in 
the following sections.

Geometry smoothing is affected by the following settings, as 
described in the sections that follow:

• Crease angles, as set in an actor’s Properties palette or 
globally in the Document tab of the General Preferences 
dialog.

• Smoothing groups, definable in the Group Editor.

• The Smooth Polygons option in the Firefly Render 
Settings dialog.

Crease Angle

Crease angle represents the angle between the normals of 
adjoining polygons. The Crease Angle property establishes a 
threshold up to which smooth shading will be applied. In other 
words, if the crease angle threshold is set to 70, smooth shading 
will be applied to all polygon creases with angles smaller than 70 

degrees. Polygon creases with angles greater than 70 degrees will 
not be smoothed.

You can specify the Crease Angle threshold in the Properties 
palette for each individual actor within a figure or object. By 
default, Crease Angle is set to 80 degrees for all actors.

 You can set crease angles for an element in the Properties dialog.

To change the crease angle globally, select Edit > General 
Preferences, and click on the Document tab.
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 Global scene crease angles can be set in the General Preferences 
dialog.

The following images provide examples of a sphere with crease 
angles set at 10 degrees and 80 degrees, respectively.

 Different crease angle settings: 10 degrees (left) and 80 degrees 
(right).

Smoothing Groups

You can use the Group Editor palette to establish smoothing 
groups, which define the specific polygons to which smooth 
shading should be applied. This approach is useful in that it 
allows you to customize smooth shading at the polygon level, 
and gives you the ability to have hard edges intermixed with 
smooth creases. Smoothing group settings will override the 
crease angle setting for those specific polygons.

Select the Grouping tool from the Editing Tools palette, which 
will bring up the Group Editor palette. You can either assign all 
polygons in one or more of your figure’s existing object groups 
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to smoothing groups, or you can create specific new smoothing 
groups, which will enable you to customize smooth shading at 
the polygon level. Please refer to “The Group Editor” on page 
681 for more information about creating new groups.

 Assign Smoothing IDs in the Group Editor.

Once you have your groups established, simply click on the 
Assign Smoothing ID button to designate the currently selected 

group as a smoothing group. At render time, polygon creases 
between all adjoining polygons within the same smoothing 
group will be smoothed. Polygon creases between adjoining 
polygons in different smoothing groups will not be smoothed, 
and will therefore be rendered as hard edges. Thus you should 
take care as to which Smoothing ID you assign to each specific 
polygon group.

Different polygon groups can be assigned the 
same Smoothing ID, which will ensure smooth 

shading across the geometric breaks between groups. To 
do this, simply create a smoothing ID for the initial 
group, and then select that same ID from the pop-up list 
when assigning Smoothing ID’s to the other groups.

Poser will recognize and support existing smoothing groups 
in imported geometry. Thus, if you import figures or objects 
from another 3D application, Poser will apply smooth shading 
according to the imported smoothing group definitions, in the 
same manner as if the smoothing groups had been assigned 
within Poser.

Smooth Polygons

In the render settings, smooth polygons activates polygon 
subdivision to smooth hard edges at render time. If your image 
contains visible rough edges because your polygon mesh is 
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sparse, then the render time polygon smoothing can render 
those edges smooth. See “FireFly Options Settings” on page 
417 for more information about applying this option.

 Enable or disable Smooth Polygons settings in the Render Settings 
dialog.

Note that the render time polygon smoothing will not override 
hard edges specified by either the crease angle or smoothing 
groups. Thus, you can specify hard edges definitively using either 
of those methods, and still apply render time polygon smoothing 
to all other edges.

The following figure illustrates the render time polygon 
smoothing effect. On the left is a sphere with a crease angle set to 

80 degrees, with no polygon smoothing. On the right is the same 
sphere with polygon smoothing enabled.

 Spheres shown without (left) and with (right) polygon smoothing.

Network Render Queue
Rendering large and complex scenes (jobs) can take a long time 
to process and monopolize your computer system. The Queue 
Manager distributes jobs between one or several nodes in a 
Network Render Queue. When you use the Queue Manager for 
remote tasks, the Network Render Queue will distribute jobs 
based on the systems that are available. You can send single-
frame or multiple-frame jobs to the Queue Manager.
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Sending Jobs to the Queue Manager

Once the Queue Manager is running on your system and/or on 
another network node, you can send jobs to render in the Queue. 
Poser Pro will launch the Queue Manager if it is not already 
running on your system. However, in order process a job in the 
Network Render Queue, the Queue Manager must be running on 
the remote system(s).

The first time you send a job to the Queue Manager you will be 
prompted to locate the Poser Pro application using the standard 
File Chooser. Navigate to where the Poser Pro application is 
installed, select Poser Pro and click OK.

Using the Render Queue for a Single-Frame job

To send a single-frame job to the Render Queue, from the Main 
Menu, select Render > Render In Queue. The current frame 
with the current FireFly Render Engine settings will become the 
rendered job. Name the job, select a file format from the pull-
down menu, and specify the output location. Click Save. This 
will submit the job to the Queue Manager and add the job to the 
job list. Sending a job to the Queue launches the Queue Manager 
if it is not already running.

When you send a single frame render to the 
Queue, the filename that you enter will be 

appended by the frame number that you are rendering. 
For example, if your project is on frame 30 when you 
render a still image, the image that is rendered in the 
Queue will be named (filename)_0030. Previous renders 
of the same frame will be overwritten.

 The Render in Queue command creates a render job.

Using the Render Queue for a Multi-Frame Job

To send a multi-frame job to the render queue, from the Main 
Menu, select Animation > Make Movie. In the Movie Settings 
dialog select Image Files from the Format pull-down menu. 
The Movie Settings will become the job properties, including: 
Options, Resolution, Time Span and Increment. (For more 
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information on Movie Settings refer to “Movie Settings” on page 
402).

 The Movie Settings tab in the Render dialog.

Once the movie settings have been defined they 
cannot be changed, and the job will retain those 

properties when sent to the Render Queue.

Next, switch to the Render Settings tab. Click on Send Render 
To and select Queue. Name the job, select a file format from the 
pull-down menu, and specify the output location. Click Save. 

This will submit the job to the Queue Manager and add the job 
to the job list. Sending a job to the Queue launches the Queue 
Manager if it is not already running.

 Rendering to the Render Queue.

Once you have submitted a job to the Queue, you can begin 
editing, start another project in Poser Pro, or start working in 
another application.
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Using the Queue Manager

The Queue Manager has three sections: The Queue Menu, the 
Job List and the Selected Job Panel.

Queue Menu

The Queue Menu allows you to configure how jobs are 
distributed for processing.

 The Render Queue menu.

• Suspended: Selecting Queue > Suspended, suspends the 
operation of all jobs.

• Process Jobs Locally: Enabling or disabling Queue > 
Process Jobs Locally, specifies whether or not the Queue 
Manager will use your local system to render your jobs.

• Send Jobs to Network: Enabling or disabling Queue > 
Send Jobs to Network, specifies whether or not the Queue 
Manager will distribute jobs to other systems.

• Accept Jobs from Network: Enabling or disabling Queue 
> Accept Jobs from Network, specifies whether or not the 
Queue Manager will process tasks from other systems. Local 
jobs will always have priority.

• Show Log Panel: Enabling Show Log Panel lets you see 
a detailed log of the jobs being processed. The Log can be 
useful for troubleshooting and tracking how other machines 
are being utilized.

Job List

The Job List shows a job’s properties including Document, 
Output File, Start Time, Completed Time, Status, Frame, 
Start, End, Increment, Host and Order. On the Selected Job 
Panel sort the jobs by clicking on any of the property headers. 
This will not change the job order.
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 The Render Queue Job List.

• Document: The name of the document in Poser Pro.

• Output File: The job name when submitted to the Queue.

• Start Time: The time the job was received by the Queue 
Manager.

• Completed Time: The time the job was completed.

• Status:

 � Running: The job is currently being processed.

 � Waiting: The job is waiting to be processed.

 � Suspended: The job is on hold.

 � Done: The job is processed and is shown on the job list 
for reference.

• Frame: Indicates the frame that is currently being rendered.

• Start: Derived from the movie settings dialog (see “Movie 
Settings” on page 402).

• End: Derived from the movie settings dialog (see “Movie 
Settings” on page 402)

• Increment: Derived from the movie settings dialog (see 
“Movie Settings” on page 402).)

• Host: Indicates the node this job came from.

Selected Job Panel

Select a job to access the following options.

 The Selected Job panel.

• Output Path: Displays the output location of a selected job.

• Go To Folder: Find the output location of your job anytime 
by highlighting the job and clicking on the Go To Folder. 
This will bring you to the output location.
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• Order: Once a job is sent to the Queue Manager the job will 
appear on the job list. You can change the order of the jobs 
by selecting <<Lower or Raise > > .

• Actions: Select a job from the Job List to change its status 
using the following actions:

 � Cancel: Click Cancel to abort a job (Running, Waiting 
or Suspended).

 � Delete: Click Delete to remove a completed job from 
the Job List (Done).

 � Suspend: Click Suspend to put a running or waiting 
job on hold.

 � Resume: Click Resume to continue processing a 
suspended job.

If you are experiencing difficulty with the Network Render 
Queue, verify the following:

• All network cables are plugged in and the network is 
functioning properly.

• Remote systems in the Network Render Queue are up and 
the Queue Manager application is installed and running.

• Your personal firewall is allowing communication between 
Poser Pro and the Queue Manager, locally and remotely.

• If you are unable to resolve a network communication issue, 
contact your Network Administrator.

64-Bit Render Engine
Poser Pro ships with 2 versions of its FireFly render engine: 
A 32-bit and a 64-bit version. Traditionally computers utilize 
a 32-bit Operating System, which can only address a limited 
amount of memory. However, there is an increasing amount of 
computers that are equipped with a 64-bit Operating System. If 
your computer has a 64-bit Operating System, Poser Pro will use 
its 64-bit FireFly Render Engine to access as much memory as 
possible.

To utilize the 64-bit FireFly Render Engine, you must select 
Render in Background (Mac OSX, Windows) or launch the 
64-bit version of Poser Pro (Windows only).

Hardware Requirements for 64-bit Render 
Engine

• Intel Core 2 Duo CPU or better

• AMD Athlon 64 CPU or better

Poser Pro supports the following 64-bit operating systems:
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• Mac OS X 10.6 

• Mac OS X 10.7

• Mac OS X 10.8

• Windows XP x64

• Windows Vista 64

• Windows 7 64

• Windows 8 64

Poser Pro will automatically select the appropriate Render 
Engine for your system. If you are using a 32-bit system and 
render in Firefly, Poser Pro will use the 32-bit Render Engine. 
If you are using a 64-bit system and render in FireFly, it will 
use the 64-bit Render Engine. This allows the Render Engine to 
access more memory thereby better utilizing available memory.

Gamma Correction and Linear 
Rendering
By configuring the gamma correction you can specify the gamma 
that has been applied to textures, and the gamma that will be 
applied to exported images. This allows you to perform linear 
rendering for improved luminance accuracy.

When you create a new scene, the default setting for Linear 
Rendering is 2.2. You must use the FireFly Render Engine to 
set the gamma value. When you are opening a document from 
a previous version of Poser, you will need to enable the gamma 
correction if you want to perform linear rendering.

Gamma settings are propagated to the Preview 
Renderer when hardware shading is enabled. 

There is no separate gamma configuration option for 
the Preview renderer; instead, they are taken from the 
Firefly render settings, Texture Manager, and gamma 
nodes in the Advanced Material Room.

HDRI files will be read and written in a linear fashion with a 
Gamma value of 1.0, ignoring whatever gamma value might be 
specified in that location.

To enable Gamma Correction, choose Render > Render 
Settings, select the FireFly Tab and then check the Gamma 
Correction Box from the Options Panel. The default gamma 
value is 2.2 for most image formats. You have the option to 
specify a custom gamma value in the text field. The text field is 
only accessible only when the Gamma Correction Box is enabled.
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 Set the Gamma Correction value in the Render Options window.

Gamma Correction Per Texture
Poser Pro’s Gamma correction on the Texture Manager allows 
you to specify gamma values per texture, giving you the ability to 
exclude certain textures from scene-wide gamma correction for 

maximum flexibility when dealing with displacement or normal 
maps.

 Gamma correction for individual textures can be set in the Texture 
Manager.

Local gamma correction is important if you know that not all 
your incoming data has the same gamma value applied and you 
know you need to adjust the value for certain textures. Gamma 
correction on the Texture Manager allows correction per texture.
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Most all applications read and write 
displacement maps linearly, even if the format 

used might specify a different gamma value. When you 
display a displacement map, it might look slightly 
different from the effect it will end up having on the 
geometry, therefore we recommend that you adjust the 
Gamma Value to 1.0 for Displacement Mapping, as well 
as for Normal Maps. Also use 1.0 for Transparency, or 
whenever a grayscale map is used to drive an effect.

For information on how to access the Texture 
Manager please refer to “Chapter 17: The 

Render Menu” on page 392.

Once you are in the Texture Manager you can specify a custom 
gamma value in the text field for the selected texture.

Rendering Layered PSD Files
Poser features additional options in the Render Settings 
dialog that allow you to specify additional information that 
can be output to a layered PSD file for further compositing 
in Photoshop. After you create your scene in Poser, you open 
the Render Settings dialog and check or uncheck the auxiliary 
render data options that you want to include in the Photoshop 
file. Then, you render your image and save it as a Photoshop PSD 

file. When you open your image in Photoshop you will see the 
full render as the Background layer. Each additional data option 
that you checked will appear on its own individual Photoshop 
layer.

The Render Options section of the Render Settings window 
includes an Auxiliary Render Data drop down menu that allows 
you to select from the following options:
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 Check or uncheck layers to be output to PSD files in the Render 
Options window.

When you open your PSD in Photoshop, the complete rendered 
image appears in a layer named Background. Depending on the 

other options that you check in the Auxiliary Render Data drop-
down, you may see additional layers as described below.

 Background layer in Photoshop.

• Normal: The world space normal of the frontmost surface, 
encoded as RGB values with x=red, y=green, z=blue. 
Normal layers are identified by the letter N in Photoshop.
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 Normal layer in Photoshop.

• Toon ID: The toon ID of the frontmost surface, where each 
ID gets its own RGB color. Toon ID layers are identified by 
the letters ID in Photoshop.

 Toon ID layer in Photoshop.

• ZDepth: The distance of the frontmost surface from the 
camera, encoded as grayscale. ZDepth layers are identified 
by the letter Z in Photoshop.

 ZDepth layer in Photoshop.

• Position: The world space position of the frontmost surface, 
encoded as RGB values with x=red, y=green, z=blue. 
Position layers are identified by the letter P in Photoshop.
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 Position layer in Photoshop.

• Texture Coordinates: The UV coordinates of the frontmost 
surface, with u = red and v = green. Texture Coordinate 
layers are identified by the letters UV in Photoshop.

 Texture Coordinates layer in Photoshop.

The remaining three options correspond to three inputs on the 
bottom of the Poser Surface Node as shown below.

 Custom Output connectors on the Poser Surface Node.
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The render will export the nodes that are plugged into these 
inputs on the Poser Surface Node. If nothing is attached to the 
Poser surface node on these inputs, the output to PSD is as 
follows:

• Custom1: If your scene contains any materials that have 
connections to the Custom_output_1 connector on the 
PoserSurface Node, they can be rendered to a Photoshop 
layer when you check this option. If there are no materials 
with connections to Custom_output_1, checking this option 
will create a layer that contains Diffuse only.

 Custom 1 layer in Photoshop with grainy grayscale effect for 
custom input.

• Custom2: If your scene contains any materials that have 
connections to the Custom_output_2 connector on the 
PoserSurface Node, they can be rendered to a Photoshop 

layer when you check this option. If there are no materials 
with connections to Custom_output_2, checking this option 
will create a layer that contains Specular only.

 Custom 2 layer in Photoshop showing custom adjustments to the 
two characters in the scene.

• Custom3: If your scene contains any materials that have 
connections to the Custom_output_3 connector on the 
PoserSurface Node, they can be rendered to a Photoshop 
layer when you check this option. If there are no materials 
with connections to Custom_output_3, checking this option 
will create a layer that contains Shadow only as shown 
below.
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 Custom 3 layer in Photoshop.

After rendering the desired layers, you can bring the saved PSD 
file into Photoshop, where you will be able to use blend styles 
in the Layers palette to composite the layers together to create 
interesting effects.

 Various layers combined in Photoshop.
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Chapter 20: The Sketch 
Designer

Poser’s Sketch Designer renders scenes as sketch-like drawings 
using black-and-white or colored brush strokes that you can 
tailor to your liking. Simulate pen, pencil, pastel, charcoal, and 
even watercolors and paintings without ever having to pick up a 
pencil or brush!

 The Sketch Designer.

You can save Sketch Designer renders and reload them later 
for further work. The Sketch Designer also lets you create 
amazing animations that look like hand-drawn movies. For best 
results, try rendering scenes using plenty of detail (hair, clothing, 
etc.) and dramatic lighting.

To access the Sketch Designer, select Window > Sketch 
Designer. Alternately, you can access the Sketch Designer 
via the Sketch tab in the Render Settings dialog, which also 
contains other render and movie settings.

Sketch Elements
The Sketch Designer recognizes three distinct divisions within 
your scene:

• Objects: Checking the Objects radio button allows you to 
determine the sketch style for objects and figures in your 
scene.

• Background: Checking the Background radio button 
allows you to determine the sketch style for your scene’s 
background.

• Edges: Checking the Edges radio button allows you to 
determine the sketch style for the edges of objects and 
figures in your scene.
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Presets
You can use the Presets pop-up window above the preview tab 
to select one of the available preset sketch styles. You can also 
use the sliders and other options to create an almost infinite 
variety of styles.

The Presets pop-up also allows you to create and remove sketch 
presets. To create a preset, adjust the sketch style to your desired 
settings, then select Presets > Create Preset. Enter a name 
for your preset and click OK. Your new preset will appear in the 
Presets menu.

To delete a preset, select the preset you wish to delete using the 
Presets menu, then select Presets > Delete Preset.

The Delete Preset option allows you to remove 
the sketch presets included with Poser. Once 

deleted, you must reinstall Poser to restore your factory 
default sketch presets.

Checkboxes
The Sketch Designer has three checkboxes:

• Over Black: Checking the Over Black checkbox renders 
your scene over a black background with white strokes. 
When disabled, the background is white with black strokes.

• Auto Density: Checking the Auto Density checkbox causes 
stroke density to reach an automatic density based on the 
current scene, ignoring the Density slider setting (see 
below). When disabled, the density is calculated based on 
the Density slider setting.

• Colored Strokes: Checking the Colored Strokes checkbox 
causes sketches to be rendered in color. When disabled, 
sketches are rendered in black and white.

Brushes
The Sketch Designer includes several predefined brushes, 
available using the Brushes pull-down menu. For maximum 
effect, try using these brushes with both the Min Width and Max 
Width sliders set to higher values.

Sketch Parameters
The Sketch Designer includes the following parameters, 
controllable using sliders. Moving a slider to the right increases 
the selected value, and vice versa. These parameters customize 
many characteristics of the sketched lines. Your sketch redraws 
each time you adjust a value, allowing you to see the results of 
your changes.
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• Density: The Density slider controls the density of lines in 
the sketch.

• Line Length: The Line Length slider defines the length of 
strokes.

• Min Width: The Min Width slider defines the width of the 
edge of each stroke, which affects the brightness of the 
original image.

• Max Width: The Max Width slider defines the width of the 
center of each stroke, which affects the brightness of the 
original image.

• Lo Brightness: The Lo Brightness slider determines the 
band of tone. A low setting only draws lines in the darkest 
parts of your scene. If the Over Black option is disabled, 
setting this control to 0 produces the best results.

• Hi Brightness: The Hi Brightness slider determines the 
band of tone. A lower setting only draws lines in the darkest 
parts of your scene. If the Over Black option is enabled, 
setting this control to 1 produces the best results.

• Stroke Head: The Stroke Head slider determines the 
amount of taper at the stroke’s head.

• Stroke Tail: The Stroke Tail slider determines the amount 
of taper at the stroke’s tail.

• Line Random: The Line Random slider controls line 
randomizations. Higher settings result in more randomly 
shaped lines.

• Color Random: The Color Random slider controls color 
randomizations. Higher settings result in more random 
colorization.

• Opacity: The Opacity slider determines the clarity of lines. 
Lower values create more transparent strokes.

• Cross Hatch: The Cross Hatch slider controls the 
frequency of cross-hatching in the strokes.

• Total Angle: The Total Angle slider determines the total 
amount of angle change that a stroke can have before it 
stops drawing. Higher values darken the image. Lower this 
value when you have lower Density settings.

• Color Cutoff: The Color Cutoff slider determines the 
threshold of color changes allowed for a stroke. Use this 
slider in conjunction with Total Angle.

• Light 1, 2, and 3: The Light 1, Light 2, and Light 3 sliders 
determine the extent to which the first three lights in your 
scene contribute to the direction of strokes. Higher values 
make the strokes go in the direction of the selected light(s).
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• BG Direction: The BG Direction slider defines the direction 
of the background strokes.

• Auto Spacing: The Auto Spacing slider controls the 
amount of space between strokes if the Auto Density option 
is enabled.

• Color Blend: The Color Blend slider determines how much 
color in the Document window will be blended into the 
sketch.

Rendering Sketches
After setting up your sketch, you can render it to the Document 
window. This is useful if you want to export a movie rendered 
using the Sketch Designer renderer. To render to the Document 
window, select Render > Sketch Style Render.

Exporting Painter Scripts
Clicking the Export Painter Script button in the lower left 
corner of the Sketch Designer exports the current Sketch 
Designer settings to Corel Painter. This has been tested to work 
with Painter 6 and previous versions, and is not supported for 
later versions though it may work with them.
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Part 5: Animating
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Chapter 21: The 
Animation Menu

The Animation pull-down menu lets you control various aspects 
of your Poser animations.

Make Movie
Setting Animation > Make Movie opens the Make movie 
window. Please refer to “Chapter 24: Rendering Animations” 
on page 510 for more information on rendering animations in 
Poser.

Recalculate Dynamics
Choose one of the options in the Animation > Recalculate 
submenu to recalculate all cloth dynamics, all hair dynamics, all 
physics dynamics, or all dynamics. For more information about 
dynamics, see “Chapter 26: The Hair Room” on page 533, 
“Chapter 27: The Cloth Room” on page 550, and “Chapter 23: 
Using Bullet Physics” on page 493.

Retime Animation
Selecting Animation > Retime Animation allows you to 
adjust the timing of your animations. Please refer to “Retiming 
Keyframes” on page 467 for more information.

Resample Key Frames
Selecting Animation > Resample Key Frames opens the 
Resample Keys window, which allows you to increase or 
decrease the number of keyframes in your animation: Please 
refer to “Resampling Key Frames” on page 468.

Loop Interpolation
If your animation contains looping cycles (such as a walk) that 
do not match evenly (causing jerky motions between the end of 
one loop and the start of the next), toggling Animation > Loop 
Interpolation on can smooth out your animation.

Quaternion Interpolation
Quaternion interpolation is a mathematical formula that can 
smooth rough animations. If your animation remains jerky 
after editing keyframes and all other efforts at smoothing it out, 
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selecting Animation > Quaternion Interpolation can possibly 
help. This option should be toggled on as a last resort.

Skip Frames
Selecting Animation > Skip Frames toggles skipping frames on 
and off. This option can help speed playback.

Mute Sound
Selecting Animation > Mute Sound toggles sound muting 
during animation playback. A check mark appears when muting 
is enabled, and vice versa.

Clear Sound
Selecting Animation > Clear Sound deletes the sound 
previously imported into your Poser scene.

Play Movie File
Selecting Animation > Play Movie File allows you to open a 
movie file for playback within Poser. A standard Open dialog 
appears, allowing you to browse to your desired movie file.
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Chapter 22: Animating 
with Poser

Poser allows you to animate figures and props, giving life to your 
scenes. You can use your work in multimedia projects, on the 
Web, and in videos by exporting rendered results to Windows 
AVI, Macintosh QuickTime, or Flash movie format. AVI movies 
are rendered in 32-bit color, which by default includes an alpha 
channel (mask) for each frame. This can aid in compositing the 
animation with other movie footage. QuickTime movies can also 
contain an Alpha channel if set to render at millions of colors.

Once rendered, exported animations can be opened and edited 
in post-production tools such as Adobe Premiere and Adobe 
After Effects, where you can edit sequences and add special 
effects. While you can create long animations, we recommend 
creating a series of shorter animations and piecing your scenes 
together using an editing application. Real movies follow this 
guideline as well: Each time a camera angle changes, you’re 
seeing a new take of a scene or a different scene altogether. 
This includes cases such as conversations, where the camera 
is switching back and forth between the participants. Poser 
includes many powerful tools designed to help you create 
stunningly realistic animations. Animation is easy to learn but 
hard to master. Start with short simple movies and work up as 
your skills improve. The results may surprise you!

Animation Overview
At its simplest, the animation process is as follows:

1. Decide how many frames you want in your animation. One 
way to do this is to decide how long your animation will be 
in seconds, then multiply that by the your desired number of 
frames per second (frame rate).

2. Create a starting pose.

3. Select your next keyframe.

4. Create a new pose.

5. Repeat Steps 3 and 4 until your animation is complete.

Poser uses a technique called keyframe animation to simulate 
motion based on a series of still poses. You set up a series of 
poses at different points in time. These are the keyframes. Poser 
fills in the gaps, interpolating between keyframes to create the 
illusion of motion. This keeps you from having to move your 
figure each time you want to create a motion, such as is done 
in stop-frame animation, where each frame is individually 
positioned (many “Claymation” movies use stop-frame 
animation).
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What You Can Animate

What can you animate using Poser? Just about everything! Here 
are some examples:

• Figures (humans, animals, clothing, etc.): If you can 
imagine a motion, you can create it using Poser! Please 
refer to “Chapter 9: Posing Figures” on page 176 for 
information about posing human figures, and to “Posing 
Animals” on page 210 for some information about posing 
animals.

• Hands: Gestures and small motions add incredible 
realism to videos. Many amateur animators ignore hands 
when animating, which subtly detracts from your scene’s 
realism. Please refer to “Posing Hands” on page 208 for 
information about posing hands.

• Faces: Animating faces can add emotion and power to your 
scene and can also mimic speech. Please refer to “Posing 
Faces” on page 204 for more information about posing 
faces.

• Props: You can animate props by moving them about the 
Poser workspace, parenting them to other actors, etc. Please 
refer to “About Props” on page 219 for more information 
about props.

• Lights and Cameras: Change color and position of lights 
and zoom, pan, or bank cameras over time.

• Deformers: You can animate magnets, waves, morph 
targets, and parameters. Please refer to “Using Deformers” 
on page 615 for more information about deformers.

• Force Fields: You can animate Force Fields to create 
realistic wind effects for strand-based hair and dynamic 
cloth. Please refer to “Wind Force Fields” on page 633 for 
more information about force fields.

• Materials: You can animate material shaders as described in 
“Part 3: Materials” on page 280.

• Walk Paths: You can create paths that your figures walk 
along, as described in “Creating a Walk Path” on page 
478.

• Background: You can animate the background using the 
Material room. Please refer to “Part 3: Materials” on page 
280 for more information about the Material room.

• Movie nodes: You can play movies on any object using 
movie nodes in the Material room.

By default, your animation moves over the Document window’s 
background. You can have still or animated backgrounds in your 
scenes. Please refer to “Importing Background Pictures” on 
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page 778 and to “Importing Movies” on page 777 for more 
information about backgrounds in Poser scenes.

Inverse Kinematics

You can use IK or not in your animations, however it is a global 
setting. If enabled on a figure’s limbs, it’s on for the duration of 
your animation, and vice versa. You can turn it on or off while 
you work, but the final state is what will “stick” in your final 
animation. Toggling IK on and off can affect your animation; it’s 
best to pick an option before starting to animate and stay with 
it to avoid having unexpected changes occur in your animation. 
Please refer to “Inverse Kinematics (IK)” on page 177 for 
more information about Inverse Kinematics.

Animation Tools

Poser has five animation tools:

• Animation controls: The simple, single channel Animation 
controls allow you to create quick click-and-drag animations 
as well as preview your work. Access the Animation 
controls by clicking the handle at the bottom of your Poser 
workspace. See “Using the Animation Controls” on page 
450 for more information.

If not displayed, choose Window > Animation 
Controls to show the Animation Controls. They 

will dock or float depending on how you last used them.

• Animation Palette: The Animation palette contains the 
advanced editing features, with which you can create more 
complex animations. Among other things, you can edit 
keyframes, animation layers and individual actors, and 
create Animation Sets. Access the Animation palette by 
selecting Window > Animation Palette. Please refer to 
“Using the Animation Palette” on page 454 for more 
information about the Animation palette.

• Graph: Each actor in your scene has a Graph for each of its 
possible motions, allowing you to exercise minute control 
over your animations. Access the Graph for any parameter 
by using the desired parameter dial’s menu as described in 
“Parameters Palette” on page 197. Please refer to “Using 
Graphs” on page 458 for more information about the 
Graph.

• Walk Designer: Creating realistic walking movements is 
a very time consuming animation task to get right. Poser’s 
Walk Designer takes the effort out of this process and lets 
you quickly create realistic walks (for human figures only). 
Access the Walk Designer by selecting Window > Walk 
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Designer. Please refer to “Using the Walk Designer” on 
page 474 for more information about the Walk Designer.

• Talk Designer: Speech is one of the most important 
aspects of many animations; due to the complexity of the 
human face, it is also one of the most challenging things to 
animate realistically. Poser’s Talk Designer animates facial 
expressions, eye and head movements to create realistic lip 
sync animations based upon speech sound files that you 
import. Access the Talk Designer by selecting Window > 
Talk Designer. Please refer to “Using the Talk Designer” on 
page 482 for more information about the Talk Designer.

Using the Animation Controls
The Animation controls are dockable and floatable. This 
palette contains the tools most commonly used when creating 
animations. They allow you to add and edit keyframes and 
preview your animation. If the Animation controls do not appear 
on your screen, choose Window > Animation Controls and 
place them where you find it most convenient (generally the top 
or bottom of your document window is the common location). 
The Animation controls appear as follows, and consists of the 
controls described in the following sections:

 Animation Controls.

Timeline/Frame Indicator

The center portion of the Animation controls displays the 
Timeline, which represents the total time of your animation in 
Poser. This timeline contains a pointer (Scrubber) representing 
the location of the current frame relative to the entire animation, 
which is visible in the Document window. The Scrubber is very 
commonly used to quickly find specific points within animations. 
Click and drag the Scrubber to quickly navigate your animation.

Just above the Scrubber is the Frame Indicator, which 
indicates both the total number of frames in your animation 
and your current position within that timeline, with the left field 
indicating position and the right indicating animation length. 
For example, if the two numbers read 60 and 120, that means 
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that you are viewing the 60th frame of an animation that is 120 
frames long.

You can jump to a specific frame by clicking the left number 
field and entering the frame number you wish to jump to. You 
can also add or remove frames by clicking the right number field 
and entering the number of frames you wish in your animation. 
Entering a larger number lengthens your animation and vice 
versa. Shortening animations will cut the excess frames from the 
end. For example, if you reduce an animation from 120 to 90 
frames, you will lose the final 30 frames.

Recording Keyframes

Poser records changes made to figures, props, materials, etc. as 
keyframes. Create keyframes by moving the scrubber to a new 
point on the timeline and making your desired change(s) to 
your scene. Recorded keyframes store new body part positions, 
new prop positions, material settings, etc. for each figure and 
prop within your scene. You can only record one set of position 
parameter settings for any given keyframe. For example, if you 
select a frame and move a figure’s arm up then change your 
mind and move the arm down again, the downward position is 
what will be “remembered” and what will affect your animation. 
To make a figure’s arm wave up and down:

1. Select a starting pose.

2. Move the scrubber to the point in time/frame number you 
wish to edit.

3. Raise the arm using the Editing tools.

4. Move the scrubber to a later point in time/frame number.

5. Lower the arm, again using the Editing tools.

6. Continue creating keyframes until the motion sequence is 
complete.

Camera animation must be enabled for the 
currently selected camera In order to 

automatically record keyframes. If animation is 
disabled, you can add keyframes manually (see 
following subsection).

Play Controls

The Play controls appear on the left side of the Animation 
controls and allow you to preview your animation using VCR-
like controls. From left to right, the Play controls are as follows:
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 The Play Controls.

• First Frame: Clicking the First Frame button moves to the 
first frame in your animation.

• End Frame: Clicking the End Frame button moves to the 
last frame in your animation.

• Stop: Clicking the Stop button stops animation playback at 
the current frame.

• Play/Pause: Clicking the Play button plays your animation 
at normal speed, including background movies and sounds 
(if any). While your animation is playing, this button 
becomes the Pause button. Clicking it freezes the animation 
at the current frame.

• Step Backward: Clicking the Step Backward button 
moves back to the previous frame (i.e., the frame before the 
current one).

• Step Forward: Clicking the Step Forward button moves 
forward one frame (i.e., the frame after the current one).

• Loop: Checking the Loop radio button causes your 
animation to repeat itself continuously when playing until 
you click the Stop button.

• Animation previews run in the Document window. Be 
sure to select the appropriate tracking mode (see “Tracking 
Mode” on page 93).

Keyframe Controls

In most cases, Poser’s automatic animation engine records 
keyframes as you create animations. Sometimes, however, 
you’ll want to manually add keyframes, such as when camera 
animation is disabled. It is important for you to track the status 
of camera animation, as you could create a series of keyframes 
without realizing that the animation is off. As mentioned 
above, if camera animation is disabled, you must manually add 
keyframes in order to record them. You may also need to fine-
tune animations, which may necessitate recording additional 
keyframes. For example, you could position the figure’s left 
foot at Frames 10 and 20, with Poser calculating its position for 
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the tween frames. If you wanted to refine this, you could add a 
keyframe at Frame 15.

The Keyframe controls allow you to quickly and easily add, 
preview, and remove keyframes within your animation. From 
left to right, the Keyframe controls are:

 The Keyframe Controls.

• Previous Keyframe: The Previous Keyframe button 
returns to the previous keyframe.

• Next Keyframe: The Next Keyframe button advances to 
the next keyframe.

• Edit Keyframes: Clicking the Edit Keyframes button 
opens the Animation Palette, discussed next.

• Add Key Frames: Clicking the Add Key Frames button 
adds a keyframe at the current frame number. For example, 
if you have existing keyframes at Frames 15 and 30, you 
could drag the Scrubber to Frame 22 and insert a keyframe 
by clicking the Add Key Frames button. You can also 
insert a keyframe by moving to any frame in your animation 
and making a change in your scene. This change will 
automatically be recorded as a new keyframe.

• Remove Key Frames: Clicking the Remove Key Frames 
button removes the currently selected keyframe. For 
example, if your character’s arm is over his head in Frame 
1, down at Frame 15 and out to the side in Frame 30 and 
you remove the keyframe in Frame 15, the figure’s arm will 
move out to the side position specified in Frame 30 without 
dropping to the figure’s side. To delete a keyframe, use the 
Next Keyframe or Previous Keyframe buttons to locate 
your desired keyframe, then click the Remove Keyframe 
button.

• Skip Frames: Check this radio button to skip frames during 
playback. This helps conserve system resources while 
previewing your animation before you render it.
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Using the Animation Palette
The Animation palette contains three tabs: the Keyframes 
tab, the Layers tab, and the Animation Sets tab. Each of these 
tabs will be described in detail in the following sections. To 
display the Animation palette, you can either select Window 
> Animation Palette, or click the Display Animation Palette 
button in the Animation controls as described above. To close 
the palette, either select Window > Animation Palette again, or 
click the small box in the upper left corner.

The upper section of the Animation palette contains several 
controls that appear on all three tabs. These are as follows:

Common Controls

Several controls and options are common to all of the tabs in the 
Animation Palette. These options are discussed below.

 The Animation Palette.

Current Layer

The Current Layer pop-up menu appears at the very top of the 
Animation palette. This menu allows you to select a specific 
animation layer within the current animation. Please refer 
to “Layers Tab” on page 469 for more information about 
animation layers.
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Frame Rate

The frame rate specifies the number of frames played per 
second. To change the scene frame rate, you can either click the 
current frame rate and enter your desired number in the text box 
that appears or click the arrow to the left of the current frame 
rate and make your selection from the Frame Rate pull-down 
menu. Choices are 12, 15, 18, 24, 25, 30, 50, and 60 frames per 
second. Some common frame rate settings are:

• NTSC: 30

• PAL: 25

• Film: 24

• Flash: 12 (recommended) or 15

For Poser integration into other apps, the user 
will need to determine the frame rate to match 

that of the hosting software. The default frame rate in 
Poser is 30 fps, but other applications might use 24 fps. 
Users will need to create a file with the same frame rate. 
This needs to be handled specially for each app.

You can also set the output frame rate using the 
Movie Settings window ( “Keyframe Controls” 

on page 452). This setting is independent from your 
scene frame rate, as specified in the Animation palette 
(see above). Additionally, you can generate a quick 
preview render by specifying the Every N-th Frame 
setting in the Movie Settings window. Again, this 
setting is for output purposes only, and is independent 
of your scene frame rate.

Time

The Time control displays the amount of time in your animation 
between the first frame and the currently selected frame. Time 
is displayed in SMTPE format (Hours:Minutes:Seconds:Frame). 
You can jump to a specific point in time by entering your desired 
numbers in the fields. For example, if you jump to 1 minute in 
an animation using 24 frames per second, you’ll arrive at Frame 
1440 (24 frames/sec times 60 seconds).

Frame

The Frame Indicator is identical to its counterpart in the 
Animation controls. You can jump to a specified frame and 
add or remove frames from your animation as described in 
“Timeline/Frame Indicator” on page 450.
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Play Controls

The Play controls are identical to their counterparts in the 
Animation controls. See “Play Controls” on page 451 for more 
information.

Play Range

By default, the entire animation plays when previewing 
animations using the Play controls. You can, however, opt to 
view only a portion of your animation during preview. This 
feature is useful if you have a long animation and only want to 
focus on small portions at a time. The Play Range indicator 
appears at the bottom of all three tabs on the Animation palette. 
To adjust the play range, drag the beginning and/or end point to 
your desired starting and ending frames, respectively.

Animation Palette Options Menu
Clicking the Options arrow at the top right of the Animation 
Palette opens the Animation palette Options menu, which 
contains the following options:

 Animation Palette options menu.

• Display Frames: Selecting the Display Frames option 
toggles the Timeline columns to display using animation 
frames.

• Display Time Code: Selecting the Display Time 
Code option toggles the Timeline columns to display, 
representing your animation’s running time.

• Loop Interpolation: Selecting the Loop Interpolation 
option toggles loop interpolation on and off. Please refer to 
“Loop Interpolation” on page 445 for more information.

• Quaternion Interpolation: Selecting the Quaternion 
Interpolation option toggles quaternion interpolation on 
and off. Please refer to “Quaternion Interpolation” on page 
445 for more information.
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Keyframes View
The Keyframes view is where you edit the keyframes in your 
animation. It shows the layout of the keyframes and allows you 
to set and move between them. You can also play animations 
directly from this palette. The Keyframes tab appears as follows:

 The Keyframes view of the Animation Palette.

When you first display this tab, it shows any keyframes you 
previously created using the Animation controls, for the 
currently selected animation layer. Please refer to “Layers 
Tab” on page 469 for more information about animation 
layers. If you wish to see the keyframes contained within a 
different animation layer, select the name of the new layer from 
the Current Layer pop-up menu. In addition to the controls 
described above, the Keyframes tab contains the following 
elements:

Keyframe Controls

The Keyframe controls are almost identical to their counterparts 
in the Animation controls. The main difference is that the 
keyframe controls in the Keyframes palette feature a button that 
allows you to open the Graph palette.

 Keyframe Controls.
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• Previous Keyframe: The Previous Keyframe button 
returns to the previous keyframe.

• Next Keyframe: The Next Keyframe button advances to 
the next keyframe.

• Show Graph Display: Clicking the Show Graph Display 
button opens the Graph, discussed in “Using Graphs” on 
page 458.

• Add Key Frames: Clicking the Add Key Frames button 
adds a keyframe at the current frame number. For example, 
if you have existing keyframes at Frames 15 and 30, you 
could drag the Scrubber to Frame 22 and insert a keyframe 
by clicking the Add Key Frames button. You can also 
insert a keyframe by moving to any frame in your animation 
and making a change in your scene. This change will 
automatically be recorded as a new keyframe.

• Remove Key Frames: Clicking the Remove Key Frames 
button removes the currently selected keyframe. For 
example, if your character’s arm is over his head in Frame 
1, down at Frame 15 and out to the side in Frame 30 and 
you remove the keyframe in Frame 15, the figure’s arm will 
move out to the side position specified in Frame 30 without 
dropping to the figure’s side. To delete a keyframe, use the 
Next Keyframe or Previous Keyframe buttons to locate 

your desired keyframe, then click the Remove Keyframe 
button.

• Skip Frames: Check this radio button to skip frames during 
playback. This helps conserve system resources while 
previewing your animation before you render it.

Using Graphs

When you double-click a keyframe, the Graph palette for that 
keyframe appears. An element’s Graph palette allows you to 
perform precise edits on keyframes and modify the interpolation 
methods used in your animation. The Graph palette contains the 
following functions:
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 The Graph Palette.

• Animatable Properties: The Animation Properties 
pull-down menu allows you to select all of the animatable 
properties for the currently selected element.

• Interpolation Methods: See “Selecting Interpolation 
Types” on page 459.

• Keyframe Controls: See “Keyframe Controls” on page 
457.

• Work Area: See below.

The following subsections describe the Graph’s functionality in 
further detail.

About the Graph Palette

The Graph Work Area consists of two axes and a graph. The 
horizontal axis represents time in frame numbers. The vertical 
axis’ values change depending on the selected attribute. If you 
choose a position attribute such as xTrans, the values represent 
positions in 3D space (Cartesian coordinates). If you select an 
editing property such as Bend, the axis represents degrees. A 
morph parameter’s values are measured in percentages.

The Graph itself shows the actual change in the attribute over 
the course of your animation. Its shape indicates the type of 
interpolation being used. You can also use the Graph palette for 
synchronizing sound to motion, as described in “Syncing Sound 
& Motion” on page 482.

Selecting Interpolation Types

The Graph contains controls allowing you to specify 
interpolation methods, which can be specified on both the 
element and frame range levels. The Interpolation controls 
appear as follows:
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 Interpolation Controls.

To choose an interpolation method, select the elements and 
frame range to modify, then click your desired Interpolation 
button. The Animation palette uses color codes to depict varying 
interpolation methods.

• Spline: Green

Splines can sometimes go beyond and exceed the 
maximum keyframed values depending on the 

slope created by tightly-spaced keyframes. Adding 
additional keyframes can constrain the slope into more 
pleasing levels.

• Linear: Red

• Constant: Grayed out

• Break Spline: A hash mark appears where Break Spline 
has been applied.

Editing the Graph

You can edit the graph to achieve varying degrees of 
interpolation. For example, to decrease the amount of Spline 
interpolation, straighten the curve. You can set the curve’s shape 
using preset interpolation methods or by dragging the curve’s 
points to obtain your desired shape. You can also apply different 
interpolation methods to different parts of the graph using the 
Break Spline function.

Be aware that changing the graph’s shape affects the selected 
element’s motion. To edit the graph, use the Animation 
Properties pull-down menu or select Graph from the 
Parameters palette (see “Using Graphs” on page 458) to 
select the attribute to be edited. Next, drag any point on the 
graph in the direction you want to move the curve. The curve 
will reshape itself based on your chosen interpolation method(s). 
Use the scrollbar to view parts of the graph that are not currently 
being displayed.

To change the type of interpolation applied to a portion of the 
graph, click and drag to select the frames you wish to change. 
Your selected area will become highlighted. Next, click one of the 
Interpolation buttons at the bottom of the palette. This can add 
keyframes to your animation.

Vertical lines on the graph denote keyframes. You can move 
these points to change when keyframes occur, and can also add 
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keyframes by clicking the point on the line where you want to 
insert the keyframe.

The Current Frame indicator is a visual reminder of the frame 
you’re currently working on. To select a keyframe, click the Next 
Keyframe or Previous Keyframe button, as appropriate, click 
a keyframe indicator, or drag the Current Frame indicator to 
the frame you wish to edit. Click and drag a rectangle to select a 
range of frames.

 Keyframes displayed in the Graph.

You can also perform the following functions using the Graph:

• To move keyframes, select the keyframe(s) you want to 
move, and drag forward or backward in the timeline to a 
new location.

• To add a keyframe, drag the Current Frame indicator 
to your desired location and click the Add Key Frames 
button.

• To delete a keyframe, move the Current Frame indicator 
to the desired keyframe and click the Delete Key Frames 
button.

• To cut, copy, and paste, use the editing hotkeys 
([COMMAND]/[CTRL]+[X], [COMMAND]/[CTRL]+[C], 
and [COMMAND]/[CTRL]+[V], respectively) or choose the 
appropriate command from the Edit menu.

• To close the Graph palette, click the small box in the upper 
left corner.

Using the Graph With the Animation Palette

If you open the Animation palette, you can access the Graph 
palette for the currently selected scene element by clicking the 
Display Graph Palette button, or by double-clicking a keyframe 
in the Animation palette. With both palettes open, you have the 
following options:

• Double-clicking any element in the Animation palette’s 
Element list switches the current Graph palette to the 
selected element.
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• Pressing Opt/ALT while double-clicking any element in 
the Animation palette’s Element list opens a new Graph 
palette for the selected element while not affecting any other 
open Graph palettes. You can use this function to open as 
many Graph palettes as you like at one time, which can 
greatly speed up your animation work. You can even open 
more than one Graph palette for each element, allowing you 
to (for example) adjust the Right Forearm’s Twist and Bend 
at once to achieve smooth realistic movement.

When you have more than one Graph palette 
open at once, changing elements by double-

clicking them will only change the most recently opened 
Graph palette. All other Graph palettes will retain their 
current settings. If you need to change more than one 
graph palette, close out all unneeded palettes, then re-
open them by selecting your currently needed elements.

Interpolation Controls

The process of filling in the blanks between keyframes (the area 
known as tween frames) is called interpolation, and the frames 
between keyframes are called tweens. Interpolation determines 
how intermediate poses are created. Please refer to “About 
Poser Files” on page 847 for a general discussion about 
interpolation.

Poser supports four types of interpolation, which allows you to 
make subtle changes to your animations. Interpolation settings 
apply to a range of frames, meaning that you can use different 
interpolation methods at different intervals in your animation. 
The Interpolation controls allow you to specify the interpolation 
method.

 Interpolation Controls.

From left to right, the buttons are:

• Spline: Places tween poses and settings on a curve. Motion 
begins at one keyframe, accelerates to full velocity, and 
gradually slows down as it approaches the next keyframe. 
For example, if the first keyframe has an arm by a figure’s 
side and the second one has it raised, the arm will begin 
moving slowly, accelerate to a constant velocity, and slow 
as it reaches the second keyframe. This is not to say that the 
movement will be fast; actual speed of motion depends on 
the amount of change between keyframes and the number 
of tween frames. In our above example, having the second 
keyframe 5 frames from the first would make a very rapid 
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motion, while having 100 frames would make a very slow 
motion. The key thing to remember is that this type of 
animation resembles a smooth curve and is normally the 
most realistic.

 Spline Interpolation.

• Linear: Takes the two keyframes and divides the motion 
between them equally with no acceleration or deceleration 
of the moving items. In the above example, the arm would 
move at a constant velocity from keyframe to keyframe. If 
you created a third keyframe with the arm back down, the 
change direction at the second keyframe would be abrupt.

 Linear Interpolation.

• Constant: This has no intermediate poses. If you set a 
series of poses with different keyframes, the first pose will 
be maintained until the second keyframe, at which point 
it will instantly change to the second pose, which will be 
maintained until the third keyframe, and so on.

 Constant Interpolation.

• Break Spline: Stops interpolation at the selected point 
so you can begin a new interpolation style. This is useful 
for blending different interpolation styles. For example, a 
bouncing ball moves in a smooth arc until it hits the floor, at 
which point it undergoes an abrupt change in direction and 
speed. This is one scenario where changing interpolation 
styles can aid your animating work.
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 Breaking interpolation.

Skip Frames

Clicking the Skip Frames radio button enabling this option 
drops frames when previewing your animation, speeding up 
playback. Click the button again to toggle its functionality off.

Loop

Clicking the Loop radio button causes your animation to repeat 
itself continuously when playing until you click the Stop button. 
Click the button again to toggle its functionality off.

This Element/All Elements

This option selects whether changes made using the Keyframes 
tab (interpolation type, keyframe changes, etc.) apply to the 
entire scene or just to the selected element. Click the This 

Element or All Elements radio button, as appropriate, to make 
your selection.

 Selecting elements to change.

Elements List/Timeline

The Elements List displays a list of all elements in your scene. 
The Timeline Area displays your animation frames and all of 
the keyframes stored for each body part/prop/material/etc. 
Keyframes appear in red, with tween (interpolated) frames 
appearing in different colors according to their interpolation 
type (see “About Poser Files” on page 847). You can expand 
and collapse element listings by clicking the triangles next to 
elements in the list. Each element can be further expanded to 
display its properties and parameters that can be animated. For 
example, you can view the Scale and Transition elements for a 
figure’s forearm. The following image displays a portion of the 
Elements List for a scene.
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 The Element List.

To select an element, click it in the Element List. This selects 
the desired element in the same manner as clicking it in the 
Document window, using the Current Actor menu or selecting 
it using any of the other available selection methods. Poser 
highlights the currently selected element in the Elements List as 
well as that element’s row in the Timeline. Use the vertical scroll 
bar on the right of the Elements List and expand and collapse 
branches to view all of the elements in your scene. Collapsing 
branches saves space in the display.

When you collapse an entire figure in the 
Elements List, the keyframes displayed will only 

be those pertaining to that figure’s location in the Poser 
workspace. You’ll need to expand the Elements List to 
show posing/parameter changes.

Double-clicking an element in the list, or selecting an element 
and clicking the Show Graph button, opens the Graph for the 
selected item. Please see “Using Graphs” on page 458.

Editing Keyframes on the Timeline

You can use the Timeline to select, add, edit, or delete 
keyframes. The Timeline appears as a grid that displays 
keyframes for each element in your scene. Columns indicate 
time, with each column corresponding to a single animation 
frame or point in time (See “Elements List/Timeline” on page 
464). The Ruler at the top of this area indicates whether 
the columns indicate frames or points in time. Each row 
corresponds to an element in your scene. As described above, 
the Timeline presents information using color codes. Use the 
horizontal and/or vertical scrollbars to navigate the Timeline if 
necessary.

Selecting Keyframes

By default, Poser selects the first frame in your animation 
(Frame 1) when you open the Animation palette. You can select 
any frame by clicking in or above its column. You can also enter 
a number in the Frame field. When you select a keyframe, Poser 
displays the current element’s row and time column, creating an 
intersection.

Selecting a different keyframe moves the intersection to the 
newly selected point. To select a keyframe, click any one of the 
light green squares on the Timeline grid.
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 Selecting Keyframes.

Adding & Removing Keyframes

Adding keyframes stores a specific pose and/or saves a Poser-
created interpolation (tween) frame. You can add keyframes 
for the entire scene or the selected element by checking either 
the This Element or All Elements radio button as described 
in “This Element/All Elements” on page 464. When This 
Element is selected, keyframes are only recorded for your 
currently selected element. When All Elements is selected, 
keyframes are recorded for every element in your scene. To add 
a keyframe:

1. Select This Element or All Elements, as appropriate.

2. Select the frame or point in time where you wish to add the 
keyframe.

3. Click the Add Keyframes button.

Removing Individual Keyframes

Removing keyframes can modify how your animation appears. 
You can clear a keyframe for a specific element or your 
entire scene by selecting This Element or All Elements, as 
appropriate. Removing a keyframe does not delete the frame, 
but removes the saved information. To remove a keyframe:

1. Select This Element or All Elements, as appropriate.

2. Select the frame or point in time where you wish to remove 
the keyframe.

3. Click the Delete Keyframes button.

Removing Multiple Keyframes

To remove an entire range of keyframes, click and drag over the 
keyframes you wish to delete in the Timeline and press [DEL]. 
To remove multiple specific keyframes, press and hold Shift 
while selecting individual keyframes, then press [DEL].

Moving Keyframes

While creating animations, you may decide to have one or more 
keyframes occur earlier or later than your present settings. 
You may also want to apply the settings in some keyframes to 
others. Poser allows you to move both individual and multiple 
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keyframes. To do this, click the keyframe you wish to move and 
drag the colored cell horizontally to its new location. To move 
multiple keyframes, select them and drag your selection to its 
new location on the timeline.

Copying Keyframes

You can copy keyframes, figure parts, and parameters appearing 
in the Element List. By doing this, you can (for example) have 
several Poser figures marching in perfect step. Although Poser 
does not limit how you copy and paste keyframes, you should 
avoid mixing data (such as copying Scale parameter settings to 
a Rotation parameter). You can also obtain unexpected results 
by copying movements from one side of a body to another. If you 
do copy parameters from side to side, you will need to make the 
affected parameters negative on the side you copied to.

Choose Edit > Copy or press [COMMAND]/[CTRL]+[C] to copy 
frames to your clipboard. When you reach your destination, 
select Edit > Paste or press [COMMAND]/[CTRL]+[V].

Alternatively, you can click the desired keyframe then press and 
hold Opt/ALT while dragging the keyframe to its new location. 
You can move multiple keyframes by selecting them and Opt/
ALT+dragging your selection to its new location.

Retiming Keyframes

Selecting Animation > Retime Animation opens the Retime 
Keys dialog, which allows you to adjust keyframe timing in your 
animation.

 The Retime Animation dialog.

By specifying source and destination frame ranges, you can 
change the amount of time a motion or motions take to occur. 
This command does not destroy any keyframes, meaning that 
you can use it to repeat motions by copying them from one time 
to another. Selecting a motion in one area and selecting a non-
overlapping destination re-maps the motion to another time 
without deleting the original motion.

To retime keyframes:

1. Open the Retime Keys dialog box.
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2. Enter the start and end frames for the section of animation 
you want to retime in the Source Frames fields.

3. Enter the range of frames to retime the animation to in 
the Destination Frames fields. If the destination range is 
longer than the source range, the animation is expanded or 
slows down, and vice versa.

4. Click OK when finished.

When using this command, all existing 
keyframes in the Destination Range are deleted.

Resampling Key Frames

Selecting Animation > Resample Key Frames opens the 
Resample Keys window, which allows you to increase or 
decrease the number of keyframes in your animation.

This window has the following options:

 The Resample Keys dialog.

• Modify: Check the appropriate radio button to sample 
keyframes for the Current Element (prop, body part, etc.), 
Current Figure (entire figure), or Everything (entire 
scene).

• Resample Method: You have two options for resampling 
keyframes:
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 � Analyze Curvature: Causes Poser to examine the 
amount of curvature (change over time) in your 
animation and automatically assign new keyframes.

 � Make key frame every X frames: Check this radio 
button and enter a value in the Frames field to create 
a keyframe every X frames, where X is the value you 
entered in the field.

• Frame Range: If you want to resample key frames in a 
specific portion of your animation, enter the start frame and 
end frame in the Frame Range fields.

Layers Tab
Animation layers, also known as non-linear animation, provide 
you with the ability to separate different parts of an animation 
into independent pieces, which can be individually edited, 
moved, or even hidden, with respect to the entire animation. At 
render time, the various layers are composited together into a 
single animation, according to your specifications. The Layers 
tab on the Animation palette contains the controls that allow 
you to create, configure, move and delete animation layers.

 Layers tab in the Animation Palette.

If you switch from the Layers tab to the 
Keyframes tab, you will see any keyframes that 

exist in the currently selected animation layer. If you 
wish to see keyframes from another layer, use the 
Current Layer pop-up menu at the top of the Animation 
palette to select any existing layers, without having to 
return to the Layers tab.
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Base Layer

When you first begin to create an animation, only one layer will 
exist; this is known as the Base layer. The Base layer is always 
present, and if you wish, you can create your entire animation 
just in this single layer. The frame count of the Base layer is 
equivalent to the length of the entire animation. The Start frame 
of the Base layer is always Frame 1, and the End frame is the last 
frame in the entire animation. Thus, changing the End frame of 
the Base layer changes the length of your animation, which will 
affect any other layers whose End frames coincide with the End 
frame of the Base layer.

You cannot change any properties of a Base 
Layer other than the End frame.

Creating, Deleting & Previewing Animation 
Layers

In addition to the shared controls common to all three tabs on 
the Animation palette (see “Using the Animation Palette” on 
page 454 for a description of these controls), the upper section 
of the Layers tab also contains three buttons:

• New: Click the New button to create a new animation layer.

• Delete: Click the Delete button to delete the currently 
selected animation layer. This feature is disabled when the 
Base layer is selected.

• Current Layer Only: Click the Current Layer Only radio 
button to temporarily exclude all other animation layers 
from the playback. Doing so allows you to isolate the specific 
animation contained within the current layer, which can be 
helpful in scenes with multiple layers.

 Current Layer Only option.

Animation Layer Controls

The lower portion of the Layers tab contains additional controls 
that allow you to configure a selected layer, and the Timeline 
Area, which displays the various layers in editable segments, 
allowing you to see the hierarchy of the layers as well as where 
each layer is placed in the timeline of the entire animation. The 
Layer controls are as follows:
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 Layer Controls.

• Layer Name: Once you have created a new layer, you can 
change its default name to anything you want. Simply select 
the layer in the Timeline display, and type the new name in 
the text field.

• Include in Playback: Check or uncheck this option to 
include or exclude the selected clip when you preview your 
animation.

• Start/End Frame: The Start frame and End frame controls 
allow you to specify the Start and End frames for the 
selected layer. While the Base layer always equals the length 
of the entire animation, other layers can be of any length 
up to the entire animation length, and can start and end 
at any point within the duration of the animation. You can 
change the Start and End frames by clicking on the frame 
number and typing a new value into the field. Alternately, 
you can click on the layer segment in the Timeline Area and 
drag it to a new position; the segment length will remain 
constant, but the Start and End frames will change. Clicking 
and dragging on either the beginning or the end of the layer 
segment will change the Start or End frame respectively, 
without moving the position of the segment within the 
animation timeline. The length of the layer segment will 
adjust to accommodate the new Start or End frame number.

• Blend In/Out Frames: The Blend In/Out feature allows 
you to gradually blend an animation layer into, or out of, 
the full animation. This feature could be used, for example, 
to create the effect of wind gradually picking up or fading 
away. The Blend in frames and Blend out frames settings 
allow to you specify over how many frames the linear blend 
will occur. The Blend In/Out frame count is indicated on 
the layer segment display as an additional shaded segment 
attached to either the beginning or end of the layer segment.
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If the animation contained within a specific layer 
is a gradual movement, then the Blend feature 

may not be effective, particularly if the Blend In/Out 
frame counts are set too low.

• Composite Method: While compositing the full animation, 
Poser begins with the Base layer, and works upwards 
through the layer hierarchy incorporating each layer one 
by one. The Composite method setting allows you to 
specify the manner in which the individual layers will be 
composited. The two options for compositing animation 
layers are Replace and Add.

 � Replace: This is the default composite method for 
animation layers. Selecting Replace means that any 
action on a given parameter for a specific actor will 
replace any actions on the same parameter, on all layers 
below the selected layer. For example, let’s suppose that 
Layer1 is below Layer2 in the animation layer hierarchy. 
Let’s also suppose that in Layer1 James’ chest is twisted 
twenty degrees to the left, but in Layer2 his chest is 
twisted only ten degrees to the left. With the Replace 
option, the Layer2 setting will replace the setting from 
Layer1.

 � Add: Selecting Add means that the values for all 
rotation and translation parameters will be added 
to one another as Poser composites each layer into 

the animation. Using the above example, the twenty 
degrees of Twist from Layer1 would be added to the 
ten degrees from Layer2, resulting in a greater effect of 
thirty degrees of Twist. However, if Layer1 had included 
a twist of negative twenty degrees, while Layer2 had 
included a twist of positive ten degrees, then the Add 
option would result in a final twist effect of negative ten 
degrees.

• Move Up/Down: If you select the Replace composite 
method, the specific order of the layers within the layer 
hierarchy will be very important, as parameter settings in 
higher layers replace those in lower layers (see above for 
additional explanation). You can change the order of layers 
within the hierarchy by clicking the Move up or Move 
down button to move the selected layer either up or down 
one level. Clicking the button a second time will repeat the 
action.

Animation Sets Tab
Animation sets allow you to store a series of animation clips 
that are frequently used in combination. For example, you could 
animate a figure raising its arm above its head and save the 
limb’s movements to a named animation set.
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Creating & Editing Animation Sets

To work with animation sets, open the Animation palette by 
selecting Window > Animation Palette. Click the Animation 
Sets tab to open the Animation Sets palette, as shown.

The Frame Rate, Time control, Frame Indicator, Play controls, 
and Skip Frames button all function as described in previous 
sections of this chapter.

 Creating an Animation Set.

• To create a new animation set, click the New button and 
name your new set. Doing so will populate the Animation 
Sets tab with additional editing controls.

• To delete an animation set, select the set from the pop-up 
menu to the right of the Attributes button, and click the 
Delete button.

• To add selected items and/or frames to your animation set, 
click and drag to make your selection and click the + button. 
You can select any combination of items/frames. The start 
and end frames will be made identical for all items in the 
animation set.

• To remove selected item(s) and/or frame(s), make your 
selection and click the – button.

 Several buttons allow you to add, remove, and set attributes for 
your animation set items and frames.

• To save an animation set, you will need to save the pose 
to the Library. To save an animation set pose, first open 
the Pose library. Click the Save to Library button at the 
bottom of the Library palette to display the New Set dialog. 
Next, click the Select Subset button at the bottom of the 
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dialog to open the Select Objects dialog. Click the Select 
from Animation Set button to display a list of the available 
animation sets. Choose one of the sets, and click OK to save 
the animation set to the library. Repeat for additional sets 
you want to save.

Setting Animation Set Attributes

The Attributes button is for use with Python scripts. You can 
add any arbitrarily named attribute with an associated value. 
Using Python scripts, you can use these attributes any way you 
wish. For example, you could create a Python script that causes 
a figure to blink their eyes repeatedly. For more information 
on using Python scripts with Poser, please refer to “Part 8: 
PoserPython” on page 836, or to the PoserPython Methods 
Manual that accompanied your Poser installation.

Applying Animation Sets to Figures

You can also apply animation sets to figures. For example, if you 
create an animation set of an arm being raised, applying that set 
to your current figure will cause its arm to raise in the exact way 
specified by the animation set. This feature can help you save 
time by allowing you to reuse complex animations over and over.

Using the Walk Designer
Of the wide range of human motions, walking is among the 
hardest to simulate with any degree of accuracy. Walking looks 
simple: just place one foot in front of the other. In reality, 
however, it is an incredibly complex motion involving a variety 
of muscles in the legs, torso, arms– practically the entire body. 
Thus, creating an accurate walk simulation entails a great deal 
of precision posing. Poser’s Walk Designer allows you to bypass 
most of this and create a realistic walk using just a few simple 
steps.

 The Walk Designer.
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Creating the Walk

To open the Walk Designer, select the figure you’d like to 
animate in the Poser scene, then choose the Window > Walk 
Designer menu command.

Unless you want your figure to walk in place (without a walk 
path), create a walk as follows:

1. Create a walk path (your figure will follow this path when 
walking)

2. Create a walk using the Walk Designer.

The Walk Designer has two sections. The upper set of controls 
creates the walk’s larger motions, while the lower set lets you set 
up the walk’s secondary motions. To preview a walk, click the 
Walk button at any time while using the Walk Designer. The 
preview will loop indefinitely and the button will change to Stop.

Views

As you can see in the previous graphic, the Walk Designer 
includes a real-time preview of the walk being created. As you 
change the parameters, the walk changes to reflect your updates. 
You can specify the angle from which to preview your walk by 
checking the appropriate radio button underneath the Preview 
tab:

• (default): Checking the radio button looks at the figure on 
an angle.

• Side: Checking the Side radio button looks at the figure’s 
side.

• Front: Checking the Front radio button looks at the figure’s 
front.

• Top: Checking the Top radio button looks down from the 
top.

The Walk Designer reflects your current Poser 
workspace’s foreground, background, and 

shadow colors, as well as tracking mode.

Figure Types

This step is optional, however it can address potential issues 
such as irregular or jerky motions in generated walks. To load 
a figure type, click the Load button in the Walk Designer and 
use the standard Open dialog to locate your desired character 
(*.CR2) file. Please see “Appendix B: Poser File Structure” 
on page 847 for more information about Poser file types, 
including CR2 files.
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Try loading the same figure you’re working on. 
For example, if creating a walk for the Don 

figure, load him into the Walk Designer for best results.

Blend & Tweak Styles

Once you’ve loaded your figure type, you can begin designing 
your walk. By default, the sliders are all in the middle of their 
ranges. This combination applies a workable default walk. 
Dragging a slide to the right increases its value and effect, and 
vice versa. To create a walk:

1. Drag the Blend sliders to create the large motions. Use 
the preview to view all of the available settings. Try using 
combinations of several settings, and remember that small 
changes can produce dramatic results.

2. Adjust the Tweak sliders to fine-tune the walk.

3. When your walk looks the way you want it to, click the Done 
button to open the Apply Walk dialog (see below).

Clicking the Defaults button restores all sliders to 
their default positions.

Loading & Saving Walks

You can load and save walk files using the Walk Designer. This 
is not the same as saving animated poses to the Library palette. 
To save a walk, create it, then click the Save button to open 
a standard dialog box allowing you to specify the name and 
location for the saved walk. Select your desired path, enter a 
name for the saved walk, and click OK.

To load a walk, click the Load button to open a standard Open 
dialog, allowing you to specify a path and filename for the walk 
file to load.

For greatest realism, load walks created using 
the same figure type.

Applying Walks

Once you’ve created your walk, you need to apply it to the 
figure’s walk path (see “Creating a Walk Path” on page 478 
for instructions on creating walk paths). The Walk Apply dialog 
allows you to specify various options for applying your newly 
created walk. If you want your figure to walk in place, you can 
use this dialog without having a walk path.

You have the following options when applying walks:
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 The Apply Walk dialog.

• Figure: If your scene has more than one figure in it, the 
Figure pull-down menu allows you to select the figure to 
apply the walk to.

• Walk in Place/Follow Path: Clicking the Walk in Place 
radio button causes the selected figure to walk in place 
without going anywhere. You can use this option to create 
a walk without a walk path. Alternately, if you wish your 
figure to follow a walk path, click the Follow Path radio 
button.

• Path: If your scene has more than one walk path, you can 
use the Path pull-down menu to specify the walk path to 
use.

• Align Head to: Checking the Align Head to box lets you 
control how the figure’s head acts as it moves along the walk 
path. One Step Ahead keeps the head aligned with the 
body and produces the most head movements. End of Path 
keeps the figure’s head looking at the end of the walk path 
no matter where it leads. Next Sharp Turn aligns the head 
to the turns in the walk path, the head only moving when 
the path curves.

• Always Complete Last Step: Checking the Always 
complete last step box forces the walk animation to 
complete within the allotted time. This is useful if the walk 
ends in mid-stride at the end.

• Transition From/To Pose at Start/End Frames: The 
Transition from pose at start and Transition from pose 
at end options allow your figure to smoothly transition 
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into and out of the walk at the beginning and end of the 
walk cycle, respectively. When enabled, Poser interpolates 
between the figure’s pose at the start of the walk and the 
settings you specified in the Walk Designer, and vice 
versa at the end of the cycle. For example, you can use this 
feature to quickly set up a runner by posing the figure in the 
crouched starting position, designing a run, and specifying a 
realistic transition time. When you play your animation, the 
runner will come off the starting blocks and begin the run. 
Checking one or both boxes enables the specified option(s). 
Once enabled, enter the number of frames to be used for the 
transition. Longer time periods (more frames) allow more 
realistic movements and vice versa.

• Start Frame: Enter the frame in your animation where the 
walk will begin in the Start Frame field.

• End Frame: Enter the frame in your animation where the 
walk will end in the End Frame field. Poser suggests a value 
that is expected to yield a natural walk speed. The more 
frames allocated, the more time a figure will take to walk 
along the specified path.

• Create Keyframes in: The Create Keyframes in setting 
allows you to select either a new or existing animation layer 
for your walk keyframes. Animation layers allow you to 
organize your animations, save and reuse specific aspects of 
a larger animation.

We recommend that you create the keyframes in a 
new animation layer; click the “New animation layer” 
radio button to select this option. Alternately, you can 
choose to use an existing animation layer by clicking 
the “Layer” radio button, and selecting the name of the 
layer from the pop-up menu. If you do not wish to use 
animation layers, you can simply write all keyframes to 
the Base Layer. For more information about animation 
layers, please see “Layers Tab” on page 469.

Creating a Walk Path

Creating a walking figure is a two-step process. The first step 
entails creating a walk path for your selected figure that defines 
where s/he is going to walk. The figure can walk in place or along 
a path.

Walk paths are designed to work with the Walk Designer (see 
“Using the Walk Designer” on page 474). While the Walk 
Designer specifies how your figure walks, a walk path specifies 
where. The path is a curve drawn in the Document window that 
sets the figure’s course as it moves about the Poser workspace. 
Create the path, design the walk, and the figure walks along the 
path from start to end, stopping at the end.

To create a walk path, Select Figure > Create Walk Path. A 
default path appears in the Poser workspace. We recommend 
shifting to the Top camera and zooming out to get the best view 
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of your scene and walk path, but you can work using any camera 
you like. The following image shows a default walk path.

 Default walk path.

Walk paths must be created on the ground plane.

Shaping Curves

The curve’s position is defined using control points. Click and 
drag control points to shape your path any way you like.

 Drag a control point to reshape the curve.

You can position the beginning and end of the walk path by 
dragging the end control points. You can also reposition the 
entire walk path by selecting the ring that appears when your 
cursor is near the walk path, which functions like the Figure 
Ring discussed in “Selecting Body Parts” on page 181.

Adding and Removing Control Points

To add control points, simply click anywhere along the line. Your 
new control points appear. Adding control points can add detail 
and/or lengthen your walk path.
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 You can add or remove points on the walk path.

To delete control points, press and hold Opt/ALT while clicking 
the point you wish to remove.

Once you have completed your walk path, use the Walk 
Designer to design a walk for your figure. Please refer to “Using 
the Walk Designer” on page 474 for more information about 
the Walk Designer.

 A reshaped walk path.

Because of the nature of the spline used for walk 
paths, it is impossible to create a hard right-

angle turn. These and other abrupt direction changes 
can result in unnatural-looking walks.

Once you have created a walk using the Walk 
Designer, you can delete the walk path. The 

figure will still behave as though the walk path was 
present.
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Sound
Poser allows you to import sounds, which play when your 
animation plays. This is a great way for you to add soundtracks, 
speech, etc. to your animations. To import a sound clip, select 
File > Import > Sound and use the standard Open dialog that 
appears to locate your desired sound file. If you wish to import 
a speech sound clip for use with the Talk Designer, select File > 
Import > Lip Sync Audio (see below for information on the Talk 
Designer). Imported sounds attach to your animations at the 
first frame and play whenever the animation is played. Also, you 
can only import one sound file. If your animation calls for more 
than one sound, edit your desired sounds together in an audio 
editing application and create a new sound file for importing 
into Poser.

Importing Sound

Selecting either File > Import > LipSync Audio or File > 
Import > Sound allows you to import WAV, MP3, and other 
audio format sound clips that you can use as a soundtrack for 
your animation. Imported speech or sounds are added to the 
beginning of your animation and play every time you play your 
animation. Upon selecting this option, a standard Open dialog 
appears, allowing you to select the filename and location of the 
sound file you wish to import. If you selected the LipSync Audio 
option, the Talk Designer will open with your specified audio 

file selected. Please refer to “Syncing Sound & Motion” on page 
482 for information on working with imported sounds.

Importing sounds files will add keyframes based 
on the current frame rate selected. For example 

a two second long sound file will expand the default 
animation to 60 frames if a frame rate of 30 frames per 
second has been selected for the animation.

Editing Sound

Sound duration appears in the Sound Range bar at the bottom 
of the Animation Palette. You can clip imported sounds by 
shortening the sound bar. However, if sound playback begins 
at any frame other than 1, the beginning of the sound will be 
clipped.

 The sound range is displayed at the bottom of the Animation 
Palette.
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To specify start and end frames for the sound, drag arrows on 
either side of the sound bar.

Syncing Sound & Motion

The Graph palette displays a graphic representation of the 
sound file called a waveform, which lets you see where changes 
in sound occur. You can use this information to position 
keyframes in your animation. Simulate speech by matching 
peaks in the waveform with changes in mouth position, as shown 
above. To display waveforms in the Graph palette, open it as 
described in “Using Graphs” on page 458 and click the Toggle 
Sound Display button to toggle waveform display on and off.

 A sound appears as a waveform in the Graph palette.

Using the Talk Designer
Poser’s Talk Designer automates the task of animating facial 
features for speech. The Talk Designer synchronizes morph 
targets, Emotional Tweak controls, and powerful eye and head 
motion modelling algorithms with your sound file, making it 
much easier to animate realistic facial expressions for speech.

The Talk Designer is configured using the Talk Designer 
palette. Choose Window > Talk Designer to open the palette.

Select File > Import > Lip Sync Audio to import a sound file, 
as described above. At the end of the import process, the Talk 
Designer palette will automatically open with your imported 
audio file selected.
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 The Talk Designer.

Select Window > Talk Designer to open the Talk Designer 
palette at any time.

Configuring the Talk Designer

The Talk Designer palette settings are described in the following 
sections. When you have configured the Talk Designer to your 
satisfaction, click the Apply button at the bottom of the palette 
to generate a lipsync animation based upon the settings you 
specified.

Input Files

• Sound file: Clicking the “...” button next to the Sound file 
setting allows you to browse to the location of the sound file 
you wish to use for your lipsync animation. Poser supports 
WAV file, as well as AIFF files on the Macintosh.

• Supplemental text: For better accuracy, we recommend 
that you include the text of the spoken words in the 
Supplemental text field. Text entries in this field will be 
required if you need to specify an alternative language. You 
can click the “...” button to browse to a text document, or 
click on the “+” button to open a text box and enter the text 
directly.

• Language: If you add supplemental text, use the Language 
pull-down menu to specify the language used. In order 



Poser Pro 2014
Reference Manual 

484

Chapter 22: Animating with Poser

to select another option from the Language menu, you 
must have text entered in the Supplemental Text field. 
After entering your text, you will have the option to select 
English, French, German, or Japanese.

• Viseme map file: A viseme map file provides information 
about which phonemes (speech sounds) are matched to 
which specific visemes, or facial expressions. These viseme 
map files are directly linked to the morph target setup of 
the individual figure. If you are working with any of the 
newer figures included with Poser, you can simply use the 
default viseme map file for the figure. If you wish to use a 
figure from a previous version of Poser, please make sure 
that a viseme map is provided in the associated pop-up 
menu. If you use a figure from a third-party source that was 
created with a different morph target setup, you will need 
to provide the viseme map file that accompanies the figure. 
We recommend that you place the viseme map file into the 
\Runtime\LipSync\ folder that accompanies your Poser 
installation. Doing so will add the file to the pop-up menu in 
the Talk Designer palette. Alternately, you can click the “...” 
button to browse to the location of the viseme map file, if 
you wish to keep it in another location.

If you are unsure whether or not your custom 
figure was created following the morph target 

standards for included Poser figures, you can try your 
animation using the default viseme map file. Smith 
Micro cannot support third-party figures. If you are 
dissatisfied with the results, you will need to contact the 
content creator.

Configuration

• Figure: Specify which figure in the scene you wish to use for 
the lipsync animation, by selecting the name of the figure 
from the pop-up menu.

• Start frame: Specify the Start Frame number for the actual 
lipsync animation. By default, the Start Frame setting is set 
to the Start Frame of the entire scene animation (frame 1).

• End frame: Specify the End Frame number for the actual 
lipsync animation. By default, the End Frame setting is set 
to the End Frame of the entire scene animation (generally 
frame 30, unless you have specified a different scene End 
Frame). Once you load a sound file, the End Frame setting 
will default to match the length of the sound file.
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If the End Frame number specified in the Talk 
Designer is greater than the End Frame for the 

entire scene animation (as specified on the Base Layer), 
then additional frames will be appended to the scene to 
accommodate the difference.

• Create Keyframes in: The Create Keyframes in setting 
allows you to select either a new or existing animation layer 
for your lipsync animation keyframes. Animation layers 
allow you to organize your animations, save and reuse 
specific aspects of a larger animation.

We recommend that you create the keyframes in a 
new animation layer; click the “New animation layer” 
radio button to select this option. You will be asked 
to name the new layer. Alternately, you can choose to 
use an existing animation layer by clicking the “Layer” 
radio button, and selecting the name of the layer from 
the pop-up menu. If you do not wish to use animation 
layers, you can simply write all keyframes to the Base 
Layer. For more information about animation layers, 
please see “Layers Tab” on page 469.

• Enunciation: The Enunciation slider allows you to 
configure the degree to which the Talk Designer will adjust 
a figure’s visemes, or facial morphs, in response to changes 
in the audio file’s perceived energy. Poser automatically 

adjusts visemes to correlate to the energy of the selected 
sound file. However, you can use the Enunciation slider 
to raise or lower the degree of reaction, to counteract or 
supplement the automatic viseme adjustment. Move the 
slider to the right to increase enunciation, or to the left to 
decrease.

Head Motions

• Eye Blink Rate: The Talk Designer can add intermittent 
eye blinks that have been modeled on studies of actual 
human blink rates, in order to animate blinks realistically 
in relation to the animation of speech. The Eye Blink Rate 
slider allows you to specify an average blink rate, measured 
in blinks per minute (BPM). To change the average blink 
rate, simply click and drag the slider, or click on the 
numerical value in the text box and enter a number directly. 
The default value is 12.5 BPM. A setting of zero (0 BPM) 
disables the automatic blink feature, which means that with 
this setting you must animate all eye blinks manually.

• Create eye motion: When people speak, their eyes 
generally look in different directions with relation to their 
subject matter and surroundings. Adding eye movements 
can result in a more realistic animation. Check the Create 
eye motion checkbox to have Poser add eye movements to 
your lipsync animation.
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• Create head motion: People naturally move their heads 
during speech, which means that adding head motion to 
your animation can yield more realistic results. Check the 
Create head motion checkbox to have Poser add head 
motion to your lipsync animation for you.

Emotional Tweaks

The Talk Designer includes six Emotional Tweaks, which are 
morph targets that can be used in conjunction with speech. 
These morph targets are based upon facial expressions 
associated with the following emotions:

• Anger

• Disgust

• Fear

• Joy

• Sadness

• Surprise

Each of these Emotional Tweaks is adjusted by a slider, which 
ranges between -100% and 100%. The values within this range 
represent the degree to which each particular emotion will 
manifest in the facial expressions of the figure during the lipsync 
animation. Feel free to mix and match the Emotional Tweaks 

slider values to suit your specific needs. To adjust the values, you 
can either move the sliders to the right or left, or you can click on 
the numerical value to the right of the slider and enter a number 
directly.

Importing BVH Motion Capture Files
Selecting File > Import > BVH Motion allows you to import 
motion-capture files in the popular BVH format. A standard 
Import dialog appears, allowing you to select your desired path 
and filename.

To determine the correct axis or scale for the BVH files consult 
the developer’s readme or documentation. Developers such as 
Biovision or House of Moves will provide this information. Or, 
you can specify whether a figure’s arms are aligned in the X or 
Z axis during import. The align axis is determined at the time 
of recording. Choose the correct axis so your figure will move 
correctly. Begin by selecting the body. Import the BVH file and 
select the Z-Axis arm alignment and Scale Automatically 
options. Some actors may not be recognized, but the BVH file 
will still load. If you make a mistake, return to Frame 1 and 
re-import the file. Imported BVH keyframes are applied to 
the currently selected figure and can be edited like any other 
keyframe (see “Editing Keyframes on the Timeline” on page 
465).
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In some cases, figures can float above the surface 
of the floor after you import BVH data. Choose 

the Scripts > Utility > dropFigToFloorAllFrames 
command for a useful Python utility that drops the 
figure to the floor across all keyframes.

Advanced Animation Techniques
This section is where we stop talking about technical details for 
a moment and focus on a few artistic considerations. Editing 
animations is pretty easy work in and of itself. Getting your 
animation to look just the way you want it and adding realism 
are the hard parts. A jerky movement can turn smooth and 
flowing or an unrealistic motion can become realistic if you keep 
a few simple techniques in mind.

Keyframes and Timing

How should you space keyframes? Begin by considering time 
and frame rate. Space keyframes so that the motion looks 
natural at the selected frame rate. For example, if you have a 
motion that requires 4/5 of a second, you’ll need 24 frames 
at 30fps, 20 frames at 24fps, 9 frames at 12fps, etc. The basic 
formula is frame rate (in frames per second) times motion 
duration in seconds = number of frames required.

Creating Realistic Motion

Now that you’ve gotten the number of frames required for 
a motion down, what’s next? Break down the motion into 
component parts. For example, look at a baseball player 
swinging a bat. At first glance, it may look like the arms are 
moving. Upon closer inspection, however, you see that the 
entire body is in motion. Some movements, like the arms and 
legs, are more pronounced that others. So, begin with the large 
movements then go back and work on the finer adjustments. 
Using our baseball player example, you could start with two 
keyframes: One at the beginning of the swing, the other at the 
end.

Previewing this animation with only two keyframes would 
probably give you a pretty good result, however the details are 
where your animations will shine.

Now that the major motions are roughed in, let’s add some 
detail. For example, add the hip swings, shoulder tilts, etc. The 
subtle details may not be overly noticeable, but your viewers will 
pick up their presence or absence though they may not be able 
to tell you what’s wrong with your animation if these elements 
are not present. Poser’s Animation palette and graph (described 
in the previous sections) are ideal for this fine-tuning. Smooth 
transitions don’t occur in all movements. For example, when a 
bat strikes a fast-moving baseball, there is an immediate change 
in direction. This is an animation where linear interpolation 
might be better suited. You can adjust splines in the Graph 
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palette, or change interpolation types to create motions. You can 
adjust splines or change interpolation types in the Graph palette.

By working this way, you can create any kind of action and can 
make that animation look as realistic as possible.

Animatable Origins

The Animatable Origin option appears in the Properties palette 
when a prop is selected, or when a body part on a poseable figure 
is selected.

 The Animatable Origin option.

When checked, the Animatable Origin option allows you to 
animate the actor’s origin as the actor is translated, rotated, or 
scaled. This allows you to optimally position the joint origin 
if the shape of the actor changes drastically by scaling or 
morphing.
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Consider the example shown in the following figures, which was 
prepared by Nerd3D. In this example, the default Andy figure 
has been morphed into an alien shape.

 A drastically morphed character.

Because the width and shape of the shoulders has changed so 
much from the original figure, the upper arm no longer rotates 
with proper respect to the new shape and size of the shoulder. 
When the “Alien Andy” morph is dialed in and the arm is raised 
up, the arm rotates through the shoulder.

 When the upper arm on the morphed character is rotated, its joint 
.center is no longer appropriate for the morphed body shape.
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When using animatable origins, you will get 
much better bending if you first merge your 

spherical and capsule zones into weight maps first, as 
outlined in “Adding a Weight Map” on page 747. At a 
minimum, convert the body parts where the mesh is 
most affected by the morph (the shoulders, forearms, 
head and neck in the case of this alien morph). Affected 
actors will also allow you to create joints that bend more 
naturally in respect to the joints around them.

After you convert your body parts into weight maps, use the 
Properties palette to set the Animatable Origin option on for 
each origin you need to change. You’ll also want to make sure 
that the Display Origin option is checked so that you can see and 
position the origin. When viewed in Outline display mode, you 
can easily see which origin points need to be adjusted when the 
morph is dialed in.  Original joint centers as they appear in relation to the morph.

The Dependency Editor, discussed in “Using Dependent 
Parameters” on page 666, allows you to link the morph with 
the new positions of the joint centers. For example, after the 
“Alien Andy” morph is dialed in, you would open the Dependent 
Parameters editor and click Start Teaching to record the new 
positions of the joint centers that you want to change. Any 
changes you make to the joint positions are changed in the 
Dependent Parameters editor as shown in the following figure.
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 The Dependent Parameters editor will track positions of the Origin 
X, Y, and Z dials after “Start Teaching” is pressed.

After you adjust the X, Y, and Z origin of the current joint, click 
Stop Teaching. Select the next joint you want to edit, and Start 
Teaching again.

DO NOT use Figure > Symmetry to copy the new 
joint positions to the other side of the body. 

Doing so will copy the positions of all joints into the 
Dependent Parameters editor.

Continue as such until all of your joints are adjusted. They will 
all be recorded in the Dependent Parameters editor. After you 
have them all set up, click Stop Teaching again. After all of your 
joints are positioned you will see the morphed character pose 
much more naturally, and the way it is supposed to.

 The new positions of the joints.
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Long/Complex Animations

If you are trying to make a long movie or one that incorporates 
changing cameras, you should create small clips and edit them 
together in a video editing application such as Adobe Premiere.

Saving Animations to the Library
You can save animations to the Library palette as still (single-
frame) or animated (multiple frame) poses for use with other 
figures/props. See “Adding Items to the Library” on page 162 
for more information on saving still or animated poses to the 
Library.
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Chapter 23: Using Bullet 
Physics

The Physics Simulation palette allows you to incorporate Bullet 
physics into your Poser animations. To open the palette, choose 
Window > Bullet Physics Controls.

After you create a simulation, the objects in your simulation can 
be assigned one of three object types, which are detailed further 
in the sections that follow:

Creating a Simulation
The Physics Simulation palette allows you to create one or more 
physics simulations in your Poser project. Each simulation 
defines the following:

• The objects that will be included in that physics simulation.

• The frames in your animation project in which the physics 
calculations will be applied to the defined objects

• Settings that will be applied to all of the objects included in 
that simulation.

To create a new simulation, follow these steps:

1. From the Physics Simulation palette, click the New button 
to create a new simulation.

2. The Simulation Name dialog will prompt you to enter a 
name for the simulation. After you enter the name, click OK 
to create the simulation.

3. To limit your simulation to certain frames in your project, 
enter the starting and ending frames of the desired frame 
range in the Start Frame and End Frame fields.

 Setting up a new simulation.

Using Live Simulation
As you configure the settings and constraints that you apply to 
the physics objects in your scene, you can view the effects of 
those settings in real time. Check the Live Simulation option 
to preview how your simulation settings and weight painting 
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affect the physics objects in your scene. The live previews are 
especially helpful while you paint constraint maps that control 
how the objects respond to gravity, motion, and collision with 
other objects.

Live simulations do not add keyframes to the 
Animation Palette.

The Live Simulation button will be disabled until 
after you set up the simulation objects in your 

scene.

Pressing the Clear Simulation button will return 
the objects to their default state. You will need to 

uncheck the Live Simulation option before clearing the 
simulation.

Calculating Simulations
Click the Calculate Simulation button to calculate your 
simulation frame by frame for the currently selected simulation. 
Keyframes will be added to the Animation palette for each object 
in the current simulation.

Keyframes that are added to the Animation 
Palette after calculating a simulation will be 

removed when you click the Clear Simulation button.

Use the Animation > Recalculate Dynamics > 
All Physics menu command to calculate all of 

the physics simulations in your current project.

Object Types
After you create a new simulation, you need to set up the 
simulation objects in your scene. Click the Objects button to 
open the Select Objects dialog.

 Click the Objects button to define your physics objects.

The Select Objects dialog displays three tabs: Choreographed, 
Rigid Dynamic, and Soft Dynamic. As you switch from one tab 
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to the next, you place a check beside each of the objects in your 
scene that you want to designate as that object type.

• Choreographed is used to define stationary or animated 
objects in your scene that the dynamic objects will collide 
with. See “Physics Object Types.” on page 496.

• Rigid Dynamic is used for hard-bodied objects that will 
have physics applied to them. These objects will maintain 
their shape when they interact with other objects in the 
scene. See “Rigid Dynamic Objects” on page 497.

• Soft Dynamic is used for soft-bodied objects that will have 
physics applied to them. The shape of these objects are 
affected by collision with other objects in the scene. See 
“Soft Dynamic Objects” on page 497.

 The Select Objects dialog allows you to assign the objects in your 
scene to one of three types of objects.

When you assign physics objects in your scene, keep in mind 
that you don’t have to assign every object in your scene as a 
physics object. For example, if your scene is composed of many 
walls and furnishings inside a room, the only objects that you 
need to assign to the current physics simulation are those that 
will directly come into contact with each other in the simulation 
that you are configuring.
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 Physics Object Types.

Choreographed Objects

Choreographed objects are those which either remain stationary 
or are animated manually with keyframes. When assigning 
choreographed objects, you only need to assign the objects that 
you expect the other physics objects to collide with.

A simple example is shown in the figure that follows. There 
are five objects in the scene: the ground, a large box, two balls, 
and a cloth plane. Only two objects in the scene are assigned 
as choreographed objects: the ground, and the large box in the 
center. These two items will not move, and the other objects in 
the scene will collide against them.

 Choreographed objects are those that other physics objects collide 
against.
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Rigid Dynamic Objects

Rigid dynamic objects are those which will interact with other 
objects, but which will maintain their shape when they collide 
with other objects in the scene. The figure shown below shows 
two balls that are selected as rigid body objects. They will 
maintain their shape when they collide against the other objects 
in the scene.

 Rigid dynamic objects maintain their shape when they collide 
against other objects.

Soft Dynamic Objects

A soft dynamic object will change its shape or appearance when 
other objects collide against it. One obvious example is a cloth 
plane, as shown in the following figure. However, it’s also useful 
for other items such as a rubber ball that squashes and stretches 
in response to its collision with the ground; or jiggle that you can 
add to a heavy cartoon figure as he or she walks or runs across 
the scene.

 Soft dynamic objects change shape when they collide against other 
objects.
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Setting Object Properties
The Properties tab in the Physics palette allows you to assign 
properties to each of the physics objects in your scene. The 
properties that are available depend on the type of object you are 
configuring.

 Setting Object Properties.

Select the object that you want to configure from the Object 
menu, and then click the Properties tab to display the following 
options:

If your scene includes several objects that need to share the same 
physics properties (for example, ten bowling pins), create the 
first object and set its physics properties.  Then use the Edit > 
Duplicate Object command to duplicate the first object and its 
physics properties. The duplicated object will automatically be 
added to the current simulation. Alternatively, you can save the 
first object to the Library with its physics properties, and then 
add it from the Library to the current simulation.

 You can duplicate objects to add a new object with the same physics 
settings.
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• Active: Check this option to apply the physics simulation 
calculations to the currently selected object. You can 
uncheck the option to remove the object from the 
calculations without affecting the other settings that are 
applied to it.

• Apply Velocity from First Frame: If an object is animated 
up to the starting frame of a physics simulation, check this 
option to set the initial velocity of the object to be the same 
when the simulation starts.  For example, if you want a 
bowling ball to move at a certain speed and direction, move 
the frame before you want the physics to take over. Advance 
to the next frame and move the ball to reflect the speed 
and direction that you want the ball to move. This will set 
the base velocity which will be taken into account when the 
simulation is calculated.

• Use Animated Mesh: When this option is checked, a new 
collision geometry will be created at every frame for the 
selected choreographed object, to support morphs, bending, 
magnets, etc. It generates a convex hull for each frame from 
the bent parts.

If you want the physics to take over at a frame 
other than 1, make sure that you set the 

appropriate start frame in the Physics Palette, as 
described in “Creating a Simulation” on page 493. 

• Collision Margin: Defines the amount of distance that will 
be allowed between physics objects and the objects they 
collide with. Penetration can occur if the margin is set too 
low. 

The Collision Margin setting is related to your 
preferred units. which are set in the Interface tab 

of the General Preferences dialog, described in 
“Interface Preferences” on page 33. For example, if 
you have your preferred units set to Millimeters, the 
value 5.0000 will represent 5 millimeters. 

• Friction: Lower friction amounts cause objects to move 
more easily over other objects. A value of 1 will make the 
object very sticky, and a value of 0 will make the object more 
slippery.

• Bounce: Low values make the object less bouncy; higher 
values make the object more bouncy. When bounce is set to 
0, the object will not bounce. A value of 1 makes the object 
bounce indefinitely.

• Linear Damping: (Hard and Soft Body objects only). The 
amount of energy that is lost during each iteration when an 
object moves linearly (such as from side to side). Without 
damping, the object will appear to vibrate in the scene. A 
value of 1 will absorb shock. A value of zero will remove 
damping from the object.
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• Rotational Damping: (Hard Body objects only). Similar to 
linear damping, except that this setting controls the amount 
of energy that is lost during each iteration when an object is 
rotating or spinning.

• Mass: (Hard and Soft Body objects only). A relative 
measurement that affects how objects of a higher mass 
interact with objects of a lower mass. Items with a lower 
mass setting will accelerate more after a collision than 
items of a larger mass. Stronger forces will be needed to 
move objects that have a higher mass. When objects with 
a higher mass interact with objects of a lower mass, the 
objects of lower mass will move more easily. Using the 
example of a bowling ball and pins, the mass of the bowling 
ball (example: 16 units) should be set higher than that of 
the pins (example: 2 units) in order for the pins to react 
appropriately when the ball strikes them.

• Internal Pressure: (Soft Body objects only). Specifies the 
internal pressure of the object. Objects that have a greater 
internal pressure will collapse upon themselves less than 
objects that have a smaller amount of internal pressure.

• Linear Stiffness: (Soft Body objects only). Lower the linear 
stiffness to make the object more stretchy; increase the 
value to make it more stiff.

Choose Edit > Memorize > All after all of the 
objects in your scene are set up. This allows you 

to go return to the original placement of your objects 
after you experiment with settings during live 
simulation. 

Simulation Settings
Click the Settings button in the upper section of the Physics 
Palette to configure general settings for the current simulation.

 Click the Settings button to configure general settings for the 
simulation.

The Simulation Settings dialog opens, and you can configure 
the following properties for the simulation:
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 Simulation Settings dialog.

• Gravity: Controls the strength of the gravity in the scene. 
Values below zero pull objects downward, while values 
above zero act like “anti-gravity” and make objects rise.

• Damping: Controls the amount of resistance that your 
objects have to gravity. Lower values make the object less 
resistant, and higher values make the object more resistant.

• Default Soft Collision Margin: Controls the distance that 
soft body objects have to be before collisions are recognized. 

The Default Soft Collision margin is the default value 
assigned to soft-bodied objects when you add them to a 
simulation.

• Default Rigid Collision Margin: Controls the distance that 
hard body objects have to be before collisions are detected. 
The Default Rigid Collision Margin is the default value 
assigned to rigid-bodied objects when you add them to a 
simulation.

• Steps Per Second: Defines the number of small steps that 
the simulation will take per second. Increasing the Steps 
per Second setting will give more stable results and better 
penetration persistence in your simulations. Calculations 
will take longer with higher steps per second.

• Better Soft Collisions with Clusters (Slower): Improves 
simulation of soft bodied objects when collisions take place, 
and can help prevent objects from penetrating through soft-
bodied objects. Using clusters on detailed objects can slow 
calculations considerably.

Object Constraints
The Constraints tab in the Physics palette allows you to configure 
one of three different types of constraints for your physics 
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objects. It also features painting tools that allow you to paint 
vertex maps that determine how the object responds to physics.

To add a constraint to the currently selected physics object, click 
the New button in the Constraints tab. You’ll see a menu that 
allows you to choose one of several constraint types. These are:

  Creating a new constraint

• Self Constraint: Defines how the object responds to physics 
calculations. Each object can have only one self-constraint. 
After you add a self-constraint, all vertices are initially set to 
fully dynamic. Use the vertex painting tools to constrain the 
vertices that you paint.

 Self Constraint with painted vertices on a cloth plane.

• Animated Constraint: Allows you to use a handle to 
animate an object. The handle can be assigned as a child of 
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any other object in your scene, or animated in any way you 
choose. The handle serves as a transform that you can move 
things around with. The handle will pull on the vertices that 
you paint. To configure an animated constraint:

 � Position the animated handle where you want it to 
appear. Generally, the handle should be positioned near 
the object that you are adding the animated constraint 
to.

 � Press the Set Handle Position button.

 � Use the painting tools to constrain selected vertices to 
the animated handle.

 Animated Constraint handle with constrained vertices.

• Object Constraint: Constrains one object to another so that 
they move together. You use a handle to define the point at 
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which the two objects are supposed to connect to each other, 
and tries to keep both objects connected at that point. For 
example, if you have two rigid boxes, named Box 1 and Box 
2, that you want to connect together at a certain point:

 � Select Box 2, and click the New button in the 
Constraint tab to create an Object Constraint for this 
object.

 � For the Constrain To object, select Box 1.

 � Position the handle at the point where you want to 
connect the two objects.

 Setup for an Object Constraint.

 � Click the Set Handle Position button after you position 
the handle.

 Setup for an Object Constraint.

You can chain multiple items together in this 
manner. For example, you can add another 

object (such as a third box), and then create another 
Object Constraint that links Box 3 to Box 2.
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Soft bodied objects may drift away from the 
handle during simulation. Adding a second 

Object Constraint between the same two objects may 
improve performance.

 � When you click the Live Simulation or Calculate 
Simulation button you should see your objects moving 
together. For example, you can drag Box 1 around, and 
Box 2 will automatically follow it.

 Move Box 1 and Box 2 will follow it.

• Limited Object Constraint: Constrains one rigid object to 
another so that they move together, and also allows you to 
limit rotation or translation in the X, Y, and/or Z direction. 
The Limited Object Constraint can only be applied to a 
Rigid Body object. Again, you have two rigid boxes, named 
Box 1, and Box 2. You want them to connect together at a 
certain point, but you want to limit the rotation of Box 2 to 
the Z axis:

 � Select Box 2, and click the New button in the 
Constraint tab to create a Limited Object Constraint 
for this object.

 � For the Constrain To object, select Box 1.

 � Position the handle at the point where you want 
to connect the two objects. (The result should look 
similar to the setup shown previously for the Object 
Constraint.)

 � Click the Set Handle Position button after you position 
the handle.

 � The lower section allows you to set the limits for the X, 
Y, or Z translations and rotations. In this example, we 
want to allow rotation only on the Z axis. The X and Y 
axis rotations are set to 0 minimum and maximum.
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 Limiting rotations to the Z axis only.

 � When you click the Live Simulation or Calculate 
Simulation button you should see your objects moving 
together, with the translations or rotations set as you 
configured for the Limited Object Constraint. In our 
example, you can drag Box 1 around, and Box 2 will 
automatically follow it but the rotation will be limited 
to the Z axis.

 Move Box 1 and Box 2 will follow it with limited rotations.

Painting Constraints

After you set up one of the constraint types mentioned in the 
previous section, you can use the paintbrush tool to paint a 
vertex map that defines how the object will respond to that 
constraint type.
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 Paintbrush tool.

After clicking the Paintbrush icon, the Dynamics Weights palette 
opens. This palette allows you to paint the vertices on the object 
to control how they will be affected by the physics engine. As you 
paint, the vertices are coded with various colors.

• Where no color appears, the object will be 100% affected by 
the dynamics in the physics calculations.

• Where color appears, darker colors define areas that will be 
affected by dynamics the most; brighter colors will define 
areas that will be less affected.

• Green areas define areas that will not be affected by the 
physics calculations.

 Cloth plane with self constrained vertices fully (left) and partially 
(right) across the top.

The Dynamics Weights palette contains the following sections 
and settings:

• Painting Modes section: Choose one of the following 
painting modes for your dynamic weights paintbrush:

 � More dynamic: Select this painting mode when you 
want to make the object more responsive to physics 
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calculations. Vertices will appear with no color when 
they are fully dynamic.

Initially, all vertices of an object are set to fully 
dynamic unless you check the Invert Colors 

option mentioned below.

 � More constrained: Select this painting mode when you 
want to paint areas on an object to reduce the amount 
of response to physics calculations. Vertices will appear 
as bright green when vertices are fully constrained, and 
the object will retain its base shape in those areas.

 � Smooth: Choose this painting mode when you want 
to smooth or blend transitions between areas that are 
more dynamic and areas that are more constrained.

 � Weight: Choose this painting mode when you want 
to paint with a predefined strength value. Enter the 
desired value in the Weight field that appears beneath 
the option.

 Dynamics Weights Palette.

Deleting Constraints

To delete a constraint, follow these steps:

1. From the Object menu in the Physics Simulation palette, 
select the object that contains the constraint you want to 
delete.

2. Switch to the Constraints tab, if necessary.

3. Select the constraint that you want to delete from the list 
of available constraints (which appears just above the 
paintbrush).

4. Press Delete to delete the selected constraint.
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Deleting a Simulation
If more than one simulation exists in your scene, first click the 
simulation that you want to delete from the list in the Simulation 
Palette. Then click the Delete button in the upper section of the 
Physics Simulation palette.

Saving Objects with Bullet Physics
After you create objects that have Bullet Physics applied, you can 
save them to the Library with their settings intact. This allows 
you to save items that bounce, or jiggle, or use specific hard or 
soft-bodied settings.

After a Bullet Physics object is saved to the Library, you will 
need to resimulate the object(s) when you load them into your 
scene. If an object is shared between two or more simulations, it 
will only save the current simulation that was selected when you 
saved the object to the Library. 
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Chapter 24: Rendering 
Animations

Your can access the Movie Settings window by selecting 
Animation > Make Movie. This window can also be accessed 
via the Render Settings dialog. The Movie Settings window 
appears as follows.

 The Movie Settings dialog.

To use the Movie Settings window:

1. Select your desired movie format using the Format pull-
down menu. Your available options are:

 � Image Files (Mac and Windows): This option creates 
an Image Sequence, which is a series of still images, 
one for each frame in your animation. For maximum 
value results and optimal quality, we recommend using 
the Image Files option to render your final movie, and 
then using a compositing tool for editing and post-
production work.

 � Flash (Mac and Windows): Adobe Flash is a popular 
format for animations posted on Web sites. If you have 
selected Flash format, click the Options button for 
settings specific to that format. The Flash movie options 
will be discussed in detail later in this chapter. See 
“Flash Options” on page 515 for more information.

 � Quicktime (Mac Only): Default Macintosh movie 
format. We recommend that you use this format 
only for preview purposes while still working on your 
animation, as it provides the fastest possible access to 
rendered results. See “QuickTime Options” on page 
513 for more information.

 � AVI (Windows Only): Three options are available in 
Windows for AVI format. Choose AVI (MJPEG) to 
produce an AVI file of any dimension, using a higher 
amount of compression (for streaming); choose AVI 
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(DV) to produce a 720x480 pixel DV-quality AVI file. 
Choose AVI (Uncompressed) to produce an AVI file of 
any dimension, which will not be compressed.

 AVI DV format will produce a 720 x 480 pixel 
AVI file, regardless of your render settings. If 

your project render settings are not set to the same 
aspect ratio, the movie will be stretched to fit within the 
720x480 movie file.

 � iPad Videos (Windows Only): Two options appear in 
Windows to save your files in M4V format. Choose iPad 
Video (small) to render a M4V file that has a higher 
amount of compression. Choose iPad Video (large) 
to create a M4V video file with less compression and 
higher quality.

iPad Small and Large options may not be 
available on earlier versions of Windows.

 � WMV/ASF (Windows Only): Three options appear for 
WMV/ASF format, for varying compression options: 
Medium Quality, High Quality, and Uncompressed.

WMV/ASF options use Windows Media Audio 10 
and Windows Media Video 9.

WMV output presets are also available in 
Windows Vista, and Poser will write out valid 

WMV files if you choose the WMV/ASF preset. While 
Media Player for Windows Vista does not support WMV 
files, you will be able to play them in any third-party 
media player that runs under Windows Vista and has 
WMV support.

2. Select which renderer you wish to use for your animation 
using the Renderer pull-down menu. Your options are the 
FireFly, Sketch or Preview render engines. See “Chapter 
19: Using The FireFly Render Engine” on page 404 
for more information about the FireFly renderer, and 
“Chapter 20: The Sketch Designer” on page 440 for 
more information about the Sketch Designer renderer. The 
Preview renderer provides a quick draft-quality render of 
your movie.

3. Under the Options section, check the appropriate 
checkboxes when available:

 � Antialias: Antialiasing is available with the Preview 
render engine, to improve the quality of images in draft 
preview renders.

 � 2D Motion Blur: This option provides realistic 2D 
motion blurring effects to images and animations 
rendered with the FireFly or Preview render engines. 
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Use the Blur Amount value to customize the results of 
this effect.

4. Click the button in the lower left corner of the Movie 
Settings tab to open the Render Dimensions dialog. Enter 
the desired dimensions for your movie.

 Setting Render Dimensions.

5. Specify your desired export Resolution Scale. The Quick-
Scale pop-up menu offers quick access to four different 
render scale options: Full Size, Half Size, Quarter Size, 
and Preview Size.

 Note that the Resolution Scale feature is not 
intended to replace the Frame Size value, but 

rather is a tool for facilitating quick render previews, as 
the smaller scale render sizes require less time to 
calculate.

The production frame is determined by the 
aspect ratio resulting from the output width and 

height. You can set the production frame to be visible in 
the Document window’s scene preview area, by selecting 
Display > Production Frame from the menu bar.

6. Specify your Time Span settings:

 � Range: Enter the start and end frame numbers for the 
portion of your animation that you wish to render in the 
Start and End boxes. This feature is useful if you wish 
to save a subset of the total animation. For example, if 
you create a 60-frame animation, you could opt to save 
a 15-frame movie beginning 35 frames into the total 
animation.

 � Increment: Click the appropriate Increment radio 
button to specify how many frames to render in your 
movie output. Your choices are as follows:
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All Frames: Clicking the All Frames button will render 
all frames in the specified range, as defined by the 
movie’s frame rate.

Frame Rate: Click the Frame Rate (number of frames 
per second) radio button to use the movie’s current 
output frame rate (as opposed to the actual frame 
rate of the Poser keyframe data) or specify your own. 
Enter the desired frame rate in the box, if you wish to 
specify a frame rate other than the rate defined for the 
document (for example, lower frame rates are generally 
recommended for Flash output). Higher numbers give 
smoother animations but require longer rendering 
times and take up more room on your hard drive. 
Please refer to “Frame Rate” on page 455 for a listing 
of common frame rates.

Every Nth Frame: Clicking this radio button allows 
you to render fewer frames, for fast preview purposes. 
For example, rendering every 2nd frame takes half the 
time as rendering every frame, and so on. Specify your 
desired “N” value in the box.

7. Click the Make Movie button to open the Save Movie 
dialog box, which allows you to browse for your desired 
folder, then click the Save button to save your new 
animation to the selected folder. Animation renders can take 
some time depending on your scene, animation settings, 
and computer, so please be patient.

QuickTime Options
When you choose Quicktime format and click the Options 
button, the Compression Settings dialog opens. This dialog 
includes the following settings for 32-bit Macintosh systems:

Certain Codecs may require a specific image 
aspect ratio in order to function properly.

 The Compression Settings dialog (32-bit Macintosh systems).
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• Compression Type: Select which Codec you wish to use 
from the Compression Type pop-up menu. Note that 
certain Codecs offer additional configuration settings, as 
mentioned below. Available choices are Animation, Apple 
Intermediate Codec, DV-PAL, DV/DVCPPRO-NTSC, 
DVCPRO-PAL, DVCPRO50-NTSC, DVCPRO50-PAL, 
H.264, MPEG-4 Video and Photo-JPEG.

Certain Codecs may require a specific image 
aspect ratio in order to function properly. 

Depending on the codec you select, the selections will 
vary.

For information on Motion, Encoding Mode, and 
Compression settings, refer to QuickTime 

documentation at http://images.apple.com/quicktime/
pdf/QuickTime7_User_Guide.pdf.

When running Poser on a 64-bit Mac, the choice set for 
Quicktime movies is a more contemporary selection set than 
previous versions of Quicktime.

 The Save dialog (64-bit Macintosh systems).

• Format: Select which Codec you wish to use from the 
Compression Type pop-up menu. Note that certain Codecs 
offer additional configuration settings, as mentioned below. 
Available choices are H.264 (saves as .MP4), Apple Pixlet 
(saves as .MOV), MPEG-4 (saves as .MP4), and DVC Pal, or 
DVC NTSC (which save as .DV).

Certain Codecs may require a specific image 
aspect ratio in order to function properly. 

Depending on the codec you select, the selections will 
vary.

http://images.apple.com/quicktime/pdf/QuickTime7_User_Guide.pdf
http://images.apple.com/quicktime/pdf/QuickTime7_User_Guide.pdf
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• Quality: Choose the level of quality that you desire. Choices 
are Maximum, High, Normal, Low, and Minimum.

Flash Options
Clicking the Flash Options button opens the Flash Settings 
dialog. You have the following options when exporting Adobe 
Flash movies:

 The Flash Export dialog.

• Overlap Colors: Checking the Overlap Colors checkbox 
causes Adobe Flash to take the color that is used the most 
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and create a silhouette of the entire object (such as a figure 
or prop). The next color is placed on top of the first, and so 
on, with each layer of color containing the layers above it. 
Selecting this option makes for larger files, but will increase 
the quality of the final file. Deselecting this option causes 
blocks of different colors to appear next to each other with 
no overlapping, which could cause the animated object to 
appear broken or discontinuous.

• Draw Outer Lines: Checking the Draw Outer Lines 
checkbox draws a border around the entire silhouette.

• Draw Inner Lines: Checking the Draw Inner Lines 
checkbox draws lines around each color layer.

• Line Width: Enter the desired line width (in pixels) in the 
Line Width box.

• Number of colors: Enter the desired number of colors 
in the Number of colors box. Note that adding colors 
will increase the file size and download time for people 
viewing this file via the Web. Four colors are good for most 
situations, though the maximum possible is 253.

• Color Quantization: Quantization is the process of 
selecting the specified number of colors that best represent 
your Poser figure. You can select either Auto or Custom 
quantization of colors. In either case, your color choices will 
be saved with the project file.

• Auto Quantization: Check the appropriate radio button 
to select if you want the quantization to occur across All 
Frames or at a Specified Frame.

 � All Frames: This option can be useful in situations 
when you want color quantization to be applied to each 
frame; for example, if you are animating materials.

 � Specified Frame: If you selected Specified Frame, 
enter the frame number where the quantization should 
occur in the Specified Frame field.

 � Custom Quantization: You can select custom colors 
by clicking within the color preview windows to bring 
up the Poser Color Picker. The number of custom color 
preview windows will be determined by the Number 
of Colors setting (see above). Mousing over any of the 
preview windows will display the RGB color values for 
that color at the top right of the Custom Color display 
window. Click on the AutoGenerate Colors button to 
restore the default custom color values.

For optimal results when exporting to Flash 
format, use the scene preview Cartoon display 

style when preparing your scene.



Poser Pro 2014
Reference Manual

517

Chapter 24: Rendering Animations

Part 6: 
Customizing 

Content
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Chapter 25: The Face 
Room

Adding realistic custom faces and creating a personalized head 
can be an extremely complex undertaking, but Poser’s powerful 
Face room greatly simplifies the process. In just a few minutes, 
you can make your figure look like you, one of your friends, or 
anyone! With a few steps, you can reshape a figure’s face using a 
collection of dials that drive sculpting morphs, or import facial 
photographs to match the face in the images.

By default, an HTML Help window opens when 
you enter the face room. This window contains 

additional tips and tricks for obtaining optimal results. 
If you do not see this window, please select Window > 
Room Help.

The Face room creates heads for use with the following figures 
(listed from newest to oldest):

• Poser 10/Poser Pro 2014 figures: Rex and Roxie

• Ryan, Alyson, and their ethnic variations, including lo res 
versions

• Poser 7 Figures: SimonG2 and Sydney G2

• Other G2 Figures: JamesG2, Jessi G2, Kelvin G2, Koji G2

• Apollo Maximus

• Miki, Miki 2, Miki 3, and Miki 4

• Poser 6 Figures: James and Jessi

• Poser 5 Figures: Don and Judy

The Face Room is shown below, with all palettes and options 
docked. If you need to show the Face Room windows, choose 
Window > Room Tools > Face, and select Face Preview, 
Photo Lineup, Texture Preview, Face Texture Tool, Face 
Shaping Tool as desired. These windows are described in the 
sections that follow.
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 The Face Room.

The number of palettes and options that you see 
in each room depends upon your screen 

resolution. At higher resolutions, the default work 
spaces display more palettes, while at lower resolutions 
you see fewer palettes.

The Face room contains the following interface elements in 
addition to some of the standard elements.

• Photo Lineup (1): The Photo Lineup area is where 
you load images and align them using a variety of tools. 
Activating the Apply Shape checkbox generates geometry 
matching your photos. The texture map and the geometry 
based on the photos gets generated on the fly.

• Face Texture Tool (2): The Face Texture Tool area lets you 
apply a multitude of ethnic and other settings to modify the 
current head texture map.

• Face Preview window (3): The Face Preview window 
displays a preview of your 3D head with textures. This 
window features Mini Camera controls in its upper right 
corner. You can also use the Face Shaping Tool (see “The 
Face Shaping Tool” on page 527) to sculpt the face to your 
exact specifications.

• Random Face button (4): Clicking the Random Face 
button creates a completely random face. This will erase 
any prior work you’ve done in the Face room and should 
be used with care. The Random Face feature is a great way 
to create realistic-looking characters by clicking a single 
button. Click it as many times as you like until you get the 
look you want!

• Reset Face Room button (5): Clicking the Reset Face 
room button restores the default head shape and texture. 
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This will erase all of your prior Face room work. Use this 
option with care.

• Texture Preview window (6): The Texture Preview 
window lets you see your head texture map as you edit it 
and also allows you to load and save textures for further 
work.

• Action buttons (7): The Action buttons are where you 
apply customized head geometries to your figures, spawn 
morph targets, or import head texture maps.

• Face Shaping Tool palette (8): The Face Shaping Tool 
window is where you control the Face Shaping tool, which 
is the equivalent of the Morphing Tool (see “Creating 
Morphs with the Morphing Tool” on page 642) for the 
Face room. You can modify heads by using the parameter 
dials and/or the tool in this room.

Each of these areas is discussed below in this chapter.

As mentioned above, there are several methods for creating 
custom heads.

• Using two images to shape the geometry and create a 
texture map.

• Using the Face Shaping tool to sculpt the head as you 
desire.

• Using the Texture Variation area to create custom texture 
maps quickly and easily.

• Using the Random Face feature.

The Face room allows you to do any or all of these things when 
creating heads. We’ll discuss the other functionality in the 
subsequent sections. For now, let’s walk through using images to 
create a custom head.

If you want to reset the Face room to its default 
state, click the Reset Face room button. This 

erases all loaded images, deletes geometry changes, and 
loses any texture modifications you might have made. 
Use this option with care!

Using Images to Create Heads
Creating custom 3D heads from existing images/photographs 
(digital or scanned) requires the following steps:

1. Load the images.

2. Align the images (if needed).

3. Align the geometry to the images.

4. Apply the new shape to your figure.
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Apply the images you used to create the head as a texture map, 
then apply the geometry shape and texture to the head.

Once you’ve completed these steps, you can proceed to use the 
Face Shaping tool and/or the Texture Variation functionality. 
If you do not want to use your own images, feel free to skip 
ahead and explore the other head creation/customization 
methods.

Step 1: Images

Creating a personalized head that matches a real person involves 
using two pictures to create a texture map. Let’s load some 
images and build a personalized head!

Please follow these simple guidelines for optimum results:

 Select an evenly lit front and profile picture for best results.

• Front image: The front image should be a straight-on 
front view with the subject directly facing the camera and 
with the camera level with the subject’s face. The picture 
should be close enough to capture plenty of detail. Lighting 
should also be adjusted to capture the most detail. Overly 
bright lighting will give the image a washed-out appearance, 
while overly dark lighting will not show off enough detail. 
The person’s mouth should be closed and the overall facial 
expression should be neutral for best results.

• Side image: The side image should be a direct side view 
with the subject facing 90 degrees from the camera and 
with the camera level with the subject’s face. The remaining 
guidelines for the front image apply to the side image as 
well. Ideally, the front and side views should be taken from 
the same distance.

The above images are great examples of ideal images. You can 
use less than ideal or even mismatched images, however you 
may get some unpredictable results. Each image has its own 
alignment tools that can help position it optimally (see next 
step). Of course, you can always experiment and have fun if you 
want to!

The Face room supports most common image formats.
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You must import existing images. Poser does not 
have the functionality to create images. Images 

can be photographs, line drawings, paintings, etc. The 
Face room accepts most common image formats. 
Textures generated from these images are sized at 
512x512 pixels by default.

Step 2: The LineUp

Begin by clicking the Load icon (see below) for the front or 
side image in the Photo Lineup area and locate the image you 
want to use. For each image, Poser will ask you to locate several 
points on the face. This will help it align and match the default 
3D head to the images, which you can then fine tune. To locate 
the specified facial point on your own photo, click its location as 
shown in the example face.

For the front image, you’ll be asked to locate the outside corner 
of the figure’s right eye and left corner of the lips, as shown 
below.

 The Photo Lineup area.

For the side image, you’ll need to locate the top of the right 
earlobe and the front of the chin in the same manner as you did 
for the front image.

The side image uses the subject’s right side. If 
your side image is of the subject’s left side, you 

can click the Flip icon to reverse the image.

Once loaded, the images appear in the workspace and the 3D 
head and texture map appear.
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 Tools in the Photo Lineup area.

Loading the images and locating the requested areas allows 
Poser to do a good job of approximating the location and shape 
of the head geometry. You may, however, wish to go in and 
perform some manual adjustments of the geometry’s location 
relative to the image.

To do this, each of the two images in the Photo Lineup area has 
the following tools:

• Load: Clicking the Load icon opens a standard OS dialog 
allowing you to browse for and select your desired front 
image. Once you load an image, you’ll be prompted to locate 
various facial features. This helps Poser custom-fit the 3D 
head to the images, as described above.

• Delete: Clicking the Delete icon deletes the currently loaded 
image.

• Zoom: Clicking and dragging the Zoom icon allows you to 
zoom in or out of the current image, allowing you to more 
precisely position and shape the head geometry. Clicking the 
Zoom icon and dragging to the right or up zooms in, while 
dragging to the left or down zooms out. This tool simply 
shifts your point of view; it does not affect the images or 
the geometry. You cannot zoom out beyond your image’s 
original size.

• Pan: Clicking and dragging the Pan tool moves the image 
in the same direction as your mouse movement. This is 
particularly useful if you need to zoom in to a particular 
area. You can individually pan the front and side images up, 
down, left, or right. The front image will pan in the X and Y 
axes (side-side and up-down) and the side image will pan in 
the Y and Z axes (up-down and front-back). This tool simply 
shifts your point of view; it does not affect the images or the 
geometry.
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• Rotate Geometry: Improper rotation may cause 
unsatisfactory photo lineup results. Ideally, the head should 
not be rotated relative to the camera. However, many 
photos show the head slightly rotated about the X axis (up 
and down), the Y axis (looking left to right), or the Z axis 
(tilting left to right). The Face room automatically detects 
and compensates for some rotation (about the Z axis in the 
front view and about the X axis in the side view), but you 
may still need to perform additional manual adjustments for 
best results.

 � To rotate about the X axis (front view), click and drag 
the mouse horizontally while pressing Shift.

 � To rotate about the Y axis (front view), click and drag 
the mouse horizontally while pressing Opt/ALT.

 � To rotate about the Z axis (front view), click and drag 
the mouse horizontally without pressing any keys.

 � To rotate about the X axis (side view), click and drag the 
mouse horizontally without pressing any keys.

• Scale Geometry: Clicking and dragging the Scale 
Geometry tool scales the geometry to align it to the image. 
This feature is useful if your loaded image(s) are larger or 
smaller than the geometry outline. You can pan up, down, 
left, and/or right. This tool scales the geometry without 
altering the image or your point of view.

• Pan Geometry: Clicking and dragging the Pan Geometry 
tool and dragging the mouse pans the geometry. This 
feature is useful if your loaded image(s) are not perfectly 
aligned with the geometry. The front image will pan in the X 
and Y axes (side-side and up-down) and the side image will 
pan in the Y and Z axes (up-down and front-back). This tool 
pans the geometry without altering the image or your point 
of view.

Poser does a good job at calculating how to shape the head 
based on the images, however you’ll probably need to fine-tune 
the head for best results. The head appears superimposed on 
the images with red lines showing the facial features and green 
control points. In this case, the head is a bit off-center as can be 
seen by both the superimpositions and the texture map. How do 
you fix this? Easy: Perform a little virtual surgery.

Step 3: Cyber Face Lifts

Looking at your loaded images, you will see the red outlines of 
a head superimposed on the images. Each major facial feature 
(eyes, nose, mouth, chin, etc.) has one or more control points, 
which appear as green dots. All you need to do is move the 
control points until they match the underlying image. Do this 
by placing the mouse pointer over the control point you wish to 
move. The cursor will change, at which point you can drag the 
selected control point up, down, left, or right. For example, you’d 
move the middle nose point until it’s just under the bridge of the 
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nose and the two side points until they’re at the corners of the 
nostrils, and so on. As you move the control points, you’ll see the 
head beginning to conform more and more to the figure. You will 
also see lines indicating how each control point has moved from 
its original position. If you wish to undo a control point move, 
simply use the [COMMAND]/[CTRL]+[Z] command to return 
the control point to its previous position.

You can also move the entire head using the Rotate Geometry, 
Scale Geometry, and Pan Geometry tools, which are described 
above. These tools move the head outline and alter the head 
geometry to match. To move your image without altering the 
head geometry, use the Pan Image tool, also described above. 
This will cause the image to slide over the geometry.

If you make a mistake while moving the control points, you can 
press [COMMAND]/[CTRL]+[Z] or select Edit > Undo to undo 
your most recent change.

Please refer to the Face room HTML Help 
window for additional tips & tricks. By default, 

this window appears when you enter the face room. If it 
does not appear, select Window > Room Help to open 
the window.

Here’s an example after adjustments.

 Results after adjusting the photo lineup points.

You can use the Zoom tool to move in closer to 
your images for even more precise control over 

the results.

Step 4: Applying the Geometry/Texture

The texture map is created in real time as you work. Enable the 
Apply Shape checkbox to apply your images to create a custom 



Poser Pro 2014
Reference Manual 

526

Chapter 25: The Face Room

head, which will appear in the Face Sculpting window. The 
head geometry is dynamically updated as long as Apply Shape 
is active.

Enabling the Apply Shape checkbox will erase 
any work you may have done with the Face 

Shaping tool. If you want to use a combination of 
images and shaping, be sure to work with the images 
before using the Face Shaping tool. This also occurs 
with textures; loading images will undo any work you 
have done in the Texture Variation area (see below).

Creating Custom Textures
The Face room includes the Texture Variation area, which 
allows you to create custom head textures from scratch or 
modify existing textures. The Face Room generates a new texture 
and blends between the imported texture and the original Poser 
figure’s texture and attempts to color match the new texture to 
the base figure if selected by the user. It also allows the user to 
select the imported Face Room photo resolutions for the new 
texture. .

To access the Texture Variation area, click the Texture 
Variation tab in area 2 of the Face room. This area allows you 
to:

• Create new textures from scratch by modifying the default 
texture.

• Modify textures created by loading images as discussed 
above.

• Edit loaded texture maps (see below).

Be sure to load/create your texture before using 
the Texture Variation area, as doing so 

afterward will lose your changes.

The Texture Variation area uses parameter dials that function 
similarly to the dials in the Parameters palette, whose 
functionality is described in “Parameters Palette” on page 197. 
You can use the Parameter Dial menu to access dial settings, 
reset a dial, or open the selected dial’s Graph (discussed in 
“Using Graphs” on page 458). You cannot, however, memorize 
Texture Variation dials. The available Texture Variation dials 
are:

• Facial Color: The Facial Color dials modify the color of 
several facial regions and include Beard dark/light, Eye 
sockets light/dark, Eyebrows lower light/dark, and 
Eyebrows upper light/dark.

• Ethnicity/Age & Gender: The Ethnicity/Age/Gender dials 
generate ethnic, age, and gender traits and include less/
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more African, less/more European, less/more Southeast 
Asian, less/more East Indian, Younger/Older, and Male/
Female.

• To modify your texture or the default texture, simply adjust 
the dials. Your work will appear in real time in both the 
Face Sculpting and Texture Preview windows.

Textures created in the Face room are scaled to 
512x512 pixels. If you used higher resolution for 

photo matching and want to keep the higher resolution, 
choose Yes in the dialog that appears after pressing 
Apply to Figure. To use larger texture maps, you can 
also import a custom texture, then modify it.

The Face Shaping Tool
The Face Shaping Tool allows you to visually sculpt your 
custom head by selecting and moving vertices. The Face room 
contains a wide array of custom vertex editing parameters 
for the Poser head that allow you to create virtually any face 
imaginable. By default, the Face Shaping Tool is active 
whenever your cursor is within the Face Sculpting window. 
Just as with the Morphing tool (see “Creating Morphs with the 
Morphing Tool” on page 642), you can use any combination 

of clicking and dragging morph targets and/or adjusting Face 
Shaping parameter dials in the Face Shaping Tool palette.

 The Face Shaping Tool.

To use the Face Shaping Tool:
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1. Click the portion of the face you wish to adjust and drag the 
mouse. This selects the vertex nearest the spot where you 
clicked and moves it in the direction you drag the mouse. 
You can use the Mini Camera controls in the upper right 
corner of the Face Sculpting window to position the head 
exactly where you want it at any time before, during, or after 
sculpting. Vertices are moved relative to your viewing angle. 
For example, if you are looking at the face head-on, clicking 
and dragging will move the morph up, down, left, and right. 
If you are looking at the top of the head, dragging will move 
vertices left, right, forward, and backward.

2. The Face Shaping Tool can manipulate all selected 
parameters in the Face Shaping Tool palette. Checking 
the checkbox next to a parameter dial includes the specified 
vertex parameter when using the tool, and clearing it means 
the tool will not affect the specified vertex parameter. Even 
if a parameter is enabled, it may or may not be affected by 
your use of the tool. For example, selecting a vertex in the 
forehead may affect the eyebrows but may not affect the 
mouth. Select your desired parameter(s), then click and 
drag any vertex on the head.

3. Once you have a portion of the head the way you want it, 
you can click the Pin button to freeze the selected vertex 
from further manipulation. Pinned vertices may move as 
you keep adjusting other portions of the body part, however 
they will retain their current settings.

You can use the [COMMAND]/[CTRL]+[Z] command to undo 
a specific parameter change made with the Face Shaping Tool. 
Or, if you want to reset all morph targets to their default values 
(0), you can click the Clear Morphs button. Also, if you want 
to clear all pins, simply click the Clear Pin Points button. Both 
buttons are located in the Face Shaping Tool palette along with 
other functionality (see below).

The Face Shaping Tool Palette

The Face Shaping Tool adjusts the parameters available in the 
Face Shaping Tool palette, which uses parameter dials that 
function similarly to the dials in the Parameters palette. You 
can use the Parameter Dial menu to access dial settings, reset 
a dial, or open the selected dial’s Graph (discussed in “Using 
Graphs” on page 458) You cannot, however, memorize Face 
Shaping Tool dials.

This is different than creating facial expressions 
since you are actually modifying head geometry 

instead of simply applying morphs to create a facial 
expression.

When sculpting a head, you can use the Face Shaping Tool, the 
dials in the Face Shaping Tool palette, or any combination you 
wish. The available Face Shaping Tool parameter dials are:
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• Facial Morphs: The Facial Morphs dial groups includes 
the following sub-groups and dials.

 � Brow Ridge: The Brow Ridge dials are High/Low, 
Inner Up/Down, Outer Up/Down, and Forward Axis 
Twist.

 � Cheekbones: The Cheekbones dials are High/Low, 
Shallow/Pronounced, Thin/Wide, and Protrusion 
Asymmetry.

 � Cheeks: The Cheeks dials are Concave/Convex, and 
Round/Gaunt.

 � Chin: The Chin dials are Forward/Back, Pronounced/
Recessed, Retracted/Jutting, Shallow/Deep, Small/
Large, Short/Tall, Thin/Wide, Chin Axis Twist, 
Forward Axis Shift, and Transverse Shift.

 � Eyes: The Eyes dials are Up/Down, Small/Large, Tilt 
Inward/Outward, Together/Apart, Height Disparity, 
and Transverse Shift.

 � Face: The Face dials are: Brow/Nose/Chin Ratio, 
Forehead/Sellion/Nose Ratio, Light/Heavy, Round/
Gaunt, Thin/Wide, Coronal Bend, Coronal Shear, 
and Vertical Axis Twist.

 � Forehead: The Forehead dials are: Small/Large, 
Short/Tall, Tilt Forward/Back, and Forward Axis 
Twist.

 � Jaw: The Jaw dials are Retracted/Jutting:, Wide/Thin, 
Jaw-Neck Slope High/Low, and Concave/Convex.

 � Mouth: The Mouth dials are Drawn/Pursed, Happy/
Sad, High/Low, Protruding/Retracted, Tilt Up/Down, 
Underbite/Overbite, Mouth-Chin Distance Short/
Long, Corners Transverse Shift, and Twist and Shift.

 � Lips: The Lips dials are Deflated/Inflated, Large/
Small, and Puckered/Retracted.

 � Nose: The Nose dials are Coronal Shear, Transverse 
Shift, Up/Down, Flat/Pointed, Short/Long, Tilt Up/
Down, Tip Transverse Shift, Transverse Shift, and 
Vertical Axis Twist.

 � Nose Bridge: The Nose Bridge dials are Shallow/
Deep, Short/Long, and Transverse Shift.

 � Nose Sellion: The Nose Sellion dials are Up/Down, 
Shallow/Deep, Thin/Wide, and Transverse Shift.

 � Nose Region: The Nose Region dials are Concave/
Convex and Frontal Axes Twist.

 � Temples: The Temples dial is Thin/Wide.

 � Ears: The Ears dials are Up/Down, Back/Front, Short/
Long, Thin/Wide, Vertical Shear, and Forward Axis 
Shear.
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• Ethnicity, Age, and Gender: The Ethnicity/Age/Gender 
dials generate ethnic, age, and gender traits and include 
less/more African, less/more European, less/more 
Southeast Asian, less/more East Indian, Younger/Older, 
and Male/Female.

• Standard Figures > Poser 5: The Standard Figures > 
Poser 5 dials generate the appearance of one or more of the 
standard Poser 5 figures and include Don, Judy, Will, and 
Penny.

To create/modify your head, simply adjust the dials or use the 
tool directly on the head. Your work will appear in real time in 
the Face Shaping Tool window.

Caricatures

The Caricature dial allows you to exaggerate or de-exaggerate 
the head and facial features. It has a meta effect, meaning it 
impacts the results of the other sculpting tools. Increasing the 
value increases the exaggeration, and vice versa, as follows:

• The default value is 0.

• Values > 0 apply exaggeration to the head, and values<0 but 
greater than –1 apply de-exaggeration.

• A value of –1 corresponds to the default head. For example, 
if you created a long nose with the other tools, a value of 
1 creates a very long nose, –1 is the default nose, and –3 
creates a very short nose.

Caricature values near –1 will work for overall 
de-exaggeration, however other tools (Face 

Shaping, Random Face, etc.) will have little effect due to 
the Caricature dial’s meta effect.

Use Morphs

The Face rooms’s morph database contains both symmetric and 
asymmetric targets. The Use Morphs radio buttons allow you to 
select between the following options:

• Both: This option makes all morph targets in the database 
available for interactive face sculpting. When you click on a 
point on the face, Poser will select morphs from either the 
symmetric or asymmetric morph target sets, depending on 
what morphs are available at that location and what will 
yield the best results.

• Symmetry: This option makes only the symmetric morph 
target set available.
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• Asymmetry: This option makes only the asymmetric morph 
target set available. Adding slight asymmetry to the face can 
often improve the realism of a computer generated face, as 
no human face is perfectly symmetric.

Loading/Saving/Previewing Textures
The Face room loads a default Face Room texture (different for 
each Face Room compatible figure), which you will see in the 
Texture Preview window. The Texture Preview window shows 
real-time previews of your head’s texture beginning with the 
default and through any changes you make by loading images 
and/or customizing textures. You can also load and save textures 
to your hard drive for later use. To load a texture, click the Load 
Texture icon on the left side of the Texture Preview window, 
which opens a Load Head Texture window that allows you 
to browse for the file you wish to load. You can modify loaded 
textures.

To save the texture being displayed in the Texture Preview 
window, click the Save Texture icon on the right side of the 
Texture Preview window, which opens a standard Save As 
dialog (see “Saving a Scene” on page 67 for information 
about the Save As dialog).

Applying Custom Heads/Textures
Once you’ve finished making changes to the head and/or texture, 
you may perform the following actions:

• Apply to Figure: Clicking the Apply to Figure button 
applies the head and texture that you created in the Face 
room to the currently selected figure in your scene. Face 
Room compatible figures are listed at the beginning of this 
chapter.

• Apply Shape Only: Clicking the Apply Shape Only dial 
applies the head shape to the currently selected figure 
without applying the texture map.

• Apply Texture Only: Clicking the Apply Texture Only 
dial applies the head texture to the currently selected figure 
without applying the head shape.

• Spawn Morph Target: Clicking the Spawn Morph Target 
button allows you to save the head as a morph target. Please 
refer to “Spawning Morph Targets” on page 661 for more 
information about spawning morph targets.

• Import Figure Head Texture: Clicking the Import Figure 
Head Texture button imports the currently selected 
figure’s head texture, which you can then modify by 
creating textures as described above. Imported textures 



Poser Pro 2014
Reference Manual 

532

Chapter 25: The Face Room

retain their original sizes. For example, if you import a 
1000x1000 texture, all changes you make to it in the Face 
room will retain the imported size. This is a great way to 
create textures that are larger than the Face room’s default 
512x512 size.

If you apply one or more heads to a scene with 
no figure, the applied head(s) will become props. 

If your scene has multiple figures, the head will be 
applied to the currently selected figure visible in the 
Select Figure menu.

To remove a custom texture after applying it to 
your figure, go into the material room and select 

the faceroomskin material. You can then replace the 
applied texture map with one of your own, remove the 
image map, etc. as desired.

Saving Faces

To save faces from the Face room, you must save PZ3 files 
containing the applied head. You can also spawn morph targets.
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Chapter 26: The Hair 
Room

Poser’s Hair room allows you to create dynamic strand-based 
3D hair for your figures or props. You can add hair wherever 
you like on any object in your scene and can add shaders in the 
Material room (see “Chapter 14: The Material Room” on page 
296) to give your hair almost any appearance from bleach 
blond to moss, lichens, grass, etc. (a shader tree is created for 
each hair group and is accessible in the Material room). You 
can even apply Force Fields (see “Wind Force Fields” on page 
633) to create realistic wind effects for your animations!

Hair contains many polygons that require hefty 
computing resources.

The Hair room appears as follows at 1280 x 960 resolution.

The number of palettes and options that you see 
in each room depends upon your screen 

resolution. At higher resolutions, the default work 
spaces display more palettes, while at lower resolutions 
you see fewer palettes:

 The Hair Room.

In addition to some standard tools, the Hair room has the 
following interface elements:

• Hair Growth Groups Controls (1): The Hair Growth 
Groups controls allow you to create, edit, and delete hair 
growth groups.

• Growth Controls (2): The Growth Controls allow you to 
specify how hair grows on growth groups.
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• Styling Controls (3): As the name implies, the Styling 
Controls allow you to control the appearance of hair.

• Dynamics Controls (4): The Dynamics Controls allow 
you to control how your hair behaves during animations.

The following subsections will walk you through creating strand-
based hair.

You can find skull-cap props in the Hair > Poser 
Content > People > Alyson > Hair Props and 

Hair > Poser Content > People > Ryan > Hair Props 
categories within the Library palette.

Step One: Defining Hair Groups
Skullcap props for Ryan and Alyson and other figures have hair 
props pre-created. You can use the grouping tool to spawn props 
for this purpose too.

If you want to be able to use the hair you are 
creating for other figures, please refer to 

“Adding Strand-Based Hair to the Library Palette” on 
page 548 for more information before proceeding.

The first step in creating strand-based hair is to define 
one or more group of polygons as a hair group. A hair 
group is a cluster of polygons that has been defined as 
an area on which hair will grow. A prop or skullcap 
can contain more than one hair group. For example, 
you can create multiple growth groups on a skull cap or 
hair prop to create a part in the hair; or small sections 
of a conforming hair prop, or a smart hair prop can be 
detailed with wisps of hair.

Please refer to the “Using the Group Editor” on 
page 681 for a general discussion about 

groups.

 Hair Growth Group settings.

To do this:
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1. Select the object you wish to grow hair on.

2. Click the New Growth Group button in Area 1 of the 
Hair room to create a new group called Hair_1 by default. 
Subsequent hair groups are numbered sequentially (Hair_2, 
etc.). You can rename groups by entering a new name in the 
New Growth Group Name box that appears. Click OK to 
proceed or Cancel to abort.

3. Click the Edit Growth Group button to enable the 
Grouping tool and open the Group Editor palette. Be 
sure that you have the correct hair group selected before 
selecting polygons for the group. Please refer to “The Group 
Editor” on page 681 for information about using the 
grouping tools.

4. Select the polygons you wish to include in the hair group 
you are creating.

You can create as many growth groups as you like, such as head 
hair, moustaches, beards, chest, back, etc.

 Assigning polygons to a hair group.

Be sure that you have the correct hair group 
selected in the Group Editor palette before 

selecting polygons for the group!

Step Two: Growing Hair
Once you’ve created a hair growth group, the next step is to grow 
the guide hairs.

As the name implies, guide hairs influence how nearby hairs 
will grow. To do this, click the Grow Guide Hairs button. The 
currently selected hair group will sprout guide hairs.
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 Growing hair on a Hair Group.

Guide hairs both shape the hair group and increase performance 
by allowing you to toggle displaying the fully populated hair 
group on and off (see below). Either before or after growing 
the guide hairs, you can apply some general parameters to 
determine the overall hair shape. These are:

 Hair Growth Controls.

• Hair Length: The Hair Length parameter determines the 
overall length of the guide hairs and subsequent populated 
hairs. Increasing this parameter lengthens the hair and vice 
versa.

• Length Variance: Real hair tends to vary somewhat in 
length. The Length Variance parameter allows you to 
control how much the hair length will vary in the currently 
selected hair group. A value of 0 means that all guide hairs 
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are exactly the same length while a value of 1 adds a great 
deal of variation.

• Pull Back: Most hair on peoples’ heads tends to be combed 
or pulled back along the scalp. The Pull Back parameter 
controls the extent to which guide hairs are pulled pack. 
Increasing this value pulls the guide hairs farther back and 
flattens them along the scalp. Negative values push the hair 
forward and away from the scalp.

• Pull Down: Just as most hair is pulled back, it can hang 
down thanks to styling, gravity, or both factors. The Pull 
Down parameter determines the extent to which this 
occurs. Increasing this value pulls the hair down and flattens 
it along the head and vice versa. Negative values create anti-
gravity hair.

• Once you’ve completed this step, your hair will be in place 
and will have its rough shape.

Don’t confuse the Pull Back and Pull Down 
parameters as replacing gravity or other 

dynamics that you can set after styling the hair. These 
parameters merely set the hair’s starting positions.

Step Three: Styling Hair
Now that you’ve grown the guide hairs and set some basic 
parameters for how the hair will look, your next step is to style 
the hair the way you want it. You can do this by setting the 
included styling parameters and/or by using the Hair Edit tool.

You can use the Hair Edit tool at any time after growing hair, 
although we recommend that you complete the previous step. 
Please see the following subsection for information on using the 
Hair Edit tool.

You can toggle the Show Populated function on 
and off while you work to check your results as 

you go.

The hair styling parameters are as follows:
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 Styling Controls.

• Show Populated: Checking the Show Populated checkbox 
displays both the guide hairs and the population hairs. 
This will show you exactly how the hair will look, but does 
increase display refresh time. The status of this box will not 
affect population of hair in the final render. Hair will always 
appear populated in a FireFly render.

• Hair Density: The Hair Density parameter controls the 
total number of hairs in the group. The number of hairs are 
displayed next to the dial’s label. Increasing this number 
makes the hair fuller and more lush. The ability to Control 
the total number of hairs is a powerful feature since it allows 
you to create custom effects, however the total number of 
hairs can impact rendering and redraw times. Experiment 
with this number to get optimum coverage without adding 
too many hairs.

As a matter of trivia, there are roughly 100-150 
hairs in eyelashes per lid, roughly 500-1,000 

hairs on each brow, and roughly 100,000 to 150,000 
hairs on the head..

• Tip Width: The Tip Width parameter controls the hairs’ 
widths (diameters) at their tips. Hair usually thins 
somewhat as it progresses from root to tip, so this number 
will typically be less than the Root Width parameter, below.



Poser Pro 2014
Reference Manual

539

Chapter 26: The Hair Room

• Root Width: The Root Width parameter controls the 
hairs’ widths (diameters) at their roots. Hair usually thins 
somewhat as it progresses from root to tip, so this number 
will typically be larger than the Tip Width parameter, above.

• Clumpiness: The Clumpiness parameter determines the 
hairs’ tendency to form dreadlock-like bunches.

• Kink Strength: The Kink Strength parameter is the 
measure of how wavy/curly hair is. Increasing this value 
increase the hairs’ waviness, and vice versa.

• Kink Scale: The Kink Scale parameter determines the size 
of hair waves/curls. Increasing this value increase the hairs’ 
waviness, and vice versa.

• Kink Delay: The Kink Delay parameter specifies the 
distance from the root at which the hair begins to curl/wave. 
Increasing this value increase the distance from the root, 
and vice versa.

• Verts Per Hair: The Verts per hair parameter controls how 
many vertex points are in each strand of hair. Increasing 
this value results in smoother, more flowing hair but 
increases the system resources needed to render/redraw 
your scene.

• Style Hairs: Clicking the Style Hairs button selects the 
Hair Select tool and opens the Hair Style Tool palette (see 
below).

Using the Hair Edit Tool/Palette

The Hair Select tool is only available in the Hair room. It allows 
you to directly edit guide hairs and create a nearly infinite 
variety of hair styles (parts, tails, etc.). You can access it by either 
selecting it in the Editing tools or by clicking the Hair Select 
button as described above. The Hair Style Tool palette appears 
as follows:
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 Hair Styling tools.

You have the following controls available for directly 
manipulating guide hairs:

• Add Hairs to Selection (1): Select the Select Hairs tool, 
then click and drag a rectangle around the guide hairs you 
wish to select for further styling. Unselected guide hairs 
are not affected by the Hair Edit tools. Selected hairs are all 
affected equally. Selecting more guide hairs can be faster, 

however you can select as few as one hair for precise control 
over the style.

 You can style selected hairs in the hair group.

For finer control over which hairs are selected, 
try switching cameras or using the Magnifier 

tool to zoom in close.
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Hair growth is based on the parent object’s 
polygon count. If you wish to add detailed hair 

groups to a low-poly prop or to a portion of a figure 
with a low poly count, you can spawn a prop of the area 
you wish to grow hair on, subdivide that prop in your 
favorite 3d modeling application, then re-import the 
prop and apply it where needed. This is the same idea as 
skullcaps except that you are not limited to heads.

• Translate Hairs (2): The Translate Hairs tool moves 
the selected hair vertically around or laterally around 
the camera’s X and Y axes depending how you drag. The 
translation may occur on the hair’s X, Y, and or Z-axes 
depending on the position of the camera relative to the hair.

• Curl Hairs (3): The Curl Hairs tool bends a guide hair. Hair 
rotation works in three dimensions, allowing you to make a 
lot of progress very quickly. Dragging perpendicular to the 
hair rotates it up and down (relative to your point of view). 
Dragging parallel to the hair rotates it in and out, again 
relative to your point of view.

• Scale Hairs (4): The Scale Hairs tool allows you to scale 
the selected hair along the camera’s X and Y axes. The hair’s 
affected axes will vary depending on the camera’s position 
relative to that item. Dragging in towards the root reduces 
the scale, and dragging away from the root increases the 

scale. Dragging laterally scales hair in two dimensions, and 
dragging vertically scales hair in the third dimension. The 
axes affected depend on your currently selected camera 
position. You can also press and hold Shift while using 
this tool to scale the selected hair(s) evenly in all three 
dimensions.

• Remove Hairs from Selection (5): Select the Deselect 
Hairs tool, or simply hold down the [CTRL] key, then click 
and drag a rectangle around the guide hairs you wish to 
deselect from further styling. The Hair Edit tools do not 
affect unselected guide hairs.

• Translate In/Out (6): The Translate Hairs In-Out tool 
moves the selected hair(s) along the Camera’s Z axis (in and 
out). This translation may take place along the hair’s X, Y, 
and/or Z axes. Dragging down pulls the hair towards you, 
and vice versa.

• Twist (7): The Twist Hairs tool rotates selected hair(s) along 
their own axis.

In addition to the editing tools, the palette has the following 
controls:

• Constrain Length: Checking the Constrain Length 
checkbox forces all selected guide hairs to retain their 
current lengths no matter how you use the hair editing tools. 
Clearing this box allows the length to vary depending on 
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how you use the hair editing tools (for example, you could 
use the Hair Translate tool to lengthen some guide hairs to 
create a ponytail.

• Falloff: The Falloff slider controls the portion of the hair 
affected by the styling. Moving the slider to the left causes 
the tools to only act near the tip of the hair. Moving the 
slider to the right causes the styling tools to affect more of 
the hair’s length. With the slider all the way to the right, the 
entire hair is affected from root to tip.

• Lengthen: Moving the Lengthen dial to the right lengthens 
the selected guide hairs and vice versa.

• Clear Selection: Clicking the Clear Selection button 
deselects all selected guide hairs.

To exit this tool, either click the Close box on the palette’s upper 
right-hand corner or select another Editing tool.

The Hair Edit tools do not affect figures or props 
in your scene, and the Document Editing tools do 

not affect hair.

Step Four: Setting Hair Dynamics
You’ve got your hair grown and styled. Now let’s add some 
dynamics to control how the hair will behave during animations.

Poser Legacy

 Dynamics Controls.
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• Do Collisions: Checking the Do Collisions box enables 
collision detection for the current hair group, which will 
prevent hairs from penetrating other objects in the scene 
(for example, long hair will not penetrate a figure’s head). In 
order to ensure proper collision detection, make sure that all 
body parts with which you want the hair to collide have the 
Collision Detection checkbox set on the Properties palette.

• Gravity: The Gravity parameter controls the strength of 
gravitational force acting on the hair.

• Spring Strength: The Spring Strength parameter 
determines the hair’s springiness. Increasing this value 
increases the springiness. A rubber band is a good example 
of an object with a high amount of springiness.

• Air Damping: The Air Damping parameter specifies the 
hair’s air resistance that occurs whenever the hair is moving 
through the air. Short hair has a lower resistance than long 
hair. Set this parameter with care as excessive values could 
cause the hair to behave unpredictably.

• Spring Damping: The Spring Damping parameter controls 
the hair’s elasticity.

• Bend Resistance: The Bend Resistance parameter 
controls the hair’s resistance to bending or folding upon 
itself.

• Position Force: The Position Force parameter is a force 
that pulls the hair vertices towards their choreographed 
position. Increasing this value decreases hair dynamics, and 
vice versa.

• Root Stiffness: The Root Stiffness parameter determines 
how stiff the hair is at its root.

• Root Stiffness Falloff: The Root Stiffness Falloff 
parameter controls how quickly the hair’s root stiffness 
decreases from root to tip.

• Calculate Dynamics: Clicking the Calculate Dynamics 
button applies the current dynamic settings to the selected 
hair group. The number of frames in the keyframed 
animation determines the calculation length. Populated 
hairs do not display during calculation.

Bullet Physics Solver

The Bullet Physics solver offers improved performance and 
appearance for dynamic hair. When using Bullet Physics for 
hair, you create growth groups, grow, and style hair as outlined 
in the previous sections in this chapter. Then you choose the 
Bullet Physics solver from the Dynamics Controls section in the 
Hair Room.
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 Dynamics Controls.

• Do Collisions: Checking the Do Collisions box enables 
collision detection for the current hair group, which will 
prevent hairs from penetrating other objects in the scene 
(for example, long hair will not penetrate a figure’s head). In 
order to ensure proper collision detection, make sure that all 
body parts with which you want the hair to collide have the 
Collision Detection checkbox set on the Properties palette.

• Gravity: Controls the strength of gravitational force acting 
on the hair. Decrease the setting to reduce the amount 
of gravitational force, or increase the setting to add more 
gravitational force.

• Stretch Resistance: Determines the stretchiness of the hair 
as it is pulled by gravity. Increase the setting to make the 
hair less stretchy (more resistant to stretching).

• Bend Resistance: The Bend Resistance parameter 
controls the hair’s resistance to bending or folding upon 
itself.

• Root Stiffness: The Root Stiffness parameter determines 
how stiff the hair is at its root (the end that comes from the 
head).

• Tip Stiffness: The Tip Stiffness parameter determines how 
stiff the hair is at its tip (the end of the strand).
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• Stiffness Falloff: The Root Stiffness Falloff parameter 
controls how quickly the hair’s root stiffness decreases from 
root to tip.

• Damping: The Damping parameter specifies the hair’s air 
resistance that occurs whenever the hair is moving through 
the air. Short hair has a lower resistance than long hair. Set 
this parameter with care as excessive values could cause the 
hair to behave unpredictably.

• Collision Margin: Controls the amount of space that exists 
between the hair and the objects that it collides against, 
before a collision is detected. If the collision margin is set 
too low, hair can “disappear” inside the objects it collides 
against.

• Friction: Controls the amount of friction from the hair to 
the choreographed objects in the scene set to collide against. 
No hair self collision using Bullet.

• Mass: Mass will not have an effect using the Bullet Physics 
for hair.

Hair Properties & Parameters
To access a hair object’s parameters and properties, you must 
first select the desired hair object, which appears in the Current 

Actor menu under the Props category. Strand-based hair has the 
following properties and parameters:

 Hair Group Properties.

Hair Properties

• Name: The Name field displays the hair object’s name. 
Enter a new name in this field if you desire.
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• Visible: Checking the Visible checkbox makes the hair 
object visible and vice versa. Invisible objects are not 
included in any render calculations, and do not appear in 
the rendered scene. See “Figure Properties” on page 193 
for information on animating the Visible property.

• Visible in Raytracing: Checking the Visible in Raytracing 
checkbox makes the hair object visible in raytraced 
reflections, such as if the figure is in front of a mirror. 
Clearing this checkbox makes the figure not appear in 
reflections.

• Bend: Checking the Bend checkbox enables bending for the 
selected hair object and vice versa. Bends are discussed in 
“Bend Body Parts” on page 114. Remember that selecting 
Display > Bend Body Parts bends all scene objects and 
this property only affects the currently selected body part.

• Casts Shadows: Checking the Casts Shadows checkbox 
forces the selected prop to cast a shadow, which will be 
visible in your scene. Clearing this box means the selected 
hair object casts no shadow.

• Displacement Bounds: The Displacement Bounds 
property determines the hair object’s displacement 
boundary. Please refer to “Chapter 19: Using The FireFly 
Render Engine” on page 404 for more information about 
displacement bounds.

• Recalculate Dynamics: The Recalculate Dynamics 
option recalculates the dynamics for the current hair object.

• Shading Rate: The Shading Rate allows you to specify the 
desired shading rate for the currently selected hair object. 
Please refer to “Chapter 19: Using The FireFly Render 
Engine” on page 404 for more information about shading 
rates.

Hair Parameters

Strand-based hair has the following parameters:
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 Hair Group Parameters.

• Dynamics: The Dynamics parameter sets the amount 
by which the previously specified dynamics will be played 
during animations. A setting of 1 means the dynamics will 
play exactly as specified, a value of 2 means the dynamics 
will behave as though all values were set to 200% of their 
current settings, and so forth. Numbers below 1 reduce 
the amount by which dynamics are applied, and negative 
numbers apply the dynamics in reverse.

• XYZRotate: The xRotate, yRotate, and zRotate parameter 
dials rotate the hair object around the selected axis.

• Scale: Increases or decreases the size of the hair object in 
all axes.

• XYZScale: The xScale, yScale, and zScale parameter dials 
increase or decrease the size of the hair object in the selected 
axis.

• XYZTran: The xTran, yTran, and zTran parameter dials 
move the hair object along the selected axis.

Hair Colors and Materials
Each strand-based hair object in your scene has its own shader 
tree, which is accessible in the Material room, allowing you 
to color your hair and add interesting effects. Please refer to 
“Chapter 14: The Material Room” on page 296 for more 
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information about the Material room. As with any other object, 
you can select strand-based hair by clicking it in the Document 
window, using the Current Actor menu, etc.

 Hair Shader.

Adding Strand-Based Hair to the 
Library Palette
Strand-based prop hair differs from geometry-based prop 
hair because it needs underlying geometry in order to “grow.” 
Strand-based hair grows in strands, much like real hair, rather 
than being made from textured polygons like geometry-based 
hair. You can’t add strand-based hair to figures/props in the 
same manner as prop-based hair. As a result, you can’t save 
strand-based hair to the Library palette unless it is growing from 
underlying geometry.

There are three ways to save strand-based hair for later use:

• Saving a PZ3 file with the hair object in it (you can do a 
merge function later, as explained in “Importing Poser 
Documents or Props” on page 779).

• Saving a prop/body part with a hair object on it. In this 
case, simply add the prop with the hair to your scene. For 
example, you could use the Group Editor to select polygons 
on a character’s head and create a skullcap prop, grow hair 
on that prop, and save the hair and prop to the Library 
palette.

• The Library palette includes skullcaps designed to fit the 
Don, Judy, James and Jessi figures. These skullcaps are 
available in the Hair category under their respective figures. 
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To use a skullcap, add it to your scene, create and style 
hair, then save the skullcap with your new hair style back to 
the Library palette for use on other figures. Add skullcaps 
to figures just as you would prop-based hair. This is the 
preferred method for saving strand-based hair.

Skullcaps are also useful because they have a 
higher polygon count than the underlying head, 

giving you more detailed control over hair surfaces. You 
can spawn props from any figure or prop, subdivide 
them in your favorite 3D modeling application, then 
apply them anywhere you like to obtain more detailed 
results.

To save strand-based hair to the Library palette:

1. Open the Hair category in the Library palette. Locate or 
create a folder in which to save your new hair.

2. Click to select the hair that you want to save.

3. Click the Add to Library button. A message informs you 
that you will need to save the hair group along with its 
parent prop. Click OK to continue.

4. Click Select Subset in the Set Name dialog. When you 
select your hair groups, make sure that you also choose the 
prop that the hair groups are attached to. For example, if 
you grew the hair groups directly on the figure’s head, make 

sure that you also include the Head in the props that you 
select.!

Strand-based hair is created on a per-object 
basis for each scene.



Poser Pro 2014
Reference Manual 

550

Chapter 27: The Cloth Room

Chapter 27: The Cloth 
Room

Poser’s Cloth room allows you to create realistic cloth that 
behaves like real fabric. Want to add custom clothing to a figure? 
Create a tablecloth? How about a flying carpet? Poser offers 
powerful tools that help you create dynamic cloth that responds 
realistically when animated. You can even apply a Force Field 
for realistic wind effects!

Using the Cloth Room
The Cloth room appears as follows.

 The Cloth Room.

The number of palettes and options that you see 
in each room depends upon your screen 

resolution. At higher resolutions, the default work 
spaces display more palettes, while at lower resolutions 
you see fewer palettes.

In addition to standard UI elements, the Cloth room contains 
the following UI elements:
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• Cloth Simulations (1): The Cloth Simulation area allows 
you to create, delete, and set up cloth simulators.

• Cloth (2): The Cloth area allows you to convert objects 
to and from dynamic cloth objects and to set up collision 
detection for your cloth.

• Cloth Groups (3): The Cloth Groups area is where you set 
up dynamic, choreographed, constrained, and decorated 
cloth groups.

• Dynamics Controls (4): The Dynamics Controls group 
sets up dynamic parameters.

The cloth room help contains additional 
information about importing props for use as 

cloth.

Conforming vs. Dynamic Cloth
As mentioned in “The Figures Category” on page 139, 
conforming clothing is a Poser figure, while dynamic cloth 
consists of props with dynamic and other behaviors applied to 
simulate cloth. Poser supports both types of cloth.

Dynamic cloth adds incredible realism to your scenes by causing 
cloth objects to move as they would in real life. For example, you 

can use dynamic cloth to create the following types of items in 
your Poser scene:

•  A tablecloth that drapes over a table

• A slip cover over furniture

• A flowing skirt that moves as a figure walks

Dynamic cloth objects require increased computing resources 
beyond those of conforming clothing. Items such as socks, 
bikinis, or tights don’t need to be dynamic since in real life these 
types of clothing tend to be close-fitting with little to no room 
for independent motion. You should generally use conforming 
clothing for these situations because it requires fewer computing 
resources.

Adding Dynamic Clothing
Dynamic clothing offers the most powerful means of clothing 
figures, allowing for realistic cloth draping and wrinkles. 
Additionally, it is very easy to create clothing props for use as 
dynamic clothing. Dynamic cloth retains its dynamics when 
saved to the Library palette, but you will need to create a new 
simulation whenever you add saved cloth objects. To add 
dynamic cloth to your current figure:

1. Select the item from the Library palette and add it to your 
scene, then switch to the Cloth room.
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2. Create a new simulation group, and select Body as your 
desired collision object.

3. Recalculate the simulation.

Using Dynamic Clothing without a 
Figure
Dynamic cloth retains its dynamics when saved to the Library 
palette, but you will need to create a new simulation whenever 
you add saved cloth objects. To add dynamic cloth without a 
figure:

1. Select the item from the Library palette and add it to your 
scene, then switch to the Cloth room.

2. Create a new simulation group, and select your desired 
collision object(s), if any.

3. Recalculate the simulation.

Using Dynamic Clothing with Morphs

Step 1: Create/Set Up a Cloth Simulator

The first step in creating dynamic cloth is creating and setting up 
a cloth simulator. You may have as many simulators as you wish 
in your scene, however each simulator requires system resources 
(RAM/CPU cycles) and increases rendering time.

 Cloth Simulations options.
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Creating the Simulation

To create a simulator, click the New Simulation button in the 
Cloth Simulation area of the screen to open the Simulator 
Settings dialog.

 Creating the Simulation.

The Simulator Settings dialog box has the following options:

• Simulation Name: Enter your desired name for the new 
simulator in the Simulation Name field. By default, 
simulators are numbered in the order they are created, e.g. 
Sim_1, Sim_2, etc.

• Simulation Range: You can either set the simulator to 
run throughout your entire animation or pick a set of 
frames during which the simulator is active by entering 
your desired frame numbers in the Start Frame and End 
Frame fields, respectively. Increasing the number of frames 
that a simulator is active requires greater amounts of 
system resources. During the frames prior to the start of a 
simulation, the cloth object will remain in its starting state. 
After the simulation ends, the cloth object will remain in its 
ending state for the rest of your animation. Additionally, 
the Steps per frame parameter dial controls the number 
of calculation steps per frame in order to smooth the cloth 
simulation. Increasing this value improves the simulation 
results but requires additional computing resources.

• Additional Cloth Collision Options: These checkboxes 
allow you to toggle the following additional collision 
detection options on and off. By default, collisions are 
calculated using cloth vertices against object polygons.

 � Object Vertex against cloth polygon: Checking 
the Object Vertex against cloth polygon checkbox 
performs additional collision calculations using object 
vertices and cloth polygons, which helps eliminate tears 
or holes that may occur when an object collides with the 
cloth. Enabling this option slows the simulation.

 � Object Polygon against cloth polygon: Checking 
the Object Polygon against cloth polygon checkbox 
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performs additional collision calculations using 
object polygons and cloth polygons, which helps 
eliminate tears or holes that may occur when an object 
collides with the cloth. Enabling this option slows the 
simulation.

 � Cloth self-collision: Checking the Cloth self collision 
checkbox allows a cloth to detect its own polygons 
during simulation, preventing (for example) a cape or 
a flag from passing through itself. Enabling this option 
slows the simulation.

• Cloth Draping: The Cloth Draping options are:

 � Drape Frame: The Drape Frame value allows you to 
set the number of frames per object to settle the cloth.

 � Calculate Drape: Clicking the Calculate Drape button 
calculates the cloth object’s draping behavior and 
caches the simulation. When calculating the simulation, 
cached drape settlings are added before beginning cloth 
simulations, meaning that the settled cloth drape is at 
frame 1 before the simulation begins.

When you have finished setting up the simulator options, click 
OK to accept your choices and create the simulator or Cancel to 
exit without creating the simulator.

The Cloth Simulation area has two other buttons:

• Delete Simulation: Simulation results are cached in a file 
during simulation computation, which Poser automatically 
loads to save time and resources. Clicking the Delete 
Simulation button deletes the cache contents.

• Simulation Settings: Clicking the Simulation Settings 
button reopens the Simulation Settings window, allowing 
you to alter your cloth simulator settings.

Think of a cloth simulator as an envelope 
supplying basic behavioral properties. You can 

have multiple cloth objects in each simulation and/or 
multiple simulations in each Poser scene. Each cloth 
object, however, can only belong to one simulation at a 
time. Increasing the number of simulations in a scene 
can add complexity and interest, but also requires 
increased computing resources.

The arrow at the top right of the Cloth Simulation area 
displays the currently selected simulator. Clicking this arrow 
opens a pull-down menu allowing you to select any of the cloth 
simulators in your scene for modification.
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Step 2: Cloth Controls

Now that you’ve created a simulator, your next step is to add 
cloth objects. Do this using the Cloth controls (area 2 of your 
screen).

 Cloth Objects settings.

Clothifying Objects

To turn an object into a dynamic cloth object, select it and click 
the Clothify button to open the Clothify window, which displays 
a list of objects eligible to be turned into dynamic cloth. Use the 
Object to clothify pull-down menu to select your desired object, 
and click the Clothify button to make the cloth object, or Cancel 
to abort.

 Choosing an object to clothify.

To turn a dynamic cloth object back into a normal prop, select 
it and click the Unclothify button. The prop will return to its 
pre-clothified shape, however it will retain its vertex groups 
and dynamic parameters, meaning you won’t have to start from 
scratch if you re-clothify the object later.

You can also create static props and morph targets from cloth 
objects as described in “Creating Props and Morph Targets” on 
page 566.

Specifying Collision Objects

Once the simulator is created and you’ve specified the basic 
parameters and created dynamic cloth, the next part of the 
simulator creation process is defining the objects that will 
use collision detection (collision objects) with the cloth. Each 
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collision object will behave in accordance with the specified 
collision behaviors when contacting the cloth. Non collision 
objects will not use collision detection with the cloth object. To 
set up collision objects, click the Collide Against button to open 
the Cloth Collision Objects window.

 Choosing collision objects.

The Cloth Collision Objects window has the following options:

• Add/Remove Collision Objects: Clicking the Add/
Remove button opens the Select Objects window, which 
displays a hierarchical list of all the objects in your scene, 
including body parts on figures. By default, all scene objects 
are selected (selected objects are checked). Add and remove 
collision objects by checking/clearing the checkboxes next to 

each object listing in the window, then click the OK button 
to accept your choices or Cancel to abort. Added objects 
appear in the Current Collision Object pull-down menu in 
the Cloth Collision Objects window. You can set collision 
options for each collision object by selecting it using the 
pull-down menu and specifying the desired settings.

 Select the object to clothify in the Select Objects dialog.

• Collision Offset: The Collision Offset parameter 
determines the distance between a cloth object and a 
collision object at which the collision detection calculations 
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begin. Increasing this value can help avoid accidental 
collisions, especially during animations, because Poser 
requires a little time to calculate actual collisions. Increasing 
this value too high can consume extra computing resources. 
Experimentation will quickly yield the proper value for each 
simulation. Please see “Collision Offset & Depth” on page 
558 for more information.

• Collision Depth: The Collision Depth parameter specifies 
how close the cloth object must be to a collision object in 
order for a collision to take place. Increasing this value 
increases the distance at which the cloth and collision object 
will collide. This is useful when creating clothing, because 
the cloth will be kept away from the figure. Increasing this 
distance makes the cloth appear more static but avoids 
having body parts penetrate the cloth (such as a leg poking 
through a skirt). Experimentation will quickly yield the 
proper value for each simulation. Please see “Collision 
Offset & Depth” on page 558 for more information.

• Static Friction: The Static Friction parameter sets the 
coefficient of friction for the collision object. This is similar 
to the Dynamic Friction parameter except that this is the 
force required to get a stationary cloth in contact with a 
solid to start moving. For example, nylon over smooth 
plastic will have a very low amount of static friction while 
denim over wood will have a high amount. You can use the 

Collision Friction checkbox (see below) to use the collision 
object’s value or the simulation’s value.

• Dynamic Friction: The Dynamic Friction parameter 
sets the coefficient of friction for the collision object when 
the object is in motion. Moving a piece of cloth across a 
surface causes friction. Silk moving over a steel surface has 
low resistance, while cotton moving over skin or coarse 
sandpaper over rough wood has high resistance. You can 
use the Collision Friction checkbox (see below) to use the 
collision object’s value or the simulation’s value.

• Figure Collision Options: The Figure Collision Options 
allow you to specify how the current cloth object will behave 
when it drapes across/collides with a figure. Most clothes 
dressed on a figure are modeled in such a way so that they 
will fit on the target figure when the figure is in default pose. 
However, most simulations including figures and dresses 
will not use figure’s default pose at the start of simulation. 
In order for the simulation to work correctly, we need to 
simulate the cloth draping process: given certain frames, the 
underlying figure will interpolate from default pose to the 
start pose, and the draping simulation ensures the cloth fits 
the figure at the start frame.

 � Start Draping From Zero Pose: Checking the Start 
draping from zero pose checkbox is used when 
creating cloth to be used as clothing on a figure. For 
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example, you can convert conforming clothing into 
dynamic cloth objects and drape them over a figure 
beginning from that figure’s default pose. This is useful 
when applying dynamic cloth to a posed figure.

 � Ignore Head Collisions: Checking the Ignore head 
collisions checkbox causes the collision detection not 
to apply when the cloth collides with a figure’s head. 
This is useful for cloth that will not normally touch the 
head, such as shirts, pants, etc.

 � Ignore Hand Collisions: Checking the Ignore hand 
collisions checkbox causes the collision detection not 
to apply when the cloth collides with a figure’s hands.

 � Ignore Feet Collisions: Checking the Ignore feet 
collisions checkbox causes the collision detection not 
to apply when the cloth collides with a figure’s feet.

Adding collision objects increases the computing 
resources required to calculate cloth behavior 

and dynamics. Thus, you should specify the minimum 
number of collision objects possible.

When you have finished setting up the collision objects, click 
OK to accept your choices or Cancel to exit without setting up 
collision objects.

The arrow at the top right of the Cloth area displays the 
currently selected cloth object. Clicking this arrow opens a 

pull-down menu allowing you to select any of the cloth objects in 
your scene for modification.

Collision Offset & Depth

The Collision depth and Collision offset dials are limited to 
minimum 0.1cm and maximum 10cm.

Before adjusting these settings, be sure to enable 
the Object vertex against cloth polygon and 

Object polygon against cloth polygon options in the 
Simulator Settings dialog.

A real piece of cloth has two sides (inside & outside) and 
thickness. A cloth mesh is composed of polygons, which 
mathematically have zero thickness. The Collision 
Depth and Collision Offset dials emulate thickness 
by “extruding” the cloth inwards by the amount of 
Collision depth units and outward by the amount 
of Collision offset units. Thus, the cloth now has a 
“thickness” of collision offset + collision depth. Any 
specified collision object intersecting this volume will be 
treated as a collision.
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Step 3: Cloth Groups

Objects being converted to cloth must have single-sided, 
connected (welded) polygons without caps. Once you’ve created 
a cloth simulator and cloth object, the next step is to create cloth 
groups (groups of vertices) within each object, thus subdividing 
the cloth object into regions (in the same manner as, for 
example, dividing a body part into different material groups). 
The exception is decorative objects such as buttons, belt buckles, 
etc., which should be separate (non-welded) objects. Cloth 
groups use vertices instead of polygons, meaning that the Group 
Editor palette operates in vertex mode in the Cloth room (as 
opposed to polygons). You can convert polygon groups to vertex 
groups in the Cloth room by clicking the Add Group button 
to open a pop-up list of existing groups. Group names with the 
suffix [P] are polygon groups. Selecting polygon groups includes 
all vertices of the affected polygons.

 Cloth Group objects.

There are four types of groups available for cloth objects:

• Dynamic: By default, cloth objects are created with one 
dynamic group (_default_) comprising the entire object. 
Dynamic cloth groups are simulated using the Dynamics 
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Controls (see following step), which determine how the 
cloth moves, folds or drapes as it responds to gravity, wind 
force and how an underlying figure/prop moves. Examples 
of moving figures and props include a ball underneath a 
carpet, or a figure underneath clothing. You can create 
multiple dynamic groups for each clothing object, and 
each dynamic group can have different dynamics settings. 
You cannot directly animate dynamic groups with regular 
keyframing.

• Choreographed: Each cloth object can have one 
choreographed group. An empty choreographed group 
is automatically created when you clothify an object. 
Choreographed vertices can follow keyframed movement or 
be excluded from the cloth simulation.

• Constrained: Each cloth object can have one constrained 
group. An empty constrained group is automatically created 
when you clothify an object. Constrained vertices “stick” to 
corresponding polygon faces of the underlying figure and 
are useful for cloth areas that have to follow the movement 
of the underlying body part. They can be used to prevent 
straps on a dress from slipping down the shoulders, or to 
create a skirt’s belt that follows the waist’s movements. 
If you do not place these vertices in a constrained group, 
gravity can cause the cloth to fall until the skirt hits the body 
or the ground. Constraining the belt vertices keeps the belt 

at the waist and reduces simulation time. If the belt contains 
complex geometry, the simulation will slow down.

• Decorations: Each cloth object can have two decorations 
groups (one “soft” and one “rigid”. These groups are 
automatically created with empty contents when you 
clothify an object. The decoration groups animate, moving 
as underlying cloth moves while staying over the underlying 
body. Good candidates for decoration vertices include tiny 
or thin polygons such as pockets, belt loops, buttons, a knot 
in a tie, etc. These are usually items sitting on another cloth 
group and have only passive movement, either following 
underlying body movement or other parts of the cloth. 
Because of their small size and/or irregularity, these can 
cause issues if not placed into this group. The decorations 
group favors accessories that are geometrically separated 
from the cloth mesh object. There are two reasons for this:

 � If the decorations group shares vertices with the cloth 
mesh, the decorations vertices will not be simulated. 
This causes the simulator to treat these areas as 
boundaries, resulting in increased movement of these 
areas compared to neighboring regions of the cloth.

 � Welding accessories to the cloth mesh often creates a 
complex mesh where one edge is shared by more than 
two polygons.

The two types of decoration groups are:
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 � Soft: Objects in the soft decorated group move with the 
underlying cloth and can flex as the cloth flexes. A good 
example would be a belt loop.

 � Rigid: Objects in the rigid decorated group move with 
the underlying cloth but do not bend or flex. Good 
examples of rigid decoration objects are buttons or the 
knot in a tie.

If you want the current cloth object to consist of a single dynamic 
group, you’re done. Continue on to Step 4 (below) to set your 
dynamics. If, however, you want to create multiple groups, you 
can do so using the following buttons:

• New Dynamic Group: Clicking the New Dynamic Group 
button opens the New Dynamic Vertex Group Name 
box. Enter your desired name for the new dynamic group 
and click OK to proceed or Cancel to abort. By default, 
your entire cloth object consists of a dynamic group called 
_default_. Any vertices that are not part of other dynamic, 
constrained, choreographed, or decorated groups when 
you’re done creating/editing groups will remain in the 
_default_ group.

 Assigning a name to a Dynamic Group.

Since each cloth object can only have one 
choreographed, constrained, and/or one each 

soft & hard decorated groups, you can only assign 
names to dynamic groups.

• Delete Dynamic Group: Clicking the Delete Dynamic 
Group button deletes the currently selected dynamic group.

• Edit Dynamic Group: Clicking the Edit Dynamic Group 
button opens the Group Editor palette, which allows you to 
add or remove vertices from the currently selected group. 
Please refer to “The Group Editor” on page 681 for 
information on using the Group Editor palette.
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• Edit Choreographed Group: Clicking the Edit 
Choreographed Group button opens the Group Editor 
palette, which allows you to add or remove vertices 
from the currently selected choreographed group 
(_choreographed_). Please refer to “The Group Editor” 
on page 681 for information on using the Group Editor 
palette.

• Edit Constrained Group: Clicking the Edit Constrained 
Group button opens the Group Editor palette, which allows 
you to add or remove vertices from the currently selected 
constrained group (_constrained_). Please refer to “The 
Group Editor” on page 681 for information on using the 
Group Editor palette.

• Edit Soft Decorative Group: Clicking the Edit Soft 
Decorative Group button opens the Group Editor palette, 
which allows you to add or remove vertices from the 
currently selected soft decoration group (_softDecorated_). 
Please refer to “The Group Editor” on page 681 for 
information on using the Group Editor palette.

• Edit Rigid Decorative Group: Clicking the Edit Rigid 
Decorative Group button opens the Group Editor 
palette, which allows you to add or remove vertices 
from the currently selected rigid decoration group 
(_rigidDecorated_). Please refer to “The Group Editor” 

on page 681 for information on using the Group Editor 
palette.

Keep the following in mind when working with cloth groups:

• Adding vertices to the current group removes them from 
other groups.

• Removing vertices from the default group adds them to the 
choreographed group.

• Removing vertices from any group adds them to the default 
group.

The arrow at the top right of the Cloth area displays the 
currently selected cloth group within the currently selected cloth 
object. Clicking this arrow opens a pull-down menu allowing you 
to select any of the cloth groups in the current cloth object for 
modification. To work on a different cloth object, use the pull-
down menu available in the Cloth area (Step 2).

Step 4: Cloth Dynamics Controls

Once you’ve created and edited cloth groups, the next step is to 
define dynamic properties for each of the dynamic groups in the 
currently selected cloth object. Dynamic properties control how 
the dynamic groups will move and behave when the dynamics 
are calculated. The Cloth Dynamics Controls have the 
following buttons:
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 The Group Editor is used in Vertex mode with Cloth Groups.

• Calculate Simulation: Clicking the Calculate Simulation 
button takes into account all of the simulation, object, 
group, and dynamics settings included in the current 
simulation and calculates the behavior of all of the cloth 
objects in the simulation for all of the specified frames. 
Please see above for information on specifying cloth 
simulation frame ranges.

If a clothified object contains morphs that are 
dialed in at frame 1, there may be occasions 

when the morphs are doubled after the cloth simulation 
is calculated. One way around this issue is to set the 
morph back to zero on frame 1, and on the end frame. 
Then set the morph back to 1 before you recalculate it.

• Play Simulation: Clicking the Play simulation button plays 
the currently selected simulation, allowing you to see how 
the cloth behaves over time. If you don’t like the current 
behavior, you can alter any of the Cloth room settings and 
try again.

• Clear Simulation: Clicking the Clear Simulation button 
empties all stored data in the current simulation (such 
as altering collision settings, adding/removing objects, 
editing groups, changing dynamics control settings, etc.), 
allowing you to specify new dynamics, thus modifying how 
the cloth object behaves. If you clear the simulation and 
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play the animation, what you are seeing is simply keyframe 
animation with no simulation being calculated.

The Cloth room includes the following dynamics controls:

 Dynamics Controls.
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• Fold Resistance: The Fold Resistance parameter specifies 
the resistance to out-of-plane bending (folding). Increasing 
this value lessens the cloth’s ability to bend. Soft fabrics like 
silk fold very easily, so a low value (1.0) is appropriate. By 
contrast, hard leather tends not to fold, so a higher value 
would be appropriate.

• Shear Resistance: The Shear Resistance parameter 
controls the cloth’s resistance to in-plane shearing, or 
side-to-side bending. A low shearing resistance allows the 
cloth triangles (caused, for example, when the corner of 
a rectangular piece of cloth is draped over a surface) to 
collapse in on themselves, so a value of 50.0 or thereabouts 
is appropriate. Wool has a low shear resistance while leather 
has a very high amount.

• Stretch Resistance: The Stretch Resistance parameter 
specifies the cloth’s resistance to in-plane bending 
(stretching). Most cloth is highly resistant to stretching, with 
some exceptions like spandex, which is more elastic. The 
default of 50.0 gives a fairly high resistance to stretching 
suitable for cotton-type materials. A lower value might be 
suitable for stretchy materials such as Lycra.

• Stretch Damping: The Stretch Damping parameter 
controls the internal energy loss caused by the motion of 
the cloth fibers against each other. Higher damping causes 
the cloth to lose its motion more quickly. Excessively high 

values can make the cloth look like it is moving in syrup, 
and extremely low values can cause the cloth to behave 
irregularly. A value of 0.01 is suitable for more uses.

• Cloth Density: The Cloth Density parameter specifies the 
mass-per-unit area density of the cloth in grams per square 
centimeter. If you take a 1cm x 1cm piece of cloth and weigh 
it, the weight in grams is what this parameter should be set 
to. For example, silk is very light while leather is very heavy 
by comparison.

• Cloth Self Friction: The Cloth Self Friction parameter 
sets the coefficient of friction between one part of the cloth 
and another, or how easily the cloth moves over itself. 
Higher values prevent the cloth from sliding over itself. For 
example, rayon has a very low amount of self-friction while 
denim has a fairly high amount.

• Static Friction: The Static Friction parameter sets the 
amount of friction between the cloth and solid objects. 
This is similar to the Dynamic Friction parameter except 
that this is the force required to get a stationary cloth in 
contact with a solid to start moving. For example, nylon over 
smooth plastic will have a very low amount of static friction 
while denim over wood will have a high amount.

• Dynamic Friction: The Dynamic Friction parameter sets 
the coefficient of friction between the cloth and solid objects 
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when the cloth is in motion. Moving a piece of cloth across 
a surface causes friction. Silk moving over a steel surface 
has low resistance, while cotton moving over skin or coarse 
sandpaper over rough wood has high resistance.

• Air Damping: The Air Damping parameter specifies the 
cloth’s air resistance that occurs whenever the cloth is 
moving through the air. Tightly woven cloth has a higher 
resistance than loosely woven fabric. Set this parameter 
with care as excessive values could cause the cloth to behave 
unpredictably.

• Collision Friction: Checking the Collision Friction 
checkbox ignores the cloth object’s Static Friction and 
Dynamic Friction parameters, instead using those same 
parameters belonging to the collision objects themselves. 
Clearing this checkbox applies the cloth dynamic settings.

• Reset: Clicking the Reset button resets all cloth dynamics 
controls.

The label at the top right of the Cloth Dynamics Controls area 
displays the currently selected cloth object. To change the object, 
use the pull-down menu in the Cloth area (Step 2).

Cloth Parameters & Properties
To access a cloth object’s parameters and properties, you must 
first select the desired cloth object.

• Dynamic cloth objects have the same properties as props. 
Please refer to “Prop Properties” on page 225 for 
information about prop properties.

• Dynamic cloth has the same parameters as strand-based 
hair objects. Please refer to “Hair Parameters” on page 
546 for information about hair object parameters.

Creating Props and Morph Targets
You can convert cloth objects into static props or morph targets 
for use in scenes where a cloth-like look is desired without the 
need for a dynamic cloth object. For example, you could create a 
tablecloth using dynamic cloth and a table prop then convert the 
dynamic cloth object into a static prop for use in future scenes. 
If you did this, you would only need to include table legs where 
visible between the floor and the edge of the cloth, thereby giving 
you full realism while reducing your scene’s polygon count.

As another example, you could drape a sheet over a figure to 
create a ghost. Then you could convert the draped sheet to a 
static prop and use the Setup room to turn it into a poseable 
ghost.
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To create a prop from your dynamic clothing object:

1. Clothify an object as described above.

2. Use the Animation controls to move to your desired frame 
(the cloth shape changes with each frame as the simulation 
plays).

3. Use the Grouping tool to spawn a new prop. Please refer to 
“The Group Editor” on page 681 for information on using 
the Grouping tool and the Group Editor palette.

Creating a prop in this method preserves the shape of the 
original cloth object at the time you created the prop but 
removes all transformation (position, rotation, and scale). For 
example, if you stretch a square into a rectangle, the new prop 
will appear as a square deformed by the cloth simulation. In 
this case, reapplying the transformations applied to the original 
clothified object restores the original appearance to the static 
prop.

To create a morph target, follow steps 1 & 2 above, then spawn 
a morph target as you would for any other prop/body part as 
described in “Spawning Morph Targets” on page 661. You can 
then apply the morph target to a prop.

Morph targets created in this manner work in 
exactly the same manner as other morph targets, 

meaning that all dynamic motion is lost.

You can also export clothified props just like you would any 
other scene object. Exported cloth objects become static mesh 
objects in your chosen export format. To do this, follow steps 1 & 
2 above, then export the object as described in “Exporting Files” 
on page 783.

Adding Dynamic Cloth to the Library 
Palette
Adding dynamic cloth to the Library palette is a special case that 
merits its own topic. To add dynamic cloth:

1. If not done yet, load your desired figure and be sure to 
disable Inverse Kinematics (see “Inverse Kinematics (IK)” 
on page 177). Next, open the Joint Editor palette (see 
“Chapter 33: Working with Joints, Weights, and Skinning” 
on page 719) and click the Zero Figure button.

2. If not loaded yet, load or import your desired cloth object 
and ensure it fits the figure without obvious intersections. If 
importing a static prop, convert it into dynamic cloth using 
the Cloth room as described in this chapter.

3. Select the cloth, then open its Properties palette and click 
the Set Parent button (or select Object > Change Parent)

4. The Choose Parent window appears. Select Hip, being sure 
not to check the Inherit bends of parent checkbox.
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5. Open the Library palette to the Props category and select 
your desired subcategory as described above. Save the cloth 
object.

6. You will be prompted to save the object as a smart prop. 
Click Yes.

If your cloth object is not tied to a figure (such as 
a tablecloth), simply save it as a prop.
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Chapter 28: The Fitting 
Room

The Fitting Room is designed to address the needs of those who 
want to use existing clothing to fit new characters. The concept 
is as follows ... you get a new figure, you find clothing that you 
like, and you use the Fitting Room to alter the fit of the clothing 
to fit the newly available figure. Along the way, the Fitting 
Room allows you to convert the new fit into a prop (for dynamic 
clothing) or figure (for conforming clothing), including adding 
groups, skeleton, and character morphs.

The fitting process is done semi-automatically, in that you 
can use one of five different fitting methods (Prefit, Tighten, 
Smooth, Soft Features, and Rigid Features) to control what 
areas of the clothing should move more or less than others: The 
calculations for each of these methods are done automatically 
in Poser, but you can use paintbrush tools to determine the 
strength at which each of these fitting methods are used. This 
gives you full control over the appearance and result of the fit.

Problems and Solutions
The Fitting Room may not convert every piece of clothing 
perfectly, and there are some known limitations in the types of 

geometry that are difficult for the fitting room to handle. The 
following are some issues that are currently known:

• Clothing that is modeled in sections, with unwelded seams, 
can become split apart at the seams when tightened. The 
Soft Features method cannot resolve this, as it s a result 
of smoothing. The smoothing algorithm moves vertices as 
they relate to their neighbors, and if a seam is not welded 
it moves the sides away from each other. To reduce the 
separation, use the Paint tools to subtract the smoothing 
down to zero on both sides of the seam. 

• Clothing that has layered parts, such as a skirt and an 
overskirt, or two or more layers of overlapping geometry, 
can intersect and cause collisions.

• Setting all vertices to the Rigid Features method (examples: 
body armor, jewelry, jeweled Egyptian collars, etc.) can 
result in unexpected translations of the geometry.

• The Prefit method can cause conflicts with the Soft Features 
and Rigid Features methods. Prefit is run first, and it can 
balloon the geometry more than desirable in the areas that 
use Soft or Rigid Features.

• For clothing that incorporates more than one of the above 
issues you can, if desired, use Poser’s GoZ plugin, Wardrobe 
Wizard, or a third-party 3D application to refit to your new 
character. Fit the clothing item as closely as you can. Then 
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import the morph as a full body morph in the Pose Room. 
Dial the morph in before you enter the Fitting Room. When 
you set up the Fitting Room simulation, uncheck the Zero 
Figure option to apply your morph to the figure. Then set all 
Tighten method vertices to zero and paint in only the areas 
that you need to tighten further. Then export as a prop or 
figure from the fitting room to complete the setup.

• Many skirts have the lower portion grouped entirely as a 
hip, and use body handles for posing. To group the lower 
portion as a hip, pay attention to the body parts that you 
select in the Transfer Figure dialog when you create the 
figure. Deselect all of the body parts that appear beneath the 
hip. When you have the Auto Group option checked, this 
will group the hip and the body handles into a single group. 
The thighs, buttocks, shins, etc. will not be included. You’ll 
need to reassign the body handles to appropriately-named 
groups using the Group Editor or another method.

• For skirts that use the traditional grouping (such as when 
the hip runs down the center of the skirt to separate the 
left and right thigh groups), the hip group may not extend 
completely to the bottom of the skirt and will cause the 
center front and back of the skirt to appear “unwelded.” You 
will need to regroup the skirt to include at least two rows of 
polygons (one row at each side of the front and back center 
lines) to add a separation between the thighs.

Preparing Your Scene
Before you enter the Fitting Room, you need to load the 
character and the clothing that you want to refit into your scene. 
The following image shows Miki 4, and a shirt from the Ryan 2 
clothing library.

 Load the character and clothing into your scene.

Adjust Scale, Position, and Rotation
When you bring a figure and clothing into the fitting room, both 
objects are converted to Poser unimeshes. What this means is 
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that any translation, rotation, or scaling will work on the entire 
object, rather than on individual body parts.

Because of this, you’ll need to consider how the default poses 
of characters differ, and whether or not you will need to rotate 
body parts to match up the default poses more closely. Default 
poses of Poser figures can be quite different from one character 
to another. Arms and legs can be bent differently, one character 
might lean more forward or backward at the waist, and so on. If 
the differences are substantial, it’s a good idea to use rotations 
on the clothing to more closely match the default pose of the 
character you want to fit.

For example, some characters are modeled with arms perfectly 
straight when they are in their default pose, while others have 
their arms and legs bent slightly differently. The steps that you 
take at this point differ slightly, depending on these differences.

For example, if you are fitting a shirt, compare the bending 
of the arms. To begin, scale and move the clothing item to 
roughly match the figure. You don’t have to account for all of 
the pokethrough when you do this. The idea is to just get the 
clothing item in roughly the right position so that you can adjust 
the arm bends.

• If the arms are straight on the character, and are also 
straight in the shirt, you can do the remainder of the fit in 
the Fitting Room.

• If the arms are straight in one case, but bent at the elbow in 
another (such as shown in the following figure), you’ll need 
to adjust the rotations of the clothing before you enter the 
Fitting Room.

 Default arm positions for Miki 4 (top) and Victoria 4 (bottom).

In cases where the default pose is different, it helps to adjust the 
rotations on the clothing before entering the Fitting Room. For 
example, if the arms are bent differently on the shirt that you’re 
trying to fit, you can use the scale and rotation dials on the right 
arm to get the sleeve to match as closely as possible, and then 
use the Figure > Symmetry commands to apply the settings to 
the other side.
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 Rotation adjustments of Victoria 4 shirt before (top) and after 
(bottom).

After you make your adjustments, you may still have 
pokethrough on the clothing in other areas. However, the 
controls in the Fitting Room will take care of this when you 
create your fitting simulation.

 Victoria 4 shirt roughly scaled, rotated, and positioned to fit Miki 4.

If you don’t need to change any rotations on 
individual body parts, you can enter the Fitting 

Room without doing so. You will be allowed to adjust the 
overall scale and position of the clothing in the Fitting 
Room.

If you do make scaling and rotation adjustments 
in the Pose Room, you will need to uncheck the 

Zero Figure option when you create your fitting 
simulation as described in the following section.
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Creating a Fitting Simulation
After you add the clothing and figure to your scene, click the 
Fitting tab to enter the Fitting Room. At this point, the first 
step is to create a fitting session, which basically identifies the 
clothing item that you want to fit, and the character that you 
want to fit it to.

To create a new fitting session, follow these steps:

1. With the character and clothing loaded into your scene, click 
the Fitting tab to switch to the Fitting Room.

2. Click the New button at the top of the Fitting Sessions 
palette.

 Click the New button to create a fitting session.

3. In the Session dialog, complete the following:

 � Name: Enter a name for the clothing fitting session.

 � Object: Expand the Object list to select the clothing 
item that you want to fit to the character.

Check the Keep Deformations option for the 
Object if you applied morph targets or other 

deformers to the clothing in the Pose Room. For 
example, if you added magnets or applied a morph that 
raises or lowers the hem of a skirt, you can check the 
Preserve Deformations option to bring the skirt into the 
Fitting Room with that length.

Uncheck the Zero Figure option for the Object if 
you have made any rotation adjustments to the 

clothing to match the default pose of the character, as 
discussed in “Adjust Scale, Position, and Rotation” on 
page 570.

 It is standard practice for content developers to 
zero their figures (scale, position, and rotation) 

and then memorize those settings before saving the item 
to the library. However, sometimes this step is omitted, 
which can result in a non-zeroed figure being saved to 
the library. Checking the Zero Figure option can 
address conformers that have not been zeroed before 
adding them to the library.
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 � Goal: Expand the Goal list to select the character that 
you want to fit the clothing to.

Check the Keep Deformations option for the 
Goal if you applied morph targets or other 

deformers to the character in the Pose Room. For 
example, if you want to fit the clothing to a specific full 
body morph (such as Pregnant, or Body Builder) you 
can check this option to load the character into the 
Fitting Room with that body shape instead of the default 
body shape.

Uncheck the Zero Figure option f you have made 
any rotation adjustments to the figure.

 Select the Object (clothing item) and Goal (character).

4. Click OK. The clothing and character will appear in the 
Fitting Room as Poser unimeshes.
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Fitting Simulation Methods
After you create your new Fitting Session, you’ll see five different 
simulation methods associated with it: Prefit, Tighten, Smooth, 
Soft Features, and Hard Features. You can use each of these 
fitting methods singly, or in combination with each other to alter 
the fit of the clothing to fit the target character.

There are many controls and options that you see in common to 
all these method types:

 Common method controls and options.

• Method menu: Allows you to choose one of five fitting 
methods that move the clothing in different ways to fit the 
clothing. You can use any of these methods singularly, or in 
combination with each other, to generate the new fit for the 
clothing.

• Enable Method: Enables or disables the currently selected 
fitting method. Uncheck this option if you do not want to 
use the currently selected method in the fitting session.

• Weight: Controls the strength at which the currently 
selected method will be applied to the clothing.

• Display Weights: Enables or disables the display of colored 
vertices that show you how much or how little the currently 
selected method is applied to each vertex in the object.

 The Display Weights option shows and hides the display of colored 
vertices that show how strong the current method is applied.
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Tighten

When you initially create a new fitting simulation, you’ll 
automatically be directed to the Tighten method by default. If 
you immediately press the Fit button in the upper section of the 
Fitting Room, you’ll be able to get an idea of which areas need to 
be worked on further.

 Tighten options.

• Pokethrough Margin: The pokethrough margin controls 
the amount of distance between the figure and the clothing 
item. The default setting creates a sufficient amount of space 
between the two to ensure that there is no pokethrough 
when the figure is posed. Decreasing the setting will 
bring the clothing closer to the figure, but may introduce 

pokethrough when posing the figure. Increasing the setting 
will create more space between the figure and the clothing.

• Exclude Goal Group: Check this option to select a group 
that you want to exclude from the Tighten fitting method. 
This will create a new group in the clothing called _clothing 
name_exclude, where _clothing name_ is the name of the 
clothing item that is assigned in the fitting session. Click the 
Grouping Tool icon to open the Group Editor. This allows 
you to choose or create groups on the goal (the character 
you are fitting to).
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 Excluding goal groups.

• Paintbrush: Click the Paintbrush icon to enable the vertex 
painting tools. Initially, all of the vertices in the clothing 
object appear with green color, which indicates that the 

Tighten method is applied at full strength. You can use the 
Paintbrush to reduce the effect in areas that you do not want 
to tighten as much.

Prefit

When you run a fitting simulation, the areas that you include in 
the Prefit method will be pulled inward or outward before the 
other fitting methods are calculated.

When you initially create a fitting simulation, it initially opens 
with the Tighten method controls displayed. A good way to 
determine areas where prefit might be required is to click the 
Fit button before you do anything else to the clothing. Then you 
can add Prefit to the areas where the figure pokes through the 
clothing.
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 Adding the Prefit method to areas that do not fit properly after 
clicking the Fit button.

In order to use the Prefit method, you will need to create a Prefit 
Adjustment. To do so, click the New button in the Adjustment 
section. A new adjustment will be created and automatically 
named for you.

 Click the New button to create a Prefit Adjustment.

After you create the Prefit adjustment, the following controls 
appear in the Fitting Sessions palette for the Prefit method:

 � Delete: Click this button to delete the currently selected 
Prefit adjustment.

 � Set Weight: Controls the weight at which the current 
Prefit adjustment will be applied to the clothing. A 
setting of 1 applies the method at its full strength.

 � Paintbrush: Click the Paintbrush icon to enable the 
vertex painting tools.

 � Object Surface Normal: Moves the clothing vertices 
that you add to the Prefit method inward or outward 
based on the direction of the normals in the clothing 
item.
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 � Goal Surface Normal: Moves the clothing vertices that 
you add to the Prefit method inward or outward based 
on the direction of the normals of the character that you 
are trying to fit.

 � Direction indicator: Moves the clothing vertices that 
you add to the Prefit method inward or outward in a 
specific direction. Drag the circular indicator around 
the globe to specify the direction of the prefit.

The Weight setting in the Prefit method controls 
the amount that the clothing will be moved 

during the Prefit method. The Direction indicator gives 
you a visual indication of this setting as you adjust the 
Weight setting. Adjust the Weight setting until the 
Direction indicator displays the amount at which you 
want the clothing to move in that direction.

 The Weight setting will resize the direction indicator to display how 
much the Prefit method will move the clothing.

 � Reverse directions: By default, the Prefit method will 
pull clothing vertices away from the character during 
the Prefit calculations. Check Reverse Directions to pull 
clothing vertices toward the character instead.
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 Prefit options.

Smooth

The Smooth method blends the vertices of the fitted clothing to 
reduce the amount of hard transitions. When you choose the 
Smooth method, you’ll notice that all vertices are smoothed at 
maximum value (all appear green). Therefore, if you need to 
make any changes to Smoothing, it will be to reduce the effect of 
smoothing where you paint.

 Smooth options.

• Paintbrush: Click the Paintbrush icon to enable the vertex 
painting tools.

Soft Features

The Soft Features method is used for areas that are flexible, but 
which you want to maintain the overall shape as it moves more 
closely to fit the figure. Examples of soft features are pockets, 
collars, seam lines, hem lines, folds, wrinkles, and so on.
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When you switch to the Soft Features method, you’ll see vertices 
that are variously colored. Poser takes a “best guess” at the areas 
where the Soft Features method will be applied by analyzing 
charges in the polygonal density and changes in the surface 
normals.

 Soft Features options.

• Auto-Generate Weight Map: Use the Auto-Generate 
Weight Map controls as follows to adjust the Soft Features 
map

 � Threshold: Poser initially generates a Soft Features 
map based on the default threshold setting of 20. 
Increase the threshold to add more vertices to the Soft 
Features vertex map.

 � Generate: After you adjust the threshold setting, click 
the Generate button to update the Soft Features vertex 
map based on the new threshold value.

 Auto-generating a Soft Features vertex map.

• Paintbrush: Click the Paintbrush icon to enable the vertex 
painting tools. When painting a Soft Features vertex map, 
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focus on areas where you want the shape to be retained as 
the clothing is fit to the figure. The following figure shows 
additional Soft Feature method added to the collar, and the 
result after the Fit is run.

 Additional Soft Features strength added to the shirt collar.

Rigid Features

Use the Rigid Features method on areas where you want to 
retain the shape when the clothing is fitted to the character. 
Examples of Rigid Features would include buttons, buckles, 

clasps, and other similar items. There is only one option for 
Rigid Features:

• Paintbrush: Click the Paintbrush icon to enable the vertex 
painting tools.

 Rigid Features options.

You might find it easier to paint Rigid Features 
while you have your Display set to Smooth 

Shaded Lined. It also helps if you reset the Fitting 
Simulation so that you can paint the rigid features while 
the clothing item is in its default shape and size. This 
allows you to more easily determine which vertices you 
need to paint.
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 Switching to Smooth Shaded Lined display mode to see polygons 
and vertices more clearly.

Painting Vertex Weights
When you click the Paintbrush icon in the Fitting Room, it opens 
the Vertex Weights palette shown in the following figure.

 Vertex Weights palette.
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The settings and options in the top section of the Vertex Weights 
palette are as follows:

 Vertex weight painting modes.

• Subtract: Use the Subtract brush to remove or reduce the 
weight of the vertices that you paint.

• Add: Use the Add brush to increase the weight of the 
vertices that you paint.

• Smooth: Use the Smooth brush to blend transitions 
between adjacent areas that have wide variations in the 
amount of weight applied to them.

• Weight: Use the Weight brush to paint with a specific 
weight value, as entered in the Weight field.

• The middle section of the Vertex Weights palette contains 
five different brush styles, ranging from a very small brush 

designed to paint single vertices to other brushes that have 
varying degrees of softness around their edges. In addition, 
the following additional settings appear here:

 Brush options.

Use the harder edge brushes to paint vertex 
weight on circular objects like round buttons, 

scale brush size to match the diameter of the button, 
then set a relatively high magnitude, center the brush 
over the button and click to quickly paint that button 
geometry.

• Radius: Controls the size of the brush. Move the slider left 
or right to adjust the size, or enter a specific value in the 
Radius text box.
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You can increase or decrease the radius of the 
brush by .0005 each time you press the Up or 

Down arrow key. Press the Shift key while using the Up 
or Down arrow key to increase/decrease by .005.

• Magnitude: Controls the strength at which the effect is 
applied while you paint. Move the slider left to decrease the 
strength, or right to increase it. You can also enter a specific 
value in the Magnitude text box.

You can increase or decrease the magnitude of 
the brush by .0005 each time you press the Left 

or Right arrow key. Press the Shift key while using the 
Left or Right arrow key to increase/decrease by .005.

• Group: Check the Group option to isolate the effects of the 
painting to a specific group. Then select the group from the 
drop-down menu.

• Invert Colors: Check this option to reverse the color 
display of the vertices, so that vertices with low values will 
be displayed green, and vertices with high values will be 
displayed with darker colors.

The bottom section of the Vertex Weights palette contains 
controls that allow you to mirror, copy, paste, and set vertices to 
specific weights.

 Mirror, Set, and Copy/Paste weights.

• Mirror: Allows you to copy weight painting from one side of 
a model to another. This helps save time, by allowing you 
to paint one side of a model and then mirroring the same 
values to the other side of the model.

• Set All: Allows you to set all vertices to 0, to 1, or to the 
value that you have entered in the Weight section in the top 
of the Vertex Weights palette.

• Copy/Paste: Provides commands that allow you to copy 
and paste weight values between objects.

Completing the Fitting Simulation
You can run the fitting simulation any time during the fitting 
process to test how the various methods are working on the 
clothing item. You will also need to run the fitting simulation 
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after you complete your fitting, in order to generate the clothing 
item that fits the character.

The controls to run the simulation and generate the final piece of 
clothing are at the top of the Fitting Simulation palette.

 Rigid Features options.

• Fit: Click the Fit button to run the fitting simulation. You 
can do this at any time during the fitting process to check 
how each fitting method affects the clothing. You’ll also need 
to do it before you spawn a prop or create the clothing figure 
to fit your specific figure.

• Reset: Clears the results of the fitting simulation from the 
clothing. This returns the clothing back to its default shape 
and position.

• Iterations: The number of times that fitting calculations are 
repeated to achieve the fit. Higher values take longer but can 
provide a more accurate fit.

• Spawn Prop: Click this button to create a prop based on the 
current shape of the clothing. You will be prompted to enter 
a name for the new prop. The new prop will appear in the 
Pose Room, but will not be rigged to conform to the figure.

• Create Figure: Click this button to create a new conforming 
figure based on the current fit. The steps are as follows:

 � The New Figure dialog prompts you to enter a name for 
the new conforming figure.

 � The Transfer Figure dialog appears. Use the Hierarchy 
List to check or uncheck the body parts that you want to 
keep in the figure.
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 Check the Keep Morphs option to add character morphs to the 
clothing.

 � If you want to transfer morphs from the character to the 
clothing, check the Transfer Morphs option. 

 � Check the Auto Group option if you want to regroup 
the clothing to match the groups in the figure. If you 
have already added the correct figure groups using 
another means, you can uncheck the option to preserve 
the existing groups.

 � Check the Zero Rotations option to set all rotations 
for each body part to zero. The results will be the 
same as what you achieve when you zero a figure after 
conforming new clothing to a figure.

 � Then click the Select button to choose the morphs that 
you want to transfer to the clothing.

When you return to the Pose Room, conform the 
clothing to the figure. Then with the Body actor 

selected on the clothing, switch to the Properties palette. 
Check the Include Morphs When Conforming option so 
that the clothing will automatically fit when you adjust 
the character’s morphs.
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 Check the Keep Morphs option to add character morphs to the 
clothing.

 � Check the Auto Group option to group the clothing 
based on the groups in the figure. Uncheck this option 
if you want to use other methods to add groups to the 
clothing.

 � When you switch to the Pose Room you’ll see your new 
clothing item. Select it, and then choose the Figure > 
Conform To command to conform it to your character.

The original version of the clothing will still 
appear in the scene. You can safely delete the 

original version without affecting the copy that is in the 
Fitting Room.
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Chapter 29: Wardrobe 
Wizard

Wardrobe Wizard is a utility that enables Poser clothing models 
originally created for one Poser figure to be worn by another. 
A very large number of figures are supported, and support for 
many past and current Poser/Smith Micro figures are built into 
Poser.

For a full complete list of figures that are 
supported by Wardrobe Wizard, see http://

www.philc.net/store_WW_Extra_Figs.php.

Before you use Wardrobe Wizard to convert clothing, you 
may want to consider spending a few minutes reading these 
instructions. Doing so may explain many questions that you 
might encounter if you dive in before understanding what each 
feature does.

Using the Wardrobe Wizard
Choose Scripts > PhilC > Wardrobe Wizard Menu then open 
the Python window to view the Wardrobe Wizard button menu 
shown below.

 Wardrobe Wizard options in the Python Palette.

The commands in this palette are as follows:

• Convert: Brings up the Plug in Graphical User Interface 
(GUI), which is explained in “Converting Clothing” on page 
590.

• Analyze Full Body Morphs: Before you can add compatible 
Full Body Morphs to the clothing you must first allow 
Wardrobe Wizard to analyze the figure. This only needs to 
be done once, (unless you subsequently change the morphs 

http://www.philc.net/store_WW_Extra_Figs.php
http://www.philc.net/store_WW_Extra_Figs.php
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in the figure). Requires the figure to be selected in the scene. 
This process is described in “Analyzing Full Body Morphs” 
on page 596.

• Smooth: Allows smoothing operations to be undertaken on 
the clothing.

• Inflate/Deflate: Allows the clothing to be inflated or 
deflated.

WW Smooth, WW Smooth More, and WW 
Inflate full body morphs are automatically 

included in each clothing conversion. If the Add Material 
Dials option is selected, further refinement is provided 
by being able to smooth and inflate by material. See 
“Choosing Additional Converting Options” on page 
594 for more details. The Smooth and Inflate menu 
buttons allow you to perform these tasks on any figure, 
independently of the conversion process.

• Utilities: Access more utilities, as discussed in “Wardrobe 
Wizard Utilities” on page 599.

• Zero Figure: Zero Pose the figure. This is a convenience 
utility. Neither the figure nor the clothing needs to be within 
the scene when performing a conversion.

• Load: Load a character into the scene using a standard 
Windows or Mac file selection dialog rather than using the 
Poser library.

• Help: Brings up the Wardrobe Wizard help file.

• Version: Displays Wardrobe Wizard version, figure support 
and system information.

• Back: Reloads the default Python script buttons.

Converting Clothing
You do not need to have any clothing or figures in your Poser 
scene in order to convert clothing. Simply click the Convert 
button from the main Wardrobe Wizard palette to open the 
Wardrobe Wizard dialog shown in the following figure.
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 Converting clothing with the Wardrobe Wizard.

Choosing the Original Clothing

Using the Original Clothing section of the GUI select the 
clothing that you wish to convert. This may be either a single 
item or an number of items. They can be Poser clothing figures, 
props or OBJ files, either in their compressed or uncompressed 
format.

 Choosing the original clothing.

Note that clothing figure files should contain only 
one item of clothing. If you have a multi item 

CR2 file then load it into Poser and save each item back 
to the library. You can then batch convert the set. If you 
have made multiple selections please note that any 
conversion option selected will be applied to the whole 
batch. Therefore do not convert pant suits within a 
batch containing skirts since each requires different 
settings.
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Please note that gloves are not supported by 
Wardrobe Wizard.

Selecting the Target Library

Use the Save Result to This Library selector to choose the 
Target Folder into which you wish the converted clothing to be 
saved. For example if you wish the clothing to be saved to the 
Poser library you would select your Poser library installation 
folder

If you want to save your converted clothing to a remote Poser 
library you would select the folder above that library’s Runtime 
folder.

Clothing will be saved to a character specific folder.

• The OBJ file will be saved to the Runtime: Geometries: 
WardrobeWizard: Figure Name folder. In this way you can 
easily reorganize your library if required.

You can move the figure CR2 and PNG files 
without worrying about editing the path to the 

OBJ file.

Selecting the Figures to Convert From and 
To

Use the Convert From scrollable list to select the figure that the 
original clothing was made for. All the figures that you have the 
support files for will be listed here.

Use the Convert To scrollable list to select the figure(s) that you 
wish the clothing to be converted to. All the figures that you have 
the support files for will be listed here.

The names of your available figures will be 
visible in the Convert to and Convert from lists. 

These are the “out of the box” versions of those figures. If 
you have these figures and receive a message that you 
do not have a supported figure, it may mean that the 
figure was customized by a third-party vendor. 
Sometimes when customizing a figure Poser or the user 
will alter the name of the OBJ file that the figure 
references. For example this can occur if the Poser Face 
room is used. The solution is to either use the out of the 
box figure or edit your custom figure to reference the 
original OBJ file.
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Click the Extra Figure Support button at the 
bottom of the Wardrobe Wizard window to 

obtain the most recent information on where to obtain 
add-ons that provide Wardrobe Wizard support for 
third-party Poser figures.

 Choosing the figure to convert clothing from and to.

Choosing the Clothing Type

Select the type of clothing that best describes the clothing being 
converted.

 Choosing the clothing type.

• Pants, Pant Suites, Shirts, Etc:- Choose this category 
for Pants, Jackets, or any clothing above the hips. Most 
anything that does not fit any of the other categories listed 
below will fit this category.

• Loose Skirts, Skirt Suites, Long Robes, Etc:- Choose this 
category for any skirt that tends to fall away from the hips. 
This also includes robes. This is probably going to be your 
preferred skirt option, including short skirts.
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• Tight Skirts: Use this option for any skirt that tends to 
closely follow the line of the legs. You may want to use this 
option if the legs of the figure you are converting to are 
significantly spread apart.

• Short Hair: Choose this option for hair that does not extend 
past the neck.

For long hair use Pants, Pant Suites, Shirts, 
Etc.

• Shoes that DO fit at Zero Pose: Use this option for any 
shoe, boot, thigh boot that fits the figure when both the 
figure and footwear are at their unconformed zero pose.

• Shoes that DO NOT Fit at Zero Pose: Choose this option 
for any shoe, boot, thigh boot that does not fit the figure 
when both the figure and footwear are at their unconformed 
zero pose. Please note that the more the shoe does not 
fit, the poorer the quality of the conversion will be. See 
“Footwear” on page 610 for more details.

Choosing Additional Converting Options

The Options section of the Wardrobe Wizard window contains 
several other options that you can check or uncheck for clothing 
conversion. These options are as follows:

 Choosing additional conversion options.

• High Resolution: Choose from High (checked) or Normal 
(unchecked) resolution. Normal resolution will convert 
faster but at the expense of definition.

• Flared: Select this option for flared pants or flared sleeves.

• Close Fit: Only deselect this option if you are converting 
particularly baggy clothing.
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• Force Reanalysis: When an item of clothing is first 
converted Wardrobe Wizard undertakes an analyses of it. 
The resulting data file is stored for future use. This greatly 
speeds up the time of any future conversion. However if for 
example you converted as a “Loose Skirt” and wish to see 
if perhaps selecting “Tight Skirt” may be better you would 
need to select the “Force Reanalyses” check box to ensure 
that Wardrobe Wizard redid the analyses with the new 
settings.

• Keep Existing Morphs: Wardrobe Wizard has the ability 
to retain any Full Body Morphs contained in the existing 
clothing. By selecting this check box you will subsequently 
be presented with a pop up list of all the available existing 
morphs and be able to select the ones that you wish to keep.

• Add Full Body Morphs: Wardrobe Wizard has the ability to 
add Full Body Morphs to the clothing to match the Convert 
To figure. For this you will first have to have Wardrobe 
Wizard analyze the figure. Also accessed via this checkbox 
option are the large number of very powerful clothing 
adjustment morphs. Please see the details in the “Full Body 
Morph” section above.

• Regroup: Generally leave this option selected. Only turn 
it off if there is some reason to not have Wardrobe Wizard 
regroup the model. Possibly some custom process that you 
wish to undertake.

• Regroup All: Forces a more aggressive regrouping 
algorithm, particularly in the torso. Use if the standard 
regroup option does not give satisfactory results.

• Fix Pokethrough: Any cloth that intersects the figure will 
be repositioned so that it remains above the skins surface. 
Use with care. This tool is also included in the Wardrobe 
Wizard Python Script buttons which may be a better time 
to use it since the converted figure will have been saved to 
the library at that point. However you will probably find 
that adjusting the newly created WW_Looseness morph 
in the clothing’s BODY will give better results and be more 
controllable. FixPokeThru works with clothing intersecting 
the figure. It is not designed to work with clothing 
intersecting clothing.

• As Prop: Delivers the converted clothing as a Poser Prop 
rather than a conforming figure. You would use this if you 
wish to use the converted clothing as dynamic clothing in 
the Poser Cloth room.

• Add Material Dials: Provides the option to allow Wardrobe 
Wizard to create a set of full body morphs that result in 
smoothing or inflation by selected material. Very powerful, 
very useful, very easy to use. By way of a bonus if you 
select this option you get an extra “Shrink to fit dial”. If you 
haven’t read these instructions you will probable not realize 
that it is there.
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• Copy Weightmaps: Provides the option to copy weight 
maps from the convert to figure into the converted clothing. 
Wardrobe Wizard will convert and save the clothing as 
normal then load the clothing and figure into the scene to 
facilitate the weight map copying process. Since the figure 
will probably be located in a remote library the user will be 
prompted to browse for its file. Upon completion the user 
will have the option to save the weight mapped clothing to a 
figure folder of their choice.

Once you have made your selections click the Convert button. 
Depending on your selections you may get supplementary pop 
up windows asking you to select such things as which morphs 
to keep etc. The progress will be displayed in the Poser Python 
output window.

Finding Your Converted Clothing
Upon completion open Poser and navigate to the designated 
library. Your converted figures will be in folders bearing the 
suffix “WW” followed by the name of the figure that they were 
converted to. The name of the clothing will be the same as the 
name of the original item, as will the thumbnail if one was 
available for the original.

Analyzing Full Body Morphs
Wardrobe Wizard has the ability to automatically create full 
body morphs in the clothing to match those contained in the 
figure that you wish to convert to. In this way if you have a figure 
that has been customized using full body morphs you can use 
Wardrobe Wizard to build compatible morphs into the clothing. 
Before this can happen you will first need to have Wardrobe 
Wizard analyze that figure. If you have the Plug in GUI open as 
shown above click the “Cancel” button then proceed as below.

1. With the desired figure selected in the Poser scene, click the 
Analyze Full Body Morphs button.
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 Analyzing Full Body Morphs.

2. A dialog opens, and prompts you to select the morphs that 
you want to include in your clothing.

 Select the full body morphs that you want to analyze.

 � Scroll through the list and check the options that you 
want to add into your clothing.

 � If you want to include all of the figure’s morphs in your 
clothing, click the Select All button.

 � Click Select None to deselect all of the selections you 
have made.

 � Click Invert Selection to switch the selected morphs to 
unselected, and vice versa.
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 � Click Cancel to exit the dialog without analyzing your 
selections.

3. Click OK to apply your selections. Wardrobe Wizard 
displays another dialog with a summary of the morphs that 
you selected.

4. Click OK again to perform the conversion. Wardrobe 
Wizard displays the progress as the morphs are being 
analyzed. When the process is complete, the dialog displays 
Done! at the end.

 Wardrobe Wizard displays a dialog when the analysis is complete.

You only need to do this once for each figure that 
you wish to have Full Body Morphs added for. 

The data is stored as a MOR file for future use. You 
would only need to reanalyze the figure if you add/
change the morphs in the figure. See additional tools 
below for dealing with characters with non-standard 
body morphs etc.

Refining the Full Body Morphs in Your 
Clothing

In addition to the Full Body Morphs that you have transferred 
from your figure to the clothing, Wardrobe Wizard also includes 
a large number of very powerful yet simple to use clothing 
adjustment Full Body Morphs. You will find these dials in the 
BODY section of your converted clothing, and listed under the 
heading WW Adjustment Morphs.

A number of other WW Adjustment morphs may be included 
when you make your selection from the pop up morph list 
during the conversion process. It is strongly suggested that 
you try them out. They provide a great deal of versatility in the 
converted clothing. To access these powerful morphs simply 
select the “Add Body Morphs” (plug-in:- “Add FBM’s”) and “Add 
Material Dials” checkboxes.
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The following morphs are built into the clothing automatically 
by Wardrobe Wizard:

• Smooth: This will provide a dial in the clothing’s BODY to 
enable small wrinkles to be ironed out.

• Smooth More: Similar to WW Smooth but applies to the 
edges of the clothing.

• Inflate: Easily adjust how tight/loose the clothing fits the 
figure. If you find a small area of the underlying figure 
poking through turn the WW Looseness dial a little. It 
is suggested that you initially try this rather than the 
“Pokethru” option.

• Shift: Translate the BODY or body parts. Use “Save Changes 
to Geometry” to make the adjustment permanent.

• Cleavage: This adjust the area of the clothing in between 
and below the breasts. It was noticed that when clothing 
made for a well endowed figure was converted to a figure of 
more petite proportions there would be some clothing “left 
over” that tended to sag. (Much the same as in real life). The 
WW Cleavage dial allows you to easily take in the slack.

• Under Breast Smooth: Sometimes required to provide 
additional smoothing to loose fitting ladies shirts.

Wardrobe Wizard Utilities

Clicking the Utilities button in the main Wardrobe Wizard 
script palette brings access to a number of utilities subdivided 
by function. These utilities are not key to converting clothing but 
are included as additional features that may prove useful.

The various utilities that are available appear in the menu shown 
below. These utilities are described in the sections that follow.

 Other Wardrobe Wizard Utilities.
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Figure Utilities

 Wardrobe Wizard Figure Utilities.

Figure Utilities Menu 1

• Load Figure: Opens a dialog that allows you to navigate to 
a character library folder on your hard drive, and select a 
character file.

• Zero Figure: Select a figure and then click this button to set 
all joint rotations to zero, and scales to 100%.

We recommend that you turn IK off before using 
the Zero Figure option.

• IK Off: Select a figure and click this button to turn Inverse 
Kinematics off.

• IK On: Select a figure and click this button to turn Inverse 
Kinematics on. IK is applied to hands and feet with this 
option.

• Transparency Off: Turns transparency off. Only works in 
older versions of Poser.

• Transparency On: Turns transparency on. Only works in 
older versions of Poser.

• Weld Figure: Click this button to create a welded copy of 
the selected figure. The copy appears in the Select Actor 
menu and is named new.

• More...: Click to display Figure Utilities Menu 2.

• Back: Goes back to the previous menu.
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Figure Utilities Menu 2

 Figure Utilities (part 2).

• Copy Scaling: Copies scaling parameters into the 
clipboard.

• Apply Scaling: Applies copied settings to the currently 
selected figure.

• Save Scaling: After you copy scaling settings to the 
clipboard, saves the scripts to your hard drive. The script is 

found in your Poser installation folder as Runtime \Python 
\poserScripts \PhilC \Wardrobe Wizard P10 \Scale.py.

• Remove Scaling: Removes scaling settings from the figure 
that you click.

• Remove Magnets: Removes magnets from the figure that 
you click.

• Copy Joint Parameters: With two (or more) figures in the 
scene, allows you to copy joint parameters from one figure 
and apply them to another.

• Back: Goes back to the previous menu.

Morphs Utilities

Morph Utilities Menu 1

Clicking the Utilities > Morph buttons brings up these buttons.
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 Wardrobe Wizard Morph utilities.

• Create MOR from Figure: This will analyze the current 
character settings and create a morph analysis files (MOR 
file.) This eases converting clothing from custom figures 
that are ‘dialed’ from existing morphs; turns it into a 1-click 
conversion.

• Create MORs from Dials: This will analyze all the dials of 
the current character and create multiple morph analysis 
files (MOR files.) This is the same thing as the existing 

‘Analyze full body morphs’ button, which creates a morph 
analysis for every clothing dial. It is intended to be used with 
figures such as V4, V41 and Apollo etc each of which contain 
some fancy string pulling in their figure CR2 files that result 
in non-standard Full Body Morph dials that Wardrobe 
Wizard can not recognize.

• Dials to Single Morph: This will convert all current 
character settings to a single Full Body Morph dial on 
the character. This is a powerful feature that will take the 
existing dials and magnets on the figure, and turn it into a 
single Full Body Morph dial on the BODY of the figure. Let’s 
say you have a character that is based on V3 morphs, and 
requires 15 morphs to be injected and set. This button will 
let you turn them all into a single ‘new’ morph, that doesn’t 
require the dials to be set, or even injected, any more.

• Dials to Multiple Morphs: This will convert all dials on 
the current character to multiple normal morphs on the 
character. This is similar to ‘Dials to Single Morph’ above, 
but creates multiple morphs, one per dial. The new morphs 
don’t require the old dials to be set, or even injected, any 
more.

• Actor Morphs to Figure: This will transfer selected actor 
morphs to the body. This is useful to bring up hair morphs 
or chest morphs etc to the BODY level, where Wardrobe 
Wizard can analyze them.
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• Figs to Morphs: Provides a method of creating a full body 
morph from a morphed version of the figure. The steps are:

 � Load the base figure and use the zero figure button.

 � Load the reshaped figure. (See Save Changes to 
Geometry below)

 � With the base figure selected click the Figs to morphs 
button. This will use the reshaped figure as a morph 
target and build a full body morph into the base figure.

 � Delete the reshaped figure.

 � Save the base figure to the library.

• Save Changes to Geometry: “Fixes” the figure’s geometry 
to whatever is currently displayed in the scene. When the 
figure is saved back to the library this new geometry is 
saved as a new OBJ file. It is very possible that the joint 
parameters will not work well. Its purpose is to:

 � Provide a figure to be used as a morph target in “Figs to 
morphs” above.

 � Enable clothing that does not fit the figure at zero pose 
to be made to fit and hence produce a good conversion. 
See the “anything else” shoe example below.

• Zero All Morphs: Sets all morph dial values to zero.

• More...: Displays Morph Utilities Menu 2, described next.

• Back: Goes back to the previous menu.

Morph Utilities Menu 2

 Morph Utilties (part 2).

• Set All Morphs: Sets all the morphs present in the figure 
to a value of 1.000 Intended as a quick way of setting all 
morphs recently created in a blank figure using magnets 
in preparation for using the Poser menu Figure/Create full 
body morph. Anything else and it just has novelty value.

• Zero All Scaling: Just what the button says.
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• Back: Goes back to the previous menu.

Texture Utilities

 Wardrobe Wizard Texture Utilities.

• Set All to White: Click this button to change all Diffuse 
Color settings to white. Links to texture maps remain 
connected to the root node.

• Edit Texture: Click this option to display a menu of texture 
maps that apply to the current figure. When you then select 

a texture map, the texture opens in the default program that 
your system uses for editing bitmaps (such as Photoshop or 
another image editor).

• Apply Texture to All Mats: Click this button to display a 
menu of texture maps that are applied to the current figure. 
When you then select one of the texture maps, it is applied 
to all materials in the current figure.

This option is not undoable, and is not 
recommended for content that uses multiple 

texture maps (such as figures that use separate head, 
body, teeth, and eyelash texture maps).

• Copy Texture to Prop: Allows you to copy material settings 
from one prop to another. They must both have the same 
material names.

• Transparency Off: Sets transparency to 0%.

• Transparency On: Sets transparency to 100%.

• Transparency Half: Sets transparency to 50%.

• Remove All Textures: Removes textures from the item that 
you click.

• Back: Goes back to the previous menu.
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Prop Utilities

 Wardrobe Wizard Prop Utilities.

• Figure to Single Prop: Converts the figure that you click 
into a single prop.

• Figure to Multiple Props: Converts the figure that you click 
into multiple props, and saves them to the Runtime \Python 
\poserScripts \PhilC \Wardrobe Wizard P10 \temp folder.

• Import Multiple Props: Allows you to import multiple 
props (for example, the individual props saved with the 
Figure to Multiple Props script mentioned above.

• Back: Goes back to the previous menu.

Lights Utilities

 Wardrobe Wizard Light Utilities.

• Intensity: Provides several different options for increasing 
or decreasing the Red, Green, Blue, or all channels of a light.
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• Swap: Flips the orientation of the lights so that right lights 
are moved to the left side, and left lights are moved to the 
right side of the scene.

• Shadows Off: Turns shadows off on all lights.

• Shadows On: Turns shadows on for all lights.

• Delete All: Deletes all lights in the scene.

• Back: Goes back to the previous menu.

Shape Utilities

Clicking on the Utilities > Shape buttons brings up the Shape 
buttons. They allow you to change the shape of the geometry. 
Once you have the shape you like save the figure to the library to 
make the shape permanent.

The tools are primarily used to fine tune the shape of skirts but 
may be used on other body parts also.

These utilities do not create a morph you 
actually change the geometry that gets saved to 

the OBJ file.

Now for those who really want to “get into it”, here is an 
explanation of how these buttons work and how they can be 
customized. The list of formulas is in the data folder under 

‘formulas.txt.’ Each line is a single formula consisting of the 
name, the direction to apply the adjustment in, the adjustment 
amount, and a set of numbers that control how the formula is 
applied.

That set of numbers is most similar to a ‘convolution kernel.’

Examples:

• 0 0 Don’t apply any adjustment.

• 1 1 All verts top to bottom get the adjustment equally.

• 1 0 Top half of the actor gets 100% of the adjustment, 
bottom half gets no adjustment.

• 1 0 0 Top THIRD of the actor gets 100% of the adjustment, 
bottom half gets no adjustment.

• 0 0 1 Top two thirds gets no adjustment, bottom third gets 
all the adjustment.

The ‘number’ of numbers on the line control how many sections 
to divide the actor into. Two numbers divides the actor into 
2 parts top to bottom, 3 numbers divides it into 3 parts, 10 
numbers divides it into 10 parts, etc.

The ‘value’ of the adjustment is the relative weight to give it.

Example:
pear xz .1 0 1 2 3 3 3 3 3 3 3 3 3 3 3 3
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This says:

• Move in the xz direction only, which doesn’t affect the 
length. .1 is the amount to move.

• There are 15 numbers following, that means divide the skirt 
up into 15 sections.

• The highest number is a 3 - that means all entries with 3 
get 100% of the adjustment, entries of 2 gets 2/3 of the 
adjustment, entries of 1 gets 1/3 of the adjustment, entries 
of 0 get none of the adjustment.

• The first number is a zero - that means the top 1/15 gets no 
adjustment.

• The second number is a one - that means the next section 
gets 1/3 of the adjustment.

• The second number is a two - that means the next section 
down gets 2/3 of the adjustment.

• The following numbers are all 3’s - that means the 
remainder of the actor gets 100% of the adjustment.

There are three Shape Utility menus, with various shapes named 
as follows. We suggest experimenting with these shapes to learn 
how you can combine them to achieve the shapes you need:

• Menu 1: Includes Undo, Flare, FlareFront, Taper, 
TaperFront, InflateThighX, InflateThighZ, and Inflate. 
Choose More to proceed to the second menu, and Back to 
return to the previous menu.

• Menu 2: Includes Undo, InflateXZ, InflateX, InflateZ, Pear, 
Hilo, Puff1, and Puff2. Choose More to proceed to the third 
menu, and Back to return to the first menu.

• Menu 3: Includes Undo, Puff3, Puff4, and Back (which 
returns to Menu 2).

Shift Utilities

These buttons move the geometry in Poser’s memory as opposed 
to translating the model in 3D space. Redundant in Wardrobe 
Wizard but retained here “just in case”.
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 Wardrobe Wizard Shift utilities.

• Shift Right: Shifts selected geometry to the right.

• Shift Left: Shifts selected geometry to the left.

• Shift Up: Shifts selected geometry upward.

• Shift Down: Shifts selected geometry downward.

• Shift Forward: Shifts selected geometry forward.

• Shift Backward: Shifts selected geometry backward.

• Back: Goes back to the previous menu.

Magnets Utilities

 Wardrobe Wizard Magnet utilities.

• Hide All Magnets: Hides all magnets in the scene.

• Show All Magnets: Shows all magnets in the scene.
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• Delete All Magnets: Deletes all magnets in the scene.

• Hide Actor Magnets: Hides all magnets on the currently 
selected actor.

• Show Actor Magnets: Shows all magnets on the currently 
selected actor.

• Delete Actor Magnets: Deletes all magnets on the currently 
selected actor.

• Add Magnet: Adds a magnet to the scene.

• Back: Goes back to the previous menu.

More Utilities

 Additional Wardrobe Wizard utilities.

• Fix Pokethrough: If a section of clothing is intersecting the 
figure this button will move it to just above the surface of the 
skin. Use with care since some clothing models intentionally 
have polygons that intersect the skin. You may be better 
served by adjusting the “WW Inflate“ full body morph that 
automatically gets included in each clothing conversion. 
FixPokethru works with clothing intersecting the figure. It is 
not designed to work with clothing intersecting clothing
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• Check For Updates: Opens your browser to a web page 
that provides information on obtaining the most recent 
updates for Wardrobe Wizard.

• Make Art: Provides a tongue in cheek solution to the often 
asked question of how Poser may be used to create art.

• Back: Goes back to the previous menu.

Footwear

Shoes

Original footwear correctly aligns to and covers the original 
figure when both the figure and the footwear are at the zero pose. 
This is achieved without the need to conform the footwear to the 
figure.

The over riding factor is that the footwear fits the figure, not the 
style of the heel.

 Converting flat footwear.

Hi Heels

The original footwear only fits the figure providing that some 
bending or morphing of the figure or footwear is undertaken. 
And/or the feet must be set invisible.

The majority of Poser high heel styled shoes fall into this 
category.
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 Converting footwear with heels.

Other Types of Shoes

Models that have to be “shoe horned” into fitting the zero posed 
figure.

Note that some high heeled shoes are correctly modeled to fit 
the figure when at the zero pose. These then take up their high 
heel shape when the foot is bent. For these use the “Shoe” type of 
conversion. Try Shoe type first.

The above two methods are going to cover the majority of shoes 
but for those that fall through the cracks try this.

1.  By hook or by crook get the shoe to fit the zero posed figure.

2.  Use the Wardrobe Wizard Poser Python buttons Utilities > 
Morphs > Save Changes to Geometry.

3.  Save the shoes back to the Poser figure library with a new 
name so as to not over write the originals.

4.  Convert using the newly created Footwear using the “Shoe” 
type but if that does not work try the Hi Heel type.

 Converting other types of shoes.

Common Questions (and Answers)
Q: Where can I get additional support for Wardrobe Wizard?

A: We suggest the following:
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• For online information, video tutorials, etc. see http://www.
philc.net/WardrobeWizard.php.

• To ask questions in the Wardrobe Wizard forum go to 
http://www.philc.net/forum/ (requires creating a free user 
account).

Q: Wardrobe Wizard starts to analyze the clothing but then 
says that it can not find the OBJ file.

A: Wardrobe Wizard can find paths in the CR2 file when the 
“figureResFile” is given in either of these two these formats:-

Relative Path
Runtime:Geometries:Folder:SubFolder:filename.obj
Runtime:libraries:character:Folder:SubFolder:filename.

obj

Absolute Path
C:\Documents and Settings:Administrator:My 

Documents:My Poser Files:Runtime:Geometries:Folder:SubFol
der:filename.obj

Open the CR2 file in a text editor to find the figureResFile line. It 
is usually within the first ten lines of the file.

Either will work but if the path is relative check to ensure that 
the CR2 file is within that same Runtime. If the path is absolute 
check that the file is actually where it is supposed to be.

Q: The conversion went well, but there is one small section 
that needs some extra adjustment. Using the Wardrobe 
Wizard smoothing or inflation morphs affects too great an 
area.

A: Use the Poser Morphing Tool to fine tune as required. This 
is a very useful tool that will allow you to smooth, push or pull 
small areas as required. Suggest setting the Magnitude to a 
very low value to allow fine control. For information about the 
Morphing tool, see “Creating Morphs with the Morphing Tool” 
on page 642.

http://www.philc.net/store_WW_Extra_Figs.php
http://www.philc.net/store_WW_Extra_Figs.php
http://www.philc.net/forum/
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Part 7: Content 
Creation Tools
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Chapter 30: Modifying 
Figures & Props

This chapter explains how to create completely custom looks for 
your figures and props. For example, human bodies come in all 
shapes and sizes. You can modify proportions using various tools 
to achieve interesting effects.

 A figure’s head reshaped by a magnet.

Poser includes a wide variety of tools for figure/prop shaping. 
Here are some tips, tricks, and important things to keep in mind 
when editing figures and/or props:

• All Poser figures come with morph targets and full body 
morphs, allowing you to reshape one or more body parts. 
You can find more information about creating morphs in 
“Creating Morphs with the Morphing Tool” on page 642 
and “Creating Morphs in Other Applications” on page 
660.

• You can use the Grouping tool (see “The Group Editor” 
on page 681 to create cloth, hair, or other groups. You 
can also deform polygon groups as mentioned in “Using 
Deformers with Grouped Objects” on page 642. The 
Grouping tool is located in the Editing tools display.

• The Scale and Taper tools (see “Scale” on page 187 and 
“Taper” on page 188, respectively) can change a body or 
element’s shape. The Scale and Taper tools are located in 
the Editing tools display.

• Deformers (magnets, force fields, and waves) can also alter 
shapes.

• You can replace body parts with props (see “Replacing a 
Body Part with a Prop” on page 228).

• You can save your work to the Library palette.
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• You can modify entire figures or individual body parts. For 
example, enlarging the abdomen can create a beer belly. 
Widening the head broadens the face. Shaping figures is 
easiest when the figure is in its default pose where you can 
clearly see the results of each of your actions.

• You may want to hide the other figures and props in your 
scene for an uncluttered view.

• As you finish shaping and posing each body part, you 
can lock it as described in “Lock Object” on page 211. 
And, once you’ve posed your figure, you can guard against 
accidental changes by locking the entire figure as described 
in “Lock Figure” on page 215.

• Symmetry can be a huge time saver, allowing you to pose 
half your figure and apply the pose to the other side. Please 
refer to “Symmetry” on page 216 for information about 
using Symmetry. Also, try using cutting and pasting to apply 
poses across multiple figures.

• If your computer can support it, we recommend enabling 
Full Tracking mode (see “Tracking Mode” on page 93) 
so you can view your work in real time. This does require 
extra computing resources, which can affect performance 
depending on your computer’s specifications and the 
complexity of your scene.

Using Deformers
Poser’s deformers (magnets, force fields, waves, morphs) shape 
body parts, props, and figures into new and interesting forms. 
You can stretch a nose, make a belly bounce with a walk, make 
hair and clothing blow in the wind, and create almost any body 
shape you can imagine. You can animate deformer settings and 
positions, allowing you to create (for example) gusting winds 
(force field), bulging muscles (morph targets), etc. The Wave, 
Force Field, and Magnet deformers can also create custom 
morph targets.

Deformers can be linked to joint rotations or 
other parameters using the Dependent 

Parameters Editor. Refer to “Using Dependent 
Parameters” on page 666 for more information..

Magnets

Magnets distort objects by stretching them. You can use the 
Rotate, Twist, Translate, and Scale tools on magnets. Please 
see “The Editing Tools” on page 184 for information on using 
the Editing tools. Here’s an example of a sphere deformed by a 
magnet:
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 When the magnet is translated and scaled, the head is reshaped 
accordingly.

Creating Magnet Deformers
To create a magnet, select the object you wish to deform then 
select Object > Create Magnet. This creates three Magnet 
objects, which together comprise the deformer.

 Parts of a magnet.

The three parts are:

• Magnet Object: The Magnet Object defines the behavior of 
the actual magnet.

• Magnet Base: The Magnet Base defines the zero point of 
the area to be deformed. Moving the Magnet Base moves the 
Magnet Object as well.
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• Magnet Zone: The Magnet Zone defines the area being 
deformed. You can move and shape the Magnet Zone to suit 
your needs.

Magnets work by deforming the area within the Magnet Zone 
along the axis defined by the Magnet Base and Magnet Object 
in an amount dependent on the distance between the Magnet 
Object and the Magnet Base.

Using Editing Tools with Magnet Objects

To use Editing tools on a Magnet Object, select the magnet in 
the Current Actor pull-down menu, then select your desired 
Editing tool.

• Rotate: The Rotate tool rotates the Magnet Object around 
its three axes.

• Twist: The Twist tool rotates the Magnet Object along its 
own axis.

• Translate/Pull: The Translate/Pull tool moves the Magnet 
Object horizontally or vertically.

• Translate In/Out: The Translate In/Out tool moves the 
Magnet Object in or out from the center of the Poser 
workspace.

• Scale: The Scale tool increases or decreases the size of the 
Magnet Object.

Magnet Deformer Properties

Magnet Objects, Magnet Bases, and Magnet Zones have 
properties that you can edit using the Properties palette.

Magnet Object Properties

Magnet Objects have the following properties:

 Magnet properties.

• Name: The Name property allows you to rename the 
Magnet Object by entering your desired name in this field.

• Visible: The Visible checkbox toggles visibility on and off. 
Checking the box makes the object visible, and vice versa. 
Invisible objects are not included in any render calculations, 
and do not appear in the rendered scene. See “Figure 
Properties” on page 193 for information on animating the 
Visible property.
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• Add element to deform: Checking the Add element to 
deform button opens a hierarchy list, allowing you to select 
added elements to be deformed by the Magnet. This only 
works if the selected element(s) are within the Magnet Zone.

Magnet Object Parameters

Magnet Objects have the following parameter dials in the 
Parameters palette:

 Magnet parameters.

• Scale: The Scale parameter dial increases or decreases the 
size of the Magnet Object in all axes.

• XYZScale: The xScale, yScale, and zScale parameter dials 
increase or decrease the size of the Magnet Object in the 
selected axis.

• XYZRotate: The xRotate, yRotate, and zRotate parameter 
dials rotate the Magnet Object around the selected axis.

• XYZTran: The xTran, yTran, and zTran parameter dials 
move the Magnet Object along the selected axis.

Magnet Base Properties

Magnet Bases have the following properties:

 Magnet Base properties.
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• Name: The Name property allows you to rename the 
Magnet Base by entering your desired name in this field.

• Visible: The Visible checkbox toggles visibility on and off. 
Checking the box makes the object visible, and vice versa. 
Invisible objects are not included in any render calculations, 
and do not appear in the rendered scene. See “Figure 
Properties” on page 193 for information on animating the 
Visible property.

• Display Origin: The Display Origin checkbox displays the 
Magnet Base’s axes. This is useful because translations, 
rotations, etc. occur based on the Magnet Base’s axes, not 
the Poser workspace’s. See the “Chapter 31: Figure and 
Prop Editors” on page 681 for a discussion about local vs. 
global coordinates.

• Casts Shadows: Checking the Casts Shadows checkbox 
forces the selected body part to cast a shadow, which will be 
visible in your scene. Clearing this box means the selected 
body part casts no shadow.

• Set Parent: Clicking the Set Parent button allows you to 
make the Magnet Base a child of another element in your 
scene. Please refer to “Poser File Types” on page 848 for a 
description of hierarchical relationships and to “Changing a 
Parent” on page 231 for information on setting parents.

• Load Morph Target: Clicking the Load Morph Target 
button displays the Load Morph Target dialog, allowing 
you to load a custom morph target for the selected force 
field (which is then editable using the Morphing Tool as 
described in “Creating Morphs with the Morphing Tool” on 
page 642).

Magnet Zone Properties

Magnet Zones have the following properties:

Setting the Magnet Zone’s display style to 
Wireframe can help make it more visible in your 

Document window.
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 Magnet Zone properties.

• Name: The Name property allows you to rename the 
Magnet Zone by entering your desired name in this field.

• Visible: The Visibility checkbox toggles visibility on and off. 
Checking the box makes the object visible, and vice versa.

• Group: Checking the Group checkbox enables grouping, 
allowing you to deform a grouped portion of the selected 
element(s). You can create groups to deform, and groups 
can consist of portions of one or more body parts, props, 
etc. Please see “The Group Editor” on page 681 for 

information on using the Grouping tool. A group is selected 
when a checkbox appears next to the group listing.

• Set Parent: Clicking the Set Parent button allows you to 
make the Magnet Zone a child of another element in your 
scene. Please refer to “Poser File Types” on page 848 for a 
description of hierarchical relationships and to “Changing a 
Parent” on page 231 for information on setting parents.

• Edit Falloff Graph: Clicking the Edit Falloff Graph button 
allows you to edit the Magnet Zone’s Falloff graph, which 
determines where the deforming area ends or falls off. 
Please see “Magnet Zone Falloff Graph” on page 620 for 
information on using this graph.

• Use Weight Map: Check this option to use a weight map to 
control the amount that the vertices are affected. Click the 
Paintbrush icon to open the Vertex Weights palette so that 
you can edit the magnet zone weight map. Vertices in the 
weight map are initially set to 100% strength. The controls 
in the Vertex Weights palette are described in “Painting 
Vertex Weights” on page 583.

Magnet Zone Falloff Graph

Selecting Edit Falloff Graph in the Magnet Zone Properties 
palette opens the Magnet Zone Falloff window.
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The left side of this graph depicts the center of the Magnet Zone, 
and the right side is its edge. By default, a smooth curve appears, 
meaning that the magnet’s influence gradually tapers off towards 
the edges of its zone. By adjusting this curve, you can alter the 
falloff properties.

 The effects of a magnet zone can be shaped with a graph.

To move control points click and drag them up and down. 
Raising a control point increases the magnet zone’s influence 
at the location. To add control points, click any spot along the 
curve. You cannot remove added control points.

 A reshaped graph for the magnet zone.

Locking Magnets

You can lock magnets to prevent accidental changes. Please refer 
to “Lock Object” on page 211.

Using Magnets with Weight Maps
Poser Pro 2014 provides features that allow you to paint weight 
maps on magnets. This feature allows users of Poser Pro 2014 to 
define the areas that the magnet will affect with greater precision 
and flexibility than that offered with the graph editor.
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Magnets are hidden by default in the Rex and 
Roxie CR2’s.

Weight mapped magnets can be used to improve bending when 
a joint, such as a shoulder, is raised or lowered. The falloff 
zone for the magnet can affect as few or as many vertices in the 
geometry as you choose, and you can control the strength at 
which the vertices are affected. This approach gives you more 
precise and specific results over using the graph editor that is 
discussed in “Magnet Zone Falloff Graph” on page 620.

The following figures demonstrate how a weight-mapped 
magnet works. In this example, a magnet has been added to 
Rex’s right shoulder to control the shape of the shoulder when it 
is rotated upward.

 Magnet added to right shoulder.

After adding the magnet, the magnet zone is set up to use weight 
maps. The Poser Pro 2014 weight painting tools are used to paint 
specific vertices that the magnet will affect, and the strength at 
which they will be affected. The following figure, showing the 
body part in Hidden Line display mode, shows an example of the 
vertices that are painted on the upper and lower sections of the 
shoulder.
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 Weight map for the magnet.

If the joint is rotated while painting the weight map, it helps 
the designer determine how the changes affect the body part as 
the joint is exercised. The following figure shows the shoulder 
rotated to the same angle as the previous Hidden Line view.

 Effect of magnet when shoulder is rotated upward.

Adding Weight Maps to Magnets

Select the right collar, and choose Object > Create Magnet.



Poser Pro 2014
Reference Manual 

624

Chapter 30: Modifying Figures & Props

 Create a magnet for the right collar.

Choose the magnet base and move it into position.

 Scale and move the magnet base into position beneath the breast.
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 Scale the magnet zone up and move it into position.

Select the magnet, and switch to the Properties Palette. Click the 
Add Element to Deform button, and then add the Chest as an 
element to deform.

 Select the magnet and add the Chest as an additional element to 
deform.
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If you later need to exclude groups that you have 
added to a magnet, elect the magnet zone and 

switch to the Properties tab. The Group option allows 
you to check groups that will be affected by the magnet 
zone. Any unchecked group will not be affected. Choose 
a group once to place a checkmark, and a second time to 
remove an existing checkmark. For more information 
about magnet zone properties, see “Magnet Zone 
Properties” on page 619.

Next, select the magnet zone and check the Use Weight Map 
option in the Properties palette. Then click the Paintbrush icon 
to open the weight painting palette. Initially, all of the vertices on 
the right collar and the chest will display in green, indicating that 
the weight map values are all at full strength.

 Enable the weight painting options for the magnet zone.

Use the Subtract brush to paint out the areas that you don’t want 
the magnet to affect. This allows you to define the affected area 
with great precision. It is helpful to view the figure in Hidden 
Line display mode while you paint the vertices. Also be sure to 
move the magnet across the range of motion that you want the 
magnet to affect. In other words, if you want the magnet to raise 
the breast, translate the magnet on the Y axis. You may find 
that some areas will need to be smoothed to create a nice blend 
between the affected and unaffected vertices.
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 Paint and smooth the weight map to affect the areas that you want 
the magnet to affect.

 The breast adjusted with the weight-mapped magnet.

Now select the left collar, and create a new magnet. Position and 
scale the magnet base and magnet zone using the same values 
as the right breast (except for the X translations, which should 
be negative values on the right breast and positive values on the 
left breast).
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 Create a magnet for the left collar, scaling and positioning them the 
same as the right collar (except X translation settings are positive).

Select the new magnet and add the Chest as an element to 
deform, just as you did for the right collar magnet.

Now select the magnet zone for the right collar (the first one you 
created). In the Properties palette, click the Paintbrush icon to 
open the Vertex Weights palette. Click the Copy/Paste button at 
the bottom of the palette, and choose Copy to copy the weight 
map into your clipboard.

 Copy the weight map from the right collar into your clipboard.

Use the Select Actor menu in the Properties Palette to select 
Magnet Zone 2 (the zone for the left collar).
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 Select the second magnet zone from the Properties tab menu.

Click to activate the paintbrush for Magnet Zone 2, and then 
click the Copy/Paste button again. This time, choose Paste 
Mirrored > X Axis to mirror the weight map from the right 
breast over to the left breast.

 Paste the weight map in the clipboard, mirrored on the X axis.
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 The final result.

Animating Magnet Zones

Select the right forearm and create a magnet using the Object > 
Create Magnet command.

 Create a magnet on the right forearm.

Select the magnet base, and then scale and position the magnet 
over the right forearm. Then scale and position the magnet zone 
to surround an area along the top of the forearm.
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 Scale and position the magnet base and magnet zone.

Select the magnet, and raise it along the Y axis to create a bump 
in the forearm.

 Scale and position the magnet base and magnet zone.

With the magnet selected, switch to the Properties palette. Click 
the Add Element to Deform button for each body part that you 
want the magnet to affect. Repeat this step to assign the Right 
Hand, Right Shoulder, Right Collar, and Chest.
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 For the magnet, add (one at a time) the Right Hand, Right 
Shoulder, Right Collar, and Chest as elements to deform.

Go to the first frame in your project. Select the magnet zone, and 
move it into position over the right hand. Then go to frame 30 
(or the last frame in your animation), and move the magnet zone 
over the shoulder.

 Position the magnet zone on the first and last frames of your 
animation.

As the animated joint zone passes over the affected body parts, 
you’ll see the bump affecting the actors that you assigned as 
affected actors. The bump will affect the hand, then the forearm, 
the shoulder, the right collar, and the chest over the course of the 
animation.
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Wind Force Fields

Selecting Object > Create Wind Force creates a wind force field 
that ads realistic wind to your scenes. Force fields affect strand-
based hair and dynamic cloth.

 A Wind Force Field.

You can position force fields using the Editing tools just as you 
would any other prop.

Force Field Properties

Force fields have the following properties, available in the 
Properties palette:

 Forcefield Properties.
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• Internal Name: The Internal Name field displays the force 
field’s internal (hidden) name, which Poser uses to track 
that part. You cannot edit a force field’s internal name 
within Poser.

• Name: The Name field displays the force field name. Enter 
a new name in this field if you desire.

• Visible: Checking the Visible checkbox makes the force 
field visible and vice versa. Invisible objects are not included 
in any render calculations, and do not appear in the 
rendered scene. See “Figure Properties” on page 193 for 
information on animating the Visible property.

• Visible in Raytracing: Checking the Visible in Raytracing 
checkbox makes the force field visible in raytraced 
reflections, such as if the figure is in front of a mirror. 
Clearing this checkbox makes the force field not appear in 
reflections.

• Casts Shadows: Checking the Casts Shadows checkbox 
forces the selected force field to cast a shadow, which will be 
visible in your scene. Clearing this box means the selected 
force field casts no shadow.

• Display Origin: Checking the Display Origin checkbox 
display’s the force field’s origin. Please refer to “The Prop 
Origin” on page 225 for more information about force 
field origins.

• Light Emitter: When checked, allows the object to be 
included in indirect lighting calculations so that light will 
bounce off the object. When unchecked, indirect lighting 
calculations are skipped for the object. This allows you to 
create objects such as illuminated light domes, which can 
have high ambient values that will cast light, but that can 
also be turned off and not rendered.

• Visible in Camera: When checked, the object is visible 
in the camera and render. When unchecked, the object 
does not render. Used in conjunction with Light Emitter, 
described previously, to create light-casting objects.

• Collision detection: Checking the Collision Detection 
checkbox enables collision detection for the currently 
selected force field. Please refer to “Collisions” on page 
75 for more information about collision detection.

• Apply Collision Setting to Children: Clicking the Apply 
Collision Setting to Children button applies the currently 
selected force field’s collision detection setting to that part’s 
children parts (if any).

• Load Morph Target: Clicking the Load Morph Target 
button displays the Load Morph Target dialog, allowing 
you to load a custom morph target for the selected force 
field, which is then editable using the Morphing Tool. 
Please refer to “Creating Morphs with the Morphing Tool” 
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on page 642 for more information about loading morph 
targets.

• Set Parent: Clicking the Set Parent button allows you 
to make the force field a child of another element in your 
scene. Please refer to “Poser File Types” on page 848 for a 
description of hierarchical relationships and to “Changing a 
Parent” on page 231 for information on setting force field 
parents.

• Displacement Bounds: The Displacement Bounds 
property determines the force field’s displacement 
boundary. Please refer to “Chapter 19: Using The FireFly 
Render Engine” on page 404 for more information about 
displacement bounds.

• Shading Rate: The Shading Rate allows you to specify the 
desired shading rate for the currently selected force field. 
Please refer to “Chapter 19: Using The FireFly Render 
Engine” on page 404 for more information about shading 
rates.

Force Field Parameters

Force fields have the following parameters, available in the 
Parameters palette:

 Forcefield Parameters.

• Scale: Increases or decreases the size of the force field in 
all axes.
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• XYZScale: The xScale, yScale, and zScale parameter dials 
increase or decrease the size of the force field in the selected 
axis. This is only available for the force field.

• XYZRotate: The xRotate, yRotate, and zRotate parameter 
dials rotate the force field around the selected axis.

• XYZTran: The xTran, yTran, and zTran parameter dials 
move the force field along the selected axis.

• Amplitude: The Amplitude parameter controls the strength 
of the force field. Increasing this value increases the wind 
speed, and vice versa.

• Spread Angle: The Spread Angle parameter specifies the 
force field’s angle of effecting degrees.

• Range: The Range parameter specifies the force field’s 
range of effect in the currently selected units (feet, 
millimeters, etc.).

• Turbulence: The Turbulence parameter controls the 
amount of irregularity in the force field’s wind stream and 
can be used to simulate gusts.

Wave Deformers

Wave deformers distort objects by creating wave paths. You 
can use the Rotate, Twist, Translate, and Scale tools on wave 
deformers. Please see “The Editing Tools” on page 184 for 
information on using the Editing tools. Here’s an example of a 
sphere deformed by a wave.

 A wave deformer applied to a forearm.

Creating Wave Deformers

To create a wave, select the object you wish to deform then select 
Object > Create Wave. This creates two Wave objects, which 
together comprise the deformer. The two parts are:
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 Parts of a Wave deformer.

• Wave Object: The Wave Object defines the behavior of the 
actual wave.

• Wave Zone: The Wave Zone defines the area being 
deformed. You can move and shape the Wave Zone to suit 
your needs.

Using Editing Tools with Wave Deformers

To use Editing tools on a Wave Object, select the wave in 
the Current Actor pull-down menu, then select your desired 
Editing tool.

• Rotate: The Rotate tool rotates the Wave Object/Zone 
around its three axes.

• Twist: The Twist tool rotates the Wave Object/Zone along 
its own axis.

• Translate/Pull: The Translate/Pull tool moves the Wave 
Object/Zone horizontally or vertically. This does not affect 
the Radial wave.

• Translate In/Out: The Translate In/Out tool moves the 
Wave Object/Zone in or out from the center of the Poser 
workspace.

• Scale: The Scale tool increases or decreases the size of the 
Wave Object.

Wave Object Properties

Wave Objects and Zones have properties that you 
can edit using the Properties palette.

Wave Objects have the following properties:
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 Wave Deformer properties.

• Name: The Name field allows you to rename the Wave 
Object by entering your desired name in this field.

• Visible: The Visible checkbox toggles visibility on and off. 
Checking the box makes the object visible, and vice versa. 
Invisible objects are not included in any render calculations, 
and do not appear in the rendered scene. See “Figure 
Properties” on page 193 for information on animating the 
Visible property.

• Radial Wave: Checking the Radial Wave radio button 
causes the wave to spread from its origin like ripples in a 
pond.

• Directional Wave: Checking the Directional Wave radio 
button causes the wave to spread in a linear fashion. The 
following two properties control the direction.

• Deformer Aligned: Checking the Deformer Aligned radio 
button cause waves to propagate along the direction of the 
Wave Object.

• Object Normals: Checking the Object Normals radio 
button cause waves to propagate along the affected object’s 
normals.

• Add element to deform: Clicking the Add element to 
deform button opens a hierarchy list, allowing you to select 
added elements to be deformed by the wave. This only 
works if the selected element(s) are within the Wave Zone.

Wave Zone Properties

Wave Zones have the following properties:
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 Wave Zone properties.

• Name: The Name field allows you to rename the Wave Zone 
by entering your desired name in this field.

• Visible: The Visible checkbox toggles visibility on and off. 
Checking the box makes the object visible, and vice versa. 
Invisible objects are not included in any render calculations, 
and do not appear in the rendered scene. See “Figure 
Properties” on page 193 for information on animating the 
Visible property.

• Group: Clicking the Group button allows you to deform a 
grouped portion of the selected element(s). You can create 
groups to deform, and groups can consist of portions 
of one or more body parts, props, etc. Please see “The 

Group Editor” on page 681 for information on using the 
Grouping tool. A group is selected when a checkbox appears 
next to the group listing.

• Set Parent: Checking the Set Parent button allows you 
to set a parent object for the Wave Zone. Please refer to 
“Changing a Parent” on page 231 for information about 
parenting objects.

• Edit Falloff Graph: Clicking the Edit Falloff Graph button 
allows you to edit the Wave Zone’s Falloff Graph, which 
determines where the deforming area ends or falls off. 
Please see the following topic for information on using this 
graph.

Setting the Wave Zone’s Display Style to 
Wireframe can help make it more visible in your 

Document Window.

• Use Weight Map: Check this option to use a weight map 
to control the amount that the vertices are affected. Click 
the Paintbrush icon to open the Vertex Weights palette so 
that you can edit the wave zone weight map. Vertices in the 
weight map are initially set to 100% strength. The controls 
in the Vertex Weights palette are described in “Painting 
Vertex Weights” on page 583.
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• Wave Zone Falloff Graph: Clicking the Edit Falloff Graph 
button in the Wave Zone Properties opens the Wave Zone 
Falloff window, which appears and functions in the same 
manner as the Magnet Falloff Graph depicted in “Magnet 
Zone Falloff Graph” on page 620.

 Wave Zone falloff graph.

Wave Deformer Parameters

Wave deformers can use the following parameter dials in the 
Parameters palette:

 Wave Deformer parameters.
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First, there are certain parameter dials that are only available for 
waves:

• Phase: The Phase parameter dial defines the position 
of the wave in infinite time. Use this parameter when 
animating waves.

• Amplitude: The Amplitude parameter dial defines the 
wave’s height.

• Wavelength: The Wavelength parameter dial defines the 
distance between wave crests (frequency).

• Stretch: The Stretch parameter dial controls the sharpness 
of each wave.

• Amp Noise: The Amp Noise parameter dial defines the 
randomness or noise of the wave’s amplitude.

• Freq Noise: The Freq Noise parameter dial defines the 
randomness or noise of the wave pattern’s frequency.

• Sinusoidal: The Sinusoidal parameter dial defines the size 
of the sine wave pattern.

• Square: The Square parameter dial defines the shape of the 
wave pattern. Increasing this value creates square-shaped 
waves.

• Triangular: The Triangular parameter dial defines the 
shape of the wave pattern. Increasing this value creates 
triangle-shaped waves.

• Turbulence: The Turbulence parameter dial defines the 
roughness of a wave pattern. Increasing this value creates 
jagged, turbulent waves, and vice versa.

• Offset: The Offset parameter dial defines if the wave’s 
pattern is above, on, or below the wave’s origin. Increasing 
this value brings the wave pattern above the origin. This 
is helpful if, for example, you want to keep clothing from 
deforming the underlying figure.

The following common parameters also apply to Wave objects:

• Scale: Increases or decreases the size of the Wave Object in 
all axes.

• XYZScale: The xScale, yScale, and zScale parameter 
dials increase or decrease the size of the Wave Zone in the 
selected axis. This is only available for the Wave Zone.

• XYZRotate: The xRotate, yRotate, and zRotate parameter 
dials rotate the Wave Object around the selected axis.

• XYZTran: The xTran, yTran, and zTran parameter dials 
move the Wave Object along the selected axis.
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Using Deformers with Grouped 
Objects
You can create custom groups using the Group Editor palette 
as described in “The Group Editor” on page 681 and apply 
deformers to these groups. Groups can contain parts of one or 
more body parts/props. You can select these groups by name 
using the Properties palette for selected magnets or waves. To 
apply a deformer to a group:

Select the body part/prop containing the group.

1. Create the deformer as described above.

2. Select the deformer’s Zone and access that zone’s properties 
as described above. Check the Group checkbox, then select 
one or more groups from the pop-up that appears. A group 
is selected when a checkbox appears next to it.

This procedure deforms on the grouped sections of body parts/
props.

Creating Morphs with the Morphing 
Tool
Morph targets are custom parameters added to body parts 
or props that allow you to reshape the affected part(s). Poser 

includes some built-in morph targets with the stock figures, and 
you can create your own. Morph targets allow you to easily resize 
and reshape items and are fully animatable.

 Faces reshaped with the Morphing Tool.

While morph targets appear as parameter dials in the 
Parameters palette, they are actually custom geometry 
containing the deformation, which you then apply using 
parameter dials. Does this seem confusing? It’s actually pretty 
simple once you get the hang of it. Let’s explore this functionality 
a little further.

You can create your own morph targets using Poser and/or 
another application. This manual primarily covers creating 
morph targets in Poser, but we will discuss using third-
party applications in general terms. Within Poser, you use a 
combination of deformers and existing morph channels (such 
as the Surprised parameter) to create morph targets. Each 
morph target gets its own Parameter dial whenever the affected 
element(s) are selected and the morph target is loaded. For 
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example, if you create a morph called Bulging Bicep for the 
upper arm, you’ll see the Bulging Bicep parameter dial in the 
Parameters palette when you’ve loaded the morph target and 
selected the upper arm.

Clicking on the Morphing Tool in the Editing Tools display 
opens the Morph Editor palette. The Morphing Tool has two 
operational modes: Combine and Create, which are covered 
in the sections that follow. Click on the appropriate tab in the 
Morph Editor to switch between these two modes.

 The Morphing Tool in the Editing Tools palette.

The Combine Tab
The Combine tab on the Morph Editor allows you to visually 
sculpt your figures’ morph targets by clicking on a body part 
such as the head, then dragging the mouse to change the shape 

of that body part. The changes that you see are all based on the 
morphs that are already present in the body part. You can do this 
with any scene object that has morph targets.
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 The Morphing Tool Combine tab.

To use the Combine tab:

1. Select the body part you wish to sculpt, then select the 
Morphing Tool. The Morph Editor palette appears. The 
Combine tab displays all of the morph targets available for 
the selected body part:

2. The list of morph targets is hierarchical and displays 
branches containing the available morph targets. Clicking 
the – icon next to an expanded branch collapses that branch, 
and clicking the + icon next to a collapsed branch expands 
that branch. You can also use the scroll bars to navigate 
the list. The Morph Editor will allow you to manipulate all 
selected morph targets. A green dot next to a morph target 
includes the specified morph target when using the tool, 
and a Lock icon means the specified morph target will not 
be affected by the tool. Even if a morph target is enabled, 
it may or may not be affected by your use of the tool. For 
example, selecting a vertex in the forehead may affect the 
eyebrows but will not affect the mouth. Select your desired 
morph target(s), then click and drag any vertex on the 
selected body part.
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 A face before and after using the Morphing Tool.

3. Once you have a portion of the body part the way you want 
it, you can click the Pin button then click one or more 
vertices to pin them, preventing further manipulation as you 
work on other areas of the object. Pinned vertices appear as 
red dots on the current object and may move as you keep 
adjusting other portions of the body part (depending on 
how many morph targets affect the pinned vertex), however 
they will retain their current settings. Also, pins are retained 
if you stop using the Morphing Tool and resume using it 
later. To stop pinning vertices, click the Morphing button 
(see below). You may notice some trembling if you adjust 
morphs that affect pinned vertices.

The Morph Editor palette has the following functions:

 Elements found in the Morphing Tool Combine tab.
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• Morphing: Clicking the Morphing button re-enables the 
Morphing Tool. Click this button after pinning vertices to 
resume adjusting morphs.

• Pin: Clicking the Pin button disables the Morphing Tool 
and allows you to pin one or more vertices as discussed 
above.

• Clear Morphs: Clicking the Clear Morphs button resets all 
morphs. Use this option with care as it will undo all of your 
changes, even if you exit and resume using the Morphing 
Tool.

• Clear Pins: Clicking the Clear Pins button removes all pins 
previously applied to the current object.

• Exaggeration min/max: Exaggeration refers to the degree 
to which a morph target’s value will affect the vertices. 
The Exaggeration Min and Exaggeration Max values 
limit the extent of a morph target’s possible effect when 
the Morphing Tool is operating. No morph target can be 
modified beyond these limits (see “Editing Parameter 
Dials” on page 201 for more information about parameter 
dial limits). Increasing these limits therefore increases the 
exaggeration effects of all morph targets. For a technical 
description of Exaggeration Min/Max, see the following 
note.

Mathematically, each morph target defines a 
displacement vector (v) on each object vertex, 

and its exaggeration value defines a multiplier (w). 
Thus, a morph target’s net effect is p + wv, where p is 
the original vertex position. If w=1, we add v+p. W can 
be any value. The larger w is, the more exaggeration 
this morph target’s effect has. The Exaggeration Min 
and Exaggeration Max values globally define the limits 
for w across all morph target weights when the 
Morphing Tool operates.

• Lock All: Clicking the Lock All button locks all morph 
targets, which disables morph-based shape changes. This 
is handy when you’re satisfied with your overall shape and 
only want to fine-tune a few specific morphs. In that case, 
you could use this option then unlock only those morphs 
you want to adjust.

• Unlock All: Clicking the Unlock All button unlocks all 
morph targets, allowing you to modify them.

To move in the Z axis, press and hold 
[COMMAND]/[CTRL] while dragging.
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The Create Tab.
The Create tab of the Morph Editor allows you to select and 
modify the mesh vertices to create new morph targets on a single 
body part or across joint seams to adjacent body parts. As with 
the Combine tab, you can apply the Create tab functionality to 
any scene object that has a mesh.

Deformations made to the mesh while using the Create tab can 
apply to the currently selected actor or to the entire figure. A 
parameter dial will appear only on body parts that are affected 
by the morph brush.

In addition to creating morph targets for individual 
actors, Poser also allows you to create Full-Body Morphs 

(FBMs). For more information about Full-Body Morphs, see 
“Creating Full-Body Morphs” on page 662.

 Morphing Tool Create Tab.
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To use the Create tab:

1. Switch to the Create tab in the Morphing Tool if necessary.

2. To create a custom morph, click the Custom_Morph text at 
the top of the Morphing Tool palette to display the menu.

3. To create a new morph, select New. You will be prompted to 
assign a name for the new morph.

 Choose New from the Custom Morph menu to create a new original 
morph.

If you do not assign a name or choose an existing 
morph before you begin painting, any changes 

that you make will be assigned the generic morph name 
of Custom Morph. You will need to use the Save a Copy 
As button at the bottom of the Morphing Tool to save the 
morph under a new name.

 � To work on an existing morph, expand the Body Parts 
submenu to choose one of the body parts that uses that 
morph (such as Waist), the morph category (such as 
Morph or JCM), and then select the morph that you 
want to edit (such as Pregnant).

 To modify an existing morph, expand the Body Parts menu to select 
the morph you want to modify.



Poser Pro 2014
Reference Manual

649

Chapter 30: Modifying Figures & Props

4. After you name your new morph or select an existing 
morph, the name of the morph will appear at the top of the 
Create tab. Set the value of the morph to 1 to begin editing.

 Set the value of the morph to 1 while you are editing.

5. Click the icon for the action you wish to use to modify the 
vertices: Push, Pull, Flatten, Smooth or Restore. You can 
also choose one of the modes from the Action menu that 
appears just above the icons.

 Vertex modification options in the Create tab.

 � Push: Selecting Push will enable you to push the 
vertices in the impact region inward from the original 
surface of the mesh, to create a concavity such as a 
dimple or a dent.

 � Pull: Selecting Pull will enable you to pull the vertices 
in the impact region outward from the original surface 
of the mesh. This task is very useful for cleaning up 
any inappropriate intersections between the figure and 
either conforming or dynamic clothing; you can select a 
region of the cloth, and simply pull it out past the point 
of intersection with the figure.
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 � Flatten: Takes all of the affected points and averages 
the plane that best fits through all those points. It then 
pushes all of the points to match that plane.

 � The following image shows an irregularly shaped object 
in three stages: The top image shows the object before 
it is flattened with the morph tool. The middle image 
shows the object after a couple of areas have been 
flattened with the Morph tool. The brush shape used no 
falloff (the last brush option) and was set to a large size. 
The third image shows the object after changing the 
Morph brush to Smooth, and then passed through the 
rough areas in the center.

  An irregularly shaped object (top); after flattening (middle) and 
then smoothed (bottom)..
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 � Smooth: With the Smooth option you can gradually 
reduce the amount of variation in the surface mesh, to 
create a smoother surface. This is particularly useful for 
surfaces with high frequency variations. Keep in mind 
that this option generally reduces definition.

 � Restore: The Restore option gradually reverts your 
recent changes back towards the original unmorphed 
geometry state. This feature can be extremely useful in 
fine-tuning your modifications, as it allows you to back 
up recent changes by gradual degrees.

Restore is not the same as Undo. If you make a 
change, and then select Edit > Undo, your entire 

change will be erased, and the mesh will revert to the 
state it was in before you made the change. By using 
Restore, you can revert the effects of your change 
gradually, thus allowing you to edit your modification 
without losing it completely.

 � Tighten Fit, Loosen Fit, and Sag: See “Using the 
Fitting Tools” on page 658.

6. Select the mode in which you wish to work: Relative to 
Surface, Screen, or Screen (In/Out).

 � Surface: When in Surface mode, all modifications you 
make to the mesh will be made along the direction of 
the surface normal. This is the default mode, as you are 

likely to want to sculpt in relation to the surface normal 
direction for most purposes.

 � Screen: Screen mode allows you to deform the mesh 
in any direction you wish. This option is useful for 
situations when you may wish to sculpt the mesh in 
a transverse or vertical direction. Please note that 
the direction of the modification in Screen mode is 
determined by the current view of the figure as relative 
to the screen. For example, if you wish to deform the 
mesh towards the camera, you should rotate the figure 
ninety degrees, then make your modification by moving 
your mouse to the side.

 � Screen (In/Out): Deforms the mesh relative to the 
screen, moving the vertices toward or away from you.

7. Select your desired brush style from the five circular brush 
style icons. Poser’s morph target creation feature uses 
a brush paradigm, which allows for varying degrees of 
precision when applying your modifications to the mesh. 
The left most brush style impacts only the closest single 
vertex to your mouse pointer, thus allowing for a great deal 
of precise control. The remaining brush styles all affect a 
region of the mesh. These regional brush styles have varying 
degrees of falloff; the modification will affect vertices within 
the impacted region to differing degrees, as determined by 
the falloff. For example, the second brush style from the left 
has a large falloff region, which means that while vertices 
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at the center of the region will be strongly impacted by your 
modifications, the impact will decrease gradually over most 
of the other vertices within the impact region. The falloff 
area decreases with the next two brush styles, and the right-
most brush style has zero falloff, so that all vertices within 
the region are impacted equally.

 Adjusting the size of the Morph Brush.

Enabling the Display Brush option in the lower 
portion of the Create tab will display a visual 

preview of the impact region. This preview is color 
coded to show the falloff effect: red indicates the area 
most strongly affected, yellow indicates less effect, and 
areas shown in green are the least affected within the 
impact region.

8. Adjust the Radius dial to increase or decrease the size of 
the impact region. If you have enabled the Display Brush 
option, the visual preview will adjust automatically to 
indicate the current impact region radius.

You can also use the Left or Right arrow keys to 
adjust the radius of the brush.

9. You may want to adjust the Magnitude dial to specify how 
much effect the Morphing Tool will have within the impact 
region. A high Magnitude setting will allow you to make 
large-scale dramatic changes, for faster workflow. A low 
Magnitude setting will allow you to make more precise, 
focused changes.

You can also use the Up or Down arrow keys to 
adjust the magnitude of the brush.
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 Radius and Magnitude settings control the size and strength of the 
Morph Brush.

We recommend that you start with a relatively 
low Magnitude setting to allow you to become 

accustomed to the Morphing Tool, and then gradually 
increase the Magnitude as needed.

10. By default, the Morphing Tool allows you to morph across 
multiple body parts. If you want to make changes to a single 
body part, check the Group option (shown in the following 
figure) and select a group from the popup menu.

 You can limit changes to one body part in the Morphing Tool.

The Group option allows you to specify which specific 
polygons the Morphing Tool will affect. When you 
enable the Group option, the Group pop-up menu will 
display a list of all polygon groups that exist for the 
currently selected actor. You can select a group from 
this list to limit the effect of the Morphing Tool to 
polygons contained in that group. You can also create 
a group for your specific purposes using the Group 
Editor (see “Chapter 30: Modifying Figures & Props” 
on page 614 for more information about the Group 
Editor).
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11. Enable or disable the following options to suit your 
requirements:

 � Average normals: Maintains more detail of the 
underlying surface when Relative to Surface is 
selected. It averages the normals of all the effected 
vertices, instead of moving each affected vertex along its 
own normal.

 � Accumulate: When Accumulate is enabled (checked), 
your change will continue to accumulate so long as 
you continue a single click-and-drag movement. This 
option allows you to make a greater degree of change 
with a single motion, but with less precision. When 
the Accumulate option is disabled (unchecked), 
each modification requires a separate click-and-drag 
operation. Use this setting for greater control over your 
modifications.

 � Stroke: When the Stroke option is enabled (checked), 
the Morphing Tool will implement your modifications 
along the trajectory of your mouse movement. This 
allows you to “paint” deformations onto the surface 
of the mesh as you move your mouse across it. When 
Stroke is disabled, your mouse movements will adjust 
the degree of the deformation, while the effect of the 
modification applies to the original impact region only.

12. Once you have configured the Morphing Tool to your 
specific needs via the Create tab, click and drag directly on 
the current actor to deform the mesh.

13. When you have completed your modifications, click the 
Save Copy As button to propagate your work to a new 
morph target.

14. The Create tab also contains the following Display options:

 Display options in the Create tab.

 � Display Mesh: The Display Mesh option will 
superimpose a visualization of the mesh over whatever 
display style you have currently selected. (See “Chapter 
6: The Display Controls and Menu” on page 105 
for more information on the various display styles.) 
This option can be very helpful in that it allows you 
to see how your deformations affect the surrounding 
polygons.

 � Display Brush: The Display Brush option displays 
a visual preview of the region you will be impacting 
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with your deformation. This preview uses different 
colors to indicate the degree to which each area of the 
impact region will be affected by your selected action. 
Specifically, red indicates the area most strongly 
affected, yellow indicates that an area is less strongly 
affected, and green areas are the least affected within 
the impact region. The Display Brush option is 
enabled by default. If you have elected to work on a 
single group rather than the entire figure, the brush will 
display only when it is over the group that is selected 
for editing.

 The Morph Brush appears as multicolored vertices that represent 
strongest and weakest areas.

 � Work With Current Morphs: When enabled, the Work 
With Current Morphs option allows you to visualize 
the current adjusted state of all other morph targets 

while you deform the mesh. This option is useful for 
creating a morph target that acts on top of another 
morph target.

This setting is useful for understanding how your 
new morph target will interact with other 

existing morph targets.

When disabled, the Work With Current Morphs 
option allows you to temporarily hide the effects of all 
other morph targets while working within the Create 
tab. Using this option allows you to work on the mesh 
geometry in its neutral state, without losing the settings 
of your other morph targets. If you leave the Create tab, 
those morph targets will automatically revert to their 
specified states.

You can use the following functions to save or reset your morph 
targets:

 Additional Morphing Tool functions.
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• Mirror: The Mirror button at the bottom of the Create tab 
brings up a pop-up menu offering six options of different 
axes and directions for creating symmetrical changes on 
the currently selected object, for example “-x to x” or “z to 
-z”. Note that these axes refer to the local coordinate system 
of the currently selected object only, and are not related to 
the world space coordinates of your Poser scene. Selecting 
one of these options will mirror morph target changes from 
one half of the currently selected object to another half of 
the same object, as defined by the axis and direction you 
selected from the menu.

If the mesh topology of the actor across which 
you are attempting to mirror is not symmetrical, 

the mirror feature may not be able to successfully 
translate your morph target changes.

• Zero Morph: The Zero Morph button will reset the surface 
mesh to its undeformed state. Zero Morph will also clear 
any morphing tool changes (stored in the Custom Morph 
channel) that will generate at each body part and the 
figure level. If the Zero Morph button has been pushed, the 
channel will still exist but the morph data is removed.

This Custom Morph channel is used as a 
receptacle for morphing edits with the morphing 

tool. Save a Copy As is the best way to preserve that 
Custom Morph data for Full Body or individual body 
part morphs.

The Zero Morph button only applies to the effects 
of your new morph target; all other morph 

target states will remain unchanged. Be sure to save a 
copy of your modifications before clicking the Zero 
Morph button if you do not wish to lose your changes.

• Save a Copy As: Whenever you enter the Create tab, any 
modifications you make will automatically be placed into 
a “Custom Morph” morph target unless you follow steps 
2 and 3 to create a new morph name or select an existing 
morph. The Save a Copy As button will allow you to save 
the current state of the Custom Morph target to a new, 
separate morph target. You can use Save a Copy As to save 
incremental modifications as you work with the mesh, or to 
propagate your final modifications to the figure for future 
use.

• Full Body Morphs created using the Save a Copy As 
and the Custom Morph functions are traditional Delta 
Add morphs with values that change linearly with the 
a master parameter value. You can edit them using the 
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dependent parameters editor, as mentioned in “Using 
Dependent Parameters” on page 666. The Save a Copy 
As morph saves a channel to each body part, and also adds 
a parameter dial to the Body that drives all of the individual 
body part channels.

The Custom Morph target is cumulative, in that 
any modifications you make will be made on top 

of the previous state of the morph target. Therefore, if 
you do not save your changes to a separate morph 
target using the Save a Copy As button, they will 
become incorporated into any figure changes, and you 
may have difficulty recovering that previous state.

Copying Morphs Between Figures
The Figure > Copy Morphs From and Object > Copy Morphs 
From commands allow you to copy morphs between figures and 
clothing. This feature works more accurately with items that are 
sparser in density (such as clothing) than with items that are 
more finely detailed (such as a face to face morph transfer).

To copy all morphs from a character to the clothing:

1. Load the character and the clothing into your scene.

2. Click to select the clothing that will receive the morphs.

3. Choose Figure > Copy Morphs From. The Copy Morphs 
dialog appears.

4. Choose the character from which you want to copy the 
morphs and then click OK to continue.

5. Use the Select Objects dialog to check the morphs that you 
want to copy to the clothing.

6. Click OK to copy the morphs.

Similarly, the Object > Copy Morphs From command allows 
you to copy morphs between objects in several different ways:

Load the source and target objects into your scene (such as a 
character and the clothing).

7. Click to select the object that will receive the morphs (such 
as a body part on the clothing).

8. Choose Object > Copy Morphs From. The Copy Morphs 
dialog appears. It displays options to choose morphs from 
the character, from the clothing, or from a prop:
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 Choosing the morph source.

 � To copy morphs from a body part on the character, 
expand the list that appears to the right of the character 
name, and choose the body part from which you want 
to copy the morphs.

 � To copy morphs from another part on the clothing, 
expand the list that appears to the right of the current 
clothing item. Choose the body part from which you 
want to copy the morphs and then click OK to continue.

 � To copy morphs from a prop (such as a magnet sphere 
or capsule), expand the list that appears to the right of 
the Props list, and select the item that you want to copy 
the morphs from. Then click OK to continue.

Using the Fitting Tools
The Create tab in the Morph Palette includes fitting tools that 
allow you to create fitting morphs for clothing. These tools do 
not take existing grouping into account and work on the entire 
object geometry.

To use the fitting tools in the Morph Palette, follow these basic 
steps:

1. Load the character and the clothing that you want to fit.

1. Translate and scale the clothing as needed to position the 
clothing around the figure as closely as possible.

2. Choose the Tighten Fit or Loosen Fit tool. Either of these 
tools allow you to select the Target figure to use. The Target 
will be the character that you want to fit the clothing to.
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 Choosing a Goal figure.

3. Create a new morph and assign a name to it.

4. Use the fitting tools to adjust the clothing as necessary. 
Adjust Brush Radius and Magnitude to increase or decrease 
the areas and amount of effect.

Tighten Fit

Tighten Fit makes the clothing tighter in the areas that you 
paint, moving it closer toward the shape of the Goal figure. 
Options are as follows:

• Goal: The figure that you’re trying to fit to.

• Attraction Points: The maximum number of closest points 
on the target geometry that are taken into account when 
tightening.

• Pokethrough Resistance: The distance that determines 
how much the clothing resists pushing into the target figure

Loosen Fit

• Loosen Fit: Makes the clothing looser in the areas that 
you paint, moving it away from the shape of the underlying 
figure. Options are as follows:

 � Goal: The figure that you’re trying to fit to.

 � Attraction Points: The maximum number of closest 
points on the target geometry that are taken into 
account when loosening.

Sag

• Sag: Use in cases where you need to add a draping effect, 
such as the underside of an arm. It will affect polygons on 
the lower side of the painted area, but not on the upper side. 
Options are as follows:

 � Gravity: Configurable gravity vector determines the 
direction towards which the clothing will sag
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 � Falloff: Slider determines how quickly vertices whose 
normals are very nearly orthogonal to the gravity vector 
are affected by the sag.

Creating Morphs in Other 
Applications

Creating Custom Morph Targets

You can create morph targets using your favorite 3D modeling 
application so long as that application can import and export 
Wavefront OBJ (*.OBJ) files. To do this:

1. Export the body part for which you wish to create the morph 
target as explained in “Exporting Files” on page 783.

2. Import the body part into your favorite 3D modeling 
application.

3. Edit the geometry, being careful to only move vertices. Do 
not add or remove vertices, or your morph target will not 
work.

4. Export the edited geometry from the 3D modeling 
application in the Wavefront OBJ (*.OBJ) format.

5. Load the morph target.

Adding Custom Morph Targets

Selecting Object > Load Morph Target allows you to load a 
morph target for your currently selected element.

You can add morph targets that you created using a third-party 
application and apply them to your figures and props. You can 
also add third-party morphs obtained from online sources such 
as Poser’s Content room, which links you to several leading 
Poser content marketplaces. Please refer to “Chapter 8: The 
Content Room” on page 173 for more information on Poser’s 
Content room.

To add a custom morph target:

1. Select the body part/prop to which you want to apply the 
morph and open its properties in the Properties palette.

2. Click Load Morph Target to open the Load Morph Target 
dialog.
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 Loading a Morph Target.

3. Enter the complete path and filename to your desired 
morph or use the Locate button to open a standard Browse 
dialog allowing you to locate the correct file. Your selected 
file must be in OBJ format, contain the same number of 
vertices as the original body part/prop, and must only 
contain the body part/prop being morphed.

4. Enter a name for the added file, then click OK to exit back to 
the Parameters palette. A new parameter dial appears with 
the name of the newly added morph.

In order for morph targets to work properly, they must have 
the same vertex order as the geometry mesh to which they are 
applied. Some applications have difficulty preserving the vertex 
order when editing or writing out morph targets. If you find that 
your imported morph targets behave unexpectedly, you may 
wish to check the Attempt Vertex Order Correction checkbox 

when loading them. This checkbox is located on the Load Morph 
Target dialog, which can be accessed by selecting Object > Load 
Morph Target, or clicking the Load Morph Target button on the 
Properties palette. Please note that significant changes to vertex 
order are not possible with automatic correction.

Combining Morphs in Poser
Poser provides a number of different ways that you can combine 
body morphs to create unique characters. For example, you can 
use the Object > Spawn Morph Target command to create a 
parameter dial for body parts and props that have been modified 
with deformers. The Figure > Create Full Body Morph 
command allows you to create a single master dial in the Body to 
drive morphs in several different body parts. Additionally, you 
can use Dependent Parameters to create master parameter dials 
that, in turn, create more realistic interactions between body 
parts and rotations.

Spawning Morph Targets

In addition to the Create tab on the Morph Editor palette, 
you can also create morph targets in Poser directly from the 
Properties palette. Selecting Object > Spawn Morph Target 
creates a morph target from deformed objects (body parts, 
props) in your scene. You will be asked to name your new morph 
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target, and a dial with your specified name will appear in the 
object’s Parameters palette.

Shape an element using any combination of deformers you like 
to get the results you want. Shaping multiple elements on a body 
part includes all changes in the shape in the morph target.

1. Select the body part/prop’s properties in the Properties 
palette, then select Spawn Morph Target. A dialog appears 
asking you to name your new target.

2. Enter your desired name and click OK. A parameter 
dial appears in the Parameters palette with the name of 
your new morph target. At this point, you can delete all 
deformers used to create the morph.

 Assigning a name to a custom morph.

Numbers greater than 0 apply the morph to the selected 
element(s), and vice versa. A value of 1 means the morph target 
is fully applied, a value of -1 means the morph is completely 

inverted, and numbers greater than +/-1 create exaggerated 
effects. Using the Bulging Bicep example, a value of 1 applies 
the bulge fully, a value of -1 applies a full concavity (the reverse 
of the original morph), and so on.

Creating Full-Body Morphs

You can save multiple body parts and then save the entire pose 
as a full-figure morph target, also known as a Full-Body Morph 
(FBM). The new morph target encompasses all of the parameters 
for that pose, meaning that everything morphs at the same time.

Only morph channels combine into a full-body 
morph. Deformers are not automatically turned 

into morph targets for full-figure morphs, nor are 
scales, rotations, and translations.

When you create a full body morph, the master 
parameter dial in the BODY will be set to a value 

of 1, and the dependent parameter dials in each 
individual body actor will be set to 0, which is more in 
line with how full body morphs are typically set up 
manually.

To create a full-body morph target:
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1. Create morph targets for as many body parts as you wish. 
Refer to this section for assistance if needed.

2. Morph each body part using the new Parameter dials as 
discussed in “Parameters Palette” on page 197. Set them 
to the values you want to appear in the full-body morph. For 
example, setting the Bulging Bicep value to 0.5 means that 
the full body morph, when set to 1, will morph that part of 
the figure as if you had applied the original morph with a 
value of 0.5.

3. Select the entire figure, then select Figure > Create Full 
Body Morph. Enter a name for your new morph in the Set 
Name dialog that appears.

When you select the figure’s body again, a parameter dial with 
your new morph target will appear. This morph functions just 
like any other morph: Numbers greater than 0 apply the morph 
to the selected element(s), and vice versa. A value of 1 means 
the morph target is fully applied, a value of -1 means the morph 
is completely inverted, and numbers grater than +/-1 create 
exaggerated effects. Using the Bulging Bicep example, a value 
of 1 applies the bulge fully, a value of -1 applies a full concavity 
(the reverse of the original morph), and so forth.

Loading Full Body Morphs

You can use a third-party application to create a full body morph 
for a Poser figure, and then use the Figure > Load Full Body 
Morph command to apply the complete morph to your figure. 
The Load Full Body Morph command will then split the morphs 
across each individual body part and create a parameter dial in 
the Body actor to control all of the individual body part morphs.

In order for the Load Full Body Morph command 
to work properly, the OBJ file must be grouped 

the same as the original figure. If the morphed figure 
does not contain groups, you will only see a parameter 
dial in the Body actor, and you will not see any change 
occur when you adjust the dial.

You can create your full body morph in a third-party application 
in one of two ways:

• You can import the unmodified OBJ file (usually found in 
the Geometries folder) into your modeling application. This 
is generally the preferred method, because you can then be 
assured that your OBJ file is not translated or modified in 
any way before you create your morph.

• Alternatively, you can load a figure into Poser from the 
library. Before you export the figure, turn off Inverse 
Kinematics and zero the figure, making sure that the hip and 
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Body actors are not translated or rotated in any way. When 
you choose the File > Export > Wavefront OBJ command, 
export the entire figure (do not omit any body parts). When 
the Export Options dialog appears, verify that As Morph 
Target (No World Transformations) and Include Existing 
Groups in Polygon Groups options are checked as shown 
in the following figure.

 Export options for geometry files.

When creating your morph in your third-party application, 
make sure that you do not add or remove vertices or otherwise 
change the geometry in any way. You can only modify the shape 
of the original figure. When you export your geometry from your 
modeling application, you must also make sure that the grouping 
information is maintained.

To load the modified body shape into Poser, follow these steps:

1. Load the original figure from the library into your scene, 
and select it to make it active.

2. Choose Figure > Load Full Body Morph. The Load Morph 
Target dialog appears.

 Loading a Morph Target.

3. Click the button to the right of the Geometry file section to 
locate the morphed OBJ file that you exported from your 
modeling application.

4. Enter a name for your morph in the Label field. This is the 
name that will be assigned to the parameter dials in the 
Body and individual body actors in the Parameters window.
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5. Choose OK to complete the process. You should see morph 
dials in the body and under each individual body part.

6. Test the morph by adjusting the dial in the Body section of 
the Parameters palette.

• If the morph does not work, it may mean that the OBJ 
you imported did not contain groups. Check to see if a dial 
appears in any of the individual body parts. If they are 
absent, your OBJ file did not contain groups. Consult the 
documentation for your modeling program to determine 
how to export the groups with your OBJ file.

• If the morph works but it makes the figure “explode”, repeat 
the process. This time, check the Attempt Vertex Order 
Correction option in the Load Morph Target dialog. This 
might resolve the problem.

Deleting Full and Partial Body Morphs

You can delete full or partial body morphs in the Parameters 
palette.

Find the parameter dial for the morph you want to delete. You 
can delete a morph by selecting a parameter from the BODY 
actor, or from any other body part actor.

Click the arrow that appears at the right side of the parameter 
dial to display the morph context menu, and choose Delete (if 
the BODY actor is selected) or Delete Morph (if a body part 
actor is selected).

 Click the arrow to the right of the morph you want to delete, then 
choose Delete (or Delete Morph) from the menu.

The Select Objects dialog will open. A check mark will appear 
beside each body part from which the morph will be deleted. 
By default, all body parts in which the selected morph appears 
are checked. Uncheck any parts where you want the morph to 
remain. Poser will ask you to confirm the deletion before the full 
body morph is removed.
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 By default, all body actors that contain the morph are selected by 
default. Uncheck any actors where you want the morph to remain.

Using Dependent Parameters
You can change any existing parameter dial or create new 
master parameter dials that can be used to control any number 
of dependent (or slave) parameters. This powerful feature lets 
you link morphs, deformers, transformations, bulge parameters, 
or just about any element in the scene to create complex 
interactions that are all driven by a master parameter.

We’ll examine how Ryan and Alyson use dependent parameters 
to control how several magnet deformers shape the forearm and 
bicep when you bend the forearm on Alyson.

Ryan and Alyson include several magnet deformers that help 
joints bend more realistically. The dependent parameters feature 
is used to link these deformers to various joints in the figure.

There are some magnet deformers that cause Alyson’s forearm 
and bicep to bulge when you bend her forearm. In previous 
versions of Poser, you had to edit the figure’s CR2 file in a 
text or CR2 editor to create a link between the forearm’s bend 
rotation and the deformers (magnets or morphs) in the forearm 
and bicep. The dependent parameters feature permits the 
user to create these links without having to hand edit text in 
the CR2 file. In addition, it permits the user to create a curved 
link that can have varying driven values at any value of the 
master parameter. Conversely, the old hand-editing method 
only created linear links between the master and dependant 
parameters.

You can see all of the magnet deformers used in 
Alyson if you choose Display > Deformers > 

Show All. You can choose Display > Deformers > Hide 
All to turn them back off after you’ve examined them.

In this example, we start by loading Alyson into an empty scene 
and selecting the Top camera view. When you select Alyson’s left 
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forearm, you’ll notice the following features in the Parameters 
palette (shown in the following figure):

• A Master Parameter icon appears beside any parameter that 
serves as a Master Parameter. Click on this button to open 
the Dependent Parameters editor. This serves the same 
function as choosing the Edit Dependencies command from 
the Parameters Option Menu (as described next).

• When two values appear beside a parameter dial, one above 
the other, they indicate the following:

 � The lower number is the natural value, which is the 
value as set by the parameter dial itself.

 � The upper number is the driven value, which is the 
sum of the natural value setting plus any values set by 
its master parameter.

 Dependent Parameter values and icons.

Select Alyson’s Left Forearm, and click the Option Menu arrow 
at the right of the Bend parameter to display the menu shown in 
the following figure. Choose Edit Dependencies from the menu 
that appears. This opens the Dependent Parameters window.
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 To open the Dependent Parameters window, choose Edit 
Dependencies for the parameter you want to edit.

The Dependent Parameters window displays the following 
settings and options:

• Master Parameter: Lists the name of the Master Parameter 
dial that will control the dependent parameters.

• Start Teaching: Click this button to “record” the changes 
that you want to link to the currently selected dial and value.

• Value slider and number: Drag the slider left or right to 
increase or decrease the value. You can also click the value 
field and enter a number.

• Dependent Parameters: Provides a list of the other 
parameters in the figure that will be affected when you 
adjust the Master Parameter dial. For example, when you 
dial the Bend morph to -90 you want a change to occur in 
the Left Shoulder body part.

• Remove Selected: To remove dependent parameters, click 
to highlight one or more of the entries in the Dependent 
Parameters list, then click the Remove Selected button.

• Type: There are two types of Master Parameter dials:

 � Keyed: This master parameter type is the only type of 
dial that you can create in the Dependent Parameter 
palette. You can create linear links or curved links that 
have varying driven values at any value of the master 
parameter.

 � Delta Add: If you see this type listed, it means that 
the relationship between the master parameter dial 
and its dependent parameters were created externally 
(most often by content developers that created the 
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relationships while editing the figure’s CR2 character 
file). A Delta Add type is also created when you use 
the Morphing Tool across body parts. Delta Add 
parameters are editable in the Dependent Parameters 
editor. When you add additional keys to a Delta master 
parameter, it remains a Delta master parameter.

 Delta Add dependent parameters.

When you look at the Bend parameter in Alyson’s left forearm, 
you’ll notice that there are a number of deformers linked to the 
parameter dial.

 Keyed dependent parameters.

These deformers cause Alyson’s forearm and bicep to bulge 
when you bend the forearm. If the deformers are displayed 
(Display > Deformers > Show All) you can observe how 
they respond when you adjust the Bend parameter on the left 
forearm. You can adjust the dial in the Parameters palette, or in 
the Dependent Parameters window.
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 Showing deformers for a figure.

The Dependent Parameter Editor Graph

The Graph in the Dependent Parameters window allows you to 
adjust how the parameter responds between keys. At a minimum 
you need two keys. But you can modify keys in the graph display 
as follows:

• Click on the graph display between two value keys and drag 
up or down to add a third value key.

• Drag the Master Parameter’s value in the graph by clicking 
on the vertical line and moving it forward or backward.

• Click on any value key and drag it up or down to increase/
decrease it’s value.

• Click and drag in an open space of the graph to select 
multiple keys. You can move this selection to include other 
keys. Key navigation is controlled via the pop-up to the right 
of the graph.

Creating Master Parameters

You can create a new Master Parameter dial from the 
Parameters option menu in the Parameters Palette. Master 
and Dependent Parameters aren’t restricted for use in figures. 
For example, you can create a Brightness master parameter 
on the main light in your scene, and use it to raise or lower the 
brightness in all of the lights in your scene at the same time.

Using Poser’s default three-light setup as an example, you would 
create a master parameter for Light 2 (the front off-white light) 
as the Master Parameter, as follows:

1. Select the actor that will serve as the master parameter. In 
this case, we want to add a new Master Parameter to Poser’s 
default Light 2.



Poser Pro 2014
Reference Manual

671

Chapter 30: Modifying Figures & Props

2. Click the Parameters Palette Options menu, and choose 
Create New Master Parameter.

 Creating a new Master Parameter dial.

3. The Dependent Parameters Editor opens and displays a 
default name of Master(x), where (x) is a number. If it is 
the first Master Parameter that you are creating, it will be 
named Master 1.

4. You need to add two keys for each dependent parameter 
that you want to add. Since Light 2 is selected, we will 
adjust the brightness on that light first. First, click the Start 
Teaching button.

5. In the Dependent Parameters palette, set the Parameter dial 
to 1.000. This is the value we will use as the “Bright” setting 
for the Master 1 Parameter dial.

6. Now you adjust the brightness on all three lights in your 
scene. It doesn’t matter which order you complete them in, 
but since we have Light 2 selected already we’ll do that one 
first. Set the Intensity for Light 2 to 200% (or double the 
normal brightness).

7. Repeat Step 6 for Lights 1 and Lights 3, selecting them from 
the Actor Selector in the Parameters Palette. As you make 
these settings, you’ll notice entries are automatically added 
to the Dependent Parameters palette.

 After the first key is created, click the Next Key button.
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8. Click the Next Key button in the Dependent Parameters 
palette to create a key for the other end of the Master 1 
parameter dial.

9. In the Dependent Parameters palette, set the Master 1 
parameter to -1.00 (negative value). This is the setting that 
we will use to turn the lights off.

10. In the Properties palette, set the intensity of your current 
light to 0% (off). Then do the same for the other two lights.

 Set the intensities for the lights to 0%.

With all of your settings configured, click the Stop Teaching 
button in the Parameters Palette. You can also close the 
Dependent Parameters palette, if desired.

 Click the Stop Teaching button when you complete the actions you 
want to perform.

To test the new master parameter dial, select Light 2 in the 
Parameters Palette, and adjust the Master 1 parameter dial. All 
three lights should be off when the dial is set to -1, on at their 
normal strength at 0, and at double brightness at 1.
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 Test the new parameter dial to make sure it works as you expect.

Editing Master Parameters

The Dependent Parameters feature can be used to create or 
enhance Full Body Morphs. In this section, we’ll describe how 
you can use the dependent parameters feature to enhance the 
Pregnant full body morph.

Create a new Poser scene and add Alyson to your scene. Select 
her Body, and expand the FBM morph section. Scroll down, if 
necessary, until you see the Pregnant morph. Click the Master 
Parameter icon to open the Dependent Parameter editor.

 A master parameter icon.

You’ll notice that a number of dependent parameters already 
appear in the Dependent Parameters editor. If you highlight one 
of the Dependent Parameters, the selected parameter appears 
in the Parameters palette. For example, when you select the 
rButtock: Pregnant entry in the Dependent Parameters list, the 
settings for the rButtock body part appear in the Parameters 
palette.
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As mentioned earlier in “Using Dependent Parameters” on page 
666, there are two numerical values listed to the right of each 
morph dial:

• The natural value (lower) designates the value that is 
currently set for the morph dial in the Parameters palette. 
In the example shown, the dial in the Parameters palette is 
set at 0%.

• The driven value (upper) designates the value as controlled 
by the master parameter. In this case, we are looking at a 
Master Parameter dial (Pregnant), so its Driven value in the 
Parameters palette is the same as that set in the Dependent 
Parameters window.

 Morphs affected by dependent parameters have two values: 
natural and driven.

The Dependent Parameters list displays a list of the morphs that 
are adjusted by the Pregnant morph. The above figure shows 
that the Pregnant morph dial in Alyson’s Body actor controls the 
Pregnant morph in the hip, waist, abdomen, chest, left buttock, 
and right buttock. If you are already familiar with previous 
versions of Poser, you might recognize this type of morph 
relationship as a “Full Body Morph.” In earlier versions of Poser, 
you would have used the Figure > Create Full Body Morph 
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command to create a master parameter dial in the figure’s Body 
part.

While the older method of creating Full Body Morphs is still 
available, the Dependent Parameters feature provides you with 
even more power. For example, you can link additional partial 
body morphs or full body morphs to the Pregnant dial so that 
there are even more changes to the shape of Alyson’s pregnant 
body. To demonstrate, we are going to make the Pregnant 
morph even more natural looking, by adding additional changes 
to the breasts and hips. The Dependent Parameters feature 
makes this a very simple process.

Since Alyson is already in your scene, select Body as the current 
body part. Scroll down until you see the Pregnant full body 
morph, and dial in or enter a setting of 1 in the Dependent 
Parameters window.

 The Pregnant morph is set on several body parts. Click Start 
Teaching to further enhance the shape.

In the Dependent Parameters window, click the Start 
Teaching button. This instructs Poser to create a link between 
the Master Parameter and the values that you select until you tell 
Poser to stop teaching the joint parameters.

Now, we’ll adjust some of the breast settings to make them 
look more like those of a pregnant woman. With Alyson’s Body 
actor selected in the Parameters window, scroll down in the 
Parameters palette and expand the morphs under the Breasts 
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category. Then you can use the dials or enter values numerically. 
The following list shows the values that we set. Yours don’t have 
to be exactly the same, feel free to experiment with other settings 
if you desire:

• Breast Diameter: 1.072

• Breast Droop: 1

• Breasts Large: 1.216

• Breasts Natural: 1

• Areola Size: .548

• Nipples: .248

 Breast morphs are adjusted for a fuller appearance.

Notice now that the shape of the breasts looks more natural and 
realistic. Now we’ll add a couple of other Full Body Morphs to 
the mix. We’ll add a touch of the Pear Figure and Rubenesque 
to adjust the overall body shape just a bit. Scroll back up to the 
Full Body morphs section in the Parameters Palette, and adjust 
the following values:

• PearFigure: .199

• Rubenesque: .199
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 Other Full Body Morphs add additional shape to the Pregnant 
morph.

Now return to the Dependent Parameters window, and click 
Stop Teaching. The settings that you dialed in while teaching 
the joint should all appear in the Dependent Parameters list. 
When you adjust the dial in the Dependent Parameters window, 
you should see the differences in the Pregnant morph respond 
accordingly. Before you close the Dependent Parameters 
window, set the value to zero.

 Set the value of the Master Parameter dial to zero before you close 
the window.

Now, go back to the Pregnant full body morph in the Parameters 
window. Adjust the value up and down to see how the new 
morph responds to the changes in the dial settings. Your 
new Pregnant morph should respond exactly as it did in the 
Dependent Parameters window. Notice how you also see the 
values of the PearFigure and Rubenesque dials change when you 
adjust the Pregnant morph. The values in the second column 
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reflect the settings that are inherited by the links that you 
created with the master parameter.

 When you adjust the Pregnant morph dial, the dependent 
parameters adjust with it.

The following figure shows the original Pregnant morph on the 
left, and the new improved version on the right. As you can see, 
the enhancements have made the morph look more natural.

 The original and modified Pregnant morph.

Before we move on to the next topic, there is one more thing 
to examine. The previous shot of the Parameters palette shows 
what happens to the PearFigure and Rubenesque morphs when 
you dial in the enhanced Pregnant morph. You’ll see that when 
the Pregnant master parameter dial is set to .820, it drives the 
PearFigure and Rubenesque morphs to .163. But what happens 
if we want the woman to be more pear-shaped?

The solution is simple enough. You can adjust the natural value 
(the lower value) of the Pear Figure morph just as you can with 
any morph dial that is not affected by a master parameter. The 
following figure shows what happens when the natural value 
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dial for the Pear Figure morph is increased to .8. The driven 
value, which was previously set to .163 by the Pregnant morph, 
increases by your .8 setting as well, and the resulting shape of 
the figure changes accordingly.

 You can still adjust the Natural value of a dependent parameter 
without affecting the Driven value.

To summarize, Dependent Parameters can be used to create 
master parameter dials that drive other parameters in a figure: 
morph dials, magnets, light settings, material settings, rotations, 
and more. As you experiment with this feature you’ll realize how 
powerful and flexible it is.

Managing Morphed Figures

Saving Morph Targets

You can save morphed figures to the Library palette. Saved 
figures retain their custom parameter dials, meaning you can use 
them the next time you load that figure. To save a figure to the 
Library palette, please refer to “Adding Items to the Library” on 
page 162.

Poser saves morph targets to an external binary file format 
(.PMD), which contains only the morph targets for a particular 
figure or scene. This format allows for faster loading and greater 
flexibility, as the targets are no longer enmeshed with the rest of 
the data in the .PZ3 scene file. This storage method also requires 
less disk space, as all instances of the same figure reference the 
same .PMD file for morph target data. If you change the morph 
targets of one or more figures created from the Library and then 
save your scene, the morph target modifications will be saved in 
a single new .PMD file accompanying the scene file.

If you wish to save the modified morph targets for any one 
figure independently, you must select the Use External Binary 
Morph Targets option in the General Preferences palette (see 
“Setting Application Preferences” on page 32), and then add 
the modified figure back into the Library as a new figure. A new 
.PMD file will be created for that figure, containing the modified 
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morph targets. You can then reuse that figure in other scenes. 
Additionally, you can easily redistribute the morph targets 
independently of the specific figure, thereby affording you 
options for greater flexibility and efficiency.

It is the responsibility of the user to comply with 
the Smith Micro Software, Inc. End User License 

Agreement, as well as any third party License 
Agreements, before distributing Poser content. PMD 
morph data can be redistributed as long as they include 
morph delta information, and not geometry 
information.

Distribution of PMD morph data found in third-
party content is subject to usage restrictions as 

outlined by the third-party content developers.

When you open and resave a Poser scene file (.PZ3) from a 
previous version, Poser will create a new external .PMD file 
containing the morph targets for that scene. If you wish to save 
morph targets for the figures in that scene independently, simply 
add those figures to the Library as described above, and then 
replace them in your scene. Poser will generate individual .PMD 
files for each of the figures.

Deleting Morph Targets

You can use the Hierarchy Editor palette to delete morphs, 
as explained in “Working with Hierarchy Branches” on page 
699.



Poser Pro 2014
Reference Manual

681

Chapter 31: Figure and Prop Editors

Chapter 31: Figure and 
Prop Editors

The Group Editor
Selecting the Grouping tool from the Editing tools display opens 
the Group Editor palette. The Group Editor lets you select and 
group individual polygons.

The Group Editor is very powerful and can 
permanently alter your figures if you overwrite 

changed figures into the Library. Be sure you 
understand how the grouping tool works before editing 
critical content. It’s wise to practice on a simple object or 
prop to grasp the concepts first.

It helps to use Smooth Lined preview mode when 
using the Group Editor as polygons and vertices 

are clearly displayed.

The Group Editor is useful for various tasks within Poser such 
as:

• Creating material groups in the Material room. Please refer 
to “Chapter 14: The Material Room” on page 296 for 
information about the Material room.

• Creating hair groups in the Hair room. Please refer 
to “Chapter 26: The Hair Room” on page 533 for 
information about the Hair room.

• Creating cloth groups in the Cloth room. Please refer 
to “Chapter 27: The Cloth Room” on page 550 for 
information about the Cloth room.

• Creating body parts in the Setup room. Please refer to 
“Chapter 25: The Face Room” on page 518 for more 
information about the Setup room.

• Creating props. You can also create new props and deform 
and morph selected portions of an element. For example, 
you could use the Group Editor to select polygons around a 
character’s eyes, nose, and forehead, and use those selected 
polygons to create a mask prop. See “Creating/Editing 
Groups” on page 689 for information on how to select 
polygons in the Group Editor.

Using the Group Editor

To create/edit a group, select the Grouping tool, which opens 
the Group Editor palette.
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 The Group Editor in the Editing Tools palette.

When this option is selected, all figures and objects in the Poser 
workspace turn gray. The Group Editor palette has the following 
sections and functions.

Creating and Deleting Groups

The top section of the group editor includes controls to navigate 
through, create, and delete groups from your current object.

 The top section of the Group Editor.

• Previous button (1): Cycles backward through the 
currently existing groups.

• Current Group pull-down menu (2): Use the Current 
Group pull-down menu to jump directly to your desired 
group.

• Next button (3): Cycles backward through the currently 
existing groups.

• New Group button (4): Clicking the New Group button 
creates a new group with the currently selected polygons.

• Delete Group button (5): Clicking the Delete Group 
button deletes the currently selected group.
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Adding, Removing, and Modifying Polygons

The Selection section of the Group Editor contains three menus 
that allow you to add or remove polygons to the currently 
selected group.

• Selection Mode (6): Click the icon to display a menu that 
allows you to choose one of the following selection modes:

 � Marquee: Allows you to add to or remove from the 
currently selected group by drawing a rectangle around 
the polygons that you want to include or exclude.

 � Draw: Allows you to add or remove from the currently 
selected group by drawing over the polygons that you 
want to include or exclude

• Select mode button (7): Click the Select button to enable 
polygon selection, and then click within the current object to 
add polygons to the current group.

• Deselect mode button (8): Click the Deselect button 
to enable polygon deselection, and then click within the 
current object to remove polygons from the current group.

 The Selection section of the Group Editor.

• Add menu (9): Expand the Add menu to add polygons to 
the currently selected group, using one of four different 
modes:

 � All: Adds all polygons in the currently selected group.

 � Group: Allows you to add polygons by group name.

 � Material: Allows you to add polygons by material name.

 � Mirror: Allows you to mirror selected polygons along 
the X, Y, or Z axis to the opposite side of the model.
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• Remove menu (10): Expand the Remove menu to remove 
polygons from the currently selected group, using one of 
four different modes:

 � All: Removes all polygons in the currently selected 
group.

 � Group: Allows you to remove polygons by group name.

 � Material: Allows you to remove polygons by material 
name.

 � Mirror: Allows you to mirror deselected polygons along 
the X, Y, or Z axis to the opposite side of the model.

• Modify menu (11): Expand the Modify menu to add or 
remove from the selection using one of the following 
methods:

 � Invert: Inverts the polygons that are assigned to the 
selected group, so that unselected polygons become 
selected, and selected polygons become unselected.

 � Grow: Expands the selection by one polygon around 
all its edges. You can also use the plus sign on your 
keyboard [ + ] to grow the selection.

 � Shrink: Reduces the selection by one polygon around 
all its edges. You can also use the minus sign on your 
keyboard [ - ] to shrink the selection.

 � Grow (Edge Loop): After selecting two or more 
polygons in a loop, click the Grow button or use the 
right parenthesis shortcut [ ) ] to expand the selection 
by one along both ends of the same loop.

 � Shrink (Edge Loop): Click the Shrink button or use the 
left parenthesis shortcut [ ( ] to shrink the selection by 
one along both ends of the same loop.

 � Mirror: Mirrors the selection on one side of the model 
to the other side, along the X, Y, or Z axis.

Showing and Hiding Faces and Objects

 Display options in the Group Editor.

• Hide Other Objects box (12): Checking the Hide Other 
Objects checkbox hides all objects in your scene other than 
the currently selected object, which can help if you have a 
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complex scene and only want to see the object being worked 
on.

• Show Multigrouped Faces box (13): Checking the Show 
multigrouped faces checkbox displays all polygons that 
are assigned to more than one group. This can occur if you 
grouped your geometry in the 3D modeling application 
and accidentally assigned some polygons to more than one 
group.

• Show Nongrouped Faces box (14): Checking the Show 
nongrouped faces box displays all polygons that do not 
belong to a group. If you leave the Setup room with one 
or more polygons that are not attached to a bone, they will 
be maintained on a prop attached to the figure and will be 
available for grouping again when you return to the Setup 
room.

The above commands are necessary for creating 
a figure using the geometry and bone structure. 

The following commands are useful and can be 
performed in the Setup room; however, they are not 
necessary for figure creation. They may, however, be 
necessary for rendering and finishing scenes using the 
newly created figure.

Geometry Functions

 Geometry Functions in the Group Editor.

• Create Prop button (14): Clicking the Create Prop button 
creates a new prop from the selected group or polygons. 
Enter a name for your new prop in the dialog that appears.

• Spawn Props button (15): Clicking the Spawn Prop 
button creates props for all groups that have been created. 
Two examples of this might be to create a suit of form-fitting 
armor or the basis for clothing props.



Poser Pro 2014
Reference Manual 

686

Chapter 31: Figure and Prop Editors

• Assign Material button (16): Clicking the Assign Material 
button creates a new material class for the selected 
polygon(s). A dialog box will appear asking you to name 
the new material class. A material class is a parameter that 
determines the polygons to which a material is applied. 
For example, if you are creating a figure with gloves on, 
you could select the polygons of both gloves as a material 
class. Later, you could use the Material command to assign 
a material, texture, bump maps, etc. to the gloves. You can 
think of material classes as groups that define areas where 
materials are applied.

• Assign Smoothing ID button (17): Clicking the Assign 
Smoothing ID button allows you to delineate smoothing 
groups for the application of smooth shading across 
adjoining polygon edges. A dialog will appear asking you to 
assign a new or existing Smoothing ID to the current group. 
Enter a new ID in the field provided. For more information 
about smoothing groups, see “Smoothing Geometry” on 
page 422.

• Create Perspective UVs button (18): Clicking the Create 
Perspective UVs button maps texture coordinates for 
a group. An example of using this command might be to 
map an imported background image of a face to a Poser 
group corresponding to the figure’s face. The face’s texture 
coordinates would map to the image.

• Reverse Group Normals button (19): Clicking the 
Reverse Group Normals button reverses the normals of 
the selected group. This allows you to turn environment-
type objects or other imports inside out for interactive 
rendering as desired.

• Auto Group button (20): See “The Auto Group Command” 
on page 687 below.

• Weld Group button (21): See “The Weld Group Command” 
on page 688 below.

Polygon & Vertex Modes

The Grouping tool operates in polygon or vertex mode, 
depending upon which room you are in when you use the Group 
Editor:

• In polygon mode, you can add/remove your currently 
selected polygon(s) to the current polygon group. While in 
this mode, you can only create/edit/delete polygon groups. 
Polygon groups are accessible from the Group Editor 
palette using certain commands, such as Add Group. 
Polygon groups will appear in the popup menu (#4 in the 
following image).



Poser Pro 2014
Reference Manual

687

Chapter 31: Figure and Prop Editors

 The top section of the Group Editor.

• In vertex mode, you can add/remove your currently selected 
vertex/vertices to the current vertex group. Likewise, in 
vertex mode, you can only create/edit/delete vertex groups. 
Poser uses vertex groups for dynamic cloth objects in the 
Cloth room and for styling hair in the Hair room. For cloth, 
using vertices allows you to select the edges of a cloth object 
(such one side of a sheet hanging from a clothesline and 
blowing in the wind). This effect cannot be achieved using 
polygon grouping.

Poser automatically selects the correct mode depending on 
which room you are currently in. For example, in the Pose 
room, the Grouping tool only operates in polygon mode; in the 
Cloth room, it operates in vertex mode.

The Auto Group Command

When you are creating groups for a newly imported geometry 
(Setup room), you can save time and effort by clicking the Auto 
Group button near the bottom of the Group Editor palette. This 
option is particularly useful when you are creating custom Poser 
figures in the Setup room. If you choose to use the Auto Group 
feature, be sure to do so after creating, positioning, and naming 
the bone structure! This is because the Auto Group feature 
places polygons into groups based on their location in 3D space 
relative to the available bones. This can cause very unpredictable 
and disorganized results if the bone structure has not been 
properly created, positioned, and named.

If you use the Auto Group feature before you 
have created, positioned, and named the bone 

structure, it can result in unpredictable groups that will 
then require extensive time-consuming repair. The 
correct bone structure used by the Alyson and Ryan 
figures is shown in “Poser Figures Hierarchy” on page 
695. Other Poser figures use similar hierarchies, but 
may have less control in mouth, hand, and feet parts.

The Auto Group feature is designed for one-time use when you 
first create a figure. You can use it as often as you wish; however, 
it completely regroups every polygon in the geometry or 
figure, which will cause the figure to lose all pre-existing group 
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assignments that match bone names. If you must use the Auto 
Group feature again after creating your figure, do it with care.

The Auto Group feature causes Poser to take a “best guess” 
when grouping polygons and bones. You may find that you 
need to fine-tune the automatically created groups by manually 
selecting polygons and moving them to different groups. Do this 
by selecting the target group and then selecting the polygon(s) 
you wish to move to the target group.

The Grouping tool automatically removes 
polygons from other named groups (including 

NO_BONE) and adds them to the selected target group 
in order to avoid having polygons assigned to more 
than one group at a time. Group Editor palette 
commands do not share this functionality.

The Weld Group Command

The Weld Group feature can be useful if, for example, you need 
to make alterations to your groups after you leave the Setup 
room or if you import a prop with groups that you want to 
change. In the Setup room, once your figure is created, Poser 
breaks the single geometry into pieces corresponding to the 
groups you created. If you reassign polygons to different groups, 
the original breaks remain, which can cause your figure to 

appear broken or disconnected at the point where the old group 
boundaries lie.

The best way to illustrate this is by using an example. Say you 
create a figure with, among others, groups for the head and neck. 
After leaving the Setup room, Poser breaks the single geometry 
into pieces whose edges correspond to the group boundaries 
you created. This is necessary in order to allow the figure to 
bend. Later, you decide to move the neck higher into the head by 
reassigning some of the polygons in the head group to the neck 
group. You can do this easily using the Grouping tool.

Poser creates a new break in the geometry at the new group 
boundary; however, the old break at the old group boundary 
still exists. This can cause your figure’s neck to appear broken or 
discontinuous as you pose and render it. To solve this problem, 
you would:

1. Select the Grouping tool.

2. Select the neck group.

3. Click the Weld Group button.
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The Weld Group function alters and combines 
the vertices on either side of the break so as to 

create a smooth bridge across the gap. A good way to 
think of this is to imagine sealing a crack. The filler 
compound joins the two surfaces, but does minutely 
alter the surface topography where the crack used to be. 
The Weld Group function works this way as well, 
modifying the geometry slightly in order to eliminate 
the break. This should be unnoticeable in most cases.

Creating/Editing Groups

To create a group, select the Grouping tool. You can then click 
individual polygons or click and drag to select multiple polygons. 
If you accidentally select one or more wrong polygons, you 
can deselect them by using the Deselect tool (see above) or 
pressing [CTRL] while clicking or dragging. If you are in the 
Setup room, polygons that have been removed from a group will 
automatically be added to a group called NO_BONE so that you 
can see which polygons are unassigned and correct the problems 
before leaving the Setup room.

To select polygons that are currently out of view, you can use the 
Wireframe display style, the camera trackball to change the view 
of your figure, and/or multiple viewpanes to bring the desired 
polygons into view.

Path names in Poser-related library files and 
scripts use a colon to separate the folders in the 

path (ie: Runtime:Libraries:character:myfolder:mypro
duct.cr2). Using a colon in figure or group names will 
cause potential problems when parsing PoserPython 
scripts, as anything after the colon is ignored. Use of a 
colon in an actor name (such as tail:1 or tail:9) is 
discouraged. Instead, name the item something like 
tail01 or tail09.

While working with the Grouping tool, pressing 
[OPT]/[ALT] allows you to quickly access the 

camera trackball.

While you are selecting polygons, it is possible that you will 
select some polygons that have previously been assigned to a 
different group, either by accident or by design. If this happens, 
the Grouping tool will remove the subject polygons from their 
previous group and assign them to the new group in order to 
ensure that no polygons belong to more than one group at a 
time.

The Group Editor palette commands do not 
share this functionality.

When you are creating groups for figures (Setup room), it is 
important to remember that joint bending only occurs between 
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an object and its parent. The bends do not progress to other 
children or above the parent in the hierarchy. Keep this in mind 
as you create your groups, and later when you fine-tune your 
joints.

The Group Editor palette appears whenever the 
Grouping tool is selected.

About Groups
This section describes how Poser differentiates between body 
part groups, material groups, and other group types on a figure 
or prop. This explanation is specific to Poser, however it will 
provide you with the background information you need in order 
to understand groups in general.

The following examples use the Alyson Casual figure (available 
in the Figures category). Add this figure to your scene by 
dragging from the Library to the document window, or by 
clicking the Change Figure or Create New Figure button at 
the bottom of the Library palette, as described in “Loading and 
Managing Items using the Library Icons” on page 135. When 
you display the figure in Outline display mode and hover your 
mouse over the various body parts, you’ll see an outline of the 
group underneath the mouse. We have color-coded the groups 
for clarity in the following figure.

Please remember that each figure/prop is 
different, having different body parts, materials, 

hair, and cloth groups. Further, the groups themselves 
may be arranged in different orders. However, the 
concepts explained here are the same for each figure/
prop.

Poser figures consist of named body parts that can be selected 
and articulated (or posed). Props normally consist of a single 
part that cannot be articulated, although poseable props do exist. 
The following graphic depicts an example of Poser body parts:
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 A figure is made up of poseable body parts, called groups.

The example displays several body parts: head, left eyeball, 
right eyeball, neck, chest, left collar, right collar., left shoulder, 
right shoulder, and abdomen Each of these body parts can be 
articulated (posed).

Each body part (or group) consists of one or more polygons.

As hinted above, there are several different types of polygon 
groups: body part groups, material groups, hair groups, and 

cloth groups for example. A polygon can belong to more than 
one type of group (such as a body part group and a material 
group, or a cloth group and a material group). A polygon can 
only be in one group of each type at a time. Thus, the following 
group combinations are possible:

• One body part may have one material assigned to it. For 
example, the neck will probably have the “skin” material.

• Two or more body parts may use the same material. For 
example, the fingers may all use the “skin” material.

• One body part may use more than one material. For 
example, each eyeball may have separate materials for the 
eyeball, iris, and pupil.

• In addition to the above, a polygon may be part of a hair 
group and/or a cloth group.
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 Polygons in the figure are assigned to groups for posing.

Since body parts and materials are the most obvious forms 
of grouping, let’s use them to illustrate grouping as a whole 
since the same concepts apply to hair and cloth groups as well. 
The graphic displays the material assignments for the above-
displayed body parts.

You can see that the head, neck, and portions of the chest use the 
skin material. The chest and collars use the shirt material. The 

eyes use eyeball, pupil, and iris materials. The head uses several 
materials including skin, lips, and eyebrows.

 Material assignments for various body parts.

The important things to remember are:

• Poser groups polygons by body part, material, hair, and 
cloth, and these groups are independent of each other.

• Each material in a figure/prop gets assigned a unique 
numbered ID, and that ID is in turn used by a polygon to 
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specify which material should be applied to that polygon. 
For example, the skin material may have ID 1, the shirt 
ID 2, etc. Each polygon in a figure/prop includes the ID 
number of the material assigned to that polygon. Changing 
a material itself will affect the appearance of all polygons 
that have the corresponding material ID. For example, if 
one made the skin green, then all polygons with the “skin” 
material ID would turn green regardless of the body part.

The following table depicts a partial list of the relationships 
between body parts and materials in the Alyson Casual figure:

Body Part Assigned Material(s)

Head Head, Nostrils, Lips, EyeSockets, 
Lacrimals, InnerMouth, TearLine, 
EyelashesBottom, EyelashesTop, Teeth, 
Gums, Tongue

Eyeballs (left and 
right)

EyeballLeft, IrisLeft, PupilLeft, CorneaLeft, 
EyeballRight, IrisRight, PupilRight, 
CorneaRight

Neck Body

Collars (left and right) Body, Shirt

Chest Body, Shirt

Again, the only relationship between the body parts, materials, 
hair, and cloth is that defined by the figure’s creator. Poser does 
not mandate any such relationship.

Now that we have differentiated between body part and material 
groups and mentioned hair and cloth, let’s describe hair and 
cloth groups in more detail:

Hair Groups

Hair groups are groups of polygons that can also belong to any 
body part, prop, and material group. Polygons that are part 
of hair groups can have real 3D hair grown on them. Please 
refer to “Chapter 26: The Hair Room” on page 533 for more 
information about the Hair room.



Poser Pro 2014
Reference Manual 

694

Chapter 31: Figure and Prop Editors

 Hair groups are special grouping assignments that can grow 
strand-based hair.

Cloth Groups

Poser’s Cloth room allows you to create realistic cloth that you 
can use for almost any purpose in your scene. Cloth groups are 
actually vertex groups, meaning that they are groups of vertices 
instead of polygons, however this makes little difference in the 
overall discussion. Vertices belonging to a cloth group cannot 
belong to a body part group.

Here is an example of a figure wearing dynamic cloth, which 
consists of props with named groups. See how the cloth 
realistically drapes and moves as the figure moves.

Please refer to “Chapter 27: The Cloth Room” on page 550 for 
more information about the Cloth room.

 Cloth groups are used in dynamic clothing, which moves 
realistically when animated.
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The Hierarchy Editor
The Hierarchy Editor shows every parent/child relationship and 
every scene element and their various parameters, from lights 
and cameras to morphs and deformers. You can also view the IK 
chain settings and external names of each item. The Hierarchy 
Editor also displays buttons that allow you to configure standard 
hierarchy, rotation order, IK chains, and new figure.

A scene’s hierarchy describes the parent-child relationships of all 
objects in your scenes.

Please refer to “Poser File Types” on page 848 
for more information about hierarchies in 

general.

Body parts or props that are physically located 
at a seam are generally contained in either a 

parent or child object. The scene’s hierarchy also defines 
data like joint rotation orders and IK relationships.

A Poser document’s hierarchy contains:

• The complete list of all objects in the scene’s universe, 
including figures, props, body parts, lights, and cameras.

• Hierarchical connections (parent/child relationships) 
between scene objects.

• Parameters, including rotation, translation, morph targets, 
and Point At (see “Point At” on page 212).

• IK chains.

Poser Figures Hierarchy

In order to make a figure bendable, it needs to be attached to 
a skeleton that moves the polygons in the geometry. In order 
to attach the polygons (or “skin”) to the bones, the polygons 
in the geometry must be named the same as the bones in the 
underlying skeleton.

To utilize as many of Poser’s posing and morphing capabilities 
as possible, there are specific naming conventions that should 
be followed. Most human Poser figures follow a hierarchical 
structure that uses the hip actor as its root. Internal body part 
groups must always begin with a lower-case letter, with right and 
left body parts always beginning with a lower-case r (for right) or 
l (for left) to work with Poser’s Symmetry commands properly.

The internal group names that are used by the Alyson and Ryan 
figures are shown below in their correct hierarchical structure. 
Alyson and Ryan have additional groups (shown in bold italics) 
which control the top and bottom teeth, several levels for the 
tongue, and an extra joint for each of the fingers and toes to 
allow for better bending. Other Poser figures may have more 
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or less groups, but the basic arrangement of the bones will be 
similar to that shown below:

hip
 waist
  abdomen
   chest
    neck
     lEye
     rEye
     TopTeeth
     BttmTeeth
     Tongue1
      Tongue2
       Tongue3
        Tongue4
         Tongue5
          Tongue6
 lCollar
  lBreast
   lShldr
    lForeArm
     lHand
      lThumb1
       lThumb2
        lThumb3
      lIndex0
       lIndex1
        lIndex2
         lIndex3
      lMid0
       lMid1
        lMid2
         lMid3
      lRing0
       lRing1
        lRing2
         lRing3
      lPinky0
       lPinky1

        lPinky2
         lPinky3
 rCollar
  rBreast
   rShldr
    rForeArm
     rHand
      rThumb1
       rThumb2
        rThumb3
      rIndex0
       rIndex1
        rIndex2
         rIndex3
      rMid0
       rMid1
        rMid2
         rMid3
      rRing0
       rRing1
        rRing2
         rRing3
      rPinky0
       rPinky1
        rPinky2
         rPinky3
 lButtock
  lThigh
   lShin
    lFoot
     lToe
      lBigToe1
       lBigToe2
      lIndexToe1
       lIndexToe2
      lMidToe1
       lMidToe2
      lRingToe1
       lRingToe2
      lPinkyToe1
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       lPinkyToe2
 rButtock
  rThigh
   rShin
    rFoot
     rToe
      rBigToe1
       rBigToe2
      rIndexToe1
       rIndexToe2
      rMidToe1
       rMidToe2
      rRingToe1
       rRingToe2
      rPinkyToe1
       rPinkyToe2

Using the Hierarchy Editor

To display the Hierarchy Editor palette, select Window > 
Hierarchy Editor.

 The Hierarchy Editor.

The Hierarchy Editor palette allows you to:
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• Select scene elements. Selecting an element in the 
Hierarchy Editor palette selects that item in the Document 
window, Current Actor pull-down, and Graph palette.

• Access object properties. Double-clicking an object listing in 
the Hierarchy Editor palette opens the Properties palette 
for the selected item.

• Quickly hide or view scene elements.

• Rename or delete elements and parameters such as morph 
targets or Point At parameters. Use caution, as this is a very 
powerful and very permanent change.

• Set up or change parent-child relationships for props.

• Set up Inverse Kinematics (IK) chains.

• Change rotation orders for props or body parts.

• Create new figures. The addition of the graphical Setup 
room (see “Chapter 27: The Cloth Room” on page 550) 
eliminates the need to use the Hierarchy Editor palette to 
create figures.

• Expand or contract the hierarchy list to view parents and 
children or parents only.

Filtering the Display

You can filter what appears in the Hierarchy Editor palette by 
selecting your desired display options at the top of the palette. 
Checking a box enables the selected option, and clearing it 
disables that option. The options are as follows:

• Show Figures: Checking the Show Figures checkbox 
displays all figures in the current Poser document.

• Show Cameras: Checking the Show Cameras checkbox 
displays all cameras in the current Poser document.

• Show Parameters: Checking the Show Parameters 
checkbox displays all object parameters in the current Poser 
document.

• Show All Parameters: Checking the Show All Parameters 
checkbox displays all parameters in the current Poser 
document.

• Show Props: Checking the Show Props checkbox displays 
all props in the current Poser document.

• Show Deformers: Checking the Show Deformers 
checkbox displays all magnets, waves, morph targets, and 
force fields in the current Poser document (scene).
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• Show Lights: Checking the Show Lights checkbox displays 
all lights in the current Poser document.

• Show Groupings: Checking the Show Groupings 
checkbox displays all of the constraint grouping and object 
grouping objects in the current Poser document, along with 
objects that are children of them.

Working with Hierarchy Branches

You can perform the following basic actions using the hierarchy 
listing:

• To expand a hierarchy branch, click the right-pointing arrow 
next to the branch you wish to expand.

• To collapse a hierarchy branch, click the downward-pointing 
arrow next to the branch you wish to collapse.

• To select an object, click its listing.

• To make an object visible or invisible, click the eye next 
to the desired icon. The eye appears bright white when an 
object is visible and gray when invisible.

• To view the Properties palette for an object, double-click 
the selected object’s listing.

• To delete a figure, prop, or light from your scene, select the 
item to delete then press [DEL]. You cannot delete body 
parts, cameras, or the ground plane.

• To rename an object, click on its listing once to select it, 
and then a second time to open a text box. (Do not simply 
double-click on the listing, as this will open the Properties 
palette for that object.) Enter the object’s new name in the 
text box.

 Elements of the Hierarchy Editor.

Reordering Scene Elements

You can reorder scene elements including props and deformers. 
Reordering deformers can be useful, especially when you have 
a long hierarchy listing. You can also reorder morph targets and 
parameters such as rotation orders (this is the same as using the 
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Joint Editor palette). You can also reorder light, camera, and 
prop Point At parameters.

Be careful when changing rotation orders as this 
might cause unexpected behavior.

Establishing Hierarchal Relationships

This does the same thing as the Set Parent menu command (see 
“Changing a Parent” on page 231). To establish a hierarchical 
relationship using the Hierarchy Editor:

1. Load your desired prop(s) into the scene.

2. Open the Hierarchy Editor palette and find the prop.

3. Drag the child object on top of the root (parent) object. A 
green box highlights the target when the child object is on 
top of it.

4. Drop the object onto the highlighted object.

 Dragging and Dropping to parent an object.

To reorder a child at the same hierarchical level:

1. Click the child object and drag to its new location. A white 
line appears just below the target location, indicating where 
the object will be placed once dropped.

2. Drop the object.

You can also create hierarchies spanning figures (such as a 
woman on horseback):
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1. Select the child figure.

2. Drag the child figure onto the desired parent.

3. Drop the child.

You can also set up hierarchies between figures outside the 
Hierarchy Editor palette as follows:

1. Use the pop-up to select the child figure.

2. Select Figure > Set Figure Parent (see “Set Figure Parent” 
on page 230) to open the Set Parent dialog.

3. Select the parent body/body part in the dialog and click OK.

Applying the Standard Hierarchy

If a figure’s geometry was created using standard body group 
names for human/biped figures, you can use the Hierarchy 
Editor to automatically apply the Poser Standard Hierarchy to 
your figure, establishing parent-child relationships. Poser can 
apply the Standard Hierarchy to full or partial figures. Refer to 
“Chapter 31: Figure and Prop Editors” on page 681 for more 
information about groups and hierarchies and how to edit them.

To apply the Poser Standard Hierarchy to a figure:

1. Choose Window > Hierarchy Editor.

2. Select the Universe.

3. Click the Apply Standard Hierarchy button.

 The Apply Standard Hierarchy button.

The Apply Standard Hierarchy button is not 
available unless the universe is selected.

Creating IK Chains

To create an IK chain:

1. Scroll to the bottom of the hierarchy list using the scroll bar 
and click the IK Chains entry to enable the Create IK Chain 
button.

2. Enter a name for the chain you are creating in the dialog 
box that pops up and click OK. A blank IK chain appears in 
the list.
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3. Plan each element in the IK chain from root to goal. For 
example, the IK chain for the right arm has the right hand 
as the goal.

4. From the hierarchy list, click and drag body part listings 
onto the new blank IK chain. They will be added to the IK 
chain in the order you drag them from root to goal. Proceed 
to add parts to the chain in the order of root to goal.

 Creating an IK chain.

Be careful when creating IK chains as you could 
cause your figure to move in unexpected ways 

when the new IK chain is added.
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Using IK

To enable IK for your figure, select Figure > Use Inverse 
Kinematics and select the chain you wish to enable. You will 
see the chains you created as well as the standard Poser chains 
(if you added chains to a standard Poser figure). A check mark 
appears next to each enabled IK chain. To disable IK, select 
Figure > Use Inverse Kinematics and select the chain you wish 
to disable. You can also open the Hierarchy Editor and check 
and uncheck the boxes next to each IK chain in the list to enable 
and disable IK.
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Chapter 32: The Setup 
Room

The Setup room is one of Poser’s most powerful features. It 
allows you to modify existing props or figures, or even create 
your own for use with Poser.

The Setup room allows you to fully rig new figures by creating 
and setting up joints, hierarchy groups and IK chains. It allows 
you to create these elements in a graphical environment, rather 
than having to manually edit a configuration file in a text-based 
environment.

When the Setup room opens, it displays many of the controls 
that you will need to create poseable figures. Depending on 
the size of your workspace, you may see the Camera controls, 
Joint Editor, Editing tools, Parameters/Properties palette, or 
Hierarchy Editor in this room. Of particular importance is the 
Bone Tool, which allows you to graphically create a skeleton for 
your figures.

The number of palettes and options that you see 
in each room depends upon your screen 

resolution. At higher resolutions, the default work 
spaces display more palettes, while at lower resolutions 
you see fewer palettes.

 The Setup Room.

The Setup room is an extremely powerful tool 
that can permanently modify your figures, 

including those originally included with Poser. Always 
save your figures to the Library palette to prevent 
inadvertently damaging one of your existing figures and 
to enable you to return to a previous figure setup if you 
choose to. This will also help you keep your figures 
organized and easy to find.
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Avoid losing your work! Be sure to save your 
work frequently and possibly to different files in 

case you run into problems.

Creating Figures for Poser
Figures do not have to be anthropomorphic (human-shaped). A 
figure’s mere appearance has no effect on how it functions within 
Poser. In reality, there are two things that determine how you 
can move and animate a figure:

• The figure’s underlying skeleton (called a bone structure), 
which determines the hierarchy and location of joints.

• The manner in which the figure’s polygons (the rough 
equivalent of skin and muscles) are grouped or attached to 
the bones.

Prior to the release of the Pro Pack add-in for Poser 4, figure 
creators pre-grouped OBJ models into specifically-named body 
parts, and then used a text-based method to convert them into 
poseable figures. While Poser still supports this method of figure 
creation, the graphical Setup room can eliminate 90% of your 
figure creation time. This room allows you to create/modify 
Poser figures in a completely graphical environment.

There are three ways to make figures for Poser:

• Using hierarchy files combined with an external model

Figure creators wishing to create Poser figures 
using the text-based method should refer to the 

“Appendix D: Creating and Converting Hierarchy Files” 
on page 871, which covers the text-based figure 
creation method in detail.

• Using the hierarchy palette (discussed in “About Groups” 
on page 690) to combine props together to form a figure.

• Importing a geometry and using the Setup room as 
discussed in this chapter.

About the Setup Room
The actual process of creating a poseable figure involves a 
greater number of detailed steps, each of which is discussed 
in this chapter. Briefly, the Setup room figure creation/
modification process is as follows:

1. Use props that are included with Poser, or create the 
geometry for your new figure in your favorite 3D modeling 
application.

2. Import your geometry as a prop using the File > Import 
command. Once the geometry is complete, enter the Setup 
room.
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3. Create and/or modify your figure’s bone structure or 
skeleton. Like a real skeleton, your figure’s skeleton is the 
underlying framework that determines where bends occur. 
You can import a skeleton from a similar figure or create 
your figure’s skeleton from scratch.

4. Position the skeleton and joints to match your figure. This 
step is critical to ensure that your figure bends as accurately 
as possible.

5. “Put meat on the bones” by grouping the various portions of 
your figure and assigning bones to those groups.

6. Fine-tune the figure’s joints, and then exit the Setup room 
to test your new figure and complete the figure creation/
modification process.

7. Assign IK chains using the Hierarchy Editor, set favored IK 
angles and joint limits, and memorize this information.

8. Readjust your figure’s joints if necessary, and then save your 
new figure to the Library palette.

Exiting the Setup room during the figure 
creation process may cause you to lose some 

recent changes. A warning will appear if exiting the 
Setup room will cause data loss.

The Setup Room Interface
The Setup room interface is designed to be similar to the Pose 
room interface and functionality, with a few minor changes:

• You cannot pose the figure you are creating while in the 
Setup room. Instead, the figure’s bone structure (if any) 
appears in the Document window, allowing you to position 
and adjust each bone.

• While in the Setup room, loading a figure from the 
Library palette loads the selected figure’s bone system and 
applies it to the current object. Geometry is altered when 
switching between the Pose and Setup rooms. While in 
the Pose room, each body part is treated as a separate 
geometry object. While in the Setup room, all of the body 
parts are combined into a single object for easier grouping 
and welding operations. Clicking the Create New Figure 
button in the Library palette loads the selected figure’s bone 
structure for modification and use on the figure you are 
creating or modifying. You can also double-click the figure 
to load its bones.

The following sections explain the figure setup process in detail.
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Setting Up an Original Figure

Step 1: Importing/Arranging Geometries

Begin the figure creation process by inserting the prop(s) you 
wish to assemble into a figure. Do this by adding props to your 
scene using the Library palette and/or by importing geometry 
objects (static mesh objects or props). If using more than one 
prop, be sure to arrange your props in their final positions before 
beginning the figure conversion process.

Please refer to “Importing Files” on page 777 
for information on importing geometries into 

Poser.

In order to be rigged, you need to create your 
geometry properly and assign each body to a 

unique Material Group; otherwise the geometry won’t 
be treated as a separate body part. Group names for the 
Alyson and Ryan figures are listed in “Poser Figures 
Hierarchy” on page 695.

Step 2: Loading and/or Creating Bone 
Structures

This section describes what bone structures are, what they do, 
and how to create/modify a bone structure for your imported 
geometry or figure.

About Bone Structures

Each Poser figure includes hierarchy and joint information that 
together determine how the figure behaves when posed. The 
Setup room expresses this information as a bone structure or 
skeleton that is tailored to each figure. Skeletons are a critical 
part of your figures because they define where and how the 
figure bends, just as your own bones define how and where 
you bend. Skeletons provide the following information for each 
figure:

• Defining the figure’s hierarchy: The skeleton defines the 
parent/child relationships in your figure. Please refer to 
“Poser File Types” on page 848 for information about 
hierarchies within Poser.

• Locating joints: Just as with your own skeleton, your figure 
will only bend at joints, which are the places where bone 
ends meet.
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• Limiting figure movement: By now, you are keenly aware 
that each joint in your body has a limited range of motion 
under normal circumstances. For example, your elbow only 
bends in one direction and cannot flex beyond straightening 
your arm out, your wrist can move in any direction within 
a narrow cone, and so forth. You can define limits for each 
of your figure’s joints. These limits can prevent you from 
creating unnatural looking poses, one part of the figure 
crossing through another part, etc.

• Figure resolution: The more bones your figure’s skeleton 
has, the greater degree of flexibility (resolution) it will 
have. For example, the Andy figure allows you to bend the 
shoulder, elbow, and wrist, but not the palm or fingers. By 
contrast, the Ryan figure lets you adjust the precise position 
of each finger.

• This image shows Andy’s left hand and underlying bone 
structure on the left, and Ryan’s left hand and bone 
structure on the right. Note that Andy has only one bone to 
define his entire hand, while Ryan has a far more realistic 
bone structure complete with palm and fully articulated 
finger joints.

 Bone structures of a simple hand and a more complex human hand.

Bones appear as light gray pyramids with the 
bases pointing towards their parents and the 

tips pointing towards the children. Selected bones 
appear red.

About Creating a Bone System

There are two basic scenarios for creating or editing a bone 
system:

• Modifying an existing figure: If you have a figure loaded 
when you enter the Setup room, the current figure’s normal 
bone system will automatically be loaded, and the separate 
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body parts will be combined into a single object for easier 
manipulation while in the Setup room.

• Creating a new figure: You enter the Setup room with 
a geometry (prop) selected. You can then load a bone 
structure from an existing figure by selecting the desired 
figure in the Library palette and clicking the Change 
Figure button. Or, you can use the Bone tool to create a 
fully customized bone system. You can also combine these 
methods by loading a bone structure and using the Bone 
tool to make modifications. The Bone tool appears in the 
Setup room workspace with the other Editing tools.

 The Bone Tool.

The following sections discuss selecting a bone system for your 
geometry and using the Bone tool.

Selecting the Proper Structure

The quickest way to define a bone structure for your new figure 
is to load the bone structure of a figure that resembles your 
current object as closely as possible. For example, the simple 
geometry shown below does not require a high-resolution 

bone structure, since it does not have fingers or other detailed 
features. If you are creating an animal figure, you should 
probably load an animal figure’s bone structure. The basic idea is 
to minimize the amount of work you have to do.

 Selecting an appropriate bone structure.

In the above graphic, the positions of the bones 
match the corresponding portions of the 

geometry. If the skeleton does not match the figure, you 
can position the bones as discussed in “Positioning the 
Bones” on page 710.
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Inserting & Deleting Bones

The Bone tool lets you create bones, either within a bone 
structure or from scratch. To create a bone, click at the point 
where you want the bone to begin (base) and drag to where you 
want the end (tip). You can fine-tune the bone’s position and 
parameters later, so you do not need to worry too much about 
being perfect.

 Adding bones to a figure.

New bones are created as children of the most recently selected 
or created bone. You can select a previously created bone (or any 

bone in the skeleton) and add new child bones by single-clicking 
the bone you wish to use as a parent and then clicking and 
dragging to create a new bone as described above.. The graphic 
shows a new bone inserted between the hip (parent) and thigh 
(child).

Bones can be selected as follows:

• In the Hierarchy or by clicking on the bone with the Bone 
tool selected

• Via the Actor selector in either the Properties palette or the 
Setup room Preview tab

To delete a bone, simply select it and press [DEL].

Positioning the Bones

Now that your bone structure is built to match your geometry, 
the next step is to align the bones with the geometry. Unless you 
have already built a bone structure for a figure and have simply 
tweaked the geometry slightly, the chances are that the default 
bone positions will not line up with the geometry, as shown 
in the graphic on the right. The figure on the left illustrates 
the effects of having a bone structure that is not positioned 
according to the geometry, while the figure on the right 
demonstrates proper figure behavior.
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 When bones are not positioned correctly, body parts can appear 
distorted.

You can position bones using any of three methods:

• Select one of the available Editing tools (Rotate, Twist, 
Translate/Pull, Translate In/Out, or Scale) and position the 
bones using the mouse.

• Use the Joint Editor palette to precisely position joints.

• Use the Symmetry control (see “Symmetry” on page 216) 
to position the bones on the opposite side of the figure.

You will probably use a combination of all three methods as 
you work to position the bones on your geometry. The following 
sections discuss each of the three methods in detail.

Positioning Bones With the Mouse

You can position bones with the mouse in one of two ways:

• Selecting the desired Editing tool followed by clicking in 
the middle of a bone uses the selected tool to modify the 
position of both the selected bone, all of its children, and 
all joint settings for both the current bone and all children 
(including falloff zones). Please refer to “Creating and Using 
Falloff Zones” on page 731 for an explanation of falloff 
zones. This Selecting, clicking and dragging into position is 
the preferred method.

• Clicking near the beginning or end of a selected bone allows 
you to translate just the selected endpoint regardless of the 
selected Editing tool. The mouse pointer changes to a bull’s 
eye when you select a bone and place the pointer near the 
beginning or end of the selected bone, as shown.
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 Adjusting bone placement.

When editing bone endpoints, joint settings such as falloff 
zones are not adjusted. This method is good for making minor 
adjustments once the bones have been placed near their final 
positions. After you have properly aligned the skeleton to the 
geometry, you can adjust the falloff zones further. Please refer 
to “Creating and Using Falloff Zones” on page 731 for an 
explanation of the various types of falloff zones.

When positioning bones using the mouse, you 
should use one of the orthographic cameras 

(Left, Right, Top, Bottom, Front, Back) to ensure that 
you are only positioning them in one plane at a time. 
Alternatively, you can use the Document window’s 
multiple pane view to position the bones in 3D space.

Positioning Bones With the Joint Editor Palette

• In addition to (or instead of) using the mouse to position 
bones, you can use the Joint Editor palette by selecting the 
bone you wish to edit. Please refer to “Chapter 33: Working 
with Joints, Weights, and Skinning” on page 719 for 
complete information on using the Joint Editor palette.

Positioning Bones Using Symmetry

Assuming your imported geometry is symmetrical, you can 
drastically reduce the amount of time it takes for you to position 
bones by positioning only those bones on half of the geometry 
and then using the Symmetry tool to automatically position the 
rest of the bones. Please refer to “Symmetry” on page 216 for 
information on using the Symmetry tool.



Poser Pro 2014
Reference Manual

713

Chapter 32: The Setup Room

The Symmetry functions involving arms, legs, 
and the torso only work when the bones in those 

regions have been named and grouped so as to belong to 
the selected areas of the geometry. If you have loaded an 
existing bone structure for use with your current 
geometry, the bones will already be named for you.

When you select a symmetry function, a dialog box appears 
asking if you wish to copy the joint zone setup as well. Click Yes 
to apply the symmetry to the bone structure.

Step 3: Naming the Bones

The Properties palette allows you to modify the following 
settings:

• Internal Name: You can modify a bone’s internal name 
while in the Setup room by entering your desired name in 
the Internal Name field. Poser uses internal names to find a 
group of polygons with a matching name. It is best to begin 
with an existing bone structure when creating figures so that 
you can start the process with a set of bones that already 
have standard internal names. You can, of course, create 
figures using custom internal and group names; however, 
this makes the process more difficult since you need to track 
the internal names and the portions of the skeleton and 
geometry they correspond to.

This is a critical point. The only way to link a 
bone to a group of polygons is to have them 

share the same exact internal name. The only place to 
modify internal names within Poser is in the Setup 
room, and then, only in the Properties palette.

If you want your figure to support many of 
Poser’s features, you should respect the bone/

body part internal naming conventions precisely. Group 
names for the Alyson and Ryan figures are listed in 
“Poser Figures Hierarchy” on page 695.

• Name: The Name field is where you input your desired 
external name, which you use for your own reference. 
You can use any name you wish. This can be helpful if, for 
example, you are working in different languages.

Any other displayed options do not affect bones 
and should be ignored.

Step 4: Attaching Bones to Geometry Parts

This is the part of the Setup room figure creation process where 
you associate (group) bones with portions of the geometry, 
giving your geometry the ability to bend and move. It is 
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important that you take great care during this step to ensure that 
your new figure will be able to bend and, just as importantly, 
bend correctly.

Your geometry consists of many polygons that together form its 
overall shape. At this point, Poser knows the skeleton, including 
its joints, parents, and children. It knows that moving one bone 
will affect its children and may affect the parent, and it knows 
how each joint should behave. However, Poser does not yet 
know which polygons need to move for any given movement 
of the skeleton. To enable your geometry to bend, you must 
combine logical subsets of the polygons that make up your 
geometry and group each subset with the appropriate bone.

Where you need to be careful is in being sure that the correct 
polygons are assigned to the correct bones, that is, the right arm 
should move when you move the right shoulder bone, and so 
forth. It is possible to assign any polygon to any bone. You could 
have polygons in the leg region grouped with a bone in the neck, 
for example. You could even have random polygons scattered 
around the geometry grouped with any bone in the skeleton. 
While you may wish to do this for experimental or artistic 
purposes, this manual will assume that you are trying to create a 
realistic figure from the geometry and skeleton.

Now that the skeleton is complete, it is appropriate to think of 
each bone as a body part. For each such body part, an identically 
named group of polygons on the geometry must exist. Each of 
the joints will cause the grouped polygons to bend where parent 

and child groups touch. Poser knows which polygons to bend by 
matching the internal name of the bone being moved with the 
internal name of a group of polygons.

If you are adjusting an existing figure in the 
Setup room, the necessary body groups will 

already exist and may already be properly set up.

To create groups, select the Grouping tool, which opens the 
Group Editor palette. The Grouping tool can select polygons to 
create a group. Then you can use the Assign Material button to 
assign a name for the body part for the selected polygons.

Requirements

As discussed in “Importing 3D Objects” on page 779, your 
imported geometry cannot have overlapping or duplicated 
polygons and, if you have created groups when you built the 
geometry, the polygons in the geometry cannot belong to more 
than one group at a time.

The Setup room allows you to create figures from a single 
geometry consisting of ungrouped polygons. This is the 
recommended method.

Grouping

There are a number of different ways that you can assign groups 
to your figures. For example, some assign groups in their 
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modeling application or with other utilities. You can, however, 
use Poser’s Group Editor to create and assign groups to the 
polygons in your model. The Group Editor allows you to select 
polygons manually and then assign them to groups. If your 
figure does not already have groups assigned, you can also use 
the Auto Group feature to automatically generate groups based 
on the bone structure of the skeleton. For further information, 
refer to “The Group Editor” on page 681 for information about 
using the Grouping tool and the Group Editor palette.

Step 5: Assigning Rotation Orders

With your bones positioned and your groups created, you’re 
almost finished. Your once-static geometry has come alive! You 
can perform this step when you are first creating and defining 
joints; however, it appears here in the figure creation process 
so that you can leave the Setup room to see how changes to the 
rotation order affect your figure’s motion and appearance.

If your figure uses a standard T-position pose, and also is 
grouped similarly to the standard Poser figures, you can use 
the Hierarchy Editor to assign standard rotation orders to the 
joints in your figure. This can save time in setting up the joint 
rotations. You can learn more about configuring rotation orders 
manually in “Setting Joint Orders” on page 741.

To apply standard rotation to a figure:

1. Choose Window > Hierarchy Editor to display the 
Hierarchy Editor.

2. Select the Universe.

3. Click the Apply Std Rotation Order button to apply the 
standard rotation settings.

Step 6: Fine-Tuning Joints

At this point, you may want to go back and fine-tune some 
or all of your joints so as to make your figure behave exactly 
as you want it to. Do this using the Bone tool and/or Joint 
Editor palette as discussed in “Chapter 33: Working with 
Joints, Weights, and Skinning” on page 719. Use spherical 
or capsule-shaped falloff zones, or weight painting, to add more 
realism to the appearance of the joints as they rotate, bend, and 
twist.

Remember that joint bending only occurs between an object 
and its parent. The bends do not progress to other children or 
above the parent in the hierarchy. Be sure to keep this in mind 
as you tweak the joints. Also, if you have body parts which are 
symmetrical left to right, and are named using the convention 
of starting with “r” for right-side body parts and “l” for left-side 
body parts, you can automatically copy joint zones by using one 
of the symmetry commands as discussed in “Symmetry” on page 
216. This can save time and effort when tweaking joints, and 
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ensures that one side of your figure will behave exactly like the 
other part.

Step 7: Testing Your Figure

This is the moment you have been working towards. At this 
point, return to the Pose room and put your new figure through 
its paces. You can use multiple view panes and the Camera 
controls to see your figure from all angles to ensure that it is 
performing as expected. If you need to make any adjustments, 
you can always return to the Setup room to further refine your 
figure. Congratulations: Your once-static geometry prop is now a 
moveable Poser figure!

Step 8: Assigning IK Chains

In order for you to be able to use IK on your new figure, you 
need to create at least one inverse kinematics chain using the 
Hierarchy Editor, as discussed in “About Groups” on page 
690.

You created the parent/child hierarchies in your 
figure when you created and edited the bone 

structure. The Hierarchy Editor will perform all of its 
functions on your new figure.

Step 9: Inverse Kinematics

If you wish to add IK capabilities to your figure, you need to add 
IK chains as discussed in “Creating IK Chains” on page 701.

Step 10: Setting & Memorizing Favored IK 
Angles

Poser’s inverse kinematics works based on the current rotations 
of a body part. Proper IK angles must be preset in the figure 
in order for IK to work predictably. The original joint rotation 
values help the IK logic know which way to bend some of the 
joints and will affect how the IK works as the figure moves. 
Setting and memorizing favored IK angles is therefore 
important.

Before memorizing the default positions for all of the body 
parts, you should bend the parts used in IK chains so that they 
favor their natural bending directions. For example, a standing 
person’s thighs bend slightly forward and out from vertical, and 
her or his shins bend slightly back and in.

These positions can be tested by lowering the hip joint in the Y 
(up/down) direction while IK is turned on for the legs. While 
doing this, the knees should bend smoothly, and not buckle or 
swing widely to either side.

Then, to test the arms, enable IK on the arms and move the 
chest side to side (X trans). The arms and shoulders should bend 
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naturally. If they do not, add small amounts of rotation into the 
joint to correct the unnatural bending.

With IK off, return the hip to zero and the chest to zero. Preserve 
the rotations on the limbs. Make sure that they are symmetric 
from one side to the other. Then memorize figure to store the 
rotations.

To set favored IK angles:

1. Disable the affected IK chain(s).

2. Position each body part in the chain by slightly bending it in 
the direction it would bend under IK by a few degrees.

3. Save the angles by memorizing the body parts or the entire 
figure by selecting Edit > Memorize > Element or Edit > 
Memorize > Figure, respectively.

4. Enable the affected IK chain(s).

Please refer to “Inverse Kinematics (IK)” on page 177 for 
more information about Poser’s Inverse Kinematics features.

Step 11: Setting Joint Limits

In the “real world”, each of your body’s joints has limits on its 
motion. For example, you cannot extend your arm at the elbow 
beyond the point where your arm is straight. Further, it is not 
possible for one of your body parts to “collide” or intrude on 

another part. You cannot simply put your hand through your 
chest.

Poser allows you to set limits for each joint to mimic these 
natural limits and help prevent you from creating unnatural 
poses. Additionally, you can create limits on the amount that a 
body part can be scaled and tapered, and you may have other 
options available depending on the body part in question.

It’s good practice to set limits per parameter for 
your figures. The user can then choose to use or 

ignore your limits using the Figure pull-down menu by 
toggling the Use Limits command on or off.

To set limits for a body part, simply select the desired body part, 
then double-click any of the parameter dials in the Parameters 
palette to open an Edit Parameter dialog box, where you can 
set limits for the selected parameter. Please refer to “Editing 
Parameter Dials” on page 201 for information on setting 
parameter limits.

Step 12: Finalizing Your New Figure

At this point, you have created and fine-tuned a new Poser 
figure. From a technical standpoint, the figure creation process is 
complete. If you wish, you can add materials and textures, make 
additional adjustments, and do anything you need to do in order 
to consider the project complete.
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You can also add morphs or use deformers that 
smooth areas like knee and elbow bends and link 

these morphs or deformers to the arm/leg bends as 
dependent parameters. For more information, see 
“Using Dependent Parameters” on page 666.

Step 13: Memorizing and Saving Your New 
Figure

You have hopefully been saving your figure throughout the 
creation process. Now that it is complete, be sure to memorize 
the figure by selecting Edit > Memorize > Figure. Also, be sure 
to save your figure in the Library palette. You can save your 
figure in an existing subcategory or create your own.

Deleting Interim Figures

If you have saved draft figures as recommended during the figure 
creation process, you may want to delete these draft figures to 
avoid wasting hard drive space. To delete an item, select it in the 
Library palette and click the Delete from Library icon (-) at the 
bottom of the palette.

Troubleshooting
When creating a new figure from an existing figure, there may 
be existing parameters that no longer function properly with the 
new geometry. For instance, morph targets that used to work on 
the old figure may do nothing if you change the geometry. You 
can delete these channels in the Hierarchy Editor by checking 
the Show Parameters box, selecting the parameters to delete, 
and pressing [DEL].
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Chapter 33: Working 
with Joints, Weights, and 

Skinning

What are Joints?
A joint is location on a figure where two body parts meet at a 
point where they bend, twist, rotate, or bulge: for example, a 
human knee or an elbow is a joint. In Poser, these realistic figure 
movements are controlled by joint settings. These joint settings 
are applied through various options in the Joint Editor.

Poser’s traditional joint system utilizes the following:

• Spherical falloff zones that use inner and outer spheres of 
influence to determine which vertices move when a joint is 
rotated, and the amount of movement the vertices move.

• Capsule-shaped falloff zones that work similarly to spherical 
zones, but which allow more flexibility in defining the 
shapes of the inner and outer zones of influence.

In addition to the traditional falloff zones, weight-mapped 
bending controls offer increased flexibility in how vertices 
respond to movement. By providing both traditional and 

weight-mapped methods, Poser offers a three-fold solution that 
allows you to use traditional falloff zones, weight maps, or a 
combination of both. You get the best of both worlds!

  A joint shown in the Joint Editor.

Using the Joint Editor
Poser makes a figure “poseable” through the use of transformers 
and transformation zones that control the way a figure bends 
and twists. These transformers and their zones skew, rotate, 
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stretch, or scale polygons that fall within a transformation zone 
to produce the desired motion.

You can use the Joint Editor to manipulate joints and blend 
transformers directly, thereby modifying how a joint or bone 
works. The Joint Editor is used to accomplish the following:

• Fine-tune the blending of existing figures to suit your needs.

• Create new types of effects in how the polygons in the 
current part respond to transformations.

• Customize joints and transformers when creating your own 
figures (such as using the Setup room, described in “Chapter 
25: The Face Room” on page 518).

To open the palette, select Window > Joint Editor. This palette 
can be used in the Pose Room and in the Setup Room. When 
used in the Pose room, the Joint Editor allows you to adjust the 
currently selected joint. When used in the Setup room, the Joint 
Editor allows you to adjust the currently selected bone.

Parts of the Joint Editor

The Joint Editor displays the various components of the selected 
joint. For example, if you have the right shin selected, the Joint 
Editor will display the settings related to the knee (the point at 
which the right shin begins).

The Joint Editor displays the following options and controls, 
depending on the joint that you have selected:

  The Joint Editor.

• Affected Actors menu: Use this menu to select additional 
body parts that you want to be affected by the parameter 
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that you are editing. For more information about affected 
actors, see “Adding Affected Actors” on page 743.

• Attribute selector: Use the Attribute selection menu to 
display and edit the settings for a specific attribute. For 
example, when you have the right shin selected, you can use 
the menu to choose one of the following attributes: Center, 
Twist, Side-Side, or Bend. In addition, there will be a couple 
of additional settings that relate to the body part that is 
immediately below the current part (its child). In the case of 
the right shin, the child attributes would relate to the right 
foot. In most cases, the attributes for the “child” part are left 
alone when editing the current joint.

• Parameter dial and value: When you choose an attribute 
that has a Parameters dial associated with it, a dial will 
appear in the Joint Editor. You can use this dial to adjust 
the parameter through its minimum and maximum values 
to test how the current joint settings affect the mesh.

• Display Options. Allows you to show or hide various 
display options for the selected transform:

 � Deformer: When checked, will display the deformers (if 
any) that are associated with the selected joint.

 � Verts: Shows or hides the display of colored dots that 
give you a visual indication of how the vertices and 

polygons will be affected when you adjust the joint 
settings.

 � Shaded: Enables shaded display mode for sphere 
or capsule zones of influence. Inner mat spheres or 
capsules are shaded green, and outer mat spheres or 
capsules are shaded red.

  A chest joint with verts and shaded display.

• Falloff Zones: There are three types of falloff zones: 
Spherical Zone, Capsule Zone, and Weight Map. Each 
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of these will be described in “Creating and Using Falloff 
Zones” on page 731.

• Joint Angles setting: This section displays or edits the 
inclusion and exclusion angles, which determines which 
vertices and polygons are included or excluded in the 
current transform. Further information can be found in 
“Setting Joint Angles” on page 740.

• Bulge Settings: Allows you to add additional settings 
that specify how polygons bulge and flex while the joint is 
moved. See “Editing Bulge Settings” on page 741.

• Joint Orders: Allows you to set the order of the X, Y, and 
Z axes, and the types of rotation that they relate to. See 
“Setting Joint Orders” on page 741.

• Scale Zones: Click this button to create weight maps that 
smooth out the transitions between joints when the joints 
are scaled along a single axis. For more information, see 
“Smoothing Scale Zones” on page 755.

• Zero Rotations button: As you are working with all of the 
joints in your figure, you may have one or more rotations 
(bend, twist, side to side, and so on) set to values other than 
zero. Click this button to return all of the joint rotations 
back to their zero values, which returns the figure to its 
normal “default” position.

  The Joint Editor: Weight Painting Controls.

How Joints are Displayed

When the Joint Editor is opened, there are several indicators 
that appear when a body part is selected. These indicators help 
you control how the joint works and responds when you pose the 
figure. Each of these indicators are described below.
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Deformer Indicators

Depending on the type of attribute selected you will see a 
different type of indicators for the joint. The following figure 
shows the types of indicators that appear when Center, Twist, 
Side-Side, Bend, and neighboring joint indicators are selected. 
You can use the handles on these indicators to visually adjust 
the joint attributes, or you can use numerical fields in the Joint 
Editor to change them. Each of these attributes will be discussed 
in “Copying Joints from Another Figure” on page 725.

 Joint Attribute Indicators.

Joint Strength Indicators

The Joint Editor allows you to control joints and blend zones. 
Blend zones define how the area that transitions from one joint 
to another react when they bend, twist, or rotate. As you work 
in the Joint Editor, you will notice that the selected body part 
is covered with different colored dots. The color of these dots 
represent where a joint parameter or falloff zone has the most 
amount of effect.

In the figure shown below, a figure’s right shin is selected as the 
current body part, and the Bend parameter is the parameter that 
is being edited. The joint is placed at the right knee. Notice the 
multi-colored dots which show how the joint affects the selected 
body part:

• Bright green dots appear where the joint or zone has the 
greatest effect. In other words, when you bend the right 
shin, the entire area that is covered with green dots will be 
affected by the bend.

• Red dots appear where little or no effect occurs. In other 
words, when you bend the right shin, the right thigh (which 
is above the shin) will not be affected.

• Yellow dots appear where there is a blend between the 
moving part (the shin) and the stationary part (the thigh). In 
other words, when the right shin is bent, the polygons that 
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are highlighted with yellow dots will stretch or squash or 
skew to make the transition as smooth as possible.

 The strength of a joint is represented with green, yellow, and red 
dots.

Editing Joint Parameters

To edit a joint’s parameters:

1. Select the desired joint in the Pose Room.

2. Choose Window > Joint Editor to open the Joint Editor.

3. Use the Selection menu to choose the attribute that you 
want to edit. Each joint will have several parameters and 
will include some of the following: Center, Twist, Bend, 
Side to Side, Front to Back, or Up and Down. These 
attributes are further described in “Copying Joints from 
Another Figure” on page 725.

4. Use the Falloff Zones section to add additional deformers 
that can affect the selected attribute. If no deformers exist, 
click the Add button to add one or more. You can add one of 
three types of transformers: Spherical, Capsule, or Weight 
Map. These will be described further in “Creating and Using 
Falloff Zones” on page 731.

5. The section beneath the Falloff Zones section shows 
numerical values for the currently selected joint attribute. 
You can either change these values manually, or by making 
adjustments to the deformers in the document window. 
For example, if you are displaying the Twist attribute, you 
can enter values for Twist Start and Twist End in the Joint 
Editor, or you can click and drag the ends of the Twist 
indicator in the document window to make adjustments 
visually.
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6. If the joint attribute allows, optionally enter Bulge Settings 
that make the selected body part bulge more realistically 
when the parameter is adjusted. These are discussed in 
“Editing Bulge Settings” on page 741.

7. Set the Joint Order as described in “Setting Joint Orders” 
on page 741.

8. When you are finished setting all of the joints, you can use 
the Zero Figure button to return the character to its default 
position, and then save the figure to your library.

Copying Joints from Another Figure
If you are creating a character that has similar size and 
proportion to another figure, you can copy joint settings from 
one figure to another. In most cases, this is only necessary when 
you are developing an original figure, and have made changes in 
the rigging of one version of the model (a low resolution version, 
for example) and want to apply the same changes to another 
version of the model (a high resolution version).

1. Load two figures into the scene :

 � The source figure (ie: the figure you want to copy 
joints from), such as a low-resolution human character.

 � The target figure (the figure that you want to copy 
joints to, such as a high-resolution version of the same 
human character.

2. Select the target figure.

3. Choose Figure > Copy Joint Zones From. The Copy Joint 
Zones dialog appears.

4. Choose the figure from which you want to copy the zones 
(the source figure), and then click OK. The joint zone 
settings will be applied to the target figure.

Joint Attribute Types
Each joint in a figure’s bone structure has some or all of the 
following attributes. The attributes available for each joint 
depend on the currently selected joint. You can think of the Joint 
Editor palette as working with body parts or bones, since the end 
result is the same. For the sake of discussion, it is appropriate to 
think of the Joint Editor palette as acting on body parts when in 
the Pose room and bones within the Setup room.

This section explains how to adjust each available joint 
parameter. Note that not all parameters will be applicable to 
every joint. Only those parameters applicable to the selected 
joint will appear in the joint editor.
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Center

The Center attribute sets the center of rotation for the selected 
bone. It is available for all bones, body parts, and props.

Hold your arm out with the palm up, bend it at the elbow, and 
notice that the center of the rotation is about halfway between 
your inner and outer elbow. Notice how your skin contracts 
above the center of rotation and expands beneath it. Imagine if 
the center of rotation was in a different location and how that 
would affect the appearance of your arm as you bend it. Move 
some other joints and imagine the changes that might occur 
if you shifted those centers. The Center attribute controls this 
aspect of joint motion.

 Center attribute and settings.

The following options are available when adjusting the Center 
joint parameter:

• Center Point: The Center Point attribute defines the XYZ 
position of the joint (center of the body part). 0,0,0 is 
located in the center of the bone structure on the floor.

• End Point: The End Point attribute is discussed in “End 
Points”, which follows.

• Orientation: The Orientation attribute defines the XYZ 
rotation of the joint and its axis. Click and drag the dials 
to set a value. Pressing and holding [OPT]/[ALT] while 
clicking a dial resets its value to 0.

• Align: Clicking the Align button aligns the joint with its 
underlying body part or group, and will automatically adjust 
the values in the Orientation fields (above). This option can 
be useful once you have created groups and attached the 
bones to the geometry. Prior to that point in the process, 
however, there is nothing to align the joint to.

• Joint Order: See “Setting Joint Orders” on page 741.

• Zero Figure: See “Parts of the Joint Editor” on page 720.
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End Points

If a joint has a single child joint, the endpoint will always be the 
origin of the child. If there are multiple children (as in a hand) 
the endpoint can be set manually. This feature is used for some 
of the interaction tools, such as the Rotate tool for orientation 
from the origin. If there is no child joint (as with the head, 
typically) the endpoint is also editable.

 End Point attributes.

Twist

The Twist attribute changes the location of the twist deformer 
for the selected bone.

There is no Twist attribute for the hip bone or its 
equivalent, since the hip is the parent for the 

entire figure and twisting the hip twists the entire figure 
in unison.

When IK is enabled, child bones rotate when the parent is 
twisted. Twisting the hip normally moves the entire body since 
the hip is usually the parent for the entire figure, meaning that 
the hip does not have this parameter.

Hold your arm out with the palm down, and twist it so your 
palm is facing up. Notice how most of your arm does not change, 
except for a region in your upper arm where the skin and 
muscles twist as you move. Imagine if the twisting began and/
or ended in a different location. The Twist attribute controls this 
aspect of joint motion.

By default, the Twist axis runs lengthwise down the center of 
each body part. For example, the arm twist axis is X, while 
legs twist along the Y axis. When this parameter is selected, 
a line with two handles appears on the figure. The red handle 
represents the starting point of the twist transformation area, 
and the green handle represents the end. Dragging these handles 
increases or decreases the Twist area.
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 Twist attribute and indicators.

The Twist parameter has the following settings and options:

• Display Options: See “Parts of the Joint Editor” on page 
720.

• Falloff Zones: See “Creating and Using Falloff Zones” on 
page 731.

• Twist Start and Twist End: Define the beginning and 
ending points of a bone’s twist area. Enter your desired 
values in the appropriate boxes, or drag the red handle of 
the indicator to adjust the Start value, and the green handle 
of the indicator to adjust the End value.

You can make twist areas larger than the 
selected bone, which can make a twisting motion 

appear more natural. In many cases, the bone’s parent 
should be included in the twist zone.

You can use the Editing tools to adjust the Twist 
parameter. This parameter exists in three 

dimensions, meaning you can rotate the figure to see the 
joint from any angle. You may, however, want to leave 
the figure in its default position and use the 
orthographic cameras (Top, Bottom, Left, Right, Front, 
Back) to constrain movement to two axes, possibly 
avoiding much confusion.

• Joint Order: See “Setting Joint Orders” on page 741.

• Zero Figure: See “Parts of the Joint Editor” on page 720.

Side-Side, Bend, Front-Back, and Up-Down

The joint settings for Side-Side, Bend, Front-Back, and Up-
Down are very similar. The main difference between them is the 
axis on which they rotate:

• The Bend attribute controls the angles of the Bend 
transformers, and defines how bulges are created. To 
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illustrate this, bend and flex various joints (such as your 
elbow or knee). You’ll notice limits of your flexibility, and 
how the skin and muscles bulge as you move. The Bend 
attribute lets you control how this occurs in your figure.

• The Side-Side, Front-Back, and Up-Down attributes 
control the angles of their respective transformers and also 
define how bulges are created. These attributes are suited 
for omnidirectional joints such as your wrists, shoulders, 
hips, ankles, etc. The various parameters are shown in the 
following table.

Attribute Body Part(s)

Bend All but Hip, Collars, and Shoulders

Side-Side Head, Neck, Chest, Abdomen, Waist, L & 
R Buttocks, L & R Thigh, L & R Shin, L & R 
Foot, L & R Toe, Toe1 parts, Toe2 parts, L & 
R Forearm, L & R Hand, L & R Thumb2, L & 
R finger parts (other than thumb)

Front-Back L & R Collar, L & R Shoulder

Up-Down L & R Collar, L & R Shoulder

 Bend attribute settings.



Poser Pro 2014
Reference Manual 

730

Chapter 33: Working with Joints, Weights, and Skinning

The following settings appear in the Joint Editor for Bend, 
Side-Side, Front-Back, and Up-Down parameters. Each of 
these three parameters is functionally identical when editing 
these joint attributes in the Joint Editor palette. The settings 
in the Joint Editor allow you to change their angles and 
transformers. Poser can also create bulges that emulate muscle 
movement.

• Display Options: See “Parts of the Joint Editor” on page 
720.

• Falloff Zones: See “Creating and Using Falloff Zones” on 
page 731.

• Joint Angles: Defines the polygons that are included or 
excluded from the Bend parameter. You can either use the 
Inclusion and Exclusion handles to adjust these values 
visually, or enter values in the Joint Angles fields. The area 
between the two red handles define the polygons that are 
excluded and will remain stationery. The area between 
the green handles defines the polygons that will move 
completely. The area in between a green handle and a red 
handle will “deform.” For more information, see “Setting 
Joint Angles” on page 740.

You can use the Editing tools to adjust the Bend, 
Side-Side, Front-Back, and Up-Down 

parameters. These parameters exist in three dimensions, 
meaning you can rotate the figure to see the joint from 
any angle. You may, however, want to leave the figure 
in its default position and use the orthographic cameras 
(Top, Bottom, Left, Right, Front, Back) to constrain 
movement to two axes, possibly avoiding much 
confusion.

• Bulge Settings: See “Editing Bulge Settings” on page 
741.

• Joint Order: See “Setting Joint Orders” on page 741.

• Zero Figure: See “Parts of the Joint Editor” on page 720.

Scaling

Each body part has parameters allowing you to scale the parent 
and child body parts. These settings are similar to the Twist 
parameters and follow the Twist axis of the child or parent body 
part. For example, Ryan’s Right Collar body part has scaling 
controls for the chest (parent) along the Y axis and the Right 
Shoulder (child) along the X axis.

The High End/Start and Low Start/End parameters define a 
blending area. For example, when scaling the head, you may 
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also want to scale the top of the neck to achieve a smooth fit. 
When setting these parameters, only one setting (high or low) 
is relevant. The unused parameter pair gets automatically set 
to some unrealistic number (such as 99,000 or 100,000), thus 
indicating that it is not relevant to the area you’re working on. 
Do not edit these out-of-limit settings.

Each blending zone’s end is represented in red, with its 
beginning in green. Effects can be either uniform or can use 
spherical falloff zones, discussed below.

 Scaling attributes.

Creating and Using Falloff Zones
Falloff Zones are Poser’s fundamental method of creating 
smooth bending figures by blending between two bones or body 
parts. You can use falloff zones on any type of rotation (such as 
Bend, Side-Side, Front-Back, or Up-Down). A Falloff Zone 
section appears in the Joint Editor where it is appropriate to 
use falloff zones on a joint. When a joint property can utilize 
Falloff Zones, the Joint Editor displays a Falloff Zones area that 
appears as shown in the following figure.

 Falloff Zone settings.



Poser Pro 2014
Reference Manual 

732

Chapter 33: Working with Joints, Weights, and Skinning

There are three types of falloff zones: Spherical, Capsule, 
and Weight Map (the latter being editable only in Poser Pro 
2012 and later), described in the sections that follow. Multiple 
Falloff Zones can be combined, regardless of type. You can 
blend multiple falloff zones together in a single joint. The type 
of blending can be set as Multiply, Add, or Replace in the 
Joint Editor. You can learn more about blending in “Blending 
Multiple Falloff Zones” on page 736.

Spherical Falloff Zones

When you use a spherical falloff zone, two spheres, a green inner 
sphere and a red outer sphere, represent the falloff zones.

The green sphere defines the area that is 100% affected by the 
transformation (motion), and the red sphere defines the limit 
of the transformer’s effect. The area between the spheres is the 
blending area, and the transformer’s effect gradually decreases 
from 100% at the boundary of the inner sphere to 0% at the 
boundary of the outer sphere.

In the figure shown below, the zones of the innerMat and 
outerMat spheres have been colored in for demonstration 
purposes. When vertices are displayed you can see how the 
positioning of the spheres affect the strength of the deformations 
in various areas.

 Spherical falloff zones.

You can edit spherical falloff zones just as you would any bone or 
body part using the Editing tools.

• Click the green sphere to edit the affected area. The 
Parameters/Properties palette displays its properties as the 
innerMatSphere, where you can make adjustments to its 
size, position and rotation.
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• Click the red sphere to edit the unaffected area. The 
Parameters/Properties palette displays its properties as the 
outerMatSphere, and you can make adjustments to its size, 
position and rotation.

 Spherical Falloff Zone parameters in the Parameters Palette.

The following properties can be edited for the inner and outer 
MatSpheres of a spherical falloff zone:

• Rotation: To change the rotation of the inner or 
outerMatSphere, change the yRotate, xRotate, or zRotate 

values to change the rotation along the y, x, or z axis 
(respectively).

• Scale: Use the Scale setting to uniformly adjust the scale 
along the x, y, and z axes. To change an axis as needed to 
create an ellipse, adjust the xScale, yScale, or zScale setting 
appropriately.

• Translation: To move the sphere, adjust the xTran, yTran, 
or zTran setting appropriately.

You can also use the Direct Manipulation Tool to 
adjust the rotation, scale, or translation of the 

falloff zone. For more information about this tool, see 
“Direct Manipulation” on page 191.

Capsule Falloff Zones

Capsule falloff zones provide a great deal more flexibility in 
controlling the shape of the zones of influence. The green 
and red capsules work similarly to the spherical falloff zones 
mentioned in the previous section. The green capsule defines 
the area that is 100% affected by the transformation, and the red 
capsule defines the limit of the transformation’s effect. The area 
in between the capsules defines the blending area.
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 Capsule Falloff Zone with Verts turned on.

If you choose to create a capsule zone, there are six unique 
parameters in the Parameters Palette to change the shape and 
size of capsules and how they affect the current joint. You will 
also see the Translate, Rotate, and Scale parameters which work 
similar to those described for the Spherical falloff zones.

• Click the green capsule to edit the affected area. The 
Parameters/Properties palette displays its properties as 
the innerMatCapsule.

• Click the red capsule to edit the unaffected area. The 
Parameters/Properties palette displays its properties as 
the outerMatCapsule.

 innerMatCapsule and outerMatCapsule parameters.

With the inner or outer MatCapsule selected, you will see the 
following parameters in the Parameters palette:
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• Right Length: Sets the length of the right half of the 
cylinder portion of the capsule.

• Right Radius: Sets the radius of the right end of the 
cylinder portion of the capsule.

• Right Cap: Sets the length of the cap at the right end of the 
capsule. Increases or decreases the distance from the Right 
Length.

• Left Length: Sets the length of the left half of the cylinder 
portion of the capsule.

• Left Radius: Sets the radius of the left end of the cylinder 
portion of the capsule.

• Left Cap: Sets the length of the cap at the left end of the 
capsule. Increases or decreases the distance from the Left 
Length.

The following diagram shows the parts of the capsule:

 A diagram of a capsule falloff zone.

Working with Falloff Zones

The sections that follow describe other ways that you can work 
with falloff zones.

You learned how to create a weight map in the section “Weight 
Maps” on page 746. If you want to create a spherical or 
capsule falloff zone, the steps are similar. Follow these steps:

1. Select the joint that you want to work on.

2. Open the Joint Editor, and select the appropriate rotation 
(Side-Side, Front-Back, Up-Down, or other).

3. In the Falloff Zones section, click the + (plus) sign to create 
a new falloff zone. Choose one of the following options:
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 � Add Sphere Zone: Choose this option to create a 
spherical falloff zone.

 � Add Capsule Zone: Choose this option to create a 
capsule-shaped falloff zone.

 Adding a Falloff zone.

4. Use the Editing Tools or the parameter dials to adjust 
the scale, rotation, and translation of the inner and outer 
MatSpheres (see “Spherical Falloff Zones” on page 732) 
or MatCapsules (see “Capsule Falloff Zones” on page 
733).

5. Repeat steps 1-4 to add additional falloff zones if desired.

Blending Multiple Falloff Zones

In addition to offering three types of falloff zones, you can also 
use more than one falloff zone for a joint. The Joint Editor 

provides a drop-down menu that lists the falloff zones that have 
been created for each joint. You can add one or more spherical, 
capsule, or weight map falloff zones to any joint.

For an example of using multiple falloff zones, open the Library 
and select the Figure category. From the People folder, add 
Alyson or Ryan (version 1) into your scene. In the Joint Editor, 
select the Side-Side property of the right or left Buttock. Click 
the Down arrow to display the list of zones for the currently 
selected joint. When you expand the list of falloff zones, you’ll 
see several as shown below.

 Blending falloff zones.
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The CR2 will display a list of zones that affect 
each joint. Figures that use multiple falloff zones 

or capsule zones will not be compatible with older 
versions of Poser. To create a figure that is backwards 
compatible with earlier versions of Poser, use only a 
single Spherical Zone on the joints that use falloff zones.

To change the blending method for a falloff zone, follow these 
steps:

1. Select the joint that you want to modify.

2. Expand the Falloff Zones selection menu, and select the 
sphere or capsule falloff zone that you want to change.

3. Select Multiply, Add, or Replace from the blend mode 
selection menu.

 Choosing a blending type.

Deleting a Falloff Zone

To delete a falloff zone, follow these steps:

1. Select the joint that you want to modify.

2. Expand the Falloff Zones selection menu, and select the 
falloff zone that you want to delete.

3. Click the Delete button in the Falloff Zones area of the Joint 
Editor and choose Delete Current Zone from the menu 
that appears.

 Deleting a falloff zone.

Enabling or Disabling a Falloff Zone

When a joint rotation uses multiple falloff zones, you can enable 
or disable the influence of a specific falloff zone to determine 
how that particular falloff zone affects the joint rotation. This 
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can help you make adjustments to the areas that are affected by 
the selected falloff zone.

To enable or disable a falloff zone:

1. Select the joint that you want to examine, and rotate the 
joint as necessary to determine the effects of the falloff 
zones.

2. Expand the Falloff Zones selection menu, and select the 
desired falloff zone.

3. Check the Active checkbox to enable the falloff zone, or 
uncheck to disable it.

 Falloff zone enabled (top) and disabled (bottom).

Changing Falloff Zone Display Mode

The default display mode for spherical and capsule falloff zones 
is Outline mode. However, you can display falloff zones in any 
available mode. To change how a falloff zone is displayed:

1. Select the falloff zone that you want to change.
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2. Select Display > Element Style.

3. Select your desired display mode. For example, Wireframe 
mode allows you to see the spheres’ areas of effect while 
still being able to see the underlying bones/geometry. 
Wireframe modes are recommended, as solid shaded 
modes will make it difficult to pick underlying Fall Zone 
geometries.

The following figure shows a capsule zone displayed in its default 
display mode (top), and with the innerMat capsule changed to 
Wireframe display style (bottom).

 An innerMat Capsule shown in default (top) and Wireframe display 
style (bottom).
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Setting Joint Angles
If you move any part of your body (for example bending your 
elbow), you will note that the skin on your upper and lower arms 
remains still except for the region near your elbow. Around your 
elbow, skin stretches or contracts depending on its location and 
the direction of motion. Slightly removed from the actual motion 
area, your skin and muscles move to adjust to the motion and 
preserve a smooth transition. The area between the inclusion 
and exclusion angles is called the blend zone, where Poser 
stretches, bends, and shrinks polygons to achieve a smooth 
transition between figure elements. This is the same as when 
you flex your leg and the skin in the area of your hip contracts or 
stretches as needed to accommodate the move.

Poser accomplishes similar movement transitions with inclusion 
and exclusion angles. The Bend, Side-Side, Front-Back, 
and Up-Down parameters allow you to define the inclusion 
and exclusion angles for the selected joint. The Inclusion and 
Exclusion angles control which polygons move as a result of a 
joint bending and how the body parts on either side of the joint 
blend to accommodate the move.

• The inclusion angle defines which polygons are affected by 
moving the selected joint. Using the previous example of 
bending your arm at the elbow, your entire arm below your 
elbow moves. The inclusion angle appears as two green lines 

that form an angle. In the Joint Editor, the Dynamic B and 
Dynamic C angles determine the inclusion angle.

• By contrast, the exclusion angle defines those polygons 
not affected by moving the current joint. Notice that your 
upper arm does not move if you simply bend your elbow. 
The exclusion angle appears as two red lines that form an 
angle. In the Joint Editor, the Static A and Static D values 
determine the exclusion angle.

 Joint inclusion and exclusion angle settings..

The above graphic shows the exclusion angle above the knee, the 
inclusion angle below, and the blend area in the vicinity of the 
joint itself. To edit inclusion and exclusion angles:
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1. Move the cursor to an end point of the inclusion or 
exclusion angles until the cursor changes to a target symbol.

2. Drag the angle. It is recommended that you use Full 
Tracking mode to view the effects of your changes as you 
drag. You can also enter your desired values in the text 
boxes.

You can use the Editing tools to adjust this 
parameter. This parameter exists in three 

dimensions, meaning you can rotate the figure to see the 
joint from any angle. You may, however, want to leave 
the figure in its default position and use the 
orthographic cameras (Top, Bottom, Left, Right, Front, 
Back) to constrain movement to two axes, possibly 
avoiding much confusion.

Editing Bulge Settings
Checking the Apply Bulge checkbox causes the polygons to 
flex and bulge as the joint moves, emulating the muscle bulging 
when real bodies move. If the box is checked, the polygons in 
the blend zone will be stretched or pinched to create bulges or 
wrinkles. Left and Right refers to the skeleton’s right and left. 
The positive dials control how much bulging out will occur when 

the joint moves, and the negative dials control the amount of 
wrinkling and pinching.

You can use Poser’s weight painting features to 
make bulges more realistic. See “Painting Bulge 

Maps” on page 754.

 Applying bulges.

Setting Joint Orders
The Joint Editor palette includes the Joint Order pull-down 
menu that defines the joint’s axes of rotation. The joint order is 
expressed as three letters corresponding to the X, Y, and Z axes.
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Using the Front camera position, the X axis runs 
from left to right, the Y axis runs from bottom to 

top, and the Z axis runs from the back to the front. This 
is called a right-handed coordinate system.

It is important to determine the best rotation order for each 
joint. This is an important part of getting your figure to move 
exactly how you want it to. When you create new bones with 
the bone tool, Poser takes its best guess at determining the best 
rotation order for the bone.

You can select rotation orders by bringing up the Joint Editor 
palette and selecting the desired order from the Joint Order 
pull-down menu.

 Setting joint rotation order.

 If you change joint order, you will probably 
need to readjust the joint zones on the currently 

selected bone.

Each joint consists of three separate joint primitives, one twist 
and two joints. You determine the joint rotation order as follows:

• The twist primitive is always placed first in the joint order.

• Because of ordered rotation problems, it is then best to place 
the rotation axis through which the joint is most likely to 
move last in the order.

• The remaining rotation axis is placed in the middle.

For an example, consider the shin of a figure:

• A shin is vertical and twists about the Y-axis. This Y axis is 
placed first in the rotation order for the shin.

• When the shin bends, it is most likely to bend around the 
X-axis. This axis is placed last in the rotation order.

• The remaining axis is the Z axis, which is placed in the 
middle. Thus, the best rotation joint order for the shin is 
YZX.
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This may seem a little confusing at first. A good 
way to visualize the correct rotation order is to 

picture the figure facing directly towards the front of the 
Poser workspace. For each possible motion of a given 
joint imagine a line running through the center of the 
joint. For example, the shin twists along a line running 
straight up and down and rotates along a line running 
from left to right. The vertical line corresponds to the Y 
axis, and the left-to-right line corresponds to the X axis. 
It is now easy to determine the proper joint order of YZX 
based on this visualization and the requirements 
outlined above.

You can also use curve bends instead of the normal twist/joint/ 
joint bends. When you set up a joint using curves, the joint will 
have one twist and one curve primitive. The curve primitive will 
automatically bend the body part as if that part were part of a 
curved chain of objects. This feature is very handy for body parts 
such as tails or antennae.

Adding Affected Actors
By default, a falloff zone only affects the body part that it is 
directly associated with. You can add additional body parts 
or objects in your scene with the Affected Actors button that 
appears at the upper right corner of the Joint Editor. For 
example, affected actors can be very useful when applied to a 

character that has wings that would affect the shoulder, but also 
the chest and the abdomen.

Affected actors allow bends to occur beyond the range of the 
current body part. For example, if you have the character’s right 
shoulder selected, you could click the Affected Actors button 
and add the right forearm to the parts that are affected by the 
currently selected zones or weight map.

If a joint’s falloff cones or spherical/capsule 
falloff zones enclose vertices of a figure that is 

not a part of the current actor or its parent, you should 
set that part as an affected actor before you use Merge 
Zones to Weight Map to convert the falloff regions to a 
new weight map. This will apply appropriate weighting 
to all of the affected vertices and will match the influence 
of the falloff regions involved.

When you modify an existing weight map, and 
you add one or more actors for the current joint 

to affect via Affected Actors, any new vertices added to 
the weight map must be weighted manually.

To add additional parts, click the Affected Actors button to 
open the Select Objects dialog. Check any additional body parts 
or objects that you want to be affected by the falloff zone.
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 Adding Affected Actors.

After you add a body part as an affected actor, you’ll want to 
modify the falloff zones so that they also include the vertices in 
the affected actor. To illustrate why, observe in the following 
figure how the falloff zones originally look for the right shoulder:

 Original falloff zones for the shoulder.

In the following figure, the right forearm has been added as an 
affected actor to the right shoulder. When the shoulder is bent, 
you see that the vertices in the right forearm are not affected. 
This is because they are not yet included in the falloff zone for 
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the shoulder. The hand and fingers rotate as they normally 
would, because they are not set up as affected actors to the 
shoulder:

 The right forearm is added as an affected actor to the shoulder, but 
falloff zones have not yet been adjusted.

The falloff zones for the right shoulder are then adjusted to 
encompass all of the vertices in the right forearm, as shown 
below. Make sure that the zones are adjusted in all camera views.

 Adjust the falloff zones of the selected actor (the right shoulder) to 
add the vertices of the affected actor (the right forearm).

Copying and Saving Joint Settings
To copy joint settings from one side of your figure to the other, 
use symmetry as described in “Symmetry” on page 216. This 
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saves time for figure creators by allowing them to rig only one 
side and then duplicate the zone settings to the opposite side.

To save your Joint Editor palette settings, you must either save 
your scene or save the affected figure to the Library palette. 
Please refer to “Saving a Scene” on page 67 for information 
on saving Poser scenes, and to “Chapter 7: The Poser Library” 
on page 122 for information on working with the Library 
palette.

Weight Maps
Weight maps allow you to paint varying strengths on vertices 
to control how they respond to a joint rotation. You can 
either create an entirely new weight map, or combine existing 
deformers into a new weight map that completely replaces the 
spherical or capsule falloff zones.

When you choose to merge existing falloff zones 
into a Weight Map, existing falloff zones will 

remain, but will be ineffective unless or until the 
blending mode of the weight map is changed from 
Replace to Add or Multiply.

If you are going to be rigging a character from scratch, the 
easiest workflow is to rig it first the “old fashioned” way … by 
using spherical and capsule falloff zones as described in the 

previous sections in this chapter. After you get that done, you 
can collapse the falloff zones down into weight maps.

The recommended workflow is as follows:

• Set up your spherical and capsule falloff zones in the joint, 
and test them to make sure they move the joint as expected. 
See “Creating and Using Falloff Zones” on page 731.

• Add affected actors in areas where the rotation of a joint 
could extend to more than one body part, and adjust the 
falloff zones to include the affected actors. See “Adding 
Affected Actors” on page 743.

• Collapse the falloff zones into a weight map. See “Adding a 
Weight Map” on page 747.

• Refine the weight map further with weight map painting. 
See “Painting Weights” on page 750.
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 A shoulder joint showing its falloff zones.

Adding a Weight Map

After you finish setting up the spherical or capsule falloff zones, 
you can collapse them down into a Weight Map for the selected 
joint. When you click the Add button, you will see two options 
for Weight Maps:

 There are two options for creating weight maps.
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• Add Weight Map: Choose this option to add a new weight 
map in addition to any existing falloff zones that may 
already appear for the selected body part. It will work 
similarly to any other falloff zone.

• Merge Zones to Weight Map: Choose this option to merge 
existing falloff zones, including joint angles, into a new 
weight map. This is probably the most useful way to begin 
with your weight map. You will see a new weight map in the 
Zones list, but the original falloff zones will still appear in 
the list as well. The blend type for the weight map will be set 
to Replace.

You don’t have to have spherical or capsule 
falloff zones to create a weight map. You can just 

create one by selecting a body part, and then choosing 
Merge Zones to Weight Map. This will create a new 
weight map based on the existing inclusion and 
exclusion angles set for the body part. Then you can 
begin painting the weight map as needed.

 Merging existing zones into a weight map.



Poser Pro 2014
Reference Manual

749

Chapter 33: Working with Joints, Weights, and Skinning

Falloff zones are processed in the order in which 
they appear in the Falloff Zones list. Therefore, if 

you have a Spherical falloff zone at the top, a Capsule 
Zone second, and a Weight Map third, the Capsule zone 
will override the effect of the Spherical zone. Then the 
Weight Map, if set to Replace, will combine the effect of 
both the Spherical and Capsule weight maps, making 
the first two falloff zones ineffective. In addition the 
weight map will also replace the Joint Angle settings, 
making them ineffective as well. The joint angles will 
still be visible as a visual guide only.

In practice, you can configure a weight map to 
work with existing falloff zones by setting the 

blend mode to Add or Replace. However, there is no 
advantage to doing so. Falloff zones that have been 
collapsed down into weight maps work equally as well 
as the falloff zones that were initially used to create 
them.

If the previous falloff zones utilized bulge 
settings, they will still be active and you will still 

be able to adjust them in the Joint Editor.

In the Joint Editor, click the Add button, and choose Merge 
Zones to Weight Map. The weight map will be set to Replace, 

which will make the spherical and capsule falloff zones 
ineffective.

 Merging existing zones into a weight map.

Deleting Weight Maps

If you don’t like the way that the joint is bending after you create 
a weight map, you can go back and delete the weight maps if you 
have to. For example, you might learn that in some views the 
center point of the joint is not set correctly, or the inclusion and 
exclusion angles aren’t working as well as they should and you 
need to make an adjustment.

When you delete a weight map that was created from existing 
falloff zones, the original zones will work as they were originally 
designed to work. You can go back and adjust the falloff zones as 
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needed, and then create a new weight map that incorporates the 
new changes.

Activating and Deactivating Weight Maps

The weight map is always active, unless you manually deactivate 
it. If you want to see how the weight map differs from the falloff 
zones from which it was created, just uncheck the Active option 
in the joint editor. The example shown below shows how a 
weight map smooths the vertices around the ankle when the foot 
is bent downward.

 You can Activate or Deactivate a weight map to observe how it 
affects a rotated joint.

Painting Weights

After you collapse your weight maps down, you can start to 
paint. Click the Paint palette icon in the Joint Editor to display 
the painting controls. As you paint, the changes reflect changes 
to the actual edge flow and surface normals in the model, and 
not relative to the screen.

After you create a Weight Map, the Weight Painting tool is 
enabled in the Joint Editor.

When weight painting, consider the following general workflow:

• Make sure that the Active option is checked before you 
start painting. With this option off, the brushes will have no 
effect.

• Start with a smoothing brush, and start with a magnitude 
setting of 1 for larger areas, and lower the setting for smaller 
areas. Smooth the vertices in the joint, but be careful not to 
oversmooth.

• Watch your brush size. Use lower settings for tight areas, 
such as those between toes or fingers.

• After you smooth out the vertices, choose the Add or 
Subtract mode. Add will increase the weighted effect on 
the vertices, while Subtract will decrease the weighted 
effect. Darker colors (darker purple) are the least weighted 
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vertices, and solid green are most weighted. Colors in 
between have varied weights.

To paint weights:

1. Click the paintbrush icon to enable the painting tools. The 
Joint Editor shows the brush controls.

 Paintbrush tools.

2. Select a brush type from the available choices.
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3. The first brush is a hard brush with a very small radius, 
suitable for working with targeted vertices.

 � The other brushes provide varying levels of hardness 
around the edges. The default brush has a softer edge 
which provides the most effect in the center and then 
gradually falls off to little or no effect on the outer 
edges. The last brush has no falloff at all, and applies 
strength evenly across the width of the brush. There are 
five brushes in the section.

 � The fourth brush will give you the best results, as 
it has a very slight feathering to the edge. If you 

use brushes that are more feathered you may throw off 
the weight balance.

4. A wireframe preview of the brush appears in the Document 
window. You can toggle this preview on or off by checking or 
unchecking the Display Brush option in the Joint Editor.

 � The inner ring of the preview shows the area that will 
have the most effect.

 � The outer ring of the preview shows the overall width of 
the brush. You can use the Radius setting in the Joint 
Editor to increase or decrease the brush width.

5. Adjust the Magnitude setting in the Joint Editor to increase 
or decrease the strength of the brush. Decrease the setting 

to produce less of a change while you paint, and increase the 
setting to produce more of a change.

When you have the paintbrush set to Add or 
Subtract mode, pay attention to the Magnitude 

setting of the brush. Setting this too high (such as 1) will 
affect the vertices more than you want them to. It is 
recommended that you start with a low magnitude 
(around .007). Then slowly go back and forth over the 
areas you want to change.

6. Use the Parameter dial in the Joint Editor palette to pose 
the body part in something other than the default position 
(at or near one of the limits is a good place to start).
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 Pose your body part while you paint across vertices to add, remove, 
or smooth the amount of effect on the vertices.

7. Choose a method for painting. As you paint, observe how 
the changes affect the body part in that pose. The shape of 
the mesh will respond to the brush as you make changes:

 � Add will increase the effect of the polygons you paint, 
moving the painted vertices more toward the “green” 

(fully effected) color. This adds more effect to the areas 
painted.

 � Remove will decrease the effect of the polygons you 
paint, moving the painted vertices more toward the red 
(little to no effect) color. This removes the effect from 
the areas painted

 � Smooth will blend the sharp contrasts between 
polygons that are affected least against those affected 
the most.

 � Weight: The Weight brush allows you to paint weight 
vertices while targeting a specific weight value. Click the 
Eyedropper to select a vertex. The weight of that vertex 
will appear in the text field and will be used as a target. 
When you paint with the Add brush, it will increase 
the weight values that are below the target setting until 
the target threshold is met. When you paint with the 
Subtract brush, it will decrease weight values that are 
above the setting until the target threshold is met.

The Smooth mode is extremely helpful. You can 
work at higher magnitudes, and it is beneficial to 

begin your weight painting with a smoothing brush to 
smooth out the mesh.
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 Vertices move as you paint them.

8. As you are painting, use the Parameter dial to test various 
positions of the joint to make sure that the weight painting 
produces desirable results. Continue to adjust the weights 
until you are satisfied with the results as the joint is 
exercised through its limits.

9. If you want to limit your weight painting to one group, check 
the Group option below the Radius and Magnitude sliders. 
Then select the group that you want to paint from the drop-
down menu.

10.  You can confine weight painting to a selected group.

11. Click the Paintbrush icon to turn weight painting off. You 
will return to the normal Joint Editor palette.

Painting Bulge Maps

You’ll notice that there are also paint palette icons near the right 
and left bulges. For certain body parts, you’ll have to paint both 
to get the correct feel for how bulges affect the joints.
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 Bulge map weight painting controls.

As you work with a joint, you may need to switch between the 
weight map on the joint, and the weight map on its bulges.

If your weight painting gets to a point where the joint weight 
map starts to look unnatural, try adding or removing from the 
bulge weight map. Then, if the bulge weight map starts to look 
unnatural, return to the joint weight map. Switch back and forth 
between them until the joint looks natural when it is rotated.

• When working on bulge weights, the brush affects the 
weight map a little bit differently. A setting of .01 on a bulge 
map has a similar effect to a setting of .001 on a weight 
map. Use a setting of .01 on a bulge map for a nice, smooth 
workflow.

• Bulge settings must be set to a value other than 0 in order to 
use a bulge map. For any bulges that you want to use (Right 
Neg, Right Pos, Left Pos, or Left Neg), set to a value less 
than or greater than 0. The Right Neg and Right Pos share 
the same map, and the Left Neg and Left Pos share the same 
map.

• Be sure to rotate the dial to its positive and negative 
positions, and check the bulge weights in both. For example, 
if you use a bulge on the right collar when the Up/Down dial 
is at a positive setting, make sure that the joint still looks 
realistic when the dial is at a negative value.

Smoothing Scale Zones

Scale zones should be part of your character or conforming 
clothing development. The Scale Zones button, located in the 
lower portion of the Joint Editor Window, helps content creators 
improve the appearance of joint transitions when a body part 
is scaled along one or more axes. For proper operation when 
scaling weight mapped figures along a single axis, it is necessary 
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to check the scale zones on each scaling axis (X, Y, and Z as they 
apply) for each adjacent body part.

For example, let’s say you have an adult male figure (here James, 
a G2 legacy figure, is being used as an example). You want to 
change him into a dwarf character. which means that you’ll want 
to substantially change the proportions of his thighs and shins.

Users of legacy figures know that body parts can only be scaled 
“so far” before they begin to crumble where they join adjacent 
body parts. For an example, compare this figure’s “normal” thigh 
(his left thigh) to the right thigh, which is scaled to 65%. You’ll 
notice that the thigh is bunching in the locations where it joins 
the hip and the shin.

The Scale Zones button in the joint editor allows you to set 
scaling zones that improves performance when characters and 
conforming clothing are scaled. You can then add weight maps 
to the blending areas to smooth the transitions when a body part 
is scaled.

 Joint seams can bunch together when a body part is scaled along a 
single axis.

Using the same legacy figure as an example, the right thigh has 
been scaled along the Y axis. When you open the Joint Editor, 
you’ll see the normal center and rotation parameters (Twist, 
Side-Side, and Bend). But you’ll also notice scaling zones for the 
adjacent body parts ... one named rShin_ScaleY and another 
named hip_scaleY. The names of these scaling zones might vary 
from figure to figure, but they will always be preceded by the 
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name an adjacent body part plus an underscore. These are the 
joint parameters that relate to the Scale Zones feature.

 Joint seams can bunch together when a body part is scaled along a 
single axis.

The Scale Zones button at the bottom of the joint editor allows 
you to add or remove scaling zones to the currently selected body 
part. At a minimum, adjacent body parts should be selected. But 
if it is possible that the scaling can “spill over” into other body 
parts, you can add them as scaling zones as well.

To assign the scaling zones, click the Scale Zones button. The 
Select Objects dialog prompts you to choose body parts that will 
scale blend with the currently selected actor (the right thigh, in 
this case). Check any parts that you want to assign, making sure 
that the adjacent actors (the hip and shin) are included.

 Click the Scale Zones button to select body parts to blend when the 
current part is scaled.

To smooth a scaling zone, scale the body part (the right thigh 
in this example) to the desired scale. Try to anticipate the 
maximum range that you would like the scaling to work. For 
example, it’s unlikely that you will want to scale a thigh to any 
less than 65% as shown in our example.
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After you scale the part, open the menu in the Joint Editor to 
select the first scaling zone that you want to work on. In the 
following figure, the rShin_scaleY joint parameter is selected. 
This is the scaling zone, as it was named for that particular joint.

 Click the Scale Zones button to select body parts to blend when the 
current part is scaled.

When you select the scale zone, you may see No Zones in the 
Falloff Zones area (which will be the case when you are weight 
mapping a new or legacy figure that has not previously been 
weight mapped). If a weight map does not exist, you’ll need to 

create one for the scale zone. Simply use the menu in the Falloff 
Zones area of the Editor to choose Add Weight Map. Then make 
sure that the mode of the new weight map is set to Replace.

Scale zone maps have to be created for each body 
part that is connected to the currently selected 

actor. For example, if you have the right thigh of a figure 
selected, you’ll need to create scale zone maps for the hip 
and the shin. Of you have a chest selected, you’ll need to 
create scale zone maps for the right and left collar, and 
for waist or abdomen (depending on the group name 
that is adjacent to the chest).

When you copy weight maps from a character to 
conforming clothing, the scale zones should 

already be set up for you, but you will need to check the 
scale zones of each body part in the clothing to make 
sure they work as expected. Before you edit the scale 
zone weight maps on conforming clothing, select the 
BODY actor of the conforming clothing, and make sure 
that Include Scales when Conforming is checked in the 
Properties palette. Sometimes the easiest way to start a 
scale zone weight map is to collapse existing zones 
(spherical and capsule zones, if they exist) into a weight 
map and then start to smooth them with the weight 
painting tools.
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 Add a weight map to the scale zone if needed.

 Make sure the weight map is set to Replace.

With the appropriate scale zone weight map selected, you can 
begin to use the Weight Painting tools to smooth out the scale 
zone. The process is similar to that mentioned in “Painting 
Weights” on page 750.

 Use the weight painting tools to improve the appearance of the 
smooth zone (here, in progress)
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As you smooth out the current body part, you might notice that 
there are areas near the adjacent body part that you can’t get 
as smooth as you like. This is probably because it falls in an 
area that is affected by both body parts. For example, as you 
work toward the top of the thigh, you might see that you can’t 
smooth it out all the way. In that case, you’ll want to check the 
smoothing zones in the hip, and make sure that you have the 
correct smoothing zone selected (rThigh_ScaleY). Add a Replace 
weight map to it if necessary, and then use the weight painting 
tools to smooth out that area.

You will need to cross over to the adjacent body 
part and work on its corresponding scale zone. 

Select that part and verify that it has a corresponding 
weight map before you paint it. When you paint close to 
the seam lines, be careful not to overblend because it 
might create a ridge at the seam. Go back and forth 
between the two areas until you get an acceptable blend.  Adjacent body parts may also affect a scale zone. Here, the scale 

zone for the hip also affects the right thigh and should be smoothed.

To summarize:

• Scale zones should be checked for each body part in the 
figure that you are rigging.

• To determine the scale zones that you need to adjust, click 
to select a body part, and then look for joints that begin with 
the name of the currently selected body part, followed by 
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an underscore and a scale zone name (example: rThigh_
ScaleY, or rThigh_smooY)

• If there are existing sphere or capsule zones associated 
with the scale zone, collapse them into a weight map set to 
Replace. If no zone exists, create a new weight map set to 
Replace.

• Go back and forth between the currently selected body parts 
and the adjacent body parts when you smooth out the scale 
zone weight maps. Take care not to oversmooth, as it can 
create a crease at the joint.

Weight Painting Tips

• There may be times when you need to pull one vertice at a 
time. For this, set the radius of the brush very small.

• There are times that the area between an inclusion and an 
exclusion angle is very narrow when a joint is rotated to 
its maximum limit. It is very difficult to get into that area 
with the weight painting tool to smooth it out. The trick is 
to widen the distance between the inclusion and exclusion 
angle so that the body part “plateaus.” Then you can use the 
Weight Painting tool to shape the body part appropriately.

  Adjust inclusion angles when weight painting a joint in its 
maximum limits.

• Another thing that will help as you use the weight painting 
tools is to select your camera, and then go into the 
Parameters palette. Set the Hither setting to 0. This will 
allow you to zoom in as close as you have to without making 
the object “disappear” in the camera view.

• The Frame Selected and Orbit Selected controls will also be 
helpful when weight painting. Click to select the joint you 
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are working on, and then click the Frame Selected control to 
frame the camera around the selected body part. Then turn 
Orbit Selected so that the camera will orbit around that part.

Fixing Mismatched Scales
If you are working with a character that makes heavy use of 
scaling zones, you may sometimes encounter situations where 
there appears to be something wrong with the scaling in one or 
more body parts. For example, scaling the chest and could cause 
the shoulders to scale so that they cause a faulty joint between 
the shoulders and collars.

This can be due to a scaling mismatch, and it can be corrected 
with the Fix Mixmatched Scale Zones button at the bottom of 
the Joint Editor.

When you fix mismatched scaling zones, the 
order that you select the body parts and 

smoothing zones is important. The following example 
shows how you can correct the scaling zones of the right 
and left shoulders in relation to the chest.

To fix mismatched scale zones in the shoulders, for example:

• Open the Joint Editor.

• Click to select the character’s chest.

• From the parameter list at the top left of the Joint Editor, 
choose the smoothing zone that you want to fix (such as the 
right collar zone as shown in the following figure).

 Choose the first smoothing zone that you want to fix.

• The Fix Mismatched Scale Zones button at the bottom of 
the Joint Editor palette will be enabled if there is a problem 
with the scaling zones. Click the button to correct the 
problem in the selected smoothing zone.
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 If enabled, click the Fix Mismatched Scale button.

• Now, click on the figure to select the opposite body part (the 
left collar in the figure).

• Go to the menu at the upper left corner of the Joint Editor 
again, and select the smoothing zone for the Chest.

• Click the Fix Mismatched Scale Zones button at the 
bottom of the Joint Editor palette to correct the smoothing 
zone between the left collar and the chest.

Transferring Zones and Weight Maps 
to Clothing
In earlier versions of Poser, content developers used information 
from the CR2 of an existing figure as a start point for their 
clothing. If an existing character has only spherical or falloff 
zones this method can still be used.

However, when weight maps are used to determine how a joint 
bends (either solely, or in addition to falloff zones), the weight 
map information is baked into the figure’s geometry. Weight 
maps are based off of vertices and index arrays that usually will 
not have a geometry counterpart in the clothing.

The Setup Room allows you to apply the rigging of a character to 
a grouped or ungrouped clothing OBJ. In the process, it will also 
transfer any spherical or capsule falloff zones. It will also analyze 
the vertices and index arrays in the character, and use that 
information to generate similar weight maps for the clothing 
geometry.

The steps to do this are fairly simple:
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1. Choose File > Import > Wavefront OBJ. Select the clothing 
object that you want to rig. This object can be pre-grouped 
in your modeling application, or it can be ungrouped.

2. The Import Options dialog appears. In most cases, clothing 
is modeled around a character that is in its default position, 
and exported at or converted to the proper scale for Poser. If 
this is the case, you should uncheck all of the import options 
as shown below. Then press OK to continue.

 Uncheck all options in the Import Options dialog if your model is 
scaled and positioned properly.

3. A dialog prompts you to locate the OBJ file that you want to 
import. After you select the object, click Open. The OBJ file 
will appear in your scene.
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 An imported clothing OBJ.

4. With the object selected as the current item, click the Setup 
room tab to enter the Setup room.

5. Open the Poser library, and click the Figures category. 
Locate the library folder that contains the original figure 

for which your clothing was designed. In the case of the 
example shown here, the Figures > Poser Pro 2014 
Content > People > Alyson folder is selected, since the suit 
is made for Alyson.

6. Drag and drop the thumbnail for the original figure from the 
Library to the OBJ file in the Setup Room. A dialog asks you 
if you want to automatically group the setup geometry based 
on the groups of the new skeleton.

 � Choose No if your clothing geometry has already been 
grouped.

 � Choose Yes if your clothing geometry does not already 
have groups, or if you want to regroup the object. Poser 
will create the groups for you automatically.

7. The skeleton is applied to the OBJ in the Setup room. You 
can then open the Group Editor to examine the groups in 
the OBJ and edit as necessary.

While examining the groups in the Setup Room, 
you may notice one or more groups that have all 

polygons assigned to them. For example, when you 
apply the Alyson skeleton to a clothing object, two 
groups (one named Figure, and the other named 1) have 
all polygons assigned to them. Select each of these 
groups in the Group Editor, and then click the Delete 
Group button to delete them.
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 Delete groups that have all polygons assigned to them.
 Review each group that has been created and edit polygons 

assigned to them if necessary.

8. After you inspect all of the groups and have edited them 
to your satisfaction, you can return to the Pose Room. You 
should now have a poseable figure.
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After applying the skeleton and joints to your 
figure, you should test the rotations of the joints 

in your clothing to make sure that falloff zones are 
adjusted for proper bending of the clothing. If you see 
polygons that do not bend properly, or which fly away 
from the figure when your character is posed, it is likely 
that you will need to adjust joint parameters such as 
falloff zones or inclusion/exclusion angles. The more the 
shape of the clothing deviates from the default body 
shape (for example, like puffy sleeves, or baggy/loose/
flowing clothing), the more necessary it will be to adjust 
spherical or capsule falloff zones.

9. Before conforming the clothing to your figure, or before 
saving the clothing to your library, choose Figure > Zero 
Figure to zero all joint rotations. Also use the Edit > 
Memorize > Figure command to memorize the conforming 
clothing. You may also want to assign a new name for the 
object in the Properties palette.

Skinning Methods
The Figure > Skinning Method commands determine how 
Poser treats a character mesh in regards to grouping:

• Choose Figure > Skinning Method > Poser Traditional 
if you want to display or create a figure that uses Poser’s 

traditional model of breaking the mesh into individual body 
parts.

• Choose Figure > Skinning Method > Poser Unimesh if 
you want your model to be used with subdivision surfaces 
(see “Working with Subdivision Surfaces” on page 769). 
Poser Unimeshes can still be posed manually or with preset 
poses that are saved to the Library. The mesh is unified, but 
body part groups are still recognized in Poser.



Poser Pro 2014
Reference Manual 

768

Chapter 33: Working with Joints, Weights, and Skinning

 The Poser 2 Male (roughly 2500 polygons) converted to Poser 
Unimesh and subdivided to level 2.

• Choose Figure > Skinning Method > Simple Bones 
Single Skin - Interoperable ... if you want to work on or 
create a figure that has a single skin mesh, but in which 
the Poser grouping is removed. Figure setup is very simple 
in this mode. You can specify joint origins and one vertex 
weight map. After you convert the model to Simple Bones 
Single Skin, test each joint and use the Simple Bone Weights 
painting mode to correct any problem areas.

 Traditionally-rigged Poser figures use a mesh 
that is broken into body parts, and has spherical 

or capsule-shaped zones of influence and weight maps. 
To export these types of figures to COLLADA, you should 
switch to Simple Bones Single Skin first. That way, you 
can preview how the figure bends in other applications. 
If you are not satisfied, you can touch up the weights at 
that point.
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 Alyson converted to Simple Bones Single Skin.

• Choose Figure > Skinning Method > Regenerate Simple 
Bone Weights if you want to start over with a new simple 
bones single skin mesh.

Working with Subdivision Surfaces
Subdivision is a process that refines the appearance of a mesh 
during preview or rendering. It is typically used to smooth 
the appearance of a low-resolution mesh to make it appear as 
though it has been created with a higher number of polygons. In 
this section you’ll learn how subdivision works, what to consider 
before you create or use models that will be subdivided, and how 
to use subdivision surfaces in Poser.

How Subdivision Works

Subdivision can be applied to polygons that are made of 3 or 
more sides. Most content developers keep all or most of the 
polygons in their model to four sided polygons for optimum 
results in subdivision.

To explain how subdivision works, let’s start with a picture of 
three polygons: one with 3 sides, one with 4 sides, and one with 
5 sides. With no subdivision, you see the polygons exactly how 
they have been created.



Poser Pro 2014
Reference Manual 

770

Chapter 33: Working with Joints, Weights, and Skinning

 3, 4, and 5-sided polygons with no subdivision.

When you set the subdivision level to 1, subdivision smooths the 
model and gives the appearance as though it is made of more 
polygons. What basically happens is that a vertex is placed in 
the center of each polygon, and then that vertex connects at the 
center of each of the edges in the original polygon: Notice the 
following in the image that appears below:

• The 3-sided polygon now looks like three four-sided 
polygons.

• The 4-sided polygon now looks like four four-sided 
polygons.

• The 5-sided polygon now looks like five four-sided polygons.

 3, 4, and 5-sided polygons with subdivision setting of 1.

If you increase the level of subdivision one more time (to a 
setting of 2), another vertex is placed in the center of each 
polygon that was created at level 1. Because a level 1 subdivision 
created all four-sided polygons, what this will result in is that 
your model will appear to have four times the number of 
polygons as the preceding level.

• Your original 3-sided polygon now looks like it has 12 
polygons.

• Your original 4-sided polygon now looks like it has 16 
polygons.

• Your original 5-sided polygon now looks like it has 20 
polygons.
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You’ll also notice that at a subdivision level of two, the outer 
edges of the polygon appear much smoother and rounder. This 
is most noticeable in the four-sided polygon. Where it originally 
appeared as a rectangular shape, it is now more like a circle.

 3, 4, and 5-sided polygons with subdivision setting of 2.

Finding the Optimum Setting

As you continue to increase the subdivision levels, you will get 
to the point where you won’t really notice much of a change in 
the appearance of the polygons. Depending on the edge loops in 
the model, this most often happens between a subdivision level 
of 2 or 3. To illustrate this, compare the figure below with the 
preceding example. You won’t notice a lot of difference in the 
shape of the outer edge of the polygon. The only thing that you 
notice now is that it appears as though there are four times the 
number of polygons. Your 3, 4, and 5-sided polygons now look 

like 48, 60, and 80 polygons (respectively), but the appearance 
hasn’t changed much along the outer edge.

 3, 4, and 5-sided polygons with subdivision setting of 3.

What this means, is at some point it won’t make a lot of 
difference in your preview or final render to increase the 
subdivision beyond an optimum point. To do so will only 
increase the load on your system resources as you increase the 
number of subdivision levels beyond what you actually need.

Now that you’ve seen how subdivision affects a single polygon, 
consider the effects on a figure such as the Poser 2 male, 
which consists of 2572 polygons. You can find this figure in the 
Character > People > Poser Originals > Poser 2 Lo Library 
category.

The Poser 2 Male is made of polygons that have 3 or more sides: 
With no subdivision, it appears as shown in the following figure. 
Pay attention to the crown of the head, which appears to have 
some hard edges.
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 Poser 2 Male with no subdivision.

When you set the subdivision level to 1, you’ll notice that the 
hard edges are softened somewhat. The hard edges at the crown 
of the head are much improved, but still don’t appear quite 
as smooth as you would like. You’ll also notice that the chest 
muscles retain their shape because the edge flow in that area 

follows the shape of the muscular detail. The facial features are 
less angular, giving a softer appearance to the eyes, nose, mouth, 
and ears. With one level of subdivision, you’ll get the equivalent 
of a model that has about 10,000 polygons.

 Poser 2 Male with subdivision setting of 1.
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Increasing the subdivision level to 2 (about 40,000 polygons) 
doesn’t seem to change the appearance of the chest and arms 
very much; however, you’ll notice that the crown of the head 
appears very smooth now. However, the facial features might be 
softened a bit too much at this level. The primary reason for this 
is because there isn’t enough edge flow in those areas to retain 
the detail in those areas, because the model wasn’t built with 
subdivision in mind.

 Poser 2 Male with subdivision setting of 2.

As you can see from the preceding examples, content creators 
should pay attention to areas that will require more detail. A 
20,000 polygon figure can easily contain enough edge loops 
to make a subdivision setting of 1 sufficient enough to produce 
sufficient detail and a great render, as long as it’s modeled with 
subdivision in mind. To maintain detail, edge loops have to be 
placed near areas where you want creases, sharp transitions, 
and folds to appear, otherwise the subdivision will smooth those 
details away.

Subdividing Figures in Poser

To turn subdivision surfaces on for Poser figures:

1. Load the desired figure or prop into Poser.

2. If you are subdividing a poseable figure, choose Figure > 
Skinning Method > Poser Unimesh. This will combine the 
model into one mesh.

3. Select the BODY actor of the figure.

4. Switch to the Properties tab, where you will see two settings 
in the Subdivision Levels section:

 � Preview: Indicates the subdivision level that will be 
used in the Preview render (the document window or 
the Raytrace Preview).
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 � Render: Indicates the subdivision level that will be 
used in the final render.

When you initially turn subdivision surfaces on, 
both the Preview and Render values are initially 

set to zero (no subdivision).

Adjust the Preview setting first. If the Preview setting 
is increased higher than the Render setting, the Render 
setting will automatically increase to match the Preview 
setting.

5. After you reach the desired Render subdivision level, 
you can reduce the Preview setting as needed to improve 
performance while composing your scene.

If you turn body parts off, subdivision will be 
recomputed accordingly.

If you have a body part that is not subdividing 
properly, you can set a different subdivision level 

for that part. Select the body part that you want to 
change, and set a different subdivision level in the 
Properties palette. Note that you may see creases at the 
seams when your model uses different subdivision 
levels. Additionally, you will not be able to smooth 
across body parts that have different subdivision levels.

Increasing the subdivision levels on cloth 
simulated objects can reduce shading artifacts.

Modeling Considerations
When using subdivision surfaces, your model must be clean. 
There is a lot of content in the Poser world that was not modeled 
with subdivision surfaces in mind, and you won’t always get the 
results you expect. For example, you might see polygons that 
appear to stretch away as shown in the following figure, which 
shows the Poser 1 male with a subdivision setting of 1. This is 
often due to vertices that are at or close to the same position in 
3D space.
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 Poser 1 Male with subdivision setting of 1.

In the case of the Poser 1 male, there isn’t a workaround for this 
issue. However, in some cases you can select the body part that 
is causing the issue. Then go into the Properties palette, and 
check the Subdivide separately from figure option. Set the 
subdivision setting to zero for that body part. Note, however, 
that the seam will be more visible where one body part is 
subdivided to different level than an adjacent body part.

 Body parts can also be subdivided individually.

The following conditions will cause subdivision to work 
improperly, and Poser will notify you when it will be unable to 
subdivide the model at all.

• Edges that are shared by more than two polygons.

• Vertices that show up twice in one polygon.

• Duplicate polygons that share the same space.

To illustrate what happens when more than two polygons share 
an edge, the following figure shows an object that is made up of 
three sections of polygons. Sections 1 and 2 appear along the top 
of the “T” shape, and are welded along the center length. The 
third section is perpendicular to sections 1 and 2, and also joins 
them at the center. Thus, each edge along the middle of the T 
shares three connecting polygons.
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The top section of the following figure shows what this T-shape 
looks like before subdivision surfaces are activated. 

 Three sections of polygons sharing the same edge.

The bottom section of the figure shows what happens to these 
polygons after subdivision surfaces are applied. Poser gives a 
warning when geometry contains problematic areas. As you 
can see, the top two sections remain joined together; but the 
third section, which was connected to the top of the T before 
subdivision, now appears to be separated from them. You will 
need to modify the model in areas where three or more polygons 
share a common edge.
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Chapter 34: Using Poser 
with Other Applications

Poser allows you to import and export various types of content 
such as background images, movies, and 3D objects. This 
allows you to use third-party applications to create textures, 
background scenes, and clothing that you can use to enhance 
your scenes.

Importing Files
Selecting File > Import allows you to bring both Poser and non-
Poser files into your scenes. These could be images, movies, or 
props (which you can convert into Poser figures as described in 
“Chapter 27: The Cloth Room” on page 550.

Importing Movies

To import movies, select File > Import > AVI Footage 
(Windows) or File > Import > QuickTime (Macintosh). You can 
use imported movies to add background action to your Poser 
animations. For example, you could have a scene with two Poser 
characters sitting on a train with an imported movie showing the 
scenery rolling past as if the train was in motion.

If your imported movie’s size or aspect ratio (width/height) is 
different than your current Document window settings, you will 
be informed that the background width and height are different, 
and will be asked if you want to change the window to match the 
background.

Selecting Yes resizes your Document window to fit the imported 
movie. It is recommended that you only use this option while the 
Document window is docked.

• Selecting No “stretches” the Document window to 
accommodate the movie. You may see areas of the 
Document window not covered by the imported movie.

• Changing the aspect ratio of imported movies can introduce 
unwanted artifacts and distortions into your scene when 
rendered. Smith Micro Software therefore recommend 
resizing your Document window or importing correctly 
sized animations.
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 Aspect ratio of imported movies can be retained or adjusted to fit 
the size of the window.

Imported movies will begin at the first frame of your Poser 
animation. If your animation is longer than the movie, the movie 
will remain in the background paused at its last frame. If your 
animation is shorter than the movie, you will see Frames 1-X of 
the imported movie, where x is the number of frames in your 
Poser animation.

When importing movies, you should try to light your scene in 
a manner consistent with the background so as to blend them 

together. Please see “Chapter 12: Lighting” on page 261 for 
information about lights in Poser.

Importing Background Pictures

You can also import static images as backgrounds. For example, 
if you are creating a scene with Poser characters in a room with 
a window, you could use a background image to simulate the 
view from the window. Selecting File > Import > Background 
Picture opens a standard Open dialog, allowing you to select 
your image’s format and location. As with movie imports, you 
are asked if you wish to resize your Document window to match 
the imported image, and the results are the same as described 
above. Changing the aspect ratio of imported images can 
introduce unwanted artifacts into your scene when rendered and 
can result in blank areas on the sides of the Document window 
(see above). We therefore recommend resizing your Document 
window or importing correctly sized images. Poser supports 
importing background images in a wide variety of formats. The 
following is only a partial list of those formats supported: SGI, 
BMP, DDS, EXR, GIF, HDR, JPG, PCD, PNG, PSD, TGA, TIFF 
and WBMP.

When importing images, we recommend that you import them 
while the document window is in its docked state. You should try 
to light your scene in a manner consistent with the background 
so as to blend them together. Please see “Chapter 12: Lighting” 
on page 261 for information about lights in Poser.
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Importing Poser Documents or Props

Selecting File > Import > Poser Document/Prop loads either 
an entire Poser scene or a Poser prop into your scene. This can 
be useful for inserting props that are not part of your Library 
palette’s Props category. Imported scenes/props become part 
of your current scene complete with animations, morphs, poses, 
etc. This option opens a standard dialog box allowing you to 
browse for the desired file. Use the Files of type pull-down 
menu to select one of the following types of Poser files:

• Poser document files (*.PZ3 and *.PZZ): This option 
imports Poser 3.0 and later scenes, both uncompressed and 
compressed.

• Poser Prop Files (*.PP2 and *.PPZ): This option imports 
uncompressed or compressed Poser prop files.

See “Miscellaneous Preferences” on page 40 
for more information about compressed file 

support within Poser.

Importing 3D Objects

Poser allows you to import geometries in the following formats:

• 3D Studio Max (File > Import > 3D Studio)

• DXF (File > Import > DXF)

• Wavefront OBJ (File > Import > Wavefront OBJ)

• LightWave LWO files (File > Import > LightWave...)

• COLLADA

Most 3D modeling applications support exporting to at least 
one of the above formats. Some formats, such as Wavefront 
OBJ, allow you to save geometries as either polygons or NURBS 
surfaces. Poser will only accept geometries saved as polygons.

Poser will import smoothing groups in Wavefront OBJ format, 
as defined in the source file. (If no smoothing groups are 
specified in the source file, none will be imported.) Please refer 
to “Smoothing Geometry” on page 422 for more information 
about smoothing groups. Note that while Poser does not support 
the 3ds Max style of defining smoothing groups, Poser does take 
into account the vertex normals when determining creases. As 
a result, OBJ files exported from 3ds Max will usually appear as 
expected, despite the fact that the 3ds Max smoothing groups are 
not read.

Tips & Tricks

When using your favorite 3D modeling application for creating 
new geometries for conversion into Poser figures/props, it is 
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a good idea to follow these guidelines in order to speed up the 
figure creation process and provide a better end result:

• Make sure that you do not have duplicate or overlapping 
polygons. Duplicate polygons occur when you have two 
identical parts of the geometry occupying the same location, 
for example if you accidentally paste an item twice. The 
following graphic depicts an instance of duplicated polygons 
within a 3D modeling application.

 Two spheres that overlap each other.

• Eliminate overlapping polygons, which can occur if 
pieces of the geometry are embedded within each other. 
The following graphic shows an example of overlapping 
polygons on the left (the smaller pipe embedded within the 
larger one), and the correct way to create the geometry on 
the right (without overlapping polygons).

 Remove overlapping polygons.

• Poser allows you to import geometries as a single file 
with groups within the file, as separate files, or as a single 
file with no groups. We recommend that you create your 
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geometries as single files with no groups, since Poser 
includes powerful grouping tools and since some geometry 
formats (such as Wavefront OBJ) allow you to assign 
polygons to more than one group at a time. Importing 
geometries with polygons assigned to more than one group 
will cause Poser to duplicate those polygons, resulting in 
additional unwanted figure parts.

Use the following procedure to import geometries into Poser:

1. Begin the process by creating a polygonal mesh object in 
your favorite 3D modeling application. Once you have 
finished, import it into Poser by selecting File > Import 
> format, where format is the format you wish to import 
(such as OBJ). A Standard Open dialog appears, allowing 
you to select your desired filename and path.

2. Once you have selected the desired geometry, the Prop 
Import Options dialog appears. It contains the following 
options:

 � Centered: Checking the Centered checkbox positions 
the imported geometry in the center of the Poser 
workspace.

 � Place on floor: When enabled, the Place on Floor 
option places the bottom of the prop at “ground level” 
on the floor of the workspace.

 � Percent of standard figure size: The Percent of 
standard figure size option scales the geometry 
relative to the height of a standard Poser figure. For 
example, setting the scale to 50% imports the geometry 
at 50% of the height of a standard Poser figure. The 
rest of the geometry scales to maintain the correct 
proportions relative to the selected height. When 
importing DXF geometries, Poser considers one DXF 
unit as being equal to the height of a standard Poser 
figure, or about six feet.

 � Offset: Entering numeric values in one or more of the 
Offset fields positions the geometry at the selected 
position within the Poser workspace.

 � Weld identical vertices: When enabled, the Weld 
identical vertices option unites identical vertices 
within the geometry.

 � Make polygon normals consistent: If the geometry 
file contains vertex normals, checking the Make 
polygon normals consistent checkbox makes the 
polygon normals consistent with the vertex normals.

 � Flip normals: The Flip Normals option reverses all of 
the geometry’s normals.

 � Flip U Texture Coordinates: The Flip U Texture 
Coordinates option reverses the geometry’s U texture 
coordinates.
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 � Flip V Texture Coordinates: The Flip V Texture 
Coordinates option reverses the geometry’s V texture 
coordinates.

Once you have finished selecting your desired options, 
click the OK button.

3. The geometry file imports into Poser. The amount of time 
required to import a geometry file depends on factors such 
as the size of the file, number of polygons or groups, speed 
of your computer, etc. A progress indicator tracks the 
import process. When the process is complete, the imported 
geometry appears in your Poser Document window.

 An object after it is imported into your scene.

Imported geometries are treated as static props. You can add 
props to the Library palette as described in “Maintaining 
Your Library Palette” on page 161 and/or can convert props 
into poseable Poser figures using either the graphical Setup 
room (see “Chapter 27: The Cloth Room” on page 550 for 
instructions on using the Setup room) or the legacy text-based 
method (refer to “Global vs. Local Coordinates” on page 862).
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Exporting Files
In addition to supporting a wide range of import formats, Poser 
supports many formats for export, allowing you to use your 
Poser output with your favorite 2D and 3D applications.

Exporting Images

To export an image, select File > Export > Image. A standard 
Save As dialog appears, allowing you to specify your desired 
filename and save location. In addition, you may be able to 
select various image-specific attributes (such as quality for JPG 
exports).

If you want Poser to write an alpha channel to 
preserve transparency in your exported image, 

you should export to either the PNG, TIFF, or PSD 
formats. An alpha channel causes the foreground to be 
transparent wherever it is empty, in order to allow the 
background to show through. This feature is essential 
for compositing in image editing applications.

Exporting an image saves a snapshot of your current scene as 
seen in the active tab of your Document window. Therefore, 
if you are in the Preview tab of the Document window, your 
exported image will be a snapshot of the scene exactly as it 
appears in the Preview tab. If you are in the Render tab, your 

exported image will be the rendered image that is currently 
selected in the Main Render menu at the bottom left of the 
Document window.

Exporting BVH Motion Files

To export a BVH motion capture file:

1. Select the figure you wish to export.

2. Select File > Export > BVH Motion.

3. Select Scale Automatically. If the exported file looks 
incorrect, re-export it and disable automatic scaling.

4. A standard Save dialog appears, allowing you to specify 
your desired filename and save location.

Exporting Painter Scripts

Clicking the Export Painter Script button in the Sketch 
Designer exports the current Sketch Designer settings to 
Corel Painter (see “Chapter 20: The Sketch Designer” on page 
440). This has been tested to work with Painter 6 and previous 
versions, and is not supported for later versions though it may 
work with them.
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Exporting 3D Objects

Poser allows you to export 3D objects in RIB, 3DS, DXF, OBJ, 
VRML, LWO, OBJ, and COLLADA formats by selecting File > 
Export > format, where format is one of the supported export 
formats. To export to a 3D format:

1. Select File > Export > format.

2. In the dialog that appears, check the appropriate radio 
button to export either a still (at the current frame of your 
animation) or an animation. If you select to export an 
animation, enter the frame starting and ending numbers in 
the appropriate text boxes and click OK.

3. Select the actor(s) you want to export in the following dialog 
and click OK.

4. A standard Save As dialog appears, allowing you to select 
your desired filename and path.

If you are trying to create a full-body morph 
target, do not select File > Export > Wavefront 

OBJ. Instead, select Figure > Create Full Body Morph.

Exporting Flash (SWF) Files

Flash is a popular 2D format most commonly used for animating 
Web content. You can export your Poser file to the Flash format 
(.SWF file) from the Make Movie dialog, and then use the Flash 
application to modify the file. Flash presentations are normally 
viewed directly within Web browsers using the Adobe Flash 
plug-in.

Please refer to “Keyframe Controls” on page 452 for 
more information about the Make Movie dialog, and to for 
information about setting Flash export options.

High Dynamic Range Image (HDRI) Export

With Poser Pro you can render and export files that are 
optimized for HDRI output. Files can be exported as Radiance 
files or OpenEXR files. HDRI optimized files accurately 
represent the wide range of exposure found in real scenes, 
including the details, shadows, and high-contrast lighting.

To optimize images for HDRI export, from the Main Menu select 
Render > Render Settings and enable the HDRI Optimized 
Output check box. To Export an HDRI file, from the Main Menu 
select File > Export. To make a movie optimized for HDRI 
output, from the Main Menu, select Render > Render Settings 
> Movie Settings, select Image Files from the Format pull-
down menu.
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When you save the file(s), you will be given the option to save as 
Radiance (.HDR) or OpenEXR (.EXR).

While more precise, files optimized for HDRI output can lead 
to perceived loss of anti-aliasing and banding in very subtle 
gradients. Optimizing for HDRI output omits dithering that 
would otherwise be applied to eliminate banding.

Optimizing images for HDRI output provides maximum 
flexibility in post-production, performing color correction or 
adjusting exposure without having to re-render the image.

 Same HDR image at varying exposures in Adobe Photoshop CS.

COLLADA Import/Export

Poser Pro offers data exchange with the industry-standard 
COLLADA format. Gain maximum flexibility by transporting 

Poser content to applications such as Softimage XSI or NVIDIA 
FX Composer without having to rely on hosting plug-ins.

Importing COLLADA Files

Importing COLLADA files allows you to import geometry with 
standard surface materials, cameras and lights. COLLADA 
import in Poser Pro does not currently support Cg shaders, 
morph targets, bones or animation.

To import a COLLADA file, from the Main Menu select File 
> Import > COLLADA\RWY. Enable the appropriate import 
options and click OK.

 COLLADA Import Options dialog.

• Import Lights: With this option enabled, Poser Pro will add 
lights stored in the COLLADA file to the current scene. For 
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more information about lights, see “Chapter 12: Lighting” 
on page 261.

• Import Cameras: With this option enabled, Poser Pro will 
add cameras stored in the COLLADA file to the current 
scene. For more information about cameras, see “Chapter 
11: Cameras” on page 242.

Exporting COLLADA Files

COLLADA offers increased flexibility by allowing to export a 
more comprehensive representation of your Poser scene. For 
example, as a game designer, you might want to import your 
scene exported from Poser Pro as COLLADA file into 3ds Max 
or Softimage. You can work on your scene in those applications, 
and then transfer it to your game engine with COLLADA. Your 
scene remains editable at any position in the pipeline. COLLADA 
is a feature-rich format that can store various aspects of your 
scene, thereby preserving a maximum of information upon 
export. Provided that the application you are exporting for 
supports those features, you can choose to transfer data such as 
static figures, props, baked morph targets, cameras, and lights.

To Export a COLLADA file:

1. From the Main Menu select File > Export > 
COLLADA|RWY (.DAE). The Export Range dialog 
appears.

2. If you want to export only the current frame, choose Single 
Frame. To export multiple frames in an animation, choose 
Multi frame export, and then enter the range of frames to be 
exported.

 Export Range dialog.

3. Click OK to continue. The Select Objects dialog appears, 
with the items in your scene selected for you. Check or 
uncheck items as desired to export.
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 Choose the objects to export from your scene.

4. Click OK to continue. The Export Options dialog appears. 
Enable the appropriate Export Options and click OK. These 
options include:

 � Export Standard Units vs. Custom Units: Select one 
of the standard Poser units. If none of the standard 
units meet your needs, then you can define your own 
measurement in meters.

 � Scale: This allows the adjustment of the scale of a 
scene upon export. Adjust the scale if you want to adjust 
the size of the scene.

 � Triangles only: Forces triangulation of polygons upon 
export.

 � Include normals: Allows you to specify whether 
polygon normals are exported explicitly. Discarding the 
normals will require the target application to recompute 
them. Toggling this option may help resolve shading 
issues.

 � Include rigging (preserves posability and 
animation): Figures are exported as poseable and 
animatable objects.

 � Export every frame as keyframe: When checked, 
will export an animation keyframe for every frame in 
the selected range. When unchecked, exports already 
existing keyframes only. This can help increase accuracy 
in a complex setup (e.g. conforming clothing) or if the 
importing application has difficulties interpolating 
between keyframes.
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 � Bake all Morphs: COLLADA files with a lot of morphs 
can be large and resource consuming. Bake Morphs 
allows the export of morph targets so you get the 
essence of the morphs without the file size and resource 
expense. You will not be able to animate those morph 
targets any more, which sacrifices some flexibility. 
However, you’ll receive the same end result if you are 
only interested in the particular shape variation that 
was present in your scene upon export.

 � Bake Diffuse Map: Blend diffuse texture with diffuse 
color. If you enable this option Poser Pro will write a 
new texture map that is shader baked into a texture 
map.

 � Bake Transparency Map: Enable this option 
when your target application expects transparency 
information in the alpha channel of the diffuse texture 
rather than as a separate transparency map. You will 
be allowed to designate a channel name, and choose 
whether or not you want to invert the transparency map 
(turn black to white and vice versa).

 � Bake Transparency to Channel: Choose this option 
if you want Poser Pro to create a texture map that has 
transparency information baked into it.

 � Invert Transparency Map: Choose this option to 
output a “negative” transparency map. For example, in 

Poser black areas indicate transparent areas and white 
areas indicate opaque areas in the transparency map. 
An inverted transparency map would be the opposite 
(black is opaque and white is transparent).

 � Maximum Texture Size: Textures in Poser content 
are often very large. Some applications experience 
difficulties upon importing COLLADA files with 
large textures. Maximum Texture Size allows you to 
automatically reduce texture size upon export, thereby 
maximizing compatibility. Your original textures 
remain untouched.

 � Power of 2: You can increase compatibility further 
by enabling the Power of 2 option. This option will 
automatically resize your textures to the nearest width 
and height that is a power of two. For example, a 
texture that is 1100x600 pixels large would be exported 
at a size of 1024x512. Once again the original texture 
remains unaffected.

When exporting to 3d software that supports 
COLLADA, you can export using Poser’s default 

skinning method, or a single mesh with weight maps. 
For more information on these options, see “Skinning 
Methods” on page 767.
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 Export Options dialog.

Using Poser with ZBrush and GoZ

Poser Pro 2012 SR3 or later and an updated 
ZBrush 4 or later are required for GoZ 

compatibility.

Users of ZBrush 4 can use GoZ to export a complete 
figure mesh, or a selected actor or body part into GoZ. 
Then use ZBrush’s powerful tools to create your morphs 
and reimport them back into Poser. The GoZ plugin 
makes morph creation - including reverse deformation 
joint controlled morphs -- easy, and painless.

Setting Your Poser Path in ZBrush

When you install Poser Pro, the required GoZ files are installed 
in your ZBrush installation folder. You’ll find the GoZ interface 
files in the following ZBrush-related folders:

• Poser Pro (Windows) will place the interface files in C:\
Users\Public\Pixologic\GoZApps\Poser.

• Poser Pro (Macintosh) will place the interface files in Users:
Shared:Pixologic:GoZApps:Poser

Once the files are installed you will need to start ZBrush to make 
sure that you have the path set to Poser. To do this, choose the 
Preferences > GoZ command, and hover over the Path to Poser 
button. If your path is set, it will appear on the screen as shown 
below.
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 Make sure that your path to Poser is set in ZBrush GoZ Preferences.

If you hover over the Path to Poser button in ZBrush and get a 
message that reads Poser application was not found, then 
you will need to set it up manually. To do this, click on the 
Path to Poser button. This will initiate a search for your Poser 
application.

If Poser is installed to the default installation path, ZBrush 
should find the application after a brief time. A screen will 
display the path (or paths, if you have multiple versions of Poser 
installed).

If one or more paths to Poser are reported in the dialog, click to 
select the path that you want to use as the default. This will set 
the preference.

 After searching for your path, it will appear in a dialog if one or 
more versions of Poser are found on your system.

• If you instead get a message that states that no version of 
Poser was found (which may be possible if you installed 
Poser to a non-standard path), then you will have to locate it 
manually. Click the Browse button to navigate to the folder 
that contains the PoserPro.exe file.

• Clicking the Not Installed button will remove the preference 
that was previously set, and cause the GoZ link to Poser to 
not work properly. If ZBrush does report your path to Poser 
properly, make sure that you click the line that displays the 
correct path to exit the dialog properly.
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Using GoZ to Create Morphs and Texture 
Maps

The GoZ plugin for Poser allows you to create full body morphs, 
partial body morphs, and joint-controlled morphs with ease. 
In addition, you can also add additional detail to a model with 
normal or displacement maps. The following sections describe 
how to initiate the steps to send your models to and from ZBrush 
with the GoZ plugin.

When using the Figure > Export Figure to GoZ 
or Object > Export Object to GoZ commands, it 

is important to remember that they apply to a single 
round-trip session between the scene you exported the 
object from, and the ZBrush document that you sent it 
to. You cannot send a figure or object to ZBrush from 
one Poser project, and then send it back to another Poser 
project.

Exporting Objects to ZBrush

When you use the GoZ plugin as a bridge between Poser and 
ZBrush, you are presented with a couple of choices in how you 
want the polygon grouping to work. These options are to assist 
in making it easier to show and hide polygons in ZBrush while 
you are editing your object. ZBrush allows you to show or hide 
polygon groups by pressing CTRL+SHIFT+Click (Windows) or 

COMMAND+SHIFT+Click (Mac). When you click on an area of 
the mesh in ZBrush, this key sequence will cycle between “Select 
only this polygon group”, “Select everything but this polygon 
group” and “Show all polygon groups.”

When you choose to export a character or actor to ZBrush, you 
are presented with the following options:

• Export Posed: This option is not checked by default. When 
unchecked, Poser will zero a figure pose before it exports the 
figure to Poser. When checked, the figure will be export to 
ZBrush in its posed position, which is desirable for creating 
joint-controlled morphs. For additional information, see 
“Creating Joint-Controlled Morphs with GoZ” on page 
797.

• Material: When you choose this option, the polygon order 
of the object that is exported to ZBrush will be grouped by 
Material. This will allow you to show or hide polygons in 
ZBrush based on their material assignments. For example, 
if you export a head, you will be able to hide the face texture 
while you work on morphs or textures for the parts inside 
the head (teeth, tongue, etc).

• Body Part: When you choose this option, the polygon order 
of the object that is exported to ZBrush will be grouped by 
body part. This will allow you to show or hide polygons in 
ZBrush based on body part. For example, you can hide all 
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parts except the head if you are working on face morphs, 
allowing you to frame only the head in the ZBrush window.

Creating Full Body Morphs with GoZ

The Figure > Export Figure Mesh to GoZ command allows you 
to export a complete figure from Poser into ZBrush. When you 
export a complete figure through GoZ and then return it back to 
Poser using the GoZ plugin for ZBrush, a full body morph dial 
will automatically be created for you when the morph is sent 
back to Poser. In addition, corresponding dials will only appear 
on the body parts that were directly affected by the morph (in 
other words, there will be no need to delete redundant morph 
dials from unaffected body parts).

To create a full body morph using GoZ:

1. Load the figure that you want to morph into your Poser 
scene, and select it as the current figure.

2. Choose Figure > Export Figure Mesh to GoZ. A dialog 
displays some options for the export.

 GoZ options dialog.

3. In the Polygon Grouping section, you have two choices 
for how you can group polygons when you export them to 
ZBrush. The method that you choose determines how you 
will be able to show and hide parts within ZBrush (either 
by material, or by body part) and are primarily for ease 
of editing in that application. For more information, see 
“Exporting Objects to ZBrush” on page 791.

4. Click Yes to continue. Your model will open in ZBrush as a 
subtool. Drag the tool onto the scene and create your morph 
as you normally do.

5. After your morph is complete, click the GoZ button in the 
Tool palette (in the upper right section of your screen by 
default) to send the OBJ file back to Poser.



Poser Pro 2014
Reference Manual

793

Chapter 34: Using Poser with Other Applications

 Press the GoZ button to send the morphed mesh back to Poser.

6. When you return to Poser, a dialog asks if you want to 
import the modified geometry as a full body morph. Enter a 
name for the new morph and press OK to continue.

 Enter a name for the new full body morph in Poser.

7. Initially, the dial will be set to zero. To test the morph, 
choose the BODY actor, and dial your morph to test it. You’ll 
also notice that a corresponding dial will only appear in the 
individual body actors that were affected by the morph.

 Test the dial in the BODY actor to make sure it works.

Creating Normal and Displacement Maps with GoZ

If you want to use ZBrush to create Normal or Displacement 
maps, the process is similar to that discussed in the previous 
sections. Normal and displacement map creation involves 
subdividing the mesh in ZBrush before painting, and then 
comparing that higher resolution mesh to the original resolution 
when your maps are generated. Please reference your ZBrush 
documentation for more detail in how to create normal and 
displacement maps.
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As long as you are working on a content item that has everything 
on a single texture, the import and export between Poser and 
GoZ should work the same as discussed under the morph 
creation sections. You select the item you want to export, use 
GoZ to transfer the OBJ to ZBrush, make your changes in 
ZBrush, and then click the GoZ button to bring it back into 
Poser.

However, it is important to note that most Poser characters use 
multiple texture maps with overlapping UV sets. A workaround 
for multi-map characters is to choose Material polygon grouping 
when you export from Poser.

Once in ZBrush, you can hide the groups that do not belong to 
a particular UV set. Hold down the CTRL and SHIFT key while 
you left-click a material group. Then you can generate a map 
from the remaining groups. ZBrush will pretend that the hidden 
groups don’t even exist when it creates your map.

After you have the desired material groups displayed, you 
will need to export the maps from within ZBrush, rather than 
exporting them back into Poser with the GoZ command.

Morphing Multiple Items

There are times when you need to have a piece of clothing over a 
character to make sure that the morphs you create will properly 
fit a character. You can use the GoZ plugin to export one item at 
a time.

For example, select the figure in the first GoZ session and export 
it into GoZ using the Figure > Export Figure Mesh to GoZ 
command, and Body Part polygon grouping. Drag the figure into 
your ZBrush document.

Then go back to Poser and export a clothing item (like pants), 
using the same steps (Export Figure Mesh to GoZ, with Body 
Part polygon grouping.) Initially it will appear in the document 
window by itself.

Go back to Poser and use the Figure > Export Figure Mesh to 
GoZ to export a third item if desired, using the same steps as you 
did with the previous clothing item.

Now you have three Poser OBJ files in ZBrush - the character, 
and two pieces of clothing. Each appears as a separate tool. The 
last item that you loaded appears in the scene.

Expand the Subtool palette in ZBrush, and press the Append 
button. Click to select the figure mesh in the selection area. 
It will load into the same document as a subtool. Repeat this 
process for the second (or additional) clothing items.
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 Click the Append button in the Subtool palette to append an object 
into your current window.

When you need to morph the clothing item, select the piece of 
clothing from the Subtool palette.

 Select the clothing item that you want to morph from the Subtool 
palette.
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To return the morphed items back to Poser, select the item 
you want to return from the Subtool palette, and press the GoZ 
button. The item will update in Poser and you will be prompted 
to enter a name for the new morph.

Return back to ZBrush and select the next item from the Subtool 
palette. Again, press the GoZ button to import that item back 
into Poser and assign the morph name.

Creating Individual Actor Morphs with GoZ

Sometimes you only need to morph an individual body part. For 
example, if you want to create a morph that changes the shape of 
a character’s nose, you only need to export the head. The steps 
to do this are similar to those discussed previously in “Creating 
Full Body Morphs with GoZ” on page 792, except that you 
initiate the GoZ command from the Object menu instead of the 
Figure menu.

To create a morph for a single body part, follow these steps:

1. Load the figure that you want to morph into your Poser 
scene, and select it as the current figure.

2. Click to select the body part that you want to export (for 
example, the Head).

3. Choose Object > Export Object to GoZ. A dialog displays 
some options for the export.

 GoZ options dialog.

4. In the Polygon Grouping section, you have two choices 
for how you can group polygons when you export them to 
ZBrush. The method that you choose determines how you 
will be able to show and hide parts within ZBrush (either 
by material, or by body part) and are primarily for ease 
of editing in that application. For more information, see 
“Exporting Objects to ZBrush” on page 791.

5. Click Yes to continue. Your body part will open in ZBrush as 
a tool. Drag the tool onto the scene and create your morph 
as you normally do.

6. After your morph is complete, click the GoZ button in the 
Tool palette (in the upper right section of your screen by 
default) to send the OBJ file back to Poser.
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7. When you return to Poser, a dialog asks if you want to 
import the modified body part. Enter a name for the new 
morph and press OK to continue.

 Enter a name for the new body part morph in Poser.

8. Initially, the dial will be set to zero. To test the morph, 
choose the actor that you morphed, and dial the morph to 
test it.

When you use the Object > Export Object Mesh 
to GoZ command to create morphs, a 

corresponding Full Body Morph dial will not be created 
in the BODY actor.

Creating Joint-Controlled Morphs with GoZ

Joint controlled morphs, in the past, have been difficult to create 
for Poser, because all morphs had to be loaded when a figure 
was in its default T-Pose. Eventually, third party Python scripts 
allowed you to load a “reverse deformation” morph that would 
track the difference between a posed object, and a “corrected” 
version of that posed object.

Basically, “reverse deformation” allows you to export a figure 
in a posed position. Then you can morph out any distortion in 
the body or piece of clothing, and when you reload that morph 
back into Poser it only keeps track of the differences between 
the posed version and the corrected version. This allows you to 
create morphs that improve the appearance of a joint when it is 
rotated, and is useful for use in legacy figures that do not utilize 
weight mapping for improved joint bending.

To create a Joint Controlled Morph (JCM) use the following 
steps:

1. Load the figure that you want to morph into your Poser 
scene, and select it as the current figure.

2. Pose the figure in the pose that you want to correct. For 
example, if you want to fix an underarm bulge that appears 
when an arm is raised, then pose the arm in the raised 
position.

3. Do one of the following:
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 � If your joint controlled morph will span more than one 
body part, choose Figure > Export Figure Mesh to 
GoZ

 � If your joint controlled morph will affect only one body 
part, choose Object > Export Object Mesh to GoZ.

A dialog displays some options for the export.

 GoZ options dialog.

4. Check the Export Posed option, so that Poser exports your 
object in its posed state.

5. In the Polygon Grouping section, you have two choices 
for how you can group polygons when you export them to 
ZBrush. The method that you choose determines how you 
will be able to show and hide parts within ZBrush (either 
by material, or by body part) and are primarily for ease 

of editing in that application. For more information, see 
“Exporting Objects to ZBrush” on page 791.

6. Click Yes to continue. Your body part will open in ZBrush 
as a subtool. Drag the tool onto the scene and create your 
morph as you normally do.

7. Use the tools in ZBrush to create a morph that improves the 
appearance of the rotation; or, to add muscle definition such 
as a muscle bulge when an arm is bent. After your morph 
is complete, click the GoZ button in the Tool palette (in the 
upper right section of your screen by default) to send the 
OBJ file back to Poser.

8. When you return to Poser, a dialog asks if you want to 
import the modified geometry. If you used the Figure > 
Export Figure Mesh to GoZ it will ask if you want to create 
a full body morph. If you used the Object > Export Object 
Mesh to GoZ it will ask if you want to create a morph 
for the body part you exported. Enter a name for the new 
morph and press OK to continue.
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 Enter a name for the new joint controlled morph in Poser.

9. Initially, the dial will be set to zero. To test the morph, 
choose the BODY actor, and dial your morph to test it. You’ll 
also notice that a corresponding dial will only appear in the 
individual body actors that were affected by the morph.

10. Use the Dependent Parameters editor to link the rotation 
of the arm to the dial setting on the morph. For example, 
if you created a morph that creates a bulge in the shoulder 
when the forearm is bent, use the Dependent Parameters 
Editor to activate the morph when the forearm is bent to the 
angle that you created the morph at, and when the forearm 
is in its default position (bent to zero degrees), set your new 
morph to zero. When you create your dependencies, make 
sure you dial your morph in the BODY actor, and not in 
each individual body part.

Importing Hair from GoZ

1. Load a character into your Poser scene, and select the figure.

1. Choose Figure > Export Figure Mesh to GoZ as discussed 
in “Exporting Objects to ZBrush” on page 791. Your 
figure will load into ZBrush as a tool.

2. Drag the figure into the ZBrush document and switch to 
Edit mode. Use the Move, Scale, and Rotate tools to zoom in 
to the head. Optionally, select a white material for the head.

3. The Standard brush will be selected by default. Press the 
CTRL/CMD key while you paint a mask on the head to 
specify where the hair will be grown.

 In ZBrush, mask the polygons where you want the hair to grow.
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4. Select the Fibermesh panel from the right side of the 
interface, and turn Preview on.

 Turn on Fibermesh preview.

5. Expand the Modifiers tab and adjust the settings as 
instructed in your ZBrush user manual. After the settings 
are to your liking, click Preview again as necessary, and 
then click Accept to create a new subtool from the mesh 
fibers.

You may be asked if you want to use Fast 
Preview mode for faster interaction.

 Click Accept to turn the fibermesh into a subtool.

6. Switch to the Subtools palette, and select the Fibermesh as 
the current subtool. Use the ZBrush styling tools to style the 
hair as instructed in your ZBrush user manual.
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 Select the Fibermesh subtool to style the hair.

7. After the hair is styled to your liking, make sure that you 
have the Fibermesh subtool selected, as shown in the 
previous figure. Then click the GoZ button to export the 
Fibermesh hair back into Poser.

 Styled hair as shown in ZBrush.

 Click the GoZ button to send the hair back to Poser.
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8. Poser will ask if you want to import the Fiber geometry as a 
hair prop. Choose OK to continue.

9. The Select Objects dialog appears, so that you can select the 
actor to attach the hair to. Choose the characters Head actor 
and click OK. The fibermesh hair appears in your scene.

 Choose the character’s Head as the parent to the fibermesh hair.

After the hair appears in your scene, you can select the hair and 
open the Material Room to change the hair colors. Note that you 
will not be able to restyle the hair in the Hair Room.

 Fibermesh hair rendered in Poser.
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Importing/Exporting a GoZ File
If ZBrush is not available on your current machine, you can 
use the File > Import > ZBrush and File > Export > ZBrush 
commands to work with Poser figures/objects on another 
machine that does have it available. This command will import 
or export a ZBrush binary object format file. When you use this 
command to export a ZBrush binary object, Poser will prompt 
you to select a folder and assign a file name to the object you 
save. The object will be saved with a .GoZ extension.

PoserFusion Hosting Plug-ins
Poser Pro includes 3ds Max, CINEMA 4D and Maya plug-
ins, letting you open and host Poser Pro files within these 
applications. Modeling articulated poseable figures is a difficult 
and time-consuming task. PoserFusion allows you to load one 
of dozens of ready-made figures and select from a wide variety 
of clothing and preset poses, allowing you to get high-quality 
results in a short amount of time.

Hosting vs. Importing

PoserFusion plug-ins allow you to host Poser files directly within 
3ds Max, CINEMA 4D, LightWave 3D and Maya. Importing 
or exporting translates data from one format to another. 

PoserFusion plug-ins serve as a liaison between the host 
application and the Poser files, actually opening Poser files and 
accessing their contents directly in the host application. This 
allows you to take advantage of Poser Pro’s speed and ease of use 
and combines Poser files with the host applications’ powerful 
modeling, rendering, and animation tools. Poser files hosted 
within supported applications retain all of their data including 
materials, articulation, textures, walks, etc. Figures and props 
are treated as primitives and are manipulated within the host 
application as you would any other object. You may, however, 
need to open the Poser file within Poser Pro depending on the 
edits you wish to perform.

PoserFusion for 3ds Max

When you open a Poser file within 3ds Max, the selected file 
retains all of the data created within Poser Pro, including the 
geometries of the figures and props, materials, and keyframe 
data. 3ds Max treats hosted Poser figures/props as 3ds Max 
geometry primitives, meaning that you can perform any action 
to the Poser figure that you can perform on any other geometry 
primitive such as translations, rotations, modifiers, mesh 
edits, etc. In addition, the Create and Modify panels allow you 
additional control over hosted Poser files.
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Installing PoserFusion for 3ds Max

The installer automatically installs the 3ds Max plug-in, which 
will be available to you as soon as you launch 3ds Max.

Loading A Poser File

To select a Poser file to open and host within 3ds Max:

1. Select the Create panel.

2. Click the Geometries button.

3. Select Poser Objects in the pull-down menu.

4. Click the Scene *.PZ3 button in the Object Type rollout.

5. The Scene Creation rollout will automatically be open at 
this point. Click the Load File (…) button to open a dialog 
allowing you to navigate to the folder containing the desired 
file. The words ‘No File Loaded’ appear to the left of the 
Load File button if you have not yet loaded a Poser file. 
Click the Load File (…) button to open a dialog allowing 
you to navigate to the folder containing the Poser file you 
wish to load. The name of the object instance appears in the 
Name and Color rollout after you have created the objects in 
the scene via clicking and dragging or keyboard entry.

Once a Poser file is loaded, the Keyboard Entry, Scene 
Options, and Info rollouts will appear.

Creating Instances

Once you have selected the Poser file, 3ds Max creates the Poser 
Universe object. To work with figures and props, you must create 
at least one instance of the figure(s) and/or prop(s) within your 
3ds Max scene. An easy way to understand this concept is to 
think of the Poser file as a template from which to create new 
figures/props. There are two ways to do this:

1. Click, drag, then release the left mouse button. Large files 
may take a moment to appear after you click. Drag slowly 
and wait for the figure/prop(s) to appear before releasing 
the mouse button.

2. Use the Keyboard Entry rollout to specify a position and 
scale, and then click the Create button.

The newly created Poser Universe, scene, and figure/prop 
primitives appear in the 3ds Max view panes.
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 A Poser scene imported into 3ds Max.

Working with Poser Files in 3ds Max

The following general rules apply when hosting Poser files within 
3ds Max:

• You can host files with multiple figures. You can also load 
one or more Poser files. 3ds Max places loaded Poser files 
into its hierarchy as follows:

 � Geometry primitives are created for each figure and 
each prop in the Poser file.

 � When you create an instance of a Poser file, 3ds Max 
will create a Poser Scene object, which is the parent 
object for all figures and props from the Poser file.

 � 3ds Max creates a Poser Universe dummy object when 
you load the first Poser file. This object is the parent 
object for all Poser Scene objects.

 � The Create and Modify panels will display different 
rollouts depending on the type of Poser object selected:

Poser figure/prop: Scene File, Scene Options, Info

Poser Scene: Scene File, Scene Options, Info

Poser Universe: Info

• You can modify any type of Poser object as if it were a 3ds 
Max object; for example, figures and props can be edited 
just like any other type of 3ds Max geometry primitive.

The Create Panel

The Create panel contains the following rollouts:

• Object Type: Standard 3ds Max rollout

• Name + Color: Standard 3ds Max rollout

• Scene Creation: Please refer to “Loading A Poser File” on 
page 804.
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• Keyboard Entry: Please refer to “Creating Instances” on 
page 804.

The Create panel also contains the following additional rollouts:

The Scene Options Rollout

Scene Options gives you the following options:

 3ds Max Scene Options.

• Scene Scaling: Enter a value in the Scale field or use the 
up and down arrows to specify the desired scale for all of 
the objects in the current scene. The scale value is expressed 
as the percentage of the original scale set when the file was 
created in Poser Pro. To scale individual figures and props, 
use the 3ds Max Scale. When clicking and dragging to create 
a Poser object, the scale value will change to reflect the size 
of the scene that you are creating as you drag.

• Display Tracking: Check the desired radio button to specify 
Box Tracking (all objects in the current Poser file appear 
as bounding boxes for all figures/props at all times), Fast 
Tracking (all objects in the current Poser file displayed in 
full while static and as bounding boxes for all figures/props 
when moving), or Full Tracking (all objects in the current 
Poser file are displayed in full at all times).

• Frame Offset/Frame Remapping: Please refer to the 
section, Animating Poser Objects in for information on 
controlling Poser animations within 3ds Max.

The Info Rollout

The Info rollout appears as follows:
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 PoserFusion for 3ds Max screen.

In addition to displaying the PoserFusion plug-in version 
number, the Info rollout contains three buttons. Clicking the 
Smith Micro Graphics button opens your Web browser and 
takes you to the Smith Micro Graphics Web page. Clicking the 
User Guide… button opens the electronic (PDF) version of 
this document. Clicking the About… button opens a window 
displaying more information about Smith Micro Graphics and 
the PoserFusion plug-in.

The Modify Panel

The Modify Panel contains the following rollouts:

• Modifiers: standard 3ds Max rollout

• Modifier Stack: standard 3ds Max rollout

• Scene File: Please refer to “The Scene File Rollout” on 
page 807.

• Scene Options: Please refer to “The Scene Options 
Rollout” on page 806.

• Info: Please refer to “The Info Rollout” on page 806.

The Scene File Rollout

The Scene File rollout appears in the Modify panel in addition 
to the Scene Options and Info rollouts:
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 The Scene File rollout.

The Scene File rollout displays the Poser scene file that the 
currently selected figure/prop or Poser Scene object is associated 
with:

• Reload File: Clicking the Reload File… button refreshes 
the data from the Poser file that is associated with the Poser 
Scene instance. This function reloads the associated Poser 
file keyframe data. Thus, if you articulate the figure in 
Poser, you can access your changes without losing any other 
modifications you may have made on top of your objects 
in 3ds Max. If the original Poser file has had figures/props 
added or removed, you will need to recreate the scene via 
the Scene Creation rollout on the Create Panel.

• File Information: Clicking the File Info… button displays 
information about the current file, including the full path, 
Poser Pro application path, and other useful information.

Animating Poser Objects in 3ds Max

You can control how any animation of your Poser objects relates 
to your current 3ds Max animation by using the Scene Options 
rollout in either the Create or Modify panel.

Frame Ranges

An out of range condition exists when the 3ds Max animation 
has frames occurring before the Poser animation’s start frame 
and/or ends after the Poser animation’s end frame. The end 
frame is defined as

End Frame=Start Frame+(Num Frames – 1)

For example, if Start Frame=10 and Num Frames=15, then End 
Frame=24.

If frame out of range radio buttons allow you to specify how to 
handle out-of-range situations.
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 Animating Poser objects in 3ds Max.

Enable the appropriate radio button to make your selection:

• Loop: Checking the Loop radio button causes the Poser 
animation to repeat as many times as necessary to fill all of 
the 3ds Max animation frames. This can include a partial 
animation cycle. For example, if the Poser animation is 30 
frames long and the 3ds Max animation is 45, the Poser 
animation will loop 1.5 times to take up all 45 frames.

• Freeze: Enabling the Freeze radio button causes the Poser 
animation to not play before its starting frame and/or after 
its ending frame.

• Hide: Enabling the Hide radio button causes the Poser 
animation to be invisible before its starting frame and/or 
after its ending frame.

Offsetting Frames

You can insert your Poser animation at any desired point in 
the 3ds Max animation using the Frame Offset controls in the 
Scene Options rollout.

 Offset options in 3ds Max.

You have three offset options:

• Start on Frame: Enter the 3ds Max animation frame where 
you wish your Poser animation to begin by either entering a 
valid frame number in the Start on Frame field or using the 
up and down arrows.

• Poser Source Frames: You are not limited to simply 
running your entire Poser animation within 3ds Max.



Poser Pro 2014
Reference Manual 

810

Chapter 34: Using Poser with Other Applications

• Start Frame: Enter the number of the frame in the Poser 
file where you wish to begin the Poser animation in the Start 
Frame field or use the up and down arrows.

• Number of Frames: Enter the number of frames in the 
Poser file after the start frame that you wish to use in the 
Number of Frames field or use the up and down arrows.

For example, you have a 100-frame 3ds Max animation and 
wish to open a 30-frame Poser animation. You could specify the 
Poser animation will begin at frame 45 of the 3ds Max frame. 
You could also specify that you wish to start the Poser animation 
from the 10th frame of the Poser file and that you wish to use the 
15 frames that follow. This scenario would cause the following 
to occur:

3ds Max animation Poser animation

Frames 0-44 As specified in the Out of 
Range options.

Frame 45 Frame 10

Frame 46 Frame 11

Frame 59 Frame 24

Frames 61-100 As specified in the Out of 
Range options.

Remapping Frames

You are not limited to simply specifying frame offsets. By 
enabling Frame Remapping, you have full control over the 
sense of time that the Poser scene experiences for shortening, 
extending, accelerating and decelerating the Poser animation. 
This provides extended control over an existing keyframed 
animation in Poser Pro, without having to go back and adjust it 
in Poser Pro.

 Frame remapping in 3ds Max.

Check the Enable box to enable Frame Remapping. Enabling 
this option disables the Frame Offset and If frame out-of-
range options. Once remapping is enabled, you can select any 
frame of the 3ds Max animation and map any frame of the Poser 
animation to that frame. This feature is extremely powerful 
since it allows you to literally reshape your Poser animation. You 
can speed it up or slow it down, run it backward, or even skip 
randomly through the animation.
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To remap frames, move to the desired 3ds Max frame using the 
time slider or other 3ds Max tool, turn on the Animate function, 
and enter a valid Poser animation frame number in the Remap 
to Frame field or use the up and down arrows.

Once you have remapped frames, you can use 3ds Max’s Track 
View window to obtain full control over how the map will 
behave. Click the Open Track View icon to open the Track View 
window. Then expand the Object node under the Poser Scene 
object. Select Remap to Frame and use the standard 3ds Max 
keyframing techniques to remap the Poser scene’s sense of time.

Poser Materials in 3ds Max

You can control your Poser objects’ materials as you would any 
other material in 3ds Max by clicking the Open Materials Editor 
icon ( ) to open the Materials Editor. Next, select the Pick 
Material from Object tool and click within the desired Poser 
figure/prop to load its materials into the 3ds Max Materials 
Editor.

PoserFusion for Cinema 4D

To host a Poser file in CINEMA 4D:

1. Go to the Plug-ins pull-down menu and select Poser 
Object.

 PoserFusion for Cinema 4D.

2. Scene Creation: After creating a Poser object, the 
properties of the object will show up in the Attribute 
Manager. Click the […] button located under the Object 
properties to load the Poser scene.

3. Material Creation: Once the file has loaded, click the Create 
materials button to create materials which approximate the 
materials from Poser.
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4. Once your Poser file is hosted in CINEMA 4D, a link is 
maintained to the Poser file on disk. Make sure you keep 
a copy of the Poser file in the same location on the disk in 
order to re-load the CINEMA 4D files that contain hosted 
Poser files.

5. In addition, you can re-load different versions of the same 
Poser file if you want to update your animation and poses.

Poser Object Properties

PoserFusion includes a number of options that affect the 
creation of textures and lights. Below is a detailed listing of the 
options and their uses.

 Poser Object Properties.

Poser File Attributes
The first attributes for Poser Objects are the Poser file options.
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• File Browse: Choose the Poser scene file you wish to import 
using the Browse […] button. Click the Browse button. 
(Then navigate to your Poser file using the file dialog and 
click Open.

• Reload File: Clicking the Reload File button reloads the 
specified Poser file into CINEMA 4D and refreshes all 
existing instances of that file. This button allows you to 
work in CINEMA 4D and Poser Pro simultaneously. You 
can quickly and easily import any changes you make to 
the Poser file. Just save your Poser file over your previous 
version, and click the Reload File button. You do not have 
to quit Poser Pro or CINEMA 4D.

Display Tracking

Each Poser object may be set to a display tracking mode. These 
modes control how the geometry is displayed during playback of 
animation, and scrubbing in the frame bar.

 Display Tracking options.

• Box: An object that is set to Box Tracking always appears 
as one or more boxes in CINEMA 4D’s view pane. This is a 
very quick way to get a general idea of the movement within 

your scene without the overhead of a complete geometry 
calculation.

• Full: An object that is set to Full Tracking displays its full 
geometry and materials even during playback or frame 
scrubbing. This mode provides the most accurate display, 
but can also be slower.

Disable Animation

When Disable Anim is enabled, the Poser file will stay at a single 
frame. Animation from inside the Poser file will be ignored and 
will not play back. During a render, the Poser file will stay static 
(not moving) through the entire render.

 Disabling Animation.

If Frame out of Range

When you have animation in a Poser file, there is a start and end 
frame for the animation within the Poser file. Your animation 
inside CINEMA 4D may be longer than the animation from 
Poser Pro. The Frame Out of Range options are used to 
determine what happens with the Poser file when the frame in 
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CINEMA 4D is outside of the animation range from your Poser 
file.

 Options if a frame is out of range.

• Loop: The Poser animation will loop as many times as 
necessary to fill all of the CINEMA 4D animation frames. 
This can include a partial loop. For example, if the Poser Pro 
animation is 30 frames long and the CINEMA 4D animation 
is 45 frames long, the Poser Pro animation will loop 1.5 
times to take up all 45 frames.

• Freeze: The Poser animation will freeze before its start 
frame and after its end frame. When viewing a frame after 
the end of the Poser animation, the Poser animation will be 
frozen in the same position as the last frame. When viewing 
a frame before the beginning of the Poser animation, the 
Poser animation will be frozen in the same position as the 
first frame.

• Hide: When hide is selected, the Poser items will only be 
visible when your CINEMA 4D frame is inside the Poser 
animation range. If your CINEMA 4D frame goes before or 

after the frame range of your Poser file, the Poser items will 
become invisible.

Frame Offset Attributes

Using these options, you can insert your Poser animation at any 
desired point in the CINEMA 4D animation. For example, if 
you have a walk cycle that starts at frame 1 in Poser, you can use 
these options to make the character start walking at frame 100 
inside CINEMA 4D.

 Frame offset attributes.

• Start on Frame: This parameter allows you to enter the 
CINEMA 4D animation frame where you wish your Poser 
animation to begin. If you enter a frame number like 125, 
then your Poser animation will start to play at frame 125. 
Until frame 125, the Frame Out of Range options will be 
used to determine if there is movement before the start 
frame.
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• Poser Start Frame: This indicates the first frame of 
animation that you wish to use from the Poser file. 
Animation in the Poser file before this frame will not appear 
in the CINEMA 4D scene.

• Num Poser frames: This is the numbers of frames after 
your Start Frame that you would like to use. If you choose 
to only use 15 frames, then you will only see 15 frames from 
your Poser animation inside of CINEMA 4D.

Frame Remapping Attributes

You are not limited to simply specifying frame offsets. By 
enabling Frame Remapping, you have full control over 
playback of your Poser animation within CINEMA 4D.

 Frame remapping attributes.

• Enable: Check the Enable box to enable frame remapping. 
Enabling this option disables frame offsets and out-of-range 
options. Once remapping is enabled, you can modify the 
playback of the Poser animation by animating the Remap to 
Frame parameter. This feature is extremely powerful since 

it allows you to literally reshape your Poser animation. You 
can speed up your Poser animation or slow it down, run it 
backward, or even skip randomly through the animation.

• Remap to Frame: To remap frames, simply animate the 
Remap to Frame parameter. Your Poser scene will move 
to whichever frame number is specified in this parameter. 
For example, to play your Poser file backwards, you would 
animate this parameter from a higher number frame, to a 
lower number frame.

Hair Attributes

PoserFusion has the ability to preview and render strand-based 
Poser hair in CINEMA 4D.

 Hair attributes.

• For speed purposes, only the guide hairs are visible by 
default. In order to view and render a full hair simulation, 
turn on the Populate hair option.
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• Hair root scale: This is the scale of the hair geometry at 
the root of the hair (close to the scalp). This can be raised if 
the hair looks too sparse close to the scalp. Try to make this 
value as small as possible for quickest rendering results.

• Hair tip scale: This is the scale of the hair geometry at 
the end of the hair. This can be raised if the hair looks too 
sparse at the tips. Try to make this value as small as possible 
for quickest rendering results.

PoserFusion for Maya

To host a Poser file in Maya, select File > Import. In the File 
Dialog, select Poser (*.*) as the file type and choose the Poser file 
you want to host inside Maya.

Make sure you keep a copy of the Poser file in the same location 
on the disk in order to re-load the Maya files that contain hosted 
Poser files so you can re-load different versions of the same 
Poser file if you want to update your animation and poses. 
Instructions on updating versions of your Poser file are located 
in the section describing the Shelf Buttons .

Import Options

PoserFusion includes a number of options for hosting your Poser 
file. To select the options for importing your file, from the Main 

Menu, select File Menu > Import Options. Select the Import 
Options that are appropriate and click Apply.

Below is a description of the options available.

Animation Controls

You can play back and view Poser animations from inside Maya 
when you use PoserFusion. One animation curve controls the 
frame you will see from the Poser file. This animation curve 
animates the frame attribute on the mpzFile node.
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 Import options.

Animation

Enabling the animation checkbox automatically sets up an 
animation that matches the range you specify for the Poser file. 
You can add animation later by animating the frame attribute on 
the mpzFile node.

 Animation checkbox.

Poser Range

This specifies the range of animation from the Poser file that 
will playback in Maya. You can use the actual frame range from 
your Poser file, or specify the first and last frame from the Poser 
file that will play back in Maya. This can be modified later by 
adjusting the animation curves.

 Poser range (for animation).
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Maya Range

This specifies Start and End frame in Maya during which 
animation will play back. The first frame specified in the Poser 
Range will start at the first frame specified in the Maya Range. 
The last frame specified in the Poser Range will occur in Maya 
at the last frame specified in the Maya Range. There are a few 
options for choosing the Animation Range in Maya.

• From Poser: Uses the animation range from the Poser file.

• Start: Specify the start frame in Maya, and the length of the 
range will automatically be imported from Poser.

• Start/End: Set a start and end frame in Maya. The length of 
the Poser Animation, as specified by the Poser Range will be 
compressed to fit in this range. This can be modified later by 
adjusting the animation curves.

 Maya Range.

Repeat Before/After

The Poser animation will play back outside of the specified 
Maya Range, based on the type of repeat option which is set. 

These options set the pre-infinity and post-infinity type on the 
animation curves. This can be modified later by adjusting the 
pre-infinity, and post-infinity options for the animation curves in 
the graph editor.

• None: No animation will playback out of the specified Maya 
Range.

• Cycle: Animation will repeat outside the Maya Range 
specified. The animation will play forward from the start 
again each time.

• Oscillate: Animation will repeat outside the Maya Range 
specified.

 Repeat options.

Texture Options

• Use Full Texture History: PoserFusion can maintain a full 
texture history back to the original Poser file. When using 
this option, any changes in color or texture maps assigned 
to the Poser shaders will update the next time the file is re-
loaded in Maya. This option is disabled by default for better 
compatibility with external renderers such as Mental Ray.
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• Process .bum Files: .bum is a special file format that 
historically was used in Poser  for bump maps. When you 
enable Process .bum files, Maya can read, and understand 
.bum files. This option is enabled by default. Disable this 
option for compatibility with Mental Ray, and other external 
renderers.

• Use Transparency Min/Max: Poser has a special function 
that allows a drop off in transparency based on surface 
angle to camera. This option emulates this behavior with 
Maya shader nodes. This option is enabled by default for 
highest compatibility with Poser shaders. Disable this 
option off if you are having trouble painting on shader 
transparency textures.

• Multiply Texture when Appropriate: Poser shaders 
multiply the texture color by the shader color. When this 
option is enabled, shaders created in Maya will have a 
multiply node inserted to emulate this behavior. This option 
is enabled by default for the highest compatibility with Poser 
shaders. This option can interfere with some Maya features 
like painting on textures, therefore disable the option if you 
experience trouble.

 Texture options.

Scale Conversions

The Poser world has a scale that goes from 0 to 1. In order 
to make it easier for Maya users, we have implemented an 
automatic scale conversion with 4 settings.

• Real Life: This is the setting to use if you are working in 
life-size scale within Maya. All geometry gets scaled up by 
243.84

• Centimeters As Feet: A number of Maya users start 
with the default units (centimeters) and use them as feet 
instead. This setting works very well with this workflow. All 
geometry gets scaled up by 8.0.

• Direct: No scale conversion occurs; the geometry is the 
same scale as in Poser.

• Manual: This mode lets the user set the Scale X, Scale Y, 
and Scale Z to any numeric value.
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 Scale conversions.

The PoserFusion Shelf

The Shelf included with PoserFusion adds a number of 
commands which work with Poser. These include commands 
to help reload files, and switch between Bounding Box, and Full 
Geometry.

 The Poser Fusion shelf.

File Update Buttons

 File Update buttons.

The first 3 icons are used for reloading and updating Poser files 
from within Maya without having to re-load the file Poser files 
are set up in Maya using Construction History. This means when 
you reload a Poser file, all texture assignments and modifications 
made in your Maya file remain the same. The only difference is 
that you’ll now be referencing the new poses/animation from the 
updated file. Here is a description of the specific functions, and 
what they do. 

File Reload Browser (selected)

Use the File Reload Browser to select a different version of a 
file from disk. The file should contain the same Poser characters 
as the file you already have loaded, but can contain different 
poses/animations. To use this function, select any character 
from the file you want to reload, and click on the shelf button. 
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 File Reload Browser.

File Reload (selected)

Use the File Reload to reload the current Poser file from disk. 
The file should contain the same Poser characters as the file you 
already have loaded, but can contain different poses/animations. 
One example of using this would be if someone had modified the 
poses or animation in the original Poser file, and you wanted to 
see the updated changes in Maya. To use this function, select any 
character from the file you want to reload, and click on the shelf 
button.

 File Reload (Selected).

File Reload (all)

This command is the same as the File Reload (selected), and 
will reload all Poser files in the scene, regardless of what is 
selected. To use this function, click on the Shelf Button. 

 File Reload (All).

Playback Buttons

 Playback buttons.

Bounding Box (selected)

This button makes the currently selected Poser character display 
as bounding boxes.
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 Bounding Box.

Bounding Box Playback (selected)

This button makes the currently selected Poser character display 
as bounding box during playback for quick interaction. 

 Bounding Box (Playback).

Full Geometry (selected)

Use this button to make the full geometry display for all Poser 
characters.

 Full Geometry.

Bounding Box (all)

Use this button to make the currently selected Poser character 
display as bounding boxes. 

 Bounding Box.

Bounding Box Playback (all)

Make all Poser characters display as a bounding boxes during 
playback.

 Bounding Box Playback.

Full Geometry (all)

Use this button to make the full geometry display for all Poser 
characters.
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 Full Geometry.

Camera Export Buttons

This button will export a camera pose from Maya to Poser. This 
feature makes it easy to line up a pose between Poser and Maya. 
To use this feature, first select a character you want to use as 
a scale reference, and then select the camera node you wish to 
export. The Export Camera window will then appear. Enter a 
name for the new camera pose. This name must end in .CM2. 
The exported camera pose will show up with the camera sets in 
Poser.

 Exporting a camera pose.

PoserFusion for LightWave

Double-click the InstallPoserFusionForLightWave.exe or 
InstallPoserFusionForLightWavex64.exe icon to run the 
respective 32-bit or 64-bit plug-in installer.

This section expands upon the LightWave installation 
instructions contained within the Poser Pro Introduction 
Guide by including instructions for LightWave. The following 
instructions should be followed after running the installation 
application on your Poser Pro CD.

Adding PoserFusion to LightWave

Launch LightWave and click the Utilities tab. Then choose Plug-
ins > Add Plug-ins as shown below.
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 Adding Poser Fusion to LightWave.

In the dialog box that appears, navigate to the PzrForLW folder 
within your LightWave plug-in folder, select the file PzrForLW.p 
and click OK. The following confirmation window should 
appear.

 Confirmation window for adding the plug-ins.

Exit and re-launch LightWave. PoserFusion for LightWave is 
now ready for use.

Using PoserFusion for LightWave

When you open a Poser file within LightWave, the selected 
file retains all of the data created within Poser including the 
geometries of the figures and props, materials, and keyframe 
data. LightWave treats hosted Poser figures/props as LightWave 
object primitives. This means that you can perform any action to 
the Poser figure that you can perform on any other LightWave 
object primitive such as scale, translate, or rotate. For example, 
if you host a Poser file containing a figure that was created with 
a walk-in-place animation, you can key a simple path that the 
entire figure follows; however, you can only perform direct 
articulation operations on the figure in Poser. If you wish to 
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modify the Poser animation, you need to modify the Poser file 
within Poser, save your changes, and re-load the figure into 
LightWave.

The Bounding Box Threshold and Dynamic 
Update settings can affect what you see during 

playback. If you see a bounding box with no articulating 
figure details when playing a keyframed animation, 
please check and adjust your Display Option settings as 
follows:

• Select the desired figure/prop, then select Extras > Statistics 
and note the number of polygons comprising the selected 
item.

• Be sure to press [ENTER] before closing the Display 
Options dialog box to save your changes.

You should now see the figure/prop within the bounding box 
when scrubbing the frame handle or doing a keyframe playback.

Loading Poser Figures

There are two ways to load Poser files into LightWave depending 
on whether you are opening the given Poser file for the first or 
subsequent times.

Loading a Poser File – First Time

To load a Poser file into LightWave for the first time:

1. In LightWave Layout, choose File > Load > Load Scene.

1. In the Load Scene dialog box, select All Files in the Files 
of Type pull-down menu. Then locate and open your 
desired Poser (*.PZ3 or *.PZZ) file.

The first time you use PoserFusion for 
LightWave you will be prompted to enter your 

name and PoserFusion for LightWave serial number. 
Click OK to continue with the import after you provide 
the information. You will be prompted to enter the path 
to the Poser application before you proceed with the 
import. The Poser Pro EXE (Windows) or APP (Mac) file 
is located in the Poser installation directory.

2. PoserFusion prompts you to choose some options for your 
geometry:

 � Convert to triangular mesh: Choose this option if you 
want to convert all polygons to triangles.

 � Leave mesh as general polygons: This is the default 
selection, which is recommended for most cases.



Poser Pro 2014
Reference Manual 

826

Chapter 34: Using Poser with Other Applications

3. Your figure(s) and/or prop(s) from the Poser file appear in 
the LightWave window.

 The Poser scene imported into LightWave.

You can now use LightWave’s tools to view any animations 
contained within the hosted Poser scene, and you can modify the 
figure(s) as described in “Working with Poser Figures and Props 
in LightWave” on page 827.

Loading a Poser File – Subsequent Times

When you open a Poser scene for the first time with PoserFusion 
for LightWave, PoserFusion automatically creates the following 
file structure in the same folder that contained the original Poser 
scene.

 Subsequent imports are numbered in sequential order.

When loading the same file for the second or subsequent time, 
you do not need to select All Files and load the Poser file. 
Instead, simply open the appropriate LightWave *.LWS file.

The <PoserFilename > .LWS file is the LightWave scene file, 
where <PoserFilename > is the name of the Poser file. This 
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scene file contains a reference to the original Poser file, meaning 
that you can perform many changes to the Poser file such as 
articulation, animation, etc. and the LWS file will load the 
current version of the Poser scene file. The exceptions to this are 
where you have changed a figure or prop’s geometry or added/
deleted a figure/prop from the Poser file. IN this case, you 
should reload the original Poser file.

In addition to the *.LWS file, LightWave creates a sub-folder 
with the name <PoserFilename > .LWO. This folder contains 
one *.LWO (LightWave geometry) file for each figure and prop 
within the Poser file. The file names will reflect the names of 
each figure and prop within the Poser file.

You may not be able to load a Poser file that has 
the same name as an *.LWS file previously 

created by PoserFusion for LightWave while that *.LWS 
file is loaded in LightWave.  This is because PoserFusion 
cannot overwrite the *.LWS and *.LWO files while they 
are open in LightWave.  This is normal behavior.

Working with Poser Figures and Props in LightWave

This section covers important topics to keep in mind when 
working with Poser files in LightWave.

Hierarchies

For each loaded Poser file, LightWave creates a <PoserScene > 
null object, which will be named according to the name of the 
loaded Poser file. If you load multiple instances of the same 
Poser file (see following section), the null objects created will be 
named <PoserScene > (1) through <PoserScene > (n), with n 
being the number of instances of the same file.

The PoserScene null object is the parent of all of the child objects 
<Figure > 1 through <Figure > n and/or <Prop > 1 through 
<Prop > n, where <Figure > and <Prop > are the names of the 
figures and props within the Poser file and n is the particular 
instance of each figure/prop (see below).

 Object properties.
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The PoserScene null object is the default selected 
item. To make changes to a specific child (figure 

or prop), you must select the desired figure/prop.

You can only access the Poser panel within 
LightWave if you have an individual figure or 

prop selected.

Creating Multiple Instances

You can create multiple instances of Poser figures or props either 
by cloning the desired figure or prop using standard LightWave 
functionality or by reloading the appropriate Poser file. Cloning 
is generally preferable since it uses less RAM and hard drive 
space. Creating a new instance of a PoserScene null object will 
create a new PoserScene null object with the name <PoserScene 
> (n+1), where n+1 is the number of the new instance. Creating a 
new instance of a figure or prop will create a new object with the 
name <Figure/Prop > (n+1).

 Creating a new object.

Cloning a null object with no child objects 
selected creates a new instance of the null object 

but does not recursively clone child objects. To clone a 
parent object and its child objects, you must select the 
child objects before cloning the null object. Please refer 
to your LightWave documentation for more information 
on hierarchies and cloning.
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Accessing Poser Functionality Within LightWave

You must have a Poser figure or prop selected in order to 
access the Poser interface within LightWave. To access Poser 
functionality in LightWave:

1. Select the Poser figure/prop.

2. Click the Item Properties button on the bottom of the 
Layout window or press [p] (lowercase) to open the Object 
Properties window.

 Object properties.

3. Select the Deform tab.

4. Double-click PzrForLW - PoserDisplacement in the 
displacement plug-in list to open the Poser Scene window.

 The Poser Scene window.

The Poser Scene Panel

The Poser Scene panel is where you access Poser functionality 
within LightWave. This window contains three tabs, which are 
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discussed in the following sections. To close the Poser Scene 
window, click the Continue button at the bottom of each tab.

The Scene File Panel

The Scene File panel displays the Poser scene file that the 
currently selected figure/prop or Poser Scene null object is 
associated with.

 Scene File options.

The following functions are available:

• Reload File: Clicking the Reload File… button refreshes the 
Poser file associated with the currently selected PoserScene 
object. This function reloads the associated Poser file 
keyframe data from the Poser file. Thus, if you articulate the 

figure in Poser, you can access your changes without losing 
any other modifications you may have made on top of your 
objects in LightWave.

• File Information: Clicking the File Info… button displays 
information about the current file, including the full path, 
Poser application path, and other useful information.

The Scene Options Panel

The Scene Options panel is where you control your hosted Poser 
scene.
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 Scene options.

The Scene Options rollout gives you the following options:

• Scale: Enter a value in the Scale field or use the mini slider 
to specify the desired scale for all of the objects in the 

current scene. The scale value is expressed as the percentage 
of the original scale set when the file was created in Poser.

• Frame out of range/Frame Offset: Please refer to 
“Animating Poser Objects in LightWave” on page 832 
for information on controlling Poser animations within 
LightWave.

The Info Panel

The Info panel displays the PoserFusion version number and 
allows you to access information about Smith Micro and Poser 
Pro.
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 The Info panel.

The Info rollout contains three buttons:

• Clicking the www.smithmicro.com button opens your Web 
browser and takes you to the Smith Micro home page.

• Clicking the User Guide… button opens the electronic 
(PDF) Poser Pro User Guide.

• Clicking the About… button opens a window displaying 
more information about PoserFusion.

Animating Poser Objects in LightWave

You can control how any animation of your Poser objects relates 
to your current LightWave animation by using the Scene Options 
rollout in either the Create or Modify panel.

Frame Ranges

An out of range condition exists when the LightWave animation 
has frames occurring before the Poser animation’s start frame 
and/or ends after the Poser animation’s end frame. The end 
frame is defined as

End Frame=Start Frame+(Num Frames – 1)

For example, if Start Frame=10 and Num Frames=15, then End 
Frame=24.

The If frame out of range boxes allow you to specify how to 
handle out-of-range situations.

 Frame ranges.

Select the appropriate box to make your selection:

• Loop: Selecting the Loop box causes the Poser animation to 
repeat as many times as necessary to fill all of the 3D Studio 
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Max animation frames. This can include a partial animation 
cycle. For example, if the Poser animation is 30 frames long 
and the LightWave animation is 45, the Poser animation 
will loop 1.5 times to take up all 45 frames.

• Freeze: Selecting the Freeze box causes the Poser animation 
to not play before its starting frame and/or after its ending 
frame.

• Hide: Selecting the Hide box causes the Poser animation to 
be invisible before its starting frame and/or after its ending 
frame.

Offsetting Frames

You can insert your Poser animation at any desired point in the 
LightWave animation using the Frame Offset function in the 
Scene Options tab.

 Offsetting frames.

You have three offset options:

• Start on Frame: Enter the LightWave animation frame 
where you wish your Poser animation to begin by either 
entering a valid frame number in the Start on Frame field or 
using the mini slider.

• Poser Source Frames: You are not limited to simply 
running your entire Poser animation within LightWave.

 � Start Frame: Enter the number of the frame in the 
Poser file where you wish to begin the Poser animation 
in the Start Frame field or use the mini slider.
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 � Number of Frames: Enter the number of frames in the 
Poser file after the start frame that you wish to use in 
the Number of Frames field or use the mini slider.

For example, say you have a 100-frame LightWave animation 
and wish to open a 30-frame Poser animation. You could specify 
the Poser animation will begin at frame 45 of the LightWave 
animation. You could also specify that you wish to start the Poser 
animation from the 10th frame of the Poser file and that you 
wish to use the 15 frames that follow. This scenario would cause 
the following to occur: 

LightWave animation Poser animation

Frames 0-44 As specified in the Out of 
Range options.

Frame 45 Frame 10

Frame 46 Frame 11

Frame 59 Frame 24

Frames 61-100 As specified in the Out of 
Range options.

Poser Materials in LightWave

This section discusses using Poser materials within LightWave.

Accessing Poser Materials

In LightWave, click the Surface Editor button on the left side of 
the LightWave window, or press F5. You can do this with any tab 
selected.

Material Hierarchies

LightWave supports hierarchical materials, meaning that each 
object in a scene will have its own list of materials.

 Material Hierarchies.
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Texture Maps

LightWave supports the use of UV mapping.

You can view and modify any texture map by opening 
LightWave’s Texture Editor window as described in your 
LightWave documentation. Poser’s Texture, Bump, Reflection, 
and Transparency texture maps will load into LightWave.

NOTE: LightWave allows you to create UV data and/
or modify it by adding and/or repositioning UVs. This 
feature gives you complete control over how textures 
are applied to your figures and props. While Poser uses 
UV mapping, users were previously limited to using 
the UV data supplied by the geometry’s creator. Using 
Poser Pro and LightWave (or any other application 
that supports UV creation and modification), you can 
manipulate your figure or prop’s UV data to have 
textures behave exactly how you want them to.

By default, the Poser texture map loads into the Color channel in 
LightWave’s Surface Editor. The Poser UV data is available for 
any map you apply in LightWave on any channel that supports 
maps by setting the Projection Type to UV in LightWave’s 
Texture Editor, and the selected UV Map to Poser UVs. This 
is true for all Poser texture maps (Texture, Bump, Reflection, 
Transparency).

The Poser UV map is loaded once and is used in every 
LightWave Texture Mapping channel where you specify it as 
described in the previous paragraph. If you want the texture 
image map to be applied to a surface parameter, you can open 
the Texture Editor and apply the Poser UV maps to the specific 
parameter.

The following example describes the steps required.

1. Launch Poser Pro. Select and save the default Simon 
scene as a Poser file.

2. Launch LightWave.

3. Load the Poser file you just created by selecting File > Load 
> Load Scene and choosing All Files from the Files of 
Type drop-down list. Open the .PZ3 file that you created in 
Step 1.

4. If prompted, locate the scene textures by selecting All Files. 
Locate the textures in your default Runtime folder.

5. After the scene opens in LightWave, open the Surface 
Editor.

6. Select a Surface name (such as Head, shown in the following 
figure).

7. Open the Color (or other channel) Texture Editor. Set 
Projection to UV, UV Map to Poser UVs and specify the 
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image file to use as the texture. Click Use Textures. The 
Poser UV map is now applied to your figure.

 Configuring texture maps.

Part 8: 
PoserPython
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Chapter 35: About 
PoserPython

This section explains a few Python basics and lists each of 
the customized PoserPython methods, including explaining 
functionality and providing syntax and use examples. It 
provides a certain level of background and behind-the-scenes 
explanations that will put the PoserPython types and methods 
involved into context.

Note that this chapter assumes that you have at least a basic 
level of understanding about the Python scripting language. 
While it does explain a few basic Python concepts in order to 
add clarity and context, this chapter is not intended to teach you 
Python. There are numerous excellent sources of information 
for learning Python, many of which are available for free. Please 
refer to “Other Important Resources” on page 10 for a listing 
of some recommended Python resources.

Python (named after Monty Python’s Flying Circus) is a high-
level, interpreted, object-oriented scripting language first 
developed in 1989 by Mr. Guido van Rossum and first released 
as free software in 1991 after extensive testing. It is an extremely 
powerful and easy-to-learn language that runs on virtually all 
platforms and that can be extensively customized and modified 
to run with other applications (such as Poser) and programming 

languages. Because it is free software, Python is freely usable and 
can be distributed free of charge. Python’s inclusion of a number 
of high-level data types as well as dynamic typing makes it easy 
for users to get their job done without the implementation hassle 
common to lower-level languages.

PoserPython is a customized implementation of the Python 
interpreter that includes many commands not found in the 
standard Python releases. This customization integrates Python 
with Poser and provides you with an extensive list of easy-
to-use commands that can greatly reduce the time you spend 
performing repetitive tasks in Poser.

One of PoserPython’s best features is that you do not need to 
be a programmer to begin enjoying its benefits. Poser includes 
a number of useful sample scripts that can be executed by 
clicking a button. You never have to see a line of code, and 
none of your friends will ever label you as a programmer! That 
said, another of PoserPython’s best features is that you can “get 
under the hood” to write scripts that will do just about anything. 
PoserPython gives you virtually full control over your Poser 
documents including figures, props, lights, cameras, scenes, 
etc. and their building blocks and parameters. As you can see, 
PoserPython benefits both novice and expert alike!

PoserPython also includes the Numerical Python extension, 
which loads automatically when Poser starts up. Many geometry 
methods use this extension for fast manipulation of vertex, set, 
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and polygon information. Please refer to http://www.python.
org/topics/scicomp/numpy.html for more information.

Why Python?
Adding support for a scripting language to Poser gives users 
unprecedented power and flexibility to automate and customize 
their Poser experience and liberate creativity and productivity. 
The combination of simplicity, power, extensibility, and free 
distribution rights is making Python an increasingly popular 
programming language and has made it the obvious choice 
for integration with Poser. The PoserPython additions provide 
advanced Poser users with virtually infinite control and 
flexibility: A few lines of Python code can quickly automate 
processes that might take hours if done manually. And, with 
Poser’s internal structures exposed in the Python environment, 
you can write importers or exporters that interact with obscure 
or proprietary data formats. Because Python runs entirely within 
Poser, the only external application you’ll need for creating 
Python scripts is your favorite text editor.

A Word of Warning
Unlimited control is a double-edged sword. On one hand, users 
have direct access to their creations and underlying data. On 
the other hand, it is impossible to anticipate every conceivable 

PoserPython script. Because of the inherent power that 
scripting provides, it is possible to accidentally or intentionally 
destroy data, possibly beyond Poser itself. We at Smith Micro 
Software have made every attempt to provide “safe” methods 
for manipulating Poser internals, and in most cases a Python 
mistake simply means that the interpreter throws an exception 
and halts the script execution. Nevertheless, Python is an entire 
programming language designed with far more than Poser in 
mind. It is a powerful tool and, like all tools, should be used 
with care. If you are not familiar with Python basics, we strongly 
recommend that you obtain training and begin your Python 
experience slowly and carefully so as to enjoy a smooth and 
trouble free learning curve.

PoserPython Types & Methods 
Listing
PoserPython consists of hundreds of custom methods, and 
Smith Micro Software is continually updating the list of available 
methods. Please refer to the PoserPython Methods Manual, 
which contains an organized listing of each PoserPython method 
available in Poser. It is included in PDF format on your Poser 
CD and is also accessible from within Poser by selecting Help > 
PoserPython Manual.

http://www.python.org/topics/scicomp/numpy.html
http://www.python.org/topics/scicomp/numpy.html
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Chapter 36: Basic 
PoserPython Concepts

This section describes some of PoserPython’s basic concepts in 
order to provide context.

How Python Integrates with Poser

There are two basic types of programming languages:

• Compiled: A special program called a compiler reads the 
code written by the programmer, translates it into a form 
directly readable by a computer, and creates an executable 
program that can run on its own on any supported computer 
platform. Languages such as C++ fit into this category.

• Interpreted: Interpreted programming languages require a 
special program called an interpreter to run the code written 
by the programmer. The interpreter reads the commands 
found in the code and executes them from beginning to 
end without translating the original code. The drawback to 
interpreted languages is that they must use the interpreter, 
and the code can never run as a standalone program. The 
advantage, however, is that a programmer can change the 
code and see the results very quickly without having to 
wait for the code to compile. Additions, edits, and deletions 
become fast and simple.

PoserPython consists of a standard Python interpreter that has 
been extended to recognize and execute commands that are 
not included with the standard Python language. PoserPython 
scripts written using the customized commands will only work 
with the Poser ProPack or subsequent versions (5 and on). You 
can, however, pass data back and forth between Poser and other 
Python scripts, programming languages, and applications.

The standard Poser application contains volumes of data about 
each item (figure, scene, light, camera, prop, etc.) found within 
a given scene. You control these parameters via the mouse and 
interface elements such as menus, buttons, dials, etc. However, 
you cannot directly manipulate the data itself. This helps make 
Poser easy to use, but does create limitations. For example, you 
have no way to automate repetitive tasks or record a complex 
series of actions for further use. PoserPython circumvents these 
limitations.

PoserPython exposes much of the raw Poser data. Using Python 
scripts, you can extract data from Poser, manipulate it, and pass 
it back into Poser. Essentially, you can program Poser to do what 
you want, and you are no longer confined to the Poser interface 
and Poser’s built-in functionality.

Basic Python Structure
Python is an object-oriented language. An object is a virtual 
entity combining structured data and the methods in which 
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the data can be manipulated. A method is a procedure for 
manipulating data, and an argument defines how the method 
is carried out. A simplistic but effective analogy is that of basic 
grammar: An object can be equated with a noun, a method 
with a verb, and an argument with an adjective or adverb. For 
example, consider the following:

car = Factory.Produce(vehicleXL)

In this case, the variable car is the result of the object factory 
being acted upon by the method produce as modified by the 
argument vehicleXL (the make and model). To put it in lay 
terms, the car’s existence and everything about the car depends 
on the factory being told to produce a car of a specified make 
and model. Consider how the value of the variable car can differ 
based on the following examples:

car = Mechanic.Repair(car, transmission)
car = Junkyard.Salvage(vehicleXL)
car = CarThief.Steal()

In the first example the car argument is passed in, modified by 
the Mechanic’s Repair method, and returned as a working car. 
The last example contains no argument. In this case, the car thief 
may not take external input to decide which car to steal. Again, 
the object defines a structured set of data, the method is what 
the object does, and any arguments describe how the method is 
performed.

car may contain either data or a reference or link to data. Please 
refer to one of the many Python resources (such as those listed 
in “Other Important Resources” on page 10) for an in-depth 

discussion of mutable vs. immutable types. The data can be 
virtually anything including letters, numbers, files, etc. As you 
begin to think of data in terms of objects and manipulating 
objects, you will find it far easier and faster to write Python 
scripts.

Sample Python Script
This section provides a brief example of how a Python script 
might look. For this example, let’s say that you have an open 
Poser scene consisting of a figure with its left forearm already 
selected. The forearm is called an actor. An actor is any element 
of a Poser scene (body part, prop, etc.) and this manual uses the 
two terms interchangeably. Let’s say you want to set the x scale 
to 88 percent.

scene = Poser.Scene()
actor = Scene.CurrentActor()
parm = actor.ParameterByCode(Poser.ParmCodeXSCALE)
parm.SetValue(88)

Let’s look at the above script in detail.

The script begins by obtaining a variable called scene, which 
is a reference to the current Poser scene. That scene contains 
numerous actors. Recall that the left forearm is already selected, 
so all the script needs to do is request the scene’s current actor 
to define the variable actor. Next, the variable parm consists 
of a reference to the left forearm’s specified parameter, in this 
case the parameter XSCALE. A parameter code (ParmCode) 
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designates an easy to remember word to signify the desired 
parameter. Lastly, the value of the parameter to which parm 
refers is reset to 88, which will cause the left forearm to shrink to 
88% of its normal size along the X-axis.

Writing Python Scripts
Write your Python scripts using your favorite text editor. 
Alternatively, you can use one of the graphical Python interfaces 
such as Tkinter for Windows to write your scripts.

Folder Syntax
Python, among other languages, designates certain special 
characters as symbols beginning with a Windows-style 
backslash. Two common examples are \t ([TAB]) and \n (new 
line). Thus, in Windows, the notation

C:\folder\test.txt

is interpreted by Python as
C:[TAB]folder[TAB]text.txt or C:   

   folder  test.txt

To work around this issue, you should use a double backslash 
(\\) to signify folders. The above example would then become:

C:\\folder\\test.txt

This would be properly interpreted to mean a specific file path.

Alternatively, you can use Macintosh format, which uses colons 
to signify folders as follows:

:folder:test.txt

Running Your Script
You can run your script directly or via the Poser Scripts menu or 
palette, all of which are described in the following chapter.

For Further Information
The preceding information was a very brief glimpse into Python 
and the PoserPython extensions. If you do not currently know 
Python, you may want to read and learn more. With the power 
and flexibility this interface offers, developing Python expertise 
would be well worth it.

To view the Poser Python Methods Manual, choose Help > 
PoserPython Manual from the menu commands.
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Chapter 37: Running 
PoserPython Scripts

Poser includes a simple graphical user interface that allows 
you to execute Python scripts by pressing a button. You can 
customize the Python Scripts palette and, in addition, you can 
run Python scripts directly.

The Scripts Menu
The Scripts menu provides a hierarchical list of PoserPython 
scripts available for use within Poser. When you first launch 
Poser, this menu will list all of the PoserPython scripts 
that were included with your Poser installation. You have 
the option of placing additional Python scripts into the 
:Runtime:Python:PoserScripts: ScriptsMenu directory within 
your Poser installation; all scripts placed into this folder will be 
accessible within Poser from the Scripts menu.

The Python Scripts Palette
Launch the Python Scripts palette within Poser by selecting 
Window > Python Scripts.

 Python Scripts palette.

Clicking some of the buttons will display a 
submenu of buttons within the Python Scripts 

palette. This is just one example of how Python scripts 
can be used to customize Poser. You can write scripts 
that will open button menus and submenus. If you are 
curious, you can open one of the existing submenu 
scripts to see how this is done.
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Using the Script Buttons

To run a script, simply press the desired button and the script 
will execute automatically.

Assigning Buttons Within the Console

Unassigned buttons do not have a label. An ellipsis (...) appears 
in unassigned buttons to mark their availability. To assign a 
script to a button, simply press the mouse on the button and 
locate the desired script (.py file) using the standard operating 
system file picker. Once you have located the desired script, 
select it and press Open.

Editing Scripts Within the Console

You can edit scripts assigned to a Poser Python Scripts palette 
button by pressing and holding [CTRL] while clicking the 
button assigned to the script you wish to edit. This opens the 
script within your operating system’s default text editor for 
easy modification. Save your changes as appropriate for the 
editor you are using. You may also select your own editor via 
the General Preferences dialog, which can be obtained by 
choosing Edit > General Preferences as described in “Setting 
Application Preferences” on page 32.

Unassigning/Reassigning Buttons Within 
the Console

To reassign a button to a different Python script, you must first 
delete its current assignment and then assign the new script to 
it. Do this by pressing and holding [OPT]/[ALT] while clicking 
the button you wish to unassign. If you wish to assign the newly 
freed up button to a different script, do so as outlined above.

Running Python Scripts Directly
The Poser Python Scripts palette keeps your frequently used 
scripts close by for easy use. However, you can run any script 
you wish by selecting File > Run Python Script to open the 
standard operating system navigation dialog. Locate the script 
you wish to run by browsing your folders and directories, then 
press Open to run the script.

Alternately, you can access your script directly from the Poser 
Scripts menu.
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Appendix A: Technical 
Support

We’ve worked hard to ensure that Poser’s powerful features are 
both easy to use and available to users running a wide variety 
of computers. However, there may be times when you need 
technical support. Smith Micro Software is pleased to offer 
free technical support to registered users of our products. To 
receive technical support, please visit our Web site at http://
my.smithmicro.com/support and browse through our extensive 
product FAQs.

Please use the following checklist before contacting Technical 
Support:

• Poser Reference Manual: This Reference Manual 
answers most Poser questions. Before contacting Technical 
Support, please read the pertinent section(s) of this manual 
thoroughly.

• FAQ: Please visit the product FAQs at the above-listed URL.

• Third-party forums: If your question is more artistic than 
technical, check out some of the great online Poser forums 
where artists come together. Please see “Third-Party 
Forums” on page 9 for links to a few online forums.

Still don’t see your question answered? Please contact Technical 
Support by clicking the link to http://support.smithmicro.
com and completing our online support form. When contacting 
Technical Support, please fill out the form as completely as 
possible and include as much information as possible. This will 
help us resolve your issue faster. Once the form is complete, a 
Technical Support representative will contact you directly as 
soon as possible. Support requests are answered via e-mail in the 
order they are received. Online support is free to all registered 
Poser users. Poser users are strongly encouraged to register at 
http://store.smithmicro.com/productregistration.aspx after 
installing the application.

Telephone support is also free to registered users. Before using 
telephone support, please check the resources listed above. 
Phone support is intended to solve critical technical issues. We 
are unable to answer project-based questions. Our Technical 
Support phone number is listed on our website at http://
smithmicro.com/contact. Telephone support hours are 10 am 
to 4 PM (U.S. Pacific time). If you call during other hours, or if a 
representative is not able to answer your call immediately, you 
will be asked to leave a message, and we will return your call 
as soon as possible (generally within two business days). When 
calling, please be in front of your computer with Poser running.

In order to receive support, we require the following 
information:

• Your name

http://my.smithmicro.com/support
http://my.smithmicro.com/support
http://support.smithmicro.com
http://support.smithmicro.com
http://store.smithmicro.com/productregistration.aspx
http://smithmicro.com/contact
http://smithmicro.com/contact
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• E-mail address

• Telephone number (including international dialing 
information, if applicable)

• Your current operating system

• Your computer specifications (CPU, RAM, hard drive, video 
card, etc.)

• Poser serial number

• Detailed description of the problem

This information will help us isolate and resolve your issue. We 
require this information in order to provide support services and 
are unable to respond to incomplete requests in a timely fashion.

For international support, please contact your local distributor. 
Smith Micro Software maintains a list of our international 
distributors at http://my.smithmicro.com/store/intlpartners.
html.

Smith Micro Software reserves the right to alter 
our technical support policies at any time 

without advance notice.

http://my.smithmicro.com/store/intlpartners.html
http://my.smithmicro.com/store/intlpartners.html
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Appendix B: Poser File 
Structure

This Appendix describes some basics about the Poser file system.

About Poser Files
Some advanced Poser users obtain added control over their work 
by editing the source files directly instead of, or in addition to, 
using the Poser application. This manual provides a detailed 
description of the Poser file formats, including syntax, layout, 
and commands/ parameters contained within each file type.

Poser uses separate files for each character, prop, light, and 
camera, as well as other files for particular character details 
(face, hands, etc.). These files typically reside in Poser’s Runtime 
folder. The Poser installer automatically creates folders and 
inserts files into their correct locations. While each type of Poser 
file has a separate extension and purpose, each of the file types 
discussed in this manual (with the exception of OBJ and non-
native Poser formats) follows the same general format and uses 
one or more subsets of the overall Poser command/parameter 
structure.

Please refer to the Poser end user license 
agreement (eula) in part 1 of this manual for 

information regarding the legal uses of the Poser file 
formats and structures.

A Word of Warning
Editing files directly can give you ultimate control over your 
Poser creations and help provide spectacular results. However, 
editing files directly could cause problems up to and including 
crashing the Poser application file, corrupting your edited file, 
and causing data loss.

Smith Micro Software provides this information as an aid 
to advanced Poser users for reference purposes only. Direct 
editing of Poser files is specifically not recommended and is not 
supported. Please do not contact Smith Micro Software tech 
support regarding file-editing problems. Any work you do within 
Poser files is done solely at your own risk. You are on your own.

This appendix provides some guidance with regard to valid 
values and error handling, however it is impossible to cover the 
nearly infinite ways in which you may edit files and how those 
edits may affect the Poser application or data.
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Editing Files
You can edit all native Poser files using a plain text editor such 
as Notepad (Windows) or Simpletext (Macintosh). In addition, 
some users have created helpful applications to aid you in 
editing Poser data. Please refer to the online 3D community 
at large for help locating and reviewing these third-party 
applications.

Poser files contain formalized descriptions and instructions 
written in a code that Poser can read. As with any computer 
program, each element of a Poser file must be in the correct 
format, using valid values, and located in the correct portion 
of the file. Poser files can be large and complex, and it is not 
advisable to modify them unless you have a good idea how to go 
about it.

All native Poser files follow a similar structure, however each 
file type has a separate filename extension and library location 
(discussed below). The simplest Poser files control props, lights, 
and cameras, while the most complex (CR2 and PZ3) describe 
Poser characters and scenes, respectively.

It should rarely be necessary to modify native Poser files outside 
of Poser, with the notable exception of CR2 files. When editing 
any Poser files, be sure to back up the original file and work on 
a copy. This will prevent data loss if something goes wrong. You 
may also wish to save iterations of files as you work, allowing you 
to easily revert to a previous state without losing all of your work.

Poser File Types
There are several native file types associated with Poser:

• Prop: This file type contains information about a prop 
including source geometry, materials, texture and other 
maps, etc. Prop files have the extension PP2. Magnet files 
are prop files with a pre-positioned magnet as the prop. 
Props are often supplied as PP2 files with embedded OBJ 
information. They may also include texture and bump map 
files.

• Camera: Camera files contain camera information 
including location, direction, focal length, etc. They have the 
extension CM2.

• Light: These files contain information on lights, including 
type, position, color, and other attributes. Light files have 
the extension LT2.

• Hair: Hair files contain information on hair props and are 
similar to prop files. This file type has the extension HR2. 
Hair files may have the geometry embedded within them (as 
opposed to in a separate OBJ file).

• Face: Face files contain information required to articulate 
and/or deform a face to the desired expression and have the 
extension FC2.
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• Hands: Like face files, hand files contain information 
required to articulate hands into the desired positions or 
gestures. Hand files have the extension HD2.

• Pose: Pose files contain information required to articulate 
an entire figure into the desired position, which can include 
face and hand information. Pose files have the extension 
PZ2.

• Character: A character file contains all information 
required for a Poser character including reference geometry, 
Joint Editor palette morph targets, materials, default pose, 
etc. These files have the extension CR2.

• Scene: This file type is what is created when you create 
a Poser scene and select File > Save within the Poser 
animation. This file type contains all of the information 
found in the above-mention files plus details on movie, 
background, rendering, animation set, lights, cameras, 
figures, and other information. Poser scene files have the 
extension PZ3. They are similar in structure to CR2 files.

• Material Collections: A Material Collection is a fully 
integrated file format, which stores groups of materials 
from a single figure for access through the Library palette. 
Material Collection files have the extension MC6/MCZ.

• External Binary Morph Targets: Poser saves morph targets 
to an external binary file format, which contains only the 

morph targets for a particular figure or scene. These files 
have the extension PMD.

File Hierarchy
For purely conceptual purposes, it is useful to think of various 
Poser file formats as falling into a loose hierarchy, with some 
files containing subsets of information stored within other file 
types. Also, while each Poser file type contains information 
unique to that format, several file types are virtually identical 
in structure. For example, hand and face information is part of 
a pose, which along with hair forms part of a character, which 
combined with other information is part of a scene.

File Families

It is also useful to think of Poser files in terms of the types of 
information they contain. For conceptual purposes only, you can 
think of Poser files as being grouped into the following families:

• Face, Hands, Pose

• Hair, Prop

• Camera, Light

• Character
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• Pose

Poser Default File Locations

In the list below, note that the following list provides the default 
locations of the Poser file types. If you are downloading any 
Poser files, be sure to place them in their correct locations. File 
placement is most critical for files that belong in the Runtime: 
Geometries folder. Library files have more flexibility. In the 
following list, an expression in parentheses means that the 
subdirectory or name depends upon the figure. You may create 
your own subfolders and relocate files within the Libraries 
subfolder. In this case, file locations will be reflected in Poser’s 
Library palette. You may place graphic (texture, bump, etc.) 
files wherever you like, since Poser allows you to specify their 
locations. The following list gives all file locations relative to the 
Poser: Runtime folder:

• OBJ (figure geometry): Geometries\(figure name)

• RSR (small file, Windows-only thumbnail graphic): 
libraries\character\ (category)\(character name)

• RSR (large file, both Mac and Windows – Binary OBJ): 
Same location as associated geometry file

• PZ3 (Poser scene): any (user-selected location)

• CM2 (Camera): libraries\camera\Camera Sets

• CR2 (Character): libraries\character\(category)\(character 
name)

• FC2 (Face): libraries\faces\(category)

• HR2 (Hair): libraries\hair\(category)

• HD2 (Hand): libraries\hand\(category)

• LT2 (Light): libraries\light\Light Sets

• PZ2 (Pose): libraries\pose\(category)

• PP2 (Prop): libraries\props\(category)

• MT5 (Shader): libraries\material\(category)

• TIF, BMP, BUM, JPG (textures, bump maps, etc.): 
textures\ (category)\(subcategory). You may store 
additional images in any folder you wish.

• PZS (Web links): Web links\(category)

• MC6/MCZ (Material Collections): libraries\material\
(category)

• PMD (Morph Targets): PMD files are binary morph target 
files that are a redistributable means to deliver morph 
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targets. If you have Use External Binary Morph Targets 
enabled in the Misc tab of the General Preferences dialog, 
PMD files are created next to a CR2 (when a figure is added 
to the Library), next to a PP2 (when a prop is added), or 
next to a PZ3 (when a scene file with morph targets was 
created in an earlier version of Poser, or when the morph set 
of figures and/or props has been changed since they were 
added to the scene).

Users who download characters or other Poser 
files may need to manually place some or all of 

the files in their correct locations. Please use the above 
list to ensure correct file placement.

Poser Pro stores files containing preference information in the 
user’s home directory. This preference information includes 
Memory dots, Library preferences, Poser UI preferences, and the 
Poser.ini/Poser Prefs file. These preference files are stored in the 
following locations:

Windows: %AppData%\Poser Pro\10\

Windows XP example: C:\Documents and 
Settings\<PoserUser>\Application Data\Poser Pro\10\

Windows Vista & 7 example: C:\Users\<PoserUser>\
AppData\Roaming\Poser Pro\10\

Mac OS X: ~/Library/Application Support/Poser Pro/10/

Mac OS X example: /Users/<PoserUser>/Library/
Application Support/Poser Pro/10/

 Poser Downloaded File Locations

By default, Poser places downloaded content (obtained using 
the Content room) in the Download library. Please refer 
to “Chapter 7: The Poser Library” on page 122 for more 
information about Poser libraries.

Other Poser File Types

Some users may encounter PHI and PCF files. Previous versions 
of Poser used PHI to perform functions that are now carried 
out in the hierarchy editor/Setup room (Pro Pack & later). PHI 
files were directly contained within OBJ files, and were located 
with the OBJ file. PCF files are used by an application called 
Objaction Mover and are beyond the scope of this document.

Commonly Used Poser Objects
Morph targets and characters are commonly used and traded/
sold by and among users and third-party vendors. This section 
provides a brief explanation of each.

Morph Targets

Morph targets are supplied as OBJ files that you import into 
Poser for application to part of a figure. The figure’s CR2 file 
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controls morph targets, and a dial appears for each morph target 
when an applicable body part is selected. For example, a head 
morph target dial will appear when you select the figure’s head. 
This Reference Manual defines and discusses OBJ morph targets 
in “Creating Morphs in Other Applications” on page 660.

Characters & Clothing

Characters can be modifications of meshes that come with Poser 
or can include entirely new OBJ meshes (models). Characters 
based on pre-existing meshes typically come as CR2, texture, 
and bump files. Also, each piece of conforming clothing uses CR2 
files to make it poseable, making clothing downloads similar to 
characters; thus, the download is similar to that of a character.

Basic File Syntax
As you will see by examining this document, each Poser file type 
uses the same general syntax.

Tabs

Tabs within Poser files are mostly insignificant, however they 
serve to show file structure, such as:

section 1
  child 1
   grandchild

   grandchild n
  child n
section n

Brackets & File Sections

Each Poser file opens and closes with brackets ({}), as does each 
section within a Poser file. Major file sections describe the file 
version, location and name of the underlying OBJ file (if any), 
and file properties. One of the major file sections (Channels) 
contains position, size, texture, morph target, and other 
properties. Poser automatically modifies values and adds entries 
as needed.

As described above, brackets denote the beginning and end of 
file sections. A left bracket begins each section, while a right 
bracket ends a section:

{begins
} ends

For example,
{
section A
}

Nested Brackets

As implied above, one can nest file sections using brackets to 
denote each section and subsection, as follows:

{
section A
 {
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 section B
 }
}

Parameters

Parameters and other items within a section do not need 
brackets. For example:

{
section A
 parameter 1
 parameter n
 {
 section B
command 1
  parameter 1
  parameter n
 command 2
  parameter 1
  parameter n
 }
}

Comments

You can insert comments into Poser files, as follows:
{
number 4.01
This text is a comment added to the CR2 file.
}

Poser & OBJ Files
The Geometries folder contains several dozen subfolders with 
names corresponding to Poser figures. Each of these subfolders 
contains OBJ files, each of which is a mesh object, e.g. a set 
of polygons arranged so as to form the desired shape. These 
polygons are placed into different groups that define important 
subdivisions within the mesh (such as body parts, also known 
as actors). In order to work with Poser, these groups must have 
specific names, such as hip, abdomen, etc. Poser groups do 
not require such specific naming conventions; figures created 
using the Setup room could have groups named, for example, 
Bone_1.

The OBJ file itself does not contain enough information to 
allow Poser to produce all of the mesh object’s properties, hence 
the presence of CR2 and other files that provide supplemental 
information. Poser files can contain embedded information that 
would normally reside within the OBJ file. This is why many 
prop downloads do not include an OBJ file.

Some native Poser files normally refer to an underlying OBJ 
geometry file, which is also in text format. Native Poser files 
describe parameters controllable within Poser, such as size, 
position, textures, etc. One OBJ file can have more than one 
Poser file pointing to it. This happens, for example, if a modified 
prop, character, etc. is saved to the Library under a different 
name and/or location.
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Character (CR2) files contain Poser-specific details such as size, 
position, pose, textures, proportions, etc. and also control the 
dials that change the figure. Normally, one CR2 file governs a 
single figure. By combining the OBJ mesh information with the 
CR2 details, Poser can create customized poseable figures.

Some Poser files (pose, face, hands, etc.) work by modifying the 
CR2 itself. Poses, faces, and hands are already described within 
the CR2, however applying the data contained in one of these 
files changes the corresponding values within the CR2 file itself. 
These applied CR2 changes are then saved to the Poser scene 
(PZ3) file. If the user saves the modified character in the Library, 
the modified information gets written to a new CR2 file.

PZ3 files are similar enough to CR2 files to allow changing a PZ3 
extension for a given scene file to CR2, thereby creating a new 
character complete with its associated props, hair, etc.

Dependent Parameters
With Poser you can set up meta-level parameters, called 
dependent parameters, which allow you to modify other 
parameters and morph targets with a single parameter dial. 
An example of this type of dependent parameter would be a 
full range of belly types, with the following values along the 
dependent parameter dial:

The Dependent Parameters editor can help you 
do this and more. Refer to “Using Dependent 

Parameters” on page 666 for additional information 
about this feature.

• -1.0 underweight belly

• -0.5 sixpack belly

• 0.0 regular belly mesh

• 0.5 slightly protruding belly

• 1.0 large protruding belly

• 2.0 hanging beer belly

This range of belly types would incorporate various morph 
targets and parameter values at each of the key points along the 
dependent parameter dial. Thus, dependent parameters are far 
more powerful in the scope of modifications they can encompass 
than a single morph target or parameter dial.

The following sample code illustrates how to set up a dependent 
parameter. This code is an example of a targetGeom channel in 
a CR2 file. The resulting dependent parameter will appear as a 
morph target parameter dial named “bump3”.

targetGeom bump3
{
name bump3
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 initValue 0
 hidden 0
 forceLimits 1
 min -100000
 max 100000
 trackingScale 0.02
 keys
 {
 static 0
 k 0 0
 }
 interpStyleLocked 0
 numbDeltas 261
 useBinaryMorph 1
 blendType 0
 valueOpKey
 Figure 1
 bone_1:1
 Custom_Morph
 beginValueKeys
 valueKey 0.5 0
 valueKey 0.75 1
 valueKey 1 0
 endValueKeys
}

The end of this sample defines some interesting interactions 
with regards to the “bump3” dependent parameter. The 
“valueOpKey” keyword identifies a section that defines that 
this parameter can be driven by the Custom_Morph dial on the 
bone_1 actor of the specified figure. The “ValueKeys” section 
defines how exactly the “bump3” dependent parameter will be 
affected:

• If Custom_Morph equals 0.5, the value of bump3 will 
increase by 0.

• Once Custom_Morph reaches 0.75, the value of bump3 will 
increase by 1.

• By the time Custom_Morph equals 1, the value of bump3 
will increase by 0 again.

• Values in between these points are determined by spline 
interpolation.

In the next example, we are looking at the rotateX parameter of 
an actor (in this case bone_2:1, which is not apparent from the 
code sample below). The resulting dependent parameter dial is 
called “xRotate”.

rotateX xRotate
{
name xrot
 initValue 0
 hidden 0
 forceLimits 0
 min -100000
 max 100000
 trackingScale 1
 keys
{
static 0
 k 0 0
}
interpStyleLocked 0
valueOpKey
 Figure 1
 bone_1:1
 Custom_Morph
 beginValueKeys
 valueKey 0.25 0
 valueKey 0.75 45
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 valueKey 1 0
 valueKey 1.25 -45
 valueKey 1.5 0
 endValueKeys
}

As in the previous example, the “valueOpKey” section defines 
that the Custom_Morph parameter dial on bone_1:1 of 
the specified figure can take control of this parameter. The 
“valueKey” value pairs add rotation in degrees of xRotate to 
certain values of the Custom_Morph parameter.



Poser Pro 2014
Reference Manual

857

Appendix C: 3D Basics

Appendix C: 3D Basics
This part describes basic 3D concepts. The following discussion 
centers on Poser, however most of these concepts apply to all 3D 
applications. Novice 3D artists should read the entire chapter 
to gain valuable “behind the scenes” insight that will help in 
learning and using Poser. Veteran 3D users can use this chapter 
as a handy reference or refresher.

About 3D Space
Let’s begin by defining the three dimensions:

• Zero dimension: A point is an example of a zero-
dimensional object. It defines a point in space but has no 
length, height, or width.

• First dimension: A one-dimensional object is a single line. 
It has length but no height or depth.

• Second dimension: A two-dimensional object has any two 
of the following three dimensions:

 � Length

 � Height

 � Depth

 A two-dimensional object.

Pick any one of the three dimensions and call it A. Now pick 
either of the remaining two dimensions and call it B. In the 
graphic, the arrows represent the two dimensions and the 
rectangle represents a two-dimensional object. You will 
immediately notice that all two-dimensional objects are perfectly 
flat, like the surface of a sheet of paper. Two-dimensional objects 
are called planes.

• Third dimension: Three-dimensional objects use all three 
of the dimensions (length, height, and depth).

As you can see from the graphic, the cube is a three-dimensional 
object. It has length, height, and depth. That’s pretty simple, 
right? Here’s the hard part: You create 3D data using two-
dimensional tools. Your computer screen is a two-dimensional 
object and your mouse can move in two dimensions; it can 
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report left-right and front-back motion but cannot report how 
far above or below the desk it is. Furthermore, your output will 
always be two-dimensional. Look at the above graphic: It does 
not have depth. It does, however, represent three dimensions 
using a simple optical illusion called perspective, which is 
defined as the tendency of objects to appear progressively 
smaller the farther away they are until they disappear on the 
horizon at a location called the vanishing point. You can see 
this by standing at the corner of a long building and noticing 
how the roof line appears to get closer to the ground the farther 
away you look. Given these limitations, you ask, how can one 
create 3D information?

 A three-dimensional object.

The short answer is that all 3D applications, Poser included, 
create a “virtual” 3D space. Look at the above graphic again. 
We can view and manipulate the cube in three dimensions by 

separating them into separate workspaces called views. One 
view will displays the A and B dimensions, the second will 
displays the A and C dimensions, and the third will displays 
the B and C dimensions. You can also have a fourth view that 
displays all three dimensions. This graphic shows how the four 
views might look in a 3D application such as Poser.

 Four views of the same object.

Let’s look at the same graphic again, only this time let’s 
substitute a simple boat for the cube to better illustrate the 
concept. One of the benefits of this system is that it becomes 
possible to precisely control your 3D model. For example, you 
can determine the length of the boat using the AB or AC view, 
the width using the AB or BC view, and the height using the 
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AC or BC view. Which view you use depends on what you are 
trying to accomplish. For example, to create the stern, you would 
probably use the BC view, and would probably use the AB view 
to create the overall shape.

 Four views of a more complicated object.

In these examples, the A, B, and C dimensions are collectively 
called axes. Taken individually, each dimension is called an 
axis. So far, we have used each axis to describe one of the three 
dimensions without caring about which axis describes which 
dimension. The A dimension could describe any of the three 
dimensions with B describing either one of the remaining two 
dimensions and so forth. We did this to illustrate the most basic 

theory behind 3D applications such as Poser. Let’s expand on 
that.

It should be obvious that the AB, AC, and BC views lack 
perspective. Two-dimensional views without perspective are 
called orthographic views. Each three-dimensional object has 
six orthographic views: Top, Bottom, Left, Right, Front, and 
Rear. Pick up any object you like and look at it from all angles; 
you will see that this always holds true. So, while the boat 
example above shows the Top (AB), Left (AC), and Rear (BC) 
views, it could just as easily show any three of the six possible 
views. This is important because, like the boat, not all three-
dimensional objects are symmetrical.

Now that you understand this fundamental concept, let’s learn 
how it’s used in the real world. To recap, the three dimensions 
are width, length, and height or depth, each dimension is 
represented by an axis, and we can view each pair of axes in two 
ways to generate a total of six possible views. So far so good, 
except for one small problem: If everyone used an arbitrary 
system of axes to define the three dimensions, then it would be 
difficult to pass data back and forth. In the above example, we 
are using the AB as the Left view. Someone else could just as 
easily define AB as any of the six available views. You can see the 
chaos that could ensue. To prevent this, both 2D and 3D objects 
conform to a standard system of axes called the Cartesian 
coordinate system. The term Cartesian is used in honor of 
the French mathematician and philosopher Rene Descartes 
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(1596–1650), who was one of the first to employ such coordinate 
systems.

Cartesian Coordinates

Before getting too far into Cartesian coordinates, let’s pause for 
a quick math review: If you arranged all of the numbers from 
negative infinity to positive infinity along a line, the number 0 
would be in the center of that line. Negative numbers would be 
on the left side of 0 with –1 being the closest to 0, and positive 
numbers would be on the right side of 0 with +1 being the closest 
to 0.

 The number 0 is in the center of an infinite amount of numbers.

Negative numbers being on the left (or front) works for 
horizontal lines or axes. For vertical lines, negative numbers are 
beneath 0 with positive numbers above 0. This stands to reason, 
since negative numbers are literally less than 0. When dealing 
with coordinate systems, we assume that each dimension is 
infinite, with zero representing the dimension’s center or origin.

The Cartesian coordinate system goes one step further by 
defining three axes, called X, Y, and Z. In our previous examples, 
we deliberately used the arbitrary letters A, B, and C to illustrate 
the concept of axes and avoided using the actual letters because 
we wanted to familiarize you with the general idea of axes and 
dimensions before focusing on how they are actually used. In the 
Cartesian coordinate system, the axes correspond to dimensions 
as follows:

• X: Width

• Y: Height

• Z: Depth

Let’s combine the origin with the Cartesian axes as follows. As 
you can see, the Cartesian coordinate system uses three axes to 
represent each of the three dimensions: X, Y and Z. The positive 
X axis points to the right, the positive Y axis points up, and the 
positive Z axis points towards the front of the scene. The center 
of the 3D space is a single point, which is the midpoint (origin) 
of the three axes. Thus, the 3D space extends to infinity in both 
negative and positive directions along all three dimensions. You 
can see the origin in any of the Poser views.
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 Directions extend along three dimensions, represented as X, Y, and 
Z.

Now that we have a standard system for defining 3D space and 
objects within that space, we can use coordinates to define the 
object’s shape. Remember that coordinates are always listed in 
XYZ order. Coordinates themselves are defined as the distance 
from the origin along each of the three axes. For example, the 
coordinate {1,1,1} signifies a point that is 1 unit to the right of the 
X origin, 1 unit above the Y origin, and 1 unit behind the Z origin.

The format of listing the X, Y, and Z coordinates 
within braces and separated by commas is the 

standard shorthand used with the Cartesian coordinate 
system.

Remember the box we used in the previous 3D example? We 
can use Cartesian coordinates to define its corners. What if we 
move the box over somewhat? The graphics on the right show 
how that might affect the coordinates. As you can see, Cartesian 
coordinates serve to define an object’s shape, size, and location 
in 3D space.

 Point coordinates.

Planes

As we discussed earlier, 3D applications must depict and 
manipulate 3D data using a series of 2D views and tools. You 
already know that 2D objects are planar because they exist on a 
mathematically defined plane. A plane is a formula defining the 
relationship between two dimensions, such as XZ. Combining 
these two facts with what we just learned about the Cartesian 
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coordinate system and a quick glance at our monitor, we find 
that 3D applications like Poser use three views aligned with 
coordinate planes to help you locate points in 3D space.

 Planes in 3D space.

You can change the Poser Document window to show several 
cameras, including the orthogonal views (Left, Right, Front, 
Back, Top, Bottom) and perspective views (Main, Auxiliary, 
Face, Hand, Posing). Please refer to the “Chapter 5: The 
Document Window” on page 72, for a description of the 
Poser Document window. The graphic shows a quick rendition 
of three orthogonal views:

 Three orthagonal views.

Global vs. Local Coordinates

There is one last wrinkle to the Cartesian coordinate system. 
To explain this wrinkle, let’s use the example of a motorcycle 
rider leaning into a turn. What just happened? For the sake of 
argument, let’s assume that the headlight is 30 inches above the 
ground when the motorcycle is upright. If the rider leans the 
motorcycle 45 degrees to the left, then headlight will now be 21.2 
inches to the left of center and 21.2 inches off the ground.
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For anyone into trigonometry, we find the new 
location by multiplying the original location by 

the sin and cosine of the angle. In this case, sin(45) = 
cos(45) =.707, and.707*30= approximately 21.2.

Thus, the headlight’s coordinates will have changed from {0, 
30,0} to {21.2, 0, 21.2}. However, nothing has changed about the 
motorcycle itself. The headlight is still in the exact same position 
relative to the rest of the machine. To demonstrate this, let’s 
create a second 3D space using the motorcycle’s center of gravity 
(balance point) as the origin. Let’s further say that the headlight 
is 12 inches above and 30 inches in front of the center of gravity. 
This means that the headlight’s relative coordinates are {0, 12, 
-30}, and these relative coordinates do not change because the 
headlight does not move relative to the center of gravity. But 
what do we mean by relative?

Has the motorcycle leaned 45 degrees to the left, or has the 
world leaned 45 degrees to the right? To an observer standing on 
the ground, the motorcycle has leaned over 45 degrees. To the 
rider, s/he is still on top of the motorcycle and it is the world that 
has leaned over 45 degrees. Further, the rider maintains her or 
his relationship to the motorcycle, meaning (for example) that 
her or his head is still 30 inches behind and 32 inches above the 
headlight. Thus, while the motorcycle’s world coordinates have 
changed, its object (or local) coordinates have remained the 
same.

 World coordinates vs. local coordinates.

If this seems a bit complex, bear with us as we use a far simpler 
example. Each object in Poser has its own object coordinate 
system. When an object is first created, its center and orientation 
are the same as the world’s. As described above, this changes 
when the object moves. The world’s center and orientation are 
still the same, but the object’s center and orientation may have 
changed. Look at the square in the graphic. Say the upper-left 
corner is located at {-5,5,0}. When the object is first created, that 
point is the same in local and global coordinates because the 
object’s center is at {0,0,0}. If we move the object +7 along the 
X axis and +3 along the Y axis, the upper-left corner would now 
be at {2,8,0} in global coordinates but would remain at {-5,5,0} 
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in local coordinates, that is, relative to the object’s center. In 
other words, any point can be specified relative to its object’s 
local coordinate system (object space) or relative to the global 
coordinate system (world space or global coordinates) shared 
by all objects.

Transformation

So far, you have learned about 3D objects, the Cartesian 
coordinate system, and the difference between object space and 
world space. Let’s move on and learn how we can use XYZ values 
to define an object’s transformation in addition to its size, 
shape, and position.

An object’s transformation describes an object’s position 
(translation), orientation (rotation), and size (scale) in 3D 
space. When an object is first created, its transformation is set 
to align with the global coordinates. Its position is set to {0,0,0}, 
its orientation is set to {0,0,0}, and its size is set to {1,1,1}. An 
object’s transformation values are almost certain to change as 
you work with the object.

Translation

An object’s translation describes its position in 3D space relative 
to its center and is measured in defined grid units. Let’s take 
another look at the box we used in an earlier example.

As you can see, the box’s center is the same as the origin 
({0,0,0}). What happens if you want to move the box? You can 
move each one of the points, delete the existing box and draw 
a new one in its new location, or simply translate the box. For 
example, setting a Translate value of {2,2,2} would move box’s 
lower left corner to {0,0,0} since (-2)+2=0. Again, the Translate 
value refers to the location of the center of the object relative to 
world space.

Rotation

An object’s rotation value refers to its orientation in 3D space 
measured in degrees. As you probably know, any actual object 
will revolve around its center of gravity (balance point). Objects 
in Poser have no mass and no center of gravity, so you can set 
the object’s center wherever you like and the object will rotate 
around that point.
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 Three axes of rotation.

Let’s think back to the motorcycle example. If you model a 
motorcycle and decide you wish to lean it 45 degrees, nothing 
is stopping you from performing trigonometric calculations to 
determine the new location of each part. Remember that each 
part of the motorcycle will move in at least two dimensions as 
the whole machine rotates. In this case, since the motorcycle is 
rotating about the Z axis, you could simply enter a rotation value 
of {0,0,45}. The trigonometric calculations will still need to be 
performed, however Poser will get stuck with the job instead of 
you.

Scale

An object’s scale value refers to its size in relation to itself and 
is measured in percent. In this case, a value of 1 corresponds 
to 100%. Take the example of a circle. As with all other Poser 
objects, it is initially created with a scale value of {1,1,1}, meaning 
that it is 100% of its original size in all three dimensions.

Now that your perfect circle is in place, you realize you need 
to double its height on the Y axis. Simply enter a scale value of 
{1,2,1} and the circle will turn into an ellipse that is twice as long 
on the Y axis as it is wide. To stretch it on the X axis, you would 
enter {2,1,1}.

 Scaling axes.

To compute every point on a model, multiply the original 
coordinates by the X, Y, and Z components. With this in mind, it 
becomes easy to see how different values can change the size of 
your object. For example, entering a scale value of {2,2,2} would 
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double the circle’s size. Poser allows you to set each scaling 
factor independently in order to obtain squashing and stretching 
effects. This is called differential scaling.

Now that you’ve learned about 3D objects, Cartesian 
coordinates, object space vs. world space, and object 
transformations, let’s go ahead and learn more about 3D objects 
themselves.

Vertices
A point is a zero-dimensional (0D) object in 3D space. It has a 
set of coordinates to define its location but has no length, width, 
or height. It is nothing more than a location in Cartesian space. 
However, we can connect points to create edges or polylines. An 
edge is part of a polygon between two vertices, and a polyline 
connects two vertices together that are not part of a polygon. At 
its root, 3D modeling consists of nothing more than connecting a 
series of vertices together to create 3D objects.

A group of vertices used to define a 3D object is called a point 
cloud. Each point in a cloud is usually called a vertex and is used 
to define one of the corners of a polygon. Points used to define 
a spline (see below) are called control points. We’ll define these 
terms a little later.

Splines
Splines are lines that are defined by multiple control points. 
The following graphic shows three basic types of splines. 
The simplest type of spline consists of a set of control points 
connected by straight lines, called a linear spline (shown on 
the near right). The other two splines are curved. You can curve 
a spline by adjusting its basis, or method used to compute 
the spline. Splines can be divided into interpolating and 
approximating.

 Splines can be linear or curved and are controlled with control 
points.

An interpolating spline will always touch the points that 
define it. In the above graphic, the two splines on the left are 
interpolating. This gives them a more drastic skin-like bend than 
approximating splines. Approximating splines, such as the right-
most example in the above graphic, have a softer curve because 
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they don’t necessarily touch the points that define them. Either 
type of spline requires three or more control points in order to 
show any curvature. Poser uses interpolating splines for such 
things as the Walk Designer and the Animation palette.

Polygons
Polygons are multiple-sided surfaces that use vertices to 
define their corners and edges to define their limits. Most 3D 
applications use triangles (3-sided polygons) and/or rectangles 
(4-sided polygons). Groups of polygons form a polygonal mesh, 
which alone or with other meshes defines a mesh object. Let’s 
reexamine the box example we used above: In this example, the 
point cloud consists of eight vertices. These eight vertices are 
connected by 12 edges, which define six rectangular polygons. 
Had we used triangles, the eight vertices would be connected by 
18 edges, which would define 12 polygons.

 Polygons.

The Poser Workspace
The Poser workspace is the virtual 3D world in which you build 
your scenes. This world contains an origin and the three axes.

The Document window acts as the viewfinder for the currently 
selected camera. By looking through this viewfinder, you can see 
the workspace. Please refer to the “Chapter 5: The Document 
Window” on page 72 for more information about the 
Document window.
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Normals
A surface normal is a line (vector) that points perpendicular to 
(away from) the surface it originates from. Since models have 
more than one surface, knowing which way the normals are 
facing can help you understand how a particular function will 
affect a model. This is important when rendering a model or for 
calculating other operations such as a collision (determining 
if two objects are residing in the same 3D space). If a model’s 
normals are inverted, certain routines may behave erratically or 
your model may render incorrectly. Poser allows you to control 
the direction of the normals and automatically performs these 
calculations for you.

 Surface normals.

Camera
The Camera is a default object. This means that it always exists 
and cannot be deleted. However, the camera is an object like 
any other and can be moved and animated. Additionally, you 
can apply many different settings to the camera including its 
position, angle, perspective, and focal length. These are 
standard photography terms. Object animation rules apply to 
the camera.

Lights
A light source is a special kind of primitive. When Poser 
launches, it places three default lights in your scene. You can 
add, edit and remove lights in your scene and can also control 
and animate many settings such as color, intensity, position, 
shaders (gels), etc.

Hierarchy
Poser objects are often grouped in a hierarchy in order to 
facilitate manipulation. The original object is known as a parent, 
and each object linked to it is known as a child. The graphic 
shows an example of a simple hierarchy. In this example, the 
trunk is the parent. The branch is a child of the trunk, the twig is 
a child of the branch, and the leaf is a child of the twig. Selecting 
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and moving the trunk will also move the branch, twig, and leaf. 
Moving the branch does not affect the trunk but moves the twig 
and leaf, and moving the twig moves the leaf without affecting 
the branch or trunk. Selecting the leaf only moves the leaf.

 An example of hierarchy.

Let’s try another example: Bend your arm at the shoulder. Notice 
that your shoulder rotation moves your upper arm, lower arm, 
wrist, hand, and fingers. In this case, your upper arm is a child of 
your shoulder and so forth. Now try bending a finger. Your hand, 
wrist, arm, and shoulder do not move.

Animation

Poser lets you animate virtually everything in your scene 
including objects, lights, materials (which can have a shader tree 

containing one or more nodes), and the camera. Each scene item 
has different settings (parameters) that can also be animated. 
For example, you can animate an object’s scale, rotation, 
translation, and shape, or a light’s color, position, and intensity 
(Poser calculates shadows). You can animate any component of 
an object’s material. Plus, you can animate the camera’s position 
and rotation. Creating animations involves making changes 
to these parameters over time and assigning these changes to 
keyframes.

Keyframing

Animations are made up of individual images known as frames. 
An animation is created when a series of frames that vary slightly 
from one frame to the next are displayed one after another over 
time.

Keyframing is the core of computer animation and involves 
the following general process: First, a starting frame is created 
on a timeline and all parameters for each object in a scene are 
assigned to that frame. Next, an ending frame is created later on 
the timeline and all changes to any parameters are assigned to 
this frame. Poser then compares the parameters assigned to the 
starting and ending frames and calculates all of the intermediate 
frames that occur between the starting and ending frames. This 
calculation is called interpolation.
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For example, if you tell Poser that an object is large and red 
at Frame #1 then small and blue at Frame #10, then Frames 
1 and 10 become the keyframes. Poser then calculates the 
intermediate values for all of the frames in between the 
keyframes. Thus, as the animation moves from Frame 1 to 
Frame 10, the large red ball will gradually shrink and turn blue 
with each passing frame until it reaches the values you set for it 
at Frame 10. Keyframing and interpolation allow you to create 
complex animations with a minimum amount of work.
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Appendix D: Creating 
and Converting 
Hierarchy Files

The Hierarchy file describes how the groups in a figure are 
arranged. It outlines the parent-child relationships between 
groups. Once created it can be imported into Poser where it is 
converted to create a new figure file in the New Figures library.

 The hierarchy file specifies four important things:

• The geometry (.OBJ) file to use.

• The hierarchical connections (parent-child relationships) of 
the body parts.

• The desired rotation order of each body part.

• A specification of each Inverse Kinematics chain to be 
included in the figure.

Hierarchy files can be created in any text editor that can save 
documents in a text-only format.

The following is an example hierarchy file: It represents the full 
hierarchy for a horse -- including curve channels for the tails.

objFile:Runtime:Geometries:horseHi:horseHiP3.obj

1 hip zxy  
 2 abdomen zyx 
  3 chest zyx 
   4 lShldr yzx 
    5 lUpArm yzx 
     6 lForeArm yzx 
      7 lWrist yzx 
       8 lHand yxz 
   4 rShldr yzx 
    5 rUpArm yzx 
     6 rForeArm yzx 
      7 rWrist yzx 
       8 rHand yxz 
   4 lowNeck zyx 
    5 upNeck zyx 
     6 head yzx 
 2 lThigh yzx 
  3 lLeg yzx 
   4 lShin yzx 
    5 lAnkle yzx 
     6 lFoot yxz 
 2 rThigh yzx 
  3 rLeg yzx 
   4 rShin yzx 
    5 rAnkle yzx 
     6 rFoot yxz 
 2 tail1 zyx curve 
  3 tail2 zyx curve 
   4 tail3 zyx curve 
    5 tail4 zyx curve

ikChain LeftLeg lThigh lLeg lShin lAnkle 
ikChain RightLeg rThigh rLeg rShin rAnkle 
ikChain LeftHand lShldr lUpArm lForeArm lWrist lHand  
ikChain RightHand rShldr rUpArm rForeArm rWrist rHand

There are more samples in the Tutorials > Figure Creation 
folder that is included with your Poser installation.
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Hierarchy File Explained
The following section explains the various parts of the Hierarchy 
file.

Hierarchy File Header

The first line of the hierarchy file contains the “OBJ File” 
command which specifies the location of the OBJ file associated 
with the new figure.

objFile:Runtime:Geometries:horseHi:horseTex.obj

The file location should be defined using a Macintosh format 
file specification (i.e. using colons). The file location is specified 
relative to the Poser application folder.

When the hierarchy file is converted, the text of the OBJ file is 
read into Poser where a geometry resource is created and linked 
to the OBJ file. This process results in a new figure file.

From then on, when Poser uses this figure file, the geometry 
resource is used to defined the figure hierarchy relationships 
rather than the text stored in the OBJ file. Reading from the 
geometry resource is dramatically faster.

Hierarchy File Body

The bulk of the hierarchy file contains lines similar to the one 
shown below:

 A typical Hierarchy file line.

The first part of the line indicates Hierarchy level, or the parent-
child relationship, of the body part. In this case, the abdomen 
body part is a child of the body part of the part on the next level 
up. Hierarchy levels are numbered in depending order, so the 
next level up from this part is 1.

In the example below, the lShin object is located on the 3rd level 
of the hierarchy. The closest level 2 line above would be the 
lThigh, so the lShin is a child of the lThigh.

 Parent-child relationships indicated in the Hierarchy file.



Poser Pro 2014
Reference Manual

873

Appendix D: Creating and Converting Hierarchy Files

The indenting of the lines is not processed but is helpful visually 
to denote the hierarchy levels.

The second part of the line specifies the name of the body part. 
In the example the part is called abdomen. This name must 
match the group name in the OBJ file.

 The body part name in a Hierarchy file line.

The 3-character string at the end of the line represents the 
rotation (or gimbal) order of the body part. A rotation order 
defined as “zxy” means that a Z axis rotation occurs first, 
followed by the X, then Y axis rotations.

 The rotation order in a Hierarchy file line.

Poser uses the following XY and Z axis orientations:

 The X, Y, and Z planes that make up 3D space.

Assigning a rotation order is a three step process:

• Always place the “twist” axis first. This axis should be placed 
lengthwise through the object. If the object, like a leg, is 
built down the Y-axis, specify the Y first since that is the axis 
along which the leg would twist.

• Of the two remaining rotations, place the one most likely 
to become 90 degrees last. This helps reduce rotation lock 
problems that occur when the middle rotation approaches 
90 degrees.

• Place the remaining rotation channel second.

• Some objects are built non-aligned to the major axes. In this 
case, you are able to “align” the coordinate system of the 
body part later, while adjusting the joint parameters. For 
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the hierarchy file, pick the rotation order that seems closest 
to what would be desired. When you align the part later, the 
twist axis you choose becomes aligned down the length of 
the body part.

Linking Body Parts Stored in Separate OBJ 
Files

If each body part were stored in a separate file, rather than all 
body parts being groups in a single file, you would specify the full 
path name for the file at the end of each line. This path is relative 
to the Poser folder.

Here is an example of three links using this method:
1 link1 yzx:Runtime:Geometries:examples:l1.obj  

 2 link2 yzx:Runtime:Geometries:examples:l2.obj  
  3 link3 yzx:Runtime:Geometries:examples:l3.obj

Using Curved Transformations

The Curved flag tells Poser that this link should use curve 
transformations. This is a method of bending designed for the 
tails of the animal figures in Poser. Here is an example used in 
the Horse figure:

 2 tail1 zyx curve  
  3 tail2 zyx curve  
   4 tail3 zyx curve  
    5 tail4 zyx curve

Inverse Kinematic Chains

The last commands in the hierarchy file specify the links that 
compose the individual inverse kinematic chains. Inverse 
Kinematic chains are defined in the following format:

 ikChain chainName firstLink nextLink nextLink... 
endGoal

In the example above the ikChain is defines as follows:

 An ikChain line in a Hierarchy file.

The name of an ikChain cannot contain spaces.

Converting Hierarchy Files
Selecting File > Convert Hier File opens a standard Open 
dialog box prompting to you locate and open a Poser 3 Hierarchy 
file (*.phi). If this file contains no errors, this function creates 
a Poser Figure (*.CR2) file. Please refer to “About Poser Files” 
on page 847 for more information about Poser files and their 
functions.

Hierarchy files are used when creating custom figures using the 
text-based method (see “Global vs. Local Coordinates” on page 
862). Since the introduction of the graphical Setup room, 
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this older method, while still supported, is far longer and more 
tedious as it forces you to do everything manually while in a 
text-based environment. Once the Hierarchy file is completed in 
the text editor, you can import it into Poser by converting it into 
a geometry resource (called a CR2 file). This geometry resource 
is then used by Poser, in conjunction with OBJ 3D data to create 
a new figure file with rotation order, and Inverse Kinematic 
relationships as defined by the hierarchy text file.

On Windows, the resource is a separate file 
ending is RSR. On a Macintosh, the resource is 

stored with the OBJ file. If you need to edit the resource 
on a Mac, use a resource editor to remove the text from 
the OBJ file, or create a new text file by copying and 
pasting from the old one.

If you make changes to the hierarchy file and then convert it 
again, the conversion won’t re-create the geometry resource 
if it already exists in the OBJ file. So, if you are trying to make 
geometry changes, you need to either delete the resource, or 
start with a new blank text file that contains only the text portion 
of the OBJ file.

To convert a Hierarchy file:

1. Choose File menu > Convert Hier File. The Open dialog 
appears.

1. Locate the Hierarchy file you created in the text editor and 
click Open.

2. If there are no errors, a Poser Figure library file is created.

3. The hierarchy conversion may take several minutes if there 
is a large geometry file.

4. The figure file that gets created references the geometry file 
whenever used. Its location should be established and not 
moved later or the figure file cannot find the geometry.

5. If the location is changed you need to edit the figure file with 
a text editor to designate the new location (specified relative 
to the Poser application in Mac format).

Verifying Hierarchy Files
Once you begin adjusting the joints you are not able to 
regenerate the figure file a second time and have all your joint 
changes in place. Make sure that all Parent-Child relationships 
are correct before editing joint parameters. You can make 
geometry corrections later, but you cannot change the hierarchy 
without creating different joints from scratch again.
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Camera  868
Camera Controls  50, 60, 247
Camera Parameters  252

Depth of Field  253
Focal  253
Focus Distance  253
F-Stop  255
Hither  256
Perspective  253
Pitch  258
Roll  258
Shutter Close  256
Shutter Open  256
XYZ Dolly  257
XYZ Orbit  257
XYZ Scale  257

Yaw  258
Yon  256

Camera Plane  248
Camera Properties  251

Animating  252
Name  251
Visible  251

Cameras  157
Auxiliary  243
Camera dots  259
Changing  91, 246
Creating  251
Dolly  245
Face  244
Flyaround  247
Focal Length control  249
Left Hand  244
Locking  259
Main  243
Mini Camera Controls  90
Orthographic  245
Pointing  258
Posing  243
Positioning  248
Right Hand  244
Roll control  250
Rotation trackball  249
Saving camera sets  259
Scale control  249
Transforms  256

Camera views
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and posing  176
Cartesian Coordinates  860
Cartoon  108
Cartoon Tones  120
Cartoon With Line  109
Cast shadows  196
Center of Mass  214
Chain Break Tool  189
Changing figures

With replaced geometry  230
Clothing  221

Conforming  222
Conforming vs Dynamic  551
Dynamic  222

Cloth Room
Air damping  566
Calculate simulation  563
Choreographed cloth groups  560, 

562
Clear simulation  563
Cloth controls  555
Cloth decorations  560
Cloth density  565
Cloth draping  554
Cloth dynamics controls  562
Cloth groups  559
Clothifying objects  555
Cloth parameters  566
Cloth self-friction  565
Cloth simulators  552

Collision depth  557, 558
Collision friction  566
Collision objects  555
Collision offset  556, 558
Collision options  553
Constrained cloth groups  560
Constrained group  562
Creating morphs with  566
Creating props with  566
Delete dynamic group  561
Delete simulation  554
Displaying tools  61
Draping from zero pose  557
Dynamic cloth groups  559, 561
Dynamic friction  557, 565
Figure collision options  557
Fold resistance  565
Ignoring feet collisions  558
Ignoring hand collisions  558
Ignoring head collisions  558
New dynamic group  561
Play simulation  563
Reset  566
Rigid decorative cloth groups  562
Shear resistance  565
Simulation name  553
Simulation range  553
Simulation settings  554
Soft Decorative cloth groups  562
Static friction  557, 565
Stretch damping  565
Stretch resistance  565

CM2  850
COLLADA  785

Export  786
Import  785

Collision detection  196
Collisions  75
Color  282
Color-blind accessibility  35
Colors  96
Color Tool  190
Comic Book Preview  120
Compound nodes

Collapsing  386
Creating  382

Compressed Files  67
Conforming Clothing  222

Adding from Library  143
Using without a figure  552

Constraint Channels  237
Content

Downloading  174
Installing  174
Loading  135
Managing  135
Online  8
Searching from Library  169

Content Collections  171
Content Paradise  173
Content Room  173



Poser Pro 2014
Reference Manual 

879

 

Context menus
Actor  79
Background  88
Cameras  87
Figure  81
Lights  85
Prop  84

Copy  69
CR2  850
Crease angles  197, 227, 423
Create Atmosphere  312
Current Actor Menu  77, 198
Custom Scatter  356
Cut  69

D
Deformers

Showing and hiding  113
Using  615
Using with grouped objects  642

Delete Figure  217
Deleting objects  199
Dependent Parameter Editor

Graph  670
Dependent parameters  854
Dependent Parameters  666, 853

Dials  201
Driven value  674

Natural value  674
Teaching  675

Depth Cueing  94, 112
Depth Map Shadows  271
Depth of Field  253, 419
Dial Groups  199
Diffuse Color  300
Direct Manipulation Tool  191
Displacement Bounds  194, 196
Displacement Map  287
Displacement maps  418
Display Controls  53, 105
Display Menu Commands

Background Color  115
Bend Body Parts  114, 195, 546
Camera Layout  110
Camera View  110, 242, 247
Clear Background Footage  116
Clear Background Picture  115
Deformers  113
Depth Cued  112
Document Style  110, 111
Element Style  110, 112
Figure Circle  114
Figure Style  110, 112
Fly Around  111
Foreground Color  115
Frame Selected  111
Ground Shadows  114
Guides  117

Orbit Selected Mode  111
Paste onto Background  116
Production Frame  99, 111, 512
Shortcuts  63
Show Background Footage  116
Show Background Picture  115
Show Camera Names  111, 242
Tracking  113
Use Background Shader Node  116

Display origin  197
Display Units  35
Documentation  6
Document Style  105, 111
Document Title  73
Document Window  52, 72

Options Menu  73
Preview tab  72
Size  76

Document Window Size  61
Double-click Behavior  36
Downloading content  174
Download Manager  20, 166
Drop to Floor  216
Duplicate  70
Dynamic Clothing  222

Adding from library  551
Saving to Library Palette  566
Using without a figure  552

Dynamics
Recalculating  200, 445
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E
Editing Tools  51, 60, 184

Using  182
Edit Menu Commands

Copy  69, 70
Copy Picture  70
Cut  69
General Preferences  32, 67, 423
Memorize  71, 200, 717, 718
Paste  70, 467
Redo  69
Restore  70, 71
Shortcuts  62
Undo  68, 69, 187, 525, 651

Elements List  464
Element Style  106, 112
Embedded library  37
Enable hardware AO  401
Enable hardware shading  400
Enable Hardware Shadows  400
Endpoints

Matching  194
End User License Agreement  12
Exit  68
Exporting  783

3D Objects  784
BVH Motion Files  783
Flash Files  784
Images  74, 783

Painter Scripts  783
SWF Files  784

Extended details  129
External library  37
Eyedropper Tool  297
Eyes

Posing  207

F
Facebook

Uploading to  103
Face Parameters  205
Face Room  518

Adjusting points and lines  524
Applying Heads  531
Applying shape  525
Caricatures  530
Customizing textures  526
Displaying tools  61
Face Shaping tool  527
Photo Lineup  522
Saving faces  532
Selecting images  521
Textures and  531
Using images with  520
Using morphs with  530

Faces  149
Posing  204

Falloff zones  731

Blending  736
Capsule  733
Changing display mode  738
Deleting  737
Enabling and disabling  737
Spherical  732
Weight maps  746
Working with  735

FastScatter  311
FC2  850
Figure Circle  114
Figure Height  213
Figure Hierarchy  695
Figure Menu Commands

Auto Balance  215
Conform To  144
Create Full Body Morph  663, 784
Create Walk Path  478
Delete Figure  217
Drop to Floor  216
Figure Height  213
Genitalia  213, 214
Hide Figure  217
Lock Figure  215
Lock Hand Parts  215
Set Figure Parent  230, 232, 701
Shortcuts  63
Show All Figures  218
Symmetry  216
Use Inverse Kinematics  178, 703
Use Limits  180, 215
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Figure Parameters  202
Figure Parent  230
Figures  139

Assigning IK chains  716
Creating  705
Hiding  217
Posing  181
Properties  193
Replacing  141
Showing all  218
Testing original  716
Visibility  193

Figure Style  106, 112
File Compression  67

Using  40
File Menu Commands

Close  67
Convert Hier File  874
Exit  68
Export  74, 783, 784
Import  481, 482, 486, 705, 777, 778, 

779, 781
New  66
Open  67
Page Setup  68
Print  68
Recent Files  67
Revert  67
Run Python Script  68, 843
Save  67
Save As  11, 67

Shortcuts  62
File Search  36

Deep  37
Shallow  36

FireFly  397
Saving render presets  422

Fitting Room  569
Adjusting to match figure  570
Completing the Simulation  585
Creating Fitting Simulation  573
Goal  574
Object  573
Painting Vertex Weights  583
Prefit Method  577
Preparing scene  570
Rigid Features Method  582
Simulation Methods  575
Smooth Method  580
Soft Features Method  580
Tighten Method  576

Fitting Tools  658
Loosen Fit  659
Sag  659
Tighten Fit  659

Flash  510
Rendering options  515

Flash Files
Exporting  784

Flat Lined  108
Flat Shaded  108

Focus Distance  119, 253
Force Limits  202
Foreground Color  96, 115
Frame Indicator  450, 455
Frame Rate  455
Frame Selected  250
Front-Back  203
F-Stop  255
Full Body Morphs

Analyzing  589
Creating  662
Deleting  665

G
Gamma correction  432

Per texture  433
Gamma node  339
Genitalia  213
Geometry

Importing  707
Global coordinates  862
Global Illumination  413
GoZ  789
Gradient bump maps  328
Graphs  58, 449, 458

Editing  460
Parameter dials  202
Using with Animation Palette  461
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Ground Plane  117
Color of  97

Ground Shadows
Showing and hiding  114

Group Editor  681
Auto Grouping  687
Creating groups  689
Polygon mode  686
Using  681
Vertex mode  686
Welding groups  688

Grouping figures  714
Grouping objects  232
Grouping Tool  190
Groups

About  690
GroupsCloth  694
GroupsHair  693

Guides  117

H
Hair  151

Adding strand-based to library  548
Adding to scene  152
Colors  547
Materials  547
Prop hair  220
Strand-based  220

Hair Edit Tool  539

Hair Parameters  546
Hair Properties  545
Hair Room

Add hairs to selection  540
Air damping  543
Bend resistance  543, 544
Calculate dynamics  543
Clear selection  542
Clumpiness  539
Collisions  543, 544
Constrain length  541
Curl hairs  541
Defining hair groups  534
Displaying tools  61
Falloff  542
Gravity  543
Growing hair  535
Hair density  538
Hair length  536
Kink delay  539
Kink scale  539
Kink strength  539
Lengthen  542
Length variance  536
Position force  543
Pull back  537
Pull down  537
Remove hairs from selection  541
Root stiffness  543, 544
Root stiffness falloff  543
Root width  539

Scale hairs  541
Setting dynamics  542
Show populated  538
Spring damping  543
Spring strength  543
Style hairs  539
Styling hair  537
Tip width  538
Translate hairs  541
Translate In/Out  541
Twist  541
Verts per hair  539

Hand Models
Using  209

Hand Parameters
Grasp  208
IndexBend  208
PinkyBend  208
RingBend  208
Spread  208
Thumb  208
ThumbBend  208

Hands  153
Locking  215
Posing  208
Presets  209

HD2  850
HDRI Export  784
HDR Images  404
HDRI Output  432
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Head Lengths  117
Head maps  291
Help

Getting  9
Online Support  9
Other Resources  10
Reference Manuals  9, 10
Smith Micro Sales  9
Technical Support  9
Third-Party Forums  9

Help Menu Commands
About Poser  9
Content Paradise  9
Other Web Links  9
PoserPython Manual  6, 9, 838
Poser Reference Manual  6, 9
SmithMicro Web Links  9

Hidden Line  107
Hierarchy  868
Hierarchy Editor  59, 695

Filtering display  698
Object relationships  700
Reordering scene elements  699
Rotation orders  701
Standard hierarchy  701
Using  697
Working with branches  699

Hierarchy Files  871
Body  872
Converting  874

Header  872
IK Chains in  874
Linking parts  874
Verifying  875

Hier Files
Converting  68

Highlights  301
Highlight Size  302
Hip-Shoulder Relationship  118
Hither  256
Horizon Line  118
HR2  850

I
IBL  263, 313, 404
IK  177, 449

Enabling/Disabling  178
Understanding  179
Using  703

IK Angles
Setting and memorizing  716

IK Chains
Assigning  716
Creating  701

Images
Exporting  74, 783

Importing  777
3D Objects  779
Background Pictures  778

ImportingProps  779, 781
Movies  777
Poser Documents  779
Tips & Tricks  779

Importing Geometry  707
Include morphs when conforming  

194
Include scales when conforming  

194
Index of Refraction  334
Indirect Light  411
Indirect Light quality  411
Infinite Lights  262

Indicators  268
Installing content  174
Installing Poser  12, 23

Upgrading from earlier version  28
Internal name  195
Interpolation

Loop  445
Quaternion  445

Interpolation Controls  462
Interpolation types  459
Irradiance caching  410
Item List panel  129

J
Joint angles
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Setting  740
Joint attributes  721

Types of  725
Joint bend  728
Joint bulges

Editing  741
Joint Centers  726
Joint display options  721
Joint Editor  59

Deformer indicators  723
Joint strength indicators  723
Parts of  720
Using  719

Joint end points  727
Joint front-back  728
Joint Orders

Setting  741
Joint parameters

Editing  724
Joints

Adding affected actors  743
Copying from another figure  725
Fine-tuning  715
Setting limits  717
Teaching  668

Joint scaling  730
Joint Settings

Copying and saving  745
Joint side-side  728

Joint twists  727
Joint up-down  728

K
Keyboard shortcuts  62
Keyframe Controls  452, 457
Keyframes

Adding  466
and timing  487
Copying  467
Editing on timeline  465
Moving  466
Recording  451
Removing  466
Resampling  445, 468
Retiming  467
Selecting  465

Keyframes tab  457
Keyframing  869
Ks Microfacet Node  344

L
Launch Behavior  32
Library

Searching  167
Library Palette  54, 122

Accessing content libraries  131
Adding actors  165

Adding dynamic cloth  567
Adding items  162
Adding items manually  166
Adding libraries  132, 134
Adding Material collections  159
Adding materials  158
Adding scenes from  160
Adding strand-based hair  548
Always on top  128
Categories  138
Categories Tab  55
Category icons  123
Conforming clothing  143
Content Collections  171
Creating subfolders  161
Deleting items  166
Details options  131
Displaying  125
Display options  128
Dragging and dropping  167
Dynamic clothing  551
Extended Details image  131
Favorites tab  56
Folder thumbnails  130
General options  128
Horizontal gap in List  131
Label Height in List  131
Library tabs  123
List options  130
Maintaining  161
Refreshing  139
Removing libraries  134
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Reopening folders  128
Saving scenes to  160
Search tab  56
Showing folder counts  128
Showing item details  130
Showing path tool tip  128
Switching libraries  131
Thumbnail size  130
Thumbnail size in List  131
Tree indentation  130
Tree options  130
Using arrow keys with  139
Using Download Manager  166

Library selection  123
Library Tab  55
Light Controls  49, 60, 267
Light emitter  195, 226
Light Emitter  193
Light Parameters  276

Angle End  277
Angle Start  277
Color  278
Distance End  277
Distance Start  277
Intensity  278
Scale  278
Shadow  277
XYZ Rotation  278
XYZ Translation  279

Light Properties
Advanced Materials  273

Ambient Occlusion  272
Animating  270
Atmosphere Strength  272
Attenuation  273
Color  273
Depth Map Shadows  271
Include in OpenGL Preview  270
LightType  271
On/Off  271
Raytrace Shadows  271
Set Parent  272
Shadow Blur Radius  271
Shadow Min Bias  271
Shadows  271
Visible  270

Lights  156, 868
Adjusting  265
Aiming  266
Animating  279
Color  265
Creating  263
Deleting  266
Image Based Lights  263
Indicators  268
Infinite lights  262
Intensity  265
Light position control  267
Memorizing  279
Point lights  262
Properties  270
Restoring  279

Saving and loading  279
Selecting  263
Spotlights  263

Light Style  312
Limiting Motion  180
Lit Wireframe  107
Load Morph Target  196
Local coordinates  862
Lock Figure  215
Lock Object  211
Log Window  45
Looping  464
Loosen Fit  659
LT2  850

M
Magnets  615

Adding weight maps  623
and Weight Maps  621
Animating zones  630
Base Properties  618
Creating  616
Locking  621
Object Parameters  618
Object Properties  617
Properties  617
Using Editing tools with  617
Zone Falloff Graph  620
Zone Properties  619
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Maps  283
Map Strength  300
Master Parameters  668

Creating  198, 670
Editing  673
Indicator  201

Material Collections
Adding to library  159

Material Room  296
About  315
Animating nodes  323
Collapsing nodes  322
Creating nodes  319
Deleting nodes  323
Delinking nodes  322
Displaying tools  61
Entering node values  322
Expanding nodes  322
Linking nodes  321
Moving nodes  322
Node connections  318
Nodes

2D Texture Nodes  373
3D Texture Nodes  364
Ambient Occlusion  358
Anisotropic  340
Blender  333
Blinn  342
Brick  376
Cellular  367

Clay  344
Color Math  337
Color Ramp  338
Component  335
Compound Nodes  381
Diffuse  344
Diffuse Nodes  344
dNdu  364
dNdv  363
dPdu  363
dPdv  363
dU  363
dV  363
Edge Blend  334
Environment Map Nodes  361
FastScatter  356
fBm  365
Fractal Sum  364
Frame Number  363
Fresnel  360
Gather  359
Glossy  342
Granite  371
Hair  350
HSV  338
Image Map  373
Math Functions  335
Math Nodes  333

Gamma  339
Movie  379
N  362
Noise  366
Phong  341
PoserSurface  325
ProbeLight  345
Raytrace Nodes  357
Reflect  357
Refract  358
Root Atmosphere Node  331
Root Background Node  329
Root Light Node  330
Root Material  325
Root Nodes  325
Simple Color  338
Skin  346
Special Nodes  346
Specualr  343
Specular Nodes  340
Sphere Map  361
Subsurface Skin  347
Tile  377
Toon  346
Turbulence  366
User Defined  337
U Texture Coordinate  363
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Variable Nodes  362
Velvet  350
V Texture Coordinate  363
Wave 2D  373
Wave 3D  373
Weave  379
Wood  372

Options menu  316
Properties

Alternate Diffuse  327
Alternate Specular  327
Ambient Color  326
Ambient Value  327
Angle  360
Angle End  330
Angle Expo  330
Angle Start  330
Attenuation  334
Auto Fit  374
Background  357, 358, 361, 

376, 381
Balance  372
Base Color  370, 371, 379
Bias  365, 366, 369, 379
Blending  334
Blue  337
Bottom  364, 365, 366, 369
Brick Color  376

Brick Height  377
Brick Width  377
Bump  327, 329
Cell Mode  368
Cloud Color  369
Color  329, 330, 335, 338, 339, 

344, 361, 367, 368, 379
Color Mode  337
Complexity  369
Component  335
Dark Color  346
Dark Wood  372
DepthCue Color  331
DepthCue EndDist  332
DepthCue On  331
DepthCue StartDist  332
Diffuse  330
Diffuse Color  326, 329, 345
Diffuse Value  326, 345
Displacement  327
Eccentricity  343
Edginess  350
ETA  347
Exposure  345
Filtering  376
Fractal Increment  365
Frame Number  381
Frequency Gap  365

Gain  365, 366, 369, 379
Global Coordinates  368, 369, 

370, 371, 372, 381
Gradient Bump  328
Gradient Mode  328
Green  337
Height  379
Highlight Size  326, 329, 351
Hue  339
IBL Contrast  331
Image Mapped  375, 381
Image Resolution  331
Image Source  374
Index of Refraction  358, 361
Ink Color  346
Inner Color  334
Input  333, 338
Intensity  330, 367, 368
Jitter  368
Ka  347, 350
Kd  344, 347, 350
Ks  342, 344, 347, 350
Light Color  346
Lighting Nodes  340
Light Wood  372
Line Width  346
Loop Movie  381
Math Argument  335, 337
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Max  367
Max Dist  359, 360
Min  367
Mirror U  376, 381
Mirror V  376, 381
Mortar Color  376, 378
Mortar Thickness  378
Mortar Width  377
Noise  377, 378
Noise Type  366, 368, 369, 

370, 371, 372, 373, 377, 
378

Normals Forward  328, 341, 
342, 343, 345, 346, 350

Octaves  364, 365, 366
Opaque in Shadow  351
Outer Color  334
Point  335
Quality  357, 358, 361
Random Color  368
Ray Bias  357, 358, 359, 360
Red  337
Reflection Color  327
Reflection Kd Mult  328
Reflection Lite Mult  327
Reflection Value  327
Reflectivity  343
Refraction Color  327

Refraction Value  327
Root Color  351
Root Softness  351
Rotation  361
Roughness  342, 343, 344, 350
Samples  359, 360
Saturation  339, 345
Scale  369, 371, 372
ScaleX  368
Scale Y  368
Scale Z  368
Shades  371
ShadowCatchOnly  328
Sharpness  342
Sheen Color  347
Signed  365
Size  341
Skin Color  347
Sky Color  369
Softness  357, 358, 361, 370, 

377, 378
Specular  330
Specular Color  326, 329, 340, 

341, 342, 343, 351
Specular Roll Off  343
Specular Value  326, 340, 341, 

343
Spot Color  370, 371

Spot Size  370
Spread  346
Strength  359
Surface Color  345
Texture Coordinates  375, 380
Texture Strength  376, 381
Thickness  347
Threshold  370
Tile  378
Tile Height  378
Tile Shape  378
Tile Width  378
Tip Color  351
ToonID  328
Translucence Color  327
Translucence Value  327
Transparency  327
Transparency Edge  327
Transparency Falloff  327
Turbulence  368, 371, 372, 

377, 378
U Highlight Size  341
U Offset  375, 377, 378, 380
U Scale  375, 379, 380
Value  336, 337, 339
Veins  371
Velvet Color  350
Velvet Sheen  350
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V Highlight Size  341
Video Source  380
V Offset  375, 377, 378, 380
Volume Color  332
Volume Density  332
Volume Noise  332
Volume On  331
Volume StepSize  332
V Scale  375, 379, 380
X  362, 363
XDir X  341
XDir Y  341
XDir Z  341
X Index  367
X Scale  364, 365, 366
Y  362, 363
Y Index  367
Y Scale  364, 365, 366
Z  362, 363
Z Index  367
Z Scale  364, 365, 366

Renaming nodes  320
Selecting nodes  319

Materials  157, 395
Basics  281
Rooms  368, 369
Roots  370

MAT poses  147

Maximum bucket size  412
MC6  850
Memorizing Items  71
Memory Dots  56, 57, 60

UI  44
Menu Bar  49
Minimum displacement bounds  412
Minimum shading rate  411
Morphing Tool  191

Combine tab  643
Create tab  647
Creating morphs with  642

Morphs
Adding custom  660
Combining  661
Copying between figures and props  

657
Creating custom  660
Creating in other applications  660
Deleting morph targets  680
Loading full body morphs  663
Managing morphed figures  679
Saving morph targets  679
Spawning  661
Splitting  201

Morph Targets  851
Creating in Poser  642
External Binary Morphs  41
Spawning  661

Motion

Limiting  180
Motion Blur Document  394
Motion Capture

Importing BVH files  486
Movies

2D Motion Blur  511
Antialiasing  511
Flash  510
Frame rate  513
Image file sequences  510
Importing  777
Playing  446
Rendering  445, 510
Rendering AVI  510
Rendering fewer frames  513
Setting time range  512

MT5  850
Multi/Sub-object Materials  282
Multi-threaded bending  33
Multi-threaded rendering  406

N
Name  195
Normal maps  306, 328
Normals  868

O
OBJ  850
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Object Menu Commands
Add Constraint  237
Change Parent  230, 232, 567
Create Camera  251
Create Grouping  233
Create Light  264
Create Magnet  616
Create Wave  636
Create Wind Force  633
Delete Object  224, 241
Load Morph Target  660, 661
Lock Actor  211, 259
Point At  212, 213, 258, 259, 267
Properties  270
Replace Body Part with Prop  229
Set Parent  267
Shortcuts  63
Spawn Morph Target  661
Spawn Prop from Convex Hull  240

Object popup menu  34
Objects

Adding new  136
Changing  136
Deleting  241
Duplicating  70
Grouping  232
One-dimensional  857
Three-dimensional  857
Two-dimensional  857
Zero dimensional  857

OBJ Files  853

Occlusion culling  404
OpenGL

Hardware Acceleration  76
Optimize simple materials  400
Options Menu

Document Window  73
Orbit Selected  250
Origins

Following when conforming  194
Outline  106

P
Page Setup  68
Painter Scripts

Exporting  443, 783
Palettes

Closing  44
Docking  42, 44
Enabling/disabling docking  44
Floating  44
Moving  42
Project Guide  30
Repositioning  42
Resizing  42
Showing and Hiding  58

Parameter Dials  200
Bend  203
Dependent Parameters  201
Displaying graph  200

Editing  200, 201
Face  205
Front-Back  203
Graph  202
Min and Max limits  201
Name  202
Resetting  200
Scale  202
Sensitivity  202
Side to Side  203
Taper  202
Turn  203
Twist  203
Value  201
XYZ Rotate  204
XYZ Scale  202
XYZ Tran  204

Parameter Groups
Creating  198
Deleting  199

Parameters
Body  203
Dependent  853
Figure  202
Memorizing  199
Posing  203
Restoring  199
Scale  202
Universal  202

Parameters Palette  53, 54, 61, 192, 
197
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Dial Groups  199
Options Menu  198
Using  182

Parent
Changing  231

Paste  70
Paste Onto Background  115
Persistent size  39
Perspective  858
Phonemes  206
Photoshop Files

Rendering in layers  434
Pictures

Copying  70
Pixel samples  411
Planes  861
Play Controls  451, 456
Play Range  456
PMD  850
Point At  212
Point Lights  262

Indicators  269
Polygon Hair node  357
Polygons  867
Pose dots  211
Pose Library  176
Poser Documents

Importing  779
Poser Download Manager  166

Poser Figures
Hierarchy of  695

Poser Files
About  847
Characters  852
Clothing  852
Common objects  851
Downloads  851
Editing  848
Families  849
Hierarchy of  849
Locations  850
Morph targets  851
Other types  851
Syntax of  852
Types of  848
Warning about editing  847

PoserFusion  803
3DSMax  803
Cinema4D  811
LightWave  823
Maya  816

Pose Room  48
PoserPython  837

Accessing manual  838
Basic structure  839
Folder syntax  841
Methods Manual (opening)  841
Running scripts  841
Running scripts directly  843
Sample script  840

Scripts Menu  842
Scripts Palette  842
Warnings about  838
Why used  838
Writing scripts  841

Poser Workspace  867
Poses  145

Figure poses  145
INJ and REM  149
MAT poses  147
MOR poses  149
Other types  148
Saving  211
with Animation Layers  149, 551

Posing
And camera views  176
Body Parts  180

Posing Figures  176
General principles  176

Post filter size  419
Post filter type  420
PP2  850
Preferences

Document  32
General  32
Interface  33
Launch behavior  34
Library  35
Miscellaneous  40
Mouse input  34
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Preferred State  33
Render  37

Preview Drawing  120
Preview Renderer  398
Preview Shadow Map Size  271
Preview Styles  60
Preview Tab

Context Menu  79
Multiple views  92
Single view  92

Preview texture resolution  402
Printing  68
Procedural Shaders  288
Production Frame  111
Project Guide  29, 30
Properties

Bend  195
Body Part  195
Cast shadows  196
Collision detection  196
Collision settings  196
Crease angle  197, 227
Displacement bounds  196
Figure  193
Internal name  195
Load Morph Target  196
Name  195
Shading rate  196
Smooth polygons  196
Visible  195

Visible in raytracing  195
Properties Palette  53, 54, 192
Props  154, 223

3D Objects  223
Adding to scene  155
Creating  224
Deforming  223
Deleting  224
Importing  779
Moving  223
Origin  225
Parameters  227
Properties  225
Replacing body parts with  228
Resizing  223

Props Library  223
Props Parameters

Scale  227
XYZ Rotate  228
XYZ Scale  227
XYZ Tran  228

Props Properties
Casts Shadows  226
Collision Detection  226
Collision Settings  226
Displacement Bounds  226
Display Origin  227
Internal name  226
Load Morph Target  226
Name  226
Set Parent  226

Shading Rate  227
Smooth Polygons  227
Visible  226
Visible in Raytracing  226

Python
Reinitializing  68
Running Scripts  68
Setting Editor  41

Python Scripts  59
Running  68

PZ2  850
PZ3  850
PZS  850

Q
Queue Manager  429

Installing  27
Sending jobs to  427

Quick-Scale  99
QuickTime

Rendering Options  513

R
Raytrace bounces  410
Raytrace Preview  402
Raytracing  409

Visibility  193
Recent Renders
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Palette  102
Uploading to Facebook  103

Redo  69
Reflection  303, 311
Reflection Map  287
Reflection maps  294
Refraction  311
Registering Poser  28
Reloading Textures  74, 395
Remove Detached Nodes  313
Render  392
Render cache  39
Render Dimensions  395
Rendered Image Cache  39
Render Engine

64-bit  431
Render Engines  397
Rendering  73, 90, 101

Area Render  89, 100
Auto settings  407
Background rendering  73
Comparing renders  101
Dimensions  75, 98
Firefly options  417
in background  392
In separate process  406
Manual settings  409
New window  101
Panning  101

Preview dimensions  75
Quality settings  406
Selecting render engine  100
Separate Process  38
Settings  74

Render Menu Commands
Area Render  392
Materials  395
MotionBlur Document  394
Reload Textures  395
Render  392
Render Dimensions  395, 396
Render in Queue  393
Render Settings  395, 397
Reuse Shadow Maps  396
Shortcuts  65
Sketch Style Render  393, 443

Render Over  417
Render Queue  426

Multi-frame job  427
Single frame job  427

Renders
Displaying recent  59, 413

Render Settings  395
Display Engine  399
Movies  402
Preview Tab  398
Procedural Shader Preview  400
Sketch Tab  398
Style Options  402
Tips and Tricks  403

Transparency Display  401
Render Tab  97
Restoring Items  70
Reuse Shadow Maps  395
Reverting Changes  67
Room Help  59
Room Tabs  51
Rotate Tool  185
Rotation  864
Rotation orders  701, 715
Rotation trackball  249
RSR  850
Run in background thread  39

S
Sag  659
Scale  202, 865
Scale Tool  187
Scaling zones  755
Scatter node  351
Scene

Adding items  137
Scene AO Options  272
Scenes

Adding hair  152
Adding props  155
Closing  67
Compressed  67
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Creating new  66
Opening  67
Opening recent  67
Removing items  138
Saving  67
Saving to Library  159

Scene style options  401
Script buttons  843

assigning  843
Assigning in console  843

Scripts
Editing in console  843

Scripts menu  842
Scripts Palette  842
Select Figure Menu  77
Selecting

with Current Actor menu  183
Setting Up

Document Window  45
Workspace  32

Set Up Ambient Occlusion  313
Set Up Light Style  312
Setup Room  704

Finalizing figure  717
Geometry requirements  714
Loading bone structure  707
Memorizing and saving figures  718

Set Up Shadow Catcher  312
Set Up Toon Render  312
Shaders  309

Shader Window  297, 298
Advanced shader view  308
Navigating  298
Simple shader view  298
Simple view  298

Shading rate  196
Shadow Blur Radius  271
Shadow catcher  312
Shadow light cameras  246
Shadow Maps

Clearing  74
Reusing  74, 395

Shadow Min Bias  271
Shadows  94, 95

Casting  409
Color of  97

Shadows Only  417
Side to Side  203
Silhouette  106
Simulation Proxies  240
Sketch Designer  59, 397, 440

Brushes  441
Checkboxes  441
Exporting Painter Scripts  443
Parameters  441
Presets  441
Rendering  443

Sketch elements  440
Sketch Style Render  393

Skinning methods  767
Skip frames  464
Smoothing geometry  422
Smoothing groups  424
Smoothing Preferences  33
Smooth Lined  109
Smooth Polygons  196, 418, 425
Smooth Shaded  109
Software Updates

Checking for  41
Sound  481

Clearing  446
Editing  481
Importing  481
Muting  446
Syncing with motion  482

Spawn Prop from Convex Hull  240
Splines  866
Spotlights  263

Indicators  269
StuffIt Connect

Uploading to  105
Subdivision Levels  194, 197, 227
Subdivision Surfaces  769

Finding optimum setting  771
How it works  769
Modeling considerations  774

Subsurface scattering  311, 409
Subsurface Skin node  347
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SWF Files
Exporting  784

Symmetry  216
Syntax

Brackets  852
of Poser files  852
Tabs in  852

System Requirements  6
Windows  8

T
Tablet Mode  34
Talk Designer  59, 450, 482

Configuration  484
Configuring  483
Emotional tweaks  486
Head motions  485

Taper  202
Taper Tool  188
Technical Support

Types of  845
Templates  283

Creating  288
Texture caching  39
Texture display  400
Texture filtering  405
Texture Map  288
Texture maps

  284
Texture Maps

Creating and using  289
Textures

Creating for characters  288
Reloading  74

Texture Shaded  110
This Element  464
Threads

Number of  38
Ticker  129
Tighten Fit  659
Tiled texture loading  405
Time Control  455
Timeline

Editing Keyframes on  465
Timeline Indicator  450
Tone mapping  421
Tools

Chain Break  189
Color  190
Direct Manipulation  191
Grouping  190
Morphing  191
Rotate  185
Scale  187
Taper  188
Translate In/Out  187
Translate/Pull  186
Twist  186

View Magnifier  190
Tool Tip Delay  128
Toon outline  419
Toon Render  312
Tracking  113
Tracking Mode  93
Transformation  864
Translate In/Out Tool  187
Translate/Pull Tool  186
Translation  176, 864
Transparency  305
Transparency Maps  286, 294
Tree list  129
Turn  203
Twist  203
Twist Tool  186

U
Undo  68
Undo/Redo

Setting number of  33
Universal Parameters  202
Universal Poses  37, 147
Updating Poser  29
Uploading to Facebook  74
Use custom gamma  339
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V
Vanishing Lines  119
Vanishing point  858
Vertices  866
View Magnifier Tool  190
Visible  195
Visible in camera  194, 195, 226
Visible in raytracing  195

W
Wacro Drawer  298
Wacros  310
Walk Designer  59, 449, 474

Applying walks  476
Blend and Tweak Styles  476
Creating walks  475
Figure Types  475
Loading walks  476
Saving walks  476
Views  475

Walk Paths
Adding control points  479
Creating  478
Removing control points  479
Shaping curves  479

Wardrobe Wizard  589
Analyzing full body morphs  589, 596
Choosing original clothing  591

Clothing Types  593
Convert  589
Convert From  592
Converting options  594
Convert To  592
Figure Utilities  600
Finding converted clothing  596
Footwear  610
Lights Utilities  605
Magnets Utilities  608
More utilities  609
Morphs utilities  601
Prop utilities  605
Questions and answers  611
Refining morphs  598
Shape utilities  606
Shift utilities  607
Target library  592
Texture utilities  604
Utilities  599

Wave Deformers  636
Creating  636
Falloff Graph  640
Object Properties  637
Parameters  640
Using Editing Tools with  637
Zone Properties  638

Weight maps
Activating  750
Adding  747
Deactivating  750

Deleting  749
Painting  750
Painting bulge maps  754
Painting tips  761
Transferring to clothing  763

Weight Maps
On Magnets  621

Welding groups  688
Wind Force Fields  633

Parameters  635
Properties  633

Window Menu Commands
Animation Controls  61
Animation Palette  58, 449, 454, 473
Bullet Physics Controls  493
Camera Controls  60
Document Window Size  61
Editing Tools  60
Graph  58
Hierarchy Editor  59, 697
Joint Editor  59
Libraries  59, 125
Light Controls  60
Log  45, 61
Memory Dots  60
Parameter Dials  192
Parameters Palette  61
Preview Styles  60
Project Guide  31, 59
Python Scripts  59, 842
Quick Start  30
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Quick Start Guide  59
Room Help  59, 325, 518, 525
Room Tools  61
Shortcuts  66
Sketch Designer  59, 440
Talk Designer  59, 450, 483
Walk Designer  59, 449, 475

Windows
Showing and Hiding  58

Wireframe  107
Workspace

Customizing  42
Setting up  41
Setting Up  32

X
XYZ Rotate  204
XYZ Scale  202
XYZ Tran  204

Y
Yon  256

Z
ZBrush  789

Creating actor morphs  796
Creating full body morphs  792

Creating joint-controlled morphs  797
Exporting objects to  791
Importing/exporting GoZ file  803
Importing hair from  799
Morphing multiple items  794
Setting Poser path  789
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